精华内容
下载资源
问答
  • 动态路由协议OSPF配置

    2021-06-08 16:50:47
    (2)规划PC及路由器相关接口的IP地址,配置动态路由协议OSPF,使PC之间能相互通信; (3)使用命令查看每台路由器上的相关信息。三、实验仪器及环境 (1)路由器2台; (2)交换机2台; (3)PC4台; (4)双绞线、控制线、背靠背...
    • 实验目的
      (1)理解动态路由协议原理;
      (2)理解动态路由协议OSPF的原理及其过程;

    (3)掌握在路由器上配置OSPF单区域。

    二、实验内容
    (1)构建网络拓扑图;
    (2)规划PC及路由器相关接口的IP地址,配置动态路由协议OSPF,使PC之间能相互通信;
    (3)使用命令查看每台路由器上的相关信息。
    三、实验仪器及环境
    (1)路由器2台;
    (2)交换机2台;
    (3)PC4台;
    (4)双绞线、控制线、背靠背连接线若干。
    四、实验原理
        OSPF(Open Shortest Path First,开放式最短路径优先)协议是目前网络中应用最广泛的路由协议之一,其属于内部网关路由协议,能够适应各种规模的网络环境,是典型的链路状态(link-state)协议。
        动态路由协议OSPF通过向全网扩散设备的链路状态信息,使网络中的每台设备最终同步一个具有全网链路状态的数据库(LSDB)。路由器采用最短路径优先(SPF)算法,以自己为根,计算到达其他网络的最短路径,最终形成全网路由信息。OSPF属于无类路由协议,支持VLSM(变长子网掩码)。OSPF以组播的形式进行链路状态通告。
    五、实验步骤
    1.设计拓扑结构
        构建实验拓扑结构图,如图1所示。

                           

    图1 网络拓扑结构图

    2.配置路由器的接口IP地址

    命令如下:

    Router>en

    Router#conf t

    Router(config)#hostname A

    A(config)#int f0/0

    A(config-if)#ip address 192.168.1.254 255.255.255.0

    A(config-if)#no shutdown

    A(config-if)#

    A(config-if)#exit

    A(config)#int s2/0

    A(config-if)#ip address 192.168.3.1 255.255.255.0

    A(config-if)#clock rate 64000

    A(config-if)#no shutdown

     

    Router>en

    Router#conf t

    Router(config)#hostname B

    B(config)#int f0/0

    B(config-if)#ip address 192.168.2.254 255.255.255.0

    B(config-if)#no shutdown

    B(config-if)#

    B(config-if)#exit

    B(config)#int s2/0

    B(config-if)#ip address 192.168.3.2 255.255.255.0

    B(config-if)#clock rate 64000

    B(config-if)#no shutdown

     

    1. 配置动态路由协议OSPF

    命令如下:

    A(config)#router ospf 1

    A(config-router)#network 192.168.1.0 0.0.0.255 area 1

    A(config-router)#network 192.168.3.0 0.0.0.255 area 1

    A(config-router)#end

     

    B(config)#router ospf 1

    B(config-router)#network 192.168.2.0 0.0.0.255 area 1

    B(config-router)#network 192.168.3.0 0.0.0.255 area 1

    B(config-router)#end

    1. 查看路由表

    查看路由表中的信息,如图2所示。

     

     

     

     

     

     

     

     

     

                 

    图2 路由表查看信息

    1. 结果测试

    测试PC0与PC1之间的连通性,如图3所示。

                

    图3 测试PC0与PC1之间的连通性

       测试PC2与PC0,PC1之间的连通性,如图4所示。

                      

    图4 测试PC2与PC0,PC1之间的连通性

    展开全文
  • 动态路由协议OSPF

    2020-11-05 17:35:31
    文章目录OSPF路由协议OSPF路由协议概述OSPF是链路状态路由协议,协议号是89OSPF的工作过程(3个表)OSPF区域区域ID骨干区域Area 0非骨干区域Router IDRouter ID选取规则DR和BDR(2种路由器)指定路由器(DR)其他...

    OSPF路由协议

    OSPF路由协议概述

    内部网关协议和外部网关协议:开放的最短路径优先协议

    • 自治系统(AS)AS是指同一个技术管理机构管理、使用统一选路策略的一些路由器的集合
    • 内部网关协议(IGP)
    • 外部网关协议(EGP)

    外部网关协议现在主要用BGP

    OSPF是链路状态路由协议,协议号是89

    传信的过程,一层一层叠加发送

    在这里插入图片描述

    OSPF的工作过程(3个表)

    1. 邻居列表
    2. 链路状态数据库
    3. 路由表

    建立邻接关系(传信的过程)——>链路状态数据库(所有链路状态学习后汇总到库里简称LSDB)——>形成最短路径(通过算法)——>形成路由表

    OSPF区域

    为了适应大型的网络,OSPF在AS内划分多个区域

    每个OSPF路由器只维护所在区域的完整状态链路状态信息
    在这里插入图片描述

    区域ID

    区域ID可以表示成一个十进制的数字

    也可以表示成一个IP

    骨干区域Area 0

    负责区域间路由信息传播

    非骨干区域

    Router ID

    OSPF区域内唯一标识路由器的IP地址

    Router ID选取规则

    自动:

    • 选取路由器loopback接口上数值最高的IP地址
    • 如果没有loopback接口,在物理端口中选取IP地址最高的

    手动

    • 也可以使用router-id命令指定Router ID

    DR和BDR(2种路由器)

    指定路由器(DR)

    其他路由器(DRothers)只和DR及BDR形成邻接关系

    在这里插入图片描述

    DR为老大,BDR为老二

    如果不选举DR和BDR,会构成n(n-1)/2个邻接关系,n为路由器个数,导致线路占用过多。

    DR和BDR的选举方法

    自动选举DR和BDR

    • 网段上Router ID最大的路由器将被选举为DR,第二大的将被选举为BDR

    手工选择DR和BDR

    • 优先级范围是0~255,数值越大,优先级越高,默认为1
    • 如果优先级相同,则需要比较Router ID
    • 如果路由器的优先级被设置为0,它将不参与DR和DBR的选举

    DR和BDR的选举过程

    路由器的优先级可以影响一个选举过程,但是它不能强制更换已经存在的DR或BDR路由器

    先开机的是老大,并且之后不会自动更改

    OSPF的组播地址

    224.0.0.5
    224.0.0.6

    如何选举OSPF

    路由器刚开机刚开始大家都以为自己是老大,再通过发送hello包选举选择DR和BDR

    1. 第一步大家通过0.5发送hello确认谁是DR谁是BDR
    2. 然后其他路由器通过0.6,把自己的链路发送给DR和BDR
    3. DR和BDR再通过0.5发送给其他路由器

    OSPF的度量值为COST

    COST=10^8/BW

    最短路径是基于接口指定的代价(cost)计算的

    接口类型 代价(108/BW)
    Fast Ethernet 1
    Ethernet 10
    56k 1785

    OSPF的数据包类型(5种数据包)

    OSPF数据包:

    承载在IP数据包内,使用协议号89

    OSBF的包类型

    OSPF的包类型 描述
    Hello包 用于发现和维持邻居关系,选举DR和BDR
    数据库描述包(DBD) 用于向邻居发送摘要信息以同步链路状态数据库
    链路状态请求包(LSR) 在路由器收到包含新信息的DBD后发送,用于请求更详细的信息
    链路状态更新包(LSU) 收到LSR后发送链路状态通告(LSA),一个LSU数据包可能包含几个LSA
    链路状态确认包(LSAck) 确认已经收到DBD/LSU,每个LSA需要被分别确认

    OSPF邻接关系的建立(7种转态)

    OSPF启动的第一个阶段是使用Hello报文建立双向通信的过程

    **一、Down状态:**初始化----路由器启动后开始向外发Hello,但是没有收到对方的Hello报文。

    **二、Init状态:**收到第一个hello包----路由器已经接收到相邻路由器发送来的Hello数据包,但自身的IP地址并没有出现在该Hello数据包内,也就是说,双方的双向通信还没有建立起来。

    **三、2-Way状态:**双向建立会话----路由器看到自身已经处于相邻路由器的Hello数据包内,双向通信已经建立

    OSPF启动的第二个阶段是建立完全的邻接关系

    **四、ExStart状态:**建立主从关系----在此状态协商DD报文发送的主从,开始的时候都认为自己是
    主路由器,发送一个空的DD报文I=1,M=1,MS=1,自己定义一个DD开始序列号,对方认同(比较Router-ID谁大)则回一个相同序列号的DD报文,I=0,M=1,MS=0。不认同则回一个不同的序列号的DD报文I=1,M=1,MS=1。同时检查MTU是否一致,不同将一直停在Exstart状态。

    **五、Exchange状态:**交换摘要信息----在这个状态,路由器向相邻的OSPF路由器发送数据库描述数据包来交换链路状态信息,每一个数据包都有一个数据包序列号。如果发现DBD里有新信息,路由器向相邻路由 器发送链路状态请求数据包来请求其相应数据。

    **六、Loading状态:**加载详细信息----根据之前的报文发送LSR请求LSU更新,直到LSACK确认完全同步

    **七、Full状态:**完全连接----收敛(同步)成功,双方达成一致

    OSPF的网络类型(4种类型)

    OSPF将网络划分为四种类型

    1. 点到点网络------自动发现邻居,不需要DR/BDR、组播224.0.0.5
    2. 广播多路访问网络(BMA)-----自动发现邻居、选DR/BDR、组播
    3. 非广播多路访问网络罗(NBMA)------手工指定邻居,选DR/BDR、单播
    4. 点到多点网络------自动发现邻居,不需要DR/BDR、组播224.0.0.5

    OSPF的使用场景

    • 网络规模,网络拓扑,其他特殊要求,路由器自身要求

    OSPF的特点

    1. 可适应大规模网络
    2. 路由变化收敛速度快
    3. 无路由环
    4. 支持变长子网掩码VLSM
    5. 支持区域划分
    6. 支持以组播地址发送协议报

    OSPF:属于链路状态路由协议,没有跳数限制,支持可变长子网掩码(VLSM),收敛速度快,使用组播发送链路状态更新

    路由协议或路由种类 优先级
    Direct 0
    OSPF 10
    IS-IS 15
    Static 60
    RIP 100
    OSPF ASE 150
    BGP 255

    OSPF配置实验

    以下配置图片为例
    在这里插入图片描述
    首先配完所有路由器的对应网口IP(int进入,ip add IP➕子网掩码)

    其次就是重点要在每个路由器上都配一个Router ID也就是路由器ID
    int loopback 0-----##进入回环网口 0为名称(每个路由器可重复)
    ip add 随意的IP地址,最好能对应上路由器以便分辨,子网掩码为32
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    上述配完以后进行ospf配置
    ospf 1 router-id 1.1.1.1-----##创建ospf进程,配置路由ID
    area 0------##在上述命令基础上进入区域0,区域0是骨干区域
    network 192.168.10.0 0.0.0.255----##宣告ospf区域内的直连网段,并且加上反掩码(此图有两个直连网段所以配置两个)
    network 10.0.0.0 0.0.0.3
    network 1.1.1.1 0.0.0.0----###记得不要忘记宣告回环网口的ID和反掩码
    在这里插入图片描述
    dis ip routing-table-----##查看路由器里的数据库信息
    在这里插入图片描述
    最后ping一下pc1与pc2(不要忘记设置各自参数)
    在这里插入图片描述
    这样我们就完成了!

    展开全文
  • 路由技术—动态路由协议OSPF协议概述内部网关协议和外部网关协议工作过程(3张表)邻居状态机OSPF区域路由器类型Router IDrouter id的定义router id 选取规则DR/BDR选举的方法ospf建立邻居的条件ospf的组播地址ospf...

    协议概述

    内部网关协议和外部网关协议

    自治系统(AS)
    内部网关协议(IGP)
    外部网关协议(EGP)

    ospf区域

    1、为了适应大型网络,ospf在AS内划分多个区域
    2、每个ospf路由器只维护所在区域的完整链路状态信息

    ospf多区域的生成

    原因:
    1、改善网络的可拓展性
    2、快速收敛
    *链接的非骨干区域可使用 虚链路技术;链接的其他系统(如rip),可使用 重分发技术。
    *虚链路使用场合:一个非骨干区域跨越一个非骨干区域时用
    作用:帮助这个非骨干区域获取完整lsdb(链路状态数据库)

    ospf路由器类型

    在这里插入图片描述

    ospf的三种通信量

    1、域内通信量(IR/BR)——单个区域内的路由器之间交换数据包构成的通信量
    2、域间通信量(BR/ABR)——不同区域的路由器之间交换数据包构成的通信量
    3、外部通信量(ASBR)——ospf域内的路由器与ospf区域外或与另一个自治系统内的路由器之间交换数据包构成的通信量

    ospf的网络类型

    点到点网络
    广播多路访问网络
    非广播多路访问网络
    点到多点网络

    ospf的工作过程(3张表)

    邻居列表
    链路状态数据库
    路由表
    在这里插入图片描述

    ospf的组播地址

    224.0.0.6 —— DR(主路由器)/BDR(备份路由器)
    224.0.0.5 —— DRother(其他路由器)

    ospf的度量值

    度量值为cost:10^8/BW(百兆宽带)

    Router ID

    router id的定义

    OSPF区域内唯一标识路由器的IP地址

    router id 选取规则

    (1)用router-id 命令指定Router ID
    (2)选取路由器loopback接口上数值最高的IP地址
    (3)如果没有loopback接口,在物理端口中选取IP地址最高的。

    DR/BDR选举的方法

    自动选举DR和BDR:网段上Router ID最大的路由器将被选举,第二大的将被选举为BDR
    手工选举DR和BDR:(接口)优先级范围:0-255,数值越大,优先级越高,默认为1
    如果优先级相同,则需要比较Router ID,
    如果路由器的优先级被设置为0,它将不参与DR与BDR的选举。
    选举过程:路由器的优先级可以影响一个选举过程,但是它不能强制更换已经存在的DR和BDR路由器。

    ospf邻居

    ospf建立邻居的条件

    1、Router ID 不能相同
    2、Hello时间必须一致
    3、DEAD时间必须一致
    4、区域ID必须相同
    5、认证必须相同
    6、STUB标志位必须相同(直连路由器特殊区域要求一致)
    7、三层MTU不匹配无法形成邻接关系(一边是Exstart,一边是exchange)
    8、OSPF版本号不同(目前版本为2)
    9、当OSPF网络类型是MA时,要求掩码一定一致(两个邻居),因为会出现DR和LSA-2,无法描述网段。

    邻居状态机

    1)Down:邻居状态机的初始状态,是指在过去的Dead—Internet时间内没有收到对方的Hello报文或OSPF没启动时。
    (1-2)Attempt:只适用于NBMA类型的接口,处于本状态时,定期向那些手工配置的邻居发送Hello报文。
    2)Init:本状态表示已经收到了邻居的hello报文,但是该报文中列出的邻居中没有包含我的Router ID(对方并没有收到我发的hello报文)。
    3)2-way:本状态表示双方互相收到了对端发送的hello报文,建立了邻居关系。在广播和NBMA类型的网络中,
    两个接口状态是DROther的路由器之间将保留在此状态。
    4)Exstart:在此状态下,路由器和它的邻居之间通过互相交换DD报文(该报文并不包含实际的内容,只包含一些标志位)来决定发送时的主/从关系。
    建立主/从关系主要是为了保证在后续的DD报文交换中能够有序的发送。
    5)Exchange:路由器将本地的LSDB用DD报文来描述,并发送给邻居。
    6)Loading:路由器发送LSR报文向邻居请求对方的DD报文。
    7)Full:在此状态下,邻居路由器的LSDB中所有的LSA本路由器全都有了。即,本路由器和邻居建立了邻接(adjacency)状态。

    ospf数据包

    ospf 所属的协议:IP
    协议号:89号
    spf的包类型和作用
    Hello包——用于发现和维持邻居关系
    数据库描述包(DBD)——选举DR/BDR 用于向邻居发送摘要信息,已同步链路状态数据库
    链路状态请求包(LSR)——在路由器收到包含信息的DBD后发送,用于请求更详细的信息
    链路状态更新包(LSU) 收到LSR后发送链路状态通告(LSA),一个LSU数据包可能包含几个LSA
    链路状态确认包(LSAck) 确认已经收到LSU,每个LSA需要被分别确认。

    ospf与rip的对比

    在这里插入图片描述

    LSA的类型与特点

    在这里插入图片描述

    OSPF的特殊区域

    末梢——阻止4、5类LSA传递进stub区域,会由ABR生成一条默认路由(3类)给stub区域
    完全末梢——阻止3、4、5类LSA传递进stub区域,会由ABR生成一条默认路由(3类)给stub区域
    次末节——阻止4、5类LSA传递进ospf,将5类的LSA转变位7类LSA,由ABR将7类LSA再次转化为5类LSA
    完全次末节——阻止3、4、5类LSA传递进ospf,会由ABR下发一条默认路由指向nssa区域。

    展开全文
  • 配置动态路由协议OSPF

    万次阅读 热门讨论 2018-03-19 14:33:15
    但大型的网络和频繁变动的拓扑,就需要配置动态路由协议! 协议就是大家都遵循的规范。 比如你在廊坊,家在西藏,你爸让你回去买个普通的白炽灯灯泡,你爸不会担心你买回家的灯泡不能用,因为全国的白炽灯灯泡就都...

    前言:

    对于拓扑结构变化少网络规模小时可以为路由器配置静态路由。但大型的网络和频繁变动的拓扑,就需要配置动态路由协议

    协议就是大家都遵循的规范。
    比如你在廊坊,家在西藏,你爸让你回去买个普通的白炽灯灯泡,你爸不会担心你买回家的灯泡不能用,因为全国的白炽灯灯泡就都是这样子,国家制定了这样的标准,大家用的是一样的。
    再比如,秦始皇为了统一,指定了度量衡,统一货币,和文字,这样不同地方的人,大家都使用同一套标准,就可以相互之间交流,不然无法沟通交流,之间就无法进行信息传递!

    动态协议非常的无私,它会将自己的路由信息分享给它的邻居路由器,让邻居知道,我可以到哪里哪里,如果你想到那里,可以通过我到哪里哪里!

    每一个路由器都配置了OSPF协议,接下来只需要给重要的节点手动配置路由,就可以实现全网互通了!
    OSPF(open shortest pass first 开发式 最短路径 优先 算法)

    过程:

    这里写图片描述
    首先为每个路由器配置信息
    路由器> R1

    enable ‘将路由器变为可用状态
    configure termial ‘进入到配置模式下
    int l1
    ip address 1.1.1.1  255.255.255.255 ‘配置回环口地址
    interface f0/0
    ip address 12.1.1.1  255.255.255.0 ‘配置接口f0/0的ip地址

    路由器>R2

    enable ‘将路由器变为可用状态
    configure termial ‘进入到配置模式下
    int l2
    ip address 2.2.2.2  255.255.255.255 ‘配置回环口地址
    interface f0/0
    ip address 12.1.1.2  255.255.255.0 ‘配置接口f0/0的ip地址
    interface f0/1
    ip address 23.1.1.2  255.255.255.0 ‘配置接口f0/0的ip地址

    路由器>R3

    enable ‘将路由器变为可用状态
    configure termial ‘进入到配置模式下
    int l3
    ip address 3.3.3.3  255.255.255.255 ‘配置回环口地址
    interface f0/1
    ip address 23.1.1.3  255.255.255.0 ‘配置接口f0/0的ip地址
    interface f0/0
    ip address 34.1.1.3  255.255.255.0 ‘配置接口f0/0的ip地址

    路由器>R4

    enable ‘将路由器变为可用状态
    configure termial ‘进入到配置模式下
    int l4
    ip address 4.4.4.4  255.255.255.255 ‘配置回环口地址
    interface f0/0
    ip address 34..1.1.4  255.255.255.0 ‘配置接口f0/0的ip地址

    接着为R1 配置动态路由协议OSPF,首先需要进入配置模式

    configure termial ‘进入到配置模式下
    router OSPF 1
    表示在这台路由器上运行一个OSPF的进程,进程标号为1.这个标号只在这个路由器内部有效!
    路由器是一台专用的网络计算机,它也有CPU,内存,硬盘。它的操作系统被称为ios (internet operating system),它上面有很多接口,其实那是一个个的网卡,所以路由器就相当于一台多网卡的计算机!进程是驻留在内存上的一个程序,它像所有的进程一样,有自己的存活周期,不可能一直运行占用着内存空间!一个路由器上可以运行一个或多个OSPF进程!就比如microsoft的word,当你打开一个word文档,在打开一个,会出现另一个word进程!

    路由器上开始运行ospf协议后,下一步

    router-id 1.1.1.1 (ip-address formate)
    在全局范围下(也就是整个网络),存在很多路由器运行了ospf协议,这时候OSPF协议就要区分每一台路由器,这时候用ip地址来区分(这里用回环口的地址表示该路由器的ip)

    标识好全局范围下的路由器后开始配置重要节点的路由器信息

    network 1.1.1.1  0.0.0.0 area 0
    network 12.1.1.0  0.0.0.255 area 0
    network +该路由器所相连的网段的路由信息 +反掩码+区域号
    R1 路由器相连相当于两个网段 1.1.1.1 (只有一个终端主机的网段) 12.1.1.0 (路由器R1和路由器R2之间的网段)
    掩码ip subnet mask :为了确定该ip是在哪个网段
    反掩码wild card bits:宣告这个网段ip地址范围大小!
    area:划分区域,可以划分42亿个区域!但这个没有具体用到!

    通过反掩码和网段可以算出来
    network 12.1.1.0  0.0.0.255 area 0
    12.1.1.0
    0.0.0.255
    反掩码0对应的网段部分不变,反掩码1对应的网段部分任意变
    这样12.1.1.0这个网段前24位不变还是12.1.1
    12.1.1.0后面的0所对应的8位(因为255代表8个1)可以任意变。
    那么这个网段包括了12.1.1.0~12.1.1.1(256)个ip地址。
    OSPF协议通过这样的机制来判断路由器的接口地址是否落在了网段地址和反掩码所代表的网段里
    如果在,这个接口将会被激活!
    激活后就会与邻居路由器交换自己的路由信息(也就是从我的这个接口可以到那些接口)
    接着配置R2>R3>R4的OSPF协议

    R2
    configure termial
    router ospf 1
    router-id 2.2.2.2
    network 2.2.2.2 0.0.0.0  area 0
    network 12.1.1.0   0.0.0.255 area 0
    network 23.1.1.0 0.0.0.255 area 0
    R3
    configure termial
    router ospf 1
    router-id 3.3.3.3
    network 3.3.3.3 0.0.0.0  area 0
    network 23.1.1.0   0.0.0.255  area 0
    network 34.1.1.0 0.0.0.255 area 0
    R4
    configure termial
    router ospf 1
    router-id 4.4.4.4
    network 4.4.4.4 0.0.0.0  area 0
    network 34.1.1.0   0.0.0.255  area 0

    这里写图片描述
    最后ping 1.1.1.1 source 4.4.4.4
    出现!!!!!就代表互通了
    总结:
    Ctrl+6:结束ping
    Ctrl+A:光标移到最前面
    Ctrl+E:光标移到最后面
    do show run | i route ospf:查看现在运行OSPF协议的路由
    网络,编程,看多少遍文档都学不会,实验

    展开全文
  • 动态路由协议OSPF介绍

    2019-07-27 23:17:51
    文章目录OSPF知识点汇总OSPF特性以及相关术语RID生成方式以及DR/BDR选举规则OSPF四种网络类型OSPF六种LSA类型介绍 OSPF知识点汇总 主要内容包括:OSPF相关术语、OSPF网络类型、常见LSA介绍、OSPF特殊区域、OSPF报文...
  • 根据上篇文章,我们认识了动态路由的中RIP协议和IS-IS两种协议,这次我们来简单认识下动态路由协议的第三种OSPFOSPF(开放式最短路径优先) 在自治系统(AS)中,OSPF与RIP和IS-IS一样,都属于内部网关协议(IGP...
  • 配置DMVPN(动态多点VPN)时使用动态路由协议ospf遇到的问题:Process 10, Nbr 2.2.2.2 on Tunnel0 from LOADING to FULL, Loading Done 配置步骤: ①动态多点GRE(mGRE); ②下一跳解析协议(NHRP); ③动态路由...
  • 0x0 ospf配置 **AR1:** ospf 100 #创建ospf协议进程号 area 0 #进入区域 network 12.1.1.0 0.0.0.255 #ospf宣告直连网段的掩码是反掩码 **AR2:** ospf 100 #创建ospf协议进程号 area 0 #进入区域 network ...
  • ospf IETF定义的一种基于链路状态的内部网关路由协议 rip 基于距离矢量算法的路由协议 存在收敛慢 易于产生环路 可扩展性差等问题 ospf 1 router-id 1.1.1.1 network 网段 子网掩码(用反子网掩码) display ospf ...
  • 分别在路由器R1、R2、R3上配置OSPF协议,实现全网互通,其中将R1上的G0/0/1口OSPF优先级设置为255,且R3不配置Router-id 1.3 实验详细步骤及配置 1、在R1上进行如下配置: <Huawei>sys [Huawei]sysname R1 [R1...
  • 动态路由协议OSPF,RIP,EIGRP对比

    千次阅读 2017-10-25 17:25:58
    动态路由协议通过一系列的进程,算法,报文来交互路由信息 一、优势 发现远端网络 (非直连网络,静态路由是直连网络) 维护最新的路由信息 选择最佳路由 如果网络失效,可以寻找最新路由 二、分类 分类 ...
  • OSPF路由协议概述 内部网关协议和外部网关协议 内治系统AS----相同路由进程协议的区域(区域系统) 内部网关协议IGP----RIP、OSPF、ISIS 外部网关协议EGP----BGP OSPF的工作过程 邻居列表 链路状态...
  • 路由协议OSPF距离矢量路由协议学习经验,练习1
  • 动态路由协议配置 OSPF

    千次阅读 2013-06-02 23:43:06
    □ 了解动态路由协议OSPF和RIP特性   OSPF(Open Shortest Path First)开放最短路径优先协议。首先必须收集有关的链路状态信息,并根据一定的算法计算出到每个节点的最短路径,向其同一管理域的所有其它路由器...
  • 路由协议ospf+快速收敛配置手册
  • 链路是路由器接口的另一种说法,因此OSPF也称为接口状态路由协议OSPF通过路由器之间通告网络接口的状态来建立链路状态数据库,生成最短路径树,每个OSPF路由器使用这些最短路径构造路由表。...
  • HM-040 动态路由协议OSPF协议原理及配置
  • 在互联网飞速发展的今天,TCP/IP协议已经成为...OSPF和EIGRP都是近年来出现的比较好的动态路由协议OSPF以协议标准化强,支持厂家多,受到广泛应用,而EIGRP协议由网络界公认的领先厂商Cisco公司发明,并靠其在业...
  • OSPF协议概述文字详细解释OSPF工作过程OSPF区域术语Router ID(身份证)Router ID选取规则DR(指定路由器)和BDR的选举方法OSPF的组播地址OSPF的数据包类型OSPF启动的七种状态一.OSPF启动的第一个阶段是使用Hello报文...
  • 实验拓扑图结构:实验目的:R2和R3属于AREA1,R3和R4属于AREA0都是OSPF路由协议,R4和R5之间是RIP路由协议,R6属于一个电信运营商,实现全网的互联互通。环境介绍:R1:f0/0(192.168.10.1/24)f0/1(192.168.20.1/...
  • 路由-OSPF(动态路由协议)1、动态学习收敛路由2、距离矢量路由协议(RIP、EIGRP、BGP)3、链路状态路由协议(OSPF、ISIS)OSPF(Open Shortest Path First,开放最短路径优先)管理距离值(AD值)不会被OSPF传递Cost(度量值,...
  • 动态路由OSPF路由协议

    2020-11-09 14:13:56
    动态路由——OSPF协议一、相关概念1.1自治系统(AS)1.2外部网关...动态路由协议可以理解为一种路由器之间用来交流的语言,而动态路由协议按照路由执行的算法可以分为: 1.距离矢量路由协议 依据从源网络到目标网络所经
  • 动态路由2 OSPF协议

    2021-03-23 14:15:37
    认识OSPF了解其原理并学会配置OSPF路由协议简介AS IGP EGP介绍骨干区域Area 0Router ID简介,和选取规则认识DR BDR的选举方式DR BDR的工作方式COST的计算方式OSPF的“5个包”详解7个状态配置命令 OSPF路由协议简介 ...
  • 关于动态路由的OSPF路由协议的基本知识点一、关于OSPF的基本概述1.1 OSPF:开放的最短路径优先协议1.2 OSPF的工作过程1.3 OSPF的基本概念1.3.1、OSPF区域1.3.2 OSPF区域ID1.3.3 骨干区域Area 0二、Router ID三、DR和...
  • 动态路由——ospf协议

    2019-09-18 06:22:45
    内容结构:OSPF路由协议:开放式最短路径优先(Open Shortest Path First,OSPF)是目前广泛使用的一种动态路由协议,它属于链路状态路由协议,具有路由变化收敛速度快、无路由环路、支持变长子网掩码(VLSM)和汇总...
  • 一、配置OSPF基本功能 1、应用环境: 在OSPF的各项配置任务中,必须先启动OSPF、指定运行OSPF的接口与区域号后,才能配置其它的功能特性。 在接口视图下配置OSPF命令不受OSPF是否使能的限制。在关闭OSPF后,...
  • OSPF(链路状态路由协议路由协议概述 按照AS分类 As是指由同一个技术管理机构管理、使用统一选路策略的一些路由器的集合。 【1】按自治系统分为 IGP:内部网关路由协议,运行在As内部的路由协议,主要解决As内部的...
  • 动态路由协议OSPF协议基础一、OSPF协议基本概念1.1动态协议的分类1.2OSPF协议的工作流程1.3OSPF区域1.3.1OSPF区域划分1.3.2OSPF区域ID1.4Router ID1.4.1Router ID1.4.2 一、OSPF协议基本概念 1.1动态协议的分类 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 28,453
精华内容 11,381
关键字:

动态路由协议ospf配置