精华内容
下载资源
问答
  • 动态路由协议RIP配置

    2021-06-08 14:25:41
    实验名称:动态路由协议RIP配置 实验性质:①综合性实验 ②设计性实验 ③√验证性实验 实验时间:2020年11月17日 实验地点:睿智4号楼303室 本实验所用设备:(1)路由器...

    信息学院

    实  验   报  告

    学号:1843295000223

    姓名:方智博

    班级:18F

    课程名称: 计算机网络

    实验名称:动态路由协议RIP配置

    实验性质:①综合性实验   ②设计性实验      ③验证性实验

    实验时间:2020年11月17日

    实验地点:睿智4号楼303室

    本实验所用设备:(1)路由器2台;(2)交换机2台;(3)PC 4台;

    (4)双绞线、控制线、背靠背连接线若干。

    • 实验目的

    (1)掌握动态路由协议的原理;

    (2)掌握经典动态路由协议的原理及过程;

    (3)掌握动态路由协议RIP的配置过程。

    (二)实验内容

    依据相应的网络拓扑要求,在路由器上配置动态路由协议RIP,实现全网连通。

    1. 拓跋图

    2、配置路由器名称、接口IP地址

    3.IP地址

    4.检测,结果检测

     

     

     

    (三)实验小结

    在静态路由配置实验的基础上来完成本实验就相对简单了。要在实验过程中进一步掌握原理,实验报告中要明确以下内容。

    (1)描述和理解实验过程;

    (2)熟练掌握操作命令。

    任课教师评语:

     

    教师签字:                                      年   月    日

         

    注:每学期至少有一次设计性实验。每学期结束请任课教师按时按量统一交到教学秘书处。

    展开全文
  • 一、动态路由RIP产生背景1、动态路由协议包括距离向量路由协议和链路状态路由协议RIP(Routing InformationProtocols,路由信息协议)是使用最广泛的距离向量路由协议RIP 是为小型网络环境设计的,因为这类协议的...

    一、动态路由RIP产生背景

    1、动态路由协议包括距离向量路由协议和链路状态路由协议。RIP(Routing Information

    Protocols,路由信息协议)是使用最广泛的距离向量路由协议。RIP 是为小型网络环境设

    计的,因为这类协议的路由学习及路由更新将产生较大的流量,占用过多的带宽。

    2、RIP 是由 Xerox 在 70 年代开发的,最初定义在 RFC1058 中。RIP 用两种数据包传输更新:更新和请求,每个有 RIP 功能的路由器默认情况下每隔 30 秒利用 UDP 520 端口向与它直连的网络邻居广播(RIP v1)或组播(RIP v2)路由更新。因此路由器不知道网络的全局情况,如果路由更新在网络上传播慢,将会导致网络收敛较慢,造成路由环路。为了避免路由环路,RIP 采用水平分割、毒性逆转、定义最大跳数、闪式更新、抑制计时 5 个机制来避免路由环路。

    RIP 协议分为版本 1 和版本 2。不论是版本 1 或版本 2,都具备下面的特征:

    1. 是距离向量路由协议;

    2. 使用跳数(Hop Count)作为度量值;

    3.默认路由更新周期为 30 秒;

    4. 管理距离(AD)为 120;

    5. 支持触发更新;

    6. 最大跳数为 15 跳;

    7. 支持等价路径,默认 4 条,最大 6 条;

    8. 使用 UDP520 端口进行路由更新。

    二、RIPv1 和 RIPv2 的区别

    RIPv1 RIPv2

    在路由更新的过程中不携带子网信息 在路由更新的过程中携带子网信息

    不提供认证 提供明文和 MD5 认证

    不支持 VLSM 和 CIDR 支持 VLSM 和 CIDR

    采用广播更新 采用组播(224.0.0.9)更新

    有类别(Classful)路由协议 无类别(Classless)路由协议

    三、RIPv1 基本配置

    c50cc732e3d815627ae3dcd5fede15f5.png

    实验步骤:

    (1)步骤 1:配置路由器 R1

    R1(config)# router rip //启动 RIP 进程

    R1(config-router)# version 1 //配置 RIP 版本 1

    R1(config-router)# network 1.0.0.0 //通告网络

    R1(config-router)# network 192.168.12.0

    (2)步骤 2:配置路由器 R2

    R2(config)# router rip

    R2(config-router)# version 1

    R2(config-router)# network 192.168.12.0

    R2(config-router)# network 192.168.23.0

    (3)步骤 3:配置路由器 R3

    R3(config)# router rip

    R3(config-router)# version 1

    R3(config-router)# network 192.168.23.0

    R3(config-router)# network 192.168.34.0

    (4)步骤 4:配置路由器 R4

    R4(config)# router rip

    R4(config-router)# version 1

    R4(config-router)# network 192.168.34.0

    R4(config-router)# network 4.0.0.0

    4.实验调试

    (1) show ip route

    该命令用来查看路由表。

    R1# show ip route

    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

    E1 - OSPF external type 1, E2 - OSPF external type 2

    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

    ia - IS-IS inter area, * - candidate default, U - per-user static route

    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    C 192.168.12.0/24 is directly connected, Serial0/0/0

    1.0.0.0/24 is subnetted, 1 subnets

    C 1.1.1.0 is directly connected, Loopback0

    R 4.0.0.0/8 [120/3] via 192.168.12.2, 00:00:03, Serial0/0/0

    R 192.168.23.0/24 [120/1] via 192.168.12.2, 00:00:03, Serial0/0/0

    R 192.168.34.0/24 [120/2] via 192.168.12.2, 00:00:03, Serial0/0/0

    R 4.0.0.0/8 [120/3] via 192.168.12.2, 00:00:03, Serial0/0/0

    R 192.168.23.0/24 [120/1] via 192.168.12.2, 00:00:03, Serial0/0/0

    R 192.168.34.0/24 [120/2] via 192.168.12.2, 00:00:03, Serial0/0/0

    以上输出表明路由器 R1 学到了 3 条 RIP 路由,其中路由条目“R 4.0.0.0/8 [120/3]

    via 192.168.12.2, 00:00:03, Serial0/0/0

    R 4.0.0.0/8 [120/3]

    via 192.168.12.2, 00:00:03, Serial0/0/0”的含义如下:

    ① R:路由条目是通过 RIP 路由协议学习来的;

    ② 4.0.0.0/8 :目的网络;

    ③ 120:RIP 路由协议的默认管理距离;

    ④ 3: 度量值,从路由器 R1 到达网络 4.0.0.0/8 的度量值为 3 跳;

    ⑤ 192.168.12.2:下一跳地址;

    ⑥ 00:00:03:距离下一次更新还有 27(30-3)秒;

    ⑦ Serial0/0/0:接收该路由条目的本路由器的接口。

    同时通过该路由条目的掩码长度可以看到,RIPv1 确实不传递子网信息。

    (2)show ip protocols

    该命令查看 IP 路由协议配置和统计信息。

    R1# show ip protocols

    【注意 】“//”后的信息表示注释,不是输出内容。

    Routing Protocol is "rip"//路由器上运行的路由协议是 RIP

    Outgoing update filter list for all interfaces is not set//在出方向上没有设置过滤列表

    Incoming update filter list for all interfaces is not set//在入方向上没有设置过滤列表

    Sending updates every 30 seconds, next due in 23 seconds//更新周期是 30 秒,距离下次更新还有 23 秒

    【注意 】

    为了防止更新同步,RIP 会以 15%的误差发送更新,即实际发送更新的周期的范围是

    25.5-30 秒。

    Invalid after 180 seconds, hold down 180, flushed after 240// invalid after:路由条目如果在 180 秒还没有收到更新,则被标记为无效

    【技术要点 】

    被标记为无效的路由条目类似如下所示:

    R 4.0.0.0/8 is possibly down, routing via 192.168.12.2, Serial0/0/0

    可以通过很多方式使路由条目进入无效周期,例如在接口上加拒绝接收 UDP520 端口的

    ACL,还比如将接口设置为被动接口等。

    // hold down:抑制计时器的时间为 180 秒

    // flushed after:路由条目如果在 240 秒还没有收到更新,则从路由表中删除此路由条目

    【提示 】

    可以通过下面的命令来调整以上三个时间参数:

    R1(config-router)# timers basic update invalid holddown flushed

    redistributing: rip

    //只运行 RIP 协议,没有其它的协议重分布进来

    Default version control: send version 1, receive version 1

    //默认发送版本 1 的路由更新,接收本版 1 的路由更新

    Interface Send Recv Triggered RIP Key-chain

    Serial0/0/0 1 1

    Loopback0 1 1

    //以上三行显示了运行 RIP 协议的接口,以及可以接收和发送的 RIP 路由更新的版本

    Automatic network summarization is in effect//RIP 路由协议默认开启自动汇总功能

    Maximum path: 4//RIP 路由协议可以支持 4 条等价路径,最大为 6 条

    【提示 】

    可以通过下面的命令来修改 RIP 路由协议支持等价路径的条数:

    R1(config-router)# maximum-paths number-paths

    Routing for Networks:

    1.0.0.0

    192.168.12.0

    //以上三行表明 RIP 通告的网络

    Routing Information Sources:

    Gateway Distance Last Update

    192.168.12.2 120 00:00:03

    //以上三行表明路由信息源,其中:

    // gateway:学习路由信息的路由器的接口地址,也就是下一跳地址

    // distance:管理距离

    // last update:更新发生在多长时间以前

    Distance: (default is 120)

    //默认管理距离是 120

    (3)debug ip rip

    该命令可以查看 RIP 路由协议的动态更新过程。

    R1#clear ip route *

    R1#debug ip rip

    clear ip route *

    R1#debug ip rip

    Feb 9 12:43:13.311: RIP: sending request on Serial0/0/0 to 255.255.255.255

    Feb 9 12:43:13.315: RIP: sending request on Loopback0 to 255.255.255.255

    Feb 9 12:43:13.323: RIP: received v1 update from 192.168.12.2 on Serial0/0/0

    Feb 9 12:43:13.323: 4.0.0.0 in 3 hops

    Feb 9 12:43:13.323: 192.168.23.0 in 1 hops

    Feb 9 12:43:13.323: 192.168.34.0 in 2 hops

    Feb 9 12:43:15.311: RIP: sending v1 flash update to 255.255.255.255 via Loopback0 (1.1.1.1)

    Feb 9 12:43:15.311: RIP: build flash update entries

    Feb 9 12:43:15.311: network 4.0.0.0 metric 4

    Feb 9 12:43:15.311: network 192.168.12.0 metric 1

    Feb 9 12:43:15.311: network 192.168.23.0 metric 2

    Feb 9 12:43:15.311: network 192.168.34.0 metric 3

    Feb 9 12:43:15.311: RIP: sending v1 flash update to 255.255.255.255 via Serial0/0/0

    (192.168.12.1)

    Feb 9 12:43:15.311: RIP: build flash update entries

    Feb 9 12:43:15.311: network 1.0.0.0 metric 1

    通过以上输出,可以看到 RIPv1 采用广播更新(255.255.255.255),分别向 Loopback0

    和 s0/0/0 发送路由更新,同时从 s0/0/0 接收三条路由更新,分别是 4.0.0.0,度量值是 3

    跳;192.168.34.0, 度量值是 2 跳;192.168.23.0,度量值是 1 跳。

    展开全文
  • 1、南昌大学实验报告学生姓名: 学 号: 专业班级: 实验类型: 验证 综合 设计 创新 实验日期: 2017/12/14 实验成绩: 实验动态路由协议RIP配置实训1、 实验目的l 深入了解RIP协议的工作原理l 学会配置RIP协议...

    《实验六 动态路由协议RIP初步配置》由会员分享,可在线阅读,更多相关《实验六 动态路由协议RIP初步配置(11页珍藏版)》请在人人文库网上搜索。

    1、南昌大学实验报告学生姓名: 学 号: 专业班级: 实验类型: 验证 综合 设计 创新 实验日期: 2017/12/14 实验成绩: 实验六 动态路由协议RIP配置实训1、 实验目的l 深入了解RIP协议的工作原理l 学会配置RIP协议网络l 掌握RIP协议配置错误排除2、 实验设备及条件l 运行Windows操作系统计算机一台l Cisco Packet Tracer模拟软件l Cisco 1841路由器两台,普通交换机三台,路由器串口线一根l RJ-45转DB-9反接线一根l 超级终端应用程序3、 实验原理3.1 RIP协议简介路由信息协议(Routing Information Proto。

    2、col,RIP)是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法(Distance Vector Algorithms),使用“跳数”(即metric)来衡量到达目标地址的路由距离。这种协议的路由器只关心自己周围的世界,只与自己相邻的路由器交换信息,范围限制在15跳(15度)之内,再远,它就不关心了。RIP应用于OSI网络七层模型的网络层。在默认情况下,RIP使用一种非常简单的度量制度:距离就是通往目的站点所需经过的链路数,取值为115,数值16表示无穷大。RIP进程使用UDP的520端口来发送和接收RIP分组。RIP分组。

    3、每隔30s以广播的形式发送一次,为了防止出现“广播风暴”,其后续的的分组将做随机延时后发送。在RIP中,如果一个路由在180s内未被刷,则相应的距离就被设定成无穷大,并从路由表中删除该表项。RIP协议是最早的路由协议,现在仍然发挥“余热”,对于小型网络,RIP就所占带宽而言开销小,易于配置、管理和实现。有两个版本。l RIPv1协议有类路由协议l RIPv2协议无类路由协议,需手工关闭路由自动汇总。另外,为了兼容IP V6的应用,RIP协议也发布了IP V6下的应用协议RIPng(Routing Information Protocol next generation)有类与无类的区别在于:有。

    4、类路由在路由更新时不会将子网掩码一同发送出去,路由器收到更新后会假设子网掩码。子网掩码的假设基于IP的分类,很明显,有类路由只会机械地支持A、B、C这样的IP地址。在IPv4地址日益枯竭的情况下,只支持有类路由明显不再适合。而无类路由支持可变长子网掩码(VISM),在网络IP的应用上可以缓解IP利用的问题。比如:有一个B类的IP地址172.16.1.1/16,默认的子网掩码是16位长,如果再进一步划分子网,采用24位长的子网掩码,可划出4个子网来(当然不止4个)。将4个子网分配出去就提高了IP的利用。如果是有类路由,则不能支持可变的子网掩码,只会机械地发送24位长的掩码,这样也就不能区分出子网。

    5、。在运行RIP v1这样的网络中,如果划分了子网则路由更新时候会丢失子网,数据就不知道从哪里转发出去。如图1所示。图1 路由汇聚造成丢包示意图在图23.1中网络运行RIP v1这样的有类路由协议,路由A发送一个数据包到目的地172.16.1.3.0/24,但是C路由收到后将自动汇总,将目的地IP汇聚成了172.16.0.0/16,这样的数据包可以转发的方面有3个,分别是B、C、D路由,C就不知道数据包怎么转发了。可能的结果是随机选一个方向转发,造成丢包现象。RIP协议的优点在于实现简单,配置容易,维护简单,可以支持IP,IPX等多种网络层协议,当然也存在问题。主要体现在:路由收敛速度慢、以跳数。

    6、(hop)标记的metric值不能真实反映路由开销、16跳的限制不适合大规模的网络、周期性广播链路开销比较大。 所以RIP协议只适合网络规模小的场合,这样其运行效率越好。适合的应用场合:采用相同网络结构的中小型网络、适用于校园网、网络结构变化缓慢的地区性网络。RIP v2增强了v1版一些不支持的功能。主要体现在:l 支持外部路由标签(Route Tag)l 报文中带mask,支持CIDR(无类别域间路由 )l 支持多播路由更新(多播地址:224.0.0.9),减少资源消耗l 支持指定下一跳地址l 支持协议报文验证,MD5和明文方式,加强安全性l Route Tag支持RIPv2的路由器协议报文。

    7、目的地址为224.0.0.9,这样减少了广播报文,减轻了网络负担。3.2 RIP协议工作原理RIP路由协议使用UDP收发报文,端口号为520,广播的目的地址为255.255.255.255(RIP v2使用的是224.0.0.9组播地址)。在网络中每台路由器维护一张路由表,所谓路由表,指的是路由器或者其他互联网网络设备上存储的表,该表中存有到达特定网络终端的路径。1RIP路由的启动。 1)路由器启动RIP后,向周围路由器发送请求报文(Request message)。2)周围的RIP路由器收到请求报文后,响应该请求,回送包含本地路由表信息的响应报文(Response message)。3)路由。

    8、器收到邻居路由器响应报文后,修改本地路由表。2RIP路由计算。1)路由器收到响应报文后,如果本地路由表中不存在收到的路由,则修改本地路由表,同时向相邻路由器发送触发修改报文,广播路由修改信息。如果收到的路由在本地路由表中已经存在,则做比较,比本地路由表中的记录更新,则个改本地路由表,再转发更新;如果收到的路由过旧,直接丢弃。2)相邻路由器收到触发修改报文后,又向其各自的相邻路由器发送触发修改报文。在一连串的触发修改广播后,各个路由器都能够得到并保持最新的路由信息。3)RIP采用老化机制对超时的路由进行老化处理,以保证路由的实时性和有效性。因此,RIP每隔一定时间周期性的向邻居路由器发布本地的路。

    9、由表,相邻路由器收到报文后,对其本地路由进行更新。除些之外,为了加快网络收敛时间,在网络发生变化时会立即发送更新。在下面两种情况下会发生更新:l 定时更新发送,每隔30s发送全部路由,保证路由信息在全网的同步;l 触发更新发送,在路由发生变化的情况下,立刻向外发送变化路由,加快网络的收敛,减少环路出现的几率。路由更新时会启动记时,防止更新包超时,动态地掌握网络的变化情况。l 定时更新时间(Periodic Update),每隔30s向外发送一次本地的全部路由。l 超时定时间(Timeout),路由在Timeout超时时间内没有更新,该路由被认为不可达,缺省为180s。如果一条路由在180s未收。

    10、到更新报文,RIP就标志该网络为不可达,同时启动抑制定时器(180s),在抑制期内,该路由的更新被忽略。抑制期满后,如果在60s内没有收到它的更新,该路由项被删除,所以路由删除时间默认为240s。3数据转发。路由器收到数据包后,根据协议采用的路由算法,在路由表中选择一条最佳路径将数据包转发出去。如果收到的数据包目的地不可达,则丢弃数据包,并向源端发送抑制信息。在网络中,通常存在多条路径,可能会产生回路,在网络中出现回路的后果很严重,数据包在网内来回震荡,带宽耗尽后造成网络不可用。RIP路由防止回路的方法有几下几种:1触发更新(Trigger Update)路由信息发生变化时,立即向邻居路由器发。

    11、送触发更新报文,通知变化的路由信息。2记数到无穷(Count to infinity)为避免路由环收敛时间过长,将Cost=16表示不可达,在出现坏消息的情况下,计算到16后,该坏消息被认为不可达路由。3水平分割(Split Horizon)RIP从某个接口学到的路由不再从该接口发布给其他路由器,防止路由循环、防止计数到无穷、发布更少的路由信息,减少带宽消耗。4毒性逆转(Poison Reverse)为RIP从某个接口学到的路由,将该路由的Cost变成16,然后发送回该接口,可以清除对方路由表中的无用信息。 4、 实验步骤4.1 配置实训网络在Cisco Packet Tracer软件中配置好。

    12、实训的拓扑,在模拟器上先练习实训中的相关配置。本次实训在思科模拟器上和实践物理环境中都能配通。本次实训拓扑如图2所示 图2 RIP实训拓扑图实训任务:l 根据实训环境配置路由器,配置RIP V1协议。 l 根据实训环境配置路由器,配置RIP V2协议,使得实训环境中的所有网络通过RIP V2协议学习路由,最终能彼此通信。 实训环境路由器的配置参数如表1所示。表1 实训路由器参数表路由器F0/0F0/1S0/0/0Router1172.16.1.1/24192.168.1.1/24Router2172.16.2.1/24172.16.3.1/24192.168.1.2/24在网络中存在3个子网,。

    13、172.16.1.0/24、172.16.2.0/24和172.16.3.0/24,此3个子网被路由分开不连续。我们知道这是B类的子网IP,B类IP默认的子网掩码为16位,255.255.0.0。在有类路由中只支持这种标准的子网掩码,在无类路由中才能支持可变子网掩码,如本例中全用了24位长的掩码,为255.255.255.0。这样设置主要在于观察RIP v1和RIP v2路由协议工作时路由汇总的不同。有关的配置命令如表2所示。表2 RIP协议有关的配置命令任务命令指定使用RIP协议router rip指定RIP版本version 1|21指定与该路由器相连的网络network network4。

    14、.2 进行RIP V1的配置拓扑图:Ping 不通4.3 进行RIP V2的配置5、 实验总结路由信息协议RIP是一种内部网关协议(IGP),RIP路由协议使用UDP收发报文,端口号为520,广播的目的地址为255.255.255.255(RIP v2使用的是224.0.0.9组播地址)。在网络中每台路由器维护一张路由表,所谓路由表,指的是路由器或者其他互联网网络设备上存储的表,该表中存有到达特定网络终端的路径。路由器启动RIP后,向周围路由器发送请求报文,周围的RIP路由器收到请求报文后,响应该请求,回送包含本地路由表信息的响应报文.(Response message)。路由器收到邻居路由器响应报文后,修改本地路由表。。

    展开全文
  • 南 昌大学 实验 报告 学生姓名 学 号 专业班级 实验类型 验证 综合 设计 创新 实验日期 2017/12/14 实验成 绩 实验动态路由协议RIP配置实训 一实验目的 深入了解RIP协议的工作原理 学会配置RIP协议网络 掌握RIP...
  • 南昌大学实验报告 学生姓名 学 号 专业班级 实验类型 验证 综合 设计 创新 实验日期 2017/12/14 实验成 绩 实验动态路由协议 RIP 配置实训 一实验目的 深入了解 RIP 协议的工作原理 学会配置 RIP 协议网络 掌握 ...
  • 南昌大学实验报告 学生姓名 学 号 专业班级 实验类型 验证 综合 设计 创新 实验日期 2017/12/14 实验成 绩 实验动态路由协议 RIP 配置实训 一实验目的 深入了解 RIP 协议的工作原理 学会配置 RIP 协议网络 掌握 ...
  • ®南昌大学实验报告学生姓名 ________学号 _专业班级______________________________实验类型 口验证■综合□设计□创新实验日期 2017/12/14__________实验成绩__________实验动态路由协议RIP配置实训...

    ®南昌大学实验报告

    学生姓名 ________学号 _专业班级______________________________

    实验类型 口验证■综合□设计□创新实验日期 2017/12/14__________实验成绩

    __________

    实验六动态路由协议RIP配置实训

    一、实验目的

    深入了解RIP协议的工作原理

    学会配置RIP协议网络

    掌握RIP协议配置错误排除

    二、实验设备及条件

    运行Windows操作系统计算机一台

    Cisco Packet Tracer模拟软件

    Cisco 1841路由器两台普通交换机三台路由器串口线一根

    RJ-45转DB-9反接线一根

    超级终端应用程序

    三、实验原理

    3.1 RIP协议简介

    路由信息协议Routi ng In formation Protocol  RIP是一种内部网关协议IGP  是一种动态路由选择

    协议用于自治系统 AS 内的路由信息的传递。 RIP协议基于距离矢量算法Distanee Vector Algorithms  使用"跳数” 即metric来衡量到达目标地址的路由距离。这种协议的路由器只关心自己周围的世界只与自己相邻的路由器交换信息

    范围限制在15跳15度之内再远它就不关心了。 RIP应用于O SI网络七层模型的网络层。

    在默认情况下 RIP使用一种非常简单的度量制度 距离就是通往目的站点所需经过的链路数取值为1~15数值16表示无穷大。 RIP进程使用UDP的520端口来发送和接收RIP分组。RIP分组每隔30s以广播的形式发送一次为了防止出现“广播风暴” 其后续的的分组将做随机延时后发送。在 RIP中如果一个路由在180s内未被刷则相应的距离就被设定成无穷大并从路由表中删除该表项。

    RIP协议是最早的路由协议现在仍然发挥“余热” 对于小型网络 RIP就所占带宽而言开销小易于配置、管理和实现。有两个版本。

    RIPv 1协议一有类路由协议

    RIP v2协议一无类路由协议需手工关闭路由自动汇总。

    另外为了兼容IP V6的应用 RIP协议也发布了IP V6下的应用协议RIPng Routing

    In formati on Protocol next gen erati on

    有类与无类的区别在于

    有类路由在路由更新时不会将子网掩码一同发送出去 路由器收到更新后会假设子网掩码。子网掩码的假设基于 IP的分类很明显有类路由只会机械地支持 A、 B、 C这样的IP地址。在IPv4地址日益枯竭的情况下只支持有类路由明显不再适合。而无类路由支持可变长子网掩码VIS M 在网络IP的应用上可以缓解IP利用的问题。

    比如有一个B类的IP地址172.16.1.1/16默认的子网掩码是16位长如果再进一步划分子网采用24位长的子网掩码可划出 4个子网来当然不止 4个 。将4个子网分配出去就提高了 IP的利用。如果是有类路由则不能支持可变的子网掩码只会机械地发送24位长的掩码这样也就不能区分出子网。在运行 RIP v1这样的网络中如果划分

    了子网则路由更新时候会丢失子网数据就不知道从哪里转发出去。如图 1所示。

    发发1721630/24

    图1路由汇聚造成丢包示意图

    在图23.1中网络运行RIP v1这样的有类路由协议路由A发送一个数据包到目的地

    怎么转发了。可能的结果是随机选一个方向转发造成丢包现象。 D

    RIP协议的优点在于实现简单配置容易维护简单可以支持 IP, IPX等多种网络层

    C

    1721640/24协议 当17然216也20存/24在问题。主要体现在路由收敛速度慢、 以跳数 ho p标记的metr ic值不能真实反映路由开销、 16跳的限制不适合大规模的网络、周期性广播链路开销比较大。

    所以RIP协议只适合网络规模小的场合这样其运行效率越好。适合的应用场合采用相同网络结构的中小型网络、适用于校园网、 网络结构变化缓慢的地区性网络。

    RIP v2增强了v 1版一些不支持的功能。主要体现在

    支持外部路由标签Route Tag

    报文中带mask支持CIDR无类别域间路由

    支持多播路由更新多播地址 224.0.0.9  减少资源消耗

    支持指定下一跳地址

    支持协议报文验证 MD5和明文方式加强安全性

    Route Tag支持

    RIP v2的路由器协议报文目的地址为 224.0.0.9这样减少了广播报文减轻了网络负担。

    3.2 RIP协议工作原理

    RIP路由协议使用UDP收发报文端口号为520广播的目的地址为255.255.255.255 RIP v2使用的是224.0.0.9组播地址 。在网络中每台路由器维护一张路由表所谓路由表指的是路由器或者其他互联网网络设备上存储的表 该表中存有到达特定网络终端的路径。

    1. RIP路由的启动。

    1路由器启动RIP后 向周围路由器发送请求报文 Request mess age  。

    2周围的RIP路由器收到请求报文后响应该请求回送包含本地路由表信息的响应报文Respons eme s s age  。

    3路由器收到邻居路由器响应报文后修改本地路由表。

    2. RIP路由计算。

    1路由器收到响应报文后 如果本地路由表中不存在收到的路由 则修改本地路由表,同时向相邻路由器发送触发修改报文 广播路由修改信息。如果收到的路由在本地路由表中已经存在则做比较 比本地路由表中的记录更新则个改本地路由表再转发更新如果

    收到的路由过旧直接丢弃。

    2相邻路由器收到触发修改报文后又向其各自的相邻路由器发送触发修改报文。在一连串的触发修改广播后各个路由器都能够得到并保持最新的路由信息。

    3 RIP采用老化机制对超时的路由进行老化处理 以保证路由的实时性和有效性。因此 RIP每隔一定时间周期性的向邻居路由器发布本地的路由表相邻路由器收到报文后

    对其本地路由进行更新。 除些之外为了加快网络收敛时间 在网络发生变化时会立即发送更新。在下面两种情况下会发生更新

    定时更新发送每隔30s发送全部路由保证路由信息在全网的同步

    触发更新发送在路由发生变化的情况下 立刻向外发送变化路由 加快网络的收

    敛减少环路出现的几率。

    路由更新时会启动记时防止更新包超时动态地掌握网络的变化情况。

    定时更新时间(Periodic Update)每隔30s向外发送一次本地的全部路由。

    超时定时间(Timeout)路由在Timeout超时时间内没有更新该路由被认为不可达缺省为180s。

    如果一条路由在180s未收到更新报文 RIP就标志该网络为不可达 同时启动抑制定时器(180s)在抑制期内该路由的更新被忽略。 抑制期满后如果在60s内没有收到它的更新该路由项被删除所以路由删除时间默认为 240s。

    3•数据转发。

    路由器收到数据包后 根据协议采用的路由算法 在路由表中选择一条最佳路径将数据包转发出去。如果收到的数据包目的地不可达则丢弃数据包并向源端发送抑制信息。

    在网络中通常存在多条路径 可能会产生回路在网络中出现回路的后果很严重数据包在网内来回震荡带宽耗尽后造成网络不可用。 RIP路由防止回路的方法有几下几种

    1 .触发更新(Trigger Update)

    路由信息发生变化时立即向邻居路由器发送触发更新报文通知变化的路由信息。

    2 .记数到无穷(Count to infinity)

    为避免路由环收敛时间过长将 Cost=16表示不可达在出现坏消息的情况下计算

    到16后该坏消息被认为不可达路由。

    3 .水平分割(Split Horizon)

    RIP从某个接口学到的路由不再从该接口发布给其他路由器防止路由循环、防止计数到无穷、发布更少的路由信息减少带宽消耗。

    4 .毒性逆转(Pois on Revers e)

    为RIP从某个接口学到的路由将该路由的 Cost变成16然后发送回该接口可以清除对方路由表中的无用信息。

    四、实验步骤

    4.1 配置实训网络

    在Cisco Packet Tracer软件中配置好实训的拓扑在模拟器上先练习实训中的相关配

    置。本次实训在思科模拟器上和

    图2 RIP实训拓扑图

    PC-PTPC2

    实训任务:

    根据实训环境配置路由器配置 RIP V1协议。

    根据实训环境配置路由器 配置RIP V2协议使得实训环境中的所有网络通过 RIP

    V2协议学习路由最终能彼此通信。

    实训环境路由器的配置参数如表 1所示。

    在网络中存在3个子网 172.16.1.0/24、 172.1620/24和172.16.3.0/24此3个子网被路由分开不连续。我们知道这是 B类的子网IP B类IP默认的子网掩码为 16位

    255.255.0.0。在有类路由中只支持这种标准的子网掩码在无类路由中才能支持可变子网

    掩码如本例中全用了 24位长的掩码为255.255.255.0 。这样设置主要在于观察 RIP v1和RIP v2路由协议工作时路由汇总的不同。

    有关的配置命令如表2所示。

    表2 RIP协议有关的配置命令

    4.2 进行RIP V1的配置拓扑图

    展开全文
  • 计算机网络实验动态路由协议RIP配置
  • 实验5 动态路由协议RIP与OSPF的配置 实验学时2 一实验目的 1熟悉CISCO IOS和CLI命令模式的使用 2了解和掌握路由器基本配置命令的使用 3掌握动态路由协议的配置 4掌握VLAN中路由器的设置 3.掌握RIP与OSPF路由协议及其...
  • 学 生 实 训 报 告实训课名称________ 计 算 机 网 络_______实训内容 RIP 动态路由协议配置学 院 数信学院 年级 050711专 业 数学与应用数学学 生 姓 名___ 杨义_ 学 号__ 13 _开 课 时 间_ 2007__ 至 _ 200...
  • 华为HCNA实验学习--RIP配置HCNA 动态路由RIP配置实验1.动态路由的概念2.静态路由的配置思路 HCNA 动态路由RIP配置实验 本章内容意在学习静态路由协议相关知识。通过本章的学习,你将掌握以下内容: 1.动态路由的概念...
  • 配置动态路由协议RIP 实验设备 装有Packet Tracer的windows计算机 实验内容 构建拓扑结构 基本链接关系和配置 交换机的基本配置 测试 实验拓扑及器材 实验过程及结果 构建拓扑结构 基本链接关系和配置如下 ...
  • 动态路由RIP协议配置

    2018-12-07 18:50:20
    动态路由RIP协议配置 网络工程与技术课的实验报告,有需要的小伙伴可以下载
  • 1.动态路由概述 配置接口IP地址后路由表中生成直连路由。 C:直连 Metric度量值:度量值越小,路径越佳。 动态路由(指的是非直连路由... 动态路由协议概述: 路由器之间用来交换信息的语言 度量值:跳数、带...
  • 动态主机配置DHCP和动态路由协议RIP实验 实验 实验要求:1、R1配置dhcp服务,能够分配1.o和2.o网段的ip地址给4台主机 dhcp:网关:.254dns:8.8.8.8 租约:12小时 给pc3分配一个固定ip2.10 2、路由器配置rip实现全网互通 ...
  • 动态路由协议RIP

    2020-11-05 08:19:25
    文章目录动态路由协议动态路由特点:按照路由执行的算法分类RIP是距离矢量路由选择协议RIP的基本概念路油表的形成RIP度量值为跳数RIP更新时间RIP路由更新消息RIPv1和RIPv2的区别RIP实验配置 动态路由: 基于某种路由...
  • 动态路由 动态路由与静态路由是一个相对的概念,与静态路由的最大的...2、路由器根据某种路由算法(不同的动态路由协议算法不同)把收集到的路由信息加工成路由表,供路由器在转发IP报文时查阅。 目前现网上常见的...
  • 动态路由基于一种动态路由协议实现的。 协议:就是一种设备之间的语言或规则,如http协议、ftp协议、dhcp协议等。 动态路由协议:就是路由器之间能够自动协商学习路由表的一种语言。 三、动态路由的特点 (1)减少了...
  • 一、配置 1、IP地址规划 192.168.1.0 /24 划分为八个子网 192.168.1.0/27(分配给骨干网络) 192.168.1.0 /30 192.168.1.4/30 预留地址 192.168.1.8/30 192.168.1.12/30 192.168.1.16/30 192.168.1.20/30 192.168....
  • RIP协议原理及配置实验报告》由会员分享,可在线阅读,更多相关《RIP协议原理及配置实验报告(5页珍藏版)》请在人人文库网上搜索。1、通信网络实验 RIP 协议原理及配置实验报班级:学号:姓名:RIP 协议原理及配置...
  • 动态路由概述:基于某种路由协议实现特点:减少了管理任务占用了网络带宽动态路由协议概述:路由器之间用来交换信息的语言度量值:跳数,带宽,负载,时延,可靠性,成本静态路由与动态路由的比较:网络中静态路由和...
  • 动态路由协议_RIP实验

    2019-06-09 08:35:34
    实验实验要求:1、R1在向R2通告时进行汇总2、R1与R2之前启用MD5认证3、R1关闭水平分割网络拓扑如下:配置如下:[R1]rip[R1-rip-1]version 2 //配置为RIPv2[R1-rip-1]undo summary //关闭路由自动汇总[R1-rip-1]...
  • 规划与配置接口 IP地址 AR1: [AR1-GigabitEthernet0/0/0]ip address 20.0.1.1 24 [AR1-GigabitEthernet0/0/1]ip address 10.0.1.1 24 AR2: [AR2-GigabitEthernet0/0/0]ip address 20.0.1.2 24 [AR2-GigabitEthernet...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,317
精华内容 2,926
关键字:

动态路由协议rip配置实验