精华内容
下载资源
问答
  • 动态路由协议

    2019-11-25 15:54:49
    动态路由协议包括距离向量路由协议和链路状态路由协议。,本实 验文档主要介绍 RIP 和 OSPF 两类动态路由协议。 RIP 概述 RIP 是由 Xerox 在 70 年代开发的,最初定义在 RFC1058 中。RIP 用两种数据包传输更新:更新...

    动态路由协议

    动态路由协议包括距离向量路由协议和链路状态路由协议。,本实 验文档主要介绍 RIP 和 OSPF 两类动态路由协议。

    RIP 概述

    RIP 是由 Xerox 在 70 年代开发的,最初定义在 RFC1058 中。RIP 用两种数据包传输更新:更新和请求,每个有 RIP 功能的 路由器默认情况下每隔 30 秒,利用 UDP 520 端口向与它直连的 网络邻居广播(RIP v1)或组播(RIP v2)路由更新。因此路由
    器不知道网络的全局情况,如果路由更新在网络上传播慢,将会导致 网络收敛较慢,造成路由环路。为了避免路由环路,RIP 采用水平 分割、毒性逆转、定义最大跳数、触发更新、抑制计时 5 个机制来
    避免路由环路。

    RIP 协议分为版本 1 和版本 2。不论是版本 1 或版本 2,都具备 下面的特征:

    1. 是距离向量路由协议;

    2. 使用跳数(Hop Count)作为度量值;
      3.默认路由更新周期为 30 秒;

    3. 管理距离(AD)为 120;

    4. 支持触发更新;

    5. 最大跳数为 15 跳;

    6. 支持等价路径,默认 4 条,最大 6 条;

    7. 使用 UDP520 端口进行路由更新。
      在这里插入图片描述

    8. 实验拓扑:

    在这里插入图片描述
    RIP 拓扑图

    (1)首先基本的接口 IP 地址配置,以及测试直连连通性。
    (2)如同静态路由实验的情况一样,PC0 要 ping 通 PC1,则数据 包去到路由器上时会查看路由表,在没配静态路由的情况下,路由器

    上是没有目的网段的路由,数据包会在路由器上丢包,为解决这一问 题,可以用动态路由协议 RIP。

    下面以 R1 的配置为例子来说明:

    R1(config)#router rip
    R1(config-router)#version 1(也可以是 version 2,两者区别在于是 否携带子网掩码)
    R1(config-router)#network 10.0.0.0 (network 时用主类网段,

    即 A/B/C 类网段)
    R1(config-router)#network 192.168.12.0
    查看: 版本 1
    R1#show ip protocols Routing Protocol is “rip”
    Sending updates every 30 seconds, next due in 17 seconds Invalid after 180 seconds, hold down 180, flushed after 240 Outgoing update filter list for all interfaces is not set Incoming update filter list for all interfaces is not set Redistributing: rip
    Default version control: send version 1, receive 1 Interface Send Recv Triggered RIP Key-chain FastEthernet0/1 1 1
    FastEthernet0/0 1 1
    Automatic network summarization is in effect Maximum path: 4
    Routing for Networks: 10.0.0.0
    192.168.12.0
    Passive Interface(s): Routing Information Sources:
    Gateway Distance Last Update Distance: (default is 120)

    R1#sh ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter

    area

    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external

    type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2,
    E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia

    • IS-IS inter area
      • candidate default, U - per-user static route, o -

    ODR

    P - periodic downloaded static route

    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 1 subnets
    C 10.1.1.0 is directly connected, FastEthernet0/1
    R 20.0.0.0/8 [120/2] via 192.168.12.2, 00:00:10,
    FastEthernet0/0
    R 172.16.0.0/16 [120/1] via 192.168.12.2, 00:00:10,
    FastEthernet0/0
    C 192.168.12.0/24 is directly connected, FastEthernet0/0

    可以发现路由器上已经学习到目标网段的路由。如果一开始的时 候没有出现两条R的记录,也是正常,因为你没有执行过Ping的 操作,路由器是不会自动添加的。当你完成了ping的操作以后, 就会动态的添加对应的路由表信息。这就是所谓的动态路由。
    然后按照同样的方法配置 R2 和 R3,发现同样的情况也会在 R2
    和 R3 出现。

    版本 2
    R1#show ip protocols

    Routing Protocol is “rip”
    Sending updates every 30 seconds, next due in 12 seconds Invalid after 180 seconds, hold down 180, flushed after 240 Outgoing update filter list for all interfaces is not set Incoming update filter list for all interfaces is not set Redistributing: rip
    Default version control: send version 2, receive 2 Interface Send Recv Triggered RIP Key-chain FastEthernet0/1 2 2
    FastEthernet0/0 2 2
    Automatic network summarization is in effect Maximum path: 4
    Routing for Networks: 10.0.0.0
    192.168.12.0
    Passive Interface(s): Routing Information Sources:
    Gateway Distance Last Update Distance: (default is 120)
    路由表也版本 1 一样
    可以通过查看 R1、R2、R3 上的路由表是否都有目标网段的地址,如 果都有则实验成功,成功后:
    在这里插入图片描述

    注意:配置完动态路由协议后,第一次Ping的时候可能会出现 “Request timed out”的情况,是属于正常的,因为,路由器 “学习”需要一定的时间。

    OSPF 概述

    OSPF 作 为 一 种 内 部 网 关 协 议 ( Interior Gateway Protocol,IGP),用于在同一个自治 系统(AS)中的路由器之间交换路由信息。OSPF 的特性如下:

    1. 可适应大规模网络;

    2. 收敛速度快;

    3. 无路由环路;

    4. 支持 VLSM 和 CIDR; 5. 支持等价路由;

    5. 支持区域划分, 构成结构化的网络;

    6. 提供路由分级管理;

    7. 支持简单口令和 MD5 认证;

    8. 以组播方式传送协议报文;

    9. OSPF 路由协议的管理距离是 110;

    10. OSPF 路由协议采用 cost 作为度量标准;

    11. OSPF 维护邻居表、拓扑表和路由表。

    12. 实验拓扑:
      在这里插入图片描述
      OSPF 拓扑图

    实验与 RIP 基本一致,不同在于使用的路由协议不一样而已

    R1(config)#router ospf 1 (OSPF 进程号一定要有)

    R1(config-router)#router-id 1.1.1.1 (给该进程一个 RID,自己取 一个 IPV4 的地址,每台路由器要不一样的 RID)
    R1(config-router)#network 10.1.1.0 0.0.0.255 area 0 (宣告
    网段,路由表上是多少位子网,宣告时就要宣告多少位,如 10.1.1.0 网段是 24 位, network 宣告就是 10.1.1.0;而后面是反掩码,简单理解就是掩码反过来,即 24 位掩 码是 255.255.255.0,反过来就是 0.0.0.255;再后面是区域号,因为 OSPF 是分区域 的,所以一定要有区域号,一般简单实验只需用一个区域 0 即可)

    R1(config-router)#network 192.168.12.0 0.0.0.255 area 0

    OSPF 邻居建立起来时会看到:
    00:46:45: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on
    FastEthernet0/0 from LOADING to FULL, Loading Done

    可通过查看命令:
    R1#show ip ospf neighbor
    Neighbor ID Pri State Dead Time Address Interface
    2.2.2.2 1 FULL/BDR 00:00:33 192.168.12.2 FastEthernet0/0
    Full 即 OSPF 建立起来

    查看路由表:
    R1#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter

    area

    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external

    type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2,
    E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia

    • IS-IS inter area
      • candidate default, U - per-user static route, o -
        ODR
        P - periodic downloaded static route
        Gateway of last resort is not set
        10.0.0.0/24 is subnetted, 1 subnets
        C 10.1.1.0 is directly connected, FastEthernet0/1 20.0.0.0/24 is subnetted, 1 subnets
        O 20.1.1.0 [110/3] via 192.168.12.2, 00:02:00,
        FastEthernet0/0
        172.16.0.0/24 is subnetted, 1 subnets
        O 172.16.23.0 [110/2] via 192.168.12.2, 00:03:08,
        FastEthernet0/0
        C 192.168.12.0/24 is directly connected, FastEthernet0/0

    查看路由表发现目标网段路由已经在路由表上,按照要求配置 R2
    和 R3,发现同样情况也会发生在 R2 和 R3 上,则实验成功,成功后:
    在这里插入图片描述

    展开全文
  • 动态路由协议之RIP协议一、动态路由1.1动态路由概述1.1.1动态路由1.1.2动态路由特点1.1.3动态路由的工作流程1.2动态路由协议1.2.1动态路由协议概述1.2.2度量值1.2.3收敛1.2.4动态路由协议分类二、RIP(距离——矢量...

    一、动态路由

    1.1动态路由概述

    1.1.1动态路由

    基于某种路由协议实现

    1.1.2动态路由特点

    (1)优点:减少了管理任务
    (2)缺点:占用了网络带宽

    1.1.3动态路由的工作流程

    是指路由器能够学习路由信息,形成自己的路由表,并且能够根据实际情况的变化适时地进行调整。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    1.2动态路由协议

    1.2.1动态路由协议概述

    路由器之间用来交换信息的语言

    1.2.2度量值

    路由器会通过度量值来确定最佳路由路径,包括跳数、宽带、负载、时延、可靠性、成本

    1.2.3收敛

    使所有路由表都达到一直状态的过程

    1.2.4动态路由协议分类

    按照路由执行的算法分类。
    距离矢量路由协议:依据从源网络到目标网络所经过的路由器的个数选择路由(RIP,IGRP)
    链路状态路由协议:综合考虑从源网络到目标网络的各条路径的情况选择路由(OSPF,IS-IS)

    二、RIP(距离——矢量路由选择协议)

    2.1RIP的基本概念

    →定期更新
    →邻居
    →广播更新
    →全路由表更新

    2.2路由表的形成

    ①路由器学习到直连路由在这里插入图片描述
    ②更新周期30s到时,路由器会向邻居发送路由表
    在这里插入图片描述③再过30s,第二个更新周期到了再次发送路由表
    在这里插入图片描述

    2.3 RIP 的度量值、更新时间

    1、RIP度量值为跳数,最大条数为15跳,16跳为不可达
    2、RIP更新时间:每隔30s发送路由更新消息,UDP520端口
    3、RIP路由更新消息是发送整个路由表的信息

    2.4路由环路

    2.4.1环路的形成

    当40网段被堵塞后,R3正常情况下会发送出这个消息,但是因为存在30s的更新时间,所以如果在R3的更新周期到来之前,R2先发送,那么就会将R3的这条宣告覆盖,R3会认为40网段正常,把40网段正常工作的数据传回R2,R2再回传给如R3,以此循环形成环路。在这里插入图片描述

    2.4.2水平分割和毒性逆转

    水平分割和毒性逆转主要是针对动态路由协议RIP中,避免路由环路,提高收敛速度产生的。
    1、水平分割:
    在路由信息传送过程中,路由器从某个接口接收到的更新信息不允许再从这个接口发回去。同时也能减少路由更新信息占用的链路带宽资源。
    2、毒性逆转:
    路由器从某个接口上接收到某个网段的路由信息之后,并不是不往回发送信息了,而是发送,只不过是将这个网段标志为不可达,再发送出去。收到此种的路由信息后,接收方路由器会立刻抛弃该路由,而不是等待其老化时间到。这样可以加速路由的收敛。

    2.5RIPv1与RIPv2的区别

    在这里插入图片描述

    三、RIP的基本配置命令

    [R1]rip 1 ###启动RIP
    [R1-rip-1]version 2 ##启动版本2 (缺省为版本1)
    [R1-rip-1]undo summary ##关闭路由自动聚合(即所有路由信息都会按照IP地址分类归类)
    [R1-rip-1]network 192.168.10.0 ##宣告主网络号, v2会携带掩码组播更新224.0.0.9, v1不携带掩码广播更新255.255.255.255
    [R1-rip-1]network 200.1.1.0
    ----兼容模式--------
    [R1] int go/0/1
    [R1-GigabitEthernet0/0/1]rip version 2 multicast ##把设置成rip1路由器的某一接口单独设置成rip版本2

    展开全文
  • 动态路由协议RIP

    2019-06-13 19:20:18
    由于接下来讲的会比较绕所以先来一张思维导图为敬:路由协议:静态路由协议动态路由协议静态路由协议静态路由协议:由管理员或者用户手动指定,告诉路由器该如何去发送数据包。优点:安全、资源消耗低。缺点:配置...

    动态路由协议RIP

    由于接下来讲的会比较绕所以先来一张思维导图为敬:
    动态路由协议RIP
    路由协议:静态路由协议和动态路由协议
    静态路由协议
    静态路由协议:由管理员或者用户手动指定,告诉路由器该如何去发送数据包。
    优点:安全、资源消耗低。
    缺点:配置麻烦,只适合小型网络中,无法自动适应网络拓扑的变化。

    动态路由协议
    动态路由协议:可以通过网络拓扑的变化,根据协议来选择最优路径。
    动态路由协议:内部网关协议(IGP)和外部网关协议(EGP)
    内外部网关协议
    内部网关协议:处于同一个AS号内部的路由协议。RIP OSPF EIGRP
    外部网关协议:处于不同AS号之间的路由协议。BGP
    AS号:自治系统号,一个运营商或者一个大型的公司。

    内部网关协议:距离矢量协议和链路状态协议
    距离矢量协议:RIP/EIGRP
    链路状态协议:OSPF

    有类路由协议:在发送路由更新的时候是不会携带子网掩码。--基本被淘汰了
    无类路由协议:在发送路由更新的时候回携带子网掩码。--VLSM

    了解完以上几个协议的包含关系后,我们再看看什么是RIP。
    RIP(route information protocol)--路由信息协议,属于内部网关协议、是一个距离矢量协议,直接工作在UDP的520端口。
    何为距离矢量协议?
    距离:有多远--对于RIP来说,是通过跳数(hop)来衡量距离的。hop:跳数,每经过一台路由器记为一跳。
    矢量:方向

    RIPv1:是一个有类路由协议,在发送路由更新的时候不会携带子网掩码,并且是以广播(255.255.255.255)的形式发送的。
    RIPv2:是一个无类路由协议,在发送路由更新的时候会携带子网掩码,并且是以组播(224.0.0.9)的形式发送的。

    RIP的选路问题:RIP是通过跳数来选择路径的,认为跳数越少越优。这也是RIP选路的一个缺陷,有可能选择一条次优路径。

    (划重点!!!!)
    RIP的四个时间
    ①更新时间:默认是30s,运行了RIP协议的路由器,每隔30s会向其他rip路由器更新一次路由信息,并且是完整性更新。
    ②失效时间:默认是180,如果在180s内没有接收到对方发送过来的路由新,那么就认为其可能处于失效状态。
    ③抑制时间:默认是180s,用于维持路由表的稳定,避免环路。
    ④刷新时间:默认是240s,经过240s后,原本处于失效状态的路由信息将会被路由器删除。

    RIP还有什么弊端???
    RIP的环路问题:不一致的路由信息会导致RIP的网络产生环路。
    RIP环路的避免:
    ①定义最大跳数:16跳,当RIP的数据包到达第16跳的时候,就会执行丢弃。
    ②水平分割:从一个接口接收到的路由信息,不会再从该接口被发送出去。
    ③路由毒化:激活了路由毒化功能之后,水平分割会自动关闭,标记了毒化的路由,其跳数被认为是无穷大。
    ④抑制计时器:在180s内不会相信其他路由器传送过来的该路由的相关信息。
    ⑤触发更新:一旦路由条目发生变换,发生进行更新。

    那么接下来我们来配置下RIP协议
    动态路由协议RIP
    将每台设备添加IP地址后,再启用RIP
    RIP的基本配置:
    IOU1(config)#router rip --启用RIP路由协议
    IOU1(config-router)# version 2--修改版本号,默认是版本1
    IOU1(config-router)#network 192.168.12.0 --通告网段,通告的是主类网段
    (注意:这里只配置IOU1和IOU3还不能ping通,与静态路由不同,RIP需要所有设备要将你所要通告的网段配置上去。)
    (所以这里还要配置IOU2才能ping通,打个比方A,B,C三个人,A想要认识C,必需经过B,所以B必须把自己想要让A知道的信息通告出来,A才知道B认识C。)
    在配置完RIP后,并没有这么快的就可以更新到路由表,所以可以手动清理路由表,
    IOU1#clear ip route *--清理路由表

    自动汇总:
    RIP是一个距离矢量协议,距离矢量协议默认是开启自动汇总的,

    这里我们可以设置六个个looback地址(都是/24的)
    动态路由协议RIP
    将这六条地址条目全部通告,但是在IOU2上学习到的只有172.16.0.0的主类网段
    动态路由协议RIP
    这样子会导致同一个网段下有两个下一跳,使得在这个路由器上要访问172.16.0.0网段会出错。
    动态路由协议RIP

    什么叫自动汇总?
    会把明细的路由信息汇总成一个主类网段。但是我们一般是关闭自动汇总,就可以明细路由了。
    IOU1(config-if)#no auto-summary ----关闭自动汇总
    路由表中可以查看到一些明细的路由
    动态路由协议RIP
    在路由表路由条目庞大的时候,会通过手动汇总来解决 汇总后的路由也能通信,我们一般会选择手动汇总。一般会选择在发送接口手动汇总

    IOU1(config-if)#ip summary-address rip 172.16.0.0 255.255.0.0 ----手动汇总
    动态路由协议RIP

    转载于:https://blog.51cto.com/14367225/2408674

    展开全文
  • 文章目录CCNA3:RIP:路由信息协议一、动态路由协议:二、RIP:路由信息协议1、RIP协议的特点:2、V1和V2的区别:3、RIP的工作原理:4、RIP的破环机制:5、RIP如果没有破环机制会怎么样?三、RIP的配置:1、基本配置...

    CCNA3:动态路由协议、RIP——路由信息协议

    一、动态路由协议:

    动态路由协议:各台路由器上运行相同的协议,这些协议会让设备间进行沟通,学习来获取未知的路由条目信息。最终实现全网可达(所谓的动态路由协议本质上就是一种算法)。

    1、动态路由协议的优点:
    (1)配置管理方便:路由器之间会通过算法自动学习未知网段的路由。
    (2)针对拓扑变化自动重新收敛:如果新增网段或断开网段,拓扑会重新收敛计算新路径,比静态更灵活。
    (3)适用于较大型或复杂的网路环境

    2、 动态路由协议的缺陷
    (1)安全:容易被终端伪装的路由器欺骗,造成数据的不安全通信。
    (2)选路不佳:由于是固定的算法,可能在大型网络中造成数据的不同步,导致算路由算错,严重时导致出环。
    (3)对硬件资源的占用:无论是带宽、CPU、内存都是硬件资源,为了保持协议之间的正常通信,它会占用这些资源。严重时,可能占完整个带宽资源,例如OSPF。以至于用户连上网的带宽都没有。

    3、动态路由协议的追求:
    (1)占用资源少
    (2)选择路径佳
    (3)收敛速度快:全网信息同一时间全网同步,降低出环的概率。

    4、动态路由协议的分类
    (1)基于AS(自治系统)——EGP外部网关路由协议,IGP内部网关路由协议。AS号:0~65535,其中1 ~ 64512为公有AS号,64512 ~ 65535为私有AS号。
    EGP负责AS之间的沟通,IGP负责一个AS内部的沟通。

    EGP协议:EGPv1、EGPv2、BGPv1~v4 、BGPv4+
    IGP协议:RIP、OSPF、EIGRP、ISIS

    如果全球只运行一个动态协议来工作合适吗?
    不合适,首先工作半径太大,且非常复杂,导致收敛速度慢(这样就很容易出环),占用资源也很多。为了解决这一问题,提出了将全球的网络范围切割成多个AS区域,让区域内部进行管理。

    (2)IGP的分类:
    ①基于更新时是否携带子网掩码:
    有类别:不携带掩码、A类、B类、C类等。
    无类别:携带掩码,不管A、B、C的主类网,我的掩码是多少就是多少。

    ②基于工作特点:
    DV距离矢量型:RIP、EIGRP
    距离矢量:邻居之间共享路由表,通过看对方的路由表判断对方能到哪里,最后再将路由写入自己的路由表中。

    LS链路状态:OSPF、ISIS
    链路状态:路由器自己先画一个拓扑,标明自己连接的邻居,自己的各个接口是怎样的,IP是多少,带宽又怎样。然后这台路由器将这个拓扑给它的邻居,这台路由器除了会收集邻居的拓扑外,还会收集其他路由器的拓扑。最后该路由器就拥有了整个网络的拓扑,最后在算出一条最合适的路由加入自己的路由表中。

    二、RIP:路由信息协议

    RIP:路由信息协议,存在v1、v2、NG三个版本,NG用于IPv6。它是标准的距离是矢量路由协议, 邻居(在同一个AS内,运行着相同协议的直连路由器) 间直接共享路由表。默认仅存在更新包。

    1、RIP协议的特点:

    (1)基于 UDP520 端口工作
    (2)支持等开销负载均衡(两条路一模一样),默认支持4条,最大6条,如果IOS版本为12.4以上可以支持16条。
    (3)使用跳数作为度量,管理距离为120。【管理距离/跳数】
    (4)使用周期和触发更新
    触发更新:用于结构突变时,进行及时的重新收敛,告诉全部路由器有一个网段发生了变化。
    周期更新:用于保活、保证数据收到,但是占用带宽。

    2、V1和V2的区别:

    RIPv1RIPv2
    V1有类别协议V2无类别协议:支持VLSM可变长子网掩码,支持CIDR无类域间路由,不支持超网。
    超网:汇总后掩码长度<主类网长度
    V1使用广播更新,更新地址255.255.255.255V2使用组播更新224.0.0.9
    V1不支持手工认证V2支持手工认证(邻居间身份核实)

    3、RIP的工作原理:

    在这里插入图片描述
    图中总共有五个网段,1、3、5是环回,2、4是它们之间的直连路由。R1和R2都有2网段,因此R1需要把自己的 1.1.1.0/24网段告诉R2,数据包就像图中那样,包中的信息包含1.1.1.0/24网段,数据包包含传输协议,源目端口,源IP、源MAC,组播更新地址等。

    R2在收到R1的包后,就知道了这个包是从自己的S0/0口进来的,R1发送的地址是12.1.1.1/24,信息中包含了到1.1.1.0/24的度量值为1跳。就会产生一个
    R  1.1.1.0/24  [120/1]  S0/0  12.1.1.1的路由表

    这个包再由R2转发给R3时,源IP被修改为23.1.1.1/24,跳数也被修改为第2跳了。最后R3学到1.1.1.0/24的路由。同理,所有的路由都可以按照这样的方式倒出全部的路由。当R1、R2、R3上都有5条路由时,即它们获得了整个拓扑的路由,也就意味着它们收敛完成。

    4、RIP的破环机制:

    (1)毒性逆转水平分割:
    触发更新:当有路由器断开了某个网段时,该路由器会发送更新包,更新包中包含断开的网段和16跳的跳数,来告诉其它路由器此网段已不可达。收到的路由器作为回应需要将这条更新包再发送给发给自己的路由器,来作为确认自己收到了。这才是破环机制的核心机制。
    (2)跳数限制——15跳
    (3)水平分割——从此口进,不从此口出。不能完全解决问题,因为这个仅适用于防止直线、星形拓扑。
    水平分割的核心作用:
    ①消除重复更新量
    ②在MA网络中消除重复更新量(MA:多路访问网络,在一个网段中,可连接的节点数量不限制)
    (4)抑制计时器——平常不工作,但是遇到跳数无征兆增大,表示网络已经出环,此时抑制180s后重新收敛寻找新网段。

    5、RIP如果没有破环机制会怎么样?

    首先我们要知道RIP的周期更新时间为30S,且每台路由器并不是同时更新的,它们错开了更新时间。
    在这里插入图片描述
    按照上图:如果R3突然断掉了3.3.3.0/24网段,在它自己的30s倒计时为0时,它将这条消息发给了R2,此时R2距离刚更新过了13s。然后过了7秒钟,R1发包告诉R2它可以到3.3.3.0/24网段,度量值为3跳,这时距离R2更新的时间还剩10s。

    此时R2会认为自己去3.3.3.0/24网段下一跳是12.1.1.1,但是它不知道R1去往3.3.3.0/24网段的下一跳也是它自己。这就导致出环了,这还没完,R2更新后,它会显示自己有去往3.3.3.0/24的路由告诉R3,最后这个图都陷入到了出环中。

    出环的原因就是我收到的信息就是我刚刚删除的,甚至是我刚刚共享给你的。

    如果有触发更新(毒性逆转水平分割),就可以即时的知道某网段已经不可达了,即时的进行更新了。

    三、RIP的配置:

    1、基本配置:

    (1)RIPv1:

    R1(config)#router rip
    R1(config-router)#version 1
    R1(config-router)#network 1.0.0.0
    R1(config-router)#network 12.0.0.0
    

    1#启动RIP协议
    2#选择RIP版本为1,若不进行版本选举,默认为升级版本1(注意不是普通版本)
    3#宣告的意义:
    1、激活接口——使接口具有接收和发送路由信息的能力
    2、路由或拓扑——不宣告某个接口,会导致该接口的信息无法传输给其他路由器

    RIP在宣告时,只能定义主类的范围
    (2)RIPv2:

    r1(config)#router rip
    r1(config-router)#version 2	
    r1(config-router)#no auto-summary	
    r1(config-router)#network 172.16.0.0
    r1(config-router)#network 192.168.1.0
    

    #3关闭自动汇总——关闭后会携带精确掩码,不关闭会携带主类掩码

    2、扩展配置:

    (1)RIPV2的认证——运行于RIP协议的邻居间,进行身份的核实。 认证≠加密
    先定制keychain,再进入和邻居相连的接口上调用

    R1(config)#key chain xxx             		钥匙库的名字为xxx,邻居可以不同
    R1(config-keychain)#key 1            	key 11把钥匙,邻居必须相同
    R1(config-keychain-key)#key-string cisco123    	钥匙为cisco123,邻居必须相同
    R1(config)#interface f0/0              进入和邻居相连的接口上调用
    R1(config-if)#ip rip authentication key-chain xxx   		明文认证双方需一致
    R1(config-if)#ip rip authentication mode md5    	密文认证双方需一致
    

    (2)RIPV2的手工汇总——在更新源路由器上所有更新发出的接口上配置

    R1(config)#interface f0/0
    R1(config-if)#ip summary-address rip 2.2.2.0 255.255.254.0
    

    (3)被动接口——仅接受不发送路由协议信息,只能用于连接用户的接口,不得用于连接邻居的接口

    R1(config)#router rip
    R1(config-router)#passive-interface lo0
    

    (4)缺省路由——在边界路由器上配置RIP缺省后,内部的路由器将自动生成缺省路由指向边界路由器,边界路由器到达ISP的缺省路由,宣告手工静态配置

    R1(config)#router rip
    R1(config-router)#default-information originate
    

    (5)加快收敛
    RIP计时器   30s更新   180s失效   180s抑制   240s刷新(非cisco300s刷新)

    180s失效 :一次没收到更新并不能判断路由就没有了,有可能会因为网络卡了,所以给了6次机会。一旦6次机会都用完了,那么就判定这条路由失效了。紧接着会发再一条带毒的路由给其他邻居,告知其他邻居该路径已不可达。

    180s抑制 :平常不工作,正常情况下假设R1到达R2,跳数为1跳。但是跳数突然无征兆的变大,表示网络已经出环,此时抑制180s后重新收敛寻找新网段。

    240s刷新 :也就是会删除没有的路由条目

    适当的修改计时器,可以加快设备的收敛速度,建议修改时维持原有的倍数关系,且不易修改的过小,否则会占用带宽资源,全网所有设备均需要修改。

    R1(config)#router rip
    R1(config-router)#timers basic 15 90 90 120
    
    展开全文
  • 动态路由协议 各台路由器上运行相同的协议,这些协议会让设备间进行沟通,学习来获取未知的路由条目信息,最终实行全网可达。 动态路由协议的障碍: 1.安全 2.选路不佳——最严重出现环路 3.对硬件资源的占用 动态...
  • 动态路由协议中的路由信息协议(RIP)以及开放式最短路径优先(OSPF) 文章目录动态路由协议中的路由信息协议(RIP)以及开放式最短路径优先(OSPF)一、动态路由1.动态路由的定义2.动态路由的特点3.动态路由协议...
  • RIP动态路由协议

    千次阅读 2017-10-10 13:26:35
    动态路由协议简介 路由协议是路由器之间交互信息的一种语言。 路由协议共享网络状态和网络可达性的一些信息。 路由协议定义了一套路由器之间通信时使用的规则。 路由协议维护路由表、提供最佳转发路径。 常用的动态...
  • ISIS动态路由协议

    2020-06-09 11:23:07
    简述IS-IS动态路由协议 动态路由是指路由器能够自动地建立自己的路由表,并且能够根据实际情况的变化适时地进行调整。 IS-IS(Intermediate System-to-Intermediate System,中间系统到中间系统)路由协议最初是ISO...
  • 动态路由协议包括IGP(内部网关协议)和EGP(外部网关协议)。 1.IGP IGP又包括距离向量路由协议和链路状态路由协议。 (1)距离向量路由协议典型代表:RIP (2)链路状态路由协议典型代表:OSPF 2.EGP 目前...
  • 常见动态路由协议

    2019-12-17 17:15:06
    动态路由协议有自己的路由算法,能够自动适应网络拓扑的变化,适用于具有一定数量三层设备的网络。缺点是配置对用户要求比较高,对系统的要求高于静态路由,并将占用一定的网络资源。 常见的动...
  • 动态路由协议及分类

    2020-07-29 08:48:02
    .3动态路由协议及分类 前面已经为大家介绍了路由器对于直连路由的发现过程,以及静态路由的概念和部 署要点。对于一个小型网络,静态路由或许已经能够满足需求,但是在大中型网络中, 由于网段数量特别多、网络拓扑...
  • 动态路由协议简单理解

    千次阅读 2020-06-19 17:41:04
    一、什么是路由?       在一个网络中,路由是一个非常基本的概念,当路由器(或者其他三层设备)收到一个IP数据包,路由器会...二、路由协议的分类      &nb
  • RIP动态路由协议一、动态路由协议简介二、动态路由的协议三、RIP路由协议V1与V2区别四、动态路由的优劣点 一、动态路由协议简介 路由协议是路由器之间交互信息的一种语言。 路由协议共享网络状态和网络可达性的一些...
  • 互联网协议 — 动态路由协议类型

    千次阅读 2020-04-19 13:04:44
    目录 文章目录目录前文列表IPv6 的路由 前文列表 《IPv6 — 网际协议第 6 版》 《IPv6 — 地址格式与寻址模式》 《IPv6 — 协议头》 《IPv6 — 通信方式》 ...距离矢量路由协议:运行距离矢量协议的路由器通告...
  • 动态路由协议(RIP)

    千次阅读 2018-11-29 16:28:47
    动态路由是基于某种路由协议实现。 路由信息协议 RIP(Routing Information Protocol) 是内部网关协议 IGP中最先得到广泛使用的协议。RIP 是一种分布式的基于距离向量的路由选择协议。 RIP是应用层协议。使用UDP...
  • 文章目录一、动态路由及RIP协议工作原理1.1 动态路由概述1.1.2 动态路由协议1.1.3 动态路由协议分类1.2 RIP路由协议工作原理1.2.1 RIP的基本概念1.2.2 路由表的形成1.2.3 RIP的度量值与更新时间1.2.4 水平分割1.2.5 ...
  • 动态路由协议一、动态路由1.1 动态路由协议基础1.1.1 概述1.1.2 特点1.1.3 度量值1.1.4 收敛1.1.5 静态路由与动态路由的比较1.2 动态路由协议分类1.2.1 距离矢量路由协议1.2.2 链路状态路由协议二、RIP路由协议2.1 ...
  • 1.1动态路由协议特点1.2 收敛1.3 动态路由协议1.4 动态路由协议概述1.5 度量值二、OSPF协议2.1 什么是OSPF?2.2 链路状态协议工作原理简介2.3 Router-id及DR选举原则2.4 OSPF协议5种报文分析三、OSPF推举实验实验...
  • OSPF路由协议 OSPF路由协议总述 四种路由类型: DR BDR ABR ASBR 五大区域: 骨干区域 标准区域 末梢区域 存末梢区域 非存末梢区域 五大数据包类型: hello DBD LSR LSU(LSA) LSACK 六种LSA: Type 1、Type 2 、Type...
  • 开放式最短路径优先(Open Shortest Path First,OSPF)是目前广泛使用的一种动态路由协议,它属于链路状态路由协议,具有路由变化收敛速度快、无路由环路、支持变长子网掩码(VLSM)和汇总、层次区域划分等优点。...
  • BGP动态路由协议一 BGP动态路由协议简述二 BGP协议的概念三 BGP协议的特征四 BGP协议工作原理五 BGP+RIP+OSPF综合实验1.实验拓扑图2.实验分布2.1 BGP配置2.2 OSPF配置2.3 RIP配置2.4查看路由条目 一 BGP动态路由协议...
  • 常见的动态路由协议可以分为“距离矢量路由协议”和“链路状态路由协议”。 其中距离矢量路由协议依据的是从源网络到目标网络所经过的路由器的个数来选择路由,典型的协议是“RIP”; 链路状态路由协议会综合考虑从...
  • 目录 定义 距离矢量路由协议 链路状态路由协议 定义 链路状态协议分类 ...路由器对于直连路由的发现过程,对于一个小型网络,静态路由已经能够满足...当我们在路由器上激活动态路由协议后,就相当于激活了路由器的某
  • Rip 动态路由协议

    千次阅读 2017-10-10 21:53:53
    路由信息协议(RIP) 是内部网关协议IGP中最先得到广泛使用的协议。 Routing Information Protocol) RIP是一种分布式的基于距离矢量的路由选择协议,是因特网的标准协议,其最大优点就是实现简单,开销较小。 但...
  • 动态路由协议---OSPF篇

    万次阅读 2018-04-10 00:39:03
    上次我们学习了动态路由协议里面的第一个协议---rip(路由信息协议),比较容易掌握。今天我们再学习第二种动态路由协议---OSPF协议! OSPF协议---开放式最短路径优先,是无类别链路状态路由协议(自治系统路由协议...
  • 5. RIP动态路由协议 5.1 RIP协议(Routing Information Protocol) (1)是一个距离矢量路由选择协议。选择最佳路径的标准是跳数,如果到达目标网络经过的路由器最少,则该路径是最佳路径。其允许的最大跳数为15跳...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 205,749
精华内容 82,299
关键字:

动态路由协议包括