精华内容
下载资源
问答
  • ASA动态路由协议

    2017-04-12 17:27:05
    GNS3模拟器中ASA防火墙的动态路由配置步骤,有拓扑图及详细的命令配置、解释。
  • OSPF动态路由协议基本工作原理

    千次阅读 2011-04-21 10:26:00
    随着Internet技术在全球范围内的飞速发展,IP网络作为一种最有前景的网络技术...本文在分析OSPF动态路由协议基本工作原理的基础上,提出了Dijkstra算法和OSPF路由表计算的实现方法。 <br /> 目前应用较多的

    随着Internet技术在全球范围内的飞速发展,IP网络作为一种最有前景的网络技术,受到了人们的普遍关注。而作为IP网络生存、运作、组织的核心——IP路由技术提供了解决IP网络动态可变性、实时性、QoS等关键技术的一种可能。在众多的路由技术中,OSPF协议已成为目前Internet广域网和Intranet企业网采用最多、应用最广泛的路由技术之一。本文在分析OSPF动态路由协议基本工作原理的基础上,提出了Dijkstra算法和OSPF路由表计算的实现方法。
     
      目前应用较多的路由协议有RIP和OSPF,它们同属于内部网关协议,但RIP基于距离矢量算法,而OSPF基于链路状态的最短路径优先算法。它们在网络中利用的传输技术也不同。
     
      RIP是利用UDP的520号端口进行传输,实现中利用套接口编程,而OSPF则直接在IP上进行传输,它的协议号为89.在RIP当中,所有的路由都由跳数来描述,到达目的地的路由最大不超过16跳,且只保留唯一的一条路由,这就限制了RIP的服务半径,即其只适用于小型的简单网络。同时,运行RIP的路由器需要定期地(一般30s)将自己的路由表广播到网络当中,达到对网络拓扑的聚合,这样不但聚合的速度慢而且极容易引起广播风暴、累加到无穷、路由环致命等问题。为此,OSPF应运而生。OSPF是基于链路状态的路由协议,它克服了RIP的许多缺陷:
     
      第一,OSPF不再采用跳数的概念,而是根据接口的吞吐率、拥塞状况、往返时间、可靠性等实际链路的负载能力定出路由的代价,同时选择最短、最优路由并允许保持到达同一目标地址的多条路由,从而平衡网络负荷;
     
      第二,OSPF支持不同服务类型的不同代价,从而实现不同QoS的路由服务;
     
      第三,OSPF路由器不再交换路由表,而是同步各路由器对网络状态的认识,即链路状态数据库,然后通过Dijkstra最短路径算法计算出网络中各目的地址的最优路由。这样OSPF路由器间不需要定期地交换大量数据,而只是保持着一种连接,一旦有链路状态发生变化时,才通过组播方式对这一变化做出反应,这样不但减轻了不参与系统的负荷而且达到了对网络拓扑的快速聚会。而这些正是OSPF强大生命力和应用潜力的根本所在。
     
      一、OSPF工作原理分析
     
      OSPF是一种分层次的路由协议,其层次中最大的实体是AS(自治系统),即遵循共同路由策略管理下的一部分网络实体。在每个AS中,将网络划分为不同的区域。每个区域都有自己特定的标识号。对于主干(backbone)区域,负责在区域之间分发链路状态信息。这种分层次的网络结构是根据OSPF的实际提出来的。当网络中自治系统非常大时,网络拓扑数据库的内容就更多,所以如果不分层次的话,一方面容易造成数据库溢出,另一方面当网络中某一链路状态发生变化时,会引起整个网络中每个节点都重新计算一遍自己的路由表,既浪费资源与时间,又会影响路由协议的性能(如聚合速度、稳定性、灵活性等)。因此,需要把自治系统划分为多个域,每个域内部维持本域一张唯一的拓扑结构图,且各域根据自己的拓扑图各自计算路由,域边界路由器把各个域的内部路由总结后在域间扩散。这样,当网络中的某条链路状态发生变化时,此链路所在的域中的每个路由器重新计算本域路由表,而其它域中路由器只需修改其路由表中的相应条目而无须重新计算整个路由表,节省了计算路由表的时间。
     
      OSPF由两个互相关联的主要部分组成:“呼叫”协议和“可靠泛洪”机制。呼叫协议检测邻居并维护邻接关系,可靠泛洪算法可以确保统一域中的所有的OSPF路由器始终具有一致的链路状态数据库,而该数据库构成了对域的网络拓扑和链路状态的映射。链路状态数据库中每个条目称为LSA(链路状态通告),共有5种不同类型的LSA,路由器间交换信息时就是交换这些LSA.每个路由器都维护一个用于跟踪网络链路状态的数据库,然后各路由器的路由选择就是基于链路状态,通过Dijkastra算法建立起来最短路径树,用该树跟踪系统中的每个目标的最短路径。最后再通过计算域间路由、自治系统外部路由确定完整的路由表。与此同时,OSPF动态监视网络状态,一旦发生变化则迅速扩散达到对网络拓扑的快速聚合,从而确定出新的网络路由表。
     
      OSPF的设计实现要涉及到指定路由器、备份指定路由器的选举、协议包的接收、发送、泛洪机制、路由表计算等一系列问题。本文仅就Dijkstra算法与路由表的计算进行讨论。
     
      二、Dijkstra算法
     
      Dijkstra算法是路由表计算的依据,通过Dijkstra算法可以得到有关网络节点的最短路径树,然后由最短路径优先树得到路由表。
     
      1.Dijkstra算法的描述如下:
     
      (1)初始化集合E,使之只包含源节点S,并初始化集合R,使之包含所有其它节点。初始化路径列O,使其包含一段从S起始的路径。这些路径的长度值等于相应链路的量度值,并以递增顺序排列列表O.
     
      (2)若列表O为空,或者O中第1个路径长度为无穷大,则将R中所有剩余节点标注为不可达,并终止算法。
     
      (3)首先寻找列表O中的最短路径P,从O中删除P.设V为P的最终节点。若V已在集合E中,继续执行步骤2.否则,P为通往V的最短路径。将V从R移至E.
     
      (4)建立一个与P相连并从V开始的所有链路构成的侯选路径集合。这些路径的长度是P的长度加上与P相连的长度。将这些新的链路插入有序表O中,并放置在其长度所对应的等级上。继续执行步骤2.
     
      2.Dijkstra算法举例:
     
      下面我们以路由器A为例,来说明最短路径树的建立过程:
     
      (1)路由器A找到了路由器B、C,将它们列入候选列表{B:1;C:2}.
     
      (2)从候选列表中找出最小代价项B,将B加入最短路径树并从候选列表中删除。接着从B开始寻找,找到了D,将其放入候选列表{C:2;D:2}.
     
      (3)从列表中找出C,再由C又找到了D.但此时D的代价为4,所以不再加入候选列表。最后将D加入到最短路径树。此时候选列表为空,完成了最短路径树的计算。
     
      三、OSPF路由表的计算与实现
     
      有关路由表的计算是OSPF的核心内容,它是动态生成路由器内核路由表的基础。在路由表条目中,应包括有目标地址、目标地址类型、链路的代价、链路的存活时间、链路的类型以及下一跳等内容。关于整个计算的过程,主要由以下五个步骤来完成:
     
      (1)保存当前路由表,当前存在的路由表为无效的,必须从头开始重新建立路由表;
     
      (2)域内路由的计算,通过Dijkstra算法建立最短路径树,从而计算域内路由;
     
      (3)域间路由的计算,通过检查Summary-LSA来计算域间路由,若该路由器连到多个域,则只检查主干域的Summary-LSA;
     
      (4)查看Summary-LSA:在连到一个或多个传输域的域边界路由器中,通过检查该域内的Summary-LSA来检查是否有比第(2)(3)步更好的路径;
     
      (5)AS外部路由的计算,通过查看AS-External-LSA来计算目的地在AS外的路由。
     
      通过以上步骤,OSPF生成了路由表。但这里的路由表还不同于路由器中实现路由转发功能时用到的内核路由表,它只是OSPF本身的内部路由表。因此,完成上述工作后,往往还要通过路由增强功能与内核路由表交互,从而实现多种路由协议的学习。
     
      OPSF作为一种重要的内部网关协协议的普遍应用,极大地增强了网络的可扩展性和稳定性,同时也反映出了动态路由协议的强大功能。但是,在有关OSPF协议的研究、实现中尚存在一些问题,如数据库的溢出、度量的刻画、以及MTU协商等等。同时,在IPv6中,OSPFv3基于链路的处理机制、IP地址的变化、泛洪范围的增加、包格式、LSA的变化以及邻居的识别等技术都将是我们共同探讨的课题。

    展开全文
  • 文章目录一、动态路由及RIP协议工作原理1.1 动态路由概述1.1.2 动态路由协议1.1.3 动态路由协议分类1.2 RIP路由协议工作原理1.2.1 RIP的基本概念1.2.2 路由表的形成1.2.3 RIP的度量值与更新时间1.2.4 水平分割1.2.5 ...

    一、动态路由及RIP协议工作原理

    1.1 动态路由概述

    ●动态路由
    基于某种路由协议实现
    ●动态路由特点
    优点:减少了管理任务
    缺点:占用了网络带宽

    1.1.2 动态路由协议

    ●动态路由协议概述
    路由器之间用来交换信息的语言
    ●度量值
    度量值是用来衡量路径优劣的参数
    •跳数:一个路由器就是一条,跳数越小越好。
    •带宽:用来标识信号传输的数据传输能力、标识单位时间内通过链路的数据量、标识显示器的显示能力。
    •负载:承载的传输数据量。
    •时延:指一个报文或分组从一个网络的一端传送到另一个端所需要的时间
    •可靠性:数据传输的稳定性和效率。
    •成本:带宽越高,路径成本越低。
    ●收敛
    使所有路由表都达到一致状态的过程
    ●静态路由与动态路由的比较
    网络中静态路由和动态路由互相补充

    1.1.3 动态路由协议分类

    按照路由执行的算法分类:
    ●距离矢量路由协议
    •依据从源网络到目标网络所经过的路由器的个数选择路由
    •RIP、IGRP
    ●链路状态路由协议
    •综合考虑从源网络到目标网络的各条路径的情况选择路由
    •OSPF , IS-IS

    1.2 RIP路由协议工作原理

    1.2.1 RIP的基本概念

    ●RIP是距离-矢量路由选择协议
    ●RIP的基本概念
    •定期更新(路由器每经过一段时间周期-30S后,向邻居发送更新信息)
    •邻居(与其相连的路由器)
    •广播更新(RIPv1 255.255.255.255)
    •组播更新(RIPv2 224.0.0.9)
    •泛洪路由表(路由器将从邻居学习到的路由放进自己的路由表中,然后将路由表所有的路由信息通告给其他路由器,直到整个网络学习到)

    1.2.2 路由表的形成

    路由器学习到直连路由
    更新周期30s到时,路由器环回向邻居发送路由表
    在这里插入图片描述

    1.2.3 RIP的度量值与更新时间

    ●RIP度量值为跳数:
    最大跳数15跳,16跳为不可达。
    ●RIP更新时间:
    每隔30s发送路由更新消息,UDP520端口
    ●RIP路由更新消息:
    发送整个路由表信息

    1.2.4 水平分割

    ●路由环路的形成:
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    ●执行水平分割可以阻止路由环路的发生
    •从一个接口学习到路由信息,不再从这个接口发送出去。
    •同时也能减少路由更新信息占用的链路带宽资源
    在这里插入图片描述

    1.2.5 RIP配置和验证

    [R1]rip 1     ###1是进程号,范围为1~65535
    [R1-rip-1]version 2     ###2是版本号,还有一个版本1
    [R1-rip-1]network 1.0.0.0      ###宣告网络号
    [R1-rip-1]network 12.0.0.0
    

    1.2.6 ripv1和v2的区别

    在这里插入图片描述

    1.2.7 rip兼容模式

    ●兼容模式默认跑rip v1版本
    ●rip没有启动,路由表中只有一些直连路由,为了从邻居获取rip路由,会以广播或组播向邻居发动request请求报文
    ●邻居收到后,会发送response回复报文,报文中包括路由表的信息
    ●路由器收到response报文后,根据rip路由更新原则更新路由表
    ●以后没经过30秒,路由器都会发送response报文保持邻居关系

    二、动态路由协议实验

    2.1 实验目的

    三台路由连接,配置路由矢量协议rip,R1、R3分别配置为Version1、Version2,R2配置为兼容模式,抓包发现三台路由器无法互相学习,尝试通过更改R2、R3的g0/0/1达到全路由的收敛。配置完成后查看路由表,三台路由器是否相互学习,并观察路由表更新方式。

    2.2 实验环境

    在这里插入图片描述

    2.3 实验步骤

    2.3.1 配置R1

    在这里插入图片描述
    rip 1 ###启动RIP进程
    Version 1 ###宣告RIP版本号
    network 12.0.0.0 ###宣告主网络号
    network 1.0.0.0
    在这里插入图片描述

    2.3.2 配置R2

    在这里插入图片描述
    rip 1 ###启动RIP进程
    network 12.0.0.0 ###宣告主网络号
    network 23.0.0.0
    network 2.0.0.0
    在这里插入图片描述

    2.3.3 配置R3

    在这里插入图片描述
    rip 1 ###启动RIP进程
    version 2 ###宣告RIP版本号
    network 12.0.0.0 ###宣告主网络号
    network 1.0.0.0
    在这里插入图片描述

    2.4 验证测试

    进入系统视图模式输入
    dis ip routing-table
    查看路由表信息
    发现R1可以学习到R2和R3的信息
    在这里插入图片描述
    dis ip routing-table 查看路由表信息
    发现R2可以学习到R1和R3的信息
    在这里插入图片描述
    dis ip routing-table 查看路由表信息
    发现R3不能学习到R1和R2的信息
    因为R2发出去的信息是version 2
    在这里插入图片描述
    因为兼容模式收 rip V1 和 rip V2 路由信息,发只能是rip V1路由信息
    解决方法:
    第一种方法:
    进入R3的接口
    Int g0/0/1
    rip version 1
    在这里插入图片描述

    第二种方法:
    进入R2的接口
    Int g0/0/1
    rip version 2 multicast
    在这里插入图片描述
    再进入R3输dis ip routing-table
    就可以看到R3可以学习到R1R2的路由信息
    在这里插入图片描述
    在这里插入图片描述

    三、实验总结

    ●华为rip路由的模式
    V1,V2和兼容模式
    ●兼容模式概述
    兼容模式可以接受rip V1和rip V2的路由信息
    兼容模式只能发送rip V1的路由信息
    ●解决兼容模式不能接受V2路由信息的问题方法:
    第一种:

    在兼容模式的路由接口,配置将数据转化成V2
    interface g0/0/1
     rip version 2 multicast 
     RIP协议中,UDP最大支持25条路由条目
    

    第二种:

    在rip V2路由接口配置,将信息转化成V1
    interface g0/0/1
     rip version 1
    
    展开全文
  • 1、动态路由是与静态路由相对的一个概念,指路由器能够根据路由器之间的交换的特定路由信息自动地建立自己的路由表,并且能够根据链路和节点的变化适时地进行自动调整2、当网络中节点或节点间的链路发生故障,或存在...

    动态路由简述:

    1、动态路由是与静态路由相对的一个概念,指路由器能够根据路由器之间的交换的特定路由信息自动地建立自己的路由表,并且能够根据链路和节点的变化适时地进行自动调整
    2、当网络中节点或节点间的链路发生故障,或存在其它可用路由时,动态路由可以自行选择最佳的可用路由并继续转发报文

    动态路由原理:

    动态路由的运作依赖路由器的两个基本功能:路由器之间适时的路由信息交换,对路由表的维护
    1、路由器之间适时地交换路由信息:
    路由器学习到直连路由
    更新周期30s到时,路由器会向邻居发送路由表
    再过30s,第二个更新周期到了再次发送路由表
    2、动态路由之所以能根据网络的情况自动计算路由、选择转发路径,是由于当网络发生变化时,路由器之间彼此交换的路由信息会告知对方网络的这种变化,通过信息扩散使所有路由器都能得知网络变化
    3、路由器根据某种路由算法(不同的动态路由协议算法不同)把收集到的路由信息填写路由表,供路由器在转发报文时查阅
    4、在网络发生变化时,收集到最新的路由信息后,路由算法重新计算,从而可以得到最新的路由表
    路由器之间的路由信息交换在不同的路由协议中过程和原则是不同的,交换路由信息的最终目的在于通过路由表找到一条转发IP报文的最佳路径。每一种路由算法都有其衡量最佳的一套原则,大多是在综合多个特性的基础上进行计算,这些特性有:跳数(经过路由器的个数)、带宽、负载(一般时间为18:00-21:00)、延迟、可靠性、成本

    常见的动态路由协议有:

    1、RIP:是内部网关协议IGP中最先得到广泛使用的协议。RIP是一种分布式的基于距离向量的路由选择协议,是因特网的标准协议,其最大优点就是实现简单,开销较小
    2、OSPF:是一个内部网关协议,用于在单一自治系统内决策路由
    3、ISIS:该路由协议最初是ISO为CLNP设计的一种动态路由协议
    4、BGP:边界网关协议,是运行于 TCP 上的一种自治系统的路由协议,是唯一一个用来处理像因特网大小的网络的协议,也是唯一能够妥善处理好不相关路由域间的多路连接的协议

    RIP的配置和验证:

    1、启动RIP进程:
    Router(config)#router rip
    2、宣告主网络号:
    Router(config-router)#network network-number
    3、查看路由表:
    Router#show ip route
    4、查看路由协议的配置:
    Router#show ip protocols

    RIP动态路由协议实验:

    第一步:首先规划地址

    PC1:192.168.10.2/24
    R1:
    f0/0接口:192.168.10.1/24
    f0/1接口:192.168.20.1/30
    R2:
    f0/0接口:192.168.20.2/30
    f0/1接口:192.168.30.1/30
    R3:
    f0/0接口:192.168.30.2/30
    f0/1接口:192.168.40.1/30
    PC2:192.168.40.2/24

    常见动态路由协议之———RIP动态路由实验


    第二步:进入R1路由器进行配置:

    输入:conf t
    输入:int f0/0(进入0/0接口)
    输入:ip add 192.168.10.1 255.255.255.0(写IP地址及子网掩码)
    输入:no shut(启用)
    输入:ex(退出)
    输入:int f0/1(进入0/1接口)
    输入:ip add 192.168.20.1 255.255.255.252(写IP地址及子网掩码)
    输入:no shut(启用)
    输入:ex(退出)
    输入:do show ip route(查看路由表)
    此时10和20网段都在路由表中

    常见动态路由协议之———RIP动态路由实验


    第三步:进入R2路由器进行配置:

    输入:conf t
    输入:int f0/0(进入0/0接口)
    输入:ip add 192.168.20.2 255.255.255.0(写IP地址及子网掩码)
    输入:no shut(启用)
    输入:ex(退出)
    输入:int f0/1(进入0/1接口)
    输入:ip add 192.168.30.1 255.255.255.252(写IP地址及子网掩码)
    输入:no shut(启用)
    输入:ex(退出)
    输入:do show ip route(查看路由表)
    此时20和30网段都在路由表中

    常见动态路由协议之———RIP动态路由实验


    第四步:进入R3路由器进行配置:

    输入:conf t
    输入:int f0/0(进入0/0接口)
    输入:ip add 192.168.30.2 255.255.255.252(写IP地址及子网掩码)
    输入:no shut(启用)
    输入:ex(退出)
    输入:int f0/1(进入0/1接口)
    输入:ip add 192.168.40.1 255.255.255.0(写IP地址及子网掩码)
    输入:no shut(启用)
    输入:ex(退出)
    输入:do show ip route(查看路由表)
    此时30和40网段都在路由表中

    常见动态路由协议之———RIP动态路由实验


    第五步:进入PC1/PC2客户机配置IP:

    PC1:
    输入:ip 192.168.10.2 192.168.10.1(写IP地址,网关)
    得到:ip 192.168.10.2 255.255.255.0 gateway 192.168.10.1(得到IP地址,自动获得子网掩码,网关)

    常见动态路由协议之———RIP动态路由实验

    PC2:
    输入:ip 192.168.40.2 192.168.40.1(写IP地址,网关)
    得到:ip 192.168.40.2 255.255.255.0 gateway 192.168.40.1(得到IP地址,自动获得子网掩码,网关)

    常见动态路由协议之———RIP动态路由实验

    以上步骤全部结束之后,在PC1中测试与PC2的互通,此时是无法ping通的:

    常见动态路由协议之———RIP动态路由实验

    因为我们没有在直连路由中配RIP路由协议,所以我们还需要进行以下操作:

    第一步:进入R1路由器进行配置:

    输入:router rip(进入路由进程)
    输入:network 192.168.10.0(宣告直连网段)
    输入:network 192.168.20.0(宣告直连网段)
    输入:version 2(启用版本2)
    输入:no auto-summary(关闭路由汇总)
    输入:ex(退出)

    常见动态路由协议之———RIP动态路由实验


    第二步:进入R2路由器进行配置:

    输入:router rip(进入路由进程)
    输入:network 192.168.20.0(宣告直连网段)
    输入:network 192.168.30.0(宣告直连网段)
    输入:version 2(启用版本2)
    输入:no auto-summary(关闭路由汇总)
    输入:ex(退出)

    常见动态路由协议之———RIP动态路由实验


    第三步:进入R3路由器进行配置:

    输入:router rip(进入路由进程)
    输入:network 192.168.30.0(宣告直连网段)
    输入:network 192.168.40.0(宣告直连网段)
    输入:version 2(启用版本2)
    输入:no auto-summary(关闭路由汇总)
    输入:ex(退出)

    常见动态路由协议之———RIP动态路由实验


    第四步:回到R1路由器查看最新的路由表:

    输入:do show ip route(查看路由表)
    此时会显示通过RIP协议学习到的30和40网段的地址

    常见动态路由协议之———RIP动态路由实验


    第五步:回到R2路由器查看最新的路由表:

    输入:do show ip route(查看路由表)
    此时会显示通过RIP协议学习到的10和40网段的地址

    常见动态路由协议之———RIP动态路由实验


    第六步:回到R3路由器查看最新的路由表:

    输入:do show ip route(查看路由表)
    此时会显示通过RIP协议学习到的10和20网段的地址

    常见动态路由协议之———RIP动态路由实验

    RIP路由协议全部配置结束之后,再次在PC1中测试与PC2的互通,此时是可以ping通的:

    常见动态路由协议之———RIP动态路由实验

    以上即RIP动态路由协议的实验过程,谢谢大家的观看!

    展开全文
  • 详细介绍了动态路由协议实现的网络间通信,步骤详尽,适合初学者的实验指导
  • 动态路由协议的配置 OSPF

    千次阅读 2013-06-02 23:43:06
    □ 了解动态路由协议OSPF和RIP特性   OSPF(Open Shortest Path First)开放最短路径优先协议。首先必须收集有关的链路状态信息,并根据一定的算法计算出到每个节点的最短路径,向其同一管理域的所有其它路由器...
    □ 了解动态路由协议OSPF和RIP特性 
    
         OSPF(Open Shortest Path First)开放最短路径优先协议。首先必须收集有关的链路状态信息,并根据一定的算法计算出到每个节点的最短路径,向其同一管理域的所有其它路由器发送链路状态广播信息。
          RIP(Routing Information Protocol) 路由信息协议,路由器收集所有可到达目的地的不同路径,并且保存到达每个目的地的最少站点数的路径信息,同时路由器也把所收集的路由信息用RIP协议通知相邻的其它路由器。

        OSPF是链路状态路由协议,RIP是距离向量路由协议。

    □ 掌握动态路由协议OSPF和RIP配置方法

     一、实验目的: 

           加深对OSPF协议工作原理的理解;掌握OSPF协议的应用及配置过程。

    二、实验拓补


    三、实验内容:

    • 配置回环口以提供稳定的OSPF路由器ID。
    • 设定OSPF的进程,并在适当的接口上启用OSPF。
    • 使用debug命令排除OSPF无法建立连接的故障。

    四、实验环境:


       PC机两台、路由器两台,线路若干

    RouterA路由器的配置:
    第1步:路由器基本配置
    Router>en
    Router#conf t
    Router (config)#hostname RouterA

    RouterA (config)#interface fastethernet 0/0
    RouterA (config-if)#ip address 192.168.1.1 255.255.255.0
    RouterA (config-if)#no shutdown
    RouterA (config-if)#Exit

    RouterA (config)#interface fastethernet 0/1
    RouterA (config-if)#ip address 192.168.12.1 255.255.255.0
    RouterA (config-if)#no shutdown
    RouterA (config-if)#Exit

    RouterB路由器的配置:
    Router>en
    Router#conf t
    Router (config)#hostname RouterB

    RouterB(config)#interface fastethernet 0/0
    RouterB (config-if)#ip address 192.168.2.1 255.255.255.0
    RouterB (config-if)#no shutdown
    RouterB (config-if)#Exit

    RouterB(config)#interface fastethernet 0/1


    RouterB (config-if)#ip address  192.168.12.2 255.255.255.0
    RouterB (config-if)#no shutdown
    RouterB (config-if)#Exit


    第2步:配置动态路由协议OSPF
    RouterA (config)#router ospf 1
    RouterA (config-router)#network 192.168.1.0 0.0.0.255 area 0
    RouterA (config-router)#network 192.168.12.0 0.0.0.255 area 0
    RouterA (config-router)#end
    RouterA #show ip route

    RouterB 动态路由协议OSPF的配置:
    RouterB (config)#router ospf 1
    RouterB(config-router)#network 192.168.2.0 0.0.0.255 area 0
    RouterB(config-router)#network 192.168.12.0 0.0.0.255 area 0
    RouterB(config-router)#end
    RouterB#show ip route

    测试连通性。
           在任意一台PC上ping另一台PC或路由器的接  

    5. 相关理论知识

         □ OSPF路由协议简介  
         OSPF(Open Shortest Path First,开放最短路径优先)是一种基于链路状态的内部网关路由协议。OSPF能对网络的变化做出快速响应,它是在网络变化时以触发的方式进行更新的,但OSPF也定期(30分钟)更新整个链路状态。

    OSPF路由协议配置
        Router(config)#router ospf process-id ;创建OSPF路由进程
        Router(config-router)#network Network  wildcard area area-id ;定义接口所属区域 
    其中:
        process-id:进程号
        Network:网络地址
        Wildcard:比特通配符 (反掩码)
        area-id:区域号

    6.检查OSPF路由协议的命令。



    Show ip protocols
    Show ip ospf
    Show ip ospf neighbor
    Show ip osfp interface
    Clear ip route


    展开全文
  • 动态路由协议之RIP配置详解

    千次阅读 2013-09-01 16:24:05
    动态路由是网络中路由器之间互相通信,传递路由信息,利用收到的路由信息更新路由表的过程。...如果使用动态路由协议,路由器之间就会将自己的路由信息向相邻的路由器发送,并接受相邻路由器发过来
  • 配置动态路由协议OSPF

    万次阅读 热门讨论 2018-03-19 14:33:15
    但大型的网络和频繁变动的拓扑,就需要配置动态路由协议! 协议就是大家都遵循的规范。 比如你在廊坊,家在西藏,你爸让你回去买个普通的白炽灯灯泡,你爸不会担心你买回家的灯泡不能用,因为全国的白炽灯灯泡就都...
  • 实验5 动态路由协议配置-RIP

    万次阅读 多人点赞 2017-12-14 22:38:38
    1.理解动态路由协议工作原理; 2.掌握动态路由协议的配置方法 3.通过动态路由技术实现网络的互连互通,从而实现信息的共享和传递。 【实验内容】 假设校园网通过1台三层交换机连接到校园网出口路由器,路由器...
  • 实验六 动态路由协议;实验1介绍;实验拓扑;理论介绍;理论介绍;理论介绍;理论介绍;实验步骤;实验步骤;实验步骤;测试结果;验证命令;注意事项;实验2介绍;实验拓扑;理论介绍;理论介绍;理论介绍;实验步骤;实验步骤;实验...
  • 实验一:RIP动态路由协议实验

    千次阅读 2019-09-22 16:14:31
    实验报告一:RIP动态路由协议实验 实验拓扑: Requirment: 某网络整体结构如果所示,在Router1上有3个回环口,IP地址如图,Router3连接两台主机,现要求通过使用路由协议实现全网互联。 在各路由器上配置静态路由...
  • 排除 ISIS 动态路由协议故障与排错解析 1. IS-IS 邻接问题 通常由链路故障和配置错误引起。 show clns neighbors 显示所有希望与被调查的路由器成为邻接的邻居 debug isis adj-packets 命令来调试 2. 部分或所有...
  • CCNP路由实验之五动态路由协议之 OSPF动态路由协议可以自动的发现远程网络,只要网络拓扑结构发生了变化,路由器就会相互交换路由信息,不仅能够自动获知新增加的网络,还可以在当前网络连接失败时找出备用路径。...
  • 动态路由概述:基于某种路由协议实现特点:减少了管理任务占用了网络带宽动态路由协议概述:路由器之间用来交换信息的语言度量值:跳数,带宽,负载,时延,可靠性,成本静态路由与动态路由的比较:网络中静态路由和...
  • 动态路由选择协议

    千次阅读 2019-02-03 22:53:52
    动态路由选择协议: 能够实现自动发现信息和信息共享的系统。动态路由选择协议的最大优点是能够缓解拓扑变化带来的影响。 动态路由选择协议的基础: 所有的路由选择协议都是围绕一种算法构建的,而算法就是逐步解决...
  • 计算机网络实验之动态路由协议RIP的配置
  • 动态路由协议RIP的基本原理与配置

    千次阅读 2017-11-15 23:20:00
    前面学习了静态路由的原理,但是用静态路由...动态路由协议基础 1.动态路由概述 动态路由是网络中路由器之间互相通信,传递路由信息,利用收到的路由信息更新路由表的过程。它能实时的适应网络结构的变化。如果路...
  • 动态路由RIP协议的原理及配置

    千次阅读 2019-10-21 16:21:38
    一:RIP路由协议原理 ​ RIP 路由协议是基于距离矢量算法,使用跳数(metric)来衡量到达目标地址的距离。它是一个用于路由器和主机间交换路由信息的距离向量协议。这种协议的路由器只与自己相邻的路由器交换信息,...
  • RIP----动态路由协议

    千次阅读 2017-11-08 21:17:00
    RIP--动态路由协议 一:实验拓扑 二:实验目标 1:实现三台路由器全网互通 2:熟练掌握RIP协议的各种命令 3:能够掌握路由表中的各种信息 三:实验原理 1):有什么说什么//指每个路由器中的路由表有什么信息把他...
  • 配置动态路由OSPF协议

    千次阅读 2020-03-22 14:50:18
    4、配置动态路由OSPF (1)Router0 A、en B、config t C、router ospf 1【这个1指的是进程号,可以随便写】 D、network 172.16.0.0 0.0.255.255 area 0 【0.0.255.255:表示的是子网掩码反过来写,0变成1,1变成0】 ...
  • 网络实验(七动态路由协议配置)

    千次阅读 2013-06-06 15:57:55
    实验七:动态路由协议的配置 这个和实验六静态路由协议的配置差不很多:总结上次的经验,这次把每一步的步骤和代码详细跟着,上次为啦贪图方便,就把代码一股脑的全放上面拉,今天同学问我实验代码,我也是第一次...
  • 路由协议:用于路由器动态寻找网络最佳路径,保证所有路由器拥有相同的路由表,一般路由协议决定数据包在网络上的行走路径。 路由协议简单分为静态路由协议动态路由协议。 静态路由协议简单说就是手工配置路由选项...
  • 一篇很有参考意义的论文,作者开发了DSR协议在内核模式下,有详细的步骤。 接口。对于想在linux下开发路由协议的人很有用。
  • - BGP是一种运行在AS与AS之间的动态路由协议,主要作用是在AS之间自动交换无环路由信息 - 以此来构建AS的拓扑图,从而消除路由环路并实施用户配置的路由策略。 - 目前公网网络条目众多,IGP协议无法承载,而BGP可以...
  • 动态路由协议-RIP原理与配置实验

    千次阅读 2020-06-01 17:33:40
    最简单的拓扑图解释RIP配置,RIP协议特点,华为模拟器中详细的配置命令
  • 动态路由器+RIP路由协议配置及验证前言一、动态路由1.1动态路由协议基础1.1.1动态路由1.1.2动态路由特点1.2动态路由协议概述1.2.1度量值1.2.2收敛1.2.3静态路由与动态路由的比较1.3动态路由协议分类二、RIP路由协议...
  • OSPF动态路由协议高级配置 路由重分发配置 一.路由重分发配置命令: Router(config-router)#redistribute protocol metric metric-value metric-type type-value subnets 二.路由重分发配置实例: OSPF协议与RIP...
  • 分别在路由器R1、R2、R3上配置OSPF协议,实现全网互通,其中将R1上的G0/0/1口OSPF优先级设置为255,且R3不配置Router-id 1.3 实验详细步骤及配置 1、在R1上进行如下配置: <Huawei>sys [Huawei]sysname R1 [R1...
  • 边界网关协议(BGP)是运行于 TCP 上的一种自治系统的路由协议。 BGP 是唯一一个用来处理像因特网大小的网络的协议,也是唯一能够妥善处理好不相关路由域间的多路连接的协议。 BGP 构建在 EGP 的经验之上。 BGP 系统...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 66,698
精华内容 26,679
关键字:

动态路由协议工作步骤