精华内容
下载资源
问答
  • 转载于:https://www.cnblogs.com/fanweisheng/p/11156797.html

     

    转载于:https://www.cnblogs.com/fanweisheng/p/11156797.html

    展开全文
  • OSPF基础知识介绍,OSPF与RIP的主要区别,OSPF协议的算法,OSPF路由表的计算与实现,OSPF协议工作原理的解释等。
  • OSPF是一种分层次的路由协议,其层次中最大实体是AS(自治系统),即遵循共 同路由策略管理下一部分网络实体。在每个AS中,将网络划分为不同区域。每个区域都有自己特定标识号。对于主干(backbone)区域,...
  • 动态路由协议RIP的基本原理与配置

    千次阅读 2017-11-15 23:20:00
    前面学习了静态路由的原理,但是用静态路由...动态路由协议基础 1.动态路由概述 动态路由是网络中路由器之间互相通信,传递路由信息,利用收到路由信息更新路由表过程。它能实时适应网络结构变化。如果路...

      前面学习了静态路由的原理,但是用静态路由搭建网络时,每一条路由的变更都需要手动进行配置,这在大型网络中的工作量是非常巨大的。有没有办法解决呢?答案是肯定的,使用动态路由即可解决此问题

    动态路由协议基础

    1. 动态路由概述

       动态路由是网络中路由器之间互相通信,传递路由信息,利用收到的路由信息更新路由表的过程。它能实时的适应网络结构的变化。如果路由更新信息表明网络发生了变化,路由选择软件就会重新计算路由,并发出新的路由更新信息。这些信息通过各个网络,引起各路由器重新启动其路由算法,并更新各自的路由表以动态的反映网络拓扑的变化。

       如果使用动态路由协议,路由器之间就会将自己的路由信息向相邻的路由器发送,并接收相邻路由器发过来的路由信息,有选择的保存这些路由信息,生成自己的路由表。

       动态路由适用于网络规模大、网络拓扑复杂的网络。动态路由的特点如下:

     减少了管理任务。因为动态路由的过程完全是由路由器自己完成的,管理员只需做简单的配置即可,路由学习、路由转发和路由维护的任务都是由动态路由来完成的。配置了动态路由后,当网络拓扑发生变化时,不需要进行重新配置,动态路由会自己了解这些变化,从而修改路由表。

     占用了网络的带宽。因为动态路由是通过与其他路由器通信来了解网络的,每个路由器都要告诉其他路由器自己所知道的的网络信息,同时还要从其他路由器学习自己所不知道的网络信息,这样就不可避免的发送包,而这些路由信息包会占用一定的网络流量。


    2. 动态路由协议

    (1) 动态路由协议概述

       动态路由是基于某种路由协议(Routing Protocol)来实现的。路由协议定义了路由器在与其他路由器通信时一些规则。也就是说,路由协议规定了路由器是如何来学习路由的,是用什么标准来选择路由以及维护路由信息的等。

       动态路由协议就像路由器之间用来交流信息的语言,通过它,路由器之间可以共享网络连接信息和状态信息。动态路由协议不局限于路径的选择和路由表的更新,当到达目的网络的最优路径出现问题时,动态路由协议可以在剩下的可用路径中,选择下一个最优路径进行替代。

       每一种动态路由协议都有它自己的路由选择算法,算法是解决问题的一系列步骤。一个路由选择算法至少要具备以下几个必要的步骤:

    * 向其他路由器传递路由信息。

    * 接收其他路由器的路由信息。

    * 根据收到的路由信息计算出每个目的网络的最优路径,并由此生成路由表。

    * 根据网络拓扑的变化及时作出反应,调整路由生成新的路由表,同时把拓扑变化以路由信息的形式向其他路由信息宣告。


    (2) 度量值

       不同的路由协议使用不同的度量,有时还使用多个度量。

    跳数:跳数(Hop Count)度量可以简单的记录路由器的跳数。

    带宽:带宽(Bandwidth)度量将会选择高带宽路径,而不是低带宽路径。

    负载:负载(Load)度量反映了占用沿途链路的流量大小。最优路径应该是负载最低的路径。不像跳数和带宽,路径上的负载会发生变化,因而度量也会跟着变化。这时需要注意,如果度量变化过于频繁,路由摆动(最优路径频繁变化)可能经常发生。路由摆动会对路由器的CPU、数据链路的带宽和全网稳定性产生负面影响。

    时延:时延(Delay)度量数据包经过一条路径所花费的时间。使用时延作为度量值的路由选择协议时将会选择使用最低时延的路径作为最优路径。

    可靠性:可靠性(Reliability)度量用来度量链路在某种情况下发生故障的可能性。可靠性可以是变化的或固定的。链路发生故障的次数或特定时间间隔内收到错误的次数都是可变可靠性度量的例子。固定可靠性度量是基于管理员确定的一条链路的已知量。可靠性最高的路径将被最优先选择。

    成本:成本(Cost)是用来描述路由优劣的一个通用术语,最小成本(最高成本)或最短(最长)仅仅指的是路由协议基于自己特定的度量对路径的一种看法。网络管理员可以对Cost进行手工定义。


    (3) 收敛

       动态路由选择协议必须包含一系列过程,这写过程用于路由器向其他路由器通告本地直连网络,接收并处理来自其他路由器的同类信息,中继从其他路由器接收到的信息。此外,路由选择协议还需要定义决定最优路径的度量。对路由选择协议来说,另一个标准是互联网网络上所有路由器的路由表中的可达信息必须是一致。使所有路由表都达到一致状态的过程叫做收敛(Convergence)。全网实现信息共享以及所有路由器计算最优路径所花费的时间的总和就是收敛时间。


    3. 静态路由和动态路由

       通过动态路由的学习,感觉动态路由协议比静态路由协议要好。动态路由协议就是自动检测并随着网络拓扑的变换更新路由表。静态路由协议对于大中型网络来说管理是困难的,但在小型网络中配置静态路由是十分方便的。

       静态路由和动态路由都有各自的特点和实用范围,在网络中静态路由和动态路由互相补充。在所有的路由中,除直连路由外静态路由的优先级最高。当一个包在路由器中进行路径选择时,路由器首先查找静态路由,如果查到则根据相应的静态路由进行转发分组,否则再查找动态路由。当静态路由与动态路由发生冲突时,以静态路由为准。


    动态路由协议分类

       常见的路由协议可以分为距离矢量路由协议和链路状态路由协议。其中距离矢量路由协议依据从源网络到目标网络所经过的路由器的个数来选择路由,典型的协议如RIP和IGRP链路状态路由协议会综合考虑从源网络到目标网络的各种路径的情况来选择路由,典型的协议如OSPF和IS-IS

    1. 距离矢量路由协议

       距离矢量名称的由来是因为路由是以矢量(距离、方向)的方式被通告出去的,其中距离是根据度量定义的,方向是根据下一跳路由器定义的。例如,“朝下一跳路由器X的方向可以到达目标A,距此5跳之远”,这个表述隐含着每个路由器向邻接路由器学习它们所观察到的路由信息,然后再向外通告自己观察到的路由信息。因为每个路由器在信息上都依赖于邻接路由器,而邻接路由器又从它们的邻接路由器那里学习路由,以此类推,所以距离矢量路由选择有时又被认为是“依据传闻进行路由选择”。

    2. 链路状态路由协议

       距离矢量路由协议所使用的信息可以比喻为路标提供的信息,而链路状态路由协议像是一张公路线路图。链路状态路由器是不容易被欺骗而做出错误的路由决策的,因为它有一张完整的网络图。链路状态不同于距离矢量依照传闻进行路由选择的工作方式,原因是链路状态路由器从对等路由器那里获取第一手信息。每台路由器会产生一些关于自己、本地直连网络以及这些链路状态的信息。这些信息从一台路由器传送到另一台路由器,每台路由器都做一份信息备份,但是绝不改动信息。最终目的是每台路由器都有一个相同的有关互联网络信息,并且每台路由器可以独立的计算各目的最优路径。


    RIP路由协议工作原理

       在学习RIP协议之前,先了解几个距离矢量路由协议的概念:

    定期更新(Periodic Updates):定期更新意味着每经过特定时间周期就要发送更新信息。需要注意,如果更新信息的发送过于频繁可能会引起拥塞,但如果更新信息发送不频繁,网络收敛时间可能长得难以接受。

    邻居(Neighbors):在路由器看来,邻居通常意味着共享相同数据链路的路由器。距离矢量路由选择协议向邻居路由器发送更新信息,并依赖邻居向它的邻居传递更新信息。因此,距离矢量路由协议被说成是使用逐跳更新方式。

    广播更新(Broadcast Update):当路由器首次在网络上被激活时,路由器怎样寻找其他路由器呢?它又是怎样宣布自己的存在呢?最简单的方法是向广播地址(在IP网络中,广播地址是255.255.255.255)发送更新信息。使用相同路由器选择协议的邻居路由器将会收到广播数据包,并且采取相应的动作。不关心路由更新信息的主机和其他设备会丢弃该数据包。

    全路由表更新(Full Routing Table Update):大多数距离矢量路由协议使用非常简单的方法告诉邻居它所知的一切,该方法就是广播它的整个路由表。邻居在收到这些更新信息之后,会收集自己需要的信息,其他则被丢弃。


    1. 路由表的形成

       在为路由器配置了接口的IP地址,并且在接口up的情况下,每个路由器的路由表中会出现直连路由的条目。如果为路由器配置了RIP路由协议,路由器之间就会互相发送自己的路由表信息。

       路由器接收到相邻路由器发送来的路由信息,会与自己路由表中的条目进行比较,如果路由表中已经有这条路由信息,路由器会比较新接收到的路由信息是否优先于现有的条目。如果优先于现有的条目,路由器会用新的路由信息替换原有的路由条目。反之,则路由器比较这条路由信息与原有的条目是否来自同一个源,如果来自同一个源,则更新,否则就忽略这条路由信息。

      wKioL1mhbpuAfKPLAACkiT2GCJk142.png


    2. RIP的度量值与更新时间

    (1) RIP的度量值

      RIP路由协议使用跳数作为唯一的度量值。

      在RIP中规定了跳数的最大值为15, 16跳视为不可达。因此,RIP路由协议不适用与大型的广域网。

    (2) RIP的更新时间

      RIP使用UDP协议,端口号是520

      路由器启动后,平均每隔30s就从每个启动RIP协议的接口不断的发送出路由更新消息。


    3. 水平分割(Split Horizon)

       网络收敛后,路由器仍然在以30s的时间间隔向外发送整个路由表。

       执行水平分割可以阻止路由环路的发生,水平分割的规则是:从一个接口学习到路由信息,不再从这个接口发送出去。水平分割不仅能够阻止路由环路的产生,同时也能减少路由更新信息占用的链路带宽资源。


    RIP路由协议的配置和验证

    1. 配置命令

     配置RIP路由协议,首先要在路由器上启动RIP进程。

      启动RIP进程的命令如下:

    1
    Router(config)# router rip

     然后要将路由器上所有启动RIP的接口的主网络号宣告出去,命令如下:

    1
    Router(config-router)# network network-number


    2. 验证配置的命令

    查看路由表

      使用查看路由表命令查看路由表是否通过RIP协议学习到了正确的路由条目,命令如下:

    1
    Router# show ip route

    查看路由协议的配置

      使用查看路由协议配置的命令,可以查看关于RIP计时器,使用的版本、宣告的网段等信息,命令如下:

    1
    Router# show ip protocols

       在路由表中可以看到网络中所有的网段,表明RIP的配置正确。在路由条目中前面有标记C的为直连路由,标记R的为通过RIP路由协议学习到的路由。在网段号后面的[120/1]表示管理距离(优先级)和度量值(跳数)。

       管理距离是一种优先级度量,当两种路由方式到达同一网络时,路由器会选择管理距离较小的路由来到达目标网段。静态路由的管理距离为1,而RIP协议的管理距离为120,因此,如果到达同一网段,同时配置了静态路由和RIP,路由器会选择静态路由指向的路径来转发数据。RIP的优先级:120,OSPF的优先级:110

      默认情况下,RIP使用版本1发送路由更新,可以接受v1和v2两个版本的路由的更新。


    RIP v1与TIP v2

       RIP路由协议包含两个版本,RIP v1和RIP v2。版本1和版本2主要的区别如下:

    * RIP v1广播发送路由更新,广播地址为255.255.255.255;RIP v2组播发送路由更新,组播地址为224.0.0.9

    * RIP v1是有类路由(Classful)协议,它们在宣告路由信息时不携带网络掩码;而RIP v2是无类路由(Classless)协议,它们在宣告路由信息时携带网络掩码。

       有类路由协议的另一个特点是在边界路由器上自动进行路由汇总


    RIP v2的配置

      配置RIP协议,使用版本v2的命令如下:

    1
    2
    3
    4
    Router(config)# router rip                      // 启动RIP进程
    Router(config-router)# version 2                  //使用版本v2
    Router(config-router)# no auto-summary              //关闭路由汇总功能
    Router(config-router)# network network-number         //宣告网段


    实验案例:验证RIP v1和RIP v2

    实验环境:

    按如图所示的拓扑图连接网络,其中10.1.1.0/24和10.1.2.0/24配置RIP v2

    wKioL1miN_LDvDBdAACZoxIRr8Q401.png

    需求描述:

    要求分别配置RIP v1和RIP v2,并验证网络是否可以正常通信。

    具体步骤:

    1. 配置路由器的接口地址,实现路由器互通(略)

    2. 分别配置RIP v1和RIP v2,验证网络通信是否正常。

    (1)配置RIP v1

    1
    2
    3
    R1(config)# router rip
    R1(config-router)# network 10.1.1.0
    R1(config-router)# network 192.168.1.0

    1
    2
    3
    R2(config)# router rip
    R2(config-router)# network 192.168.1.0
    R2(config-router)# network 192.168.2.0

    1
    2
    3
    R3(config)# router rip
    R3(config-router)# network 10.1.2.0
    R3(config-router)# network 192.168.2.0

    (2)查看路由表,显示结果如下:

    R1的路由表

    wKioL1miRDKCZ6GqAACSxhSQvFE448.png

    R2的路由表

    wKiom1miRETSEglaAACRBM4x2bY071.png

    R3的路由表

    wKiom1miREaAUE_JAACS9uPHTF4471.png

       可以看出路由表条目错误,路由器把10.1.1.0/24和10.1.2.0/24两个网段自动进行汇总,形成了10.0.0.0/8网段,R2路由器保存了两条到达10.0.0.0/8网段的路由,一个指向R1,一个指向R3,从而发生错误的数据转发情况。


    (3)配置RIP v2

    1
    2
    3
    4
    5
    R1(config)# router rip
    R1(config-router)# version 2
    R1(config-router)# no auto-summary
    R1(config-router)# network 10.1.1.0
    R1(config-router)# network 192.168.1.0
    1
    2
    3
    4
    5
    R2(config)# router rip
    R2(config-router)# version 2
    R2(config-router)# no auto-summary
    R2(config-router)# network 192.168.1.0
    R2(config-router)# network 192.168.2.0
    1
    2
    3
    4
    5
    R3(config)# router rip
    R3(config-router)# version 2
    R3(config-router)# no auto-summary
    R3(config-router)# network 10.1.2.0
    R3(config-router)# network 192.168.2.0

    (4)查看路由表,显示结果如下:

    R1的路由表

    wKiom1miTAbj5K3LAACZ5GaaxYc963.png

    R2的路由表

    wKioL1miS_eC5wHaAACWeEJOP2M044.png

    R3的路由表

    wKiom1miTAfDfpwgAACXyWIZWfw264.png

       在路由表中可以看到网络中所有的网段,表明RIP的配置正确,经验证,PC1与PC2可以正常通行

    wKioL1miTbGhyInOAABvbe8Es9w528.png

      使用show ip protocols 命令查看路由协议信息

    wKioL1miTxmCUs68AACdBpT4Hi0971.png

        通过实验,可以知道,RIP v1不支持不连续的子网,因为会自动进行路由汇总;RIP v2可以配置不进行自动汇总功能,在宣告路由信息时携带网络掩码,就不会产生前面的转发错误了。由此可知,RIPv2支持不连续的子网










    本文转自 杨书凡 51CTO博客,原文链接:http://blog.51cto.com/yangshufan/1959692,如需转载请自行联系原作者
    展开全文
  • 文章目录前言一、BGP概述1.1BGP简介1.2BGP的特征1.3各路由协议的分类二、BGP工作原理2.1BGP报文2.2BGP数据库2.3BGP的类型三、BGP协议的配置3.1配置思路3.2配置实验3.2.1拓扑图3.2.2配置步骤3.2.3各路由器配置3.2.4...

    前言

    边界网关协议(BGP)是运行于 TCP 上的一种自治系统的路由协议。 BGP 是唯一一个用来处理像因特网大小的网络的协议,也是唯一能够妥善处理好不相关路由域间的多路连接的协议。 BGP 构建在 EGP 的经验之上。 BGP 系统的主要功能是和其他的 BGP 系统交换网络可达信息。网络可达信息包括列出的自治系统(AS)的信息。这些信息有效地构造了 AS 互联的拓朴图并由此清除了路由环路,同时在 AS 级别上可实施策略决策。

    一、BGP概述

    1.1BGP简介

    BGP是一种运行在AS与AS之间的动态路由协议,主要作用是在AS之间自动交换无环路由信息
    以此来构建AS的拓扑图,从而消除路由环路并实施用户配置的路由策略。目前公网网络条目众多,
    IGP协议无法承载,而BGP可以轻松应对,通常BGP协议用于ISP和ISP之间或跨域地域总、分公司之间
    的路由信息交换

    1.2BGP的特征

    ●传输协议:TCP,端口号179
    ●BGP是外部路由协议,用来在AS之间传递路由信息
    ●是一种增强的路径矢量路由协议
    ●拥有可靠的路由更新机制
    ●具备丰富的Metric度量方法
    ●无环路协议设计
    ●为路由条目附带多种属性信息
    ●支持CIDR(无类别域间选路)
    ●丰富的路由过滤和路由策略
    ●无需周期性更新
    ●路由更新时只发送增量路由
    ●周期性发送KeepAlive报文以保持 TCP连通性

    1.3各路由协议的分类

    按自治系统分为

    • IGP:自治系统内部路由协议,主要:RIP1/RIP2、OSPF、ISIS、EIGRP(思科私有协议)
      IGP是运行在AS内部的路由协议,主要解决AS内部的选路问题,发现、计算路由
    • EGP:自治系统之间的路由协议,通常:BGP
      EGP是运行在AS与AS之间的路由协议,他解决AS之间选路问题。

    按协议类型分类

    • 距离矢量路由协议:rip1/2、BGP(路径矢量协议)、EIGRP(高级距离矢量协议)
    • 链路状态路由协议:OSPF、ISIS ###SFP最短路径算法

    二、BGP工作原理

    2.1BGP报文

    ●Open报文
    OPen报文是TCP建立后发送的第一个报文,用于建立BGP对等体之间的连接关系,
    主要包含BGP版本号、本地AS编号、Holdtime等信息

    ●UPdate报文
    Update报文用来在BGP之间更新路由信息,Updata报文可以通告多条属性相同的可达路由信息
    也可以撤销多条路由不可达的路由信息

    ●Notification报文
    报文的作用是当BGP检测到错误状态时候,立即向对等体发送NOtification报文,之后BGP就会中断
    只要收到Notification报文就会返回idle状态

    ●Route-Refresh
    用来告知对等体所支持路由的刷新能力,BGP的入口策略路由发生变化,本地的BGP路由会向对等体发送
    Route-Refresh报文,收到信息后,对等体将其路由信息重新发送给本地BGP路由器

    ●KeepAlive
    该报文在对等体之间周期的发送报文,用以保持连接的有效性并维护其连接,KeepAlive报文只有一个BGP
    报文头,默认KeepAlive报文发送周期为60S,保持时间180S,这个类似于OSPF中的Hello报文

    2.2BGP数据库

    ●IP路由表:全局路由信息库,包括最优的IP路由信息
    ●BGP路由表:BGP路由信息库,包括本地BGPSpeak通告的路由信息,将其最优的添加到路由表中
    ●邻居表:对等体邻居清单表,包括对等体两端的邻居信息及邻居列表
    ●Adi-RIB-In:对等体宣告给本地的Speak的未处理的路由信息库
    ●Adjust-RIB-OUT:本地Speak宣告给指定的对等体路由信息库

    2.3BGP的类型

    两种邻居:IBGP和EBGP
    ●IBGP:同一个AS内部BGP邻居关系,IBGP邻居是指运行BGP协议的对等体两端在同一个AS域内,属于BGP AS内部
    ●EBGP:AS之间的BGP邻居关心,EBGP通常指运行BGP协议的对等体两端在不同AS内部

    三、BGP协议的配置

    3.1配置思路

    1、启用BGP,后面跟AS系统号
    2、宣告Route-id,建立邻居关系用
    3、宣告和谁建立邻居关系,
    4、通告BGP路由,(network、import)

    3.2配置实验

    3.2.1拓扑图

    4台路由器,R1、R2、R4之间为电信运营商,底层用的OSPF协议,上层为BGP协议,国家骨干网为BGP协议。
    在这里插入图片描述

    3.2.2配置步骤

    1.配置4台路由器的接口IP、回环地址
    2.配置R1、R2、R4的OSPF协议
    3.配置R1、R2、R3、R4的BGP协议
    4.配置R2与R3的rip协议,设置引入路由
    5.进行测试

    3.2.3各路由器配置

    R4配置

    interface GigabitEthernet0/0/0
     ip address 15.0.0.2 255.255.255.252
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255
    #
    interface LoopBack1
     ip address 202.0.0.1 255.255.255.0
    #
    interface LoopBack2
     ip address 202.0.1.1 255.255.255.0
    #
    bgp 100                                                               #进BGP进程
     router-id 4.4.4.4                                                    #配置BGProuterid
     peer 1.1.1.1 as-number 100                                           #邻居路由建立对等体关系
     peer 1.1.1.1 connect-interface LoopBack0                             #回环口和对等体建立关系
     peer 2.2.2.2 as-number 100              
     peer 2.2.2.2 connect-interface LoopBack0
     import-route direct                                                  #引入路由
    #
    ospf 1 router-id 4.4.4.4
     area 0.0.0.0
      network 15.0.0.0 0.0.0.3
      network 4.4.4.4 0.0.0.0
      network 202.0.0.0 0.0.0.255
      network 202.0.1.0 0.0.0.255
    

    R1配置

    interface GigabitEthernet0/0/0
     ip address 15.0.0.1 255.255.255.252
    #
    interface GigabitEthernet0/0/1
     ip address 12.0.0.1 255.255.255.252
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    bgp 100
     router-id 1.1.1.1
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack0
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
    #
    ospf 1 router-id 1.1.1.1
     area 0.0.0.0
      network 1.1.1.0 0.0.0.255
      network 15.0.0.0 0.0.0.3
      network 12.0.0.0 0.0.0.3
    

    R2配置

    interface GigabitEthernet0/0/0
     ip address 12.0.0.2 255.255.255.252
    #
    interface GigabitEthernet0/0/1
     ip address 23.0.0.1 255.255.255.252
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    bgp 100
     router-id 2.2.2.2
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack0
     peer 3.3.3.3 as-number 200
     peer 3.3.3.3 ebgp-max-hop 2                                      #建立EBGP连接允许的最大跳数
     peer 3.3.3.3 connect-interface LoopBack0
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
    #
    ospf 1 router-id 2.2.2.2
     import-route rip 1                                               #引入rip路由
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 12.0.0.0 0.0.0.3
    #
    rip 1
     version 2
     network 2.0.0.0
     network 23.0.0.0
     import-route ospf 1                                              #引入OSPF路由
    

    R3配置

    interface GigabitEthernet0/0/0
     ip address 23.0.0.2 255.255.255.252
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    bgp 200
     router-id 3.3.3.3
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 ebgp-max-hop 2
     peer 2.2.2.2 connect-interface LoopBack0
    #
    rip 1
     version 2
     network 3.0.0.0
     network 23.0.0.0
    

    在配置完毕后,查看各个路由器的路由表,R3的路由表可以看到所有的路由信息了
    在这里插入图片描述

    3.2.4测试

    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • ISIS是一个分级链接状态路由协议,基于DECnet PhaseV 路由算法,实际上与OSPF非常相似,它也使用Hello协议寻找毗邻节点,使用一个传播协议发送链接信息。ISIS可以在不同子网上操作,包括广播型LAN、WAN和点...

    前言

    ISIS是一个分级的链接状态路由协议,基于DECnet PhaseV 路由算法,实际上与OSPF非常相似,它也使用Hello协议寻找毗邻节点,使用一个传播协议发送链接信息。ISIS可以在不同的子网上操作,包括广播型的LAN、WAN和点到点链路。

    一、ISIS基本原理

    1.1概述

    中间系统到中间系统(IS-IS,Intermediate system to intermediate system,意为“中间系统到中间系统”)是一种内部网关协议,是电信运营商普遍采用的内部网关协议之一。标准的IS-IS协议是由国际标准化组织制定的ISO/IEC 10589:2002 所规范的。但是标准的IS-IS协议是为无连接网络服务(CLNS)设计的,并不直接适合于IP网络,因此互联网工程任务组制定了可以适用于IP网络的集成化的IS-IS协议,称为集成IS-IS,它由RFC 1195等RFC文档所规范。由于IP网络的普遍存在,一般所称的IS-IS协议,通常是指集成IS-IS协议。
    简单而言

    • ISIS是链路状态协议,使用SPF算法
    • ISIS使用Hello包建立邻居关系、使用LSP交换链路状态信息,采用分层设计

    1.2ISIS路由器分类

    • ISIS协议有2种路由选择级别,L1和L2.

    L1负责在同一个区域内传播链路状态信息(类似OSPF中的1类和2类)
    L2负责在不同的区域内相互传播链路状态信息(类似OSPF的3类)

    • 三种路由器

    L1能获取区域内的路径信息
    L2能获取区域间的路径信息
    L1-2能同时获取区域内和区域间路径

    • 连接L2路由器和L1/L2路由器的路径会形成骨干区域
    • IS-IS区域边界位于链路上,而不是路由器中,每台IS-IS路由器仅属于一个区域

    1.3ISIS邻居关系

    • 相同区域内
      L1可以和L1,L1-2建立邻居关系,但无法和L2建立邻居关系
      L2可以和L2,L1-2建立邻居关系
      L1-2可以和L1和L2建立邻居关系
    • 不同区域内
      L1无法和其他路由建立邻居关系
      L2可以和其他路由建立邻居关系,除了L1
      L1-2可以和其他路由建立邻居关系,除了L1

    1.4NSAP地址

    • IS-IS LSP使用NSAP地址来标识路由器并建立拓扑表,因此为IP提供路由选择需要NSAP地址
    • NSAP地址8-20字节,用16进制标识,包含如下主要信息:
      【1】区域编号
      【2】系统编号(固定6个字节)
      【3】NSEL位(固定1字节并置0)

    例如:49.0001.0002.0002.0002.00

    • 现网NET地址常见的规划方式
      通过环回口32位地址补齐成48位获得
      例如:221.15.23.180 ###补足3位,然后4位分割
      221.15.23.180====221.015.023.180=2210.1502.3180
      转换后:49.0020.2210.1502.3180.00

    二、ISIS基本配置

    2.1路由泄露

    就是把 L2区域的具体的路由发布到 L1 区域当中去,从而是 L1 能够选择更优的路由。

    2.2路由重分发

    在大型的企业中,可能在同一网内使用到多种路由协议,为了实现多种路由协议的协同工作,路由器可以使用路由重分发(route redistribution)将其学习到的一种路由协议的路由通过另一种路由协议广播出去,这样网络的所有部分都可以连通了。 为了实现重分发,路由器必须同时运行多种路由协议,这样,每种路由协议才可以取路由表中的所有或部分其他协议的路由来进行广播。

    2.3路由汇总

    路由汇总的含义是把一组路由汇聚为一个单个的路由广播。路由汇总的最终结果和最明显的好处是缩小网络上的路由表的尺寸。
    例如:
    把这几个网络地址展开为2进制的,然后看相同的网络位,连续而且相同的网络位就是这几个网络地址的汇总地址了,例如:
    172.168.4.1/24
    172.168.5.1/24
    172.168.6.1/24
    172.168.7.1/24
    这几个地址展开来是:
    10101100.10101000.00000100.00000001
    10101100.10101000.00000101.00000001
    10101100.10101000.00000110.00000001
    10101100.10101000.00000111.00000001
    他们都有相同的前22位,所以汇总地址就是 172.168.4.0/22
    还有,汇总只能汇总到主类的边界,也就是说A类只能汇总到/8,B类只能汇总到/16,C类只能汇总到/24。
    路由汇总其实是另外一个路由知识,下次单独拿出来再仔细说清楚

    2.4实验拓扑图

    在这里插入图片描述

    2.4实验步骤

    1、进行基础配置,配置6台路由器的ISIS、rip,各接口IP地址,查看此时各路由器路由表
    2、配置路由泄露,将level2区域的路由引入到level1,查看此时各路由器路由表的变化
    3、配置路由重分发,查看各路由器路由表的变化
    4、进行路由汇总,减少路由表尺寸,查看各路由器路由表的变化

    2.5各路由器配置命令

    R5配置

    [R5]isis 1
    [R5-isis-1]is-level level-1                            ##将路由器isis等级设置L1
    [R5-isis-1]network-entity 49.0002.0050.0500.5005.00    #宣告IP地址
    [R5]int g0/0/0
    [R5-GigabitEthernet0/0/0]ip add 45.0.0.2 30
    [R5-GigabitEthernet0/0/0]isis enable                   #开启isis
    [R5-GigabitEthernet0/0/0]un sh
    [R5]int loo 0
    [R5-LoopBack0]ip add 5.5.5.5 32
    [R5-LoopBack0]isis enable 
    [R5]int loo 1
    [R5-LoopBack1]ip add 202.0.0.1 24
    [R5-LoopBack1]isis enable 
    [R5]int loo 2
    [R5-LoopBack2]ip add 202.0.1.1 24
    [R5-LoopBack2]isis enable 
    

    R4配置

    [R4]isis 1
    [R4-isis-1]network-entity 49.0002.0040.0400.4004.00     #宣告IP地址
    [R4]int g0/0/1
    [R4-GigabitEthernet0/0/1]ip add 34.0.0.2 30
    [R4-GigabitEthernet0/0/1]isis enable 
    [R4-GigabitEthernet0/0/1]un sh
    [R4]int g0/0/0
    [R4-GigabitEthernet0/0/0]ip add 45.0.0.1 30
    [R4-GigabitEthernet0/0/0]isis enable
    [R4-GigabitEthernet0/0/0]un sh
    [R4]int loo 0
    [R4-LoopBack0]ip add 4.4.4.4 32
    [R4-LoopBack0]isis enable 
    

    R3配置

    [R3]isis 1
    [R3-isis-1]is-level level-2                              ##将路由器isis等级设置L1-2
    [R3-isis-1]network-entity 49.0000.0030.0300.3003.00      #宣告IP地址
    [R3]int g0/0/0
    [R3-GigabitEthernet0/0/0]ip add 23.0.0.2 30
    [R3-GigabitEthernet0/0/0]isis enable 
    [R3-GigabitEthernet0/0/0]un sh
    [R3]int g0/0/1
    [R3-GigabitEthernet0/0/1]ip add 34.0.0.1 30
    [R3-GigabitEthernet0/0/1]isis enable 
    [R3-GigabitEthernet0/0/1]un sh
    [R3]int loo 0
    [R3-LoopBack0]ip add 3.3.3.3 32
    [R3-LoopBack0]isis enable 
    

    R2配置

    [R2]isis 1
    [R2-isis-1]network-entity 49.0001.0020.0200.2002.00       #宣告IP地址
    [R2]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip add 12.0.0.2 30
    [R2-GigabitEthernet0/0/1]isis enable 
    [R2-GigabitEthernet0/0/1]un sh
    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip add 23.0.0.1 30
    [R2-GigabitEthernet0/0/0]isis enable 
    [R2-GigabitEthernet0/0/0]un sh
    [R2]int loo 0
    [R2-LoopBack0]ip add 2.2.2.2 32
    [R2-LoopBack0]isis enable 
    

    R1配置

    [R1]isis 1
    [R1-isis-1]is-level level-1                              ##将路由器isis等级设置L1
    [R1-isis-1]network-entity 49.0001.0010.0100.1001.00      #宣告IP地址
    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 12.0.0.1 30
    [R1-GigabitEthernet0/0/1]isis enable 
    [R1-GigabitEthernet0/0/1]un sh
    [R1]int loo 0
    [R1-LoopBack0]ip add 1.1.1.1 32
    [R1-LoopBack0]isis enable 
    [R1]rip 1
    [R1-rip-1]version 2                                       #设置rip版本为2   
    [R1-rip-1]network 16.0.0.0
    [R1-rip-1]undo summary                                    #关闭自动聚合
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 16.0.0.1 30
    [R1-GigabitEthernet0/0/0]un sh
    

    R6配置

    [R6]int g0/0/0
    [R6-GigabitEthernet0/0/0]ip add 16.0.0.2 30
    [R6-GigabitEthernet0/0/0]un sh
    [R6]int loo 0
    [R6-LoopBack0]ip add 6.6.6.6 32
    [R6]int loo 1
    [R6-LoopBack1]ip add 203.0.0.1 24
    [R6]int loo 1
    [R6-LoopBack1]ip add 203.0.0.1 24
    [R6]int loo 2
    [R6-LoopBack2]ip add 203.0.1.1 24
    [R6]rip 1
    [R6-rip-1]version 2
    [R6-rip-1]network 16.0.0.0
    [R6-rip-1]network 6.0.0.0
    [R6-rip-1]network 203.0.0.0
    [R6-rip-1]network 203.0.1.0
    [R6-rip-1]undo summary
    

    在基本配置完毕后,查看路由表可以发现R6学习不到Isis区域的路由,R1只能学习到R6、R2的路由,R5只能学习到R4的路由,R2、R3、R4已经学习到了ISIS区域的路由
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    我们要进行路由泄露,将level2区域的路由引入到level1

    [R4]isis 1
    [R4-isis-1]import-route isis level-2 into level-1 
    
    [R2]isis 1
    [R2-isis-1]import-route isis level-2 into level-1 
    

    配置完毕重新查看路由表,R1和R5已经学习到了IsIS区域所有的路由信息
    在这里插入图片描述
    在这里插入图片描述
    下一步做路由重分发,将ISIS区域的路由信息引入到rip区域,rip区域的路由信息引入到ISIS区域

    [R1]isis 1
    [R1-isis-1]import-route rip 1 level-1
    [R1]rip 1
    [R1-rip-1]import-route isis 1 cost 5
    

    配置完成后查看R6与R5的路由表,R6已经学习到了ISIS区域的路由,R5已经学习到了ISIS区域R6的路由
    在这里插入图片描述
    在这里插入图片描述
    在查看这些路由表时,我们可以使用路由汇总技术,减少路由表尺寸,把一组路由汇聚为一个单个的路由广播

    [R1]isis 1
    [R1-isis-1]summary 203.0.0.0 255.255.254.0 level-1
    
    [R4]isis 1
    [R4-isis-1]summary 202.0.0.0 255.255.254.0 level-1-2
    

    汇总完成后可以看到202、203各用一个IP地址代表一组IP地址的集合
    在这里插入图片描述

    展开全文
  • BGP动态路由协议 ####BGP概述#### 1、 自治系统(AS)是由-个技术管理机构管理,使用统一选路策略- -组路由器集合, 自治系统编号范围: 1-65535,其中1-64511是互联网.上注册公有AS号,类似公网IP地址。 64512-65535是...
  • 文章目录一、动态路由及RIP协议工作原理1.1 动态路由概述1.1.2 动态路由协议1.1.3 动态路由协议分类1.2 RIP路由协议工作原理1.2.1 RIP的基本概念1.2.2 路由表的形成1.2.3 RIP的度量值与更新时间1.2.4 水平分割1.2.5 ...
  • 一、动态路由协议的基本介绍:路由协议的分类:静态路由与动态路由动态路由分类:动态路由协议tips:既然分为内部网关协议和外部网关协议?那们这个内与外相对的是什么呢?1、在因特网中,会将互联网划分为许多较小...
  • 动态路由协议概述 路由器之间用来交换信息语言 度量值 跳数,带宽,负载,时延,可靠性,成本 收敛 使所有路由表都达到一致状态过程(所有路由表都学习到路由条目) 静态路由与动态路由比较 网络中静态路由和...
  • 动态路由协议

    2020-11-03 19:22:33
    这里写目录标题动态路由协议动态路由动态路由的特点动态路由协议概述度量值收敛静态路由与动态路由的比较按照路由执行的算法分类RIP路由协议工作原理RIP的基本概念路由表的形成三级目录 动态路由协议 动态路由 基于...
  • 实验十五————动态路由协议RIP

    千次阅读 2018-05-29 15:10:22
    实验内容实验目的掌握RIP动态路由协议的基本原理和配置实验步骤构建基本网络拓扑结构IP地址信息:PC1的IP地址:192.168.1.2 网关地址:192.168.1.1PC2的IP地址:192.168.2.2 网关地址:192.168.2.1PC3的IP地址:...
  • 一、动态路由协议的基本介绍:路由协议的分类:静态路由与动态路由动态路由分类:动态路由协议tips:既然分为内部网关协议和外部网关协议?那们这个内与外相对的是什么呢?1、在因特网中,会将互联网划分为许多较小...
  • RIP 动态路由协议

    2021-03-19 11:22:55
    动态路由协议思维导图一、回顾引入1.1 路由概念1.2 路由协议分类二、距离矢量路由协议2.1 概念2.2 距离矢量路由选择协议2.2.1路由器初始启动2.2.2 初次路由信息交换2.2.3 路由收敛完成三、RIP基本原理3.1 RIP协议3.2...
  • 动态路由协议基础

    2021-04-20 16:41:28
    今天学习了动态路由协议,展示思维导图 动态路由基础 RIP基本原理 RIP工作过程 RIP防环机制 RIP版本区别 RIP配置 第一章:动态路由基础 路由行为 当网络设备收到一个IP报文时,会在自己路由表中查询报文...
  • 动态路由RIP协议一、动态路由协议基础1.1 概述1.2 度量值1.3收敛1.4动态路由分类二、RIP工作原理2.1 基本原理2.2 路由环路2.3水平分割2.4 毒性逆转三、RIP v1和RIP v2区别 一、动态路由协议基础 1.1 概述 相较于...
  • 目前应用较多的路由协议有RIP和OSPF,它们同属于内部网关协议,但RIP基于距离矢量算法,而OSPF基于链路状态最短路径优先算法。它们在网络中利用传输技术也不同。RIP是利用UDP520号端口进行传输,实现中利用套...
  • 文章目录CCNA3:RIP:路由信息协议一、动态路由协议:二、RIP:路由信息协议1、RIP协议的特点:2、V1和V2的区别:3、RIP的工作原理:4、RIP的破环机制:5、RIP如果没有破环机制会怎么样?三、RIP的配置:1、基本配置...
  • 实验三 动态路由协议配置 ** 一、实验目的 ⑴ 掌握动态协议分类、基本工作原理; ⑵ 掌握动态协议配置方法。 二、实验条件 Cisco2621 Router、PacketTrace仿真软件、具备Windows操作系统PC机 三、实验原理及相关...
  • 二 、OSPF特点OSPF是一种无类路由协议,支持VLSM可变长子网掩码。支持IPV4和IPV6.组播地址:224.0.0.5 224.0.0.6。OSPF度量:从源到目的所有出接口度量值,和接口带宽反比(10^8/带宽)。收敛速...
  • 动态路由简述: 1、动态路由是与静态路由相对一个概念,指路由器能够根据路由器之间交换特定路由信息...动态路由的运作依赖路由器两个基本功能:路由器之间适时路由信息交换,对路由表维护1、路由器...
  • 动态路由协议一、动态路由1.1 动态路由协议基础1.1.1 概述1.1.2 特点1.1.3 度量值1.1.4 收敛1.1.5 静态路由与动态路由比较1.2 动态路由协议分类1.2.1 距离矢量路由协议1.2.2 链路状态路由协议二、RIP路由协议2.1 ...
  • 理论+实验:RIP(动态路由协议

    千次阅读 2020-07-01 17:26:38
    RIP基本原理2.1 RIP路由表的形成2.2 RIP的更新与维护2.3 触发更新三、动态路由协议四、动态路由协议分类五、RIP路由协议工作原理5.1 RIP是距离-矢量路由选择协议5.2 RIP的基本概念六、水平分割七、实验7.1 实验设备...

空空如也

空空如也

1 2 3 4 5 ... 13
收藏数 253
精华内容 101
关键字:

动态路由协议的基本原理