精华内容
下载资源
问答
  • 动态路由协议

    2020-09-15 11:24:19
    什么是动态路由协议路由协议是用于路由器之间交换路由信息的协议。动态路由协议分为内部网关协议(IGP)和外部网关协议(EGP)。通过路由协议,路由器可以动态共享有关远程网络的信息,路由协议可以确定到达各个...

    什么是动态路由协议:路由协议是用于路由器之间交换路由信息的协议。动态路由协议分为内部网关协议(IGP)和外部网关协议(EGP)。通过路由协议,路由器可以动态共享有关远程网络的信息,路由协议可以确定到达各个网络的最佳路径,然后将路径添加到路由表中。动态路由协议可以自动的发现远程网络,主要的好处是:只要网络拓扑结构发生了变化,路由器就会相互交换路由信息,不仅能够自动获知新增加的网络,还可以在当前网络连接失败时找出备用路径
    动态路由协议的用途:交换路由信息,并将其选择的最佳路径添加到路由表中。路由协议的用途如下:
      1.发现远程网络
      2.维护最新路由信息
      3.选择通往目的网络的最佳路径
      4.当前路径无法使用时找出新的最佳路径
    路由协议由哪些部分组成:
      1.数据结构 - 某些路由协议使用路由表和/或数据库来完成路由过程。此类信息保 存在内存中。
      2.算法 - 算法是指用于完成某个任务的一定数量的步骤。路由协议使用算法来路由信息并确定最佳路径。
      3.路由协议消息 - 路由协议使用各种消息找出邻近的路由器,交换路由信息,并通过其它一些任务来获取和维护准确的网络信息。
      动态路由协议的运行过程如下:
      (动态路由协议的运行过程由路由协议类型及协议本身所决定)1.路由器通过其接口发送和接收路由消息。
      2.路由器与使用同一路由协议的其它路由器共享路由消息和路由信息。
      3.路由器通过交换路由信息来了解远程网络。
      4.如果路由器检测到网络拓扑结构的变化,路由协议可以将这一变化告知其它路由器

    展开全文
  • 动态路由协议Dynamic routing protocols have been divided into 2 categories i.e Distance vector protocols and Link state protocols. Both of these protocols are being explained in detail in this tutorial...

    动态路由协议

    Dynamic routing protocols have been divided into 2 categories i.e Distance vector protocols and Link state protocols. Both of these protocols are being explained in detail in this tutorial.

    动态路由协议分为距离矢量协议链路状态协议两大类 。 本教程将详细说明这两种协议。

    1)距离矢量路由协议 (1) Distance Vector Routing Protocols)

    RIP and IGRP are the distance vector routing protocols. All the distance vector routing protocols have some features which are being given below.

    RIP和IGRP是距离矢量路由协议。 所有距离矢量路由协议都具有以下功能。

    • The periodic updates of the entire routing table are sent to all neighboring routers.

      整个路由表的定期更新将发送到所有相邻路由器。

    • Convergence is very slow in distance vector protocols and these are susceptible to protocols loops.

      距离矢量协议的收敛非常慢,并且容易受到协议循环的影响。

    • The distance is used to calculate the metric of the routing.

      距离用于计算路由度量。

    • Bellman-Ford algorithm is used to find the shortest path.

      Bellman-Ford算法用于查找最短路径。

    Distance vector routing protocols send updates about all connected neighbors directly connected networks. This update is sent regularly. It is sent to RIP every 30 seconds and in IGRP, this update is sent every 90 seconds. With these updates, neighbors can add routes to their routing tables. After this, all the neighbors forward their entire routing table, sharing it with all the neighbors.

    距离矢量路由协议发送有关所有已连接邻居的直连网络的更新。 此更新会定期发送。 它每30秒发送到RIP,在IGRP中,此更新每90秒发送一次。 通过这些更新,邻居可以将路由添加到其路由表中。 此后,所有邻居都转发其整个路由表,并与所有邻居共享。

    There are many disadvantages to this kind of process. Routing information goes from one neighbor to pass periodic updates of another, so convergence is very slow. Together, all the neighbors depend on each other, so the chances of looping are also very high.

    这种过程有很多缺点。 路由信息从一个邻居传到另一个邻居的定期更新,因此收敛非常慢。 在一起,所有邻居都相互依赖,因此循环的机会也很高。

    Distance vector protocols use distance to calculate metric. RIP is calculated by metric hop counts. In IGRP the metric is calculated with bandwidth and delay.

    距离矢量协议使用距离来计算度量。 RIP通过跃点计数来计算。 在IGRP中,度量标准是根据带宽和延迟来计算的。

    2)链路状态路由协议 (2) Link State Routing Protocols)

    Link state protocols were developed to overcome looping and convergence problems in the distance vector protocols. Link state routing protocols build 3 kinds of routing tables. These are being given below.

    开发了链路状态协议以克服距离矢量协议中的循环和收敛问题。 链路状态路由协议建立3种路由表。 这些在下面给出。

    1. Neighbor table

      邻居表

      This table contains a list of all the neighbors, and also, which of the neighbors is connected to which interface. Neighbor table is created by sending hello packets.

      该表包含所有邻居的列表,以及哪个邻居连接到哪个接口。 邻居表是通过发送hello数据包创建的。

    2. Topology table

      拓扑表

      This is also called link state table. In this, all links of one area are stored in the map. Also, every link's status is also stored.

      这也称为链接状态表。 这样,一个区域的所有链接都存储在地图中。 同样,每个链接的状态也会被存储。

    3. Shortest path table

      最短路径表

      The best routes are stored for every destination in this table. The link states sending updates about the status of routers directly connected networks in routing protocols. All routers store this information in the topology table. The number of routers within an area is their topology table.

      最佳路线存储在此表中的每个目的地。 链接状态发送有关路由协议中与路由器直接连接的网络的状态有关的更新。 所有路由器都将此信息存储在拓扑表中。 一个区域内的路由器数量是其拓扑表。

    If any change occurs in a link, only related updates to this link are sent to all routers and all routers adjust their topology table accordingly. The only link that has changed has been updated, due to this, the bandwidth also does not have much effect. But due to the management of 3 tables, the CPU is highly utilized. The shortest path is calculated by the Dijkstra formula in the link state protocols.

    如果链接发生任何更改,则仅对此链接的相关更新会发送到所有路由器,并且所有路由器都会相应地调整其拓扑表。 唯一已更改的链接已更新,因此,带宽也没有太大影响。 但是由于管理3个表,因此CPU利用率很高。 最短路径由链路状态协议中的Dijkstra公式计算得出。

    翻译自: https://www.includehelp.com/computer-networks/categories-of-dynamic-routing-protocols.aspx

    动态路由协议

    展开全文
  • 动态路由协议之RIP协议一、动态路由1.1动态路由概述1.1.1动态路由1.1.2动态路由特点1.1.3动态路由的工作流程1.2动态路由协议1.2.1动态路由协议概述1.2.2度量值1.2.3收敛1.2.4动态路由协议分类二、RIP(距离——矢量...

    一、动态路由

    1.1动态路由概述

    1.1.1动态路由

    基于某种路由协议实现

    1.1.2动态路由特点

    (1)优点:减少了管理任务
    (2)缺点:占用了网络带宽

    1.1.3动态路由的工作流程

    是指路由器能够学习路由信息,形成自己的路由表,并且能够根据实际情况的变化适时地进行调整。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    1.2动态路由协议

    1.2.1动态路由协议概述

    路由器之间用来交换信息的语言

    1.2.2度量值

    路由器会通过度量值来确定最佳路由路径,包括跳数、宽带、负载、时延、可靠性、成本

    1.2.3收敛

    使所有路由表都达到一直状态的过程

    1.2.4动态路由协议分类

    按照路由执行的算法分类。
    距离矢量路由协议:依据从源网络到目标网络所经过的路由器的个数选择路由(RIP,IGRP)
    链路状态路由协议:综合考虑从源网络到目标网络的各条路径的情况选择路由(OSPF,IS-IS)

    二、RIP(距离——矢量路由选择协议)

    2.1RIP的基本概念

    →定期更新
    →邻居
    →广播更新
    →全路由表更新

    2.2路由表的形成

    ①路由器学习到直连路由在这里插入图片描述
    ②更新周期30s到时,路由器会向邻居发送路由表
    在这里插入图片描述③再过30s,第二个更新周期到了再次发送路由表
    在这里插入图片描述

    2.3 RIP 的度量值、更新时间

    1、RIP度量值为跳数,最大条数为15跳,16跳为不可达
    2、RIP更新时间:每隔30s发送路由更新消息,UDP520端口
    3、RIP路由更新消息是发送整个路由表的信息

    2.4路由环路

    2.4.1环路的形成

    当40网段被堵塞后,R3正常情况下会发送出这个消息,但是因为存在30s的更新时间,所以如果在R3的更新周期到来之前,R2先发送,那么就会将R3的这条宣告覆盖,R3会认为40网段正常,把40网段正常工作的数据传回R2,R2再回传给如R3,以此循环形成环路。在这里插入图片描述

    2.4.2水平分割和毒性逆转

    水平分割和毒性逆转主要是针对动态路由协议RIP中,避免路由环路,提高收敛速度产生的。
    1、水平分割:
    在路由信息传送过程中,路由器从某个接口接收到的更新信息不允许再从这个接口发回去。同时也能减少路由更新信息占用的链路带宽资源。
    2、毒性逆转:
    路由器从某个接口上接收到某个网段的路由信息之后,并不是不往回发送信息了,而是发送,只不过是将这个网段标志为不可达,再发送出去。收到此种的路由信息后,接收方路由器会立刻抛弃该路由,而不是等待其老化时间到。这样可以加速路由的收敛。

    2.5RIPv1与RIPv2的区别

    在这里插入图片描述

    三、RIP的基本配置命令

    [R1]rip 1 ###启动RIP
    [R1-rip-1]version 2 ##启动版本2 (缺省为版本1)
    [R1-rip-1]undo summary ##关闭路由自动聚合(即所有路由信息都会按照IP地址分类归类)
    [R1-rip-1]network 192.168.10.0 ##宣告主网络号, v2会携带掩码组播更新224.0.0.9, v1不携带掩码广播更新255.255.255.255
    [R1-rip-1]network 200.1.1.0
    ----兼容模式--------
    [R1] int go/0/1
    [R1-GigabitEthernet0/0/1]rip version 2 multicast ##把设置成rip1路由器的某一接口单独设置成rip版本2

    展开全文
  • 文章目录CCNA3:RIP:路由信息协议一、动态路由协议:二、RIP:路由信息协议1、RIP协议的特点:2、V1和V2的区别:3、RIP的工作原理:4、RIP的破环机制:5、RIP如果没有破环机制会怎么样?三、RIP的配置:1、基本配置...

    CCNA3:动态路由协议、RIP——路由信息协议

    一、动态路由协议:

    动态路由协议:各台路由器上运行相同的协议,这些协议会让设备间进行沟通,学习来获取未知的路由条目信息。最终实现全网可达(所谓的动态路由协议本质上就是一种算法)。

    1、动态路由协议的优点:
    (1)配置管理方便:路由器之间会通过算法自动学习未知网段的路由。
    (2)针对拓扑变化自动重新收敛:如果新增网段或断开网段,拓扑会重新收敛计算新路径,比静态更灵活。
    (3)适用于较大型或复杂的网路环境

    2、 动态路由协议的缺陷
    (1)安全:容易被终端伪装的路由器欺骗,造成数据的不安全通信。
    (2)选路不佳:由于是固定的算法,可能在大型网络中造成数据的不同步,导致算路由算错,严重时导致出环。
    (3)对硬件资源的占用:无论是带宽、CPU、内存都是硬件资源,为了保持协议之间的正常通信,它会占用这些资源。严重时,可能占完整个带宽资源,例如OSPF。以至于用户连上网的带宽都没有。

    3、动态路由协议的追求:
    (1)占用资源少
    (2)选择路径佳
    (3)收敛速度快:全网信息同一时间全网同步,降低出环的概率。

    4、动态路由协议的分类
    (1)基于AS(自治系统)——EGP外部网关路由协议,IGP内部网关路由协议。AS号:0~65535,其中1 ~ 64512为公有AS号,64512 ~ 65535为私有AS号。
    EGP负责AS之间的沟通,IGP负责一个AS内部的沟通。

    EGP协议:EGPv1、EGPv2、BGPv1~v4 、BGPv4+
    IGP协议:RIP、OSPF、EIGRP、ISIS

    如果全球只运行一个动态协议来工作合适吗?
    不合适,首先工作半径太大,且非常复杂,导致收敛速度慢(这样就很容易出环),占用资源也很多。为了解决这一问题,提出了将全球的网络范围切割成多个AS区域,让区域内部进行管理。

    (2)IGP的分类:
    ①基于更新时是否携带子网掩码:
    有类别:不携带掩码、A类、B类、C类等。
    无类别:携带掩码,不管A、B、C的主类网,我的掩码是多少就是多少。

    ②基于工作特点:
    DV距离矢量型:RIP、EIGRP
    距离矢量:邻居之间共享路由表,通过看对方的路由表判断对方能到哪里,最后再将路由写入自己的路由表中。

    LS链路状态:OSPF、ISIS
    链路状态:路由器自己先画一个拓扑,标明自己连接的邻居,自己的各个接口是怎样的,IP是多少,带宽又怎样。然后这台路由器将这个拓扑给它的邻居,这台路由器除了会收集邻居的拓扑外,还会收集其他路由器的拓扑。最后该路由器就拥有了整个网络的拓扑,最后在算出一条最合适的路由加入自己的路由表中。

    二、RIP:路由信息协议

    RIP:路由信息协议,存在v1、v2、NG三个版本,NG用于IPv6。它是标准的距离是矢量路由协议, 邻居(在同一个AS内,运行着相同协议的直连路由器) 间直接共享路由表。默认仅存在更新包。

    1、RIP协议的特点:

    (1)基于 UDP520 端口工作
    (2)支持等开销负载均衡(两条路一模一样),默认支持4条,最大6条,如果IOS版本为12.4以上可以支持16条。
    (3)使用跳数作为度量,管理距离为120。【管理距离/跳数】
    (4)使用周期和触发更新
    触发更新:用于结构突变时,进行及时的重新收敛,告诉全部路由器有一个网段发生了变化。
    周期更新:用于保活、保证数据收到,但是占用带宽。

    2、V1和V2的区别:

    RIPv1RIPv2
    V1有类别协议V2无类别协议:支持VLSM可变长子网掩码,支持CIDR无类域间路由,不支持超网。
    超网:汇总后掩码长度<主类网长度
    V1使用广播更新,更新地址255.255.255.255V2使用组播更新224.0.0.9
    V1不支持手工认证V2支持手工认证(邻居间身份核实)

    3、RIP的工作原理:

    在这里插入图片描述
    图中总共有五个网段,1、3、5是环回,2、4是它们之间的直连路由。R1和R2都有2网段,因此R1需要把自己的 1.1.1.0/24网段告诉R2,数据包就像图中那样,包中的信息包含1.1.1.0/24网段,数据包包含传输协议,源目端口,源IP、源MAC,组播更新地址等。

    R2在收到R1的包后,就知道了这个包是从自己的S0/0口进来的,R1发送的地址是12.1.1.1/24,信息中包含了到1.1.1.0/24的度量值为1跳。就会产生一个
    R  1.1.1.0/24  [120/1]  S0/0  12.1.1.1的路由表

    这个包再由R2转发给R3时,源IP被修改为23.1.1.1/24,跳数也被修改为第2跳了。最后R3学到1.1.1.0/24的路由。同理,所有的路由都可以按照这样的方式倒出全部的路由。当R1、R2、R3上都有5条路由时,即它们获得了整个拓扑的路由,也就意味着它们收敛完成。

    4、RIP的破环机制:

    (1)毒性逆转水平分割:
    触发更新:当有路由器断开了某个网段时,该路由器会发送更新包,更新包中包含断开的网段和16跳的跳数,来告诉其它路由器此网段已不可达。收到的路由器作为回应需要将这条更新包再发送给发给自己的路由器,来作为确认自己收到了。这才是破环机制的核心机制。
    (2)跳数限制——15跳
    (3)水平分割——从此口进,不从此口出。不能完全解决问题,因为这个仅适用于防止直线、星形拓扑。
    水平分割的核心作用:
    ①消除重复更新量
    ②在MA网络中消除重复更新量(MA:多路访问网络,在一个网段中,可连接的节点数量不限制)
    (4)抑制计时器——平常不工作,但是遇到跳数无征兆增大,表示网络已经出环,此时抑制180s后重新收敛寻找新网段。

    5、RIP如果没有破环机制会怎么样?

    首先我们要知道RIP的周期更新时间为30S,且每台路由器并不是同时更新的,它们错开了更新时间。
    在这里插入图片描述
    按照上图:如果R3突然断掉了3.3.3.0/24网段,在它自己的30s倒计时为0时,它将这条消息发给了R2,此时R2距离刚更新过了13s。然后过了7秒钟,R1发包告诉R2它可以到3.3.3.0/24网段,度量值为3跳,这时距离R2更新的时间还剩10s。

    此时R2会认为自己去3.3.3.0/24网段下一跳是12.1.1.1,但是它不知道R1去往3.3.3.0/24网段的下一跳也是它自己。这就导致出环了,这还没完,R2更新后,它会显示自己有去往3.3.3.0/24的路由告诉R3,最后这个图都陷入到了出环中。

    出环的原因就是我收到的信息就是我刚刚删除的,甚至是我刚刚共享给你的。

    如果有触发更新(毒性逆转水平分割),就可以即时的知道某网段已经不可达了,即时的进行更新了。

    三、RIP的配置:

    1、基本配置:

    (1)RIPv1:

    R1(config)#router rip
    R1(config-router)#version 1
    R1(config-router)#network 1.0.0.0
    R1(config-router)#network 12.0.0.0
    

    1#启动RIP协议
    2#选择RIP版本为1,若不进行版本选举,默认为升级版本1(注意不是普通版本)
    3#宣告的意义:
    1、激活接口——使接口具有接收和发送路由信息的能力
    2、路由或拓扑——不宣告某个接口,会导致该接口的信息无法传输给其他路由器

    RIP在宣告时,只能定义主类的范围
    (2)RIPv2:

    r1(config)#router rip
    r1(config-router)#version 2	
    r1(config-router)#no auto-summary	
    r1(config-router)#network 172.16.0.0
    r1(config-router)#network 192.168.1.0
    

    #3关闭自动汇总——关闭后会携带精确掩码,不关闭会携带主类掩码

    2、扩展配置:

    (1)RIPV2的认证——运行于RIP协议的邻居间,进行身份的核实。 认证≠加密
    先定制keychain,再进入和邻居相连的接口上调用

    R1(config)#key chain xxx             		钥匙库的名字为xxx,邻居可以不同
    R1(config-keychain)#key 1            	key 11把钥匙,邻居必须相同
    R1(config-keychain-key)#key-string cisco123    	钥匙为cisco123,邻居必须相同
    R1(config)#interface f0/0              进入和邻居相连的接口上调用
    R1(config-if)#ip rip authentication key-chain xxx   		明文认证双方需一致
    R1(config-if)#ip rip authentication mode md5    	密文认证双方需一致
    

    (2)RIPV2的手工汇总——在更新源路由器上所有更新发出的接口上配置

    R1(config)#interface f0/0
    R1(config-if)#ip summary-address rip 2.2.2.0 255.255.254.0
    

    (3)被动接口——仅接受不发送路由协议信息,只能用于连接用户的接口,不得用于连接邻居的接口

    R1(config)#router rip
    R1(config-router)#passive-interface lo0
    

    (4)缺省路由——在边界路由器上配置RIP缺省后,内部的路由器将自动生成缺省路由指向边界路由器,边界路由器到达ISP的缺省路由,宣告手工静态配置

    R1(config)#router rip
    R1(config-router)#default-information originate
    

    (5)加快收敛
    RIP计时器   30s更新   180s失效   180s抑制   240s刷新(非cisco300s刷新)

    180s失效 :一次没收到更新并不能判断路由就没有了,有可能会因为网络卡了,所以给了6次机会。一旦6次机会都用完了,那么就判定这条路由失效了。紧接着会发再一条带毒的路由给其他邻居,告知其他邻居该路径已不可达。

    180s抑制 :平常不工作,正常情况下假设R1到达R2,跳数为1跳。但是跳数突然无征兆的变大,表示网络已经出环,此时抑制180s后重新收敛寻找新网段。

    240s刷新 :也就是会删除没有的路由条目

    适当的修改计时器,可以加快设备的收敛速度,建议修改时维持原有的倍数关系,且不易修改的过小,否则会占用带宽资源,全网所有设备均需要修改。

    R1(config)#router rip
    R1(config-router)#timers basic 15 90 90 120
    
    展开全文
  • 1 OSPF工作过程:(1) 宣告OSPF的路由器从所有OSPF协议的接口上发出HELLO包.(2) 邻接关系,可以想象成一条点到点的虚链路,它是在一些邻居路由器之间构成的.(3) 每台路由器都会在所有形成邻接关系之间的邻居之间发送链路...
  • RIP 动态路由协议

    2021-03-19 11:22:55
    动态路由协议思维导图一、回顾引入1.1 路由概念1.2 路由协议分类二、距离矢量路由协议2.1 概念2.2 距离矢量路由选择协议2.2.1路由器初始启动2.2.2 初次路由信息交换2.2.3 路由收敛完成三、RIP基本原理3.1 RIP协议3.2...
  • 动态路由OSPF路由协议

    2020-11-09 14:13:56
    动态路由——OSPF协议一、相关概念1.1自治系统(AS)1.2外部网关协议(EGP)1.3内部网关协议(IGP)二、OSPF工作过程2.1:建立邻居列表2.2:链路状态数据库2.3:生成路由表三、OSPF基本概念3.1OSPF区域3.2区域ID3.3...
  • RIP动态路由协议

    千次阅读 2017-10-10 13:26:35
    动态路由协议简介 路由协议是路由器之间交互信息的一种语言。 路由协议共享网络状态和网络可达性的一些信息。 路由协议定义了一套路由器之间通信时使用的规则。 路由协议维护路由表、提供最佳转发路径。 常用的动态...
  • 动态路由协议中的路由信息协议(RIP)以及开放式最短路径优先(OSPF) 文章目录动态路由协议中的路由信息协议(RIP)以及开放式最短路径优先(OSPF)一、动态路由1.动态路由的定义2.动态路由的特点3.动态路由协议...
  • 常见的动态路由协议可以分为“距离矢量路由协议”和“链路状态路由协议”。 其中距离矢量路由协议依据的是从源网络到目标网络所经过的路由器的个数来选择路由,典型的协议是“RIP”; 链路状态路由协议会综合考虑从...
  • 本章目录概述一、OSPF的报文类型二、ospf工作原理 概述 本章主要介绍OSPF的五种报文类型和建立邻居关系的过程,没有详细介绍关于ospf里的一些基础内容。 一、OSPF的报文类型 Hello报文是用来打招呼用的,用来发现、...
  • 一、动态路由RIP产生背景1、动态路由协议包括距离向量路由协议和链路状态路由协议。RIP(Routing InformationProtocols,路由信息协议)是使用最广泛的距离向量路由协议。RIP 是为小型网络环境设计的,因为这类协议的...
  • 动态路由协议之OSPF协议基础一、OSPF协议基本概念1.1动态协议的分类1.2OSPF协议的工作流程1.3OSPF区域1.3.1OSPF区域划分1.3.2OSPF区域ID1.4Router ID1.4.1Router ID1.4.2 一、OSPF协议基本概念 1.1动态协议的分类 ...
  • OSPF动态路由协议

    2021-05-08 18:48:44
    OSPF动态路由协议 OSPF的作用: 在公司内部的多个路由器之间,动态/自动的学习路由条目信息。 最终是为了: 以最快的速度,计算出一个,去往目标网络,最好的,无环的路由。 OSPF的概述: -OSPF主要是应用在企业内部...
  • OSPF动态路由协议基本工作原理

    千次阅读 2011-04-21 10:26:00
    随着Internet技术在全球范围内的飞速发展,IP网络作为一种最有前景的网络技术...本文在分析OSPF动态路由协议基本工作原理的基础上,提出了Dijkstra算法和OSPF路由表计算的实现方法。 <br /> 目前应用较多的
  • 动态路由协议及分类

    2020-07-29 08:48:02
    .3动态路由协议及分类 前面已经为大家介绍了路由器对于直连路由的发现过程,以及静态路由的概念和部 署要点。对于一个小型网络,静态路由或许已经能够满足需求,但是在大中型网络中, 由于网段数量特别多、网络拓扑...
  • 文章目录1、动态路由2、RIP路由协议工作原理3、VPN(Virtual Private Network)路由器工作原理: 1、动态路由 基于某种动态路由协议实现 特点:减少了管理任务、占用了网络带宽 不需要手工配置路由表,路由器之间...
  • 路由技术—动态路由协议OSPF协议概述内部网关协议和外部网关协议工作过程(3张表)邻居状态机OSPF区域路由器类型Router IDrouter id的定义router id 选取规则DR/BDR选举的方法ospf建立邻居的条件ospf的组播地址ospf...
  • 动态路由协议简单理解

    千次阅读 2020-06-19 17:41:04
    一、什么是路由?       在一个网络中,路由是一个非常基本的概念,当路由器(或者其他三层设备)收到一个IP数据包,路由器会...二、路由协议的分类      &nb
  • 动态路由协议(OPSF)

    2021-10-25 09:37:06
    一.OSPF基本概念/工作过程 1)OSPF路由协议概述 OSPF:开放的最短路径优先协议 内部网关协议和外部网关协议 自治系统(AS) 内部网关协议(IGP) 外部网关协议(EGP) AS:由同一个技术管理机构管理,使用...
  • 动态路由协议RIP

    2019-12-29 12:28:54
    RIP(Routing Information Protocol,路由信息协议)是最典型的距离矢量路由协议,常被用于在小型的网络中交互路由信息,它是最先得到广泛使用的IGP协议。 RIP目前有三个版本,分别是面向IPv4的RIPv1和RIPv2,以及...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 149,525
精华内容 59,810
关键字:

动态路由协议的工作过程包括