精华内容
下载资源
问答
  • 动态路由协议的种类

    2013-08-22 01:11:30
    动态路由协议的种类:(1)RIP路由协议RIP协议最初是为Xerox网络系统的Xerox parc通用协议而设计的,是Internet中常用的路由协议。RIP采用距离向量算法,即路由器根据距离选择路由,所以也称为距离向量协议。路由器...

    动态路由协议的种类:

    1RIP路由协议

    RIP协议最初是为Xerox网络系统的Xerox parc通用协议而设计的,是Internet中常用的路由协议。RIP采用距离向量算法,即路由器根据距离选择路由,所以也称为距离向量协议。路由器收集所有可到达目的地的不同路径,并且保存有关到达每个目的地的最少站点数的路径信息,除到达目的地的最佳路径外,任何其它信息均予以丢弃。同时路由器也把所收集的路由信息用RIP协议通知相邻的其它路由器。这样,正确的路由信息逐渐扩散到了全网。

       RIP使用非常广泛,它简单、可靠,便于配置。但是RIP只适用于小型的同构网络,因为它允许的最大站点数为15,任何超过15个站点的目的地均被标记为不可达。而且RIP每隔30s一次的路由信息广播也是造成网络的广播风暴的重要原因之一。

    2OSPF路由协议

       0SPF是一种基于链路状态的路由协议,需要每个路由器向其同一管理域的所有其它路由器发送链路状态广播信息。在OSPF的链路状态广播中包括所有接口信息、所有的量度和其它一些变量。利用0SPF的路由器首先必须收集有关的链路状态信息,并根据一定的算法计算出到每个节点的最短路径。而基于距离向量的路由协议仅向其邻接路由器发送有关路由更新信息。

      与RIP不同,OSPF将一个自治域再划分为区,相应地即有两种类型的路由选择方式:当源和目的地在同一区时,采用区内路由选择;当源和目的地在不同区时,则采用区间路由选择。这就大大减少了网络开销,并增加了网络的稳定性。当一个区内的路由器出了故障时并不影响自治域内其它区路由器的正常工作,这也给网络的管理、维护带来方便。

    3BGPBGP4路由协议

       BGP是为TCPIP互联网设计的外部网关协议,用于多个自治域之间。它既不是基于纯粹的链路状态算法,也不是基于纯粹的距离向量算法。它的主要功能是与其它自治域的BGP交换网络可达信息。各个自治域可以运行不同的内部网关协议。BGP更新信息包括网络号/自治域路径的成对信息。自治域路径包括到达某个特定网络须经过的自治域串,这些更新信息通过TCP传送出去,以保证传输的可靠性。

    为了满足Internet日益扩大的需要,BGP还在不断地发展。在最新的BGP4中,还可以将相似路由合并为一条路由。

    4IGRPEIGRP协议

       EIGRP和早期的IGRP协议都是由Cisco发明,是基于距离向量算法的动态路由协议。EIGRP(Enhanced Interior Gateway Routing Protocol)是增强版的IGRP协议。它属于动态内部网关路由协议,仍然使用矢量-距离算法。但它的实现比IGRP已经有很大改进,其收敛特性和操作效率比IGRP有显著的提高。

    它的收敛特性是基于DUAL ( Distributed Update Algorithm ) 算法的。DUAL 算法使得路径在路由计算中根本不可能形成环路。它的收敛时间可以与已存在的其他任何路由协议相匹敌。

       Enhanced IGRP 与其它路由选择协议之间主要区别包括:收敛宽速(Fast Convergence)、支持变长子网掩模(Subnet Mask)、局部更新和多网络层协议。执行 Enhanced IGRP 的路由器存储了所有其相邻路由表,以便于它能快速利用各种选择路径(Alternate Routes)。如果没有合适路径,Enhanced IGRP 查询其邻居以获取所需路径。直到找到合适路径,Enhanced IGRP 查询才会终止,否则一直持续下去。

       EIGRP 协议对所有的 EIGRP 路由进行任意掩码长度的路由聚合,从而减少路由信息传输,节省带宽。另外 EIGRP 协议可以通过配置,在任意接口的位边界路由器上支持路由聚合。

       EIGRP 不作周期性更新。取而代之,当路径度量标准改变时,Enhanced IGRP 只发送局部更新(Partial Updates)信息。局部更新信息的传输自动受到限制,从而使得只有那些需要信息的路由器才会更新。基于以上这两种性能,因此 Enhanced IGRP 损耗的带宽比 IGRP 少得多。

    使用增强的内部网关路由选择协议,一个路由器保持一份它的邻近路由器的路由表副本。如果它不能从这些表中找到一条到达目的地的路由,它向它的邻近路由器询问一个路由并且它们轮流询问它们的邻近的路由器直到找到一个路由。为了保持所有的路由器注意邻近路由器的状态,每个路由器定时发出握手信息包。一个在一定时间间隔内没有收到握手信息包的路由器被认为是无效的。

    静态路由是指路由表由网络管理人员手动设定的一种路由方式。静态路由的好处是网络寻址快捷,适用于网络变动不大的网络系统。

    动态路由是指路由表不是由网络管理人员手动设定,而是由路由器通过端口进行地址学习自动生成路由表的方式。动态路由的好处是对网络变化的适应性强,适用于网络环境变化大的网络系统。

    在一个路由器中,可同时配置静态路由和一种或多种动态路由。它们各自维护的路由表都提供给转发程序,但这些路由表的表项间可能会发生冲突。这种冲突可通过配置各路由表的优先级来解决。通常静态路由具有默认的最高优先级,当其它路由表表项与它矛盾时,均按静态路由转发。


    转载于:https://blog.51cto.com/615861010/1280252

    展开全文
  • 动态路由协议的种类: (1)RIP路由协议  RIP协议最初是为Xerox网络系统的Xeroxparc通用协议而设计的,是Internet中常用的路由协议。RIP采用距离向量算法,即路由器根据距离选择路由,所以也称为距离向量协议。...
     动态路由协议的种类:
    (1)RIP路由协议 
      RIP协议最初是为Xerox网络系统的Xerox parc通用协议而设计的,是Internet中常用的路由协议。RIP采用距离向量算法,即路由器根据距离选择路由,所以也称为距离向量协议。路由器收集所有可到达目的地的不同路径,并且保存有关到达每个目的地的最少站点数的路径信息,除到达目的地的最佳路径外,任何其它信息均予以丢弃。同时路由器也把所收集的路由信息用RIP协议通知相邻的其它路由器。这样,正确的路由信息逐渐扩散到了全网。 
          RIP使用非常广泛,它简单、可靠,便于配置。但是RIP只适用于小型的同构网络,因为它允许的最大站点数为15,任何超过15个站点的目的地均被标记为不可达。而且RIP每隔30s一次的路由信息广播也是造成网络的广播风暴的重要原因之一。 
    (2)OSPF路由协议
            0SPF是一种基于链路状态的路由协议,需要每个路由器向其同一管理域的所有其它路由器发送链路状态广播信息。在OSPF的链路状态广播中包括所有接口信息、所有的量度和其它一些变量。利用0SPF的路由器首先必须收集有关的链路状态信息,并根据一定的算法计算出到每个节点的最短路径。而基于距离向量的路由协议仅向其邻接路由器发送有关路由更新信息。 
      与RIP不同,OSPF将一个自治域再划分为区,相应地即有两种类型的路由选择方式:当源和目的地在同一区时,采用区内路由选择;当源和目的地在不同区时,则采用区间路由选择。这就大大减少了网络开销,并增加了网络的稳定性。当一个区内的路由器出了故障时并不影响自治域内其它区路由器的正常工作,这也给网络的管理、维护带来方便。 
    (3)BGP和BGP4路由协议
           BGP是为TCP/IP互联网设计的外部网关协议,用于多个自治域之间。它既不是基于纯粹的链路状态算法,也不是基于纯粹的距离向量算法。它的主要功能是与其它自治域的BGP交换网络可达信息。各个自治域可以运行不同的内部网关协议。BGP更新信息包括网络号/自治域路径的成对信息。自治域路径包括到达某个特定网络须经过的自治域串,这些更新信息通过TCP传送出去,以保证传输的可靠性。 
          为了满足Internet日益扩大的需要,BGP还在不断地发展。在最新的BGP4中,还可以将相似路由合并为一条路由。 
    (4)IGRP和EIGRP协议
    EIGRP和早期的IGRP协议都是由Cisco发明,是基于距离向量算法的动态路由协议。EIGRP(Enhanced Interior Gateway Routing Protocol)是增强版的IGRP协议。它属于动态内部网关路由协议,仍然使用矢量-距离算法。但它的实现比IGRP已经有很大改进,其收敛特性和操作效率比IGRP有显著的提高。
    它的收敛特性是基于DUAL ( Distributed Update Algorithm ) 算法的。DUAL 算法使得路径在路由计算中根本不可能形成环路。它的收敛时间可以与已存在的其他任何路由协议相匹敌。
    Enhanced IGRP 与其它路由选择协议之间主要区别包括:收敛宽速(Fast Convergence)、支持变长子网掩模(Subnet Mask)、局部更新和多网络层协议。执行 Enhanced IGRP 的路由器存储了所有其相邻路由表,以便于它能快速利用各种选择路径(Alternate Routes)。如果没有合适路径,Enhanced IGRP 查询其邻居以获取所需路径。直到找到合适路径,Enhanced IGRP 查询才会终止,否则一直持续下去。
    EIGRP 协议对所有的 EIGRP 路由进行任意掩码长度的路由聚合,从而减少路由信息传输,节省带宽。另外 EIGRP 协议可以通过配置,在任意接口的位边界路由器上支持路由聚合。 
    EIGRP 不作周期性更新。取而代之,当路径度量标准改变时,Enhanced IGRP 只发送局部更新(Partial Updates)信息。局部更新信息的传输自动受到限制,从而使得只有那些需要信息的路由器才会更新。基于以上这两种性能,因此 Enhanced IGRP 损耗的带宽比 IGRP 少得多。
    使用增强的内部网关路由选择协议,一个路由器保持一份它的邻近路由器的路由表副本。如果它不能从这些表中找到一条到达目的地的路由,它向它的邻近路由器询问一个路由并且它们轮流询问它们的邻近的路由器直到找到一个路由。为了保持所有的路由器注意邻近路由器的状态,每个路由器定时发出“握手”信息包。一个在一定时间间隔内没有收到“握手”信息包的路由器被认为是无效的。 
     
     
          静态路由是指路由表由网络管理人员手动设定的一种路由方式。静态路由的好处是网络寻址快捷,适用于网络变动不大的网络系统。 
          动态路由是指路由表不是由网络管理人员手动设定,而是由路由器通过端口进行地址学习自动生成路由表的方式。动态路由的好处是对网络变化的适应性强,适用于网络环境变化大的网络系统。
         在一个路由器中,可同时配置静态路由和一种或多种动态路由。它们各自维护的路由表都提供给转发程序,但这些路由表的表项间可能会发生冲突。这种冲突可通过配置各路由表的优先级来解决。通常静态路由具有默认的最高优先级,当其它路由表表项与它矛盾时,均按静态路由转发。

    转载于:https://blog.51cto.com/nics122/159881

    展开全文
  • 一、什么是路由?       在一个网络中,路由是一...随着网络路由的发展,路由的种类有很多,如静态路由、动态路由、缺省路由等。 二、路由协议的分类      &nb

    一、什么是路由?

          在一个网络中,路由是一个非常基本的概念,当路由器(或者其他三层设备)收到一个IP数据包,路由器会找出报文中的IP头里的目的IP地址,然后拿着目的IP地址到自己的路由表中进行查找,找到“最匹配”的路由条目后,将数据包根据路由条目所指示的出接口或下一跳IP转发出去。随着网络路由的发展,路由的种类有很多,如静态路由、动态路由、缺省路由等。

    二、路由协议的分类

          动态路由是指路由器能够根据路由器之间的交换的特定路由信息自动地建立自己的路由表,并且能够根据链路和节点的变化适时地进行自动调整。而路由协议是用于路由器之间交换路由信息的协议,路由协议的分类大致如下图所示:
    在这里插入图片描述

    图1 路由协议的分类

    (1) 按用途分类
          动态路由协议按用途分类可以分为内部网关协议(Interior Gateway Protocol,简称IGP)和外部网关协议(Exterior Gateway Protocol,简称EGP)。一个Internet网可以被分成多个域或多个自治系统,各自治系统通过一个核心路由器连到主干网上,每个自治系统都有自己的路由技术,对不同的自治系统路由技术是不相同的。所谓内部网关协议,就是指用于自治系统内部的路由协议,而外部网关协议,就是指用于自治系统间接口上的单独的协议。

    (2) 按操作分类
          动态路由协议按操作分类可以分为距离矢量路由协议、链路状态路由协议或路径矢量路由协议。其中距离矢量路由协议和链路状态路由协议属于内部网关协议,而路径矢量路由协议则属于外部网关协议。

    (3) 按行为分类
          动态路由协议按行为分类可以分为有类路由协议和无类路由协议,他们二者本质区别就是在发送路由更新时是否发送子网掩码,有类路由协议不会在路由更新中发送子网掩码信息,而无类路由协议在路由更新中包含子网掩码信息。目前,仅RIPv1和IGRP是有类路由协议,所有其他IPv4和IPv6路由协议都是无类路由协议。

    三、路由协议的使用

          在学习的过程中,面对众多的动态路由协议,我开始思考,这么多的路由协议在不同的网络中应该如何选择呢?为了解决这个疑问,就需要对这些动态路由协议的特性和优缺点进行比较,并根据实际情况选择出一个最佳方案。

    (1) IGP和EGP
          首先,是内部网关协议和外部网关协议,对于这两个协议,根据它们各自的用途,很容易做出判断:在公司、组织、服务提供商各自的内部网络中使用IGP,而在服务提供商、公司和大型企业之间则使用EGP实现互联。目前,边界网关协议(BGP)是目前唯一可行的EGP,而对于IGP就有很多的选择如RIP、EIGRP、OSPF和IS-IS等。

    (2) 距离矢量路由协议和链路状态路由协议
          根据路由算法,动态路由协议可分为距离向量路由协议和链路状态路由协议。距离矢量路由协议基于Bellman-Ford算法,主要有RIP、IGRP;链路状态路由协议基于Dijkstra算法,即最短优先路径算法,如OSPF。在距离向量路由协议中,路由器将部分或全部的路由表传递给与其相邻的路由器;而在链路状态路由协议中,路由器将链路状态信息传递给在同一区域内的所有路由器。
    距离矢量路由协议通过向其邻居发送自己的路由表的方式来维护自己本身的路由信息,有跳数限制,适合运用于小型网络中。链路状态路由协议从网络或者网络的限定区域内的所有其他路由器处收集信息然后在不依赖其他路由器的情况下计算到达各个网络的路由,收敛速度快,适合在大型网络中运行。

    (3) RIPv2和EIGRP
          RIPv2和EIGRP均为距离矢量路由协议。RIP是路由器生产商之间使用的第一个开放标准,是最广泛的路由协议,在所有IP路由平台上都可以得到。RIP有两个版本:RIPv1和RIPv2,它们均基于经典的距离向量路由算法,最大跳数为15跳。RIP具有算法简单、可以与不同厂商的路由器互联的特点,但在路径较多时收敛速度慢,广播路由信息时占用的带宽资源较多,它适用于网络拓扑结构相对简单的小型网络中。
    IGRP为第一代思科专有协议,是一种动态的、长跨度的路由协议,最大跳数为255跳,与RIP相比,IGRP的收敛时间更长,但传输路由信息所需的带宽减少,适合较为复杂的网络。EIGRP为IGRP的增强版,它使用与IGRP相同的路由算法,但它集成了链路状态路由协议和距离向量路由协议的长处,同时加入扩散更新算法(DUAL)具有快速收敛、减少了带宽的消耗、减少路由器CPU的利用等特点。

    (4) OSPF和IS-IS
          OSPF和IS-IS是链路状态路由协议的两个最典型的代表,都采用STP算法来计算路由;开放式最短路径优先(OSPF)协议是一种为IP网络开发的内部网关路由选择协议,它能够在自己的链路状态数据库内表示整个网络,这极大地减少了收敛时间,并且支持大型异构网络的互联,具有快速收敛、区域划分、无跳数限制、安全性好等优点。中间系统到中间系统(IS-IS)是由国际标准化组织制定最初是为OSI协议簇设计的,后来添加了对IP网络的支持。ISIS和OSPF从基本功能与操作上都非常相似,但也存在着差异,如封装位置、划分边界、支持路由等。

    四、总结

          以上对各类路由协议的描述,对于在不同的网络中选择何种路由协议这个问题可以得出初步的结论:在公司、组织各自的内部网络中使用IGP,而在服务提供商、公司和大型企业之间使用EGP实现互联。在IGP的配置中,如果网络规模较小,路由器的数量小于或等于15个,则可以考虑使用RIP或IGRP。对于小规模的网络,可以使用RIPv2协议;而对于中型的网络,使用EIGRP协议则更为合适;如果是大型网络,则需要考虑使用OSPF协议。

    展开全文
  • ISIS动态路由协议什么事IS-IS简介华为IS-IS路由种类和功能Level-1Level-2Level-1-2三种路由器功能:L1,L2和L1-2IS-IS度量值邻居关系建立IS-IS 特点NSAP地址NSAP地址换算华为IS-IS常用命令实验验证R5配置R4...

    什么事IS-IS

    IS-IS(Intermediate System-to-Intermediate System,中间系统到中间系统)路由协议最初是ISO(the International Organization for Standardization,国际标准化组织)为CLNP(Connection Less Network Protocol,无连接网络协议)设计的一种动态路由协议。

    简介

    为了提供对IP路由的支持,通过对IS-IS进行扩充和修改,使IS-IS能够同时应用在TCP/IP和OSI环境中,形成了集成化IS-IS(Integrated IS-IS或Dual IS-IS)。现在提到的IS-IS协议都是指集成化的IS-IS协议,主要用于城域网和承载网。
    IS-IS属于内部网关路由协议,用于自治系统内部。IS-IS是一种链路状态协议,与TCP/IP网络中的OSPF协议非常相似,使用最短路径优先算法进行路由计算。
    ISO网络和IP网络的网络层地址的编址方式不同。IP网络的三层地址是常见的IPv4地址或IPv6地址,IS-IS协议将ISO网络层地址称NSAP(Network Service Access Point,网络服务接入点),用来描述ISO模型的网络地址结构。
    运行IS-IS协议的网络包含了终端系统(End System)、中间系统(Intermediate System)、区域(Area)和路由域(Routing Domain)。一个路由器是Intermediate System(IS),一个主机就是End System(ES)。主机和路由器之间运行的协议称为ES-IS,路由器与路由器之间运行的协议称为IS-IS。区域是路由域的细分单元,IS-IS允许将整个路由域分为多个区域,IS-IS就是用来提供路由域内或一个区域内的路由。

    华为IS-IS的路由种类和功能

    为了支持大规模的路由网络,IS-IS在路由域内采用两级的分层结构。一个大的路由域被分成一个或多个区域(Areas)。并定义了路由器的三种角色:Level-1、Level-2、Level-1-2。区域内的路由通过Level-1路由器管理,区域间的路由通过Level-2路由器管理。下面简要说明一下这三类路由器角色

    Level-1

    Level-1路由器负责区域内的路由,它只与属于同一区域的Level-1和Level-1-2路由器形成邻居关系,维护一个Level-1的链路状态数据库,该链路状态数据库包含本区域的路由信息,到区域外的报文转发给最近的Level-1-2路由器。(类似OSPF中的1类和2类)

    Level-2

    Level-2路由器负责区域间的路由,可以与同一区域或者其它区域的Level-2和Level-1-2路由器形成邻居关系,维护一个Level-2的链路状态数据库,该链路状态数据库包含区域间的路由信息。所有Level-2路由器和Level-1-2路由器组成路由域的骨干网,负责在不同区域间通信,路由域中的Level-2路由器必须是物理连续的,以保证骨干网的连续性(类似OSPF的3类)

    Level-1-2

    同时属于Level-1和Level-2的路由器称为Level-1-2路由器,可以与同一区域的Level-1和Level-1-2路由器形成Level-1邻居关系,也可以与同一区域或者其他区域的Level-2和Level-1-2路由器形成Level-2的邻居关系。Level-1路由器必须通过Level-1-2路由器才能连接至其他区域。Level-1-2路由器维护两个链路状态数据库,Level-1的链路状态数据库用于区域内路由,Level-2的链路状态数据库用于区域间路由。

    每台路由器只能属于一个区域,区域边界在链路上。

    三种路由器的功能:L1,L2和L1-2

    L1能获取区域内的路径信息

    L2能获取区域间的路径信息

    L1-2:能同时获取区域内和区域间路径

    连接L2路由器和L1/L2路由器的路径会形成骨干区域

    IS-IS度量值

    接口的度量值默认是10,可修改

    邻居关系的建立

    相同区域内

    L1可以和L1,L1-2建立邻居关系,但无法和L2建立邻居关系

    L2可以和L2,L1-2建立邻居关系

    L1-2可以和L1和L2建立邻居关系

    不同区域内
    L1无法和其他路由建立邻居关系

    L2可以和其他路由建立邻居关系,除了L1

    L1-2可以和其他路由建立邻居关系,除了L1

    IS-IS 特点

    1.维护一个链路状态数据库,并使用SPF算法来计算最佳路径;
    2.用Hello包建立和维护邻居关系;
    3.使用区域来构造两级层次化的拓扑结构;
    4.在区域之间可以使用路由汇总来减少路由器的负担;
    5.支持VLSM和CIDR;
    6.在广播多路访问网络通过选举指定IS(DIS)来管理和控制网络上的泛洪扩散;
    7.具有认证功能;
    8.IS-IS采用Cost作为度量值;
    9.快速收敛;
    10.适合大型网络。

    NSAP地址

    • IS-IS中NSAP类似于OSPF中的router-id
    • LSP 使用NSAP地址来标识路由器并建立拓扑表,因此为IP提供路由选择需要NSAP地址
    • NSAP地址8-20字节,用16进制标识,包含如下主要信息:
      • 1.区域编号
      • 2.系统编号(固定6个字节)
      • 3.NSEL位(固定1字节,并重置为0)

    NSAP地址的换算

    • 原则:
      • 通过环回口32位地址补齐成48位获得,即补足3位,然后4位分割
    • 例如:49.0001.0020.0200.2002.00
      • 分析:49.0001:49是固定格式,0001代表在area1,若区域为2,则为49.0002
      • 0020.0200.2002:是由IP地址2.2.2.2转换过来的 00:固定格式1.4.1:NSAP地址的换算 原则: 通过环回口32位地址补齐成48位获得,即补足3位,然后4位分割
      • 举例:12.12.12.12 补足3位:变成012.012.012.012 4位分割:变成0120.1201.2012所以12.12.12.12转换49.0001.0120.1201.2012.00

    华为IS-IS常用命令

    查看命令

    dis isis peer  	 				##查看isis邻居关系
    dis isis 1 brief    			##查看isis接口的明细
    dis isis interface g0/0/1		##查看接口isis详情
    

    配置命令

    [Huawei]  isis 1   											##isis 后面跟进程。默认不加就是1进程	
    [Huawei-isis-1]  network-entity 49.0001.0010.0100.1001.00 	##补足三位,然后4位分割
    [Huawei-isis-1]  is-level level-1    						##根据网络结构配置IS-IS路由类型,这边有路由器类型
    [Huawei-isis-1]  int g0/0/1             					##进接口
    [Huawei-g0/0/1] isis enable									##启动ISIS
    

    路由重分发

    isis 1
    import-route   rip 1 lever-1   					##引入后变成L1信息  默认值
    
    rip 1
    import-route isis 1 cost 5 						##对于rip的度量值是跳数 
    
    isis 1
    import-route isis level-2 into level-1			##华为手册这个叫路由泄露
    

    路由汇总

    isis 1
    summary 202.0.0.0 255.255.254.0 level-1-2		##ABR汇总:域间路由汇总
    
    isis 1
    summary 203.0.0.0 255.255.254.0 level-1			##ASBR汇总:不同协议间的路由汇总
    

    实验验证

    在这里插入图片描述

    R5配置

    [R5]isis 1
    [R5-isis-1] is-level level-1										#将路由器isis等级设置L1
    [R5-isis-1] network-entity 49.0002.0050.0500.5005.00				#0002宣告Area区域0050...宣告环回地址
    [R5-isis-1]int g0/0/0												#进接口				
    [R5-GigabitEthernet0/0/0]ip address 45.0.0.2 30						#添加IP地址
    [R5-GigabitEthernet0/0/0]isis enable 1								#开启isis(重要一定要开启)
    [R5-GigabitEthernet0/0/0]int loo 0
    [R5-LoopBack0] ip address 5.5.5.5 32
    [R5-LoopBack0] isis enable 1
    [R5-LoopBack0] int loo 1
    [R5-LoopBack1] ip address 202.0.0.1 24
    [R5-LoopBack1] isis enable 1
    [R5-LoopBack1]int loo 2
    [R5-LoopBack2] ip address 202.0.1.1 24
    [R5-LoopBack2] isis enable 1
    

    R4配置

    [R4]isis 1
    [R4-isis-1]is-level level-1-2										#将路由器isis等级设置L1-2
    [R4-isis-1]network-entity 49.0002.0020.0200.2002.00
    [R4-isis-1]int g0/0/0
    [R4-GigabitEthernet0/0/0]ip address 45.0.0.2 30
    [R4-GigabitEthernet0/0/0]isis enable 1
    [R4-GigabitEthernet0/0/0]int g0/0/2
    [R4-GigabitEthernet0/0/2]ip add 34.0.0.1 30
    [R4-GigabitEthernet0/0/2]isis enable 1
    [R4-GigabitEthernet0/0/2]int loo 0
    [R4-LoopBack0]ip add 4.4.4.4 32
    [R4-LoopBack0]isis enable 1
    

    R3配置

    [R3]isis 1
    [R3-isis-1]is-level level-2												#将路由器isis等级设置L2
    [R3-isis-1]network-entity 49.0000.0030.0300.3003.00
    [R3-isis-1]int g0/0/2
    [R3-GigabitEthernet0/0/2]ip add 34.0.0.2 30
    [R3-GigabitEthernet0/0/2]isis enable 1
    [R3-GigabitEthernet0/0/2]int g0/0/1
    [R3-GigabitEthernet0/0/1]ip add 23.0.0.1 30
    [R3-GigabitEthernet0/0/1]isis enable 1
    [R3-GigabitEthernet0/0/1]int loo 0
    [R3-LoopBack0]ip add 3.3.3.3 32
    [R3-LoopBack0]isis enable 1
    

    R2配置

    [R2]isis 1
    [R2-isis-1]is-level level-1-2
    [R2-isis-1]network-entity 49.0001.0020.0200.2002.00
    [R2-isis-1]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip add 23.0.0.2 30
    [R2-GigabitEthernet0/0/1]isis enable 1
    [R2-GigabitEthernet0/0/1]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip add 12.0.0.1 30
    [R2-GigabitEthernet0/0/0]isis enable 1
    [R2-GigabitEthernet0/0/0]int loo 0
    [R2-LoopBack0]ip add 2.2.2.2 32
    [R2-LoopBack0]isis enable 1
    

    R1配置

    [R1]isis 1
    [R1-isis-1]is-level level-1
    [R1-isis-1]network-entity 49.0001.0010.0100.1001.00
    [R1-isis-1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 12.0.0.2 30
    [R1-GigabitEthernet0/0/0]isis enable 1
    [R1-GigabitEthernet0/0/0]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 16.0.0.1 30
    [R1-GigabitEthernet0/0/1]int loo 0
    [R1-LoopBack0]ip add 1.1.1.1 32
    [R1-LoopBack0]isis enable 1
    [R1-LoopBack0]q
    [R1]rip 1																#进入rip进程
    [R1-rip-1]version 2														#选择版本2
    [R1-rip-1]undo summary 													#关闭路由汇总
    [R1-rip-1]network 1.0.0.0					
    [R1-rip-1]network 16.0.0.0												#宣告网段
    

    R6配置

    [R6]int g0/0/1
    [R6-GigabitEthernet0/0/1]ip add 16.0.0.2 30
    [R6-GigabitEthernet0/0/1]int loo 0
    [R6-LoopBack0]ip add 6.6.6.6 32
    [R6-LoopBack0]int loo 1
    [R6-LoopBack1]ip add 203.0.0.1 24
    [R6-LoopBack1]int loo 2
    [R6-LoopBack2]ip add 203.0.1.1 24
    [R6-LoopBack2]q
    [R6]rip 1
    [R6-rip-1]undo summary 
    [R6-rip-1]version 2
    [R6-rip-1]network 6.0.0.0
    [R6-rip-1]network 16.0.0.0
    [R6-rip-1]network 203.0.0.0
    [R6-rip-1]network 203.0.1.0
    

    路由重分发配置

    [R1]rip 1														
    [R1-rip-1]import-route isis 1 cost 5 							#将rip注入到isis中
    [R1-rip-1]q
    [R1]isis 1
    [R1-isis-1]import-route rip 1 level-1							#将isis注入到rip中
    
    • 此时使用R2查看路由信息,发现isis中的路由可以学习到rip中路由表条目了

    • 但是此时会发现,R1和R6学习不到isis中的路由网段,且R5也学习不到本区域外的网段,那么如何解决?

      • 原因:因为R1是L1,所以他只能学习区域内的路由,其他区域的isis路由信息学习不到
      • 解决:路由泄露
    [R2]isis 1
    [R2-isis-1]import-route isis level-2 into level-1 					#将isisL2的信息泄露成L1的信息
    
    • 此时再次查看R1和R5,会发现已经学习到路由条目了
    • 同理,在R4上,将路由信息泄露给R5
    [R4]isis 1
    [R4-isis-1]import-route isis level-2 into level-1 
    
    • 我们发现R5和R6的两个loopback地址是同网段的,使用其他路由器查看路由表的时候,可以发现这些loopback地址是分开的
    [R2]dis ip routing-table
    省略内容
          202.0.0.0/24  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet0/0/0
          202.0.1.0/24  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet0/0/0
          203.0.0.0/24  ISIS-L1 15   74          D   12.0.0.1        GigabitEthernet0/0/1
          203.0.1.0/24  ISIS-L1 15   74          D   12.0.0.1        GigabitEthernet0/0/1
    
    • 我们可以汇总
    [R4]isis 	
    [R4-isis-1]summary 202.0.0.0 255.255.254.0 level-1-2					#R4汇总
    [R1]isis                           
    [R1-isis-1]summary 203.0.0.0 255.255.254.0 level-1						#R1汇总
    
    • 此时我们使用路由查看IP地址
    [R2]dis ip routing-table
    省略内容
          202.0.0.0/23  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet0/0/0
          203.0.0.0/23  ISIS-L1 15   74          D   12.0.0.1        GigabitEthernet0/0/1
    

    实验结束

    展开全文
  • 文章目录动态路由协议---链路状态协议OSPF(接上次生成odpf多区域原因OSPF三种通信量域内通信量(Intra-Area Traffic)域间通信量(Inter-Area Traffic)外部通信量(External Traffic)OSPF路由器类型内部...
  • 动态路由协议(Dynamic Source Routing, DSR)是在移动自组网(MANET)中使用一种路由协议。它工作在TCP/IP协议族网际层。   它首部采用扩展性良好TLV格式。除固定部分外,不同类型选项(option)以TLV格式...
  • 介绍了IP路由器的几大功能,给出了静态路由协议和动态路由协议,以及内部网关协议和外部网关协议的概念,同时简要介绍了目前最常见的RIP、OSPF、BGP和BGP-4这几种路由协议,然后描述了路由算法的设计目标和种类,...
  • 对于路由协议的种类,我们在之前的文章中已经为大家概括和总结了。现在我们主要针对两个协议再来具体分析一下,一个是IGRP网关路由协议,一个是EIGRP协议。这两个协议但从名字上面您就能想到其中的关联。 IGRP ...
  • 文章目录一、ISIS概述1.1 简述IS-IS动态路由协议1.2 华为IS-IS的路由种类和功能1.3 邻居关系的建立1.4 NSAP地址1.5 IS-IS状态协议1.6 IS-IS配置命令二、ISIS配置实验2.1 IS-IS协议的配置思路2.2 实验环境2.3 实验...
  • 静态路由和默认路由的区别

    千次阅读 2018-10-18 08:48:13
    路由表中明细路由(静态路由)时,就会先找明细路由,在明细中找不到路由时, 就走默认。地址掩码越小、精度越高,就匹配哪个!!! 比如同样目标地址,... 路由协议或路由种类|相应默认路由优先级(Prefer...
  • 动态路由协议的种类: (1)RIP路由协议 RIP协议最初是为Xerox网络系统的Xerox parc通用协议而设计的,是Internet中常用的路由协议。RIP采用距离向量算法,即路由器根据距离选择路由,所以也称为距离向量协议。...
  • 备注:路由分为两大种类,有动态路由,静态路由 1.动态路由 RIP、OSPF、IS-IS、IGRP、EIGRP、BGP 自动学习更新路由信息。 2.静态路由混淆注意点 管理距离(协议优先级):发现路由优先级 度量值(metric):路径...
  • 这个ppt讲述内容挺多,当初做课件时候没有把它分成一节一节形式,具体内容有:计算机网络中地址种类,IP地址分配规则,子网与子网掩码,网络通信路由,动态路由与路由选择协议
  • TCP-IP协议详解

    热门讨论 2008-11-24 20:46:50
    20.5 异种协议的IP封装 219 20.6 小结 220 第21章 Windows 98 221 21.1 Windows 98网络体系结构 221 21.1.1 安装网卡 222 21.1.2 更改网卡配置 224 21.1.3 当Windows 98引导失败 224 21.2 配置Windows 98的TCP/IP ...
  • · 案例背景 - 全网采用动态路由协议OSPF,设备间自动学习路由,当网络结构发生变化时造成网络不通,管理员无法及时发现问题所在。 - 设备种类繁多,各个厂家新旧设备混合使用,设备间兼容性存在一定问题。...
  • 路由器原理

    2010-01-03 19:25:00
    介绍了IP器的几大功能,给出了静态路由协议和动态路由协议,以及内部网关协议和外部网关协议的概念,同时简要介绍了目前最常见的RIP、OSPF、BGP和BGP-4这几种路由协议,然后描述了路由算法的设计目标和种类,着重...

空空如也

空空如也

1 2 3
收藏数 54
精华内容 21
关键字:

动态路由协议的种类