精华内容
下载资源
问答
  • 动态路由和静态路由

    千次阅读 2014-09-14 11:02:42
    静态路由  静态路由是由管理员在路由器中手动配置的固定路由,路由明确地指定了包到达目的地必须经过的路径,除非网络管理员干预,否则静态路由不会发生变化。静态路由不能对网络的改变作出反应,所以一般说静态...
    静态路由
    
        静态路由是由管理员在路由器中手动配置的固定路由,路由明确地指定了包到达目的地必须经过的路径,除非网络管理员干预,否则静态路由不会发生变化。静态路由不能对网络的改变作出反应,所以一般说静态路由用于网络规模不大、拓扑结构相对固定的网络。
    静态路由特点
    1、它允许对路由的行为进行精确的控制;
    2、减少了网络流量;
    3、是单向的;
    4、配置简单。
    在所有的路由中,静态路由优先级最高。当动态路由与静态路由发生冲突时,以静态路由为准。

    动态路由
        动态路由是网络中的路由器之间相互通信,传递路由信息,利用收到的路由信息更新路由器表的过程。是基于某种路由协议来实现的。常见的路由协议类型有:距离向量路由协议(如RIP)和链路状态路由协议(如OSPF)。路由协议定义了路由器在与其它路由器通信时的一些规则。动态路由协议一般都有路由算法。其路由选择算法的必要步骤  
    1、向其它路由器传递路由信息;  
    2、接收其它路由器的路由信息;
    3、根据收到的路由信息计算出到每个目的网络的最优路径,并由此生成路由选择表;
    4、根据网络拓扑的变化及时的做出反应,调整路由生成新的路由选择表,同时把拓扑变化以路由信息的形式向其它路由器宣告。
    动态路由适用于网络规模大、拓扑复杂的网络。
    动态路由特点:
    1、无需管理员手工维护,减轻了管理员的工作负担。
    2、占用了网络带宽。
    3、在路由器上运行路由协议,使路由器可以自动根据网络拓朴结构的变化调整路由条目;
        根据是否在一个自治域内部使用,动态路由协议分为内部网关协议(IGP)和外部网关协议(EGP)。这里的自治域指一个具有统一管理机构、统一路由策略的网络。自治域内部采用的路由选择协议称为内部网关协议,常用的有RIP、OSPF;外部网关协议主要用于多个自治域之间的路由选择,常用的是BGP和BGP-4。下面分别进行简要介绍。


    RIP路由协议

        RIP协议最初是为Xerox网络系统的Xerox parc通用协议而设计的,是Internet中常用的路由协议。RIP采用距离向量算法,即路由器根据距离选择路由,所以也称为距离向量协议。路由器收集所有可到达目的地的不同路径,并且保存有关到达每个目的地的最少站点数的路径信息,除到达目的地的最佳路径外,任何其它信息均予以丢弃。同时路由器也把所收集的路由信息用RIP协议通知相邻的其它路由器。这样,正确的路由信息逐渐扩散到了全网。
        RIP使用非常广泛,它简单、可靠,便于配置。但是RIP只适用于小型的同构网络,因为它允许的最大站点数为15,任何超过15个站点的目的地均被标记为不可达。而且RIP每隔30s一次的路由信息广播也是造成网络的广播风暴的重要原因之一。
    OSPF路由协议
        80年代中期,RIP已不能适应大规模异构网络的互连,0SPF随之产生。它是网间工程任务组织(IETF)的内部网关协议工作组为IP网络而开发的一种路由协议。
        0SPF是一种基于链路状态的路由协议,需要每个路由器向其同一管理域的所有其它路由器发送链路状态广播信息。在OSPF的链路状态广播中包括所有接口信息、所有的量度和其它一些变量。利用0SPF的路由器首先必须收集有关的链路状态信息,并根据一定的算法计算出到每个节点的最短路径。而基于距离向量的路由协议仅向其邻接路由器发送有关路由更新信息。
        与RIP不同,OSPF将一个自治域再划分为区,相应地即有两种类型的路由选择方式:当源和目的地在同一区时,采用区内路由选择;当源和目的地在不同区时,则采用区间路由选择。这就大大减少了网络开销,并增加了网络的稳定性。当一个区内的路由器出了故障时并不影响自治域内其它区路由器的正常工作,这也给网络的管理、维护带来方便。
    BGP和BGP-4路由协议
        BGP是为TCP/IP互联网设计的外部网关协议,用于多个自治域之间。它既不是基于纯粹的链路状态算法,也不是基于纯粹的距离向量算法。它的主要功能是与其它自治域的BGP交换网络传达信息。各个自治域可以运行不同的内部网关协议。BGP更新信息包括网络号/自治域路径的成对信息。自治域路径包括到达某个特定网络须经过的自治域串,这些更新信息通过TCP传送出去,以保证传输的可靠性。
        为了满足Internet日益扩大的需要,BGP还在不断地发展。在最新的BGp4中,还可以将相似路由合并为一条路由。
    路由表项的优先问题
        在一个路由器中,可同时配置静态路由和一种或多种动态路由。它们各自维护的路由表都提供给转发程序,但这些路由表的表项间可能会发生冲突。这种冲突可通过配置各路由表的优先级来解决。通常静态路由具有默认的最高优先级,当其它路由表表项与它矛盾时,均按静态路由转发。
    展开全文
  • 静态路由是在路由器中设置的固定的路由表。除非网络管理员干预,否则静态路由不会发生变化。由于静态路由不能对网络的改变...在所有的路由中,静态路由优先级最高。当动态路由与静态路由发生冲突时,以静态路由为准。
  • 第06章 动态路由和静态路由 6.1路由-网络层实现的功能 网络层功能就是给传输层协议提供简单灵活的、无连接的、尽最大努力交付的数据包服务。 通俗一点来讲,网络中的路由器为每一个数据包单独的选择转发路径,网络层...

    第06章 动态路由和静态路由

    6.1路由-网络层实现的功能

    网络层功能就是给传输层协议提供简单灵活的、无连接的、尽最大努力交付的数据包服务。

    通俗一点来讲,网络中的路由器为每一个数据包单独的选择转发路径,网络层不提供服务质量的承诺。

    也就说路由器直接丢弃传输过程中出错的数据包,如果网络中待发的数据包太多,路由器处理不了就直接丢弃,路由器也不判断数据包是否重复,也不确保数据包按发送顺序到达终点。

    image-20200612201111903

    6.1.1 网络畅通的条件

    image-20200612201257503

    计算机网络畅通的条件就是数据包能去能回,道理很简单、也很好理解,却是我们排除网络故障的理论依据。

    image-20200612201636462

    以下情况网络不通

    目标主机不可到达 image-20200612201651030

    请求超时

    image-20200612201713072

    网络排错

    明白了网络畅通的条件,网络排错就变得简单了。

    先检查数据包是否能够到达目标网络

    再检查数据包是否能够返回来。

    如果网络不通,您就要检查计算机是否配置了正确的IP地址子网掩码以及网关,再逐一检查沿途路由器上的路由表,查看是否有到达目标网络的路由;然后逐一检查沿途路由器上的路由表,检查是否有数据包返回所需的路由。

    6.1.2静态路由

    要想实现全网通信,也就是网络中的任意两个节点都能通信,这就要求每个路由器的路由表中必须有到所有网段的路由。

    对于路由器来说,它只知道自己直连的网段,直连的网段不用添加静态路由,对于没有直连的网段,需要管理员人工添加到这些网段的路由。

    管理员人工添加到某个网段如何转发,就是静态路由。

    后面还会讲到配置网络中的路由器使用动态路由协议(RIP、OSPF)自动构建路由表,就是动态路由。

    思科路由器添加静态路由的命令

    R1路由器直连A、B两个网段,C、D网段没有直连,你需要添加到C、D网段的路由。

    R2路由器直连B、C两个网段,A、D网段没有直连,你需要添加到A、D网段的路由。

    R3路由器直连C、D两个网段,A、B网段没有直连,你需要添加到A、B网段的路由。

    image-20200612202945072

    主机部分必须为0,因为表示网段,接着写下一跳的网关或者写出口(点到点设备)

    如果想配置某个地址,子网掩码要写成255.255.255.255

    点到点链路静态路由下一跳

    点到点链路下一跳可以是数据包的转发出口 image-20200612203542121

    在R1上添加到192.168.1.0/24网段的路由可以使用以下命令R1(config)#iproute 192.168.1.0 255.255.255.0 serial 2/0

    注意:Serial 2/0是路由器R1接口

    路由器只关心到某个网段如何转发

    路由器只关心到某个网段如何转发数据包,因此我们在路由器上添加路由,必须是到某个网段(子网)的路由,不能添加到某个特定地址的路由。

    以下命令试图添加到一个IP地址的路由,路由器报错。

    R1(config)#ip route 192.168.1.3 255.255.255.0 172.16.0.2

    %Inconsistent address and mask --错误的地址和子网掩码

    如果你就想让路由器转发到一个IP地址的路由,子网掩码要写成四个255,这就意味着IP地址的32位二进制是全部的网络位,该网段中就这一个地址。

    R1(config)#ip route 192.168.1.3 255.255.255.255 172.16.0.2

    6.2实战:配置静态路由

    6.2.1查看路由表

    6.2.2添加静态路由

    6.2.3测试网络是否畅通

    6.2.4删除静态路由

    image-20200612210503011

    6.3路由汇总

    Internet是全球最大的互联网,如果Internet上的路由器把全球所有的网段都添加到路由表,那将是一个非常庞大的路由表。路由器每转发一个数据包,都要检查路由表为该数据包选择转发接口,庞大的路由表势必会增加处理时延。

    通过合理的地址规划,可以通过路由汇总简化路由表。

    将物理位置连续的网络分配地址连续的网段,就可以在边界路由器上将远程的网络合并成一条路由,这就是路由汇总。

    6.3.1通过路由汇总简化路由表

    不汇总的路由表

    image-20200612210553228

    汇总后的路由表

    image-20200612210602177

    将北京的网络汇总成172.0.0.0 255.0.0.0网段。

    image-20200612210623055

    将北京的网络汇总成172.0.0.0 255.0.0.0网段。

    6.3.2路由汇总例外

    针对例外的网段需要单独添加路由。

    image-20200612210643557

    6.3.3 无类域间路由(CIDR)

    无类域间路由(CIDR)采用13~27位可变网络ID,而不是A、B、C类网络ID所用的固定的8、16和24位。

    这样我们可以将子网掩码向左移动1位,合并两个网段;向左移动2位合并4个网段;向左移动3位合并8个网段;向左移动n位,就可以合并2n个网段。

    image-20200612210707335

    路由汇总一定要能够想起前面讲的超网合并网段,对于R2路由器来说A区的就相当于一个合并了四个网段的超网。

    6.4默认路由

    6.4.1全球最大的网段

    我们在路由器上添加以下三条路由。

    R1(config)#ip route 172.0.0.0 255.0.0.0 10.0.0.2 --第1条路由

    R1(config)#ip route 172.16.0.0 255.255.0.0 10.0.1.2 --第2条路由

    R1(config)#ip route 172.16.10.0 255.255.255.0 10.0.3.2 --第3条路由

    从上面3条路由可以看出,子网掩码越短(子网掩码写成二进制形式1的个数越少),主机位越多,该网段的地址数量就越大。

    如果想让一个网段包括全部的IP地址,这就要求子网掩码短到极限,最短就是0,子网掩码变成了0.0.0.0,这就意味着该网段的32位二进制的IP地址都是主机位,任何一个地址都属于该网段。因此0.0.0.0 子网掩码0.0.0.0网段包括了全球所有IPv4地址,也就是全球最大的网段,换一种写法就是0.0.0.0/0。

    在路由器上添加添加到0.0.0.0 0.0.0.0网段的路由,就是默认路由。

    R1(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.2 --第4条路由

    任何一个目标地址都与默认路由匹配,根据前面讲的“最长前缀匹配”算法,默认路由是在路由器没有为数据包找到更为精确匹配的路由,先匹配子网掩码长的,最后匹配的一条路由。

    6.4.2使用默认路由作为指向Internet的路由

    网络末端路由器B和D只需添加一条默认路由。

    image-20200612233607020

    RA路由器上的路由表也可以精简

    对A路由路由表进行精简,在A路由器上可以把内网看做是10.0.0.0 255.0.0.0这个网段。所以只需添加一条路由。

    image-20200612233624585

    6.4.3让默认路由代替大多数网段的路由

    对于C路由器来说,1和2两种方式都可以,但1这种方式路由条目更少。

    image-20200612233640299

    6.4.4默认路由和环状网络

    当ping不存在的网段,会来回循环

    image-20200612233647508

    6.4.5默认路由造成的往复转发

    当ping不存在的网段,会在RA和RB之间来回

    image-20200612233653151

    6.4.6使用默认路由和路由汇总简化路由表

    image-20200612233701683

    image-20200612233708915

    6.4.7Windows上的默认路由和网关

    计算机也有路由表,我们可以在Windows操作系统上运行route print显示Windows操作系统上的路由表,也可以运行netstat –r显示Windows操作系统上的路由表。

    查看Windows上的路由表

    image-20200612233809733

    在Windows上添加默认路由

    image-20200612233837065

    在Web服务器上需要添加到内网的路由

    添加到某个网段的路由

    image-20200612233849697

    image-20200612233855735

    如果想删除到172.16.0.0 255.255.255.0网段的路由,指向以下命令。

    route delete 172.16.0.0 mask 255.255.255.0

    6.5网络排错案例

    在石家庄

    image-20200612234108493

    6.5.1网络排错要有全局观

    网络出现不通的故障,要确保数据包有去有回,确保沿途的路由知道源和目标网络的路由。

    出现网络故障,不要只检查自己所管辖的网络。也要确保远程网络中的路由器的路由表,有返回的路由。

    6.5.2计算机网关也很重要

    计算机不设置网关,只能和本网段的计算机通信。

    image-20200612234128661

    6.6动态路由-RIP协议

    6.6.1 介绍RIP协议

    路由信息协议RIP(Routing Information Protocol)是一个真正的距离矢量路由选择协议。

    它每隔30秒就送出自己完整的路由表到所有激活的接口。

    RIP协议选择最佳路径的标准就是跳数,认为到达目标网络经过的路由器最少的路径就是最佳路径。

    默认它所允许的最大跳数为15跳,也就是说16跳的距离将被认为是不可达的。

    在小型网络中,RIP会运转良好,但是对于使用慢速WAN连接的大型网络或者安装有大量路由器的网络来说,它的效率就很低了。

    RIPv1广播255.255.255.255不带子网掩码不支持变成子网支持等长子网
    RIPv2多播224.0.0.9带子网掩码支持变长子网

    6.6.2 RIP协议工作原理

    举例说明192.168.10.0/24网段如何通过RIP协议通告给网络中的其他路由器的。

    如果学到到一个网段有两条路径,只保留最佳路径。

    image-20200612234142328

    6.6.3在路由器上配置RIP协议

    搭建实验环境

    image-20200612234211128

    在R1上的配置

    R1#config t

    Enter configuration commands, one per line. End with CNTL/Z.

    R1(config)#router rip

    R1(config-router)#network 192.168.0.0

    R1(config-router)#network 192.168.1.0

    R1(config-router)#network 192.168.4.0

    R1(config-router)#version 2

    network的应该怎么写

    就要看接口属于哪个网络,多个接口属于同一个网段(按A、B、C分类),只需写一个。

    RA(config-router)#network 172.16.0.0

    RA(config-router)#network 192.168.10.0

    image-20200612234720248

    RA(config-router)#network 172.16.0.0

    RA(config-router)#network 172.17. 0.0

    image-20200612234248933

    6.6.4查看路由表

    R3#show ip route

    R 192.168.4.0/24 [120/2] via 192.168.6.1, 00:00:08, Serial2/0

    ​ [120/2] via 192.168.2.1, 00:00:02, Serial2/1

    R 192.168.5.0/24 [120/1] via 192.168.6.1, 00:00:08, Serial2/0

    C 192.168.6.0/24 is directly connected, Serial2/0

    R 192.168.0.0/24 [120/2] via 192.168.2.1, 00:00:02, Serial2/1

    R 192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:02, Serial2/1

    C 192.168.2.0/24 is directly connected, Serial2/1

    C 192.168.3.0/24 is directly connected, FastEthernet0/0

    路由条目的详细说明

    image-20200612234305655

    管理距离是指一种路由协议的路由可信度。每一种路由协议按可靠性从高到低,依次分配一个信任等级,这个信任等级就叫管理距离(administrative distance,缩写:AD)。

    AD值越低,则它的优先级越高。 一个管理距离是一个从0-255的整数值,0是最可信赖的,而255则意味着不会有业务量通过这个路由。

    默认情况下的管理距离值:直连接口 0 ,静态路由 1,OSPF 110,RIP 120

    6.6.5观察RIP协议路由更新活动

    默认情况下RIP协议发送和接收路由更新信息以及构造路由表的细节是不显示的,如果我们想观察RIP协议路由更新的活动,可以输入命令debug ip rip 命令,输入该命令后将显示发送和接收到的RIP路由更新信息,显示路由器使用了RIP的V1版还是V2版本。可以看到发送路由消息使用的多播地址是224.0.0.9, 输入undebug all关闭所有诊断输出。

    R3#debug ip rip

    RIP protocol debugging is on

    *Mar 1 01:22:52.703: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (192.168.3.1

    *Mar 1 01:22:52.703: RIP: build update entries --更新路由表

    *Mar 1 01:22:52.703: 192.168.0.0/24 via 0.0.0.0, metric 3, tag 0

    *Mar 1 01:22:52.703: 192.168.1.0/24 via 0.0.0.0, metric 2, tag 0

    *Mar 1 01:22:52.703: 192.168.2.0/24 via 0.0.0.0, metric 1, tag 0

    6.6.6测试RIP协议健壮性

    动态路由协议会随着网络的变化重新生成到各个网络的路由,当最佳路径没有了,就会从备用路径中重新选择一个最佳路径

    6.6.7 RIP协议排错

    如果网络中的路由配置了RIP协议,但没有从邻居路由器学习到路由,就要测试网络中的直连的路由之间是否能够通信,确保IP地址子网掩码配置正确,路由器使用串口相连,还要确保在DCE端配置了时钟频率。

    再就是检测RIP协议是否配置正确,网络中的路由最好都使用相同版本的RIP协议,Network命令后面的网段是否正确。

    查看路由器上的RIP协议配置,输入show ip protocols。

    查看运行的IP协议

    R1#show ip protocols

    Routing Protocol is “rip”

    Maximum path: 4

    Routing for Networks:

    192.168.0.0

    192.168.1.0

    192.168.4.0

    Routing Information Sources:

    Gateway Distance Last Update

    192.168.1.2 120 00:00:06

    192.168.4.2 120 00:00:23

    Distance: (default is 120)

    6.6.8RIP协议数据包报文格式

    image-20200612234341609

    image-20200612234358852

    6.7动态路由-OSPF协议

    6.7.1什么是最短路径优先

    最短路径优先示意图

    image-20200612234414174

    计算最短路径

    image-20200612234422770

    6.7.2 OSPF术语

    1. Router-ID

    网络中运行OSPF协议的路由器都要有一个唯一的标识,这就是Router-ID,并且Router-ID在网络中绝对不可以有重复。

    1. COST(开销)

    OSPF协议选择最佳路径的标准是带宽,带宽越高计算出来的开销越低。到达目标网络的各个链路累计开销最低的,就是最佳路径。

    1. 链路(Link)

    就是路由器上的接口,在这里,应该指运行在OSPF进程下的接口。

    1. 链路状态(Link-State)

    链路状态(LSA)就是OSPF接口上的描述信息,例如接口上的IP地址,子网掩码,网络类型,Cost值等等,OSPF路由器之间交换的并不是路由表,而是链路状态(LSA)。

    1. 邻居(Neighbor)

    OSPF只有邻接状态才会交换LSA。

    6.7.3OSPF协议工作过程

    运行OSPF协议的路由器有3张表,邻居表、链路状态表和路由表。下面以这三张表的产生过程为线索,来分析在这个过程中,路由器发生了那些变化,从而说明OSPF协议的工作过程。

    OSPF协议工作过程

    image-20200612234505255

    6.7.4 OSPF的5种报文

    类型1,问候(Hello)数据包,发现并建立邻接关系。

    类型2,数据库描述(Database Description)数据包,向邻居给出自己的链路状态数据库中的所有链路状态项目的摘要信息。

    类型3,链路状态请求(Link State Request,LSR)数据包,向对方请求某些链路状态项目的完整信息。

    类型4,链路状态更新(Link State Update,LSU)数据包,用洪泛法对全网更新链路状态。这种数据包是最复杂的,也是OSPF协议最核心的部分。路由器使用这种数据包将其链路状态通知给相邻路由器。在OSPF中,只有LSU需要显示确认。

    类型5,链路状态确认(Link State Acknowledgement,LSAck)数据包,对LSU做确认。

    6.7.5OSPF支持多区域

    划分区域的好处就是把利用洪泛法交换链路状态信息的范围局限于每一个区域而不是整个的自治系统,这就减少了整个网络上的通信量。在一个区域内部的路由器只知道本区域的完整网络拓扑,而不需知道其他区域的网络拓扑的情况。

    image-20200612234520279

    6.8 配置OSPF协议

    本节实验环境 配置OSPF协议

    image-20200612234529128

    6.8.1 在路由器配置OSPF协议

    R1#config t

    Enter configuration commands, one per line. End with CNTL/Z.

    R1(config)#router ospf ?

    <1-65535> Process ID

    R1(config)#router ospf 1

    R1(config-router)#network 192.168.0.0 0.0.0.255 area 0

    R1(config-router)#network 192.168.1.0 0.0.0.255 area 0

    R1(config-router)#network 192.168.4.0 0.0.0.255 area 0

    R1(config-router)#

    6.8.2查看OSPF协议三张表

    R1#show ip ospf neighbor --显示邻居表

    Neighbor ID Pri State Dead Time Address Interface

    192.168.5.1 0 FULL/ - 00:00:37 192.168.4.2 Serial2/1

    192.168.2.1 0 FULL/ - 00:00:34 192.168.1.2 Serial2/0

    R1#show ip ospf neighbor detail --显示邻居详细信息

    R1#show ip ospf database --显示链路状态数据库

    R1#show ip ospf database router --显示完整的链路状态数据库

    R1#show ip route ospf --只显示OSPF协议学到的路由

    6.8.3监控OSPF协议的活动

    R1#debug ip ospf hello

    R1#undebug all

    6.8.4验证OSPF协议健壮性

    断开最佳连接,跟踪数据包路径。

    恢复最佳连接,跟踪数据包路径。

    看看在此期间,网络中断的时间。

    6.8.5 OSPF协议配置排错

    R1#show ip protocols --显示OSPF协议的配置

    Routing Protocol is “ospf 1”

    Outgoing update filter list for all interfaces is not set

    Incoming update filter list for all interfaces is not set

    Router ID 192.168.4.1

    Number of areas in this router is 1. 1 normal 0 stub 0 nssa

    Maximum path: 4

    Routing for Networks:

    192.168.0.0 0.0.0.255 area 0

    192.168.1.0 0.0.0.255 area 0

    192.168.4.0 0.0.0.255 area 0

    Reference bandwidth unit is 100 mbps

    Routing Information Sources:

    Gateway Distance Last Update

    192.168.2.1 110 00:13:59

    192.168.5.1 110 00:13:59

    192.168.6.2 110 00:13:59

    192.168.6.1 110 00:13:59

    Distance: (default is 110)

    展开全文
  • 路由优先级

    2011-09-14 18:56:22
    华为则认为外部路由不可轻易相信,ibgp的路由优先级较高于ebgp,建议通常情况下最好使用动态路由协议,所以静态路由的优先级反而较低。另外,北电华为都将OSPF协议区分为内部外部,设置了相应的优先级,北电甚至...
  • 静态路由 60 Rip 100 ospf 10 路由度量(路由开销cost) 对于同一个路由协议,当到达某个目标网段有多条路由供选择时,此时路由器会优先选cost值较小的链路; 注意:先比较路由优先级,再比较路由度量,意味...

    一条路由不建议配多条缺省路由

    路由优先级

    代表路由的优先程度,当多个路由协议的路由都可以到达某个目标网段时,此时路由会优先级数据较小的路由,数字越小越优先;
    常用路由协议的默认优先级:

    类型优先级
    直连路由0
    静态路由60
    Rip100
    ospf10

    例图1

    路由度量(路由开销cost)

    对于同一个路由协议,当到达某个目标网段有多条路由供选择时,此时路由器会优先选cost值较小的链路;

    注意:先比较路由优先级,再比较路由度量,意味着只有当路由优先级相同时才会使用路由度量;
    路由表中始终放置最优路由;

    展开全文
  • 网工必备静态路由优先级

    千次阅读 2021-04-09 10:47:55
    路由概念 想要不同子网能够进行通信,需要三层设备实现跨网段转发,而路由就是指导着报文转发的路径信息,通过路由可以确定转发IP报文的路径。 如图,N想要去往M,需要经过多个路由器,通过路由进行多次转发。 ...

     

    路由概念

    想要不同子网能够进行通信,需要三层设备实现跨网段转发,而路由就是指导着报文转发的路径信息,通过路由可以确定转发IP报文的路径。

    如图,N想要去往M,需要经过多个路由器,通过路由进行多次转发。

     

    路由表概念

    路由指导着报文转发的路径。这就有一个概念叫做路由条目:目标网络、掩码、出接口以及下一跳。如图:

    在路由设备中,存在这着多条路由条目,分别去往不同的网络。这些路由条目共同构成路由表。

    路由表构成如下图所示:

    目的网络地址:目标网络,表示IP包的目的地址或目的网络。

    子网掩码:目标网络的子网掩码。

    协议类型:使用的路由协议,直连路由为Direct、静态路由为Static、动态路由有OSPF、RIP等。

    路由优先级:使用不同路由协议,其优先级也不同,路由优先级可以自行设置。

    开销:当到达一个目的地的多个路由优先级相同时,路由开销最小的将成为最优路由(基于链路状态协议时使用)。

    标志:U表示该路由可以使用;G表示该路由是到一个网关,如果没有该标志,说明目的地是直连的;H表示该路由是到一个主机;D表示该路由是由重定向报文创建。

    下一跳地址:去网目标网络下一个路由器接口IP,也就是往哪个路由器发。

    出接口:去往目标网络是从哪个接口输出数据。

     

    路由器根据路由表的数据,当收到数据包,会检查数据包里的目标地址,匹配路由表进行转发。

     

    静态路由概念

    静态路由是由管理员手动配置的路由,网络发生变化时也需要手动配置。适合

    缺点:

    1. 当网络拓扑结构和链路状态发生变化,需要对路由器的静态路由信息进行大范围修改,工作复杂度高;

    2. 网络发生故障时,不能重选路由,很可能使路由失败。

     

     

     

    优点:

    1. 因为不需要频繁交换路由信息,所以网络安全保密性。

     

    配置静态路由常用命令

    配置静态路由命令:

    ip route 目标网络 目标网络子网掩码 下一接口ip地址/送出口

    (注:此处的目标网络是指一个地址段,不是一个IP地址)

    如:ip route 192.168.2.0 255.255.255.0 192.168.3.1(g0/0/0)

    查看路由表:display ip routing-table

     

     

    静态路由适合小型、网络拓扑结构不易变化,对网络安全保密性高的网络。通常与动态路由结合使用。

     

    静态路由配置实验

    实验目的:

    • 对网络配置静态路由,使同子网设备能够进行通信;

    • 设置多条静态路由,为其配置不同优先级,分析实验现象;

     

    实验拓扑如下:

    1. 在PC1、PC2上配置相关IP地址与网关信息;

    2. 在路由器R1配置如下:

    <Huawei>sys

    [Huawei]un in en  //关闭提示信息

    [Huawei]int g0/0/0

    [Huawei-GigabitEthernet0/0/0]ip add 192.168.1.254 24  //配置端口IP

    [Huawei-GigabitEthernet0/0/0]int g0/0/1

    [Huawei-GigabitEthernet0/0/1]ip add 192.168.3.1 24

    [Huawei-GigabitEthernet0/0/1]int g0/0/2

    [Huawei-GigabitEthernet0/0/2]ip add 192.168.4.1 24

    [Huawei-GigabitEthernet0/0/2]q

    [Huawei]ip route-static 192.168.2.0 24 192.168.4.2   //配置目标网段192.168.2.0的静态条目

    [Huawei]ip route-static 192.168.2.0 24 192.168.3.2   //配置目标网段192.168.2.0的静态条目

     

    1. 在路由器R2配置如下:

    <Huawei>sys

    [Huawei]un in en   //关闭提示信息

    [Huawei]int g0/0/0

    [Huawei-GigabitEthernet0/0/0]ip add 192.168.2.254 24   //配置端口IP

    [Huawei-GigabitEthernet0/0/0]int g0/0/1

    [Huawei-GigabitEthernet0/0/1]ip add 192.168.3.2 24

    [Huawei-GigabitEthernet0/0/1]int g0/0/2

    [Huawei-GigabitEthernet0/0/2]ip add 192.168.4.2 24

    [Huawei-GigabitEthernet0/0/2]q

    [Huawei]ip route-static 192.168.1.0 24 192.168.3.1   //配置目标网段192.168.1.0的静态条目

    [Huawei]ip route-static 192.168.1.0 24 192.168.4.1   //配置目标网段192.168.1.0的静态条目

    1. 测试PC1与PC2的连通性;

    1. 查看路由表;

     

    为什么要配置两条静态路由?

    给2个路由器之间配置2条静态路由可以实现链路负担,增加可靠性,如果其中一条断掉可以使用另一条进行传输。

    在不设置优先级的前提下,有2条静态路由,路由器会选择一条继续传输。

    1. 由图可知,在PC1上使用tracert 192.168.2.2命令进行路由跟踪,可知路由器选择下一跳接口为R2的:192.168.4.2;

    1. 当关闭R3的192.168.4.2对应接口:

    1. 使用tracert 192.168.2.2命令进行路由跟踪;

    由上图可知,这个时候路由器会选择另一条静态路由。

     

     

    如何指定走哪一条静态路由?

    使用指定优先级:路由器在选择路由条目时,如果有2条去往目的网络的路由,会比较路由条目的优先级,选择优先级高的进行转发(值越小,优先级越高)。

    默认优先级举例:直连路由优先级0;静态路由优先级60;OSPF路由优先级10。

     

    接上例:

    若我们想指定数据从接口192.168.3.2进行数据转发,则设置其优先级<60。

    1. 先开启路由器R2接口;

    1. 使用tracert 192.168.2.2命令进行路由追踪;

    1. 在路由器R1上进行优先级配置;

    [Huawei]undo ip route-static 192.168.2.0 24 192.168.3.2  

    //删除先前的静态路由(可以在最开始配置静态条目的时候直接配置优先级)

    [Huawei]ip route-static 192.168.2.0 24 192.168.3.2 preference 20

    //配置此条静态路由条目为20

     

    1. 使用tracert 192.168.2.2命令进行路由追踪;

    由上图可知,数据转发切换线路了。

    1. 查看路由表。

    (6)配置成功。

     

    展开全文
  • 1.动态路由/静态路由 动态路由 路由选择器自动共享路由信息 自动构造路由表,需要一个路由协议,如RIP或OSPF 静态路由 路由选择器不共享路由信息(单方向路由) 手工构造路由表 2.直连路由/网关路由(间接路由) 其...
  • 动态路由协议的种类: (1)RIP路由协议  RIP协议最初是为Xerox网络系统的Xeroxparc通用协议而设计的,是Internet中常用的路由协议。RIP采用距离向量算法,即路由器根据距离选择路由,所以也称为距离向量协议。...
  • Linux 策略路由对二层通信的影响
  • 静态路由优先级、缺省路由总结

    千次阅读 2020-08-03 20:03:21
    静态路由 dis ip routing-table—查询路由表 dis interface 端口号—查看端口详细信息 IP route-static 目标ip 子网掩码 下一跳ip—配置静态路由 缺省路由 ip route-static 0.0.0.0 0 下一条ip—配置缺省路由(0.0....
  • 静态路由手动配置,动态路由对端设备给予,一般静态路由优先级动态路由高。 静态路由适合小型网络,在路由条目较多的环境下容易出错,需要管理员手动配置,可能会出现环路。 动态路由适合大型网络,不需要手动...
  • 在所有的路由中,静态路由优先级最高。当动态路由与静态路由发生冲突时,以静态路由为准 动态路由  是网络中的路由器之间相互通信,传递路由信息,利用收到的路由信息更新路由器表的过程。它能实时地适应网络结构的...
  • 静态路由和动态路由

    2021-01-05 11:38:05
    静态路由 选取最优路由时的标准: 1.子网掩码长度最长的最...每种协议metric值定义的都不同,静态路由和路由优先级有关,这是人为指定的,RIP协议跳数有关,跳数越小越优先,OSPF协议带宽有关,带宽最大最优先。met
  • 在操作系统上, 同网段IP是通过二层方式直接通信, 不经过网关,成为了一个根深蒂固的观念, 就算在有直连路由的同时也配置同网段的静态路由, 也不会有人怀疑直连路由的优先级, 认为还是会优先二层通信, 特别是玩过...
  • 路由和静态路由

    2021-04-11 10:09:04
    路由和静态路由 一、路由的基本原理 1.路由 *路由:找到去往不同网段的路 *路由选路:路由器负责为数据包选择最佳的传输路径 2.路由器: *作用:链接不同的网络,为数据包寻找去往目标地址最佳的出口。路由器的...
  • 76:路由优先级:(preference,思科:管理距离)衡量路由的优先程度,到达同一个目标又两种路由协议,此时优选路由优先级较小的路由协议。 路由优先级方位0~255 常见路由协议默认的优先级: 直连路由 0 静态路由 60 ...
  • 接口在PPPoE模式下如何修改优先级? 同时存在PPPoE拨号宽带固定IP宽带的情况下,为什么要修改优先级和管理距离?  ①Wan1接口在设置为PPPoE...默认情况下,新建静态路由管理距离默认为10,优先级默认为0(需...
  • 静态路由配置示例与路由的优先级

    千次阅读 2019-01-02 22:00:00
    现要求通过配置静态路由实现不同网段的任意两台主机之间能够互通。 1. 基本配置思路分析 静态路由的配置比较简单, 虽然在1 0.3. 1 小节介绍静态路由命令时看起来参数选项比较多, 但实际上在配置静态路由时就是...
  • #路由优先级 ## 什么是路由优先级? 指的是路由优先程度(思科的称为管理距离),衡量路由的优先程度,到达同一个目标由两种路由协议,此时优选路由优先级较小的路由协议 ... 静态路由:60 RIP:10...
  • 学习基于前人的PPT维基百科、百度百科等一系列权威资料。学习笔记仅个人学习用,便于...根据路由器学习路由信息、生成并维护路由表的方法包括直连路由(Direct)、静态路由(Static)和动态路由(Dynamic)。 直连路...
  • 路由静态动态

    2021-03-10 22:05:19
    2、静态路由 定义 适用环境 元素 部署 3、动态路由 定义 分类 按照使用范围进行分类 按照协议的特点进行分类 按照是否传递网络掩码进行分类 二、路由配置 1、永久静态路由配置 控制层面: 数据层面: ...
  • Track与nqa联动 VS 静态路由优先级相同 有蛮长一段时间没有写博客了,下面就来说一下Track与nqa联动 VS 静态路由优先级相同的情况,也不知道对不对,请指正!请看下图:说明:SWA是机房1的,SWB是机房2的,SWC是某...
  • 配置静态路由,动态路由,默认路由

    万次阅读 多人点赞 2019-07-30 16:06:09
    一、什么是路由 路由(routing)是指分组从源到目的地时,决定端到端路径的网络范围的进程[1]。路由工作在OSI参考模型第三层——网络层的数据包转发设备。路由器通过转发数据包来实现网络互连。虽然路由器可以支持...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 26,452
精华内容 10,580
关键字:

动态路由和静态路由的优先级