精华内容
下载资源
问答
  • 基于eNSP的华为设备--单臂路由配置,静态路由配置,RIP动态路由配置,OSPF动态路由配置华为模拟器配置单臂路由功能快捷键合理的创建标题,有助于目录的生成如何改变文本的样式插入链接与图片如何插入一段漂亮的代码...

    基于eNSP的华为设备--单臂路由配置,静态路由配置,RIP动态路由配置,OSPF动态路由配置

    华为模拟器配置单臂路由

    拓扑图如下在这里插入图片描述

    拓扑图简介:
    两个二层交换机下,有vlan 10 和vlan 20 ,网关在路由器,设置一个单臂路由使vlan 10 与vlan 20可以通信。

    路由器R1:
    #
    interface GigabitEthernet0/0/0.1
     dot1q termination vid 10
     ip address 192.168.1.1 255.255.255.0
     arp broadcast enable
    #
    interface GigabitEthernet0/0/0.2
     dot1q termination vid 20
     ip address 192.168.2.1 255.255.255.0
     arp broadcast enable
    #
    interface GigabitEthernet0/0/1
     ip address 10.10.1.1 255.255.255.0
    #
    //配置时记得进行dot1q进行封装:
     dot1q termination vid 10       /dot1q封装,对应所属vlan
     arp broadcast enable         /启用arp广播
     //创建以及开启VLAN
     int vlan 10
     vlan 10
     
    

    对于交换机LSW1 与LSW2
    设置vlan 将其放入相应端口

    LSW1:
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet0/0/5
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet0/0/10
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/11
     port link-type access
     port default vlan 20
     #
    

    将PC设置好静态地址,则可以Ping通。

    华为模拟器配置静态路由

    拓扑图如下:
    在这里插入图片描述

    实验目的:配置静态路由,使两边PC能够ping通。

    路由器R12 与R13:

    R-12:
    interface GigabitEthernet0/0/0
     ip address 10.10.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.1.1 255.255.255.0
     dhcp select global
    
    ip route-static 192.1.4.0 255.255.255.0 10.10.1.2
    //华为模拟器和思科模拟器在静态路由配置上的区别。
    
    //DHCP 的配置:
    
    dhcp enable  //打开dhcp
    ip pool test   //配置地址池的名字
    gateway-list  192.168.1.1  //配置网关地址
    network 10.1.1.0 mask 24 //配置地址池地址
    excluded-ip-address 10.1.1.2 10.1.1.5   //不允许分配的地址
    
    R -13配置等同类似
    

    华为模拟器配置RIP路由

    拓扑如图:
    在这里插入图片描述目的:为三个路由器配置rip协议,实现动态路由

    R2上的配置:
    //Rip -v2的配置
    rip 1
     undo summary
     version 2
     network 192.168.1.0
     network 192.168.2.0
    #
    //包括其后的端口及ip配置
    //以及PC上静态配置ip
    

    R3上的配置

    #
    interface GigabitEthernet0/0/0
     ip address 192.168.2.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.3.1 255.255.255.0
    #
    rip 1
     undo summary  //自动取消汇总
     version 2
     network 192.168.2.0
     network 192.168.3.0
    #
    
    //查看路由命令
     display ip routing-table 
     display ip routing-table protocol rip 
    

    华为模拟器配置单区域OSPF

    在这里插入图片描述
    配置OSPF为什么最好设置一个环回口呢?意义和好处是什么?

    A:回环口IP可以做为路由器的管理IP,而且回环口IP是路由器ID取值的第一标准,如果配置了回环口IP,那么这个IP就是路由器的ID,如果没有配置回环口IP,那么路由器ID就选取物理接口上IP最大的作为ID,而且环回口都是UP状态,除非路由器挂掉,不会频繁变动,因此路由器不必频繁重新向邻居介绍自己或者是更新路由状态,可以减少不必要的开销。

    答疑以后,下面是命令

    设置回环口:

    //  设置回环口,并设置IP地址
    
    [Huawei]int LoopBack 5
    [Huawei-LoopBack5]ip add 10.10.2.4 24
    
    

    配置OSPF的命令:

    ospf 1 router-id 10.0.1.1
     area 0.0.0.0
      network 10.0.1.0 0.0.0.255
      network 10.0.12.0 0.0.0.255
    #
    

    华为模拟器配置多区域OSPF

    拓扑图如下:
    在这里插入图片描述

    //用红线标出来的地方,分别是area 1 ,area 0 和 area 2

    设置环回口,设置接口及其IP地址,设置OSPF及不同区域,将不同的区域中添加上不同的网段即可。

    R-14的配置:

    #
    interface GigabitEthernet0/0/0
     ip address 10.0.0.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     ip address 12.0.0.1 255.255.255.0
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.0
    #
    ospf 1 router-id 1.1.1.1
     area 0 
      network 1.1.1.0 0.0.0.255
      network 12.0.0.0 0.0.0.255
     area 1
      network 10.0.0.0 0.0.0.255
    #
    其他的以此类推!
    
    展开全文
  • 文章目录什么是动态路由和概述动态路由特点动态路由如何实现动态路由协议选择依据:度量值收敛动态路由协议分类什么是RIPRIP的基本概念路由表的形成RIP的度量值与更新时间RIP协议防环机制RIP路由协议版本区别RIP配置...

    什么是动态路由和概述

    动态路由是与静态路由相对的一个概念,指路由器能够根据路由器之间的交换的特定路由信息自动地建立自己的路由表,并且能够根据链路和节点的变化适时地进行自动调整。当网络中节点或节点间的链路发生故障,或存在其它可用路由时,动态路由可以自行选择最佳的可用路由并继续转发报文。
    动态路由概述:动态路由概述:路由器之间用来交换信息的语言

    动态路由特点

    1.减少了网络管理
    2.占用了网络带宽(少量,可忽略不计)

    动态路由如何实现

    基于某种路由协议实现

    动态路由协议

    路由之间用来交换信息的语言

    选择依据:度量值

    跳数、带宽、时延、可靠性、成本、负载
    路由器会通过度量值来确定最优路由路径

    收敛

    使所有路由器都到达一致状态的过程

    动态路由协议分类

    距离矢量路由协议
    ——依据从源网络到目标网络所经过的路由器的个数选择路由 - - RIP、IGIP(思科私有协议)
    链路状态路由协议
    ——综合考虑从源网络到目标网络的各条路径的情况选择路由 - - OSPF、ISIS

    什么是RIP

    RIP(Routing Information Protocol,路由信息协议)是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法(DistanceVectorAlgorithms),使用“跳数”(即metric)来衡量到达目标地址的路由距离。这种协议的路由器只关心自己周围的世界,只与自己相邻的路由器交换信息,范围限制在15跳(15度)之内,再远,它就不关心了。RIP应用于OSI网络七层模型的应用层。各厂家定义的管理距离(AD,即优先级)如下:华为定义的优先级是100,思科定义的优先级是120。

    RIP的基本概念

    RIP是距离矢量路由选择协议
    定期更新(更新路由表)
    邻居
    广播更新
    全路由表更新
    RIP有两个版本:广播更新、组播更新

    路由表的形成

    1.路由器会学习到直连路由
    2.rip更新周期30s,每30s路由器会向邻居发送路由表
    3.路由器学习到相邻路由的非直连网段
    4.从哪个接口上学习过来的,nexthop下一跳就是那个接口
    5.再过30s,第二个更新周期到了再次发送路由表,路由器学习并再次更新路由条目

    RIP的度量值与更新时间

    RIP度量值为跳数
    ——最大跳数为15跳,16跳为不可达
    RIP更新时间
    ——每隔30s发送路由更新消息,UDP520端口
    RIP路由更新消息
    ——发送整个路由表信息

    RIP协议防环机制

    路由毒化
    ——当路由器发现路由链路进行变更或者down掉后,会将这个路由毒化,标志为16跳,不可达
    水平分割
    水平分割可以阻止路由环路的发生
    ——从一个接口学习到路由信息,不再从这个接口发送回去,同时也能减少路由更新信息占用的链路带宽资源

    RIP路由协议版本区别

    在这里插入图片描述
    1.版本1是有类路由协议,有固定边界,不能进行子网划分
    2.版本1是通过广播更新的,版本2是组播224.0.0.9
    3.版本1自动路由汇总无法关闭,版本2是支持自动路由汇总,可以手动关闭
    4.版本1不支持不连续子网,版本2支持不连续子网

    RIP配置命令

    【R1】rip 1 启动RIP
    【R1 - rip - 1】version 2 启动版本2(缺省版本1)
    【R1 - rip - 1】undo summary 关闭路由自动聚合(即所有路由信息都会按照IP地址分类归类)
    【R1 - rip - 1】network x.x.x.x 宣告网段
    【R1 - rip - 1】network x.x.x.x 宣告网段

    展开全文
  • 使用思科的YDT-RouteSim路由模拟器设计的RIP动态路由配置,教会你如何使用思科路由配置你的网络!
  • 为了安全的原因,我们可以在相同OSPF区域的路由器上启用身份验证的功能,只有经过身份验证的同一区域的路由器才能互相通告路由信息。在默认情况下OSPF不使用区域验证。通过两种方法可启用身份验证功能,纯文本身份 ...
  • 第一步:首先是设置配置文件的配置列表,然后在配置读取配置类上增加刷新注解@RefreshScope import lombok.extern.slf4j.Slf4j; import org.springframework.boot.context.properties.ConfigurationProperties; ...

    第一步:首先是设置配置文件的配置列表,然后在配置读取配置类上增加刷新注解@RefreshScope

    
    import lombok.extern.slf4j.Slf4j;
    import org.springframework.boot.context.properties.ConfigurationProperties;
    import org.springframework.cloud.context.config.annotation.RefreshScope;
    import org.springframework.cloud.gateway.filter.FilterDefinition;
    import org.springframework.cloud.gateway.route.RouteDefinition;
    import org.springframework.http.MediaType;
    import org.springframework.stereotype.Component;
    
    import javax.validation.Valid;
    import javax.validation.constraints.NotNull;
    import java.util.ArrayList;
    import java.util.Arrays;
    import java.util.List;
    
    /**
     * @author :lhb
     * @date :Created in 2020-09-09 08:59
     * @description:GateWay路由配置
     * @modified By:
     * @version: $
     */
    @Slf4j
    @RefreshScope
    @Component
    @ConfigurationProperties(prefix = "spring.cloud.gateway")
    public class GatewayRoutes {
        /**
         * 路由列表.
         */
        @NotNull
        @Valid
        private List<RouteDefinition> routes = new ArrayList<>();
    
        /**
         * 适用于每条路线的过滤器定义列表
         */
        private List<FilterDefinition> defaultFilters = new ArrayList<>();
    
        private List<MediaType> streamingMediaTypes = Arrays
                .asList(MediaType.TEXT_EVENT_STREAM, MediaType.APPLICATION_STREAM_JSON);
    
        public List<RouteDefinition> getRoutes() {
            return routes;
        }
    
        public void setRoutes(List<RouteDefinition> routes) {
            this.routes = routes;
            if (routes != null && routes.size() > 0 && log.isDebugEnabled()) {
                log.debug("Routes supplied from Gateway Properties: " + routes);
            }
        }
    
        public List<FilterDefinition> getDefaultFilters() {
            return defaultFilters;
        }
    
        public void setDefaultFilters(List<FilterDefinition> defaultFilters) {
            this.defaultFilters = defaultFilters;
        }
    
        public List<MediaType> getStreamingMediaTypes() {
            return streamingMediaTypes;
        }
    
        public void setStreamingMediaTypes(List<MediaType> streamingMediaTypes) {
            this.streamingMediaTypes = streamingMediaTypes;
        }
    
        @Override
        public String toString() {
            return "GatewayProperties{" + "routes=" + routes + ", defaultFilters="
                    + defaultFilters + ", streamingMediaTypes=" + streamingMediaTypes + '}';
        }
    }
    

    第二步:配置监听nacos监听器

    
    import cn.hutool.core.exceptions.ExceptionUtil;
    import com.alibaba.fastjson.JSONObject;
    import com.alibaba.nacos.api.NacosFactory;
    import com.alibaba.nacos.api.PropertyKeyConst;
    import com.alibaba.nacos.api.config.ConfigService;
    import com.alibaba.nacos.api.config.listener.Listener;
    import com.alibaba.nacos.api.exception.NacosException;
    import lombok.extern.slf4j.Slf4j;
    import org.apache.commons.collections.CollectionUtils;
    import org.apache.commons.collections.MapUtils;
    import org.springframework.beans.factory.annotation.Autowired;
    import org.springframework.beans.factory.annotation.Value;
    import org.springframework.cloud.context.scope.refresh.RefreshScope;
    import org.springframework.cloud.gateway.event.RefreshRoutesEvent;
    import org.springframework.cloud.gateway.route.RouteDefinition;
    import org.springframework.cloud.gateway.route.RouteDefinitionWriter;
    import org.springframework.context.ApplicationEventPublisher;
    import org.springframework.context.ApplicationEventPublisherAware;
    import org.springframework.stereotype.Component;
    import reactor.core.publisher.Mono;
    
    import javax.annotation.PostConstruct;
    import javax.annotation.Resource;
    import java.util.List;
    import java.util.Map;
    import java.util.Properties;
    import java.util.Set;
    import java.util.concurrent.ConcurrentHashMap;
    import java.util.concurrent.Executor;
    import java.util.concurrent.TimeUnit;
    import java.util.stream.Collectors;
    
    /**
     * @author :lhb
     * @date :Created in 2020-09-08 16:39
     * @description:监听nacos配置变更
     * @modified By:
     * @version: $
     */
    @Slf4j
    @Component
    public class GateWayNacosConfigListener implements ApplicationEventPublisherAware {
    
        @Autowired
        private RouteDefinitionWriter routedefinitionWriter;
    
        private ApplicationEventPublisher publisher;
    
        private static final Map<String, RouteDefinition> ROUTE_MAP = new ConcurrentHashMap<>();
    
        @Autowired
        private GatewayRoutes gatewayRoutes;
        @Resource
        private RefreshScope refreshScope;
    
        @Value(value = "${spring.cloud.nacos.config.server-addr}")
        private String serverAddr;
        @Value(value = "${spring.cloud.nacos.config.group:DEFAULT_GROUP}")
        private String group;
        @Value(value = "${spring.cloud.nacos.config.namespace}")
        private String namespace;
    
        private String routeDataId = "gateway-routes.yml";
    
        @PostConstruct
        public void onMessage() throws NacosException {
            log.info("serverAddr={}", serverAddr);
    
            Properties properties = new Properties();
            properties.put(PropertyKeyConst.SERVER_ADDR, serverAddr);
            properties.put(PropertyKeyConst.NAMESPACE, namespace);
            ConfigService configService = NacosFactory.createConfigService(properties);
            this.publisher(gatewayRoutes.getRoutes());
            log.info("gatewayProperties=" + JSONObject.toJSONString(gatewayRoutes));
            configService.addListener(routeDataId, group, new Listener() {
                @Override
                public Executor getExecutor() {
                    return null;
                }
    
                @Override
                public void receiveConfigInfo(String config) {
                    log.info("监听nacos配置: {}, 旧的配置: {}, 新的配置: {}", routeDataId, gatewayRoutes, config);
                    refreshScope.refresh("gatewayRoutes");
                    try {
                        TimeUnit.SECONDS.sleep(5);
                    } catch (InterruptedException e) {
                        log.error(ExceptionUtil.getMessage(e));
                    }
                    publisher(gatewayRoutes.getRoutes());
                }
            });
        }
    
        private boolean rePut(List<RouteDefinition> routeDefinitions) {
            if (MapUtils.isEmpty(ROUTE_MAP) && CollectionUtils.isEmpty(routeDefinitions)) {
                return true;
            }
            if (CollectionUtils.isEmpty(routeDefinitions)) {
                return true;
            }
    
            Set<String> strings = ROUTE_MAP.keySet();
            return strings.stream().sorted().collect(Collectors.joining())
                    .equals(routeDefinitions.stream().map(v -> v.getId()).sorted().collect(Collectors.joining()));
        }
    
        /**
         * 增加路由
         *
         * @param def
         * @return
         */
        public Boolean addRoute(RouteDefinition def) {
            try {
                log.info("添加路由: {} ", def);
                routedefinitionWriter.save(Mono.just(def)).subscribe();
                ROUTE_MAP.put(def.getId(), def);
            } catch (Exception e) {
                e.printStackTrace();
            }
            return true;
        }
    
        /**
         * 删除路由
         *
         * @return
         */
        public Boolean clearRoute() {
            for (String id : ROUTE_MAP.keySet()) {
                routedefinitionWriter.delete(Mono.just(id)).subscribe();
            }
            ROUTE_MAP.clear();
            return false;
        }
    
        /**
         * 发布路由
         */
        private void publisher(String config) {
            this.clearRoute();
            try {
                log.info("重新更新动态路由");
                List<RouteDefinition> gateway = JSONObject.parseArray(config, RouteDefinition.class);
                for (RouteDefinition route : gateway) {
                    this.addRoute(route);
                }
                publisher.publishEvent(new RefreshRoutesEvent(this.routedefinitionWriter));
            } catch (Exception e) {
                e.printStackTrace();
            }
        }
    
        /**
         * 发布路由
         */
        private void publisher(List<RouteDefinition> routeDefinitions) {
            this.clearRoute();
            try {
                log.info("重新更新动态路由: ");
                for (RouteDefinition route : routeDefinitions) {
                    this.addRoute(route);
                }
                publisher.publishEvent(new RefreshRoutesEvent(this.routedefinitionWriter));
            } catch (Exception e) {
                e.printStackTrace();
            }
        }
    
        @Override
        public void setApplicationEventPublisher(ApplicationEventPublisher app) {
            publisher = app;
        }
    
    }
    
    

    第三步:配置nacos的yml文件:

    spring:
      cloud:
        gateway:
          discovery:
            locator:
              enabled: true
              lower-case-service-id: true
          routes:
            # 认证中心
            - id: firefighting-service-user
              uri: lb://firefighting-service-user
              predicates:
                - Path=/user/**
              #          - Weight=group1, 8
              filters:
                - StripPrefix=1
              # 转流服务
            - id: liveStream
              uri: http://192.168.1.16:8081
              predicates:
                - Path=/liveStream/**
              #          - Weight=group1, 8
              filters:
                - StripPrefix=1
            - id: firefighting-service-directcenter
              uri: lb://firefighting-service-directcenter
              predicates:
                - Path=/directcenter/**
              filters:
                - StripPrefix=1
            - id: firefighting-service-datainput
              uri: lb://firefighting-service-datainput
              predicates:
                - Path=/datainput/**
              filters:
                - StripPrefix=1
            - id: firefighting-service-squadron
              uri: lb://firefighting-service-squadron
              predicates:
                - Path=/squadron/**
              filters:
                - StripPrefix=1
            - id: firefighting-service-iot
              uri: lb://firefighting-service-iot
              predicates:
                - Path=/iot/**
              filters:
                - StripPrefix=1
            - id: websocket
              uri: lb:ws://firefighting-service-notice
              predicates:
                - Path=/notice/socket/**
              filters:
                - StripPrefix=1
            - id: firefighting-service-notice
              uri: lb://firefighting-service-notice
              predicates:
                - Path=/notice/**
              filters:
                # 验证码处理
                #            - CacheRequest
                #            - ImgCodeFilter
                - StripPrefix=1
            - id: websocket
              uri: lb:ws://firefighting-service-notice
              predicates:
                - Path=/notice/socket/**
              filters:
                - StripPrefix=1
            - id: firefighting-service-supervise
              uri: lb://firefighting-service-supervise
              predicates:
                - Path=/supervise/**
              filters:
                - StripPrefix=1
            - id: firefighting-service-new-supervise
              uri: lb://firefighting-service-new-supervise
              predicates:
                - Path=/new/supervise/**
              filters:
                - StripPrefix=2
            - id: firefighting-service-train
              uri: lb://firefighting-service-train
              predicates:
                - Path=/train/**
              filters:
                - StripPrefix=1
            - id: firefighting-support-user
              uri: lb://firefighting-support-user
              predicates:
                - Path=/support/**
              filters:
                - StripPrefix=1
            - id: firefighting-service-firesafety
              uri: lb://firefighting-service-firesafety
              predicates:
                - Path=/firesafety/**
              filters:
                - StripPrefix=1
            - id: firefighting-service-bigdata
              uri: lb://firefighting-service-bigdata
              predicates:
                - Path=/bigdata/**
              filters:
                - StripPrefix=1
            - id: firefighting-service-act-datainput
              uri: lb://firefighting-service-act-datainput
              predicates:
                - Path=/act_datainput/**
              filters:
                - StripPrefix=1
            - id: firefighting-service-publicity
              uri: lb://firefighting-service-publicity
              predicates:
                - Path=/publicity/**
              filters:
                - StripPrefix=1
            - id: firefighting-service-preplan
              uri: lb://firefighting-service-preplan
              predicates:
                - Path=/preplan/**
              filters:
                - StripPrefix=1
            - id: firefighting-service-uav
              uri: lb://firefighting-service-uav
              predicates:
                - Path=/uav/**
              filters:
                - StripPrefix=1
            - id: firefighting-service-ard-mgr
              uri: lb://firefighting-service-ard-mgr
              predicates:
                - Path=/ard_mgr/**
              filters:
                - StripPrefix=1
            - id: admin-server
              uri: lb://admin-server
              predicates:
                - Path=/adminsServer/**
              filters:
                - StripPrefix=1
    
    展开全文
  • 这里写自定义目录标题欢迎使用Markdown编辑器新的改变功能快捷键合理的创建标题,有助于目录的生成如何改变文本的样式插入链接与图片如何插入一段漂亮的代码片生成一个适合你的列表创建一个表格设定内容居中、居左、...

    中兴rip动态路由基本配置

    一、实验目的
    1:掌握RIP协议的配置实验 
    2:通过动态路由协议RIP实验学习路由的设置
    二、实验内容
    具体实验拓扑如下:
    在这里插入图片描述
    三、实验流程
    (一)配置任务说明

    成员 IP
    成员1 171.12.1.1
    成员2 171.42.1.1

    (二)实验配置过程
    1、路由器R1的基本配置
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    2、路由器R2的基本配置
    在这里插入图片描述
    四、查看和验证
    (一)实验结果查看
    路由表1:
    在这里插入图片描述

    路由表 2:
    在这里插入图片描述
    (二)实验结果验证
    在这里插入图片描述
    在这里插入图片描述
    Over~

    展开全文
  • springcloud gateway动态路由配置

    千次阅读 2020-03-11 13:36:24
    最近在给公司搭建的springcloud gateway框架,每次配置文件修改路由表信息之后就得重启或者重新发布,故采用动态路由配置功能。看了网上的资料,决定采用redis缓存机制实现。 欢迎使用Markdown编辑器 你好! 这是...
  • 提问:如何在设备上配置默认路由? 回答: Ruijie#configure terminal Ruijie (config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 0/0 10.0.0.1 ----路由下一跳接口为fa0/0,下一跳网关为10.0.0.1 ——————...
  •  我们通过配置基本路由,可以实现页面间的切换,但是如果在一个页面中有一列表标题,我们点击各个标题,就能进入到此标题所表示的内容页面中,这该如何实现呢,下面就要用到我们的动态路由了,实际效果如下图所示:...
  • - BGP是一种运行在AS与AS之间的动态路由协议,主要作用是在AS之间自动交换无环路由信息 - 以此来构建AS的拓扑图,从而消除路由环路并实施用户配置的路由策略。 - 目前公网网络条目众多,IGP协议无法承载,而BGP可以...
  • 面包屑 如图所示:是在element中获取的面包屑组件,...在路由配置meta对象存储信息,供当前配置路由使用 path: '/home', name: 'home', meta:{ arr:[ {text:"用户信息", icon:"el-icon-user-solid",linto:
  • 如何配置动态路由 在router/index下配置 { path:'/user:id',//使用:就可以将id变为动态绑定 name:'user' } 遇到的问题 组件会复用,生命周期函数不会被重新执行 解决方法 监听路由变化 watch watch:{ $route:(to...
  • gateway配置路由主要有两种方式,一种是用yml配置文件,一种是写代码里,这两种方式都是不支持动态配置的。如: 下面就来看看gateway是如何加载这些配置信息的。 1 路由初始化 无论是yml还是代码,这些配置最终...
  • 配置动态路由RIP协议

    2020-03-22 12:16:14
    一、网络结构 (1) 交换机与PC机、交换机与路由器的连接由以太网接口用直连线连接即可(每个设备会自动生成无数个以太网接口f0/0、f0/1……) (2) 路由器之间是广域网之间连接,必须用串口...1、终端配置 P...
  • 当不能通过动态路由协议学到一些目标网络的路由时,配置静态路由就会显得十分重要 需要更多网工学习资料,HCIA/HCIP/HCIE学习视频,可以点击:进入群聊 二、静态路由应用场景: 静态路由主要应用在小型网络中,三...
  • 动态路由协议的基本配置---RIP

    千次阅读 2016-12-14 21:44:37
    在上一篇博客中我们讲解了如何配置静态路由与缺省路由,这次,我们学习一下动态路由协议体系中的RIP协议。 RIP协议英文名称为Routing Information Protocol ,中文名称为路由信息协议。RIP是一种基于距离矢量算法的...
  • 1.1 实验目的 学会用RIP协议配置动态路由; 1.2 实验内容 学习关于RIP一些基本知识; 了解RIP协议的特点; 明确RIP缺点和优点; 学习如何配置基本RIP命令; 知道使用RIP协议所带来的问题。
  • 1、单页面应用 1.1、多页面应用 1.2、单页面应用 1.3、vue-router 2、安装vue-router 2.1、Install vue-router 2.2、生成目录介绍 ...6.1、动态路由实现 7、编程式导航 8、路由嵌套 9、路由元信息、 10、导航拦截

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 498
精华内容 199
关键字:

动态路由如何配置