精华内容
下载资源
问答
  • 一、配置IPv4静态路由 Router(config)# ip route network-address subnet-mask {ip-address | exit-inif} network-address – 要加入路由表远程网络目标网络地址,通常称为“前缀”。 subnet-mask – 要加入...

    一、配置IPv4静态路由

    Router(config)# ip route network-address subnet-mask {ip-address | exit-inif}

    • network-address – 要加入路由表的远程网络的目标网络地址,通常称为“前缀”。
    • subnet-mask – 要加入路由表的远程网络的子网掩码或仅掩码。
    • ip-address – 相连路由器将数据包转发到远程目标网络所用的 IP 地址。一般称为“下一跳”。
    • exit-intf – 用于将数据包转发到下一跳的送出接口

    配置下一跳静态路由

    R1(config)# ip route 172.16.1.0 255.255.255.0 172.16.2.2
    

    配置直连静态路由

    R1(config)# ip route 172.16.1.0 255.255.255.0 s0/0/0
    

    配置完全指定静态路由

    R1(config)# ip route 172.16.1.0 255.255.255.0 G0/1 172.16.2.2
    

    二、配置IPv4默认路由

    Router(config)# ip route 0.0.0.0 0.0.0.0 {ip-address | exit-inif}

    • ip-address – 相连路由器将数据包转发到远程目标网络所用的 IP 地址。一般称为“下一跳”。
    • exit-intf – 用于将数据包转发到下一跳的送出接口
    • 默认路由是特殊的静态路由,因为全0为所有网络且全0的子网掩码为全0

    配置默认默认路由

    R1(config)# ip route 0.0.0.0 0.0.0.0 172.16.2.2
    

    三、配置IPv6静态路由

    Router(config)# ipv6 route ipv6-prefix/prefix-length {ipv6-address | exit-inif}

    • ipv6-prefix – 要加入路由表的远程网络的目标网络地址。
    • prefix-length – 要加入路由表的远程网络的前缀长度。
    • ipv6-address --·通常称为下—跳路由器的IP地址。
    • exit-inif – 使用传出接口,将数据包转发到目标网络。

    下一跳静态 IPv6 路由

    R1(config)# ipv6 route 2001:DB8:ACAD:2::/64 2001:DBB:ACAD:4::2
    

    直连静态 IPv6 路由

    R1(config)# ipv6 route 2001:DB8:ACAD:2::/64 s0/0/0
    

    完全指定静态 IPv6 路由

    R1(config)# ipv6 route 2001:DB8:ACAD:2::/64 s0/0/0 fe80::2
    

    四、配置IPv6默认路由

    Router(config)# ipv6 route ::/0 {ipv6-address | exit-inif}

    • ::/0匹配任何IPv6前缀,而无论前缀长度。
    • ipv6-address – 相连路由器将数据包转发到远程目标网络所用的 IP 地址。一般称为“下一跳”。
    • exit-intf – 用于将数据包转发到下一跳的送出接口
    • 默认路由是特殊的静态路由,因为全0为所有网络且全0的子网掩码为全0

    配置默认默认路由

    R1(config)# ipv6 route ::/0 2001:DB8:ACAD:4::2
    

    五、验证路由

    IPv4

    • show ip route
    • show ip route static
    • show ip route 网络

    IPv6

    • show ipv6 route
    • show ipv6 route static
    • show ipv6 route 网络

    六、静态和动态路由的优缺点

    静态路由

    优点 缺点
    易于在小型网络中实施。 仅适用于简单拓扑或特殊用途,如默认静态路由。
    非常安全。与动态路由协议相比,不会发送通告。 随着网络的不断扩大,配置复杂性会显著增加。
    总是通过同—路径到达目的网络 需要人工干预来重新路由流量。
    不需要路由算法或更新机制;因此,不需要额外的资源(CPU 或 RAM) 。

    动态路由

    优点 缺点
    适用于需要多个路由器的所有拓扑中。 可能会使实施更加复杂。
    通常不受网络规模限制 不够安全.需要其他配置设置来确保安全。
    如果可以,请自动适应拓扑以重新路由流量。 根据当前网络拓扑结构确定路径
    需要占用额外的CPU、RAM和链路带宽。

    七、RIP的配置

    尽管在现代网络中极少使用 RIP,但是作为了解基本网络路由的基础则十分有用。本部分简要概述如何配置基本 RIP 设置和如何验证 RIPv2
    RIP可以理解为告诉你旁边的路由器你的邻居有那些

    开启与关闭RIPv1

    请使用 router rip 命令启用 RIP。该命令并不直接启动 RIP 进程。而是在配置了 RIP 路由设置的情况下提供对路由器配置模式的访问。当启用 RIP 时,默认版本为 RIPv1。 可使用 no router rip 全局配置命令,禁用并消除 RIP。该命令会停止 RIP 进程并清除所有现有的 RIP 配置。

    R1(config)# router rip					# 开启RIP
    R1(config-router)#
    
    R1(config)# no router rip				# 关闭RIP
    

    启用 RIPv2

    配置了 RIP 进程的思科路由器会默认运行 RIPv1。但它可以同时解释 RIPv1 和 RIPv2 消息。使用 version 2 路由器配置模式命令启用 RIPv2。请注意现在RIP 进程在所有更新中包含子网掩码,所以 RIPv2 是一种无类路由协议。

    R1(config)# router rip
    R1(config-router)# version 2
    

    通告网络

    进入 RIP 路由器配置模式后,路由器便按照指示开始运行 RIPv1。但路由器还需了解应该使用哪个本地接口与其它路由器通信,以及需要向其它路由器通告哪些本地连接的网络。 要为网络启用 RIP 路由,请使用网络 network network-address 路由器配置模式命令。输入每个直连网络的有类网络地址。
    此命令在每 30 秒一次的 RIP 路由更新中向其它路由器通告该指定网络。
    注:RIPv1 是 IPv4 的一个有类路由协议。因此,如果输入子网地址,IOS 会自动将其转换到有类网络地址。 例如,输入 network 192.168.1.32 命令会在运行配置文件中自动转换到 network 192.168.1.0。IOS 不提示错误消息,而会纠正该输入,并输入有类网路地址。

    R1(config)# router rip
    R1(config-router)# network 192.168.1.0			# 通告网络
    R1(config-router)# network 192.168.2.0
    R1(config-router)# 
    

    禁用自动汇总(禁止地址聚合)

    默认情况下,RIPv2 像 RIPv1 一样在主网边界上自动汇总网络。使用 no auto-summary 路由器配置模式命令,修改默认 RIPv2 自动汇总行为当使用 RIPv1 时,此命令无效。 当已禁用自动汇总时,RIPv2 不会再将网络汇总到其在边界路由器上的有类地址。
    注:禁用自动汇总之前必须启用 RIPv2。

    R1(config)# router rip
    R1(config-router)# no auto-summary
    

    被动接口

    默认情况下,将 RIP 更新从所有启用 RIP 的接口发出。但是,RIP 更新信息实际上仅需要从连接到其他启用 RIP 路由器的接口发出。
    在这里插入图片描述

    例如,请参考图 1 中的拓扑结构。即使此 LAN 上没有 RIP 设备,RIP 也会将更新通过其 G0/0 接口发送出去。 R1 无法得知该 LAN 上是否有 RIP 设备,因此每 30 秒就会发送一次更新。在 LAN 上发送不需要的更新会在以下三个方面对网络造成影响:浪费带宽、浪费资源、安全风险。使用 passive-interface 路由器配置命令阻止通过路由器接口传输路由更新,但是仍然允许将该网络通告至其他路由器。可使用 passive-interface default 命令将所有接口设为被动。不能设为被动的接口可以使用 no passive-interface 命令重新启用。
    注:所有路由协议都支持 passive-interface 命令。

    R1(config)# router rip
    R1(config-router)# passive-interface g0/0
    

    传播默认路由

    请参阅图 1。在此场景中,R1 是边缘路由器,单宿主到运营商。因此,使 R1 到达互联网的所有要求是从 Serial 0/0/1 接口发出的默认静态路由。
    在这里插入图片描述

    类似的默认静态路由可配置在 R2 和 R3 上,但是在边缘路由器 R1 上进入它一次,然后使 R1 通过 RIP 将其传播至所有其他路由器更具可扩展性。要在 RIP 路由域中为所有其它网络提供互联网连接,需要将默认静态路由通告给使用该动态路由协议的其它所有路由器。

    R1(config)# ip route 0.0.0.0 0.0.0.0 s0/0/1 209.165.200.226
    R1(config)# router rip
    R1(config-router)# default-information originate
    

    验证RIP路由

    show ip protocols 命令用于显示路由器当前配置的 IPv4 路由协议设置。
    show ip route 命令用于显示安装在路由表中的 RIP 路由

    R1# show ip protocols
    R1# show ip route
    

    本文只用于学习与记录

    展开全文
  • 有: 1. Stub AS只有一个入口和一个出口网络。2. 转接AS(Transit AS)当数据从一个AS到另一个AS时,必须经过Transit...IGP使用的路由更新包比BGP使用的路由更新包更小(因此BGP承载更多的路由属性)。BGP可在给定路...

    有: 1. Stub AS

    只有一个入口和一个出口的网络。

    2. 转接AS(Transit AS)

    当数据从一个AS到另一个AS时,必须经过Transit AS。

    如果企业网络有多个AS,则在企业

    网络中可设置Transit AS。

    IGP和BGP最大的不同之处在于运行协议的设备之间通过的附加信息的总数不同。IGP使用的路由更新包比BGP使用的路由更新包更小(因此BGP承载更多的路由属性)。BGP可在给定的路由上附上很多属性。

    当运行BGP的两个路由器开始通信以交换动态路由信息时,使用TCP端口179,他们依赖于面向连接的通信(会话)。

    BGP必须依靠面向连接的TCP会话以提供连接状态。因为BGP不能使用Keepalive信息(但在普通头上存放有Keepalive信息,以允许路由器校验会话是否Active)。标准的Keepalive是在电路上从一个路由器送往另一个路由器的信息,而不使用TCP会话。路由器使用电路上的这些信号来校验电路没有错误或没有发现电路。  某些情况下,需要使用BGP:

    ? 当你需要从一个AS发送流量到另一个AS时;

    ? 当流出网络的数据流必须手工维护时;

    ? 当你连接两个或多个ISP、NAP(网络访问点)和交换点时。

    以下三种情况不能使用BGP:

    ? 如果你的路由器不支持BGP所需的大型路由表时;

    ? 当Internet只有一个连接时,使用默认路由;

    ? 当你的网络没有足够的带宽来传送所需的数据时(包括BGP路由表)。

    【学习】路由协议配置-OSPF

    OSPF配置

    一、OSPF协议特点

    链路状态协议Open Short Path First

    国际开放标准,任何公司均可使用

    Link-state advertisements 链路状态公告

    传递的是链路状态而不是路由表

    LSA将被存储-转发到区域中所有路由器

    OSPF 的链路状态数据被收集到OSPF路由器中

    OSPF采用SPF算法来计算出到达目标的最短路径

    Link(链路)=路由器接口

    State=接口及与其相邻路由器关系的描述

    分区域的协议(骨干区域和下级区域共存为AS)

    Cost=10^8/bandwidth

    任何节点手工汇总,支持不连续网络

    二、OSPF配置

    Router(config)#router OSPF proceed-id(进程号)

    进程号与其他路由器无关是本地的进程

    Router(confi...路由协议(RIP、OSPF、EIGRP和BGP) 整理5

    【学习】路由协议配置-EIGRP

    EIGRP配置

    一、EIGRP协议特点

    混合型路由协议

    无类路由协议

    主播方式更新

    快速收敛

    减少带宽消耗

    支持多种网络层协议

    路由边界自动汇总(不用特定处理时,不支持不连续网络,对于RIP、IGRP也是一样,边界自动汇总)

    EIGRP的三种数据库

    邻居关系数据库

    拓扑结构数据库Destination Successor(最佳) Feasible Susccesser(备用)

    路由表显示

    展开全文
  • 在分析静态和动态路由之前,我们先看什么是路由?在互联网上,有大量信息要传递,大量信息就是大量数据包,数据包和生活中快递包裹一样,有发件人收件人地址。快递包裹是由快递公司各个节点,一下一下转发...

    在分析静态和动态路由之前,我们先看什么是路由?

    在互联网上,有大量的信息要传递,大量的信息就是大量的数据包,数据包和生活中的快递包裹一样,有发件人收件人地址。

    快递包裹是由快递公司的各个节点,一下一下转发到目的地。

    数据包则是由互联网上的各个路由器,一下一下转发到目的地,数据包走的路径,我们叫做路由。

    路由器如何进行路由选择?

    对快递公司来说,会查看一个包裹的目的地,但不是一下把完整的地址看完,而是只看省份,这样效率就比较高,因为快递公司只需要将这个包裹送到目的省份的分公司就好了,目的省份的分公司,再去查看地址后面的部分,也就是某市,这样再送去相关的城市。然后市公司的节点,再查看细节部分。

    对路由器来讲,看的是数据包的目标ip地址,而ip地址分为网络位和主机位,相当于普通快递包裹的省份信息,和后面的细节信息。

    当然,路由器和快递公司一样,一开始不需要看完整的ip,只要看网络位进行路由选择即可。

    如图,当RA收到一个数据包,会查看数据包的网络位,也就是ip地址前面的部分,如果是192.168开头,则发给RB,如果是10开头,则发给RC,而不需要查看完整的ip

    路由表长这样

    这里是RA的路由表,RA会根据路由表进行数据包的转发。

    路由表里的路由条目是怎么来的呢?

    可以使用静态手工配置,也可以使用动态自动学习。

    静态路由的优点是指哪打哪,只要配置的时候不打错,那么路由就不会错。

    而且静态路由非常的省资源,是人类写好的,不需要机器再去做各种学习和计算。

    静态路由也有缺点,就是当路径非常复杂的时候

    这时去往一个目标,需要配置多条路由(因为高可靠性网络往往需要主路径,备路径,备备路径),还要配置路由的优先级,还要配置路由的健康检测,一系列下来,工作量巨大不说,因为附加了很多复杂的技术(bfd,dldp等),路由器的工作压力也会大起来,这时就不适合用静态路由了。

    这种复杂的高可靠性网络,我们都会选用动态路由,动态路由的优点是,路由器可以自动学习到各种路由条目,包括主路由备路由备备路由,而且自动进行健康检测,知道路由是否失效,是否要切换。

    当然,相比单纯的静态路由,使用动态路由的话,路由器需要交换协议报文,路由计算,路由检测等,会消耗一定的运算资源和带宽资源。

    最后,总结一下

    静态路由适合比较简单的网络拓扑,而动态路由适合比较复杂的网络拓扑。

    但简单并不代表规模小,也有些大型网络项目,采用虚拟化等技术,将多台价值百万的高端路由设备,虚成一台逻辑设备,简化拓扑,然后使用静态路由。

    如图,在某省会城市大型政务网项目,4台12510x(就是很厉害的一个设备),通过irf技术,虚拟成1台逻辑设备,简化拓扑,然后使用简单的静态路由。

    以上,是个人见解,如有想法,请移步评论区哦!

    如果你看到了这里,百哥想请你帮个小忙:

    1.帮我点赞,喜欢,收藏三连,方便你最快找到百哥,也让更多的人真正爱上ICT技术,学好ICT技术

    2.关注我和专栏,这是一个会陪你至少10年的技术号,定期分享ICT技术。

    3.关注我的直播课百哥的直播 自助自取哦听百哥讲云计算,让你的技术之路走的更顺遂。

    展开全文
  • 主要为大家介绍了动态路由协议概念、分类、组成部分和优缺点,路由协议主要好处,只要网络拓扑结构发生了变化,路由器就会相互交换路由信息,不仅能够自动获知新增加网络,还可以在当前网络连接失败时找出备用...
  • 动态路由协议优点:

    动态路由协议的优点

    1. 配置管理方便
    2. 针对拓扑的变化进行自动的重新收敛
    3. 适用于中大型网络,复杂的网络

    动态路由协议的缺点

    1. 选路不佳——环路
    2. 占用硬件资源
    3. 安全

    衡量一个动态路由协议好坏的标准

    1. 选路佳
    2. 占用资源少
    3. 收敛速度快

    动态路由协议的分类

    根据AS(自治系统)区分IGP、EGP,AS自治系统自治系统号——0-65535 其中1-64511公有 ,64512-65535私有

    • IGP 内部网关协议,IGP负责一个AS内部的沟通;— RIP、OSPF、 EIGRP 、ISIS
    • EGP 外部网关协议,EGP负责AS间的沟通; —EGP V1-V2、BGP V1–V4 V4+

    NA部分主要学习IGP,IGP从两个方面分类:
    1、根据更新路由条目时是否携带子网掩码分为:

    • 有类别动态路由协议(不携带子网掩码)
    • 无类别动态路由协议(携带子网掩码)

    2、基于工作特点分为:

    • DV距离矢量(包括:RIP/EIGRP)类似纸质地图
    • LS链路状态(包括:OSPF/ISIS) 类似电子地图

    DV距离矢量工作特点:路由器共享路由表互相学习,更新路由表。
    LS链路状态工作特点:不仅更新路由表,还更新拓扑(告诉别人它在哪),可以计算路由最佳路径,所以需要算法支撑。

    展开全文
  • 认识动态路由协议:什么是动态路由协议:路由协议是用于路由器之间交换路由信息协议。动态路由协议分为内部网关协议(IGP)和外部网关协议(EGP)。通过路由协议,路由器可以动态共享有关远程网络信息,路由协议可以...
  • 静态路由主要有以下几种用途:在不会显著增长的小型网络中,使用静态路由便于维护...静态路由的优点和缺点通过比较,我们可以列出每种路由方式的优点。一种方式的优点也就是另一种方式的不足之处。静态路由的优点...
  • 在分析静态和动态路由之前,我们先看什么是路由?在互联网上,有大量信息要传递,大量信息就是大量数据包,数据包和生活中快递包裹一样,有发件人收件人地址。快递包裹是由快递公司各个节点,一下一下转发...
  • 在分析静态和动态路由之前,我们先看什么是路由?在互联网上,有大量信息要传递,大量信息就是大量数据包,数据包和生活中快递包裹一样,有发件人收件人地址。快递包裹是由快递公司各个节点,一下一下转发...
  • 动态路由

    2021-04-05 13:50:58
    动态路由的优缺点 动态路由的度量值 动态路由的收敛 静态路由与动态路由的比较 动态路由协议分类 距离矢量路由协议 链路状态路由协议 距离矢量路由协议 链路状态路由协议 RIP路由协议 RIP的基本概念 ...
  • 或存在其它可用路由时,动态路由可以自行选择最佳的可用路由并继续转发报文动态路由原理:动态路由的运作依赖路由器的两个基本功能:路由器之间适时的路由信息交换,对路由表的维护1、路由器之间适时地交...
  • 动态路由协议分类

    千次阅读 2015-12-03 10:21:12
    路由器根据路由表生成方式可以分为:直连路由,静态路由,动态路由 动态路由协议很多有点复杂。本文介绍一下动态路由的优缺点和分类。
  • 网络 :动态路由

    2021-03-07 14:23:20
    动态路由的优缺点 优点 :实时基于拓扑的变化而进行路由表的收敛 缺点 : 额外占用硬件资源 安全风险 计算错误的风险 动态路由协议的分类 AS ---- 自治系统 :标准编号 0 – 65535,其中1-64511为共有,64512-...
  • 4.1.1动态路由选择协议原理 动态路由选择协议通过大量控制消息传输来维护它们路由表,路由刷新信息是其中重要控制消息。路由刷新信息通常可以构造出部分或全部路由表,通过分析来自所有路由器刷新消息,...

空空如也

空空如也

1 2 3 4 5 ... 10
收藏数 187
精华内容 74
关键字:

动态路由的优缺点