精华内容
下载资源
问答
  • 思科路由器如何配置VLAN的IP
    千次阅读
    2021-07-20 02:25:01

    我们的思科路由器如何配置VLAN的IP呢?想必很多网络技术的新手都不清楚,所以小编这里就推荐下配置VLAN的IP方法和介绍VLAN给你们认识认识。

    VLAN:英文全称为Virtual Local Area Network,中文称虚拟局域网,VLAN其实就相当于一个小型网络的统称,如校园网内有三个不同网段,分别为10.0.0.0、172.16.1.0和192.168.1.0,我们可以分别将这三个网段划分为三个不同的VLAN,以便于管理。举个例子,只允许10.0.0.0网段访问172.16.1.0网段,不能访问192.168.1.0网段,此时VLAN的好处显露无疑。今天笔者同大家分享思科路由器如何配置VLAN的IP。

    1、启动计算机并连接到思科路由器,进入VLAN配置模式。在命令行提示符下键入以下命令,然后按ENTER键

    host1(config)#interface fastEthernet 4/0

    请注意,在这个例子中,我们指定的VLAN使用的是快速以太网连接,标有“快速以太网”。

    2、对VLAN进行封装,输入以下命令:

    host1(config-if)#encapsulation vlan

    3、创建一个子接口的VLAN,这将主机的IP,通过添加一个子识别号码。键入以下命令,然后按ENTER键。

    host1(config-if)#interface fastEthernet 4/0.35

    4、指定的VLAN ID,通过键入以下命令

    Read more: How to Configure a VLAN IP | eHow.com "host1(config-if)#vlan id 333",

    5、分配给VLAN的IP地址,在命令提示符下键入以下命令,然后按回车键。

    host1(config-if)#IP address 192.168.1.13 255.255.255.0

    通过这5个命令,你就成功在路由器上的VLAN配置了IP地址了,是不是很简单呢。

    小编这里再给大家推荐下思科路由器常见的配置,以便于你们接下来的学习。

    怎么给路由器配置IP?

    router(config)#interface fastethernet 0/1

    router(config-if)#ip address 192.168.1.100 255.255.255.0

    router(config-if)#no shutdown

    怎么给交换机配置IP?

    switch(config)#interface vlan 1

    switch(config-if)#ip address 192.168.1.100 255.255.255.0

    switch(config-if)#no shutdown

    静态路由配置方式:

    router(config)#ip route 192.168.1.0 255.255.255.0 192.168.10.1

    默认路由配置方式:

    router(config)#ip route 0.0.0.0 0.0.0.0 192.168.10.1

    浮动路由配置:

    router(config)#ip route 192.168.1.0 255.255.255.0 192.168.10.1 50

    router(config)#ip route 0.0.0.0 0.0.0.0 192.168.10.1 50

    给交换机配置默认网关,方便管理

    switch(config)#ip default-gateway 192.168.2.254

    辅助地址配置:

    switch(config-if)#ip address 192.168.1.1 255.255.255.0 secondary

    更多相关内容
  • Centos 给网卡添加第二IP 地址

    千次阅读 2021-05-15 04:25:46
    有的时候我们购买了服务器需要申请多个 IP ,那么申请的 IP 该怎么添加进系统呢?添加单个 IP 地址:在/etc/sysconfig/network-scripts/中新建文件ifcfg-eth0:*,*为数字序号,多个IP则依次增大以 ifcfg-eth0:1 为例...

    重要:本文最后更新于2017-03-19 15:05:51,某些文章具有时效性,若有错误或失效,请在下方留言。

    有的时候我们购买了服务器需要申请多个 IP ,那么申请的 IP 该怎么添加进系统呢?

    3f7ab320873c9ec0530271c9de02d5f5.png

    添加单个 IP 地址:

    在/etc/sysconfig/network-scripts/中新建文件ifcfg-eth0:*,*为数字序号,多个IP则依次增大

    以 ifcfg-eth0:1 为例,建立文件ifcfg-eth0:1

    仿照 /etc/sysconfig/network-scripts/ifcfg-eth0 文件,增加一个新增虚拟端口的文件 如:

    #复制一份 ifcfg-eth0,重命名为 ifcfg-eth0:1

    cp /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0:1

    编辑 ifcfg-eth0:1 文件:

    vi /etc/sysconfig/network-scripts/ifcfg-eth0:1

    只需要修改其中的 DEVICE=eth0:1 IPADDR=你需要添加的 IP,然后重启网络 service network restart 骚等一分钟等连上网络。

    多个 IP 只需要新建多个 ifcfg-eth0:1~255 文件,并修改 DEVICE 和 IPADDR 。

    展开全文
  • Ubuntu配置IP

    万次阅读 2019-03-20 12:39:30
    1 修改配置interfaces文件 1.1 打开文件 命令: sudo vim /etc/network/interfaces 1.2 在原内容下添加内容 光标滑到最后一行,按“o”键添加行。 加入: auto eth0 iface eth0 inet static address 10.214.161....

    1 修改配置interfaces文件

    1.1 打开文件

    命令:

    sudo vim /etc/network/interfaces
    

    1.2 在原内容下添加内容

    光标滑到最后一行,按“o”键添加行。

    加入:

    auto eth0          
    iface eth0 inet static  
    address 10.214.161.240     
    netmask 255.255.255.0      #子网掩码
    gateway 10.214.161.1        #默认网关
    

    其中,

    eth0 为网卡号,需要自行修改为你自己的。
    address 为IP地址,自行设置。
    netmask 为子网掩码,一般默认为255.255.255.0,不用改。
    gateway 为网关,需要自行修改为你自己的。

    2 修改DNS

    2.1 打开文件

    命令:

    sudo vim /etc/resolve.conf
    

    2.2 修改文件

    nameserver 127.0.0.1
    nameserver 8.8.8.8
    

    其中,

    第一行一般是默认的,
    第二行需要修改为你自己的DNS服务器。

    3 重启网络

    命令:

    sudo /etc/init.d/networking restart
    

    4 重新查看并确认配置

    命令:

    ifconfig -a
    

    在这里插入图片描述
    看到 inet addr 为我们先前配置的ip,说明已经配置成功。

    5 若还未成功

    根据本人血泪的教训,若还未成功,试试:

    1. 确认网线是未损坏的。 2. 确认接口是正常的,包括主机和交换机的接口。 3. 重启试试。
    展开全文
  • eNSP交换机配置IP

    千次阅读 2022-03-20 12:24:20
    这里写自定义目录标题欢迎使用Markdown编辑器新的改变功能快捷键合理的创建标题,有助于目录的生成如何改变文本的样式插入链接与图片如何... 这是你一次使用 Markdown编辑器 所展示的欢迎页。如果你想学习如何使用Mar

    交换机的配置

    在聊交换机设置IP的前,首先聊以下方面,这也是为了新手更好的去理解。如果基础的可以直接看VLAN的命令的配置
    1、交换机的工作原理
    2、VLAN的的作用
    3、 VLAN的命令配置

    交换机的工作原理

    1、学习:把数据包的SMAC(源MAC地址)与接收端口对立,将MAC以及对应的IP地址记录到MAC地址表中。
    2、泛洪:把广播报文发送到除接收端口以外的端口。
    3、转发:根据DMAC查MAC地址表转发
    4、丢弃:收到不识别的报文,丢弃。
    交换机的所有接口都属于同一个广播域。在现实生活中,考虑到不同部门的设备可能连在同一个交换机上,又不能进行数据共享。
    需要将不同的部分隔离开,数据不互通。下面就介绍解决这问题的方法————VLAN

    VLAN

    1、VLAN的作用:隔离广播域。使为一个VLAN都是单独的广播域。	共有4096个VLAN,可用VLAN 1~4094个
    2、VLAN的接口类型:①access:接入链路需要配置。例:交换机与终端相连的接口
    									②trunk:干道链路。例:交换机和交换机相连的接口,允许多个VLAN流量通过。
    									③hybrid:混合链路
    3、在不通过的VLAN 里面,设备是不能通信的。除非给交换机配置IP地址,配置完IP以后,可以当交换机来用。
    

    VLAN命令配置

    实验拓扑图:在这里插入图片描述
    设置VLAN面对的是交换机的配置
    1、给PC机配置IP地址
    在这里插入图片描述
    2、交换机配置:
    ①[Huawei]vlan 10 单一创建VLAN
    [Huawei-vlan10]
    [Huawei]vlan batch 10 20 批量创建,创建了VLAN 10 和VLAN 20
    补:VLAN 1是交换机默认的,所有的接口都在VLAN 1 里面。
    [Huawei]int vlanif 10 进入创建的VLAN 10 里
    [Huawei-Vlanif10]ip address 192.168.1.1 24 给VLAN 10 创建IP地址 配置方法跟接口的配置方法一样

    • [Huawei-Vlanif10]dis this 查看配置的IP地址是否配置正确
      - interface Vlanif10 ip address 192.168.1.254 255.255.255.0
      - return
      [Huawei-Ethernet0/0/1]port link-ty access 在PC机相接的接口配置access,
      [Huawei-Ethernet0/0/1]port default vlan 10 允许VLAN 10 的数据通过。
      【完】
      上面配置的VLAN IP,对于PC机来说是网关。
      以上就是对交换机设置IP的步骤
      注:此时的交换机可以当路由器来用了。

    格外的小实验

    实验内容:
    按上拓补图,在交换机上创建VLAN 10 和VLAN 20 ,并依据上图提供的IP地址网段,配置交换机和PC机。
    使其不同的VLAN通信。
    实验步骤 :
    1、创建 VLAN 10 和VLAN 20
    2、给VLAN 10 和VLAN 20 创建IP
    3、基于接口,设置接口类型
    4、设置PC的基本配置,网关设置为交换机VLAN的IP
    答案:
    交换机的全部配置——————dis cu(可以看所有的配置)
    interface Vlanif10
    ip address 192.168.1.254 255.255.255.0

    interface Vlanif20
    ip address 192.168.2.254 255.255.255.0

    interface Ethernet0/0/1
    port link-type access
    port default vlan 10

    interface Ethernet0/0/2
    port link-type access
    port default vlan 20
    【完】

    展开全文
  • AIX系统网络IP配置(smit)

    千次阅读 2020-04-30 17:40:04
    一、IP配置 1、输入命令 smit tcpip: 2、选择"Minimum Configuration & Startup": 3、选择网卡: 4、输入hostname、IP、子网掩码、默认网关: 5、输入后,回车生效: 6、输入 ifconfig -a ,...
  • CentOS配置静态IP

    千次阅读 2020-06-27 23:11:27
    一、为什么要在CentOS中配置...、在NAT模式下配置centOS中的静态ip的方法 1、设置虚拟机的网卡类型为NAT 模式 点击“编辑虚拟机设置”: 选择NAT模式: 2、查找子网IP、子网掩码、网关IP参数 点击“虚拟网络编辑器
  • 使用CLI在交换机上配置IP地址设置

    千次阅读 2021-07-15 02:06:59
    kmgmt3029-Upgrade-Firmware-Cisco-Business-Mobile-app目标交换机可以有多个IP地址。每个IP地址都可分配给指定接口或端口、链路聚合组(LAG)或虚拟局域网(VLAN)。...交换机的IP地址可以手动配置或从动态主...
  • Linux虚拟机ip配置

    千次阅读 2022-04-09 10:13:05
    随机分配IP地址 1、 修改网卡的配置信息: ...配置静态IP 之前设置以dhcp的方式生成IP,每次联网的时候都会分配一个IP使用,也就是说IP可能会变,所以才使用静态IP。 1、修改配置信息 vi /etc/sysconfi...
  • Centos7 配置静态IP地址

    千次阅读 2022-02-26 15:35:08
    Centos7 配置静态、动态IP地址一、配置静态IP地址第一步:进入存放修改IP地址的目录: ```cd /etc/sysconfig/network-scripts/```第二步:修改ip地址的文件:```vim ifcfg-ens33```第三步:查看网关: 编辑--》虚拟...
  • 主要是用四种方法(1)Ifconfig命令一种使用ifconfig命令配置网卡的ip地址。此命令通常用来零时的测试用,计算机启动后ip地址的配置将自动失效。具体用法如下。Ipconfig ethx ipadd netmask x.x.x.x。其中ethx中的...
  • centos7配置ip

    千次阅读 2018-09-05 17:43:44
    安装完centos7,重启就可以与linux一次接触了。我是最小化安装,所以没有图形界面。登录介面显示发型版本和内核版本: CentOS Linux 7(Core) Kernel 3.10.0-862.e17.x86_64 on an x86_64 下面就是登录提示...
  • linux下配置ip地址四种方法(图文)

    千次阅读 2021-05-09 02:54:33
    本文转自,http://nanwangting.blog.51cto.com/608135/200097配置IP方式有两种:1、通过命令直接配置sudo ifconfig eth0 IP地址 netmask 子网掩码------配置IP地sudo route add default gw 网关------...
  • windows配置多个IP

    万次阅读 2018-07-11 13:45:35
    许多时候,我们需要在单网卡的情况下进行多个IP配置,如本机需要连接同一交换机下不同网段的设备。
  • Linux网络配置配置网络IP地址)

    千次阅读 2021-04-20 21:59:40
    Linux主机配置网络IP地址 一、配置网络配置文件 #Linux服务器网络配置文件在/etc/sysconfig/network-scripts下 [root@localhost network-scripts]# ls ifcfg-ens33 ifdown-eth ifdown-post ifdown-Team ifup-aliases...
  • 刚安装虚拟机,可能会没有IP,也没有对应的 配置文件 ifcfg-eth01. 使用命令 :service network restart 生成文件ifcfg-eth0进入该文件的位置 /etc/sysconfig/network-scripts/ifcfg-eth02. 编辑该文件 vi ifcfg-...
  • cisco配置vlan和ip

    千次阅读 2020-10-26 19:00:45
    vlan 2 name v2 exit 将交换机端口分配给vlan 2.1 分配接入端口 interface FasEthernet0/1 switchport mode access switchport access clan 2 exit 2.2 分配共享端口 interface FastEthernet0/3 switchport mode...
  • [TCP/IP] TCP/IP 详解 卷1 协议 第2版 (英文版)

    千次下载 热门讨论 2013-12-28 09:00:19
    [Addison-Wesley Professional] TCP/IP 详解 卷1 协议 第2版 (英文版) [Addison-Wesley Professional] TCP/IP Illustrated Volume 1 The Protocols 2nd Edition (E-Book) ☆ 图书概要:☆ TCP/IP Illustrated, ...
  • 如何配置Linux系统的IP地址?

    万次阅读 多人点赞 2017-03-20 08:28:08
    如何配置Linux系统的IP地址,使其能够连接局域网甚至外网。其实这并不难,Linux系统网络配置的方法有多种。下面,以VMware虚拟机中的Linux系统为例,进行讲解。我的真实机是Windows系统,网络连接的详细信息如下:已...
  • Ubuntu配置和修改IP地址

    千次阅读 2020-12-30 17:55:40
    1、修改配置文件/etc/network/interfacesroot@ubuntu:~#sudo gedit /etc/network/interfaces添加以下内容:auto eth0 #设置自动启动eth0接口iface eth0 inet static #配置静态IPaddress 192.168.11.88 #IP地址...
  • Ip地址的配置与解释

    万次阅读 多人点赞 2018-10-11 00:05:21
    以Windows10系统为列,打开控制面板,找不到控制面板可以直接在搜索框输入“控制面板”: 控制面板➡网络和Internet➡网络和共享中心...这IP地址的设置界面,我们一般需要设置IP地址、子网掩码、默认网关与DNS服务...
  • kali 配置静态ip的坑

    千次阅读 2022-02-18 23:32:52
    但是kali默认ip配置是DHCP模式,每次连接登录还需要看一眼kali的ip,为了方便起见,配置静态的较好。 可能是版本的问题,收集到,配置文件的目录有两个 /etc/network/interfaces.d/ifcfg-eth0 /etc/network/interfa
  • 重磅推出,TCP/IP路由技术(第二卷)(全新翻译版),真正高清带完整书签版,网络技术人员的福音。 本书在《tcp/ip路由技术(第一卷)》的基础上,深入系统地阐述了tcp/ip相关高级路由技术,包括bgp、多播、ipv6以及网络...
  • suse linux中为单网卡配置IP的方法

    千次阅读 2021-05-11 15:32:55
    永久配置的方法:知道在Linux下网卡被称为eth0,eth1,eth2.....,所有网卡的配置文件都存储在/etc/sysconfig/network/下,文件名是以ifcfg-eth0,ifcfg-eth1,ifcfg-eth2....来命名的。一块网卡对应一个配置文件。如果...
  • IP网络配置

    千次阅读 2019-04-19 10:34:08
    TCP/IP协议想要运行正常的话,网络中的主机和路由器不可避免地需要配置一些信息(如接口的IP地址等)有了这些配置信息主机/路由器才能提供/使用特定的网络服务。主机信息的必要元素有: IP地址,子网掩码,DNS服务器...
  • ubuntu配置静态IP教程

    千次阅读 2021-04-08 16:45:32
    下边介绍第二种修改配置文件的方法: 点个赞加个关注吧! 后记:这个配置文件是yaml文件,所以一般报错,都是跟格式有关。 温馨提示:服务器配置IP之后,如果网线不是连接状态,即使配置完成后IP也不会显示...
  • Ubuntu 18.04配置静态IP地址

    千次阅读 2021-08-13 14:49:34
    在本文中,我们将解释如何使用Netplan实用程序在Ubuntu 18.04中为网络接口配置网络静态或动态IP地址。 想把ubuntu的ip地址设置成静态ip,折腾了一段时间,还是无法成功,特从网上搜了一下,发现设置ip的方式改了。 ...
  • Linux下配置网卡ip别名何谓ip别名? 用windows的话说,就是为一个网卡配置多个ip。 什么场合增加ip别名能派上用场? 布网需要、多ip访问测试、特定软件对多ip的需要…and so on. 下面通过几个例子简单介绍一下如何...
  • 华为路由器配置ip

    千次阅读 2021-04-06 09:59:16
    设备ip配置 基础命令配置 进入系统视图模式 修改设备主机名为R1 退出当前模式 save保存 配置路由接口ip地址 使用display ip interface brief查看接口与ip等摘要信息 退出当前接口配置 配置路由第二个接口ip...
  • VMware虚拟机NAT模式配置静态IP

    千次阅读 2022-03-26 22:16:04
    VM在NAT模式下,设置虚拟机的静态IP

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,347,572
精华内容 539,028
关键字:

如何配置第二ip