精华内容
下载资源
问答
  • 2019-04-24 07:34:57

    在这里插入图片描述

    拓补说明

    PC1和PC2经过交换机1和交换机2通过OSPF路由协议实现互联互通

    操作步骤

    1. 交换机1的配置
    <Huawei>system-view                                      #进入系统视图
    [Huawei]sysname  Switch1                                 #配置系统名称为 Switch1
    [Switch1]vlan 10                                         #创建VLAN 10
    [Switch1-vlan10]quit                                     #退出VLAN 10视图
    [Switch1]vlan 30                                         #创建VLAN 30
    [Switch1-vlan30]quit                                     #退出VLAN 30视图
    [Switch1]interface  GigabitEthernet 0/0/2                #进入千兆以太网接口 G 0/0/2 
    [Switch1-GigabitEthernet0/0/2]port link-type access      #配置端口链路类型为 ACCESS
    [Switch1-GigabitEthernet0/0/2]port default  vlan  10     #配置端口默认 VLAN 为10
    [Switch1-GigabitEthernet0/0/2]quit                       #退出千兆以太网接口 G 0/0/2
    [Switch1]interface  GigabitEthernet  0/0/1               #进入千兆以太网接口 G 0/0/1
    [Switch1-GigabitEthernet0/0/1]port link-type access      #配置端口链路类型为 ACCESS
    [Switch1-GigabitEthernet0/0/1]port default  vlan 30      #配置端口默认 VLAN 为30
    [Switch1-GigabitEthernet0/0/1]quit                       #退出千兆以太网接口 G 0/0/1
    [Switch1]interface  Vlanif  10                           #进入 VLANIF 10接口
    [Switch1-Vlanif10]ip address  10.10.10.1 24              #配置IP地址为10.10.10.1 掩码长度为24位
    [Switch1-Vlanif10]quit                                   #退出 VLANIF 10接口
    [Switch1]interface Vlanif 30                             #进入 VLANIF 30接口
    [Switch1-Vlanif30]ip address  10.10.30.1 24              #配置IP地址为10.10.30.1 掩码长度为24位
    [Switch1-Vlanif30]quit                                   #退出 VLANIF 30接口
    [Switch1]ospf 1 router-id 10.10.30.1                     #创建 OSPF 进程1 路由ID为10.10.30.1
    [Switch1-ospf-1]area  0.0.0.0                            #进入OSPF 区域 0.0.0.0(骨干区域)
    [Switch1-ospf-1-area-0.0.0.0]network  10.10.10.0 0.0.0.255      #发布网段 10.10.10.0 反掩码为0.0.0.255
    [Switch1-ospf-1-area-0.0.0.0]network  10.10.30.0 0.0.0.255      #发布网段 10.10.30.0 反掩码为0.0.0.255
    

    交换机2的配置

    <Huawei>system-view                                      #进入系统视图
    [Huawei]sysname Switch2                                  #配置系统名称为 Switch2
    [Switch2]vlan 20                                         #创建VLAN 20
    [Switch2-vlan20]quit                                     #退出VLAN 20视图
    [Switch2]vlan 30                                         #创建VLAN 30
    [Switch2-vlan30]quit                                     #退出VLAN 30视图
    [Switch2]interface  GigabitEthernet  0/0/1               #进入千兆以太网接口 G 0/0/1
    [Switch2-GigabitEthernet0/0/1]port link-type access      #配置端口链路类型为 ACCESS  
    [Switch2-GigabitEthernet0/0/1]port default  vlan 30      #配置端口默认 VLAN 为30
    [Switch2-GigabitEthernet0/0/1]quit                       #退出千兆以太网接口 G 0/0/1
    [Switch2]interface GigabitEthernet 0/0/2                 #进入千兆以太网接口 G 0/0/2
    [Switch2-GigabitEthernet0/0/2]port link-type access      #配置端口链路类型为 ACCESS  
    [Switch2-GigabitEthernet0/0/2]port default  vlan  20     #配置端口默认 VLAN 为20 
    [Switch2-GigabitEthernet0/0/2]quit                       #退出千兆以太网接口 G 0/0/2
    [Switch2]interface  Vlanif  20                           #进入 VLANIF 20接口
    [Switch2-Vlanif20]ip address  10.10.20.1 24              #配置IP地址为10.10.20.1 掩码长度为24位
    [Switch2-Vlanif20]quit                                   #退出 VLANIF 20接口
    [Switch2]interface  Vlanif  30                           #进入 VLANIF 30接口
    [Switch2-Vlanif30]ip address  10.10.30.2 24              #配置IP地址为10.10.30.2 掩码长度为24位
    [Switch2-Vlanif30]quit                                   #退出 VLANIF 30接口
    [Switch2]ospf 1 router-id  10.10.30.2                    #创建 OSPF 进程1 路由ID为10.10.30.2
    [Switch2-ospf-1]area 0.0.0.0                             #进入OSPF 区域 0.0.0.0(骨干区域)
    [Switch2-ospf-1-area-0.0.0.0]network  10.10.30.0 0.0.0.255         #发布网段 10.10.30.0 反掩码为0.0.0.255 
    [Switch2-ospf-1-area-0.0.0.0]network  10.10.20.0 0.0.0.255         #发布网段 10.10.20.0 反掩码为0.0.0.255
    

    验证配置

    配置PC1
    在这里插入图片描述配置PC2
    在这里插入图片描述在PC1上PING PC2 10.10.20.1,通了。
    在这里插入图片描述

    更多相关内容
  • 实验十一 配置 OSPF 路由协议 111 路由协议 OSPF 概述 OSPF 路由协议是一种典型的链路状态路由协议用于一个自治系统内部在这个自治 系统中所有的 OSPF 路由器都维护一个相同的描述这个自治系统结构的数据库其中存放 ...
  • 实验十一配置OSPF路由协议.pdf
  • 学习情境1-1-C配置OSPF路由协议 学习目标 能够正确使用华为VRP操作系统完成OSPF路由协议配置 能够正确验证RIP路由的配置结果 教学资源 1OSPF路由配置实训指导书 2相关教学课件PPT 3任务单技能评价表 4. 设备PC机...
  • 探讨在路由器上配置OSPF路由协议.pdf
  • 目录一、OSPF的简单概述1.1 OSPF是链路状态型路由协议1.2 OSPF基础知识1.3 OSPF工作原理描述二、OSPF的特点三、ospf单区域配置实验3.1 网络拓扑图3.2 IP地址配置3.3 OSPF配置四、实验结果测试五、最后 一、OSPF的...

    有理想,有抱负,懂得自律,相信在不久的将来你会成功的!

    打开微信搜索【孩子上学后】,关注这个不一样的程序员。

    一、OSPF的简单概述

    OSPF是一种链路状态型路由协议,采用链路状态类型,即使网络中有环路,也不会影响路由的数据传输,可以实现稳定的路由控制。

    另外OSPF支持子网掩码,由此,曾经的RIP协议中无法实现可变长的子网构造的网络路由控制成为现实。

    为了减少网络流量,OSPF还引入了 “区域” 的概念,区域是将一个自治的网络分为若干个更小的范围,因此可以减少路由协议之间不必要的交换。

    1.1 OSPF是链路状态型路由协议

    OSPF为链路状态路由器,路由器之间链路状态生成网络拓扑信息,然后再根据拓扑信息生成路由表。

    与哪个网络或者是与哪个路由器相连的信息需要通过接力的形式来传递,使每一个路由器都知道,路由器之间的信息。

    OSPF中掌握着整个网络的拓扑结构,可以从中找到最短路径来决定最终的路由选择。

    RIP的路由选择,要求途中所经过的路由器越少越好。与之相比,OSPF可以给每条链路赋予一个权重(也可以叫做代价),并始终选择一个权重最小的路径作为最终路由。

    1.2 OSPF基础知识

    在OSPF中,把连接在同一个链路的路由器称为相邻路由器。在一个相对简单的网络结构中,例如每个路由器仅仅跟一个路由连接时,相邻路由之间可以交换路由信息。所以缺点也就很明显了,要是这是个复杂的网络拓扑结构的话,每次交换的路由信息就会非常大。而且当网络比较稳定时,也需要定期进行交换,这在一定程度上浪费了网络的带宽。

    OSPF根据作用可以分为5种类型的包。

    通过发送hello包,确认是否连接,每个路由器为了同步路由控制信息,利用数据库描述包互相发送路由摘要信息和版本信息。如果版本太老,则首先发出一个链路状态请求路由控制信息,然后链路状态信息更新包接收路由状态信息,再通过链路状态确认包通知大家本地已经接收路由控制信息。

    1.3 OSPF工作原理描述

    OSPF中进行确认连接的协议叫做hello协议。

    LAN中每10秒发送一次hello包,如果没有hello包到达,可以判断连接是否断开。具体为,允许空等3次,直到第4次时仍无发聩,就认为连接已经断开。

    二、OSPF的特点

    • OSPF可以在大型网络中使用
    • 无路由自环
    • 使用带宽作为测量值
    • 收敛速度快
    • 通过分区实现高效网络管理

    三、ospf单区域配置实验

    3.1 网络拓扑图

    image-20201126141725477

    3.2 IP地址配置

    image-20201126141825903

    image-20201126141840470

    R2配置

    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo info	
    [Huawei]undo info-center ena	
    [Huawei]undo info-center enable 
    Info: Information center is disabled.
    [Huawei]inter	
    [Huawei]interface g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add	
    [Huawei-GigabitEthernet0/0/1]ip address 192.168.1.254 24
    [Huawei-GigabitEthernet0/0/1]inter g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add	
    [Huawei-GigabitEthernet0/0/0]ip address 192.168.2.1 24
    

    R1配置

    <Huawei>sys	
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo if	
    [Huawei]undo info	
    [Huawei]undo info-center en	
    [Huawei]undo info-center enable 
    Info: Information center is disabled.
    [Huawei]inter	
    [Huawei]interface g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add	
    [Huawei-GigabitEthernet0/0/0]ip address 192.168.2.2 24
    [Huawei-GigabitEthernet0/0/0]inter g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add	
    [Huawei-GigabitEthernet0/0/1]ip address 192.168.3.1 24
    
    

    R3配置

    <Huawei>sys	
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo info	
    [Huawei]undo info-center ena	
    [Huawei]undo info-center enable 
    Info: Information center is disabled.
    [Huawei]inter	
    [Huawei]interface g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip ad	
    [Huawei-GigabitEthernet0/0/0]ip address 192.168.3.2 24
    [Huawei-GigabitEthernet0/0/0]inter g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add	
    [Huawei-GigabitEthernet0/0/1]ip address 192.168.4.254 24
    

    3.3 OSPF配置

    R1配置

    [Huawei]router id 1.1.1.1	# 设置了路由器身份编号
    [Huawei]ospf 1	# 设置ospf进程号为1
    [Huawei-ospf-1]area 0	# 设置ospf的区域0
    [Huawei-ospf-1-area-0.0.0.0]netwo	
    [Huawei-ospf-1-area-0.0.0.0]network 192.168.2.0 0.0.0.255	
    [Huawei-ospf-1-area-0.0.0.0]netwo	
    [Huawei-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255
    

    network 192.168.2.0 0.0.0.255

    ]network 192.168.3.0 0.0.0.255

    上面两行命令是指将网络192.168.2.0 192.168.3.0通告给OSPF协议,0.0.0.255是该网络的反掩码。

    R2配置

    [Huawei]router id 2.2.2.2
    [Huawei]ospf 1
    [Huawei-ospf-1]area 0
    [Huawei-ospf-1-area-0.0.0.0]net	
    [Huawei-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255
    [Huawei-ospf-1-area-0.0.0.0]network 192.168.2.0 0.0.0.255
    

    R3配置

    [Huawei]router id 3.3.3.3
    [Huawei]ospf 1
    [Huawei-ospf-1]area 0
    [Huawei-ospf-1-area-0.0.0.0]net	
    [Huawei-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255
    [Huawei-ospf-1-area-0.0.0.0]network 192.168.4.0 0.0.0.255
    

    四、实验结果测试

    image-20201126153719491

    image-20201126153818765

    五、最后

    通过上面的实验内容,我们可以看出OSPF协议与RIP协议是有相似之处的,都是将协议发布到与该路由相邻网段中。但是两者算法确是不一样的,OSPF采用的是权值(代价)最小,而RIP采用的是路径最小。OSPF的功能更加强大,可以支持可变长子网掩码等等。

    我是啃书君,一个专注于学习的人,你懂的越多,你不懂的越多

    下一期内容,将要描述OSPF协议的多区域配置问题。

    展开全文
  • OSPF路由协议详解及配置

    千次阅读 2021-08-13 22:22:32
    文章目录一、OSPFv2基本概念1.1 OSPF的基本概念1.2 层次划分模型1.3 OSPF区域划分优势1.4 OSPF路由器类型1.5 OSPF路由类型1.6 OSPF支持的网络1.6.1 P2P1.6.2 广播型网络1.6.3 NBMA网络1.6.4 P2MP网络1.7 OSPF报文...

    一、OSPFv2基本概念

    1.1 OSPF的基本概念

    Open Shortest Path First开放最短路径优先协议
    由IETE开发、核心算法SPF
    无类路由协议、链路状态协议、IGP
    协议号89
    支持触发更新、增量更新、周期更新1800s、3600s失效
    协议优先级10
    组播更新地址:224.0.0.5(所有路由器)、224.0.0.6(DR/BDR)
    三张表:邻居表、链路状态数据库表、ospf路由表

    触发更新
    OSPF触发更新是说在一个OSPF area中,其中一台路由器的接口down掉或者链路状态信息发生变化,它便会发送组播分组来声明自己的新状态(以组播形式发送LSU),这个过程称作触发更新。

    增量更新
    只对变换的LSDB进行更新

    周期更新
    周期更新1800s,避免LS age3600s超时

    链路状态协议
    路由器会发送它的直连网段告诉对方形成邻居关系,对方学习到内容以后就会形成完整的网络拓扑结构,也就是形成了链路状态的结构。

    1.2 层次划分模型

    骨干模型:域间通信需经过骨干区域
    非骨干区域:常规区域间不能直接互相交换数据包

    只有一个区域时,区域号配置为非0会有什么问题?
    不利于后期扩展

    1.3 OSPF区域划分优势

    减小链路状态数据库同步范围、缩小LSA泛洪范围和SPF算法频率,从而便于管理

    1.4 OSPF路由器类型

    Internal Router内部路由器
    ABR区域边界路由器
    ASBR自治域边界路由器

    1.5 OSPF路由类型

    在这里插入图片描述

    1.6 OSPF支持的网络

    在这里插入图片描述
    P2P和广播可以建立邻接关系,但无法计算出路由,因为广播的DR/BDR需要224.0.0.6

    1.6.1 P2P

    仅支持两台路由器互连
    支持广播、组播
    在这里插入图片描述

    [Huawei]dis ospf peer 
    
    	 OSPF Process 1 with Router ID 1.1.1.1
    		 Neighbors 
    
     Area 0.0.0.0 interface 192.168.12.1(Serial1/0/0)'s neighbors
     Router ID: 2.2.2.2          Address: 192.168.12.2    
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: None   BDR: None   MTU: 0    
       Dead timer due in 36  sec 
       Retrans timer interval: 5 
       Neighbor is up for 00:00:07     
       Authentication Sequence: [ 0 ] 
    
    [Huawei]dis ospf lsdb 
    
    	 OSPF Process 1 with Router ID 1.1.1.1
    		 Link State Database 
    
    		         Area: 0.0.0.0
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     Router    2.2.2.2         2.2.2.2             48  48    80000002      48
     Router    1.1.1.1         1.1.1.1             47  48    80000002      48
    

    1.6.2 广播型网络

    两台或两台以上的路由器通过共享介质互连。
    支持广播、组播。
    在这里插入图片描述

    1.6.3 NBMA网络

    两台或两台以上路由器通过VC互连。
    不支持广播、组播。
    在这里插入图片描述

    1.6.4 P2MP网络

    多个点到点网络的集合。
    支持广播、组播。
    在这里插入图片描述

    1.7 OSPF报文

    1.7.1 OSPF五种报文

    在这里插入图片描述

    1.7.2 OSPF协议报文头部

    在这里插入图片描述
    Version :对于当前所使用的OSPFv2,该字段的值为2。
    Type:OSPF报文类型。
    Packet length:OSPF报文的总长度
    Router ID:发送该报文的路由器标识符
    Area ID:发送该报文的路由器所在区域
    Checksum:除了认证字段的整个报文的效验和
    Auth Type:0:不认证;1:简单明文密码认证;2:加密(MD5)认证。
    Authentication:认证所需的信息。该字段的内容随AuType的值不同而不同。
    在这里插入图片描述

    1.7.3 Option字段

    Option可选字段出现在每一个Hello数据包、DD和每个LSA中
    Option字段允许路由器和其他路由器进行一些可选性能的通信
    在这里插入图片描述
    DN:用来避免在MPLS VPN中出现环路。当PE向CE发送3类、5类和7类LSA时需要设置DN位,其他PE路由器从CE接收到该LSA时,不能够在它的OSPF路由计算中使用该LSA。
    O:该字段指出始发路由器支持Opaque LSA(类型9、类型10和类型11)。
    DC位:当始发路由器支持按需链路上的OSPF的能力时,该位将被设置。
    EA:当始发路由器具有接收和转发External-Attributes-LSA(type8 LSA)的能力时,该位被置位。
    N位:只用在Hello数据包中。N=1表明路由器支持7类LSA。N=0表明该路由器将不接收和发送NSSA LSA。
    P位:只用在NSSA LSA。该位将告诉NSSA区域的ABR路由器将7类LSA转换为5类LSA。
    MC位:当始发路由器支持转发组播数据包的能力时,该位将被置位。
    E位:当始发路由器具有接收AS-external-LSA(type5 LSA)的能力时,该位被置位。在所有5类LSA和始发于骨干区域以及非末节区域的LSA中,该位置为1。而始发于末节区域的LSA中,该位置为0。如果Hello报文中该位被置位则表明该接口具有接收和发送5类LSA的能力。
    MT位:表示始发路由器支持多拓扑OSPF。
    在这里插入图片描述

    1.7.4 五种OSPF报文格式

    1.7.4.1 Hello报文

    在这里插入图片描述
    Network Mask: 发送Hello接口所在网络的掩码
    Hello Interval:发送Hello的时间间隔
    Options: 可选项
    Rtr Pri: 8bit,DR优先级,默认1,如果为0不参与选举
    Router DeadInterval:邻居失效时间
    Designated Router:本网段上DR路由器的接口IP地址
    Backup Designated Router:本网段上BDR路由器的接口IP地址
    Neighbor:用Router ID标识
    在这里插入图片描述

    1.7.4.2 DD报文

    在这里插入图片描述
    Interface MTU: 16 位,表示在不分片的情况下,此接口最大可发出的IP报文长度。华为默认不填充接口实际MTU值,所以值为0
    Options: 含义同OSPF头中一致。
    I(Initialization)位:当发送连续多个DD报文时,如果这是第一个DD报文,则置为1;否则置为0
    M(More)位:当发送连续多个DD报文时,如果后续DD报文中不再有LSA头,则置为0
    M/S(Master/Slave)位:当两台OSPF路由器交换DD报文时,首先需要确定双方的主从关系,Router大的一方会成为Master当值为1表示发送方为Master
    DD Sequence Number: 32 位,DD报文序列号,主从双方利用序列号来保证DD报文传输的可靠性和完整性
    LSA Headers:本LSDB中LSA头部
    在这里插入图片描述

    1.7.4.3 LSR报文

    在这里插入图片描述
    LS type::32 位,LSA类型号。
    Link State ID:32位,根据LSA中的 LS Type 和LSA Description 在路由域中描一个LSA
    Advertising Router: 32位,产生此LSA的路由器Router ID

    这里的Link State ID和Advertising Router,跟DD报文中的LSA Header中的Link State ID和Advertising Router一模一样
    在这里插入图片描述

    1.7.4.4 LSU报文

    在这里插入图片描述
    Number ofLSAs:32位,表示Update中所包含的LSA的数量。
    LSAs:多个完整LSA的内容。
    在这里插入图片描述

    1.7.4.5 LSAck报文

    在这里插入图片描述
    LSA Headers:LSA头列表,OSPF通过LSA头对收到的完整LSA做确认。一份LSAck可以对多份LSU中的LSA做确认。
    在这里插入图片描述

    1.7.5 LSA类型

    在这里插入图片描述

    1.7.6 LSA报文头部

    在这里插入图片描述
    LS age:此字段表示LSA已经生存的时间,单位是秒。
    Option:该字段指出了部分OSPF域中LSA能够支持的可选性能。
    LS type:此字段标识了LSA的格式和功能。常用的LSA类型有五种。
    Link State ID:与LSA中的LS Type和Advertising Router一起用来在OSPF中唯一标识 LSA
    Advertising Router:产生此LSA的路由器的Router ID。
    Sequence Number:当LSA每次新的实例产生时,这个序列号就会增加。这个更新可以帮助其他路由器识别最新的LSA实例。
    Checksum:关于LSA的全部信息的校验和。因为Age字段,所以校验和会随着老化时间的增大而每次都需要重新进行计算。
    Length:是一个包含LSA头部在内的LSA的长度。
    在这里插入图片描述

    1.7.7 六种LSA报文格式

    1.7.7.1 Router-LSA

    在这里插入图片描述
    Link State ID:是指始发路由器的Router-ID。
    Advertising Router:发送该LSA1的Router-ID。

    Flag:
    V:置1时,说明始发路由器是一条或者多条具有完全邻接关系的虚链路的一个端点。
    E:当始发路由器是一个ASBR路由器时,该为置为1。
    B:当始发路由器是一个ABR路由器时,该为置为1。
    Number of links:表明一个LSA所描述的路由器链路数量。

    Link Type:
    值为1表示为点到点网络,常见的PPP链路需要使用点到点网络描述。
    值为2表示连接一个transit网络,有至少两台路由器的广播型网段或NBMA网段就是一种Transit网段。
    值为3表示连接stubnet网络,一般该网络上不存在邻居关系,如只有一个出口的以太网或回环接口。
    值为4表示虚链路。

    Link ID:
    Link Type为1时该值表示邻居路由器的路由器ID。
    Link Type为2时该值表示DR路由器的接口的IP地址。
    Link Type为3时该值表示IP网络或子网地址。
    Link Type为4时该值表示邻居路由器的路由器ID。

    Link Data:
    Link Type为1时该值表示和网络相连的始发路由器接口的IP地址。
    Link Type为2时该值表示和网络相连的始发路由器接口的IP地址。
    Link Type为3时该值表示网络的子网掩码。
    Link Type为4时该值表示始发路由器的虚链路接口的IP地址。

    ToS,暂不支持。

    Metric:是指一条链路或接口的代价。
    在这里插入图片描述
    在这里插入图片描述

    1.7.7.2 Network-LSA

    在这里插入图片描述
    Link State ID:是指DR的接口IP地址。
    Advertising Router:发送该LSA2的Router-ID。
    Network Mask:指定这个网络上使用的地址或者子网的掩码。
    Attached router:连接到本网络的所有邻居路由器的RouterID(包括DR的Router ID)
    在这里插入图片描述

    1.7.7.3 Network-Summary-LSA

    在这里插入图片描述
    Link State ID:对于3类LSA来说,表示所通告的网络或子网的IP地址。
    Advertising Router:发送该LSA3的Router-ID。
    Network Mask:对于3类LSA来说,表示所通告的网络的子网掩码。
    Metric:产生该LSA3的ABR到目标网络的开销值
    在这里插入图片描述

    1.7.7.4 ABSR-Summary-LSA

    在这里插入图片描述
    Link State ID:对于4类LSA来说表示所通告的ASBR路由器的路由器ID。
    Advertising Router:发送该LSA4的Router-ID。
    Network Mask:对于4类LSA来说,该字段没有实际意义,一般置为0.0.0.0。
    Metric:始发路由器到目的地址的路由的代价。

    在这里插入图片描述

    1.7.7.5 AS-External-LSA

    在这里插入图片描述
    Link State ID:引入的外部路由的网络号。
    Advertising Router:发送该LSA5的Router-ID。
    Network Mask:引入的外部路由的子网掩码。
    Eeternal Type:用来指定这条路由使用的外部度量的类型。如果该E bit设置为1,那么度量类型就是E2;如果该E bit设置为0,那么度量类型就是E1。默认2,仅考虑外部成本
    Metric:ASBR到外部网络的开销。
    Forwarding Address:是指到达所通告的目的地的数据包应该被转发到的地址。如果是0.0.0.0,访问外部网络的报文转发给ASBR,如果是非0,报文转发给该非0地址。
    External Route Tag:标记外部路由。在路由引入时配置给外部路由,默认值是1。
    在这里插入图片描述

    1.7.7.6 总结

    只有DD、LSAck包含LSA Header,LSU包含LSA整个部分
    LSR只包含LSA里面LS Type、LS ID、Advertising Router

    六种LSA对应的LS ID、Advertising Router
    1类、4类LSA的LS ID都是Router ID
    2类LS ID是DR接口IP地址
    3、5、7类LS ID是网络号
    所有类型LSA的Advertising Router都是发送者的Router ID

    Router-LSA中的link type、link id、link data。

    2、3、4、5、7类LSA都有Netmask ,4类LSA的Netmask为0

    二、OSPFv2原理描述

    2.1 形成OSPF邻居关系条件

    ①Router ID不冲突
    ②Area ID一致
    ③认证类型和密码一致
    ④网络号和掩码一致
    ⑤MA网络中,至少有一个路由器优先级不为0
    ⑥Hello、Dead时间一致
    ⑦区域类型一致
    ⑧MTU一致
    ⑨网络类型一致
    ⑩ospf静默接口不收不发

    2.2 OSPF状态机

    Down:这是邻居的初始状态,表示没有从邻居收到任何信息。在NBMA网络上,此状态下仍然可以向静态配置的邻居发送Hello报文,发送间隔为PollInterval,通常和Router DeadInterval间隔相同。

    Attempt:此状态只在NBMA网络上存在,表示没有收到邻居的任何信息,但是已经周期性的向邻居发送报文,发送间隔为HelloInterval。如果Router DeadInterval间隔内未收到邻居的Hello报文,则转为Down状态。

    Init:在此状态下,路由器已经从邻居收到了Hello报文,但是自己不在所收到的Hello报文的邻居列表中,表示尚未与邻居建立双向通信关系。在此状态下的邻居要被包含在自己所发送的Hello报文的邻居列表中。

    2-Way Received:此事件表示路由器发现与邻居的双向通信已经开始(发现自己在邻居发送的Hello报文的邻居列表中)。Init状态下产生此事件之后,如果需要和邻居建立邻接关系则进入ExStart状态,开始数据库同步过程,如果不能与邻居建立邻接关系则进入2-Way。

    2-Way:在此状态下,双向通信已经建立,但是没有与邻居建立邻接关系。这是建立邻接关系以前的最高级状态。

    1-Way Received:此事件表示路由器发现自己没有在邻居发送Hello报文的邻居列表中,通常是由于对端邻居重启造成的。

    ExStart:这是形成邻接关系的第一个步骤,邻居状态变成此状态以后,路由器开始向邻居发送DD报文。主从关系是在此状态下形成的;初始DD序列号是在此状态下决定的。在此状态下发送的DD报文不包含链路状态描述。

    Exchange:此状态下路由器相互发送包含链路状态信息摘要的DD报文,描述本地LSDB的内容。

    Loading:相互发送LS Request报文请求LSA,发送LS Update通告LSA。

    Full:两台路由器的LSDB已经同步。

    2.3 OSPF邻居建立过程

    在这里插入图片描述
    在这里插入图片描述

    2.3.1 邻居关系建立

    R1向R2发送第一个Hello包,其中Advertising router为1.1.1.1
    在这里插入图片描述
    同时,R2也向R1发送第一个Hello包,其中Advertising router为2.2.2.2
    在这里插入图片描述
    当R1收到R2发送的第一个Hello包时,状态机从down变为init
    R1向R2发送Advertising router为1.1.1.1,Active Neighbor为2.2.2.2
    在这里插入图片描述
    此时R2收到R1发送的第二个Hello包时,状态机从init变为2-way
    并且R2向R1发送Advertising router为2.2.2.2,Active Neighbor为1.1.1.1
    R1收到后,状态机从init变为2-way

    在之后的四十秒内进行DR/BDR选举
    在这里插入图片描述

    2.3.2 邻接关系建立

    选举完DR/BDR,R1和R2同时进入Exstart状态,并互相发送第一个DD报文
    R2发送的第一个空DD报文Sequence=106,I、M、M/S分别置位
    在这里插入图片描述
    R1发送的第一个空DD报文Sequence=110,I、M、M/S分别置位
    在这里插入图片描述
    其中R1的RID为1.1.1.1,R2的RID为2.2.2.2,R2的RID>R1的RID,所以R2为主路由器,R1为从路由器。并且两个路由器状态机从Exstart变成Exchange
    R1从路由器要回复DD报文,并且Sequence遵循主路由器。即Slave回应的DD报文是对Master发送的DD报文进行确认。
    在这里插入图片描述
    直到双方的DD报文的M位=0,才结束交互DD报文
    在这里插入图片描述
    从路由器对主路由进行确认
    在这里插入图片描述
    DD交互完之后,两个路由器状态机从Exchange进入Loading状态
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    2.4 区域结构设计

    2.4.1 区域间路由传递

    在这里插入图片描述
    BR将一个区域内的链路状态信息转化成路由信息,然后发布到邻居区域。
    链路状态信息转换成路由信息其实就是将一类和二类LSA转化成三类LSA的过程。注意,区域间的路由信息在ABR上是双向传递的。

    2.4.2 2.区域间路由计算

    计算路由时,路由器计算自己区域内到 ABR 的成本加上 LSA3 传递的区域间成本,得到的是当前路由器到目标网络端到端的成本

    2.4.3 区域间路由环路的产生

    如果没有其他区域围着Area0的这一设计要求,每个区域都可以互相学习到路由
    为了避免上述环路,限定LSA3路由的流动规则:不允许非ABR产生LSA3

    避免环路:①非骨干区域必须围着骨干区域②三类LSA传递规则:从骨干区域传来的三类LSA不再传回骨干区域;不允许非ABR产生LSA3

    2.4.4 LSA3特性

    ①边界路由器ABR为区域内的每个网络号各产生一份LSA3并向其他区域通告
    ②边界有多个ABR,每个ABR都会产生LSA3来通告区域间路由。这两个LSA3通过Advertising Router来区分。根据本路由器到达目的网段的累计开销进行比较,最终生成最小开销路由。如果根节点到达目的网段的累计开销值相同,则产生等价负载的路由。
    ③LSA3跨区域传播时,再由该区域的ABR 产生 LSA3 继续泛洪。
    ④计算路由时,路由器计算自己区域内到 ABR 的成本加上 LSA3 传递的区域间成本,得到的是当前路由器到目标网络端到端的成本
    ⑤具有矢量特性,只有出现在ABR路由表里的路由才会被通告给邻居区域
    ⑥如果ABR路由器上路由表中的某条OSPF路由不再可达,则ABR产生LS Age 3600s 的LSA3 区域内泛洪 ,用于在区域内撤销该网络

    2.4.5 手动建立邻居

    OSPF支持通过单播方式建立邻居关系。
    对于不支持组播的网络可以通过手动配置实现邻居的发现与维护。
    配置:
    Ospf 1
    Peer 2.2.2.2

    2.4.6 邻居与邻接

    邻居(Neighbor):
    OSPF路由器启动后,便会通过OSPF接口向外发送Hello报文用于发现邻居。状态到达2-way 即可称为建立了邻居关系。
    邻接(Adjacency):
    只有当双方成功交换DD报文,并同步LSDB后,达到Full状态,才形成真正意义上的邻接关系。运行OSPF的路由器之间需要交换链路状态信息和路由信息,在交换这些信息之前路由器之间首先需要建立邻接关系。

    2.4.7 邻居和邻接关系

    在这里插入图片描述
    链路两端的OSPF接口的网络类型必须一致,否则双方不可以建立起邻居关系
    广播—P2P时,双方仍可以正常的建立起邻居关系,但互相学不到路由信息。
    P2MP—P2P时,双方不能正常的建立起邻居关系。

    2.4.8 OSPF四种特殊区域

    在这里插入图片描述

    2.4.8.1 Stub区域

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    2.4.8.2 Totally Stub区域

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    2.4.8.3 NSSA区域

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    2.4.8.4 Totally NSSA区域

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    三、OSPFv2扩展特性

    3.1 OSPFv2收敛特性

    在这里插入图片描述

    3.2 Database Overflow

    Database Overflow:限制非缺省外部路由数量,避免数据库超限。

    原理
    通过设置路由器上非缺省外部路由数量的上限,来避免数据库超限。OSPF网络中所有路由器都必须配置相同的上限值。这样,只要路由器上外部路由的数量达到该上限,路由器就进入Overflow状态,并同时启动超限状态定时器(默认超时时间为5秒),路由器在定时器超过5秒后自动退出超限状态。

    OSPF Database Overflow过程:
    进入Overflow状态时,路由器删除所有自己产生的非缺省外部路由。
    处于Overflow状态中时,路由器不产生非缺省外部路由;丢弃新收到的非缺省外部路由且不回复确认报文;当超限状态定时器超时,检查外部路由数量是否仍然超过上限,如果超限则重启定时器,如果没有则退出超限状态。
    退出Overflow状态时,路由器删除超限状态定时器;产生非缺省外部路由;接收新收到的非缺省外部路由并回复确认报文;准备下一次进入超限状态。

    3.3 缺省路由

    普通区域:
    ASBR上手动配置产生缺省5类LSA,通告到整个OSPF自治域(特殊区域除外)。

    Stub区域:
    ABR自动产生一条缺省3类LSA,通告到整个Stub区域内。

    Totally Stub区域:
    ABR会自动产生一条缺省3类LSA,通告到整个Stub区域内。

    NSSA区域:
    在ABR自动产生一条缺省7类LSA,通告到整个NSSA区域内;
    在ASBR手动配置产生一条缺省7类LSA,通告到整个NSSA区域内。

    Totally NSSA区域:
    ABR自动产生一条缺省3类LSA,通告到整个NSSA区域内。
    ABR自动产生一条缺省七类LSA,通告到整个NSSA区域内。

    OSPF 缺省路由通常应用于下面两种情况:
    ①由区域边界路由器(ABR)发布 Type3 缺省 Summary LSA,用来指导区域内设备进行区域之间报文的转发。
    ②由自治系统边界路由器(ASBR)发布 Type5 外部缺省 ASE LSA,或者 Type7 外部缺省NSSA LSA,用来指导自治系统(AS)内设备进行自治系统外报文的转发。

    OSPF 缺省路由的发布原则如下:
    ①OSPF 路由器只有具有对外的出口时,才能够发布缺省路由 LSA。
    ②如果 OSPF 路由器已经发布了缺省路由 LSA,那么不再学习其它路由器发布的相同类型缺省路由。即路由计算时不再计算其它路由器发布的相同类型的缺省路由 LSA,但数据库中存有对应 LSA。
    ③外部缺省路由的发布如果要依赖于其它路由,那么被依赖的路由不能是本 OSPF 路由域内的路由,即不是本进程 OSPF 学习到的路由。因为外部缺省路由的作用是用于指导报文的域外转发,而本 OSPF 路由域的路由的下一跳都指向了域内,不能满足指导报文域外转发的要求。

    3.4 路由过滤

    可以使用路由策略route-policy,filter,filter-policy,filter-lsa-out,访问控制列表(access-list),地址前缀列表(prefix-list)。

    路由引入的过滤
    OSPF可以引入其它路由协议学习到的路由。在引入时可以通过配置路由策略来过滤路由,只引入满足条件的路由。

    配置示例:
    [R3-ospf-1]import-route rip 1 route-policy GOK
    

    路由视图下的LSA过滤:
    3类LSA学习、发布的过滤:
    通过filter import、filter export命令在ABR上对进入或离开本区域的3型LSA进行过滤。该配置只在ABR上有效(只有ABR才能发布3型LSA)。
    在这里插入图片描述

    配置示例:
    [R3-ospf-1-area-0.0.0.1]filter [ip-prefix|acl] gok [import/export]
    

    5、7类LSA生成的过滤:
    OSPF 引入外部路由后会生成5、7型LSA。可以通过filter-policy export来对5、7型LSA的生成进行过滤。该过滤规则只在ASBR上配置才有效。

    配置示例:
    [R3-ospf-1]filter-policy [acl-number|ip-prefix gok] export 
    

    接口视图下的LSA过滤
    通过ospf filter-lsa-out命令, 匹配除Grace LSA外的所有LSA、3、5、7型LSA,并匹配ACL规定的路由前缀时,实现LSA的通告过滤。

    配置示例:
    [R3-GigabitEthernet0/0/0]ospf filter-lsa-out all 
    

    路由计算的过滤:
    通过filter-policy import过滤规则,可以设置 OSPF对数据库中的区域内、区域间、外部LSA计算为路由条目时进行过滤。

    该过滤只作用于路由表项的添加与否,即只有通过过滤的路由才被添加到本地路由表中,产生该路由的LSA仍然会在OSPF自治系统内扩散。
    对本地计算出来的路由执行过滤,只有被过滤策略允许的路由才能被加表,没有通过过滤策略允许的路由不加表,此命令不影响路由器之间通告和接收LSA

    配置示例:
    [R3-ospf-1]filter-policy [acl-number|ip-prefix gok] import 
    

    3.5 Forwarding Address

    在这里插入图片描述
    RTB将通过RIP学来的路由重发布到OSPF,RTA通过OSPF学习到RIP中192.168.3.0/24的外部路由,但是下一跳是RTB。所以RTA访问192.168.3.0/24的流量先发送给RTB,RTB收到后又转发给RTC。在RTA上这条路由是次优的,最优的下一跳应当为RTC。

    OSPF通过设置Forwarding Address来解决这个问题。

    FA=0数据包要经过ASBR访问外部网络,如果FA!=0,数据包要转发至拥有FA地址的路由设备,再由其转发到外部网络。

    如果FA!=0,则要根据OSPF路由表中是否有FA地址对应的路由来判断可达性,若不可达,则该外部路由不进 IP 路由表。

    3.6 认证

    区域认证方式和接口认证方式。当两种认证方式都存在时,优先使用接口认证方式。
    认证模式分为null(不认证)、simple(明文)、MD5以及HMAC-MD5。

    3.7 虚连接vlink

    应用场景:
    ①连接断开的Area0
    在这里插入图片描述
    ②修复Area2未连接到Area0
    在这里插入图片描述

    配置示例:
    ospf 1
     area 1 
     vlink-peer 3.3.3.3
    

    3.8 OSPF与IS-IS比较

    3.8.1 基本特点

    相同点:
    均为IGP协议,且应用广泛;
    均支持IP环境;
    均采用分层设计和分区域设计。

    不同点:
    OSPF仅支持IP;IS-IS既支持IP,又支持CLNP;
    OSPF支持的网络类型丰富;IS-IS仅支持两种网络类型;
    OSPF支持虚连接;IS-IS虽然有类似功能,但是多数厂商不支持;
    OSPF工作在IP之上;IS-IS工作在数据链路层之上;
    OSPF基于接口划分区域;IS-IS基于设备划分区域。

    3.8.2 邻接关系特点

    相同点:
    均通过Hello建立和维护邻居关系;
    多点访问网络均选举DR/DIS。
    不同点:
    OSPF建立邻居关系条件相对苛刻;IS-IS的要求则相对宽松;
    OSPF点对点链路形成邻居关系比较可靠;IS-IS可靠性相对较弱;
    OSPF邻居关系不分层次;IS-IS邻居关系分两个层次;
    OSPF处理DR/BDR和IS-IS处理DIS方式不同。

    3.8.3 数据库同步特点

    相同点:
    均需形成统一的LSDB。
    不同点:
    OSPF LSA种类繁多;IS-IS LSP种类较少;
    OSPF与IS-IS数据库同步过程不同;
    OSPF LSA生存时间从零递增;IS-IS LSP生存时间从最大值递减。

    3.8.4 其他特点

    相同点:
    均使用SPF算法计算路由;
    无环路,收敛快,支持大规模网络部署。
    不同点:
    OSPF开销类型较为简单;IS-IS开销类型相对较复杂;
    OSPF支持按需拨号网络;IS-IS无此特性。

    展开全文
  • 拓扑介绍 上述拓扑中配置OSPF,分为三...1 按照拓扑中区域规划运行OSPF路由协议,完成设备间的个网段互通 2 用户不能直接发布到OSPF中,需要作为外部路由注入OSPF,且在注入后需将连续网段聚合 3 将area2配置..

    拓扑介绍

    上述拓扑中配置OSPF,分为三个区域,area0、area1、area2。CR1有三个接口分别属于区域0、区域1、区域2,CR2三个接口分别属于区域0、区域1、区域2,AR1两个接口属于区域1,AR2有两个接口属于区域2;其中AR所接用户使用Loopback1 、2、3模拟外部网络。

    实验任务

    1 按照拓扑中区域规划运行OSPF路由协议,完成设备间的个网段互通

    2 用户不能直接发布到OSPF中,需要作为外部路由注入OSPF,且在注入后需将连续网段聚合

    3 将area2配置成OSPF特殊区域,要求将AR1的外部路由不能注入区域2,但不会影响area2内注       入其所连接的用户网段

    4 合理设置个链路的开销值,使AR路由器上行链路实现主备备份;且区域间流量不穿越骨干链路

    5 设置个链路的OSPF报文认证以提高网络的安全性 

    配置IP地址

    CR1

    interface Ethernet0/0/0
     ip address 20.1.1.2 255.255.255.252

    interface Ethernet0/0/1
     ip address 10.1.1.1 255.255.255.252

    interface GigabitEthernet0/0/0
     ip address 30.1.1.1 255.255.255.252

    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255

    CR2 

    interface Ethernet0/0/0
     ip address 31.1.1.1 255.255.255.252

    interface Ethernet0/0/1
     ip address 10.1.1.2 255.255.255.252

     interface GigabitEthernet0/0/0
     ip address 21.1.1.2 255.255.255.252

    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255

    AR1

    interface Ethernet0/0/0
     ip address 20.1.1.1 255.255.255.252

    interface Ethernet0/0/1
     ip address 21.1.1.1 255.255.255.252

    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255

    interface LoopBack1                        
     ip address 100.1.1.1 255.255.255.255
    interface LoopBack2
     ip address 100.1.1.2 255.255.255.255
    interface LoopBack3
     ip address 100.1.1.3 255.255.255.255        //模仿外部路由

    AR2

    interface Ethernet0/0/0
     ip address 30.1.1.2 255.255.255.252

    interface Ethernet0/0/1
     ip address 31.1.1.2 255.255.255.252

    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255

    interface LoopBack1
     ip address 200.1.1.1 255.255.255.255
    interface LoopBack2
     ip address 200.1.1.2 255.255.255.255
    interface LoopBack3
     ip address 200.1.1.3 255.255.255.255         //模仿外部路由

    //逻辑接口相对物理接口永不DOW

    查询指令:display ip interface brief

     

    配置OSPF全局功能

    CR1

    ospf 1 router-id 1.1.1.1          //必须配置区域ID 一般用loopback地址 唯一性
     area 0.0.0.0          //划分多区域 宣告区域内地址
      network 1.1.1.1 0.0.0.0        
      network 10.1.1.0 0.0.0.3
     area 0.0.0.1
      network 20.1.1.0 0.0.0.3
     area 0.0.0.2
      network 30.1.1.0 0.0.0.3

    AR1

    ospf 1 router-id 3.3.3.3
     area 0.0.0.1
      network 3.3.3.3 0.0.0.0
      network 20.1.1.0 0.0.0.3
      network 21.1.1.0 0.0.0.3

    //另外两台路由器同上

    //配置OSPF用反掩码

    //默认进程号是1 不同的进程号表示不同的OSPF协议 互不干扰 如想学习路由必须通过import-route

    查询指令:display ospf peer          display ospf 1 peer brief              display ip routing-table 
             通过Ping1.1.1.1测试接口连通性

     

     

    路由引入

    AR1和AR2

      ospf                                                                                                                                                         import-route direct         //        引入AR1和AR2外部路由  

    查询指令 display ip routing-table                 display  ospf 1 routing 

    路由汇聚

    AR1

    ospf 1
     asbr-summary 100.1.1.0 255.255.255.0         // 把三条外部路由聚合成一条,减少路由条目

    AR2

    ospf 1 
     asbr-summary 200.1.1.0 255.255.255.0

    查询指令:display  ip routing-table protocol ospf 

    //ospf 的 ASBR summary 中的 cost :设置聚合路由的开销。cost 的取值范围是 0~16777214。
    当此参数缺省时,对于 Type1 类外部路由,取所有被聚合路由中的最大开销值作为聚合路
    由的开销;对于 Type2 类外部路由,则取所有被聚合路由中的最大开销值再加上 1 作为聚
    合路由的开销。
    import route 默认为 type 2

     

    特殊区域

    根据实验要求将 Area2 配置成 OSPF 特殊区域,要求 AR1 路由器上的外部路由不能注入
    Area2 ,但是不影响 Area2 内注入其所连接的用户网段,因此我们需要把 Area2 配置为 NSSA
    区域;配置命令 nssa 时,可以配置后面的可选参数

    CR1

    ospf 1
     area 2
      nssa        //  设置area2为NSSA区域

    CR2

    ospf 1
     area 2
      nssa        

    AR2

    ospf 1
     area 2
      nssa      

    //配置特殊区域时,所有属于此区域的路由器必须全部配置相同的类型,否侧无法建立邻居关系,

    如果配置错误,邻居关系会断掉

    查询指令: display ospf 1 lsdb         //查看OSPF进程号为1的链路状态数据库信息

    通过查看 OSPF 链路状态数据库,可以看到在 AR2 LSDB 中存在 7 类 LSA ,7 类 LSA
    只会存在 NSSA 特殊区域中;在 NSSA 区域中引入外部路由采用 7 类 LSA ,在传出 NSSA
    区域时由 ABR 把 7 类 LSA 转换成 5 类 LSA 传递出去。

     

    链路开销 

    根据实验要求设置各链路的开销值,使 AR 路由器上行链路实现主备备份;且区域间流量不
    穿越骨干链路;通过修改 AR 其中一条链路接口 COST 值来实现 AR 上行链路的主备备份,
    并且使区域间流量不穿越骨干链路

    CR1

    interface Ethernet0/0/0                                                                                                                                     ospf cost 100

    AR1

    interface Ethernet0/0/0                                                                                                                                     ospf cost 100

    //修改cost (1-65535) 越小越优                                                                                                                        //配置整条链路开销 两端接口都要配置


    查询指令  display  ospf interface Ethernet 0/0/0         //查看OSPF接口信息

     

    OSPF认证

     接口认证:

    interface Ethernet0/0/0
     ospf authentication-mode simple ciphe password

    区域认证:

    ospf 1                                                                                                                                                                area 1
    authentication-mode simple ciphe password

    //验证两端端口都要配置相同的密码 同时配置区域认证和接口认证,接口认证优先

    查询指令:display  current-configuration  interface                                                                                                    display ospf peer    //如果配置正确 邻居关系不会受影响

     

    快速收敛:

    //修改点到点链路类型 减少选举DR和BDR时间 ,可以指定LSA更新时间间隔为0来取消LSA的更新时间间隔,是的拓扑变化时立即通过LSA发布到网络中,加快路由收敛速度

    更改接口类型:

    interface Ethernet0/0/0
     ospf network-type p2p        

    更改LSA更新时间:


    ospf 1 
     lsa-originate-interval 0

    //两端端口都要配置成P2P类型

    查询指令:display  ospf interface  Ethernet 0/0/0  //查询网络类型为P2P

     查询指令:display  current-configuration  configuration ospf          //查看LSA更新时间为0

     

    展开全文
  • 文章目录前言一、 OSPF的基本原理1.1 OSPF区域化结构1.2 OSPF报文类型1.3 多区域OSPF网络二、 OSPF多区域配置示例三、精彩链接四、最后 前言 与RIP协议一样,OSPF也是一种IGP。通常,我们把一个以OSPF协议作为其IGP...
  • OSPF路由协议配置

    千次阅读 2018-06-24 18:22:28
    1.按照要求连接好电缆,打开超级终端软件,设置波特率 为9600,进入...3.查看路由器的运行配置文件,看有没有已经有的路由信 息,如果有,先删除相关的信息,静态路由器的删除方 式,在全局模式下,用no...
  • 配置动态路由OSPF协议

    千次阅读 2020-03-22 14:50:18
    一、网络结构 (1) 交换机与PC机、交换机与路由器的连接由以太网接口用直连线连接即可(每个设备会自动生成无数个以太网接口f0/0、f0/1……) (2) 路由器之间是广域网之间连接,必须用...配置路由器Router...
  • OSPF路由协议基础(OSPF基本配置

    万次阅读 多人点赞 2020-12-04 11:50:25
    OSPF路由协议基础(OSPF基本配置) 文章目录OSPF路由协议基础(OSPF基本配置)一、拓扑图二、OSPF基本配置三、总结 一、拓扑图 二、OSPF基本配置 [R4]router id 4.4.4.4 [R4]ospf [R4-ospf-1] [R4-ospf-1]area 0...
  • area 0 end show ip route R1 en conf t interface fa 0/0 no shutdown ...ospf 1 network 192.168.3.0 0.0.0.255 area 0 network 192.168.4.0 0.0.0.255 area 0 end show ip route R2 en conf t interface fa 0/0 no ...
  • eNSP实验三:OSPF路由协议

    千次阅读 2022-05-10 19:26:49
    通过OSPF动态路由协议,来实现这些网络之间的互联互通。内容为OSPF的基本配置命令;如何查看OSPF的运行状态;通过cost控制OSPF的选路;OSPF发布默认路由的方法;OSPF认证配置方法。
  • ospf协议剖析
  • 【课程思政案例】广域网互联技术:OSPF路由协议配置--树立正确的三观.pdf
  • OSPF路由协议详解

    万次阅读 多人点赞 2019-06-18 16:44:48
    无类别链路状态路由协议,组播更新224.0.0.5/6;跨层封装到三层,协议号89; 基于拓扑工作,故更新量大-----需要结构化部署–区域划分、地址规划 触发更新、每30min周期更新 OSPF的数据包: Hello包 DBD–数据库描述...
  • 配置NSSA区域OSPF路由协议地址汇总.pdf
  • 0 引言  根据是否在一个自治域内部使用,动态路由协议分为内部网关协议(IGP)和...这类协议的例子有OSPF,RIP等路由协议,通过提供共享路由选择信息的机制来支持被动路由协议。路由选择协议消息在路由器之间传送。路
  • 掌握在路由器上配置 OSPF 单区域。需要在路由器和交换机上配置 OSPF 路由协议,使全网互通,从而实现信息的共享和传递。
  • 华为eNSP配置动态路由OSPF协议

    千次阅读 2021-01-13 17:02:49
    一是动态路由OSPF协议;二是华为OSPF协议命令配置;三是配置OSPF静默接口;四是联通测试和查看OSPF邻居表;五是Wireshark数据抓包R1接口e0/0/0。
  • OSPF路由协议PPT教学课件.pptx
  • 实验3OSPF协议的规划与配置实验 某企业内部网络拓扑如下图所示,企业网络使用多区域OSPF进行路由规划。为了实现企业各网段之间、企业网络与Internet之间的相互访问,需要在各路由器上完成路由配置。已知企业向ISP...
  • OSPF动态路由协议 拓扑图 配置pc的IP,子网掩码和网关 Pc1 IP 192.168.1.1 子网掩码 255.255.255.252 网关 192.168.1.2 Pc2 IP 192.168.5.2 子网掩码 255.255.255.252 网关 192.168.5.1 Pc3 IP 192...
  • OSPF路由协议

    2022-03-09 21:00:40
    为适应大型网络配置的需要,OSPF协议引入“分层路由”的概念,将整体网络划分为较小的区域(Area),从而限制了路由信息传播的范围,每个区域都是一个独立的网络,区域内的路由器只保存该区域的链路状态信息,而OSPF...
  • OSPF的基础配置/原理及认证
  • OSPF路由协议概念及工作原理.pdf
  • 思科路由器配置ospf协议(六)

    千次阅读 2021-12-30 22:49:16
    拓扑图 配置路由的串口和光口和上一篇文章...查看路由表,o代表ospf协议路由 测试结果 //路由1的配置 Router> Router>en Router#conf t Router(config)#int s0/3/0 Router(config-if)#ip add ...
  • 这是一个基于eNSP的 单臂路由+OSPF路由协议已经配置好了的拓扑图,可以直接进行通信,里面含有各个设备的配置命令。

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 41,389
精华内容 16,555
关键字:

怎么配置ospf路由协议