精华内容
下载资源
问答
  • void pcl::registration::getCorDistMeanStd ( const pcl::Correspondences & correspondences, double & mean,double & stddev )
  • Packet Tracer –配置多区域OSPFv2

    万次阅读 2020-06-01 11:10:39
    9.2.2.6 Packet Tracer –配置多区域OSPFv2 拓扑结构 Packet Tracer –配置多区域OSPFv2图 地址表 设备 接口 IP 地址 子网掩码 OSPFv2 区域 ...

    9.2.2.6 Packet Tracer –配置多区域OSPFv2

    拓扑结构

                                       9.2.2.6 Packet Tracer –配置多区域OSPFv2

                                                                   Packet Tracer –配置多区域OSPFv2图

    地址表

    设备

    接口

    IP 地址

    子网掩码

    OSPFv2 区域

    R1

    G0/0

    10.1.1.1

    255.255.255.0

    1

    G0/1

    10.1.2.1

    255.255.255.0

    1

    S0/0/0

    192.168.10.2

    255.255.255.252

    0

    R2

    G0/0

    10.2.1.1

    255.255.255.0

    0

    S0/0/0

    192.168.10.1

    255.255.255.252

    0

    S0/0/1

    192.168.10.5

    255.255.255.252

    0

    R3

    G0/0

    192.168.2.1

    255.255.255.0

    2

    G0/1

    192.168.1.1

    255.255.255.0

    2

    S0/0/1

    192.168.10.6

    255.255.255.252

    0

    目标

    第 1 部分:配置多区域 OSPFv2

    第 2 部分:验证并检查多区域 OSPFv2

    背景

    在本练习中,您将配置多区域 OSPFv2。网络已经连接而且接口上配置了 IPv4 编址。您的任务是启用多区域 OSPFv2,验证连接并检查多区域 OSPFv2 的操作。

    第1部分:配置OSPFv2

    步骤1:在R1上配置OSPFv2。

    在R1上配置OSPFv2,进程ID为1,路由器ID为1.1.1.1。

    R1>en
    R1#config t
    R1(config)#router ospf 1
    R1(config-router)#router-id 1.1.1.1

    步骤2:在R1的OSPFv2中发布每个直接连接的网络。

    根据地址表在OSPFv2分配区域中配置每个网络。

    R1(config-router)#network 10.1.1.0 0.0.0.255 area 1
    R1(config-router)#network 10.1.2.0 0.0.0.255 area 1
    R1(config-router)#network 192.168.10.0 0.0.0.3 area 0

    分别使用2.2.2.2和3.3.3.3的路由器ID 对R2R3重复上述步骤。

    R2>en
    R2#config t
    R2(config)#router ospf 1
    R2(config-router)#router-id 2.2.2.2
    R2(config-router)#network 10.2.1.0 0.0.0.255 area 0
    R2(config-router)#network 192.168.10.0 0.0.0.3 area 0
    R2(config-router)#network 192.168.10.4 0.0.0.3 area 0
    R3>en
    R3#config t
    R3(config)#router ospf 1
    R3(config-router)#router-id 3.3.3.3
    R3(config-router)#network 192.168.2.0 0.0.0.255 area 2
    R3(config-router)#network 192.168.1.0 0.0.0.255 area 2
    R3(config-router)#network 192.168.10.4 0.0.0.3 area 0

    第2部分:验证和检查多区域OSPFv2

    步骤1:验证与每个OSPFv2区域的连接。

    从R1 ping区域0和区域2中的以下每个远程设备:192.168.1.2、192.168.2.2和10.2.1.2。

    步骤2:使用show命令检查当前OSPFv2操作。

    使用以下命令来收集有关OSPFv2多区域实现的信息。

    show ip protocols
    show ip route
    show ip ospf database
    show ip ospf interface
    show ip ospf neighbor

    实验问答题

    1.哪些路由器是内部路由器?
    _______R2________________________
    2.哪些路由器是主干路由器?
    ______R1,R2和R3都是骨干路由器。____________________
    3.哪些路由器是区域边界路由器?
    _________R1和R3__________________
    4.哪些路由器是自治系统路由器?
    ______没有,所有三个路由器上的所有活动接口都连接到OSPF区域。______________________
    5.哪些路由器会生成第 1 类 LSA?
    _____所有OSPF路由器都会生成Type 1 LSA。_______________
    6.哪些路由器会生成第 2 类 LSA?
    __每个属于DR的区域中都有隐藏的路由器。路由器ID 4.4.4.4、5.5.5.5、6.6.6.6、9.9.9.9__________
    7.    哪些路由器会生成第 3 类 LSA?
    _____R1和R3因为它们都是ABR,并且需要将区域信息从一个区域泛洪到另一个区域。_____
    8.哪些路由器会生成第 4 类和第 5 类 LSA?
    _____无,因为网络中没有ASBR。_________
    9.每台路由器有多少个区域间路由?
    __R1和R3具有两个IA,R2具有4个IA。__________
    10.为什么在此类网络中通常会有一个 ASBR?
    _____ASBR用于连接外部路由域。______

     

     

    展开全文
  • 区域的作用: ** 1.安全策略都基于区域实施 2.在同一区域内部发生的数据流动是不存在风险的,不需要实施任何安全策略。 只有当不同安全区域之间发生数据流动时,才会触发设备的安全检查,并实施相应的安全策略。 3....

    **

    区域的作用:

    **
    1.安全策略都基于区域实施
    2.在同一区域内部发生的数据流动是不存在风险的,不需要实施任何安全策略。
    只有当不同安全区域之间发生数据流动时,才会触发设备的安全检查,并实施相应的安全策略。
    3.一个接口只能属于一个区域,而一个区域可以有多个接口。在这里插入图片描述
    **

    DMZ区域,

    **
    1.两个防火墙之间的空间被称为DMZ。与Internet相比,DMZ可以提供更高的安全性,但是其安全性比内部网络低。
    2.服务器 内 外网都可以访问,但还是与内网隔离.
    就算是黑客把DMZ服务器拿下,也不能使用服务器来控制内网的网络.起到安全的策略
    **

    Trust区域,

    **
    可信任的接口.是局域网的接口.此接口外网和DMZ无法访问.
    外部不能访问trust口
    DMZ不能访问trust口
    **

    Untrust区域

    **
    不信任的接口,是用来接internet的,这个接口的信息内网不接受
    可以通过untrust口访问DMZ,但不能访问trust口**

    **

    重点:

    华为防火墙系统默认的系统 默认区域有四个,且优先级不能更改:非受信区(Untrust) 优先级5,非军事化区(DMZ)优先级50,受信区(Trust) 优先级85,本地区域(Local) 优先级100;如不满组网需求,可自行创建安全区域,数量最大为16个(包含默认4个),但是优先级不能与现有区域优先级相同。

    **

    扩展:
    1、域基本分为:local、trust、dmz、untrust这四个是系统自带不能删除,除了这四个域之外,还可以自定义域。
    2、域等级local>trust>dmz>untrust,自定义的域的优先级是可以自己调节的。
    3、域与域之间如果不做策略默认是deny的,即任何数据如果不做策略是通不过的,如果是在同一区域的就相当于二层交换机一样直接转发。
    4、当域与域之间有inbound和outbound区分,华为定义了优先级地的域向优先级高的域方向就是inbound,反之就是outbound

    展开全文
  • 4.1图像分割之区域生长法

    万次阅读 多人点赞 2018-08-04 16:37:39
    我们将讨论以区域为基础的图像分割处理技术。传统的区域分割方法有区域生长和区域分裂与合并, 其中最基础的是区域生长法。 区域生长法  区域生长是根据事先定义的准则将像素或者子区域聚合成更大...
     我们将讨论以区域为基础的图像分割处理技术。传统的区域分割方法有区域生长和区域分裂与合并,
     其中最基础的是区域生长法。
    

    区域生长法

    区域生长是根据事先定义的准则将像素或者子区域聚合成更大区域的过程。其基本思想是从一组生长点开始(生长点可以是单个像素,也可以是某个小区域),将与该生长点性质相似的相邻像素或者区域与生长点合并,形成新的生长点,重复此过程直到不能生长为止。生长点和相似区域的相似性判断依据可以是灰度值、纹理、颜色等图像信息。所以区域生长算法关键有三个:
    1、选择合适的生长点
    2、确定相似性准则即生长准则
    3、确定生长停止条件
      下面给出一个区域生长的实例:图(a)为原始图像,数字表示像素的灰度。以灰度值为8的像素为初始的生长点,记为f(i,j)。在8邻域内,生长准则是待测点灰度值与生长点灰度值相差为1或0.那么图(b)是第一次区域生长后,f(i-1,j)、f(i,j-1)、f(i,j+1)和生长点灰度值相差都是1,因而被合并。图©是第二次生长后,f(i+1,j)被合并。图(d)为第三次生长后,f(i+1,j-1)、f(i+2,j)被合并,至此,已经不存在满足生长准则的像素点,生长停止。
    这里写图片描述

    示例演示

    我们实现一个功能,鼠标选择一个初始生长点,生长准则是待测点灰度值与初始生长点灰度值差的绝对值不大于8。示例代码中regionGrow函数参考了《数字图像处理与机器视觉》第九章第五节,regionGrowFast函数是优化过的实现,代码如下:

    cv::Mat MainWindow::regionGrowFast(const cv::Mat &src, const cv::Point2i seed, int throld)
    {
        //convert src to gray for getting gray value of every pixel
        cv::Mat gray;
        cv::cvtColor(src,gray, cv::COLOR_RGB2GRAY);
    
        // set every pixel to black
        cv::Mat result = cv::Mat::zeros(src.size(), CV_8UC1);
        if((seed.x < 0) || (seed.y < 0))
            return result;
        result.at<uchar>(seed.y, seed.x) = 255;
    
        //gray value of seed
        int seed_gray = gray.at<uchar>(seed.y, seed.x);
        //grow direction sequenc
        int grow_direction[8][2] = {{-1,-1}, {0,-1}, {1,-1}, {1,0}, {1,1}, {0,1}, {-1,1}, {-1,0}};
        //seeds collection
        std::vector<cv::Point2i> seeds;
        seeds.push_back(seed);
    
        //start growing
        while(! seeds.empty()){
            //get a seed
            cv::Point2i current_seed = seeds.back();
            seeds.pop_back();
    
            for(int i = 0; i < 8; ++i){
                cv::Point2i neighbor_seed(current_seed.x + grow_direction[i][0], current_seed.y + grow_direction[i][1]);
                //check wether in image
                if(neighbor_seed.x < 0 || neighbor_seed.y < 0 || neighbor_seed.x > (gray.cols-1) || (neighbor_seed.y > gray.rows -1))
                    continue;
                int value = gray.at<uchar>(neighbor_seed.y, neighbor_seed.x);
                if((result.at<uchar>(neighbor_seed.y, neighbor_seed.x) == 0) && (abs(value - seed_gray) <= throld)){
                    result.at<uchar>(neighbor_seed.y, neighbor_seed.x) = 255;
                    seeds.push_back(neighbor_seed);
                }
            }
        }
        return result;
    }
    

    运行结果:

    这里写图片描述

    [代码下载]

    展开全文
  • OpenCV实现图像二值化分割 标记连通区域 删除面积小的区域,使用OpenCV实现这一功能:对图像进行二值化分割,并用“红色矩形”标记连通区域的面积,为了减少噪声的干扰,删除面积小的区域,代码中将连通区域面积...

     OpenCV删除面积小的区域 实现图像二值化分割 标记连通区域

       【尊重原创,转载请注明出处】http://blog.csdn.net/guyuealian/article/details/78142749
       之前本博客在Matlab实现了《Matlab形态学图像处理:二值图像分割 标记连通区域和重心位置 删除连通区域》http://blog.csdn.net/guyuealian/article/details/71440949,现在本人使用OpenCV实现这一功能:对图像进行二值化分割,并用“红色矩形”标记连通区域的面积,为了减少噪声的干扰,删除面积小的区域,代码中将连通区域面积(像素个数)不足100的区域认为是噪声点,并将其删除(即置为背景黑色)。本人制作了一个GIF动画图,以便大家观看效果图:

    OpenCV参考代码如下:

    #include "stdafx.h"
    #include <iostream>  
    #include<vector>
    #include<algorithm>
    #include <opencv2\opencv.hpp>  
    #include <opencv2\highgui\highgui.hpp>  
    using namespace std;
    using namespace cv;
    
    
    //轮廓按照面积大小升序排序
    bool ascendSort(vector<Point> a, vector<Point> b) {
    	return a.size() < b.size();
    
    }
    
    //轮廓按照面积大小降序排序
    bool descendSort(vector<Point> a, vector<Point> b) {
    	return a.size() > b.size();
    }
    int main() {
    	Mat srcImage = imread("D:\\OpencvTest\\123.jpg");
    	Mat thresholdImage;
    	Mat grayImage;
    	cvtColor(srcImage, grayImage, CV_BGR2GRAY);
    	threshold(grayImage, thresholdImage, 0, 255, CV_THRESH_OTSU + CV_THRESH_BINARY);
    	//Mat resultImage;
    	//thresholdImage.copyTo(resultImage);
    	vector< vector< Point> > contours;  //用于保存所有轮廓信息
    	vector< vector< Point> > contours2; //用于保存面积不足100的轮廓
    	vector<Point> tempV;				//暂存的轮廓
    
    	findContours(thresholdImage, contours, CV_RETR_LIST, CV_CHAIN_APPROX_NONE);
    	//cv::Mat labels;
    	//int N = connectedComponents(resultImage, labels, 8, CV_16U);
    	//findContours(labels, contours2, CV_RETR_EXTERNAL, CV_CHAIN_APPROX_NONE);
    
    	//轮廓按照面积大小进行升序排序
    	sort(contours.begin(), contours.end(), ascendSort);//升序排序
    	vector<vector<Point> >::iterator itc = contours.begin();
    	int i = 0;
    	while (itc != contours.end())
    	{
    		//获得轮廓的矩形边界
    		Rect rect = boundingRect(*itc);
    		int x = rect.x;
    		int y = rect.y;
    		int w = rect.width;
    		int h = rect.height;
    		//绘制轮廓的矩形边界
    		cv::rectangle(srcImage, rect, { 0, 0, 255 }, 1);
    		//保存图片
    		char str[10];
    		sprintf(str, "%d.jpg", i++);
    		cv::imshow("srcImage", srcImage);
    		imwrite(str, srcImage);
    		waitKey(1000);
    	
    		if (itc->size() < 100)
    		{
    			//把轮廓面积不足100的区域,放到容器contours2中,
    			tempV.push_back(Point(x, y));
    			tempV.push_back(Point(x, y+h));
    			tempV.push_back(Point(x+w, y+h));
    			tempV.push_back(Point(x+w, y));
    			contours2.push_back(tempV);
    			/*也可以直接用:contours2.push_back(*itc);代替上面的5条语句*/
    			//contours2.push_back(*itc);
    
    			//删除轮廓面积不足100的区域,即用黑色填充轮廓面积不足100的区域:
    			cv::drawContours(srcImage, contours2, -1, Scalar(0,0,0), CV_FILLED);
    		}
    		//保存图片
    		sprintf(str, "%d.jpg", i++);
    		cv::imshow("srcImage", srcImage);
    		imwrite(str, srcImage);
    		cv::waitKey(100);
    		tempV.clear();
    		++itc;
    	}
    	return 0;
    }

    【2】findContours的用法:

    using namespace std;
    using namespace cv;
    using namespace cv::xphoto;
    #include "stdafx.h"
    #include <iostream>  
    #include<vector>
    #include<algorithm>
    #include <opencv2\opencv.hpp>  
    #include <opencv2\highgui\highgui.hpp>  
    using namespace std;
    using namespace cv;
    
    //轮廓按照面积大小升序排序
    bool ascendSort(vector<Point> a, vector<Point> b) {
    	return a.size() < b.size();
    
    }
    
    //轮廓按照面积大小降序排序
    bool descendSort(vector<Point> a, vector<Point> b) {
    	return a.size() > b.size();
    }
    
    //自己实现的将灰度图像转为三通道的BGR图像
    cv::Mat gray2BGR(cv::Mat grayImg) {
    	if (grayImg.channels() == 3)
    		return grayImg;
    	cv::Mat bgrImg = cv::Mat::zeros(grayImg.size(), CV_8UC3);
    	std::vector<cv::Mat> bgr_channels;
    	cv::split(bgrImg, bgr_channels);
    	bgr_channels.at(0) = grayImg;
    	bgr_channels.at(1) = grayImg;
    	bgr_channels.at(2) = grayImg;
    	cv::merge(bgr_channels, bgrImg);
    	return bgrImg;
    }
    
    //自定义的drawImage函数的功能类似于OpenCV的drawContours函数
    cv::Mat drawImage(cv::Mat image, vector< vector< Point> > pointV) {
    	cv::Mat destImage=image.clone();
    	if (destImage.channels()==1)
    	{
    		destImage = gray2BGR(destImage);
    	}
    	for (size_t i=0;i<pointV.size();i++)
    	{
    		for (size_t j = 0; j<pointV.at(i).size(); j++)
    		{
    			cv::Point point = pointV.at(i).at(j);
    			destImage.at<Vec3b>(point) = cv::Vec3b(0, 0, saturate_cast<uchar>(255-i*5));
    		}
    
    	}
    	return destImage;
    }
    int main() {
    	Mat srcImage = imread("D:\\OpencvTest\\mask5.jpg");
    	cv::imshow("srcImage", srcImage);
    	Mat thresholdImage;
    	Mat grayImage;
    	cvtColor(srcImage, grayImage, CV_BGR2GRAY);
    	threshold(grayImage, thresholdImage, 0, 255, CV_THRESH_OTSU + CV_THRESH_BINARY);
    	cv::Mat mask = thresholdImage.clone();
    	//(1)CV_RETR_EXTERNAL, CV_CHAIN_APPROX_SIMPLE
    	vector< vector< Point> > contours1;
    	findContours(mask, contours1, CV_RETR_EXTERNAL, CV_CHAIN_APPROX_SIMPLE);
    	cv::Mat destImage = drawImage(mask, contours1);
    	imshow("destImage", destImage);
    
    	//(2)CV_RETR_EXTERNAL, CV_CHAIN_APPROX_NONE
    	vector< vector< Point> > contours2; 
    	findContours(mask, contours2, CV_RETR_EXTERNAL, CV_CHAIN_APPROX_NONE);
    	cv::Mat destImage2 = drawImage(mask, contours2);
    	imshow("destImage2", destImage2);
    
    	//(3)CV_RETR_LIST, CV_CHAIN_APPROX_NONE
    	vector< vector< Point> > contours3; 
    	findContours(mask, contours3, CV_RETR_LIST, CV_CHAIN_APPROX_NONE);
    	cv::Mat destImage3 = drawImage(mask, contours3);
    	imshow("destImage3", destImage3);
    
    
    	//(4)CV_RETR_CCOMP, CV_CHAIN_APPROX_NONE
    	vector< vector< Point> > contours4;
    	findContours(mask, contours4, CV_RETR_CCOMP, CV_CHAIN_APPROX_NONE);
    	cv::Mat destImage4 = drawImage(mask, contours4);
    	imshow("destImage4", destImage4);
    
    
    	//cv::Mat imge2 = gray2BGR(mask);
    	//drawContours(imge2, contours4, -1, cv::Scalar(0, 0, 255), 1);
    	//cv::fillConvexPoly(mask, contours1.at(0), cv::Scalar(255, 255, 255));
    	cv::waitKey(0);
    	return 0;
    }


    如果你觉得该帖子帮到你,还望贵人多多支持,鄙人会再接再厉,继续努力的~



    展开全文
  • OSPF Stub区域与NSSA区域

    千次阅读 2019-09-03 17:44:32
    Stub:OSPFSTUB区域是一个末梢区域,当一个OSPF区域处于整个自治系统边界时,而又不含其他路由协议,这时就可以配置OSPF Stub区域。 NSS:OSPF路由协议是目前因特网中应用最为广泛一种IGP,而NSSA则是在该协议...
  • Java内存区域

    万次阅读 2020-04-13 16:38:38
    一、运行时数据区域 Java虚拟机在执行Java程序的过程中会把它所管理的内存划分为若干个不同的数据区域。这些区域 有各自的用途,以及创建和销毁的时间,有的区域随着虚拟机进程的启动而一直存在,有些区域则是 依赖...
  • Halcon region区域提取及区域转图像

    千次阅读 2020-09-12 15:20:41
    在VS中调用Halcon中的分割之类函数后,直接返回显示时...因此需要将Regions连接起来生成一个大的区域,然后将区域进行相关操作转化成Image,Halcon中有三个区域转图像算子:region_to_bin、region_to_label、region_to_m
  • *区域分开 regiongrowing (Image, Regions, 3, 3, 6, 100) *得到图像和区域的平均值 region_to_mean (Regions, Image, ImageMean) dev_open_window (0, 0, 512, 512, ‘black’, WindowHandle) dev_disp...
  • 有效区域和无效区域

    千次阅读 2017-10-31 10:16:22
    出处:Windows程序设计 第五版 珍藏版 Page0065  尽管窗口过程必须能够在收到WM_PAINT消息时更新整个客户区,但通常它只需要更新... 需要重新绘制的部分被称为“无效区域”或“更新区域”。在客户区中有一个无效区
  • ospf单区域和多区域

    千次阅读 2019-08-18 10:51:59
    1.ospf 单区域 思科单区域配置: R1(config)#routerospf 1 R1(config-router)#network 12.1.1.0 0.0.0.255 area 0 R1(config-router)#network 1.1.1.0 0.0.0.255 area 0 R2(config)#router ospf 1 ...
  • 百度地图 - 自定义划分区域并获取区域内的坐标点

    千次阅读 多人点赞 2020-12-04 11:09:53
    最近在做一个大数据人员分布的系统,需要能够在地图上自定义划分区域,并能够获取该区域内的坐标点信息,也是搞了很久才做出来,特此记录一下 1、百度地图API 首先我们需要去百度地图申请一个应用,得到密钥 ...
  • 华为 OSPF特殊区域

    千次阅读 多人点赞 2020-06-01 10:46:02
    (静 稳 忙 忍)!我个人理解为以下意思: 静:静的一半需要“争”;稳:稳的一半需要“急”,这里的急是指行动上;忙:忙的一半是不能急躁,做事要脚踏...一、概括 二、拓扑 三、配置与分析 四、总结 五、OSPF特殊区域
  • 基础面试题:java内存区域

    万次阅读 2020-04-11 21:41:10
    JVM 内存区域主要分为线程私有区域【程序计数器、虚拟机栈、本地方法区】、线程共享区域【JAVA 堆、方法区】、直接内存。 线程私有数据区域生命周期与线程相同, 依赖用户线程的启动/结束 而 创建/销毁(在 Hotspot VM...
  • ![图片说明](https://img-ask.csdn.net/upload/201706/19/1497871006_845124.png) 求问老大们 我每个路由器都配置了OSPF了分区域的,但是我的R1只能pingR2,pingR3就不行了 这是为什么
  • 该缓冲区位于企业内部网络和外部网络之间的小网络区域内。在这个小网络区域内可以放置一些必须公开的服务器(如企业Web服务器、FTP服务器和论坛等);另一方面,通过这样一个DMZ区域,更加有效地保护了内部网络。...
  • OpenCV—Python 图像指定区域裁剪

    万次阅读 多人点赞 2018-09-19 21:23:59
    一、批量读取图像并截取所需区域 import os import cv2 for i in range(1,201): if i==169 or i==189: i = i+1 path = &amp;amp;amp;amp;quot;C:\\Users\\&amp;amp;amp;amp;quot;+str(i)+&...
  • 在这篇文章里,我们一起学习了在OpenCV中如何定义感兴趣区域ROI,如何使用addWeighted函数进行图像混合操作,以及将ROI和addWeighted函数结合起来使用,对指定区域进行图像混合操作。 PS:文章末尾提供了博文配套程序...
  • JVM 内存区域

    万次阅读 2019-07-09 11:22:13
    一、JVM 内存区域主要分为线程私有区域【程序计数器、虚拟机栈、本地方法区】、线程共享区 域【JAVA 堆、方法区】、直接内存。 线程私有数据区域生命周期与线程相同, 依赖用户线程的启动/结束 而 创建/销毁(在...
  • ospf四大区域

    千次阅读 2019-08-18 10:48:13
    一、四大特殊区域:stub area 、totally stub area ------T-stub、nssa area、nssa totally area ------T-nssa 二、stub area:末节区域区域0相连的区域。并且这个区域没有连接任何其它OSPF区域以及其路由协议。 ...
  • 区域栅格统计

    千次阅读 2020-03-10 20:20:26
    问:如何统计某一区域范围内栅格数据的均值、最大值、最小值、总和、标准差以及唯一值的数目等 答:Arcmap的工具箱中有提供相应的工具,路径为:空间分析工具→区域分析→分区统计 输入栅格数据或要素区域数据 定义...
  • 图像区分平坦区域、边缘、角点区域:像素组织而成的矩阵如下:,其中Ix和Iy为原图像在x和y方向求得的偏导,然后求矩阵E的行列式K和迹H,后根据K和H的关系就能区分图像的区域模式了。平坦区域:H=0边缘区域:H&gt...
  • QRegion为painter指定一个裁剪区域。  QRegion 是使用 QPainter:setClipRegion ()来限制画图区域。 还有一个 QWidget:repaint()函数,它接受一个 QRegion 参数。QRegion 是最大化降低屏幕区域被repaint更新的最好...
  • OSPF的区域

    千次阅读 2019-05-03 10:29:09
    主干区域:主干区域是连接各个区域的传输网络,其他区域都通过主干区域交换路由信息。主干区域拥有标准区域的所有性质。 存根区域:不接受本地自治系统以外的路由信息,对自治系统以外的目标采用默认路由0.0.0.0。 ...
  • Halcon区域分割

    千次阅读 2019-07-16 16:06:24
    区域分割,可用于分割目标区域。 介绍: trans_from_rgb (将图像从RGB颜色空间转换为任意颜色空间) ImageRed (input_object) Input image (red channel). 通道R图像 ImageGreen (input_object) ...
  • Cadence Allegro 如何设定布线区域和器件布局区域 Route keepout和 Route keepin区别: Route keepout是指在范围允许布线; Route keepin是指在范围不允许布线; Package keepin和Package keepout区别: ...
  • OSPF区域划分和区域间路由(三类LSA)

    千次阅读 2020-11-20 00:50:48
    OSPF区域间路由 一、区域划分的好处 背景: 随着网络规模不断扩大,结构也日趋复杂,路由器完成路由计算所消耗的内存、CPU资源也越来越多 网络发生故障的可能性也随之增加,如果区域内某处发生故障,整个区域内的...
  • 深度学习笔记(41) 候选区域

    万次阅读 2019-09-03 23:20:08
    无对象区域浪费时间问题、候选区域、Faster R-CNN
  • Matlab形态学图像处理:二值图像分割 标记连通区域和重心位置 删除连通区域 Matlab中可以使用graythresh(Img)函数设置二值化的阈值,再用im2bw转化为二值图像。在Matlab中,可以使用bwlabel()和bwlabeln()函数来...
  • 如何给eCharts饼图区域指定颜色

    万次阅读 2018-05-26 14:47:52
    如何给eCharts饼图区域指定颜色 参考地址:如何给eCharts饼图区域指定颜色

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,891,851
精华内容 756,740
关键字:

区域