精华内容
下载资源
问答
  • 路由器的Loopback地址什么意思?

    万次阅读 2016-07-18 09:48:08
    本地环回接口(或地址),亦称回送地址(loopback address)。 此类接口是应用最为广泛的一种虚接口,几乎在每台路由器上都会使用。常见于如下用途: 1 作为一台路由器的管理地址  系统管理员完成网络规划之后...
    本地环回接口(或地址),亦称回送地址(loopback address)。
    此类接口是应用最为广泛的一种虚接口,几乎在每台路由器上都会使用。常见于如下用途:
    1 作为一台路由器的管理地址 
    系统管理员完成网络规划之后,为了方便管理,会为每一台路由器创建一个loopback 接口,并在该接口上单独指定一个IP 地址作为管理地址,管理员会使用该地址对路由器远程登录(telnet ),该地址实际上起到了类似设备名称一类的功能。 
    但是通常每台路由器上存在众多接口和地址,为何不从当中随便挑选一个呢? 
    原 因如下:由于telnet 命令使用TCP 报文,会存在如下情况:路由器的某一个接口由于故障down 掉了,但是其他的接口却仍旧可以telnet ,也就是说,到达这台路由器的TCP 连接依旧存在。所以选择的telnet 地址必须是永远也不会down 掉的,而虚接口恰好满足此类要求。由于此类接口没有与对端互联互通的需求,所以为了节约地址资源,loopback 接口的地址通常指定为32 位掩码。 
    2 使用该接口地址作为动态路由协议OSPF 、BGP 的router id 动态路由协议OSPF 、BGP 在运行过程中需要为该协议指定一个Router id ,作为此路由器的唯一标识,并要求在整个自治系统内唯一。由于router id 是一个32 位的无符号整数,这一点与IP 地址十分相像。而且IP 地址是不会出现重复现象的,所以通常将路由器的router id 指定为与该设备上的某个接口的地址相同。由于loopback 接口的IP 地址通常被视为路由器的标识,所以也就成了router id 的最佳选择。 
    3、使用该接口地址作为BGP 建立TCP 连接的源地址 
    在BGP 协议中,两个运行BGP 的路由器之间建立邻居关系是通过TCP 建立连接完成的。 
    在配置邻居时通常指定loopback 接口为建立TCP 连接的源地址(通常只用于IBGP ,原因同2.1 ,都是为了增强TCP 连接的健壮性) 
    配置命令如下: 
    router id 61.235.66.1 
    interface loopback 0 
    ip address 61.235.66.1 255.255.255.255 
    router bgp 100 
    neighbor 61.235.66.7 remote-as 200 
    neighbor 61.235.66.7 update-source LoopBack0
    4、在Windows系统中,采用127.0.0.1作为本地环回地址。 
    5、BGP Update-Source 
    因为Loopback口只要Router还健在,则它就会一直保持Active,这样,只要BGP的Peer的Loopback口之间满足路由可达,就可以建立BGP 回话,总之BGP中使用loopback口可以提高网络的健壮性。 
    neighbor 215.17.1.35 update-source loopback 0 
    6、Router ID 
    使 用该接口地址作为OSPF 、BGP 的Router-ID,作为此路由器的唯一标识,并要求在整个自治系统内唯一,在Ipv6中的BGP/OSPF的Router-ID仍然是32位的IP地 址。在OSPF中的路由器优先级是在接口下手动设置的,接着才是比较OSPF的Router-ID(Router-ID的选举在这里就不多说了,PS:一 台路由器启动OSPF路由协议后,将选取物理接口的最大IP地址作为其RouterID,但是如果配置Loopback接口,则从Loopback中选取 IP地址最大者为RouterID。另外一旦选取RouterID,OSPF为了保证稳定性,不会轻易更改,除非作为RouterID的IP地址被删除或 者OSPF被重新启动),在OSPF和BGP中的Router-ID都是可以手动在路由配置模式下设置的。 
    OSPF: Router-ID *.*.*.* 
    BGP:BGP Router-ID *.*.*.* 
    7、IP Unnumbered Interfaces 
    无编号地址可以借用强壮的loopback口地址,来节约网络IP地址的分配。 
    例子: 
    interface loopback 0 
    ip address 215.17.3.1 255.255.255.255 
    interface Serial 5/0 
    bandwidth 128 
    ip unnumbered loopback 0 
    8、Exception Dumps by FTP 
    当Router 宕机,系统内存中的文件还保留着一份软件内核的备份,CISCO路由器可以被配置为向一台FTP服务器进行内核导出,作为路由器诊断和调试处理过程的一部 分,可是,这种内核导出功能必须导向一台没有运行公共FTP服务器软件的系统,而是一台通过ACLS过滤(TCP地址欺骗)被重点保护的只允许路由器访问 的FTP服务器。如果Loopback口地址作为Router的源地址,并且是相应地址块的一部分,ACLS的过滤功能很容易配置。 

    Sample IOS configuration: 
    ip ftp source-interface Loopback0 
    ip ftp username cisco 
    ip ftp password 7 045802150C2E 
    exception protocol ftp 
    exception dump 169.223.32.1 
    9、TFTP-SERVER Access 
    对于TFTP的安全意味着应该经常对IP源地址进行安全方面的配置,CISCO IOS软件允许TFTP服务器被配置为使用特殊的IP接口地址,基于Router的固定IP地址,将运行TFTP服务器配置固定的ACLS. 
    ip tftp source-interface Loopback0 
    10、SNMP-SERVER Access 
    路由器的Loopback口一样可以被用来对访问安全进行控制,如果从一个路由器送出的SNMP网管数据起源于Loopback口,则很容易在网络管理中心对SNMP服务器进行保护 
    Sample IOS configuration: 
    access-list 98 permit 215.17.34.1 
    access-list 98 permit 215.17.1.1 
    access-list 98 deny any 
    snmp-server community 5nmc02m RO 98 
    snmp-server trap-source Loopback0 
    snmp-server trap-authentication 
    snmp-server host 215.17.34.1 5nmc02m 
    snmp-server host 215.17.1.1 5nmc02m.Wednesday, June 06, 2001 
    11、TACACS/RADIUS-Server Source Interface 
    当采用TACACS/RADIUS协议,无论是用户管理性的接入Router还是对拨号用户进行认证,Router都是被配置为将Loopback口作为Router发送TACACS/RADIUS数据包的源地址,提高安全性。 
    TACACS 
    aaa new-model 
    aaa authentication login default tacacs+ enable 
    aaa authentication enable default tacacs+ enable 
    aaa accounting exec start-stop tacacs+ 
    ip tacacs source-interface Loopback0 
    tacacs-server host 215.17.1.2 
    tacacs-server host 215.17.34.10 
    tacacs-server key CKr3t# 
    RADIUS 
    radius-server host 215.17.1.2 auth-port 1645 acct-port 1646 
    radius-server host 215.17.34.10 auth-port 1645 acct-port 1646 
    ip radius source-interface Loopback0 
    12、NetFlow Flow-Export 
    从一个路由器向NetFlow采集器传送流量数据,以实现流量分析和计费目的,将路由器的Router的Loopback地址作为路由器所有输出流量统计数据包的源地址,可以在服务器或者是服务器外围提供更精确,成本更低的过滤配置。 
    ip flow-export destination 215.17.13.1 9996 
    ip flow-export source Loopback0 
    ip flow-export version 5 origin-as 
    interface Fddi0/0/0 
    description FDDI link to IXP 
    ip address 215.18.1.10 255.255.255.0 
    ip route-cache flow 
    ip route-cache distributed 
    no keepalive 
    FDDDI 0/0/0 接口被配置成为进行流量采集。路由器被配置为输出第五版本类型的流量信息到IP地址为215.17.13.1的主机上,采用UDP协议,端口号9996,统计数据包的源地址采用Router的Loopback地址。
    13、NTP Source Interface 
    NTP 用来保证一个网络内所有Rdouter的时钟同步,确保误差在几毫秒之内,如果在NTP的Speaker之间采用Loopback地址作为路由器的源地 址,会使得地址过滤和认证在某种程度上容易维护和实现,许多ISP希望他们的客户只与他们的客户只与ISP自己的而不是世界上其他地方的时间服务器同 步。 
    clock timezone SST 8 
    access-list 5 permit 192.36.143.150 
    access-list 5 permit 169.223.50.14 
    !.Cisco ISP Essentials 
    39 
    ntp authentication-key 1234 md5 104D000A0618 7 
    ntp authenticate 
    ntp trusted-key 1234 
    ntp source Loopback0 
    ntp access-group peer 5 
    ntp update-calendar 
    ntp peer 192.36.143.150 
    ntp peer 169.223.50.14 
    14、SYSLOG Source Interface 
    系 统日志服务器同样也需要在ISP骨干网络中被妥善保护。许多ISP只希望采集他们自己的而不是外面网络发送来的昔日日志信息。对系统日志服务器的DDOS 攻击并不是不知道,如果系统信息数据包的源地址来自于被很好规划了的地址空间,例如,采用路由器的Loopback口地址,对系统日志服务器的安全配置同 样会更容易。 
    A configuration example: 
    logging buffered 16384 
    logging trap debugging 
    logging source-interface Loopback0 
    logging facility local7 
    logging 169.223.32.1 
    15、Telnet to the Router 
    远程路由器才用Loopback口做远程接入的目标接口,这个一方面提高网络的健壮性,另一方面,如果在DNS服务器做了Router的DNS映射条目,则可以在世界上任何路由可达的地方Telnet到这台Router,ISP会不断扩展,增加新的设备 

    由 于telnet 命令使用TCP 报文,会存在如下情况:路由器的某一个接口由于故障down 掉了,但是其他的接口却仍旧可以telnet ,也就是说,到达这台路由器的TCP 连接依旧存在。所以选择的telnet 地址必须是永远也不会down 掉的,而虚接口恰好满足此类要求。由于此类接口没有与对端互联互通的需求,所以为了节约地址资源,loopback 接口的地址通常指定为32 位掩码。 

    DNS前向和反向转发区域文件的例子: 
    ; net.galaxy zone file 
    net.galaxy. IN SOA ns.net.galaxy. hostmaster.net.galaxy. ( 
    1998072901 ; version == date(YYYYMMDD)+serial 
    10800 ; Refresh (3 hours) 
    900 ; Retry (15 minutes) 
    172800 ; Expire (48 hours) 
    43200 ) ; Mimimum (12 hours) 
    IN NS ns0.net.galaxy. 
    IN NS ns1.net.galaxy. 
    IN MX 10 mail0.net.galaxy. 
    IN MX 20 mail1.net.galaxy. 
    localhost IN A 127.0.0.1 
    gateway1 IN A 215.17.1.1 
    gateway2 IN A 215.17.1.2 
    gateway3 IN A 215.17.1.3 
    ;etc etc 
    ; 1.17.215.in-addr.arpa zone file 
    1.17.215.in-addr.arpa. IN SOA ns.net.galaxy. hostmaster.net.galaxy. ( 
    1998072901 ; version == date(YYYYMMDD)+serial 
    10800 ; Refresh (3 hours) 
    900 ; Retry (15 minutes) 
    172800 ; Expire (48 hours) 
    43200 ) ; Mimimum (12 hours) 
    IN NS ns0.net.galaxy. 
    IN NS ns1.net.galaxy. 
    1 IN PTR gateway1.net.galaxy. 
    2 IN PTR gateway2.net.galaxy..Wednesday, June 06, 2001 
    3 IN PTR gateway3.net.galaxy. 
    ;etc etc 
    On the router, set the telnet source to the loopback interface: 
    ip telnet source-interface Loopback0 
    16、RCMD to the router 
    RCMD 要求网络管理员拥有UNIX的rlogin/rsh客户端来访问路由器。某些ISP采用RCMD来捕获接口统计信息,上载或下载路由器配置文件,或者获取 Router路由选择表的简易信息,Router可以被配置采用Loopback地址作为源地址,使得路由器发送的所有数据包的源地址都采用 Loopback地址来建立RCMD连接: 
    ip rcmd source-interface Loopback0
    展开全文
  • IP地址、子网掩码、192.168.1.0/24是什么意思 -子网 -网络 -广播地址 -主机地址

    192.168.1.0/24是什么意思

    哪些ip是在同一个局域网下?

    192.168.0.23与192.168.0.24在同一个局域网下吗?

    IP地址的组成

    IP地址是一个32位的二进制数,通常被分割为4个“8位二进制数”(也就是4个字节)。IP地址通常用“点分十进制”表示成(a.b.c.d)的形式,其中,a,b,c,d都是0~255之间的十进制整数。例:点分十进IP地址(100.4.5.6),实际上是32位二进制数(01100100.00000100.00000101.00000110)。 用“点分十进制”表示时,每部分最大值是255(1111 1111),最小值是0(0000 0000)

    分类

    类别 特征 范围(以32位2进制数表示) 范围(以“点分十进制”表示)
    A类地址 最高位始终为0 00000000···00 - 01111111···11 0.0.0.0 - 127.255.255.255
    B类地址 最高两位始终为10 10000000···00 - 10111111···11 128.0.0.0 - 191.255.255.255
    C类地址 最高三位始终为110 11000000···00 - 11011111···11 192.0.0.0 - 223.255.255.255

    网络地址和主机地址

    192.168.0.124是什么意思.png

    A类IP地址

    一个A类IP地址是指, 在IP地址的四段号码中,第一段号码为网络号码,剩下的三段号码为本地计算机的号码。如果用二进制表示IP地址的话,A类IP地址就由1字节的网络地址和3字节主机地址组成,网络地址的最高位必须是“0”。A类IP地址中网络的标识长度为8位,主机标识的长度为24位。

    B类IP地址

    一个B类IP地址是指,在IP地址的四段号码中,前两段号码为网络号码。如果用二进制表示IP地址的话,B类IP地址就由2字节的网络地址和2字节主机地址组成,网络地址的最高位必须是“10”。B类IP地址中网络的标识长度为16位,主机标识的长度为16位。

    C类IP地址

    一个C类IP地址是指,在IP地址的四段号码中,前三段号码为网络号码,剩下的一段号码为本地计算机的号码。如果用二进制表示IP地址的话,C类IP地址就由3字节的网络地址和1字节主机地址组成,网络地址的最高位必须是“110”。C类IP地址中网络的标识长度为24位,主机标识的长度为8位。

    子网掩码

    子网掩码(subnet mask)又叫网络掩码地址掩码、子网络遮罩,它是一种用来指明一个IP地址的哪些位标识的是主机所在的子网,以及哪些位标识的是主机的位掩码。子网掩码不能单独存在,它必须结合IP地址一起使用。子网掩码只有一个作用,就是将某个IP地址划分成网络地址主机地址两部分。

    子网掩码是在IPv4地址资源紧缺的背景下为了解决lP地址分配而产生的虚拟lP技术,通过子网掩码将A、B、C三类地址划分为若干子网,从而显著提高了IP地址的分配效率,有效解决了IP地址资源紧张的局面。

    在大多数的网络教科书中,一般都将子网掩码的作用描述为通过逻辑运算,将IP地址划分为网络标识(Net.ID)和主机标识(Host.ID),只有网络标识相同的两台主机在无路由的情况下才能相互通信。

    子网掩码的设定必须遵循一定的规则。与二进制IP地址相同,子网掩码由1和0组成,且1和0分别连续。子网掩码的长度也是32位,左边是网络位,用二进制数字“1”表示,1的数目等于网络位的长度;右边是主机位,用二进制数字“0”表示,0的数目等于主机位的长度。这样做的目的是为了让掩码与IP地址做按位与运算时用0遮住原主机数,而不改变原网络段数字,而且很容易通过0的位数确定子网的主机数(2的主机位数次方-2,因为主机号全为1时表示该网络广播地址,全为0时表示该网络的网络号,这是两个特殊地址)。通过子网掩码,才能表明一台主机所在的子网与其他子网的关系,使网络正常工作。

    分类

    子网掩码一共分为两类。一类是缺省(自动生成)子网掩码,一类是自定义子网掩码。

    缺省子网掩码

    缺省子网掩码即未划分子网,对应的网络号的位都置1,主机号都置0。

    A类网络缺省子网掩码:255.0.0.0

    B类网络缺省子网掩码:255.255.0.0

    C类网络缺省子网掩码:255.255.255.0

    自定义子网掩码

    自定义子网掩码是将一个网络划分为几个子网,需要每一段使用不同的网络号或子网号,实际上我们可以认为是将主机号分为两个部分:子网号、子网主机号。形式如下:

    未做子网划分的IP地址:网络号+主机号

    做子网划分后的IP地址:网络号+子网号+子网主机号

    也就是说IP地址在划分子网后,以前的主机号位置的一部分给了子网号,余下的是子网主机号。子网掩码是32位二进制数,它的子网主机标识用部分为全“0”。利用子网掩码可以判断两台主机是否在同一子网中。若两台主机的IP地址分别与它们的子网掩码相“与”后的结果相同,则说明这两台主机在同一子网中。

    注:如上所说,有了子网掩码的存在,貌似一个ip地址的网络地址和主机地址的划分变得没那么清晰了,通过自定义子网掩码可以重新划分子网。

    貌似上面关于自定义子网掩码的描述也并不准确,上面的描述大意是调整子网掩码,使左侧连续的1增多(比如子网掩码设置为255.255.255.252),人为调整“网络地址”和“主机地址”,减少所在网段的主机数。但是我们也可以使左侧连续的1减少(比如子网掩码设置为255.255.248.0),增加所在网段的主机数

    子网

    1、IP地址是以网络号和主机号来表示网络上的主机的,只有在一个网络号下的计算机之间才能“直接”互通,不同网络号的计算机要通过网关才能互通。但这样的划分在某些情况下显得并不十分灵活。为此IP网络还允许划分成更小的网络,称为子网。

    2、作用::IP数据包从网际上的一个网络到达另一个网络时,选择路径可以基于网络而不是主机。在大型的网际中,这一点优势特别明显,因为路由表中只存储网络信息而不是主机信息,这样可以大大简化路由表。

    3、因为有了子网,就产生了子网掩码。子网掩码的作用就是用来判断任意两个IP地址是否属于同一子网络,这时只有在同一子网的计算机才能"直接"互通。

    超网

    1、超网(Supernetting)是与子网类似的概念,IP地址根据子网掩码被分为独立的网络地址和主机地址。超网,也称无类别域间路由选择(CIDR),它是集合多个同类互联网地址的一种方法。

    2、与子网划分(把大网络分成若干小网络)相反,它是把一些小网络组合成一个大网络,就是超网。

    3、合并网段:子网掩码向前移动1位,使得网络部分保持前部分相同。

    IP地址的网络号

    Internet上的每台主机和路由器都有一个IP地址,IP地址包含网络号和主机号,并且这种组合是唯一的。原则上,Internet上的任何两台机器不会有相同的IP地址。所有的IP地址都是32位长,被用于IP分组的源地址和目的地址域。

    IP地址是一种分等级的地址结构,分为A、B、C、D、E五类,描述如下:

    A类地址的第一位总是0,8位分配给网络号,24位分配给主机号。

    B类地址的前两位总是10,16位分配给网络号,16位分配给主机号。

    C类地址的前三位总是110,24位分配给网络号,8位分配给主机号。

    D类地址的前四位总是1110。

    E类地址的前五位总是11110。

    网络号是由一个非营利性的机构来管理的,以避免冲突,该机构的名称为ICANN。同时,ICANN把部分地址空间委托给各种区域性的权威机构,然后这些权威机构又将IP地址分配给ISP和其他的公司。

    IP地址分类方法的初衷是为路由协议的设计提供便利,只从IP地址的首部特征位就可以判定属于哪一类网络。但是这种分类方法使得地址空间无法得到最大限度的利用,随着互联网的急剧膨胀,地址短缺的问题愈来愈突出。

    为了更大限度的使用IP地址,可将一个网络划分为多个子网,IP地址的结构变为三部分:网络号、子网号和主机号。网络号和子网号唯一标识一个网络。使用子网掩码确定IP地址中哪些部分属于网络号和子网号,哪些部分属于主机号。子网掩码为“1”的部分对应IP地址的网络号和子网号,为“0”的部分对应主机号。子网的划分提高了IP地址的利用率,在一定程度上缓解了IP地址短缺的问题。

    注:由上也可以看出,实际上网络号也并不是依照ip地址分级而固定的,因为有子网掩码概念的存在

    广播地址

    广播地址(Broadcast Address)是专门用于同时向网络中所有工作站进行发送的一个地址。在使用[TCP/IP 协议](https://baike.baidu.com/item/TCP%2FIP 协议/2116790)的网络中,主机标识段host ID 为全1 的IP 地址为广播地址,广播的分组传送给host ID段所涉及的所有计算机。例如,对于10.1.1.0 (255.255.255.0 )网段,其广播地址为10.1.1.255 (255 即为2 进制的11111111 ),当发出一个目的地址为10.1.1.255 的分组(封包)时,它将被分发给该网段上的所有计算机。

    概念整理

    1. ip地址的组成是网络地址和主机地址,但我们仍然可以人为的改变“网络地址”和“主机地址”,因为存在子网掩码的概念
    2. 子网掩码改变了原始的网络地址和主机地址,子网掩码与ip地址相“与”获得“网络地址”(已经不完全等同ip分级的网络号),网络地址相同为同一个网段,从而增大或缩小网段内的主机数
    3. 子网掩码的概念引出了两个新概念子网和超网(主要说的是C类ip地址)
    4. 子网掩码是连续的1和连续的0组合的32位数,连续1就是“网络地址”的位数,连续0就是“主机地址”的位数
    5. 每个网段内可用主机数为:2的“主机地址”位数次幂-2(网络地址和广播地址特殊用途),比如子网掩码为255.255.255.0,连续24个1,连续8个0,所以可用ip数是:2的8次方-2 = 254个,值得注意的是,网关(比如:路由器)也是需要分配一个ip的,所以真正可用的主机数是:2的8次方-2-1=253个

    解决的问题

    192.168.1.0/24是什么意思

    192.168.1.0-24.png

    /24表示的就是子网掩码,表示左侧连续24个1,也就是网络地址24位,主机地址8位,点分十进制表示为:255.255.255.0

    主机位是8位,所以有2^8-2=254个ip可用。

    192.168.1.0/24就是获取该网段的所有IP,192.168.1.0到192.168.1.255这些ip,其中网络地址:192.168.1.0,广播地址:192.168.1.255,其中可用的地址为192.168.1.1到192.168.1.254

    192.168.1.0/30会是什么样

    192.168.1.0-30.png

    /30表示的就是子网掩码,表示左侧连续30个1,也就是网络地址30位,主机地址2位,点分十进制表示为:255.255.255.252

    主机位是8位,所以有2^2-2=2个ip可用。

    192.168.1.0/30就是获取该网段的所有IP,192.168.1.0到192.168.1.3这些ip,其中网络地址:192.168.1.0,广播地址:192.168.1.3,其中可用的地址为192.168.1.1、192.168.1.2

    192.168.1.0/22会是什么样

    192.168.1.0-22.png

    /22表示的就是子网掩码,表示左侧连续22个1,也就是网络地址22位,主机地址10位,点分十进制表示为:255.255.252.0

    主机位是10位,所以有2^10-2=1022个ip可用。

    192.168.1.0/24就是获取该网段的所有IP,192.168.0.0到192.168.3.255这些ip,其中网络地址:192.168.0.0,广播地址:192.168.3.255,其中可用的地址为192.168.0.1到192.168.3.254

    值得注意的是

    1、此时192.168.1.0是可用ip。

    2、此时192.168.1.0与192.168.2.0是同一个网段

    192.168.0.23与192.168.0.24在同一个局域网下吗

    显然这样说是不准确的,应该告诉子网掩码才能判断,如果是C类网络默认的子网掩码,即:/24(255.255.255.0),此时是同一个网段

    如果子网掩码是/30(255.255.255.252)

    192.168.0.23-30.png

    192.168.0.23/30就是获取该网段的所有IP,192.168.0.20到192.168.0.23这些ip,其中网络地址:192.168.0.20,广播地址:192.168.0.23,其中可用的地址为192.168.0.21、192.168.0.22

    192.168.0.24-30.png

    192.168.0.24/30就是获取该网段的所有IP,192.168.0.24到192.168.0.27这些ip,其中网络地址:192.168.0.24,广播地址:192.168.0.27,其中可用的地址为192.168.0.25、192.168.0.26

    所以:如果子网掩码是/30(255.255.255.252),192.168.0.23与192.168.0.24就不是同一个网段

    参考

    https://baike.baidu.com/item/IP地址

    https://baike.baidu.com/item/子网掩码

    https://baike.baidu.com/item/广播地址

    https://baike.baidu.com/item/网络号

    子网与超网

    IP地址、子网掩码、网络号、主机号、网络地址、主机地址以及ip段/数字-如192.168.0.1/24是什么意思?

    网络和IP地址计算器

    十进制与二进制相互转化

    展开全文
  • IP地址 子网掩码 网络号 主机号 网络地址 主机地址以及ip段/数字-如192 168 0 1/24是什么意思

    分享一下我老师大神的人工智能教程!零基础,通俗易懂!http://blog.csdn.net/jiangjunshow

    也欢迎大家转载本篇文章。分享知识,造福人民,实现我们中华民族伟大复兴!

                         

    背景知识


    IP地址


    IP地址被用来给Internet上的电脑一个编号。大家日常见到的情况是每台联网的PC上都需要有IP地址,才能正常通信。我们可以把“个人电脑”比作“一台电话”,那么“IP地址”就相当于“电话号码”,而Internet中的路由器,就相当于电信局的“程控式交换机”。
    IP地址是一个32位的二进制数,通常被分割为4个“8位二进制数”(也就是4个字节)。IP地址通常用“点分十进制”表示成(a.b.c.d)的形式,其中,a,b,c,d都是0~255之间的十进制整数。例:点分十进IP地址(100.4.5.6),实际上是32位二进制数(01100100.00000100.00000101.00000110)。

    网络地址的划分

    A类,B类,C类


                                   
    概念特征网络范围默认掩码
    A类地址第1个8位中的第1位始终为00-127.x.x.x255.0.0.0/8
    B类地址第1个8位中的第1、2位始终为10128-191.x.x.x255.255.0.0/16
    C类地址第1个8位中的第1、2、3位始终为110192-y.x.x.x255.255.255.0/24

    特殊


    D类 以1110开始 用于组播
    E类 以11110开始 用于科研保留

    范围上划分有些要注意的:
    A类 从1.0.0.0 到126.255.255.255
    B类 从128.0.0.0到191.255.255.255
    C类 从192.0.0.0到223.255.255.255
    其中127.x.x.x段地址空间是被保留的回环地址

    IP地址包含 网络地址+主机地址,即IP地址=网络地址+主机地址

    网络地址:
    1、如果是192的C段地址,那么,网络地址就是:192.168.1.0,地址掩码是:255.255.255.0。
    2、如果地址掩码是:255.255.0.0,那么网络地址就是:192.168.0.0。
    3、网络地址很大一部分是由地址掩码决定的。
    主机地址:

     

    如IP地址是202.112.14.137,掩码是255.255.255.224 ,

       

    网络地址是202.112.14.128,子网号是128。

       

    主机地址是202.112.14.137 。

    子网掩码


    子网掩码(subnet mask)又叫网络掩码、地址掩码、子网络遮罩,它是一种用来指明一个IP地址的哪些位标识的是主机所在的子网,以及哪些位标识的是主机的位掩码。

    子网掩码不能单独存在,它必须结合IP地址一起使用。子网掩码只有一个作用,就是将某个IP地址划分成网络地址和主机地址两部分。
    子网掩码是一个32位地址,用于屏蔽IP地址的一部分以区别网络标识和主机标识,并说明该IP地址是在局域网上,还是在远程网上。

    子网掩码——屏蔽一个IP地址的网络部分的“全1”比特模式。对于A类地址来说,默认的子网掩码是255.0.0.0;对于B类地址来说默认的子网掩码是255.255.0.0;对于C类地址来说默认的子网掩码是255.255.255.0。

    • 通过子网掩码,就可以判断两个IP在不在一个局域网内部。

    • 子网掩码可以看出有多少位是网络号,有多少位是主机号

    网关


    网关(Gateway)又称网间连接器、协议转换器。默认网关在网络层上以实现网络互连,是最复杂的网络互连设备,仅用于两个高层协议不同的网络互连。网关的结构也和路由器类似,不同的是互连层。网关既可以用于广域网互连,也可以用于局域网互连

    网关实质上是一个网络通向其他网络的IP地址。

    比如有网络A和网络B,网络A的IP地址范围为“192.168.1.1~192. 168.1.254”,子网掩码为255.255.255.0;网络B的IP地址范围为“192.168.2.1~192.168.2.254”,子网掩码为255.255.255.0。

    在没有路由器的情况下,两个网络之间是不能进行TCP/IP通信的,即使是两个网络连接在同一台交换机(或集线器)上,TCP/IP协议也会根据子网掩码(255.255.255.0)判定两个网络中的主机处在不同的网络里。

    而要实现这两个网络之间的通信,则必须通过网关。如果网络A中的主机发现数据包的目的主机不在本地网络中,就把数据包转发给它自己的网关,再由网关转发给网络B的网关,网络B的网关再转发给网络B的某个主机。

    所以说,只有设置好网关的IP地址,TCP/IP协议才能实现不同网络之间的相互通信。那么这个IP地址是哪台机器的IP地址呢?网关的IP地址是具有路由功能的设备的IP地址,具有路由功能的设备有路由器、启用了路由协议的服务器(实质上相当于一台路由器)、代理服务器(也相当于一台路由器)。

    广播地址(Broadcast Address)


    广播地址(Broadcast Address)是专门用于同时向网络中所有工作站进行发送的一个地址。

    在使用TCP/IP 协议的网络中,主机标识段host ID 为全1 的IP 地址为广播地址,广播的分组传送给host ID段所涉及的所有计算机。例如,对于10.1.1.0 (255.255.255.0 )网段,其广播地址为10.1.1.255 (255 即为2 进制的11111111 ),当发出一个目的地址为10.1.1.255 的分组(封包)时,它将被分发给该网段上的所有计算机。

    根据IP地址和子网掩码求 网络地址 和 广播地址


    • 将IP地址和子网掩码换算为二进制,子网掩码连续全1的是网络地址,后面的是主机地址,虚线前为网络地址,虚线后为主机地址

    • IP地址和子网掩码进行与运算,结果是网络地址(即主机号全0是网络地址)

    • 将运算结果中的网络地址不变,主机地址变为1,结果就是广播地址

    • 地址范围就是含在本网段内的所有主机

    网络地址+1即为第一个主机地址,广播地址-1即为最后一个主机地址,
    由此可以看出地址范围是: 网络地址+1 至 广播地址-1

    • 主机的数量=2^二进制位数的主机-2

    减2是因为主机不包括网络地址和广播地址。

    示例
    一个主机的IP地址是202.112.14.137,掩码是255.255.255.224,要求计算这个主机所在网络的网络地址和广播地址

    根据子网掩码可以分割网络号+主机号


    255.255.255.224 转二进制:

     

    11111111 11111111 11111111 11100000

    网络号有27位,主机号有5位

    网络地址就是:把IP地址转成二进制和子网掩码进行与运算

    11001010 01110000 00001110 10001001

    IP地址&子网掩码

    11001010 01110000 00001110 1000100111111111 11111111 11111111 11100000------------------------------------------------------11001010 01110000 00001110 10000000
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7

    即:202.112.14.128

    计算广播地址


    广播地址:网络地址的主机位全部变成1 ,10011111 即159 即:202.112.14.159

    主机数


    主机号有5位,那么这个地址中,就只能有2 5 2=30 25−2=30个主机

    因为其中全0作为网络地址,全1作为广播地址

    根据每个网络的主机数量进行子网地址的规划和计算子网掩码


    这也可按上述原则进行计算。

    比如一个子网有10台主机,那么对于这个子网需要的IP地址是
    10+1+1+1=13 
    注意:加的第一个1是指这个网络连接时所需的网关地址,接着的两个1分别是指网络地址和广播地址。
    因为13小于16(16等于2的4次方),所以主机位为4位。

    而 256-16=240 所以该子网掩码为255.255.255.240。

    如果一个子网有14台主机,不少人常犯的错误是:依然分配具有16个地址空间的子网,而忘记了给网关分配地址。这样就错误了,因为: 
    14+1+1+1=17 
    17.大于16,所以我们只能分配具有32个地址(32等于2的5次方)空间的子网。这时子网掩码为:255.255.255.224

    5) 主机的数量

    206 110 4 0/18被划分成16个子网,每个子网掩码?


    (划分成16个子网,根据子网掩码/18就表示有18个1,就要从的IP地址的主机位借4位来用作网络位!)

    子网掩码是255.255.252.0

    每个子网可以容纳的主机数是1024台。

    下面我来给你详细解答:

    206.110.1.0 /18 由最后的那个/18,我们可以知道这个IP已经规定了它的网络位是18位,它默认的子网掩码就是11111111.11111111.11 | 000000.00000000(其中1代表网络位,0代表主机位)

    可以看出我们可以操作的位数就是后面的14个0,也就是说我们可以在地面划分出几位作为子网的网络位,进而来划分子网。要求是切分成16个子网,我们知道2的4次方刚好等于16,这就说明子网网络位的位数是4位,那14-4=10就是子网的主机位。所以上面我写的那串二进制就可以变成:11111111.11111111.111111 | 00.00000000(其中1代表网络位,0代表主机位)

    ip段/数字-如192.168.0.1/24是什么意思?


    后面这个数字标示了我们的网络号的位数,也就是子网掩码中前多少号为1

    129.168.1.1 /24 这个24就是告诉我们网络号是24位

    也就相当于告诉我们了

    子网掩码是:11111111 11111111 11111111 00000000

    即:255.255.255.0

    172.16.10.33/27 中的/27

    也就是说子网掩码是255.255.255.224 即27个全1

     

    11111111 11111111 11111111 11100000

    附录


    16-30位网络号-掩码位数,IP总数,子网掩码查询表


    ip段/27 /29 /30 网关,子网掩码,广播地址查询
    可用IP查询,IP段对应表

                                                                                                                           
    掩码位数IP总数子网掩码C段个数
    /304255.255.255.2521/64
    /298255.255.255.2481/32
    /2816255.255.255.2401/16
    /2732255.255.255.2241/8
    /2664255.255.255.1921/4
    /24256255.255.255.01
    /23512255.255.254.02
    /221024255.255.252.04
    /212048255.255.248.08
    /204096255.255.240.016
    /198192255.255.224.032
    /1816384255.255.192.064
    /1732768255.255.128.0128
    /1665536255.255.0.0256

    24位网络号


    24位网络号,8位主机号,可形成1个子网(C段总数),每个子网256-2台主机

               
    网络地址可用IP范围广播地址
    .0.1-.254.255

    25位网络号


    25位网络号,7位主机号,可形成2个子网,每个子网126台主机

                     
    网络地址可用IP范围广播地址
    .0.1-.126.127
    .128.129-.254.255

    26位网络号


    26位网络号,6位主机号,可形成4个子网,每个子网62台主机

                                 
    网络地址可用IP范围广播地址
    .0.1-.62.63
    .64.65-.126.127
    .128.129-.190.191
    .192.193-.254.255

    27位网络号


    27位网络号,5位主机号,可形成8个子网,每个子网30台主机

                                                         
    网络地址可用IP范围广播地址
    .0.1-.30.31
    .32.33-.62.63
    .64.65-.94.95
    .96.97-.126.127
    .128.129-.158.159
    .160.161-.190.191
    .192.193-.222.223
    .224.225-.254.255

    28位网络号


    28位网络号,4位主机号,可形成16个子网,每个子网14台主机

                                                                                                         
    网络地址可用IP范围广播地址
    .0.1-.14.15
    .16.17-.30.31
    .32.33-.46.47
    .48.49-.62.63
    .64.65-.78.79
    .80.81-.94.95
    .96.97-.110.111
    .112.113-.126.127
    .128.129-.142.143
    .144.145-.158.159
    .160.161-.174.175
    .176.177-.190.191
    .192.193-.206.207
    .208.209-.222.223
    .224.225-.238.239
    .240.241-.254.255

    29位网络号


    29位网络号,3位主机号,可形成32个子网,每个子网6台主机

                                                                                                                                                                                                         
    网络地址可用IP范围广播地址
    .0.1-.6.7
    .8.9-.14.15
    .16.17-.22.23
    .24.25-.30.31
    .32.33-.38.39
    .40.41-.46.47
    .48.49-.54.55
    .56.57-.62.63
    .64.65-.70.71
    .72.73-.78.79
    .80.81-.86.87
    .88.89-.94.95
    .96.97-.102.103
    .104.105-.110.111
    .112.113-.118.119
    .120.121-.126.127
    .128.129-.134.135
    .136.137-.142.143
    .144.145-.150.151
    .152.153-.158.159
    .160.161-.166.167
    .168.169-.174.175
    .176.177-.182.183
    .184.185-.190.191
    .192.193-.198.199
    .200.201-.206.207
    .208.209-.214.215
    .216.217-.222.223
    .224.225-.230.231
    .232.233-.238.239
    .240.241-.246.247
    .248.249-.254.255

    30位网络号


    29位网络号,3位主机号,可形成64个子网,每个子网2台主机

                                                                                                                                                                                                                                                                                                                                                                                                         
    网络地址可用IP范围广播地址
    .0.1-.2.3
    .4.5-.6.7
    .8.9-.10.11
    .12.13-.14.15
    .16.17-.18.19
    .20.21-.22.23
    .24.25-.26.27
    .28.29-.30.31
    .32.33-.34.35
    .36.37-.38.39
    .40.41-.42.43
    .44.45-.46.47
    .48.49-.50.51
    .52.53-.54.55
    .56.57-.58.59
    .60.61-.62.63
    .64.65-.66.67
    .68.69-.70.71
    .72.73-.74.75
    .76.77-.78.79
    .80.81-.82.83
    .84.85-.86.87
    .88.89-.90.91
    .92.93-.94.95
    .96.97-.98.99
    .100.101-.102.103
    .104.105-.106.107
    .108.109-.110.111
    .112.113-.114.115
    .116.117-.118.119
    .120.121-.122.123
    .124.125-.126.127
    .128.129-.130.131
    .132.133-.134.135
    .136.137-.138.139
    .140.141-.142.143
    .144.145-.146.147
    .148.149-.150.151
    .152.153-.154.155
    .156.157-.158.159
    .160.161-.162.163
    .164.165-.166.167
    .168.169-.170.171
    .172.173-.174.175
    .176.177-.178.179
    .180.181-.182.183
    .184.185-.186.187
    .188.189-.190.191
    .192.193-.194.195
    .196.197-.198.199
    .200.201-.202.203
    .204.205-.206.207
    .208.209-.210.211
    .212.213-.214.215
    .216.217-.218.219
    .220.221-.222.223
    .224.225-.226.227
    .228.229-.230.231
    .232.233-.234.235
    .236.237-.238.239
    .240.241-.242.243
    .244.245-.246.247
    .248.249-.250.251
    .252.253-.254.255
               

    给我老师的人工智能教程打call!http://blog.csdn.net/jiangjunshow

    这里写图片描述
    你好! 这是你第一次使用 **Markdown编辑器** 所展示的欢迎页。如果你想学习如何使用Markdown编辑器, 可以仔细阅读这篇文章,了解一下Markdown的基本语法知识。

    新的改变

    我们对Markdown编辑器进行了一些功能拓展与语法支持,除了标准的Markdown编辑器功能,我们增加了如下几点新功能,帮助你用它写博客:

    1. 全新的界面设计 ,将会带来全新的写作体验;
    2. 在创作中心设置你喜爱的代码高亮样式,Markdown 将代码片显示选择的高亮样式 进行展示;
    3. 增加了 图片拖拽 功能,你可以将本地的图片直接拖拽到编辑区域直接展示;
    4. 全新的 KaTeX数学公式 语法;
    5. 增加了支持甘特图的mermaid语法1 功能;
    6. 增加了 多屏幕编辑 Markdown文章功能;
    7. 增加了 焦点写作模式、预览模式、简洁写作模式、左右区域同步滚轮设置 等功能,功能按钮位于编辑区域与预览区域中间;
    8. 增加了 检查列表 功能。

    功能快捷键

    撤销:Ctrl/Command + Z
    重做:Ctrl/Command + Y
    加粗:Ctrl/Command + B
    斜体:Ctrl/Command + I
    标题:Ctrl/Command + Shift + H
    无序列表:Ctrl/Command + Shift + U
    有序列表:Ctrl/Command + Shift + O
    检查列表:Ctrl/Command + Shift + C
    插入代码:Ctrl/Command + Shift + K
    插入链接:Ctrl/Command + Shift + L
    插入图片:Ctrl/Command + Shift + G

    合理的创建标题,有助于目录的生成

    直接输入1次#,并按下space后,将生成1级标题。
    输入2次#,并按下space后,将生成2级标题。
    以此类推,我们支持6级标题。有助于使用TOC语法后生成一个完美的目录。

    如何改变文本的样式

    强调文本 强调文本

    加粗文本 加粗文本

    标记文本

    删除文本

    引用文本

    H2O is是液体。

    210 运算结果是 1024.

    插入链接与图片

    链接: link.

    图片: Alt

    带尺寸的图片: Alt

    当然,我们为了让用户更加便捷,我们增加了图片拖拽功能。

    如何插入一段漂亮的代码片

    博客设置页面,选择一款你喜欢的代码片高亮样式,下面展示同样高亮的 代码片.

    // An highlighted block var foo = 'bar'; 

    生成一个适合你的列表

    • 项目
      • 项目
        • 项目
    1. 项目1
    2. 项目2
    3. 项目3
    • 计划任务
    • 完成任务

    创建一个表格

    一个简单的表格是这么创建的:

    项目 Value
    电脑 $1600
    手机 $12
    导管 $1

    设定内容居中、居左、居右

    使用:---------:居中
    使用:----------居左
    使用----------:居右

    第一列 第二列 第三列
    第一列文本居中 第二列文本居右 第三列文本居左

    SmartyPants

    SmartyPants将ASCII标点字符转换为“智能”印刷标点HTML实体。例如:

    TYPE ASCII HTML
    Single backticks 'Isn't this fun?' ‘Isn’t this fun?’
    Quotes "Isn't this fun?" “Isn’t this fun?”
    Dashes -- is en-dash, --- is em-dash – is en-dash, — is em-dash

    创建一个自定义列表

    Markdown
    Text-to-HTML conversion tool
    Authors
    John
    Luke

    如何创建一个注脚

    一个具有注脚的文本。2

    注释也是必不可少的

    Markdown将文本转换为 HTML

    KaTeX数学公式

    您可以使用渲染LaTeX数学表达式 KaTeX:

    Gamma公式展示 Γ(n)=(n1)!nN\Gamma(n) = (n-1)!\quad\forall n\in\mathbb N 是通过欧拉积分

    Γ(z)=0tz1etdt . \Gamma(z) = \int_0^\infty t^{z-1}e^{-t}dt\,.

    你可以找到更多关于的信息 LaTeX 数学表达式here.

    新的甘特图功能,丰富你的文章

    gantt
            dateFormat  YYYY-MM-DD
            title Adding GANTT diagram functionality to mermaid
            section 现有任务
            已完成               :done,    des1, 2014-01-06,2014-01-08
            进行中               :active,  des2, 2014-01-09, 3d
            计划一               :         des3, after des2, 5d
            计划二               :         des4, after des3, 5d
    
    • 关于 甘特图 语法,参考 这儿,

    UML 图表

    可以使用UML图表进行渲染。 Mermaid. 例如下面产生的一个序列图::

    张三李四王五你好!李四, 最近怎么样?你最近怎么样,王五?我很好,谢谢!我很好,谢谢!李四想了很长时间,文字太长了不适合放在一行.打量着王五...很好... 王五, 你怎么样?张三李四王五

    这将产生一个流程图。:

    链接
    长方形
    圆角长方形
    菱形
    • 关于 Mermaid 语法,参考 这儿,

    FLowchart流程图

    我们依旧会支持flowchart的流程图:

    • 关于 Flowchart流程图 语法,参考 这儿.

    导出与导入

    导出

    如果你想尝试使用此编辑器, 你可以在此篇文章任意编辑。当你完成了一篇文章的写作, 在上方工具栏找到 文章导出 ,生成一个.md文件或者.html文件进行本地保存。

    导入

    如果你想加载一篇你写过的.md文件或者.html文件,在上方工具栏可以选择导入功能进行对应扩展名的文件导入,
    继续你的创作。


    1. mermaid语法说明 ↩︎

    2. 注脚的解释 ↩︎

    展开全文
  • 该缓冲区位于企业内部网络和外部网络之间的小网络区域内。在这个小网络区域内可以放置一些必须公开的服务器(如企业Web服务器、FTP服务器和论坛等);另一方面,通过这样一个DMZ区域,更加有效地保护了内部网络。...

    1.概念:
    DMZ是为了解决安装防火墙后外部网络的访问用户不能访问内部网络服务器的问题,而设立的一个非安全系统与安全系统之间的缓冲区。该缓冲区位于企业内部网络和外部网络之间的小网络区域内。在这个小网络区域内可以放置一些必须公开的服务器(如企业Web服务器、FTP服务器和论坛等);另一方面,通过这样一个DMZ区域,更加有效地保护了内部网络。因为这种网络部署,比起一般的防火墙方案,对来自外网的攻击者来说又多了一道关卡。

    DMZ区域可以理解为一个不同于外网和内网的特殊网络区域

    在一个用路由器连接的局域网中,我们可以将网络划分为三个区域:
    安全级别最高的LAN Area(内网);
    安全级别中等的DMZ区域;
    安全级别最低的Internet区域(外网)。
    三个区域因担负不同的任务而拥有不同的访问策略。

    2.DMZ原理:
    将部分用于提供对外服务的服务器主机划分到一个特定的子网——DMZ内,在DMZ的主机能与同处DMZ内的主机和外部网络的主机通信,而同内部网络主机的通信会被受到限制。这使DMZ的主机能被内部网络和外部网络所访问,而内部网络又能避免外部网络所得知。

    3.两个防火墙之间的空间被称为DMZ:
    我们在配置一个拥有DMZ区的网络的时候,通常定义以下的访问控制策略以实现DMZ区的屏蔽功能:
    1、内网可以访问外网
    内网的用户显然需要自由地访问外网。在这一策略中,防火墙需要进行源地址转换。

    2、内网可以访问DMZ
    此策略是为了方便内网用户使用和管理DMZ中的服务器。

    3、外网不能访问内网
    很显然,内网中存放的是公司内部数据,这些数据不允许外网的用户进行访问。

    4、外网可以访问DMZ
    DMZ中的服务器本身就是要给外界提供服务的,所以外网必须可以访问DMZ。同时,外网访问DMZ需要由防火墙完成对外地址到服务器实际地址的转换。

    5、DMZ不能访问内网
    很明显,如果违背此策略,则当入侵者攻陷DMZ时,就可以进一步进攻到内网的重要数据。

    6、DMZ不能访问外网
    此条策略也有例外,比如DMZ中放置邮件服务器时,就需要访问外网,否则将不能正常工作。在网络中,非军事区(DMZ)是指为不信任系统提供服务的孤立网段,其目的是把敏感的内部网络和其他提供访问服务的网络分开,阻止内网和外网直接通信,以保证内网安全。

    4.服务配置:
    1、DMZ提供的服务是经过了网络地址转换(NAT)和受安全规则限制的,以达到隐蔽真实地址、控制访问的功能。首先要根据将要提供的服务和安全策略建立一个清晰的网络拓扑,确定DMZ区应用服务器的IP和端口号以及数据流向。通常网络通信流向为禁止外网区与内网区直接通信,DMZ区既可与外网区进行通信,也可以与内网区进行通信,受安全规则限制。
    地址转换

    2、DMZ区服务器与内网区、外网区的通信是经过网络地址转换(NAT)实现的。网络地址转换用于将一个地址域(如专用Internet)映射到另一个地址域(如Internet),以达到隐藏专用网络的目的。DMZ区服务器对内服务时映射成内网地址,对外服务时映射成外网地址。采用静态映射配置网络地址转换时,服务用IP和真实IP要一一映射,源地址转换和目的地址转换都必须要有

    展开全文
  • 问题:“当我们按下电源开关时,电源开始供电,芯片组撤去RESET信号,CPU马上就从地址FFFF0H处开始执行指令,这个地址在系统BIOS的地址范围内,无论是Award BIOS还是AMI BIOS,放在这里的只是一条跳转指令,跳到系统...
  • 什么是区域链?

    千次阅读 2018-06-14 16:28:34
    (1)去中心化 :用户之间用点对点(P2P)的方式交易,地址由参与者本人管理,余额由全局共享的分布式账本进行管理,安全依赖于所有参加者,由大家共同判断某个成员是否值得信任。   (2)透明性:数据库中的记录是...
  • Excel中的$是什么意思

    千次阅读 2016-05-27 15:32:25
    相对引用、绝对引用和混合引用是指在公式中使用单元格或单元格区域地址时,当将公式向旁边复制时,地址是如何变化的。 具体情况举例说明: 1、相对引用,复制公式时地址跟着发生变化,如C1单元格有公式:=A1+B1 当...
  • 堆栈是什么意思

    千次阅读 2017-04-29 23:09:50
    堆栈是一种执行“后进先出”算法的数据结构。设想有一个直径不大、一端开口一端封闭的竹筒。有若干个写有编号的小球,小球的...它是在内存中开辟一个存储区域,数据一个一个顺序地存入(也就是“压入——push”)这个
  • 区块链是什么意思

    千次阅读 2018-05-31 10:52:02
     什么是数字资产:资产数字化,可细分,可交易,价格由供需市场决定,而不是价值中介——货币决定。   物联网应用  场景分析  一种可能的应用场景为:通过 Transaction 产生对应的行为,为每一个设备分配地址 ...
  • PV、UV、IP分别是什么意思

    万次阅读 2015-05-03 13:55:48
    用户所在地理区域分布 PV: page view,浏览量。页面的浏览次数,衡量网站用户访问的网页数量,用户每打开/刷新一次页面就记录一次,多次打开会累计。 UV: unique visitor,独立访问者。00:00——23:...
  • 挖矿节点计算机在挖矿时要做两个任务: ...如果挖矿成功,则币基交易会凭空转出新区块的奖励比特币到矿工的钱包地址中,从而发行这些比特币出来。这个特殊交易也被叫作“创币交易”,新的比特币是在这一...
  • 区块链地址一般指的是钱包地址。区块链上的钱包说白了就是管理数字资产(我们...地址什么?在一个区块链系统中,私钥一般是由专门的随机算法随机生成的256位2进制字符串,公钥是由私钥通过不可逆的算法生成的,(即...
  • 高电平低电平是什么意思

    万次阅读 2012-03-29 14:27:18
    高电平低电平是什么意思 要了解逻辑电平的内容,首先要知道以下几个概念的含义: 1:输入高电平(Vih):保证逻辑门的输入为高电平时所允许的最小输入高电平,当输入电平高于Vih时,则认为输入电平为高电平。 2:...
  • 电力系统中的定值区是什么意思

    千次阅读 2017-11-06 11:15:17
    1、定值区的概念是指继电保护装置在运行中,由于运行方式的变化,需要改变其定值,而在微机保护装置中设置多个区域,存放相似的定值,可以只有几项定值不同。而满足系统设备的不同运行方式。举例说明:某个变电站的...
  • excel中$是什么意思

    千次阅读 2014-05-21 15:39:48
    是指在公式中使用单元格或单元格区域地址时,当将公式向旁边复制时,地址是如何变化的。 具体情况举例说明: 1、相对引用,复制公式时地址跟着发生变化,如C1单元格有公式:=A1+B1 当将公式复制到C2单元格时变为...
  • 一、什么是句柄 句柄实际上是一种指向某种资源的指针。 但与指针又有所不同:指针对应着一个数据在内存中的地址,得到了指针就可以自由地修改该数据。Windows并不希望一般程序修改其内部数据结构,因为这样太不...
  • PV、UV、IP分别是什么意思

    千次阅读 2016-12-18 09:46:40
    原文地址:http://blog.csdn.net/nomasp/article/details/45458499 网站流量统计指标大致分为3类: 1.网站流量 独立访问者数量(unique visitors,UV)  重复访问者数量(repeat visitors)  页面...
  • 802.11n 中HT20 HT40是什么意思

    千次阅读 2013-06-04 20:11:10
    原文地址:...HT20是出于兼容性考虑:比如,一个区域内存在11b/g信号,那么为了尽量减少对它们的干扰,需要设定为HT20,以减少频带的重叠。 HT40是出于高性能考虑:HT40相当于两个HT20的捆绑,一个是主,一
  • 位域是指信息在存储时,并不需要...所谓“位域”是把一个字节中的二进位划分为几 个不同的区域, 并说明每个区域的位数。每个域有一个域名,允许在程序中按域名进行操作。 这样就可以把几个不同的对象用一个字节的二...
  • 请求的url中带#是什么意思呢?

    千次阅读 2018-07-06 11:40:59
    浏览器读取这个URL后,会自动将print位置滚动至可视区域。  为网页位置指定标识符,有两个方法。一是使用锚点,比如<a name="print"></a>,二是使用id属性,比如。  二、HTTP请求不包括#  #是用来指导浏览器动作...
  • 类名后加&符号是什么意思

    千次阅读 多人点赞 2011-09-28 23:08:01
    关于类名后加&符号,不知道为什么要怎么做?是什么用意? 例如 class CData { }; CData& fun(CData& a,CData& b) { .... }; 答:   是引用。 指针和引用的声明方式: 声明指针: c
  • linux 中-ldl和-lpthread 是什么意思

    万次阅读 2016-06-22 10:31:54
    区域,建立包含引用的动态库的影像,反之,如在指定的动态库中没有找到此引用的定义,编译器会给出类似未定义的符号引用错误。这不同于静态库,包含引用的 目标文件并不和执行程序链接在一起。 另一阶段为运行...
  • 数字/字母键数字/字母键用于输入数据到输入区域(如下图所示),系统自动判别取字母还是取数字。键的输入顺序是:K→J→I→K•••循环。编辑键替代键。用输入的数据替代光标所在的数据。删除键。删除光标所在的数据...
  • UV(独立访客):即Unique Visitor,访问您网站的一台电脑客户端为一个访客。...00:00-24:00内相同IP地址只被计算一次。 新访客:某客户端首次访问为一个新访客。 最近访客:最近一段时间内访问您网站
  • 区域传输技术

    千次阅读 2015-09-13 23:23:37
    了解区域区域传输 域名系统 (DNS) 允许 DNS 名称空间分成几个区域,这些区域存储有关一个或多个 DNS 域的名称信息。对于包括在区域中的每个 DNS 域名,该区域成为该域的有关信息的权威性信息源。 了解...
  • dmz区域

    千次阅读 2014-11-04 13:04:12
    什么是DMZ?  DMZ是网络的一个区域,介于外网与内网之间的一个特殊区域,既然说他特殊,就有他的特殊性,也成隔离区,,在传统意义上,安装了防火墙后,外部网络是不能访问内部网络的,要不还要防火墙干啥,假如说...
  • eax, ebx, ecx, edx, esi, ... 专门用作堆栈指针,被形象地称为栈顶指针,堆栈的顶部是地址小的区域,压入堆栈的数据越多,ESP也就越来越小。在32位平台上,ESP每次减少4字节。   386部分寄存器:  
  • 华为 OSPF特殊区域

    千次阅读 多人点赞 2020-06-01 10:46:02
    我个人理解为以下意思: 静:静的一半需要“争”;稳:稳的一半需要“急”,这里的急是指行动上;忙:忙的一半是不能急躁,做事要脚踏实地,找到目标之后要提高专注力、要专一,要努力;忙字的一半是亡,如果同时做...
  • 或者说内核态为什么还要有虚拟地址存在? 开场白: 按照以前书上,或linux内核2.6 内核的逻辑地址 与 用户空间逻辑地址 (逻辑地址有时也被叫虚拟地址) 都是位于 0x00000000~0xFFFFFFFF 这段虚拟地址空间 ,其中...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 101,389
精华内容 40,555
关键字:

区域地址是什么意思