精华内容
下载资源
问答
  • 主要介绍了用jquery实现可输入多选下拉组合框的实例代码,非常不错,具有参考借鉴价值,需要的朋友参考下
  • 易语言组合框下拉内容模糊搜索模块,模块有三个程序,分别相应的子程序下调用,希望给有需要的易友分享.
  • VC 在组合框的下拉列表框实现自动选择,当Combobox组合框中键入字符时,组合框会根据用户的输入在列表框自动选择匹配的项,其实就是大家熟悉的搜索提示,用户输入时,Combobox下拉框会智能匹配用户的输入内容,...
  • 能记住你在组合框中输入内容,采用vc++编写,简单小巧!
  • 组合框下拉列表的数据进行模糊查询,操作简单,非常实用
  • 易语言组合框读取access数据库的数据
  • 窗体上建立一个简单组合框在组合框的文本框输入数字字符,按回车键后加入到组合框的列表框内,如图E.8所示;单击“交换”按钮,将列表框最小值项目和第0个项目交换;最大值与最后项目交换,如图所示: 提示...

    题目来源:大工慕课 链接
    原题:Visual Basic程序设计教程(第二版)龚沛曾主编,高等教育出版社 实验5-8
    作者:Caleb Sung

    题目要求

    窗体上建立一个简单组合框,在组合框的文本框输入数字字符,按回车键后加入到组合框的列表框内,如图E.8所示;单击“交换”按钮,将列表框中最小值项目和第0个项目交换;最大值与最后项目交换,如图所示:
    这里写图片描述

    提示

    1. 只能输入数字,Combo1_KeyPress事件通过如下代码实现:
    Select Case KeyAscii
    Case 48 to 57,13 '0~9数字和回车键为合法数据
    Case Else '否则为非法数据,去除非法字符
    KeyAscii=0
    End Select
    1. 求最大值和最小值必须声明4个变量:如Min、iMin、Max、iMax分别存放最小值、最小值下标、最大值和最大值下标,并将列表框中低0个项目作为上述4个变量的初值。
    2. 按照求最大值和最小值的方法,在组合框中找最小值和最大值,并获得最小值和最大值下标;注意比较时要用Val函数,否则作为字符串比较。
    3. 将组合框的第0项与最小值交换、最大值与最后项交换。例,最大值与最后项交换的代码如下:
    t=Combo1.List(Combo1.ListCount-1)
    Combo1.List(Combo1.ListCount-1)= Combo1.List(iMax)
    Combo1.List(iMax)= t

    参考解答

    首先画一个高度较高的ComboBox,它的按钮长这个样子:
    这里写图片描述
    随后选中画好的ComboBox,在属性面板里找到Style属性,设置为“1 - Simple Combo”:
    这里写图片描述
    接下来画一个Button,就可以愉快的Coding了 (>^ω^<)

    Private Sub Combo1_KeyPress(KeyAscii As Integer)
        Select Case KeyAscii
        Case 48 To 57, 13
        Case Else
        KeyAscii = 0
        End Select
        If KeyAscii = 13 Then
            Combo1.AddItem Combo1.Text
            Combo1.Text = ""
        End If
    End Sub
    
    Private Sub Command1_Click()
        Max = Val(Combo1.List(0))
        iMax = 0
        Min = Val(Combo1.List(0))
        iMin = 0
        For i = 1 To Combo1.ListCount - 1
            If Val(Combo1.List(i)) > Max Then
                Max = Val(Combo1.List(i))
                iMax = i
            ElseIf Val(Combo1.List(i)) < Min Then
                Min = Val(Combo1.List(i))
                iMin = i
            End If
        Next i
        t = Combo1.List(Combo1.ListCount - 1)
        Combo1.List(Combo1.ListCount - 1) = Combo1.List(iMax)
        Combo1.List(iMax) = t
        t = Combo1.List(0)
        Combo1.List(0) = Combo1.List(iMin)
        Combo1.List(iMin) = t
    End Sub
    
    
    展开全文
  • vc++6.0如何实现模态对话框编辑框中输入数据,单击确定按钮将数据添加到组合框按钮!我'是个新手,请求详解!
  • 组态王下拉式组合框使用样例,可以直接使用,包含说明
  • 易语言使用配置文件保存组合框项目易语言源码.rar 易语言使用配置文件保存组合框项目易语言源码.rar 易语言使用配置文件保存组合框项目易语言源码.rar 易语言使用配置文件保存组合框项目易语言源码.rar 易语言...
  • 一、Combo Box组合框 QComboBox小部件是一个组合按钮...组合框可以编辑,允许用户修改列表的每个项。 组合框可以包含pixmap和字符串;insertItem()和setItemText()函数被适当重载。对于可编辑组合框,提供函数...
     
    

    一、概述

    Designer中输入工具部件中的Combo Box组合框与其他可视化工具组合框功能相同,组合了按钮和弹出列表的功能,显示当前项并可以弹出可选择项的列表。组合框可以编辑,允许用户修改列表中的每个项。Combo Box组合框对应PyQt中的类QComboBox。

    QComboBox组合框使用Model/View框架来弹出列表和存储项,默认情况下项存储在 QStandardItemModel类型的Model中,弹出列表是 QListView的子项,通过model() 和view()方法可以访问QComboBox的Model和View,当然也可以通过setModel() 和setView()来改变这种默认设置。

    PyQt中的组合框可以包含字符串和pixmap的项, 这些项的数据访问可以使用Qt.DisplayRole 和 Qt.DecorationRole来访问,当用户在可编辑组合框中输入一个新字符串时,可以使用QValidator将输入数据进行约束(例如限制只能是某个范围的数字输入等)

    展开全文
  • vb.net的winform(windows窗体)开发,实现组合框ComboBox显示值与返回值不同的几种方法(里面有5种方法哟),VB.net2010上编译通过,绝对可以运行,希望能给初学都以帮助,里面有详细解释加说明。觉得写得好的,请加...
  • 组合框:既能输入数据,又能选择“ 应用背景:页面有两个列表框,需要把其中一个列表框的元素移动到另一个列表框 。  实现的基本思想:  (1)编写init方法对两个列表框进行初始化;  (2)为body添加...
  • 一个可以输入值的下拉框 通过css样式来实现的
  • 列表框和组合框 列表框是CListBox类的对象,组合框是CComboBox的对象。 列表框 属性设置 列表框的重要属性有: Selection 该属性决定用户的选择方式,缺省值为 Single 。属性值有: ①:Single ── 单项...
    上一篇:MFC界面编程基础(12):组框、单选按钮和复选框下一篇:MFC界面编程基础(14):滚动条

    列表框和组合框

    列表框是CListBox类的对象,组合框是CComboBox的对象。

    列表框

    • 属性设置
      列表框的重要属性有:
    • Selection
      该属性决定用户的选择方式,缺省值为 Single 。属性值有:
      ①:Single ── 单项选择
      ②:Multiple ── 多项选择,但是忽略 Ctrl 和 Alt 键。
      ③:Extended ── 允许使用 Ctrl 和 Alt 进行多项选择
      ④:None ── 禁止选择
      在这里插入图片描述
    • Sort
      当该属性被设置为True后,列表框中的选项按字母顺序排列。
      在这里插入图片描述
    • 常用成员函数
    • 添加项目
      格式: int AddString( LPCTSTR lpszItem );
      例如:语句 m_l. AddString(" 陈蓉 ") ; 把“陈蓉”添加到了列表框 m_l 中。
    • 删除项目
      格式: int DeleteString( UINT nIndex );
      说明: nIndex 表示被删除项目在列表框中的位置,对于第一个选项nIndex应为 0 。
      例如:语句 m_l. DeleteString (4) ;删除列表框中的第 5 个项目。
    • 获取当前被选定的项目的序号
      格式: int GetCurSel( ) const;
      例如:语句int I=m_l.GetCurSel(); 将使I 获得 m_l 列表框中当前选定的项目的序号。
    • 获取列表框中指定的项目
      格式 1 : int GetText( int nIndex, LPTSTR lpszBuffer ) const;
      格式 2 : void GetText( int nIndex, CString& rString ) const;
      说明 :将列表框中第 nIndex 个选项的文本送到 lpszBuffer 或 rString 中。
      例如:假定有说明语句 char s1[20]; CString s2;则语句 m_l.GetText(4, s1); 和 m_l. GetText(4, s2); 把第 5 项内容分别送到 s1 和 s2 中。

    【例】

    编写一个能对列表框进行项目添加、修改和删除操作的应用程序,如图所示。“添加”按钮的功能是将文本框中的内容添加到列表框,“删除”按钮的功能是删除列表框中选定的选项。如果要修改列表框,则首先选定选项,然后单击“修改”按钮,所选的选项显示在文本框中,当在文本框中修改完之后再单击“修改确定”按钮更新列表框。
    在这里插入图片描述

    • 界面设计
      首先创建一个对话框应用程序框架,然后放置按钮。列表框和命令按钮按表连接变量,其余控件不需要连接变量。
      在这里插入图片描述
    • 初始化
      列表框的选项在对话框的初始化函数中用 AddString 函数添加。
    BOOL CTESTDlg::OnInitDialog() 
    { 
    	┆ 
    	// TODO: Add extra initialization here 
    	m_l.AddString(" 大学计算机基础 "); 
    	m_l.AddString("C/C++ 程序设计 "); 
    	m_l.AddString("VB 程序设计 "); 
    	m_l.AddString(" 软件技术基础 "); 
    	┆ 
    } 
    
    • 消息处理函数
    …………………………………………………………
    void CTESTDlg::OnButton1() // 选择“添加”后执行的函数 
    { 
     // TODO: Add your control notification handler code here 
     UpdateData(TRUE); 
     m_l.AddString(m_e); 
     m_e=""; 
     UpdateData(FALSE); 
    } 
    …………………………………………………………
    void CTESTDlg::OnButton2() // 选择“删除”后执行的函数 
    { 
     // TODO: Add your control notification handler code here 
     int n=m_l.GetCurSel(); 
     m_l.DeleteString(n); 
    } 
    …………………………………………………………
    void CTESTDlg::OnButton3() // 选择“修改”后执行的函数 
    { 
     // 将选定的项目送编辑框供修改 
     // TODO: Add your control notification handler code here 
     CString s; 
     int n=m_l.GetCurSel(); 
     m_l.GetText(n,s); 
     m_e=s; 
     UpdateData(FALSE); 
    } 
    …………………………………………………………
    void CTESTDlg::OnButton4() // 选择“确定修改”后执行的函数 
    { 
     // 将修改后的项目送回列表框中,替换原项目,实现修改。 
     // TODO: Add your control notification handler code here 
     UpdateData(TRUE); 
     int n=m_l.GetCurSel(); 
     m_l.DeleteString(n); 
     m_l.InsertString(n,m_e); 
     m_e=""; 
     UpdateData(FALSE); 
    } 
    …………………………………………………………
    

    组合框

    • 属性设置

    • 种类( Type )
      该属性用于指定组合框的类型,共有三个选择: Simple 、 Dropdown 和 Droplist ,默认值为 Dropdown 。
      在这里插入图片描述

    • 键入列表框项( Enter listbox items )
      在列表框的属性窗口有一个“ Data ”属性,这是在设计阶段输入选项的地方,如图所示。输入每一项都需要用分号分隔
      在这里插入图片描述

    • 常用成员函数
      编辑框和列表框的成员函数几乎都可以用于组合框,但是列表框的成员函数 GetText() 在组合框中的是 GetLBText()

    • int GetLBText( int nIndex, LPTSTR lpszText ) const;

    • void GetLBText( int nIndex, CString& rString ) const;
      说明 :使用 GetLBText 函数可以将组合框中的第 nIndex 个项目的文本送入 lpszText 或 rString 中。

    • 组合框发出的消息

    • CBN_SELECTCHANGE :组合框的列表框中的选项改变时发送

    • CBN_EDITCHANGE :组合框的编辑框中文本改变时发出

    【例】

    设计一个如图所示的对话框。如果单击“确定”按钮,则用 MessageBox 显示如图所示的信息框。
    在这里插入图片描述

    • 首先创建一个对话框程序框架,然后放置各控件,进行属性设置,组合框的选项在设计阶段直接输入,按表连接变量,其余控件不需要连接变量。

    在这里插入图片描述

    • 消息处理函数
    void CTESTDlg::OnButton1() 
    { 
     // TODO: Add your control notification handler code here 
     UpdateData(TRUE); 
     CString s; 
     s=" 品牌 :"; 
     s=s+m_c; 
     s=s+"\n"; 
     s=s+" 数量 :"; 
     s=s+m_e; 
     MessageBox(s); 
    }
    
    上一篇:MFC界面编程基础(12):组框、单选按钮和复选框下一篇:MFC界面编程基础(14):滚动条
    展开全文
  • 易语言组合框基本属性方法事件

    千次阅读 2020-07-08 09:09:11
    本节视频教程录制了易语言组合框的取项目数、取项目数值、取项目文本、置项目文本、加入项目、插入项目、删除项目等属性。 组合框基本属性方法事件截图 视频链接: 76 属性: 左边 顶边 ...

    本节视频教程录制了易语言组合框的取项目数、取项目数值、取项目文本、置项目文本、加入项目、插入项目、删除项目等属性。

    组合框基本属性方法事件截图

    视频链接:

    76

    属性:

    左边

    顶边

    宽度

    高度

    标记

    可视

    禁止

    鼠标指针

    类型

    内容

    最大文本长度

    起始选择位置

    被选择字符数

    被选择文本

    自动排序

    行间距

    文本颜色

    背景颜色

    字体

    现行选中项

    列表项目

    项目数值

    数据源

    数据列

     

    方法:

    取顶端可见项目

    置顶端可见项目

    取项目数

    取项目数值

    置项目数值

    取项目文本

    置项目文本

    加入项目

    插入项目

    删除项目

    清空

    选择

     

    取顶端可见项目

    置顶端可见项目

    取项目数

    取项目数值

    置项目数值

     

    取项目文本

    置项目文本

     

    加入项目

    插入项目

    删除项目

     

    清空

    选择

    自有事件:

    列表项被选择

    编辑内容被改变

    将弹出列表

    列表被关闭

    双击选择

       

     

    列表项被选择

    编辑内容被改变

    将弹出列表

    列表被关闭

    双击选择        

    基本事件:

    鼠标左键被按下

    鼠标左键被放开

    被双击

    鼠标右键被按下

    鼠标右键被放开

    鼠标位置被移动

    获得焦点

    失去焦点

    按下某键

    放开某键

    字符输入

    滚轮被滚动

    组合框基本属性方法事件源码:

    .版本 2
    .支持库 spec
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 _按钮1_被单击
    .局部变量 项目数量
    
    项目数量 = 组合框1.取项目数 ()
    信息框 (“组合框项目数量为:” + 到文本 (项目数量), #信息图标, , )
    
    .子程序 _组合框1_列表项被选择
    
    调试输出 (组合框1.现行选中项)
    
    .子程序 __启动窗口_创建完毕
    
    组合框1.现行选中项 = 0
    
    .子程序 _按钮2_被单击
    
    调试输出 (组合框1.取项目数值 (组合框1.现行选中项))
    
    .子程序 _按钮3_被单击
    
    调试输出 (组合框1.取项目文本 (组合框1.现行选中项))
    
    .子程序 _按钮4_被单击
    
    组合框1.置项目文本 (组合框1.现行选中项, 编辑框1.内容)
    
    .子程序 _按钮5_被单击
    
    调试输出 (组合框1.加入项目 (编辑框1.内容, ))
    
    .子程序 _按钮6_被单击
    
    组合框1.插入项目 (到整数 (编辑框2.内容), 编辑框1.内容, )
    
    .子程序 _按钮7_被单击
    
    组合框1.删除项目 (到整数 (编辑框2.内容))
    
    .子程序 _按钮8_被单击
    
    组合框1.清空 ()
    
    .子程序 _按钮9_被单击
    
    调试输出 (组合框1.选择 (组合框1.取项目文本 (组合框1.现行选中项)))

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言教程组合框基本属性方法事件

     

    展开全文
  • C# ComboBox:组合框控件

    千次阅读 2019-06-11 23:19:40
    C#WinForm开发中组合框(ComboBox)控件也称下拉列表框, 用于选择所需的选项,例如注册学生信息时选择学历、专业等。 使用组合框可以有效地避免非法值的输入在组合框中也有一些经常使用的属性,如下表所...
  • QT实现可编辑组合框

    2019-11-04 22:01:16
    1.应用场景描述:使用QComboBox对列表内容进行选择的同时能够修改item项(一般来说不应该出现这样的需求,既然使用QComboBox,那么就应该是对已设定好内容进行选择,实际应用最好再重新设计功能模块)。...
  • 界面上方放3个组合框分别标注“年龄”,“性别”,“籍贯”;组合 框下面放一个文本区域用于 * 登记学生情况,程序运行时,用户输入姓名后,再输入其他项时,可用组合框选项自动输入
  • MFC 组合框的用法大全

    千次阅读 2018-06-18 23:31:14
    Combo Box (组合框)控件很简单,可以节省空间。从用户角度来看,这个控件是由一个文本输入控件和一个下拉菜单组成的。用户可以从一个预先定义的列表里选择一个选项,同时也可以直接文本框里面输入文本。下面的例子...
  • ComboBox 控件的文本框允许用户选择项目从下拉列表或选择输入新文本。 介绍: 1.属性 常用属性 Name 获取或设置控件的名称。 Text 获取或设置与此控件显示的文本。此控件一般不适用。 ...
  • MFC编程之组合框控件

    2018-05-04 15:46:35
    什么是组合框这里我做了一个例程,选择不同的边缘会又不一样的值,并且能修改和保存。 下面是效果图。...简易组合框中的列表框是一直显示的。 下拉式组合框默认不显示列表框,只有点击了...
  • Designer中输入工具部件的Combo Box组合框与其他可视化工具组合框功能相同,组合了按钮和弹出列表的功能,显示当前项并可以弹出可选择项的列表。组合框可以编辑,允许用户修改列表的每个项。Combo Box组合框对应...
  • 使用配置文件保存组合框项目易语言源码
  • 易语言模块-组合框模糊搜索模块3.0

    千次阅读 2015-06-21 16:28:25
    易语言模块-组合框内容模糊搜索_anme886 本模块是全项目文本内容搜索,使用正则表达式,并且支持首字母搜索 最新版网盘下载地址提取码: h722 ...
  • 组合框控件是我们工作中用得很频繁的一个控件,其实就是把一个编辑框和列表框组合一起。 适用范围:当你有多个同级选项时,你又不想创建很多个单选框按钮,这时,组合框就能帮你完成这个复杂的创建过程。 组合框...
  • jQuery UI超级组合框 一个简单的jQuery UI小部件,其行为类似于选择下拉列表,允许免费用户输入。 现场演示和安装说明。 执照 麻省理工学院
  • VBA组合框

    千次阅读 2016-01-15 21:40:31
    如果组合框内容既定,则编程时写入即可: Private Sub ComboBox1_Enter() ComboBox1.DropDown End Sub Private Sub xx_Initialize() ComboBox1.AddItem "小明" ComboBox1.AddItem "小红" ComboBox1.AddItem "小刚...
  • 在组合框中输入内容,自动定位到相近位置。

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 228,147
精华内容 91,258
关键字:

怎样在组合框中输入内容