精华内容
下载资源
问答
  • 自动点击通达信验证码自动登陆 免验证码登陆通达信 用按键精灵制作的通达信 自动识别验证码登陆脚本
  • xp系统自动登陆器,程序,8.65kb,帮助用户自动快速登陆系统。用户登陆系统完全自动化。
  • 然后根据关键字,【FiddlerScript 注入cooke实现自动登录,Fiddler实现免登陆,浏览器通代理实现自动登录】全网搜了一下,根本没有教程。。通过那个软件的错误信息,指定使用的是Fiddler,然后沿着这思路,把这个.

    一,问题描述

     

    最近看到一个用易语言写的软件,点击运行,会自动将电脑的代理修改为:http=127.0.0.1:xxx;https=127.0.0.1:xxx ,使用chrome浏览器或火狐浏览器配置这个代理,访问指定的几个网址,根本不需要登录,返回的页面,已经是登录的情况。然后根据关键字,【FiddlerScript 注入cooke实现自动登录,Fiddler实现免登陆,浏览器通代理实现自动登录】全网搜了一下,根本没有教程。。通过那个软件的错误信息,知道使用的是Fiddler,然后沿着这思路,把这个实现了,历经曲折,过程如下,其实很简单。验证的过程有点费时间。。

     

    二、解决方法

     

    刚开始使用FiddlerScript没有成功,网站关于这该的教程很少。。然后想到的验证方式就是,直接修改cookie,实现,发现有些网站能登陆,有些登录不了,测试如下,

    两个浏览器:360,chrome都装了EditThisCookie,来测试,chrome上通过账号登录,通过EditThisCookie获取登录后的cookie导入到360中,有些网站能登录,有些网站不行
    可以登录的网站:www.ngrok.cc
    不可以登录的网站:www.tianyancha.com,bbs.125.la

    通过易语言的奇易模块可以实现这种效果,代码如下:

    .版本 2
    .支持库 spec
    .支持库 eAPI
    
    .程序集 窗口程序集_启动窗口
    .程序集变量 监听服务器, Fiddler
    
    .子程序 _按钮1_被单击
    .局部变量 L_Cookie, 文本型
    
    网页_访问_对象 (“https://www.ngrok.cc/login.html”, , , L_Cookie, , , , , , , , , , , , , , , )
    网页_访问_对象 (“https://www.ngrok.cc/login.html”, 1, “username=xxx&passwd=xxx”, L_Cookie, , , , , , , , , , , , , 真, , )
    调试输出 (L_Cookie)
    编辑框1.内容 = L_Cookie
    信息框 (“登陆成功”, 0, , )
    
    .子程序 _按钮2_被单击
    
    监听服务器.置SSL抓包 (真)  ' 启动抓取https模式
    监听服务器.置自动注册代理 (真)  ' 运行后自动开启IE代理
    监听服务器.启动代理 (5858, &回调_数据)
    程序_延时 (1000, )
    打开指定网址 (“https://www.ngrok.cc/user.html”)
    
    .子程序 回调_数据
    .参数 数据地址, 整数型, , 通过该地址来接受网页的数据,不可忽略!
    .参数 数据序号, 整数型, , 通过该序号来对网页进行控制,不可忽略!
    .局部变量 fd, Fiddler数据结构
    .局部变量 a, 文本型
    .局部变量 L_正则, 正则表达式类
    .局部变量 L_BID, 文本型
    .局部变量 L_网页数据, 文本型
    
    fd = 监听服务器.解析数据 (数据地址)
    .如果真 (fd.数据类型 = “recv”)  ' recv
        调试输出 (“返回包:” + fd.网页地址)
        .如果真 (寻找文本 (fd.网页地址, “https://www.ngrok.cc/user.html”, , 假) > -1)
            调试输出 (“成功置入Cookie”)
            监听服务器.recv_新增SetCookie (数据序号, 编辑框1.内容 + “; path=/”)
            监听服务器.停止代理 ()
        .如果真结束
    
    .如果真结束
    .如果真 (fd.数据类型 = “send”)
        调试输出 (“提交包:” + fd.网页地址)
    .如果真结束
    
    
    
    .子程序 _按钮3_被单击
    
    监听服务器.停止代理 ()
    
    .子程序 __启动窗口_可否被关闭, 逻辑型
    
    监听服务器.停止代理 ()
    

    测试了各种方法。。最后就几行代码通杀。。测试了4-5个网站基本上都能免登陆。。

    在FiddlerScript中的OnBeforeRequest方法最下面加入以下代码就行了

    if (oSession.HostnameIs("www.ngrok.cc")||oSession.uriContains('ngrok.cc')){
    	oSession.oRequest["Cookie"] = "__guid=140640820.4178234843920325600.1597912780035.9578; PHPSESSID=xxxx; monitor_count=5";
    }

    其中的Cookie是通过登录获取到,然后复制下来,填在这里,这样的话,不管哪个浏览器,只要走这个代理,请求中的cookie就会设置成这个cookie,然后响应的就是登录成功之后的数据。

    展开全文
  • 1:web自动登陆,selenium自动登陆测试 2:二维码生成和识别 3:无密码通过cookie登陆 4:zxing库使用和修改
  • 开机自动登陆: 运行--regedit打开注册表并定位到HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/CurrentVersion/Winlogon 在右边窗口中找到AutoAdminLogon字符串值,将其值改为1,然后在空白位置右键新建字符串值,名...

    开机自动登陆:
    运行--regedit打开注册表并定位到HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/CurrentVersion/Winlogon
    在右边窗口中找到AutoAdminLogon字符串值,将其值改为1,然后在空白位置右键新建字符串值,名为DefaultUserName,设其值为须自动登陆的用户名如Administrator。最后再在空白位置右键新建字符串值,其名为DefaultPassword,设其值为自动登陆用户名的密码如123。

    注销后自动登陆:
    同样在自动登陆功能开启基础上运行--regedit打开注册表并定位到HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/CurrentVersion/Winlogon
    在右边窗口中找到DWORD值ShowLogonOptions将其值为1
    然后找到ForceAutoLogon并将其值设为1。

    不明白的话再来个傻瓜式的,
    开机自动登陆:1新建文本文档,将以下内容复制进去后更改用户名与密码,密码若无则使引号内容为空(连空格都不能留),保存,并将扩展名由.txt改为.reg
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows NT/CurrentVersion/Winlogon]
    "AutoAdminLogon"="1"
    "AltDefaultUserName"="须设开机自动登陆的用户名"
    "DefaultPassword"="须设开机自动登陆的密码"

    注销自动登陆:
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows NT/CurrentVersion/Winlogon]
    "DefaultUserName"="须设注销自动登陆的用户名"
    "ShowLogonOptions"=dword:00000001
    "AutoAdminLogon"="1"'
    "DefaultPassword"="须设开机自动登陆的密码"
    "ForceAutoLogon"="1"


    名词解释:
    autoadminlogon二进制中1表示真,0表示假.此处为启用自动登陆功能;设除1与0以外的数字无效。
    altdefaultusername 建立自动登陆用户名信息
    defaultpassword自动登陆用户所使用的登陆密码
    ShowLogonOptions自动显示登录选项。
    forceautologon强制系统进行自动登录,值设为1表示真,0表示假。此值设为1表强制登陆,即不关开机还是注销;设除1与0以外的数字无效。

     

    搞定(^0^)
    ————————————————
    版权声明:本文为CSDN博主「叶振溪」的原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。
    原文链接:https://blog.csdn.net/yezhenxi/article/details/5702930

    展开全文
  • 实现自动登陆(java) 实现自动登陆(java) 实现自动登陆(java) 实现自动登陆(java)
  • 支持XP和WIN7的开机自动登录自动登录命令的批处理。
  • 自动登录功能

    千次阅读 2019-05-15 21:07:20
    下面记录并分享一下自动登录功能的实现: 一、自动登录 1)登录功能是用Session实现的,就是向Session对象中保存当前用户的对象 2)自动功能用Cookie实现,就是登陆时将用户的信息保存为持久化Cookie 3)下次访问时...

    下面记录并分享一下自动登录功能的实现:

    一、自动登录
    1)登录功能是用Session实现的,就是向Session对象中保存当前用户的对象
    2)自动功能用Cookie实现,就是登陆时将用户的信息保存为持久化Cookie
    3)下次访问时,读取请求中如果有用户信息的Cookie就可以自动登陆

    二、防止表单重复提交
    使用session技术实现
    1)在jsp页面中生成一个唯一随机值,将其保存到session中,同时将其保存为表单的隐藏域的值
    2)在处理请求时,获取session中相关的值,获取请求参数的值,比较两者是否相同,如果相同则说明不是重复提交,请求通过。否则则为重复提交,请求不通过。

    展开全文
  • 很多朋友就希望最好电源一打开就能进行工作,如果用户登陆还得密码,那真的有点浪费时间,下面我们来看看ubuntu下如何实现用户自动登陆.. 方法/步骤 左边的应用面板中 打开dash菜单 点...

    溪西创客小屋

    很多朋友就希望最好电源一打开就能进行工作,如果用户登陆还得密码,那真的有点浪费时间,下面我们来看看ubuntu下如何实现用户自动登陆..

    左边的应用面板中   打开dash菜单

    点选dash菜单下面的第二个A标志的 应用选项卡

    点击  过滤结果 并在下面的类别中  选中  系统

    展开  左边的  已安装   找到 系统设置 并打开

    点选 系统设置中的  用户账户

    进入用户账户 后  点击  解锁  在弹出的密码认证窗口中    输入用户密码  授权

    完成 解锁后   右上角的 图标会显示为  锁定 

    点击 打开   自动登陆   按钮  这样以后再重新启动计算机就会 自动登陆默认的ubuntu桌面

    为了安全 如果你想设置回 登陆需要密码 可以关闭 自动登陆 就可以了

    • ubuntu登录自动运行脚本

          登录ubuntu后执行前面的命令,就能加载无线驱动,但是可不可以登录的时候自动运行呢?省得每次登录的时候都要敲命令,而且还要切换root用户才能执行相关命令,这样比较麻烦。

             可以写一个脚本,把那些命令全部写在脚本里面,然后在.profile文件(/etc/profile)中添加执行这个脚本的语句,这样就OK了,

             1.以root用户,新建个脚本文件:vi winless.sh

               内容如下:

                    #!bin/sh

                    cd hybird_wl

                    make clean

                    make

                    rmmod b43

                    rmmod ssb

                    rmmod wl

                    modprobe lib80211

                    insmod wl.ko

               2.将winless.sh文件赋suid 以及执行权限

                 chmod gu+s winless.sh

                 chmod 777 winless.sh

               3.在.profile文件中添加一条语句即可.

                 echo 123456 | sudo -S ./winless.sh

                 注:这里123456是密码,参数-S专门为执行sudo命令的时候要输入密码而准备的,表示标准输入。

      ---------------------------注:
    • in login.sh:

    • #auto start when login
      #roslaunch CDHF_Robot cyberCtrl_R32.launch
      /home/ubuntu/dev/Qt/build-QtView3D-Desktop-Debug/QtView3D

    • in /etc/profile,add:

    • #echo ubuntu | sudo -S ~/.bashrc
      source /opt/ros/indigo/setup.bash
      export ROS_PACKAGE_PATH=~/dev/ros:/opt/ros/indigo/share:/opt/ros/indigo/stacks
      sh /home/ubuntu/dev/login.sh


    • 使用sudo 运行脚本添加
    • echo ubuntu | sudo -S /home/ubuntu/dev/login.sh

    • 不使用sudo运行添加

    • sh /home/ubuntu/dev/login.sh

    展开全文
  • 校园网网页认证自动登录

    万次阅读 多人点赞 2018-11-21 20:13:36
    校园网网页认证自动登录认证python+定时任务 实现校园网自动登录认证一、总览二、具体步骤 python+定时任务 实现校园网自动登录认证 说明:因为我们学校校园网登陆需要网页认证,且每天3点左右会自动断网,所以需要...
  • 项目需求要求,打开网页直接登录,不要出现登录页面。... // 自动登录 autoLogin ({commit}) { return new Promise((resolve, reject) => { doLogin({ username: 'admin', password: md5('adm
  • CentOS自动登陆

    千次阅读 2014-04-27 20:57:49
    项目需要去掉CentOS登陆框直接进入系统,简单的配置即可解决。 修改文件:vim /etc/gdm/custom.conf 加入内容: [daemon] AutomaticLogin=自动登陆的用户名 AutomaticLoginEnable=True
  • 呵呵,开机自动登陆,注销自动登陆

    千次阅读 2010-06-29 22:05:00
    呵呵,开机自动登陆,注销自动登陆
  • 有时候win10好烦,需要自己输入密码登录,当然,这里有个前提就是,如果是公司电脑,一般是有安全性考虑,就请自觉设置密码,如果是个人在家的电脑,那么就可以设置无密码登录了。 Step WIN+R或者在运行中弹出窗口...
  • 设定linux自动登录

    千次阅读 2017-07-22 11:35:41
    设定Linux自动登陆在实验场景中我们可能会经常重新启动Linux,然后反复输入账户...基于Linux一切皆文件的思想,我们可以通过修改配置文本的方式决定是否启用自动登录,以及自动登录的账户是普通用户账户还是root账户。
  • 域用户登陆自动注销脚本 域用户登陆自动注销脚本 域用户登陆自动注销脚本 域用户登陆自动注销脚本 域用户登陆自动注销脚本
  • c__winform实现网页上用户自动登陆,模拟网站登录
  • SecureCRT自动登录

    千次阅读 2017-07-20 20:43:30
    SecureCRT自动输入账户名密码实现自动登录背景 在登录公司服务器的时候,为了保证集群的安全,往往会设置一层跳板机(堡垒机)来转发跳转登录,需要先登录到跳板机,再登录到服务器,再切换用户。这过程未免显得...
  • 如果是密钥登录的话还比较好自动登录,如果是密码登录的话一般用expect,还可以使用sshpass expect expect是一个用来处理交互的命令。借助Expect,我们可以将交互过程写在一个脚本上,使之自动化完成。形象的说,...
  • cookie实现自动登陆原理

    万次阅读 2016-01-27 17:31:08
    cookie实现自动登陆原理
  • Win10、Win7、WinXP如何开机自动登录?如何取消开机自动登录? 开机自动登录 开始菜单搜索框输入“netplwiz”按回车 或“Win+R”组合键打开“运行”框内输入“netplwiz” 或“运行”框内输入“control user...
  • 易语言源码qq自动登陆器,自动登陆QQ,想开发QQ自动登陆器的朋友,快下了
  • 这个在原来的基础上进行了修改,可以自动加载 自动登陆(登录)163邮箱 本人初学VB,欲求代码程序,请加QQ:364924648,或邮箱:zhangqiang13131@163.com
  • android记住密码和自动登录功能源码

    千次下载 热门讨论 2012-07-04 11:27:34
    android 客户端记住密码和自动登录功能,好看的UI界面,绝对源码、可运行。
  • windows电脑的时候,如果电脑有密码,需要输入密码才能登录,但是设置了开机自动登录后,即使没有密码也能登录,当然也可以取消自动登录; 首先我们在键盘上按Win+R组合按键,将运行窗口打开; 然后我们在运行窗口...
  • Python自动登录QQ

    万次阅读 多人点赞 2019-03-16 15:35:55
    Python自动登录QQ 这是一份来自网络的代码,经过了我的修改和验证。 首先我的运行环境是Python3.7,需要安装PyUserInput库。 直接上代码吧: #!/usr/bin/python import os import time import win32gui import win...
  • 自动登录脚本

    2021-05-17 19:38:04
    一个自动登录脚本。有兴趣的可以看看哈! 效果如图: 关注公众号回复:login 获取相应脚本
  • 将Putty的快捷方式 “属性”->“目标”修改为:   ..."C:/Program Files/PuTTY/putty.exe" -load "colinux" -ssh -l root -pw root ...sys_name - 系统登陆账户名称 sys_pwd -系统登陆密码
  • Windows2000 自动登录 适合服务器按计划安排的自动重启与运行。
  • Expect是一个用来处理交互的命令。可以将交互过程写在一个...2、ssh自动登陆脚本 #!/usr/bin/expect spawn ssh用户名@服务器IP expect "*password:" send "密码\r" expect "*#" int...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 953,822
精华内容 381,528
关键字:

怎样自动登录