精华内容
下载资源
问答
  • 非常详细的思科2950系列交换机配置文档,符合所有对思科2950系列交换机的人群。
  • 思科2950交换机VLAN划分配置思科2950交换机VLAN划分配置思科2950交换机VLAN划分配置
  • 思科2950交换机相关配置包括基本操作,端口配置,MAC地址表相关命令,VTP的配置等。
  • 通过配置线连接交换机,又发现又设置了enable密码,于是笔者只能想到恢复初始配置,遂将实现过程整理如下: 1、按住前面板的mode键不放,插上电源,等3-5秒后松开mode键,我们将会看到如下提示: The system has ...

    通过配置线连接交换机,又发现又设置了enable密码,于是笔者只能想到恢复初始配置,遂将实现过程整理如下:
    1、按住前面板的mode键不放,插上电源,等3-5秒后松开mode键,我们将会看到如下提示:

    The system has been interrupted prior to initializing the
    flash filesystem. The following commands will initialize
    the flash filesystem, and finish loading the operating
    system software:

    flash_init
    load_helper
    boot
    

    switch:
    2、到这里我们输入flash_init命令,开始初始化flash,完了后,我们再输入ren flash:config.text flash:config.old

     命令对已存丰的config.text重新命名成config.old,不删除、方便以后还可以恢复,最后我们在使用boot命令进行启动。
    

    switch: flash_init
    Initializing Flash…
    flashfs[0]: 18 files, 2 directories
    flashfs[0]: 0 orphaned files, 0 orphaned directories
    flashfs[0]: Total bytes: 7741440
    flashfs[0]: Bytes used: 3966464
    flashfs[0]: Bytes available: 3774976
    flashfs[0]: flashfs fsck took 6 seconds.
    …done initializing flash.
    Boot Sector Filesystem (bs:) installed, fsid: 3
    Parameter Block Filesystem (pb:) installed, fsid: 4
    switch: dir

    List of filesystems currently registered:

               flash[0]: (read-write)
              xmodem[1]: (read-only)
                null[2]: (read-write)
                  bs[3]: (read-only)
    

    switch:
    在这里插入图片描述
    3、这样我们等启动好了,再次使用enable命令进入特权模式就没有密码了,还可以使用dir命令查看到我们重命名的文件,如下所示:

    Switch>en
    Switch#dir
    Directory of flash:/

    2  -rwx     2664051   Mar 01 1993 00:03:22  c2950-i6q4l2-mz.121-11.EA1.bin
    4  -rwx        1216   Apr 15 1994 21:28:58  vlan.dat
    5  -rwx        4413   Jan 31 1994 21:45:53  config.old
    6  -rwx           5   Jan 31 1994 21:45:53  private-config.text
    7  drwx         704   Mar 01 1993 00:04:00  html
    

    19 -rwx 109 Mar 01 1993 00:04:01 info
    20 -rwx 109 Mar 01 1993 00:04:01 info.ver
    21 -rwx 269 Jan 01 1970 00:01:46 env_vars

    7741440 bytes total (3774976 bytes free)
    Switch#

    如果上述的操作进行要输入dir的时候到敲任何键都不动了的话,就要修改波特率为交换机本身的波特率115200。
    在这里插入图片描述

    switch: flash_init
    Initializing Flash…
    flashfs[0]: 18 files, 2 directories
    flashfs[0]: 0 orphaned files, 0 orphaned directories
    flashfs[0]: Total bytes: 7741440
    flashfs[0]: Bytes used: 3966464
    flashfs[0]: Bytes available: 3774976
    flashfs[0]: flashfs fsck took 6 seconds.
    …done initializing flash.
    Boot Sector Filesystem (bs:) installed, fsid: 3
    Parameter Block Filesystem (pb:) installed, fsid: 4
    修改完波特率后,就可以正常输入dir了
    switch: dir

    那么如何修改交换机的波特率为默认波特率呢?

    cisco 交换机恢复IOS与更改波特率
    https://blog.csdn.net/weixin_33724659/article/details/92696183
    第一步:执行flash_init

    switch: flash_init

    第二步:修改波特率
    为了提高文件传输速率,需要修改console口的波特率,先使用如下指令修改设备的波特率
    switch: set BAUD 115200

    第三步:是用xmodem传输IOS文件
    在设备上输入如下指令:
    switch: copy xmodem: flash:c2950.bin
    flash:后面的“c3560-ipservicesk9-mz.122-53.SE.bin”(上面的c2950.bin)为IOS文件名,需要在本地PC上事先准备好。
    然后点击超级终端“发送”菜单,选择发送文件,使用xmodem方式。
    文件开始通过console发送到交换机上,传输时间是根据文件大小决定的,10M的文件大约需要50分钟。

    第四步:设置启动文件
    当IOS文件正确传输到交换机上面,执行以下指令设置启动文件。
    switch: set BOOT flash:c2950.bin

    第五步:重置波特率

    交换机上执行如下指令重置波特率:

    switch: unset BAUD

    PC上将超级终端的波特率改回9600,生效后,
    光标在switch: unset BAUD 位置不动了,那么还是波特率没改回来,修改回9600就可以继续往下走了
    在这里插入图片描述
    第六步:启动IOS

    在交换机上执行以下指令,启动IOS。
    switch: boot

    展开全文
  • 首先配置一下交换机SC-2950>SC-2950>enSC-2950#conf tEnter configuration commands, one per line.End with CNTL/Z.SC-2950(config)#config-register 0x2102SC-2950(config)#end添加三个VLANSC-2950#vlan d.....
    首先配置一下交换机
    SC-2950>
    SC-2950>en
    SC-2950#conf t
    Enter configuration commands, one per line.    End with CNTL/Z.
    SC-2950(config)#config-register 0x2102
    SC-2950(config)#end
    添加三个VLAN
    SC-2950#vlan data
    SC-2950(vlan)#vlan 10 name v1
    VLAN 10 added:
            Name: v1
    SC-2950(vlan)#vlan 20 name v2
    VLAN 20 added:
            Name: v2
    SC-2950(vlan)#vlan 30 name v3
    VLAN 30 added:
            Name: v3
    SC-2950(vlan)#exit
    APPLY completed.
    Exiting....
    SC-2950#
    划分接口到各个VLAN
    SC-2950#conf t
    Enter configuration commands, one per line.    End with CNTL/Z.
    SC-2950(config)#int fa0/1             //留给管理员
    SC-2950(config-if)#switchport mode access
    SC-2950(config-if)#sw acc vlan 10
    SC-2950(config-if)#no shutdown
    SC-2950(config-if)#exit

    SC-2950(config)#int range f0/2 - 15
    SC-2950(config-if-range)#sw mode acc
    SC-2950(config-if-range)#sw acc vlan 20
    SC-2950(config-if-range)#no sh
    SC-2950(config-if-range)#exit
    SC-2950(config)#int range f0/16 - 24
    SC-2950(config-if-range)#sw mode acc
    SC-2950(config-if-range)#sw acc vlan 30
    SC-2950(config-if-range)#no sh
    SC-2950(config-if-range)#exit
    激活VLAN,并且给VLAN 10加个IP以便管理
    SC-2950(config)#int vlan 10
    SC-2950(config-if)#ip add 192.168.1.1 255.255.255.0
    SC-2950(config-if)#no sh
    SC-2950(config-if)#exit
    SC-2950(config)#int vlan 20
    SC-2950(config-if)#no sh
    SC-2950(config-if)#exit
    SC-2950(config)#int vlan 30
    SC-2950(config-if)#no sh
    SC-2950(config-if)#exit
    将交换机指向网关
    SC-2950(config)#ip default-gateway 192.168.1.254
    SC-2950(config)#end
    SC-2950#
    检测配置
    SC-2950#sh vlan brief

    VLAN Name                                                         Status        Ports
    ---- -------------------------------- --------- -------------------------------
    1        default                                                    active
    10     v1                                                             active        Fa0/1
    20     v2                                                             active        Fa0/2, Fa0/3, Fa0/4,Fa0/5
                                                                                                    Fa0/6, Fa0/7, Fa0/8,Fa0/9
                                                                                                    Fa0/10, Fa0/11, Fa0/12,Fa0/13
                                                                                                    Fa0/14, Fa0/15
    30     v3                                                             active        Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                                                                    Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                                                                    Fa0/24
    SC-2950#sh ip int b
    Interface                                    IP-Address            OK? Method Status                                Prot
    ocol
    FastEthernet0/23                     unassigned            YES unset    up                                        down

    FastEthernet0/24                     unassigned            YES unset    up                                        down

    Vlan1                                            unassigned            YES unset    up                                        down

    Vlan10                                         192.168.1.1         YES manual up                                        up

    Vlan20                                         unassigned            YES unset    up                                        up

    Vlan30                                         unassigned            YES unset    up                                        down
    SC-2950#sh run
    Building configuration...

    Current configuration : 1482 bytes

    ...

    !
    interface FastEthernet0/24
    switchport access vlan 30
    !
    interface Vlan1
    no ip address
    !
    interface Vlan10
    ip address 192.168.1.1 255.255.255.0
    !
    interface Vlan20
    no ip address
    !
    interface Vlan30
    no ip address
    !
    ip default-gateway 192.168.1.254
    ip http server
    !
    ...
    保存配置
    SC-2950#write
    Building configuration...
    [OK]

    转载于:https://blog.51cto.com/binotes/159170

    展开全文
  • 思科2950配置

    2013-01-29 09:56:53
    思科2950交换机 配置Cisco2950交换机 一.CISCO2950交换机的基本配置 Switch> Switch>enable 进入特权执行模式
  • (1)拖拽一个PC机(PC-PT),一个交换机2950-24) (2)选择配置线连接PC机和交换机,PC机选F0口,交换机选择F0/0口 2、配置交换机 单击交换机,选择CLI,进行配置 进入特权模式 返回用户模式 进入全局配置模式...

    交换机的配置

    1、建立拓扑图
    (1)拖拽一个PC机(PC-PT),一个交换机(2950-24)

    在这里插入图片描述(2)选择配置线连接PC机和交换机,PC机选F0口,交换机选择F0/0口
    在这里插入图片描述2、配置交换机
    单击交换机,选择CLI,进行配置
    进入特权模式
    在这里插入图片描述返回用户模式
    在这里插入图片描述
    在这里插入图片描述进入全局配置模式下
    在这里插入图片描述主机名配置:
    在这里插入图片描述配置交换机的远程登陆密码
    在这里插入图片描述
    配置交换机的特权密码
    在这里插入图片描述取消配置交换机的特权密码
    在这里插入图片描述为交换机分配管理IP地址
    在这里插入图片描述将接口关闭
    在这里插入图片描述显示Vlan IP端口状态 up/down
    在这里插入图片描述取消交换机管理IP地址
    在这里插入图片描述配置接口速率,配置接口双工模式
    在这里插入图片描述显示端口状态
    在这里插入图片描述• 清空flash中的配置参数在这里插入图片描述3、配置完成
    在这里插入图片描述

    展开全文
  • 2950交换机 简明配置维护手册 中国思科培训网 目录 说明... 3 产品特性... 3 配置端口... 4 配置一组端口... 4 配置二层端口... 6 配置端口速率及双工模式... 6 端口描述... 7 ...

     
     
     
     
     
     
    2950交换机
    简明配置维护手册
     
     
     
     
     
     
     
     
     
     
    中国思科培训网

    目录
     

    本手册只包括日常使用的有关命令及特性,其它未涉及的命令及特性请参考英文的详细配置手册。
    2950是只支持二层的交换机
    支持VLAN
    • 到250 个VLAN
    • 支持VLAN ID从1到4094( IEEE 802.1Q 标准)
    • 支持ISL及IEEE 802.1Q封装
    安全
    • 支持IOS标准的密码保护
    • 支持标准及扩展的访问列表来定义安全策略
    • 支持基于VLAN的访问列表
    监视
    • 交换机LED指示端口状态
    • SPAN及远端SPAN (RSPAN) 可以监视任何端口或VLAN的流量
    • 内置支持四组的RMON监控功能(历史、统计、告警及事件)
     
     
     
     
    命令
    目的
    Step 1 
    configure terminal
    进入配置状态
    Step 2 
    interface range {port-range}
    进入组配置状态
    Step 3 
     
    可以使用平时的端口配置命令进行配置
    Step 4 
    end
    退回
    Step 5 
    show interfaces [interface-id]
    验证配置
    Step 6 
    copy running-config startup-config
    保存
     
     
    当使用interface range命令时有如下的规则:
    • 有效的组范围:
      • vlan1 到4094
      • fastethernet 槽位/{first port} - {last port}, 槽位为0
      • gigabitethernet槽位/{first port} - {last port},槽位为0
      • port-channel port-channel-number - port-channel-number, port-channel号从1到64
    • 端口号之间需要加入空格,如:interface range fastethernet 0/1 – 5 是有效的,而interface range fastethernet 0/1-5 是无效的.
    • interface range 命令只能配置已经存在的interface vlan
    • 所有在同一组的端口必须是相同类别的。
    见以下例子:
    Switch# configure terminal
     
    Switch(config)# interface range fastethernet0/1 - 5 
     
    Switch(config-if-range)# no shutdown 
    Switch(config-if-range)#
    *Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
    *Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
    *Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
    *Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to up
    *Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet0/5, changed state to up
    *Oct 6 08:24:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/05, 
    changed state to up
    *Oct 6 08:24:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed 
    state to up
    *Oct 6 08:24:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed 
    state to up
    以下的例子显示使用句号来配置不同类型端口的组:
    Switch# configure terminal
     
    Switch(config)# interface range fastethernet0/1 - 3, gigabitethernet0/1 - 2 
     
    Switch(config-if-range)# no shutdown 
    Switch(config-if-range)#
    *Oct 6 08:29:28: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
    *Oct 6 08:29:28: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
    *Oct 6 08:29:28: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
    *Oct 6 08:29:28: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to up
    *Oct 6 08:29:28: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed state to up
    *Oct 6 08:29:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/ 1, 
    changed state to up
    *Oct 6 08:29:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/ 2, 
    changed state to up
    *Oct 6 08:29:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/ 3, 
    changed state to up
     
    2950的所有端口缺省的端口都是二层口,如果此端口已经配置成三层端口的话,则需要用switchport来使其成为二层端口。
    可以配置快速以太口的速率为10/100Mbps及千兆以太口的速率为10/100/1000-Mbps; 但对于GBIC端口则不能配置速率及双工模式,有时可以配置nonegotiate,当需要联接不支持自适应的其它千兆端口时
     
    命令
    目的
    Step 1 
    configure terminal
    进入配置状态.
    Step 2 
    interface interface-id
    进入端口配置状态.
    Step 3 

    speed {10 | 100 | 1000 | auto | nonegotiate}

    设置端口速率
       1000 只工作在千兆口. GBIC模块只工作在1000 Mbps下. nonegotiate 只能在这些GBIC上用 1000BASE-SX, -LX, and -ZX GBIC.
    Step 4 

    duplex {auto | full | half}

    设置全双工或半双工.
    Step 5 
    end
    退出
    Step 6 
    show interfaces interface-id
    显示有关配置情况
    Step 7 
    copy running-config startup-config
    保存
     
     
     
    Switch# configure terminal
     
    Switch(config)# interface fastethernet0/3
     
    Switch(config-if)# speed 10
     
    Switch(config-if)# duplex half
     
     
    命令
    目的
    Step 1 
    configure terminal
    进入配置模式
    Step 2 
    interface interface-id
    进入要加入描述的端口
    Step 3 
    description string
    加入描述 (最多240个字符).
    Step 4 
    end
    退回.
    Step 5 
    show interfaces interface-id description
    or
    show running-config
    验证.
    Step 6 
    copy running-config startup-config
    保存
     
     

    Use the no description interface configuration command to delete the description.

    This example shows how to add a description on Fast Ethernet interface 0/4 and to verify the description:

    Switch# config terminal
     
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)# interface fastethernet0/4
     
    Switch(config-if)# description Connects to Marketing
     
    Switch(config-if)# end
     
    Switch# show interfaces fastethernet0/4 description
     
    Interface Status         Protocol Description
    Fa0/4     up             down     Connects to Marketing
    主要命令见下表:
    Show Commands for Interfaces Command
    目的
    show interfaces [interface-id]
    显示所有端口或某一端口的状态和配置.
    show interfaces interface-id status [err-disabled]
    显示一系列端口的状态或错误-关闭的状态
    show interfaces [interface-id] switchport
    显示二层端口的状态,可以用来决定此口是否为二层或三层口。
    show interfaces [interface-id] description
    显示端口描述
    show running-config interface [interface-id]
    显示当前配置中的端口配置情况
    show version
    显示软硬件等情况
     
     
    举例如下:
    Switch# show interfaces status
     
    Port    Name               Status       Vlan       Duplex Speed Type
    Gi0/1                      connected    routed     a-full a-100 10/100/1000Base
    TX
    Gi0/2   wce server 20.20.2 disabled     routed       auto   auto 10/100/1000Base TX
    Gi0/3   ip wccp web-cache notconnect   routed       auto   auto 10/100/1000Base TX
    Gi0/4                      notconnect   routed       auto   auto 10/100/1000Base TX
    Gi0/5                      notconnect   routed       auto   auto 10/100/1000Base TX
    Gi0/6                      disabled     routed       auto   auto 10/100/1000Base TX
    Gi0/7                      disabled     routed       auto   auto 10/100/1000Base TX
    Gi0/8                      disabled     routed       auto    100 10/100/1000Base TX
    Gi0/9                      notconnect   routed       auto   auto 10/100/1000Base TX
    Gi0/10                     notconnect   routed       auto   auto 10/100/1000Base TX
    Gi0/11                     disabled     routed       auto   auto unknown
    Gi0/12                     notconnect   routed       auto   auto unknown
     
    Switch# show interfaces fastethernet 0/1 switchport
     
    Name: Fa0/1
    Switchport: Enabled
    Administrative Mode: static access
    Operational Mode: down
    Administrative Trunking Encapsulation: dot1q
    Negotiation of Trunking: Off
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: ALL
    Pruning VLANs Enabled: 2-1001
    Protected: false
    Unknown unicast blocked: disabled
    Unknown multicast blocked: disabled
    Voice VLAN: dot1p (Inactive)
    Appliance trust: 5
     
     
    Switch# show running-config interface fastethernet0/2
     
    Building configuration...
    Current configuration : 131 bytes
    !
    interface FastEthernet0/2
     switchport mode access
     switchport protected
     no ip address
     mls qos cos 7
     mls qos cos override
    end
    Clear命令
    目的
    clear counters [interface-id]
    清除端口计数器.

    clear line [number | console 0 | vty number]

    重置异步串口的硬件逻辑
     
     

    Note   clear counters 命令只清除用show interface所显示的计数,不影响用snmp得到的计数

    举例如下:
    Switch# clear counters fastethernet0/5 
    Clear "show interface" counters on this interface [confirm] y 
    Switch#
    *Sep 30 08:42:55: %CLEAR-5-COUNTERS: Clear counter on interface FastEthernet0/5
    by vty1 (171.69.115.10)
    可使用clear line 命令来清除或重置某一端口或串口,在大部分情况下并不需要这样做:
    Switch# clear interface fastethernet0/5 
     
     
    命令
    目的
    Step 1 
    configure terminal
    进入配置状态
    Step 2 

    interface {vlan vlan-id} | {{fastethernet | gigabitethernet} interface-id} | {port-channel port-channel-number}

    选择要关闭的端口
    Step 3 
    shutdown
    关闭
    Step 4 
    end
    退出
    Step 5 
    show running-config
    验证
     
     
    使用 no shutdown 命令重新打开端口.
    举例如下:
    Switch# configure terminal
     
    Switch(config)# interface fastethernet0/5 
    Switch(config-if)# shutdown 
    Switch(config-if)#
    *Sep 30 08:33:47: %LINK-5-CHANGED: Interface FastEthernet0/5, changed state to a 
    administratively down
    Switch# configure terminal
     
    Switch(config)# interface fastethernet0/5 
    Switch(config-if)# no shutdown 
    Switch(config-if)#
    *Sep 30 08:36:00: %LINK-3-UPDOWN: Interface FastEthernet0/5, changed state to up
     一个VLAN就是一个交换网,其逻辑上按功能、项目、应用来分而不必考虑用户的物理位置。任何交换口都可以属于某一VLAN, IP包、广播包及组播包均可以发送或广播给在此VLAN内的最终用户。每一个VLAN均可看成是一个逻辑网络,发往另一VLAN的数据包必须由路由器或网桥转发(如下图)。由于VLAN被看成是一个逻辑网络,其具有自己的网桥管理信息庫 (MIB) 并可支持自己的生成树


     VLAN
    作为逻辑定义的网络示意图


    VLAN常常与IP子网相联系,同一IP子网属于同一VLAN。在3550上VLAN之间的数据包可以由VLAN端口进行转发。

    Catalyst 3550交换机支持250个 VLAN,可以分别是VTP client, server, 及 transparent modes. VLAN号可以从1到4094. VLAN号1002到1005保留给令牌环及FDDI VLAN. VTP只能学习到普通范围的VLAN, 即从VLAN到1到1005; VLAN号大于1005属于扩展VLAN,不存在VLAN数据庫中。 交换机必须配置成VTP透明模式当需要生成VLAN 号从1006到4094.

    本交换机支持基于每一VLAN的生成树(PVST),最多支持128个生成树。本交换机支持ISL及IEEE 802.1Q trunk二种封装。

    VLAN号1, 1002到1005是自动生成的不能被去掉。
    VLAN号1到1005的配置被写到文件vlan.dat 中, 可以用show vlan 命令查看, vlan.dat 文件存放在NVRAM中.
    注意   不要手工删除vlan.dat 文件,可能造成VLAN的不完整。 如要删除vlan需要用有关的命令来进行
     
     
    命令
    目的
    Step 1 
    configure terminal
    进入配置状态
    Step 2 
    vlan vlan-id
    输入一个VLAN号, 然后进入vlan配置状态,可以输入一个新的VLAN号或旧的来进行修改。
    Step 3 
    name vlan-name
    (可选)输入一个VLAN名,如果没有配置VLAN名,缺省的名字是VLAN号前面用0填满的4位数,如VLAN0004是VLAN4的缺省名字
    Step 4 
    mtu mtu-size
    (可选) 改变MTU大小
    Step 5 
    end
    退出
    Step 6 

    show vlan {name vlan-name | id vlan-id}

    验证
    Step 7 
    copy running-config startup config
    (可选) 保存配置
     

    no vlan nameno vlan mtu 退回到缺省的vlan配置状态

    举例如下:
    Switch# configure terminal
     
    Switch(config)# vlan 20
     
    Switch(config-vlan)# name test20
     
    Switch(config-vlan)# end
     
     
     
    也可以在enable状态下,进行VLAN配置:
     
    命令
    目的
    Step 1 
    vlan database
    进入VLAN配置状态
    Step 2 
    vlan vlan-id name vlan-name
    加入VLAN号及VLAN名
    Step 3 

    vlan vlan-id mtu mtu-size

    (可选) 修改MTU大小
    Step 4 
    exit
    更新VLAN数据庫并退出
    Step 5 

    show vlan {name vlan-name | id vlan-id}

    验证配置
    Step 6 
    copy running-config startup config
    保存配置(可选)
     
     
    举例如下:
    Switch# vlan database
     
    Switch(vlan)# vlan 20 name test20
     
    Switch(vlan)# exit
     
    APPLY completed.
    Exiting....
    Switch# 
    当删除一个处于VTP服务器的交换机上删除VLAN时,则此VLAN将在所有相同VTP的交换机上删除。当在透明模式下删除时,只在当前交换机上删除。
    注意   当删除一个VLAN时,原来属于此VLAN的端口将处于非激活的状态,直到将其分配给某一VLAN。
     
     
     
    命令
    目的
    Step 1 
    configure terminal
    进入配置状态
    Step 2 
    no vlan vlan-id
    删除某一VLAN.
    Step 3 
    end
    退出
    Step 4 
    show vlan brief
    验证
    Step 5 
    copy running-config startup config
    保存
     
     
    也可用vlan database 进入VLAN配置状态,用no vlan vlan-id 来删除。
     
     
    命令
    目的
    Step 1 
    configure terminal
    进入配置状态
    Step 2 
    interface interface-id
    进入要分配的端口
    Step 3 
    switchport mode access
    定义二层口
    Step 4 
    switchport access vlan vlan-id
    把端口分配给某一VLAN
    Step 5 
    end
    退出
    Step 6 
    show running-config interface interface-id
    验证端口的VLAN号
    Step 7 
    show interfaces interface-id switchport
    验证端口的管理模式和VLAN情况
    Step 8 
    copy running-config startup-config
    保存配置
     
     

    使用 default interface interface-id还原到缺省配置状态。

    举例如下:
    Switch# configure terminal 
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)# interface fastethernet0/1 
     
    Switch(config-if)# switchport mode access 
     
    Switch(config-if)# switchport access vlan 2
     
    Switch(config-if)# end 
    Switch#
     
     
    命令
    目的
    Step 1 
    configure terminal
    进入配置状态
    Step 2 
    interface interface-id
    进入端口配置状态
    Step 3

    switchport mode {dynamic {auto | desirable} | trunk}

    配置二层trunk模式。
    • dynamic auto—自动协商是否成为trunk
    • dynamic desirable—把端口设置为trunk如果对方端口是trunk, desirable, 或自动模式
    • trunk—设置端口为强制的trunk方式,而不理会对方端口是否为trunk
    Step 4
    switchport access vlan vlan-id
    (可选) 指定一个缺省VLAN, 如果此端口不再是trunk
    Step 5 
    switchport trunk native vlan vlan-id
    指定802.1Q native VLAN号
    Step 6 
    end
    退出
    Step 7 
    show interfaces interface-id switchport
    显示有关switchport 的配置
    Step 8 
    show interfaces interface-id trunk
    显示有关trunk的配置
    Step 9 
    copy running-config startup-config
    保存配置
     
    举例:
    Switch# configure terminal 
     
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)# interface fastethernet0/4 
     
    Switch(config-if)# switchport mode trunk 
     
    Switch(config-if)# end 
    定义trunk允许的VLAN
    缺省情况下trunk允许所有的VLAN通过。可以使用 switchport trunk allowed vlan remove vlan-list 来去掉某一VLAN
     
    Command
    Purpose
    Step 1 
    configure terminal
    进入配置状态
    Step 2 
    interface interface-id
    进入端口配置
    Step 3 
    switchport mode trunk
    配置二层口为trunk
    Step 4 

    switchport trunk allowed vlan {add | all | except | remove} vlan-list

    (可选) 配置trunk允许的VLAN.
    使用add, all, exceptremove关健字
    Step 5 
    end
    退出
    Step 6 
    show interfaces interface-id switchport
    验证VLAN配置情况.
    Step 7 
    copy running-config startup-config
    保存配置
     
     
    回到允许所有VLAN通过时, 可用no switchport trunk allowed vlan 端口配置命令.
    举例如下:
    Switch(config)# interface fastethernet0/1
     
    Switch(config-if)# switchport trunk allowed vlan remove 2
     
    Switch(config-if)# end
     
    配置Native VLAN(802.1q)
    封装802.1q的trunk端口可以接受带有标签和不带标签的数据流,交换机向native vlan传送不带标签的数据流,缺省情况下native VLAN是1。
     
     
    命令
    目的
    Step 1 
    configure terminal
    进入配置状态
    Step 2 
    interface interface-id
    进入配置成802.1qtrunk的端口
    Step 3 
    switchport trunk native vlan vlan-id
    配置native VLAN号
    Step 4 
    end
    退出
    Step 5 

    show interfaces interface-id switchport

    验证native VLAN配置
    Step 6 
    copy running-config startup-config
    保存配置
     
     
    使用no switchport trunk native vlan 端口配置命令回到缺省的状态

    负载均衡可以使用流量分流到其它平行的trunks上去. 交换机为了避免环路, STP通常是阻断所有端×××换机之间只留一条链路 。使用负载均衡后, 可以把不同VLAN的流量分配到不同的trunk上。

    可以通过配置STP端口权值STP路径值来实现负载均衡. 如果使用STP端口权值来配置那么二条负载均衡的trunk必须联同一交换机上。使用路径值则即可以联相同的交换机与可以联不同的交换机。
    使用STP端口权值的负载均衡

    当同一台交换机的二个口形成环路时, STP端口权值用来决定那个口是enable的,那个口是阻断的。 可以通过配置端口权值来决定二对trunk各走那些VLAN, 有较高权值的端口(数字较小的)vlan, 将处于转发状态,同一个VLAN在另一个trunk有较低的权值(数字较大)则将处在阻断状态。 即同一VLAN只在一个trunk上发送接受。


    基于端口权值的负载均衡示意图

    trunk1将发送和接收VLAN8-10的数据,trunk2将发送和接收VLAN3-6的数据

    配置如下:
     
    Command
    Purpose
    Step 1 
    configure terminal
    进入Switch 1配置状态
    Step 2 
    vtp domain domain-name
    配置VTP域
    Step 3 
    vtp server
    将Switch 1配置成VTP server.
    Step 4 
    end
    退出
    Step 5 
    show vtp status
    验证VTP的配置
    Step 6 
    show vlan
    验证VLAN
    Step 7 
    configure terminal
    进入配置状态
    Step 8 

    interface fastethernet 0/1

    进入F0/1端口
    Step 9 
    switchport mode trunk
    配置成trunk端口
    Step 10 
    end
    退出
    Step 11 

    show interfaces fastethernet0/1 switchport

    验证VLAN配置
    Step 12
     
    在switch1上的F0/2上重复7到11步骤
    Step 13
     
    在Switch 2的F0/1,F0/2上重复7到11步骤。
    Step 14 
    show vlan
    当trunk已经起来,在switch2上验证已经学到相关的vlan配置
    Step 15 
    configure terminal
    在Switch 1上进入配置状态
    Step 16 
    interface fastethernet0/1
    进入要配置的端口
    Step 17 
    spanning-tree vlan 8 port-priority 10
    将端口权值10赋与VLAN 8.
    Step 18 
    spanning-tree vlan 9 port-priority 10
    将端口权值10赋与VLAN 9.
    Step 19 
    spanning-tree vlan 10 port-priority 10
    将端口权值10赋与VLAN 10.
    Step 20 
    exit
    退回.
    Step 21
    interface fastethernet0/2
    进入F0/2
    Step 22
    spanning-tree vlan 3 port-priority 10
    将端口权值10赋与VLAN 3.
    Step 23
    spanning-tree vlan 4 port-priority 10
    将端口权值10赋与VLAN 4.
    Step 24
    spanning-tree vlan 5 port-priority 10
    将端口权值10赋与VLAN 5.
    Step 25
    spanning-tree vlan 6 port-priority 10
    将端口权值10赋与VLAN 10.
    Step 26
    end
    退出
    Step 27 
    show running-config
    验证配置
    Step 28
    copy running-config startup-config
    保存配置
     
     
    配置STP路径值的负载均衡
    也可以通过配置配置STP路径值来实现负载均衡,如下图所示
    Trunk1走VLAN8-10,Trunk2走VLAN2-4


     
     
    命令
    目的
    Step 1 
    configure terminal
    进入 Switch 1配置状态
    Step 2 

    interface fastethernet 0/1

    进入F0/1
    Step 3 
    switchport mode trunk
    配置Trunk,只能是dot1q模式
    Step 4
    exit
    退回
    Step 5
     
    在F0/2口上重复2-4步骤
    Step 6 
    end
    退出
    Step 7 
    show running-config
    验证配置
    Step 8 
    show vlan
    验证switch1已经学到Vlan
    Step 9 
    configure terminal
    进入配置状态
    Step 10 
    interface fastethernet 0/1
    进入F0/1
    Step 11 
    spanning-tree vlan 2 cost 30
    设置Vlan2生成树路径值为30
    Step 12 
    spanning-tree vlan 3 cost 30
    设置Vlan3生成树路径值为30
    Step 13 
    spanning-tree vlan 4 cost 30
    设置Vlan4生成树路径值为30
    Step 14 
    end
    退出
    Step 15 
     
    在switch1的F0/2上重复9-11步骤设置VLAN8,9,10生成树路径值为30
    Step 16 
    exit
    退出
    Step 17 
    show running-config
    验证配置
    Step 18 
    copy running-config startup-config
    保存配置
    以本工程一个例子说明,该例子是信息大厦主楼十楼四台2950交换机堆叠的例子。例子中,第一、二台管理vlan做hsrp,IP地址如图所示。
     
    1、STEP 1:配置Clust管理vlan,如将vlan 5作为管理vlan。
     
     
     
     
     
     
     
     
     
     
     
     
    命令:
    interface vlan 5
    no shutdown
    end
     
    2、STEP 2:查看各台设备上管理vlan的MAC地址。
    命令:
    show interface vlan 5
    结果:

    ZL-10th -Floor-1中的MAC地址为:000a.f404.ad80

    ZL-10th -Floor-2中的MAC地址为:000a.f404.a500

    ZL-10th -Floor-3中的MAC地址为:000a.f404.ab80

    ZL-10th -Floor-4中的MAC地址为:000a.f404.ac00
    3、STEP 3:在第一台设备上的配置
    命令:
    cluster standby-group ZL-10th-Floor
    由于要配置standby,所以该命令是配置standby组名
    cluster enable ZL-10th-Floor 0
    配置cluster名,该台机是主设备
    cluster member 1 mac-address 000a.f404.a500
    配置第二台堆叠设备的参数,硬件地址为管理vlan地址
    cluster member 2 mac-address 000a.f404.ab80
    配置第三台堆叠设备的参数
    cluster member 3 mac-address 000a.f404.ac00
    配置第四台堆叠设备的参数
    interface vlan 5
    ip address 132.107.77.74 255.255.255.128
    standby 2 ip 132.107.77.73
    standby 2 priority 110
    standby 2 preempt delay sync 0
    standby 2 name ZL-10th-Floor
    上面几条命令是管理vlan里standby的配置
    4、STEP 4:配置第二台堆叠设备
    命令:
    cluster standby-group ZL-10th-Floor
    cluster member 0 mac-address 000a.f404.ad80
    配置第一台堆叠设备参数
    cluster member 2 mac-address 000a.f404.ab80
    cluster member 3 mac-address 000a.f404.ac00

    cluster commander-address 000a.f404.ad80 member 1 name ZL-10th-Floor

    上面一条命令指明是第二台堆叠设备
    interface Vlan5
    ip address 132.107.77.75 255.255.255.128
    standby 2 ip 132.107.77.73
    standby 2 priority 100
    standby 2 preempt delay sync 0
    standby 2 name ZL-10th-Floor
    配置standby参数
    5、STEP 5:配置第三台堆叠设备

    cluster commander-address 000a.f404.ad80 member 2 name ZL-10th-Floor

    6、配置第四台堆叠设备

    cluster commander-address 000a.f404.ad80 member 3 name ZL-10th-Floor

     

    转载于:https://blog.51cto.com/idiot988/890272

    展开全文
  • 思科交换机配置命令大全switch> 用户模式 1:进入特权模式enable switch> enable switch# 2:进入全局配置模式configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3:交换机命名hostname...
  • 思科交换机配置命令大全 switch> 用户模式 1:进入特权模式 enable switch> enable switch# 2:进入全局配置模式 configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3:交换机命名 ...
  • switch> 用户模式 1:进入特权模式 enable switch> enable switch# 2:进入全局配置... enable switch#c onfigure terminal switch(conf)# 3:交换机命名 hostname aptech2950 以 aptech2950 为例 switch>...
  • 思科2950交换机为例,登录进入交换机,输入管理口令进入配置模式,敲入命令: Switch#c onfig terminal 进入配置模式 Switch(config)# Interface fastethernet 0/1 #进入具体端口配置模式 Switch(config-...
  • 思科2950型的配置

    2009-05-22 21:10:10
    思科2950交换机相关配置 基本操作 2950(config)#int vlan1 2950(config-if)#ip address 192.168.1.100 255.255.255.0 (VLAN1里面设置IP地址) 2950(config)#ip default-gateway 192.168.1.1 (设置默认网关) 2950...
  • 该资源包括2950、3550、4006、6000四种类型交换机配置手册,手册均为中文
  • switch> 用户模式 1:进入特权模式 enable switch> enable switch# 2:进入全局配置... enable switch#c onfigure terminal switch(conf)# 3:交换机命名 hostname aptech2950 以 aptech2950 为例 switch>...
  • CISCO交换机配置2950

    2007-09-08 00:38:01
    2950交换机 简明配置维护手册 中国思科培训网 目录 说明3 产品特性3 配置端口4 配置一组端口4 配置二层端口6 配置端口速率及双工模式6 端口描述7 监控及维护端口8 监控端口和控制器...
  • 思科交换机简单配置

    2008-04-02 22:45:26
    单位需要对原有基本没有进行设置过的2950和3550交换机进行SNMP管理。由于之前纸上谈兵的时候较多,没有经过实践磨练,这次设置出了不少差错,害得同事白跑了一趟,实在是深感抱歉。现将配置默抄下来,供自己参考。若...
  • 思科交换机强制恢复出厂设置(清密码)1)拔下交换机电源,用手按住交换机“Mode” 按钮,插上电源,等待交换机进入控制台模式。其提示符为“switch:”2)switch: flash_init //初始化flash文件系统3)switch: dir ...
  • 单位的无线上网最近老是不稳定,于是就想telnet到接AP的交换机上看看running config的配置.但是连上后发现密码已非原始密码,问了老大,他也不知道,据说被供应商改掉了,于是电话供应商问密码,折腾了半天,得到的答复是:...
  • 有的交换机,例如 2950只能封装 dot1q,因此无需执行该命令。 Switch(config)#interface f0/2 Switch(config-if)#switchport trunk encapsulation dot1q Switch(config-if)#switchport mode trunk Switch...
  • 思科交换机隔离访问

    2012-02-15 17:01:16
    cisco低端交换机中的实现方法:  1.通过端口保护(Switchitchport protected)来实现的。... 相对来说cisco 3550或者2950交换机配置相对简单,进入网络接口配置模式:  Switch(config)#int range f0/1...
  • TELNET不上思科交换机

    2015-02-05 14:24:12
    后来才发现是:cisco2950是二层交换机 即使你配置了多个VLAN的IP,也只能有一个VLAN来进行管理,其他的都会失效不知道谁加上去一个VLAN100的,害我瞎忙活半天。interface Vlan100ip address 10.0...
  • 我和网络工程师学了初始设置思科2950交换机,一口气设置了10台,三年来都是作为傻瓜交换机使用的,虽然只是简单设置了一下,但总算开了个好头,终于敢对交换机下手了,为以后公司域管理工作做了个小小的准备工作,这...
  • 方案1——基于端口的MAC地址绑定 思科2950交换机为例,登录进入交换机,输入管理口令进入配置模式,敲入命令: Switch#config terminal  #进入配置模式 Switch(config)# Interface fastethernet 0/1 #进入...
  • cisco交换机IP-MAC地址绑定配置

    千次阅读 2017-11-08 23:54:00
    思科2950交换机为例,登录进入交换机,输入管理口令进入配置模式,敲入命令: Switch#c onfig terminal 进入配置模式 Switch(config)# Interface fastethernet 0/1 #进入具体端口配置模式 Switch(config-if)#...
  • ProxmoxVE6.2 VLAN配置

    2020-10-04 11:49:14
    交换机:思科2950 交换机配置: FastEthernet0/1口连接Pve节点enp3s0端口 配置为Trunk FastEthernet0/2口连接测试计算机 配置为VLAN 100 方案1 一、创建网桥 创建Linux Bridge 设置名称:vmbr0 开启VLAN感知 设置...

空空如也

空空如也

1 2 3 4 5
收藏数 85
精华内容 34
关键字:

思科2950交换机配置