精华内容
下载资源
问答
  • 2022-02-15 18:23:20

    目录

    一、.HSRP

    1.1HSR0P的原理

    1.2.1HSRP的相关概念

    1.2.2HSRP组成员

    1.3HSRP的状态

    1.4HSRP的计时器

    1.5HSRP与VRRP的区别

    1.6HSRP配置


    一.HSRP
    1.1HSR0P的原理

    建设企业网络的主要目的是让最终用户可以访问其数据与服务。最终用户往往把企业网络作为一个整体系统来看待,并不关心到底是哪台具体的路由器或交换机在工作。网络工程师在设计方案时,必须使网络作为个整体系统来提供服务,即使出现故障,也能维持正常的网络连接。HSRP为这种情况提供了一个较好的解决方案。
     

    1.2.1HSRP的相关概念

    HSRP (Hot Standby Routing Protocol,热备份路由选择协议)是Cisco私有的一种技术,它确保了当网络边缘设备或接入链路出现故障时,用户通信能迅速并透明地恢复,以此为IP网络提供冗余性。通过应用HSRP,可使网络的正常运行时间接近100%,从而满足用户对网络可靠性的要求。
    HSRP为IP网络提供了容错和增强的路由选择功能。通过使用同一个虚拟IP地址和虚拟MAC地址,LAN网段上的两台或多台路由器可以作为一台虚拟路由器对外提供服务。HSRP 使组内的Cisco路由器能互相监视对方的运行状态。
    1.虚拟路由器组的成员通过HSRP消息不断地交换状态信息。
    2.如果其中一台出现故障,另一台可接替它继续完成路由功能


    1.2.2HSRP组成员


    HSRP备份组由一台活跃路由器、一 台 备份路由器、台 虚拟路由器和其他路由器组成(在三层交换机配置HSRP时也使用HSRP定义的备份路由器等名称)其中,各路由器的功能如下。

    (1)活跃路由器的功能是转发 发送到虚拟路由器的数据包。组中的另一台路由器被选为备份路由器。活跃路由器通过发送Hello消息来承担和保持它活跃的角色。

    (2)备份路由器 的功能是监视HSRP组的运行状态,并且当活跃路由器不能运行时,迅速承担起转发数据包的责任。备份路由器也传输Hello消息,告知组中所有路由器备份路由器的角色和状态变化。

    (3)虚拟路由器 (即该LAN上的网关)的功能是向最终用户提供一台 可以连续工作的路由器,虚拟路由器配有它自己的IP地址和MAC地址,但并不实际转发数据包。

    (4)HSRP备份组可以包含其他路由器。这些路由器监视Hello消息,但不做应答。这些路由器转发任何经由它们的数据包,但并不转发经由虚拟路由器的数据包。
    当活跃路由器失效时,其他HSRP路由器将不能接收到Hello消息,随后备份路由器就承担起活跃路由器的角色.
     

    1.3HSRP的状态

    HSPP配置的路由器有六种状态,分别如下。

    1.初始状态。

    2.学习状态。

    3.监听状态。

    4.发言状态。

    5.备份状态。

    6.活跃状态。

    并不是所有的HSRP路由器都经历所有状态。例如,不是备份路由器或活跃路由器的路由器不会有备份状态和活跃状态

    1.初始状态
    所有路由器都从初始状态开始。这是一种起始状态, 同时表明HSRP还没有运行,配置发生变或一个端口第一次启用时, 进入该状态。

    2.学习状态

    欢中器等待来自活跃路由器的消息。这时,路由器还没有看到来自活跃路由器的Hello消息,也没有学习到虚拟路由器的IP地址。

    3.监听状态

    欧中器知道了虚拟路由器的P地址,但它既不是活跃路由器,也不是备份路由器。这时,路由器监听来自活跃路由器和备份路由器的Hello消息。除活跃路由器和备份路由器之外的路由器都保持监听状态。

    4.发言状态

    路由器周期性地发送Hell消息,并参与活跃路由器或备份路由器的竞选。路由器在获得 虚拟路由器的P地址之前,不能进入发言状态。

    5.备份状态
    路由器是成为下一个活跃路由器的候选设备,并且它也周期性地发送Hlo消息,在一 个组中只有一台备份路由器。

    6.活跃状态

    在活跃状态,路由器负责转发发送到备份组的虚拟MAC地址的数据包.活跃路由器周期性地发洪Hello消息,在一个组中,必须有且只有台活跃路由器。
     

    1.4HSRP的计时器

    HSRP使用两个计时器Hell间隔计时器和保持时间计时器任何状态的HSP路由器都会在Hllo间隔计时器超时后生成Hello 包。默认的Hllo间隔是3s,默认的保持时间是10s.

    未配置计时器的路由器会从活跃路由器或备份路由器学到这些计时器的值。活跃路由器上配置的计时器值会覆盖其他路由器上的计时器设定值同-个HSRP组内的路由器应该使用相同的计时器值。通常,保持时间会大于或等于Hello间隔的三倍,并且保持时间的取值必须大于Hello间隔、其他HSRP路由器按照保持时间对活跃路由器进行监控:当收到任何活跃路由器发出的Hello包时,路由器会根据HSRP Hello消息中的相应字段重置保持时间值。
    通常,默认的HSRP计时器值适用于大多数的LAN网段。

    1.5HSRP与VRRP的区别

    HSRP是Cisco的专有协议。在Cisco的HSRP之后,IETF (Internet Engineering Task Foroe,internet工程任务组)也制定了一种路由备份冗余协议: VRRP (Virtual Router Redundancy Protocol,虚拟路由器冗余协议)。目前,包括Cisco在内的主流厂商均已在其产品中支持VRRP

    VRRP的工作原理与HSRP相似,也是将系统中的多台路由器组成VRRP组,该组拥有同一个虚拟IP地址作为LAN的默认网关地址。在任何时刻,-个组内控制虚拟IP 地址的路由器是主路由器(Master),由它来转发数据包。如果主路由器发生了故障,VRRP 组将选择一个优先权最高的冗余备份路由器(Backup) 作为新的主路由器.

    VRRP和HSRP也有很多不同。VRRP 与HSRP的一一个主要区别表现在安全性方面: VRRP允许参与VRRP组的设备间建立认证机制。另一个主要区别: VRRP 中只有三种状态:初始状态 (lnitialile)、主状态(Master). 备份状态(Backup), 而HSRP有六种状态。另外,在报文类型、报文格式和通过TCP而非UDP发送报文方面也有所不同。
     

    1.6HSRP配置

     路由器配置
    R3#conf t进入特权模式
    R3(config)#int f0/0进入接口模式
    R3(config-if)#ip add 13.1.1.1 255.255.255.0配置接口IP
    R3(config-if)#no shutdown开启此接口
    R3(config-if)#int f1/0进入接口
    R3(config-if)#ip add 23.1.1.1 255.255.255.0配置接口IP
    R3(config-if)#no shutdown开启此接口
    R3(config-if)#end退出
    R3#conf t进入全局模式
    R3(config)#ip route 192.168.1.0 255.255.255.0 13.1.1.10添加静态路由
    R3(config)#ip route 192.168.1.0 255.255.255.0 23.1.添加静态路由
    R3(config)#ip route 192.168.1.0 255.255.255.0 23.1.1.1 2添加静态路由
    R3(config)#ip route 192.168.1.0 255.255.255.0 23.1.1.10 2添加静态路由
    R3(config)#int loopback 0创建环回口
    R3(config-if)#no shutdown开启此接口

    ESW1(config-if)#ip add 3.3.3.3 255.255.255.255配置环回口IP
    三层交换机(1)
    ESW1#conf t进入全局模式
    ESW1(config)#ip routing开启路由功能
    ESW1(config)#exit退出
    ESW1#vlan database进入vlan数据库
    ESW1(vlan)#vlan 100 创建vlan
    VLAN 100 modified:
    ESW1(vlan)#vlan 200创建vlan
    VLAN 200 modified:
    ESW1(vlan)#exit退出
    ESW1#conf t进入全局模式
    Enter configuration commands, one per line. End with CNTL/Z.
    ESW1(config)#int f1/2进入接口模式
    ESW1(config-if)#switchport mode access将此接口设置为access模式
    ESW1(config-if)#switchport access vlan 100将此接口加入vlan
    ESW1(config-if)#int f1/1进入此接口
    ESW1(config-if)#switchport mode access设置为access模式
    ESW1(config-if)#switchport access vlan 200将此接口划分进vlan
    ESW1(config-if)#int vlan 100进入vlan
    ESW1(config-if)#ip add 192.168.1.10 255.255.255.0创建vlanIP
    ESW1(config-if)#no shutdown开启此接口
    ESW1(config)#int vlan 200进入vlan
    ESW1(config-if)#ip add 13.1.1.10 255.255.255.0创建vlan200
    ESW(config-if)#no shutdown开启此接口
    ESW1(config-if)#exit退出
    ESW1(config)#int vlan 100进入vlan100
    ESW1(config-if)#standby 1 ip 192.168.1.1设置虚拟组IP
    ESW1(config-if)#standby 1 priority 105优先级为105
    ESW1(config-if)#standby 1 preempt开启抢占
    ESW1(config-if)#standby 1 track f1/1开启接口跟踪
    ESW1(config)#ip route 0.0.0.0 0.0.0.0 13.1.1.1添加默认路由 


    三层交换机(2)
    ESW2#vlan database进入vlan数据库
    ESW2(vlan)#vlan 100创建vlan
    VLAN 100 added:
    Name: VLAN0100
    ESW2(vlan)#vlan 200创建vlan
    VLAN 200 added:
    Name: VLAN0200
    ESW2(vlan)#exit退出
    ESW2#conf t进入全局模式
    ESW2(config)#int f1/1进入接口模式
    ESW2(config-if)#switchport mode access将此接口设置为access模式
    ESW2(config-if)#switchport access vlan 200将此接口加入vlan
    ESW2(config-if)#int f1/2进入接口模式
    ESW2(config-if)#switchport mode access将此接口设置为access模式
    ESW2(config-if)#switchport access vlan 100将此接口加入vlan
    ESW2(config-if)#int vlan 100进入vlan
    ESW2(config-if)#ip add 192.168.1.11 255.255.255.0配置vlanIP
    ESW2(config-if)#no shutdown开启此接口
    ESW2(config-if)#int vlan 200进入vlan200
    ESW2(config-if)#ip add 23.1.1.10 255.255.255.0配置vlanIP
    ESW2(config-if)#no shutdown开启此接口
    ESW2(config-if)#exit退出
    ESW2(config)#ip routing开启路由功能
    ESW2(config)#int vlan 100进入vlan100
    ESW2(config-if)#standby 1 ip 192.168.1.1配置虚拟组IP
    ESW2(config-if)#standby 1 priority 100优先级为100(默认为100,可不设)
    ESW2(config-if)#standby 1 preempt开启抢占
    ESW2(config-if)#standby 1 track f1/1开启接口跟踪
    ESW2(config)#ip route 0.0.0.0 0.0.0.0 23.1.1.1设置默认路由
     

    更多相关内容
  • HSRP(Hot Standby Router Protocol 热备份路由器协议)是Cisco的专有协议HSRP把多台路由器组成一个“热备份组”,形成一个虚拟路由器。这个组内只有一个路由器是Active(活动)的,并由它来转发数据包,如果活动...

     

    HSRP简介

     

    HSRP(Hot Standby Router Protocol 热备份路由器协议)是Cisco的专有协议。HSRP把多台路由器组成一个“热备份组”,形成一个虚拟路由器。这个组内只有一个路由器是Active(活动)的,并由它来转发数据包,如果活动路由器发生了故障,备份路由器将成为活动路由器。从网络内的主机来看,网关并没有改变。

     

    HSRP工作原理

    HSRP(Hot Standby Router Protocol 热备份路由器协议)把多台路由器组成一个虚拟路由器(Virtual Router)。PC上设置网关后,如果网关down了就断网了,导致网络连接不稳定。因此需要备用网关,即冗余网关,确保网络连接正常。HSRP可以提供冗余网关的解决方案。

    VR虽然是虚拟路由器,但同样需要有三层IP地址和二层Mac地址。三层IP地址是手动配的,但不能乱配,需要配置成和真实路由器处于同一网段的IP地址。VR的二层地址是自动生成的。例如0000.0c07.ac01,前6位0000.0c是Cisco买来的。中间4位07.ac是HSRP号。最后2位01是HSRP Group组号。每个HSRP组内只能有一个路由器是Active(活动)的,一个路由器是Standby备份的,其余路由器将处于监听状态。通过Active路由器来转发数据,如果Active路由器down了,Standby备份路由器将成为Active路由器,以保证网络的正常运行。属于同一个HSRP组的路由器的虚拟三层IP地址必须一致。

    例如将真实路由器A和B捆绑成虚拟路由器VR后,谁成为Active路由器,谁成为Standby备份路由器呢?HSRP用优先级来决定,优先级高的成为Active路由器。优先级默认都是100,可以修改。如果优先级相同,IP地址高的成为Active路由器。路由器间通过组播(224.0.0.2)Hello包来互相监听各自的存在。Hello包默认每3秒发一次,如果长期收不到Active路由器发出的Hello包,就认为Active路由器出故障了,Standby备份路由器就将成为Active路由器。

     

     

    HSRP报文格式

     

    • 版本:指示HSRP的版本信息。

    • 操作码:用来描述数据包中报文的类型,可能的值为0、1和2,分别表示是Hello、Coup和Resign消息。

    • 状态:描述发出该报文的路由器的当前状态。有0、1、2、4、8、16六种状态,分别表示为Initial、Learn、Listen、Speak、Standby和Active状态。

    • 呼叫时间(Hellotime):只在呼叫报文中有意义,表示路由器定时发送呼叫报文的间隔时间,以秒为单位。如果该参数没有在路由器上配置,它可能要从活动路由器上学习获得。默认值为3秒。

    • 保持时间(Holdtime):只在呼叫报文中有意义,被接收路由器用来判断该呼叫报文是否合法,单位为秒,其值至少是呼叫时间的3倍。如果该参数没有配置,也同样可以从活动路由器上学习。活动路由器不能从等待路由 器学习呼叫时间和保持时间,它只能继续使用从先前的活动路由器学习来的该值。默认值为10秒。

    • 优先级:该参数用来选择活动和等待路由器,两个具有不同优先级的路由器,优先级高的将成为活动路由器。两个具有相同优先级的路由器,IP地址大的将成为活动路由器。默认优先级为100。

    • 组:用来标记路由器所在的热等待组。对令牌环类型的网络,合法的值是0、1和2,对于其它类型的网络,合法值是0-255。

    • 认证码:包括8个明文的字符作为密码,如果没有配置,默认值为cisco。

    • 虚拟IP地址:用来指定本热等待组的虚拟IP地址,它可以从活动路由器的呼叫报文中学习到。如果没有配置该地址,并且呼叫报文是需要认识的,那么只能通过活动路由器学习。

     

     

    HSRP状态

    Initial

    初始状态,Hold时间10s后进入Listen

    Learn

    例如路由器A上新建了VR并设置了VR的IP,B加入了该VR但没有设置VR的IP,那B会从A那里学习到VR的IP。当然如果A和B都手动设了同样的VR的IP,就不会有这个状态

    Listen

    路由器加入进VR后,此时它既不是Active也不是Standby路由器,因此它监听Active和Standby发出的Hello包。如果收不到,Hold时间10s后进入Speak

    Speak

    路由器主动发送Hello包,包含自己的优先级,自己的IP地址,VR的IP地址等。参加竞选,竞争成为Active或Standby备份路由器。

    Standby

    竞选成为Standby路由器后,将定时发送Hello包。如果Standby状态下收不到Active路由器的Hello包,不经过Hold时间马上将自己置为Active。

    Active

    竞选成为Active路由器后,将定时发送Hello包。并承担转发数据的责任。

    (Hello时间默认3s,Hold时间默认10s,是可以修改的,你可以改小点,比如改成500ms,但时间越短,占的资源就越多,需要你权衡利弊。通常Hold时间最少应是Hello时间的3倍)。

     

     

    HSRP定时器

    HSRP使用2个定时器:Hello间隔和Hold时间。默认Hello间隔是3秒,默认的Hold间隔是10秒。Hello间隔定义了两组路由器之间交换信息的频率。Hlod间隔定义了经过多长时间后,没有收到其它路由器的信息,则活动路由器或者备用路由器就会被宣告为失败。配置计时器并不是越小越好,虽然计时器越小则切换时间越短。计时器的配置需要和STP等的切换时间相一致。另外,Hold间隔最少应该是Hello间隔的3倍。

     

    展开全文
  • HSRP-热备份路由协议原理及实验—基于Cisco Packet Tracer0 引言1 HSRP协议概述2 工作原理2.1 核心原理2.2 工作流程3 相关命令4 实验4.1 实验要求4.2 实验分析4.3 实验步骤4.4 实验结果4.5 实验可能存在的故障分析5 ...

    0 引言

    如果一个公司只有一个路由器与外网相连,当该链路发生故障时,将导致整个公司员工都上不了网,影响较大。为避免这种不利影响,中大型公司一般会再买一台路由器,用于连接内外网,作为网关的备份。那么,当公司的当前路由器链路发生故障时,如何让员工不需要做任何操作且毫无感觉,而上网时数据能瞬间自动选择通过备份路由器流向外网。
    本节内容HSRP协议主要是解决当前路由器发生故障时,让员工不需要做任何操作,而上网时数据能瞬间自动选择通过备份路由器流向外网。

    1 HSRP协议概述

    (1)HSRP协议:Hot Standby Router Protocol,热备份路由协议(类似的有VRRP协议,公有协议),是cisco平台一种特有的技术,是cisco的私有协议。注意,热备份路由协议其实备份的是网关,该协议的所有操作都是在网关接口里配置。
    (2)工作条件:①启用HSRP协议,并且相关路由器都需要加入同一个“热备份组”;②这个组瞬间出现一个虚拟路由器,“热备份组”内的物理路由器都需要给虚拟路由器指定相同的虚拟IP;③组内通过优先级判断谁是活跃路由器。
    在这里插入图片描述
    (3)组号:1~225,组号仅是标识符,没有大小之分。
    (4)优先级:1~255。默认为100。数字越大,优先级越高。只有物理路由器有优先级,虚拟路由器没有。
    (5)组员:加入到同一组。

    • 1)虚拟路由器(老大):必须设置虚拟IP,不占用实际端口。
    • 2)活跃路由器:优先级最高的。
    • 3)备份路由器:优先级次之。
    • 4)其他路由器:优先级再次之。

    (6)HSRP组成员通过定时发送hello包来交流,默认每个3秒发送一次。
    (7)坚持时间:10秒。备份路由器在发送hello包后没有按时收到活跃路由器的hello包时,坚持10秒后若仍收不到才上位为活跃路由器。
    (8)占先权preempt:备份路由器当检测不到对方或检测到对方优先级比自己低,立即抢占活跃路由器名分。(能提高切换速度)一般给备份路由器配置,活跃路由器配不配无所谓。
    (9)配置跟踪track

    • 1)应用背景:当活跃路由器与外网相连的链路坏了,但是活跃路由器没坏且与内网连接的链路正常时,活跃路由器仍然能在组内发hello包,此时备份路由器无法上位,内部无法上网。
    • 2)配置跟踪track:这时需要在活跃路由器上网关接口上配置跟踪外网接口,监听其工作状态,当外网接口down掉,路由器将自动降低优先级,至少需要降到优先级比备份路由器低。如果路由器还连接了其他专线网络,则需要同样跟踪。

    2 工作原理

    2.1 核心原理

    配置多台路由器用于连接内外网,那么一个网段就有多个网关,将一个网段的多个网关加入同一个HSRP组中。正常情况下,内外网的通信,数据流量只从一个路由器的网关通过,该路由器称为活跃路由器。当活跃路由器失效后,备份路由器将自动成为新的活跃路由器,承担转发用户流量的职责。

    2.2 工作流程

    (1)所有员工网关均指向虚拟路由器
    (2)数据经过虚拟路由器时,由虚拟路由器转发至活跃路由器与外网连接。
    (3)当活跃路由器路损坏后,备份路由器在下一次发送hello包后没有按时收到活跃路由器的hello包,心有不甘想要上位,忍耐10秒钟(给活跃路由器3次机会)。
    (4)10秒过后备份路由器上位为活跃路由器,数据经过虚拟路由器时,转发至活跃路由器与外网连接。
    (5)当备份路由器配置了占先权preempt时,当检测不到活跃路由器或检测到对方优先级比自己低时,立即抢占活跃路由器名分。
    (6)当原活跃路由器再次上线时,发送hello包,此时由于本身优先级高重新占回活跃路由器地位。

    3 相关命令

    对路由器接口设置HSRP组号、设置虚拟IP地址、优先级、占先权以及接口跟踪。

    conf t
    int f0/x					#注意由于是对网关进行备份,因此需要进入网关所在接口进行配置
    standby 1 ip 10.1.1.254		#将该接口加入热备份组(组号1)并同时指定虚拟IP
    standby 1 priority 200		#设置优先级为200
    standby 1 preempt			#设置占先权活跃路由器可不设置
    standby 1 track f0/x 数字	
    #设置跟踪f0/x(为外网接口)的状态,当该接口down掉时,本接口自动降低xx优先级(真实机可以设置降多少优先级),本软件不能自降值。
    en
    show standby brief      # 查看热备份的简要信息
    show standby            # 查看热备份的详细信息,可以查看自降优先级时降了多少。
    

    4 实验

    4.1 实验要求

    按下图拓补图构建网络,暂不考虑VLAN进行实验,并完成如下要求:
    在这里插入图片描述

    (1)要求设置R1为活跃路由器,R2作为备份路由器,此时内网PC可以与外网通信,分别查看R1和R2的热备份状态。
    (2)down掉R1的内网接口,此时内网PC仍旧可以与外网通信,分别查看R2的热备份状态。
    (3)将R1的内网接口up,此时内网PC仍旧可以与外网通信,分别查看R1的热备份状态。
    (4)down掉R1的外网接口,此时内网PC仍旧可以与外网通信,查看R1自降了多少优先级。

    4.2 实验分析

    (1)故障情形分类:本实验为模拟路由器故障后网络的工作状态,为此先分析故障可能发生的情况,分别是R1上f0/0接口断开、R1上F0/1接口断开、R2上f0/0接口断开、R2上F0/1接口断开共4种基本情况。
    (2)数据流向方案分类:数据从内网流到外网,共有R1与R2两条路可以选择,同理地从外网到内网也有两条路可以选择。当R1上任意一个端口发生故障时,从内到外,应自动切换成R2路径(HSRP协议解决),从外到内,也应切换成R2路径(后续再学)。
    (3)为完成本实验,本实验中外网进入内网的流向指向R2,是为了保证在R1发生故障时,内外网仍可以通信。

    4.3 实验步骤

    (1)首先规划网段,其次为所有PC接口配IP,内网PC网关应指向虚拟网关
    在这里插入图片描述
    (2)为所有路由接口配置IP。

    # 为R1配置IP
    en
    conf t
    ho R1
    int f0/0
    no shut
    ip add 10.1.1.252 255.255.255.0
    no shut
    exit
    int f0/1
    ip add 20.1.1.1 255.255.255.0
    no shut
    exit
    do show ip int b
    do wr
    
    # 为R2配置IP
    en
    conf t
    ho R2
    int f0/0
    ip add 10.1.1.253 255.255.255.0
    no shut
    exit
    int f0/1
    ip add 30.1.1.1 255.255.255.0
    no shut
    exit
    do show ip int b
    do wr
    
    # 为R3配置IP
    en
    conf t
    ho R3
    int f0/0
    ip add 30.1.1.2 255.255.255.0
    no shut
    exit
    int f0/1
    ip add 20.1.1.2 255.255.255.0
    no shut
    exit
    int f1/0
    ip add 40.1.1.254 255.255.255.0
    no shut
    exit
    do show ip int b
    do wr
    

    (3)为所有路由接口配置路由表。

    # 为R1配置路由表
    conf t
    ip route 0.0.0.0 0.0.0.0 20.1.1.2
    # 为R2配置路由表
    conf t
    ip route 0.0.0.0 0.0.0.0 30.1.1.2
    # 为R3配置路由表,本应该该同时指向R1和R2,以后会有其他方式也让R3自动判断方向。
    conf t
    ip route 10.1.1.0 255.255.255.0 30.1.1.1
    

    (4)对路由器接口设置HSRP组号、设置虚拟IP地址、优先级、占先权以及接口跟踪。

    # 为路由器R1配置
    conf t
    int f0/0					#注意由于是对网关进行备份,因此需要对网关所在接口进行配置
    standby 1 ip 10.1.1.254		#将该接口加入热备份组(组号1)并同时指定虚拟IP
    standby 1 priority 195		#设置优先级为195
    standby 1 preempt			#设置占先权,活跃路由器可不设置
    standby 1 track f0/1		#设置跟踪f0/1的状态,当该接口down掉时,本接口自动降低优先级(真实机可以设置降多少优先级)
    exit
    do show standby brief      #查看热备份简要信息
    do wr
    
    # 为路由器R2配置
    conf t
    int f0/0
    standby 1 ip 10.1.1.254
    standby 1 priority 190		#设置优先级200低于优先路由器R1。
    standby 1 preempt			#设置占先权,备份路由器应设置。
    standby 1 track f0/1		#设置跟踪f0/1的状态,宜设置。
    exit
    do show standby brief      #查看热备份简要信息
    do wr
    

    tips:
    无论网络多么复杂,对于路由器都是先给接口配IP,再配路由表,之后再考虑复杂的部分。

    4.4 实验结果

    (1)正常状态下,10.1.1.1能ping通40.1.1.1。分别查看R1和R2的热备份状态。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    (2)down掉R1的f0/0端口,10.1.1.1能ping通40.1.1.1。并且检查到热备份状态中R2成为活跃路由器。
    在这里插入图片描述
    在这里插入图片描述
    (3)然后将R1的f0/0端口up,10.1.1.1能ping通40.1.1.1。并且检查R1的热备份状态。
    在这里插入图片描述
    (4)down掉R1的f0/1端口,10.1.1.1继续能ping通40.1.1.1。并且检查R1的自降优先级降了多少。
    在这里插入图片描述
    在这里插入图片描述

    4.5 实验可能存在的故障分析

    在这里插入图片描述

    (1)故障:若PC1和PC2能ping通上图中的1,却不能ping通2。
    (2) 原因分析:从路由方面去考虑。R2的路由配置完整,PC1或PC2ping上图中的1时,数据可以传输过去,也可以从R2传输回来,因此可以ping通。而若R3的路由出现问题,PC1或PC2ping上图中的2时,数据可以传输过去,但是R2回包时,若没有10.1.1.0/24对应的路由条目,那么数据无法传输回来,因此出现上述问题。注意,分析故障时,一定要从去和回考虑

    5 归纳

    (1)了解HSRP基本概念。
    (2)理解HSRP的作用及工作原理。
    (3)注意HSRP的配置是针对路由器上的内网网关做备份,相关操作需要进入网关接口里设置。
    (4)掌握配置热备份的思路步骤,并熟悉其相关命令。

    参考文章

    [1]《HSRP百科
    [2] 《HSRP协议原理及配置方法——基于PacketTracer仿真实验》
    [3] 视频传送门

    展开全文
  • hsrp思科热备路由协议

    2014-05-21 17:20:31
    所谓的热备份路由协议HSRP)主要是向我们提供了这样一种机制,它的设计目的主要在于支持IP传输失 败情况下的不中断服务。具体说,就是本协议用于在源主机无法动态地学习到首跳路由器IP地址的情况下 防止首跳路由的...
  • HSRP热备份路由协议

    2011-06-18 16:37:27
    HSRP:热备份路由协议,它确保了当前网络边缘设备或接入链路出现故障时,用户通讯能迅 速并透明的恢复。并以此为 IP网络提供冗余性。通过应用 HSRP,可使网络的正常运行时间 接近 100%,从而满足用户对网络可靠性的...
  • HSRP:热备份路由器协议HSRP:Hot Standby Router Protocol),是cisco平台一种特有的技术,是cisco的私有协议。 该协议中含有多台路由器,对应一个HSRP组。该组中只有一个路由器承担转发用户流量的职责,这就是...

    一、概述

    HSRP:热备份路由器协议(HSRP:Hot Standby Router Protocol),是cisco平台一种特有的技术,是cisco的私有协议。
    该协议中含有多台路由器,对应一个HSRP组。该组中只有一个路由器承担转发用户流量的职责,这就是活动路由器。当活动路由器失效后,备份路由器将承担该职责,成为新的活动路由器。这就是热备份的原理。百度百科

    二、原理

    在这里插入图片描述
    备份的是网关。

    三、实验

    1)网段规划

    在这里插入图片描述

    2)配置IP开通端口

    两台PC IP配置
    在这里插入图片描述
    在这里插入图片描述
    两个网关配置IP+开启端口
    R1-GW

    Router>en
    Router#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#ho R1-GW
    R1-GW(config)#
    R1-GW(config)#
    R1-GW(config)#int f0/0
    R1-GW(config-if)#ip add 192.168.1.252 255.255.255.0
    R1-GW(config-if)#no shut
    
    R1-GW(config-if)#
    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    
    R1-GW(config-if)#exit
    R1-GW(config)#int f0/1
    R1-GW(config-if)#ip add 10.1.1.1 255.255.255.0
    R1-GW(config-if)#no shut
    R1-GW(config-if)#exit
    R1-GW(config)#do show ip int b
    Interface              IP-Address      OK? Method Status                Protocol 
    FastEthernet0/0        192.168.1.252   YES manual up                    up 
    FastEthernet0/1        10.1.1.1        YES manual up                    up 
    Vlan1                  unassigned      YES unset  administratively down down
    

    R2-GW

    Router>en
    Router#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#ho R2-GW
    R2-GW(config)#int f0/0
    R2-GW(config-if)#ip add 192.168.1.253 255.255.255.0
    R2-GW(config-if)#no shut
    
    R2-GW(config-if)#
    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    
    R2-GW(config-if)#
    R2-GW(config-if)#exit
    R2-GW(config)#int f0/1
    R2-GW(config-if)#ip add 20.1.1.1 255.255.255.0
    R2-GW(config-if)#no shut
    
    R2-GW(config-if)#
    %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
    
    R2-GW(config-if)#exit
    R2-GW(config)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
    
    R2-GW(config)#
    R2-GW(config)#do show ip int b
    Interface              IP-Address      OK? Method Status                Protocol 
    FastEthernet0/0        192.168.1.253   YES manual up                    up 
    FastEthernet0/1        20.1.1.1        YES manual up                    up 
    Vlan1                  unassigned      YES unset  administratively down down
    

    R-waiwang

    Router>
    Router>en 
    Router#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#ho R-waiwang
    R-waiwang(config)#int f0/0
    R-waiwang(config-if)#ip add 10.1.1.2 255.255.255.0
    R-waiwang(config-if)#no shut
    
    R-waiwang(config-if)#
    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    
    R-waiwang(config-if)#exit
    R-waiwang(config)#int f0/1
    R-waiwang(config-if)#ip add 20.1.1.2 255.255.255.0
    R-waiwang(config-if)#no shut
    
    R-waiwang(config-if)#
    %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
    
    R-waiwang(config-if)#exit
    R-waiwang(config)#int f0/3
    %Invalid interface type and number
    R-waiwang(config)#int f1/0
    R-waiwang(config-if)#ip add 30.1.1.254 255.255.255.0
    R-waiwang(config-if)#no shut
    
    R-waiwang(config-if)#
    %LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up
    
    R-waiwang(config-if)#exit
    R-waiwang(config)#do show ip int b
    Interface              IP-Address      OK? Method Status                Protocol 
    FastEthernet0/0        10.1.1.2        YES manual up                    up 
    FastEthernet0/1        20.1.1.2        YES manual up                    up 
    FastEthernet1/0        30.1.1.254      YES manual up                    up 
    FastEthernet1/1        unassigned      YES unset  administratively down down 
    Vlan1                  unassigned      YES unset  administratively down down
    

    外网PC
    在这里插入图片描述
    在这里插入图片描述

    3)配置路由表

    R1-GW
    R1-GW(config)#ip route 0.0.0.0 0.0.0.0 10.1.1.2
    R2-GW
    R1-GW(config)#ip route 0.0.0.0 0.0.0.0 20.1.1.2

    R-waiwang
    在这里插入图片描述
    为了体现实验,我们如果将R1接口down掉,PC可以使用备份路由上网,所以我们要将外网路由的下一跳IP指向R2的F0/1的IP

    R-waiwang(config)#ip route 0.0.0.0 0.0.0.0 20.1.1.1

    R-waiwang(config)#do show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is 20.1.1.1 to network 0.0.0.0
    
         10.0.0.0/24 is subnetted, 1 subnets
    C       10.1.1.0 is directly connected, FastEthernet0/0
         20.0.0.0/24 is subnetted, 1 subnets
    C       20.1.1.0 is directly connected, FastEthernet0/1
         30.0.0.0/24 is subnetted, 1 subnets
    C       30.1.1.0 is directly connected, FastEthernet1/0
    S*   0.0.0.0/0 [1/0] via 20.1.1.1
    

    4)热备份

    R1-活跃路由器

    R1-GW(config)#int f0/0
    R1-GW(config-if)#standby 1 ip 192.168.1.254  创建热备份组号为1,虚拟网关IP为192.168.1.254
    %HSRP-6-STATECHANGE: FastEthernet0/0 Grp 1 state Speak -> Standby
    
    %HSRP-6-STATECHANGE: FastEthernet0/0 Grp 1 state Standby -> Active
    R1-GW(config-if)#standby 1 priority 200      设置优先级为200
    R1-GW(config-if)#standby 1 preempt           设置占先权
    R1-GW(config-if)#standby 1 track f0/1        跟踪f0/1接口    
    

    查看热备份配置信息

    R1-GW#show standby brief 
                         P indicates configured to preempt.
                         |
    Interface   Grp  Pri P State    Active          Standby         Virtual IP
    Fa0/0       1    200   Active   local           192.168.1.253   192.168.1.254  
    

    R2-备份路由器

    R2-GW(config)#int f0/0
    R2-GW(config-if)#standby 1 ip 192.168.1.254
    R2-GW(config-if)#standby 1 priority 
    %HSRP-6-STATECHANGE: FastEthernet0/0 Grp 1 state Speak -> Standby
    
    R2-GW(config-if)#standby 1 priority 195
    R2-GW(config-if)#standby 1 preempt
    

    查看热备份配置信息

    R2-GW#show standby brief 
                         P indicates configured to preempt.
                         |
    Interface   Grp  Pri P State    Active          Standby         Virtual IP
    Fa0/0       1    195 P Standby  192.168.1.252   local           192.168.1.254  
    R2-GW#
    

    5)测试

    我们进入活跃路由器将网关接口f0/0,down掉,备份路由器每隔一段时间会与活跃路由器进行通信(检测端口是否正常),当检测到活跃路由器异常时会自动升级为活跃路由器,如果活跃路由器的故障修复重新启动,那么会重新接管活跃路由器的身份,备份路由器会自动降级。

    也就是说活跃路由器故障那么会由备份路由器接管,故障修复后备份路由器会回到原来的位置。
    备份路由器的身份转变取决于活跃路由器是否出现异常。

    C:\>ping -t 30.1.1.1
    
    Pinging 30.1.1.1 with 32 bytes of data:
    
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Reply from 30.1.1.1: bytes=32 time=15ms TTL=126
    Reply from 30.1.1.1: bytes=32 time<1ms TTL=126
    Reply from 30.1.1.1: bytes=32 time=12ms TTL=126
    Reply from 30.1.1.1: bytes=32 time<1ms TTL=126
    Reply from 30.1.1.1: bytes=32 time<1ms TTL=126
    Reply from 30.1.1.1: bytes=32 time<1ms TTL=126
    Request timed out.
    Request timed out.
    Reply from 30.1.1.1: bytes=32 time<1ms TTL=126
    Reply from 30.1.1.1: bytes=32 time=1ms TTL=126
    Reply from 30.1.1.1: bytes=32 time<1ms TTL=126
    Reply from 30.1.1.1: bytes=32 time=1ms TTL=126
    Reply from 30.1.1.1: bytes=32 time<1ms TTL=126
    Reply from 30.1.1.1: bytes=32 time=1ms TTL=126
    Reply from 30.1.1.1: bytes=32 time=1ms TTL=126
    

    将f0/1接口down掉
    在这里插入图片描述
    查看活跃路由器的热备份信息

    R1-GW#sh standby brief 
                         P indicates configured to preempt.
                         |
    Interface   Grp  Pri P State    Active          Standby         Virtual IP
    Fa0/0       1    190   Standby  192.168.1.253   local           192.168.1.254  
    R1-GW#sh standby
    FastEthernet0/0 - Group 1
      State is Standby
        16 state changes, last state change 03:33:02
      Virtual IP address is 192.168.1.254
      Active virtual MAC address is 0000.0C07.AC01
        Local virtual MAC address is 0000.0C07.AC01 (v1 default)
      Hello time 3 sec, hold time 10 sec
        Next hello sent in 0.035 secs
      Preemption disabled
      Active router is 192.168.1.253, priority 195 (expires in 9 sec)
        MAC address is 0000.0C07.AC01
      Standby router is local
      Priority 190 (configured 200)
        Track interface FastEthernet0/1 state Down decrement 10
      Group name is hsrp-Fa0/0-1 (default)
    R1-GW#
    

    查看备份路由器的热备份信息

    R2-GW#sh standby brief 
                         P indicates configured to preempt.
                         |
    Interface   Grp  Pri P State    Active          Standby         Virtual IP
    Fa0/0       1    195 P Active   local           192.168.1.252   192.168.1.254  
    R2-GW#
    
    展开全文
  • hsrp热备份路由协议ppt

    2012-06-12 17:55:42
    所谓的热备份路由协议HSRP)主要是向我们提供了这样一种机制,它的设计目的主要在于支持IP传输失败情况下的不中断服务。具体说,就是本协议用于在源主机无法动态地学习到首跳路由器IP地址的情况下防止首跳路由的...
  • VTP&HSRP路由

    2020-11-25 11:26:11
    VTP树生成协议&热备份路由协议
  • HSRP简介HSRP(Hot Standby Router Protocol 热备份路由器协议)是Cisco的专有协议HSRP把多台路由器组成一个“热备份组”,形成一个虚拟路由器。这个组内只有一个路由器是Active(活动)的,并由它来转发数据包,...
  • HSRP(热备份路由协议)是Cisco的一种私有技术,它能够确保当网络边缘设备或接入链路出现故障时,用户通信能迅速并透明的恢复,以此为IP网络提供冗余性。 HSRP为IP网路提供了容错和增强的路由选择功能。通过使用同一...
  • Cisco配置HSRP实现路由热备份组

    千次阅读 2020-12-12 19:31:16
    HSRP热备份路由协议思科私有的用于建立网关冗余自动切换的冗余协议,关于备份我在上一篇博客中有过提及,虽然PVST也能实现一定的冗余效果,但必须进行手动的网关切换,这时如果局域网内主机群过于庞大那么将会非常...
  • 解决办法:热备份路由协议 配置步骤: 1、 设置虚拟接口 Standby 编号 ip IP地址 2、 设置端口优先级(实现自动切换) 优先级大的为活动网关(active),优先级小的备份网关() standby 编号 priority 优先级数...
  • 目录一、HSRP的原理1.1HSRP概述作用1.2HSRP组成员1.3HSRP原理HSRP的配置及应用HSRP的配置命令如下1、配置HSRP的成员2、配置HSRP优先级3、配置HSRP的占先权4、配置HSRP的端口跟踪5、配置Hello消息的计时器6、检查HSRP...
  • 目录 一、基础知识 二、实验过程 1)配IP 2)配置路由 3)热备份 ...上图中下面的一台交换机下的俩PC是公司内网,上面那俩...于是有了HSRP(Hot Standby Routing Protocol)热备份路由协议(用来备份网关的),这...
  • 详解思科私有HSRP协议及配置

    千次阅读 2018-08-28 14:55:07
     HSRP(Hot StandbyRouter Protocol 热备份路由器协议)是Cisco的专有协议HSRP把多台路由器组成一个“热备份组”,形成一个虚拟路由器。这个组内只有一个路由器是Active(活动)的,并由它来转发数据包,如果活动...
  • 步骤1:路由ip配置 路由r1配置 Router>en Router#conf t Router(config)#ho r1 r1(config)#int f0/0 r1(config-if)#ip add 10.1.1.252 255.255.255.0 r1(config-if)#no sh r1(config-if)#exit r1(config)#int...
  • Cisco配置路由冗余VRRP/HSRP

    千次阅读 2019-09-11 21:26:24
    前言: 最近整理一些以前的学习笔记(有部分缺失,会有些乱,日后再补)。 过去都是存储在本地,此次传...虚拟路由冗余协议(Virtual Router Redundancy Protocol),IETF公共标准 与HSRP使用基本相同,只有将HSRP的stan...
  • STP 生成树协议 当三个交换机相连,会有交换网络环路形成 在每个交换机上- 选 根桥 - 选跟口 - Spanning-tree protocol 生成树 协议 逻辑上断开环路 protocol 标准 资源消耗 收敛速度 树的数量 STP 802.1...
  • Cisco——HSRP实验案例

    千次阅读 2021-02-19 09:16:49
    HSRP 是网关备份协议中的一种,在实际教学当中,常常重点演示的是HSRP 部分的配置,而对于上联链路出故障后切换,演示不是很详细,在这里我做了个小实验,用于演示下HSRP 切换的详细过程。 实验: 01 ...
  • cisco配置hsrp配置

    千次阅读 2020-07-02 15:08:04
    via 192.168.2.2, 00:00:14, FastEthernet0/1 Switch# 可以看到192.168.1.0和192.168.2.0是直连路由,192.168.3.0和192.168.4.0是通过rip协议获取到的路由。 SW2: Switch#show ip route Codes: C - connected, S - ...
  • HSRP是 Hot Standby Routing Protocol(热备份路由协议)的缩写,它的作用是当核心路由器不能正常工作时, 备用路由器能够实现自动平滑的替换,以保证网络正常使用。该协议中含有多台路由器,对应一个HSRP组。 该...
  • 首先用思科HSRP热备份路由协议配置。 首先在为这个拓扑配置命令前先分析一下这个拓扑图,了解它的实验目的及要求与想要达成的效果。 然后在看需要为这拓扑配置的命令。 分析拓扑图:(不论配置什么协议实现...
  • 现在我们配置了多台路由器,一台路由出现故障,则切换至另外一个路由器,切换的过程,如果网工手动配置的话,那还不累死个人,公司一百个人,难道要一个一个配置?肯定不是,这时候,我们发明出了一个新的协议来解决...
  • HSRP:热备份路由器协议HSRP:Hot Standby Router Protocol),是cisco平台一种特有的技术,是cisco的私有协议。该协议中含有多台路由器,对应一个HSRP组。该组中只有一个路由器承担转发用户流量的职责,这就是...
  • 热备份路由协议(HSRP)是思科推出的用于建立容错默认网关的专有冗余协议,由RFC 2281进行描述。虚拟路由冗余协议(VRRP)是基于标准的HSRP替代协议,由IETF标准RFC 3768进行描述。这两种技术在概念上相似,但互不兼容。
  • end Router# show ip route 配置HSRP路由协议 Router> enable //进入特权模式 Router# configure terminal //进入全局配置模式 Router(config)# interface fastEthernet 0/0 Router(config-if)#standby 1 ip 192.168...
  • HSRP的作用是指能够将...一 简单配置HSRP(热备份路由选择协议)步骤 1,进入接口VLAN1,配置IP地址和子网掩码 2,配置虚拟IP 地址作为网关:standby ip 192.168.1.254 3,配置优先级:standbky priority 105 (优先...
  • cisco配置hsrp配置实例

    千次阅读 2019-12-25 17:03:52
    使用cisco packet tracer模拟器实现网络拓扑配置,交换机使用3560,路由器使用2911。 显示所有端口 Options-->Preferences-->选中Always Show Port Labels: 2、网络拓扑如下 3、具体配置 PC1目前只...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,709
精华内容 1,083
关键字:

思科hsrp路由协议