精华内容
下载资源
问答
  • Cisco show 命令
    千次阅读
    2010-10-17 19:38:00

    Show access-lists 显示当前所有ACL的内容
    Show buffers 显示缓存器统计信息
    Show cdp entry 显示CDP表中所列相邻设备的信息
    Show cdp interface 显示打开的CDP接口信息
    Show cdp neighbors 显示CDP查找进程的结果
    Show dialer 显示为DDR(数字数据接受器)设置的串行接口的一般诊断信息
    Show flash 显示闪存的布局和内容信息
    Show frame-relay lmi 显示关于本地管理接口(LMI)的统计信息
    Show frame-relay map 显示关于连接的当前映射入口和信息
    Show frame-relay pvc 显示关于帧中继接口的永久虚电路(pvc)的统计信息
    Show hosts 显示主机名和地址的缓存列表
    Show interfaces 显示设置在路由器和访问服务器上所有接口的统计信息
    Show interfaces 显示路由器上配置的所有接口的状态
    Show interfaces serial 显示关于一个串口的信息
    Show ip interface 列出一个接口的IP信息和状态的小结
    Show ip interface 列出接口的状态和全局参数
    Show ip protocols 显示活动路由协议进程的参数和当前状态
    Show ip route 显示路由选择表的当前状态
    Show ip router 显示IP路由表信息
    Show ipx interface 显示Cisco IOS软件设置的IPX接口的状态以及每个接口中的参数
    Show ipx route 显示IPX路由选择表的内容
    Show ipx servers 显示IPX服务器列表
    Show ipx traffic 显示数据包的数量和类型
    Show isdn active 显示当前呼叫的信息,包括被叫号码、建立连接前所花费的时间、在呼叫期间使用的自动化操作控制(AOC)收费单元以及是否在呼叫期间和呼叫结束时提供AOC信息
    Show isdn ststus 显示所有isdn接口的状态、或者一个特定的数字信号链路(DSL)的状态或者一个特定isdn接口的状态
    Show memory 显示路由器内存的大小,包括空闲内存的大小
    Show processes 显示路由器的进程
    Show protocols 显示设置的协议
    Show protocols 显示配置的协议。这条命令显示任何配置了的第3层协议的状态
    Show running-config 显示RAM中的当前配置信息
    Show spantree 显示关于虚拟局域网(VLAN)的生成树信息
    Show stacks 监控和中断程序对堆栈的使用,并显示系统上一次重启的原因
    Show startup-config 显示NVRAM中的启动配置文件
    Show ststus 显示ISDN线路和两个B信道的当前状态
    Show version 显示系统硬件的配置,软件的版本,配置文件的名称和来源及引导映像
    Shutdown 关闭一个接口

    更多相关内容
  • show命令管道符深入解析,常用的in b sess 等等
  • 这篇文章为读者介绍了一些cisco路由器show命令的例子,在网络中,网络管理员应该随时了解路由器的各种状态,以便及时的排除故障。  show命令可以同时在用户模式和特权模式下运行,“show ?”命令来提供提供一个可...
  • show version命令可用于检验和检修启动过程中使用的一些基本硬件和软件组件。验证设备的内存、接口和许可 Router#show version Cisco IOS Software [Everest], ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), ...

    show version

    show version命令可用于检验和检修启动过程中使用的一些基本硬件和软件组件。验证设备的内存、接口和许可

    Router#show version 
    Cisco IOS Software [Everest], ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 16.6.4,RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2018 by Cisco Systems, Inc.
    Compiled Sun 08-Jul-18 04:33 by mcpre
    
    Cisco IOS-XE software, Copyright (c) 2005-2018 by cisco Systems, Inc.
    All rights reserved.  Certain components of Cisco IOS-XE software are
    licensed under the GNU General Public License ("GPL") Version 2.0.  The
    software code licensed under GPL Version 2.0 is free software that comes
    with ABSOLUTELY NO WARRANTY.  You can redistribute and/or modify such
    GPL code under the terms of GPL Version 2.0.  For more details, see the
    documentation or "License Notice" file accompanying the IOS-XE software,
    or the applicable URL provided on the flyer accompanying the IOS-XE
    software.
    
    ROM: IOS-XE ROMMON
    
    Router uptime is 14 minutes, 49 seconds
    Uptime for this control processor is 14 minutes, 49 seconds
    System returned to ROM by power-on
    System image file is "bootflash:isr4300-universalk9.16.06.04.SPA.bin"
    Last reload reason: PowerOn
    
    
    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.
    
    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
    
    If you require further assistance please contact us by sending email to
    export@cisco.com.
    
    
    Suite License Information for Module:'esg'
    
    --------------------------------------------------------------------------------
    Suite                 Suite Current         Type           Suite Next reboot
    
    --------------------------------------------------------------------------------
    FoundationSuiteK9     None                  None           None
    
    securityk9
    appxk9
    	
    AdvUCSuiteK9          None                  None           None
    
    uck9
    cme - srst
    cube
    
    Technology Package License Information:
    
    ------------------------------------------------------------------------
    Technology    Technology-package                  Technology-package
                  Current              Type           Next reboot
    ------------------------------------------------------------------------
    appxk9           None             None             None
    uck9             None             None             None
    securityk9       securityk9       Permanent        securityk9
    ipbase           ipbasek9         Permanent        ipbasek9
    
    cisco ISR4331/K9 (1RU) processor with 1795999K/6147K bytes of memory.
    Processor board ID FLM232010G0
    3 Gigabit Ethernet interfaces
    32768K bytes of non-volatile configuration memory.
    4194304K bytes of physical memory.
    3207167K bytes of flash memory at bootflash:.
    
    0K bytes of WebUI ODM Files at webui:.
    
    Configuration register is 0x2102
    
    Router# 
    

    版本内容详解

    1. ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M):表示这台路由器正在运行UNIVERSALK9镜像,这个镜像能提供所有基本的思科IOS软件功能,包括支持强加密。M代表扩展包(extended maintenance package)

    2. Version 16.6.4,RELEASE SOFTWARE (fc3):表示主版本是16,次版本是6,以及重建版本是4

    3. Router uptime is 14 minutes, 49 seconds:表示机器已经运行了14分钟49秒
      System image file is "bootflash:isr4300-universalk9.16.06.04.SPA.bin"

      • bootflash表示它位于引导闪存中。

      • isr4300-universalk9.16.06.04.SPA.bin表示IOS镜像文件的名称。

      • isr4300是指这个镜像的硬件平台。

      • SPA表示这个镜像文件已经进行了数字签名。

      • bin是指一种文件格式后缀,在这里是一个二进制文件。

    4. Last reload reason:这个参数可以用来判断当前路由器最后一次加载原因。

      (这个信息可以帮助工程师们进行排错,特别在路由器崩溃的时候)

      • PowerOn表示正常开机启动

      • Reload Command表示最后一次加载是因为reload命令来重启路由器

    5. 下面的信息是关于设备的加密功能。

      This product contains cryptographic features and is subject to United States and local country laws governing import, export, transfer and use. Delivery of Cisco cryptographic products does not imply third-party authority to import, export, distribute or use encryption.
      Importers, exporters, distributors and users are responsible for compliance with U.S. and local country laws. By using this product you agree to comply with applicable laws and regulations. If you are unable to comply with U.S. and local laws, return this product immediately.
      
      A summary of U.S. laws governing Cisco cryptographic products may be found at:http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
      
      If you require further assistance please contact us by sending email toexport@cisco.com.
      
    6. 下面是关于设备许可(License)的信息。许可信息分为两种:

      • 套件许可证 Suite License

      • 技术包许可证 Technology Package

      Technology Package License Information:
      
      ------------------------------------------------------------------------
      Technology    Technology-package                  Technology-package
                    Current              Type           Next reboot
      ------------------------------------------------------------------------
      appxk9           None             None             None
      uck9             None             None             None
      securityk9       securityk9       Permanent        securityk9
      ipbase           ipbasek9         Permanent        ipbasek9
      

      这里显示该设备拥有ipbasek9软件包和securityk9软件包的永久许可。这是默认的镜像功能集,并且是订购路由器时在功能集中指定的软件包。

      Technology:技术包的名称

      Technology-package Current :表示当前技术包的名称

      Type:表示技术包的类型,Permanent 表示永久使用,None表示没有使用权。

      Technology-package Next reboot:表示下次设备重启后,技术包的使用权限。显示技术包名称表示下次重启还可以使用,None表示下次重启没有使用权限。

      如果工程师想要升级IOS或者安装新功能,需要三个流程。

      • 第一步:购买软件包或功能,并获取产品激活密钥或PAK。

      • 第二步:使用PAK来获取许可证以及设备的UDI或唯一设备标识符。

      • 第三步:安装许可证。

      在购买时可以购买一套许可证,其中包含很多功能。如果这么做,这些信息将会出现在套件许可证下面。

      cisco ISR4331/K9 (1RU) processor with 1795999K/6147K bytes of memory.
      Processor board ID FLM232010G0
      3 Gigabit Ethernet interfaces
      32768K bytes of non-volatile configuration memory.
      4194304K bytes of physical memory.
      3207167K bytes of flash memory at bootflash:.
      
      0K bytes of WebUI ODM Files at webui:.
      
      Configuration register is 0x2102
      
    7. 1795999K/6147K:表示大约2GB的DRAM被划分为主内存(左侧)和共享内存(右侧)。

      • 主内存会保留给CPU执行IOS命令,并保存运行配置和路由表等。

      • 共享内存用于在路由的网络接口上传输或接收数据时对数据进行缓冲。

      当路由器关闭电源时,DRAM的内容会丢失。

    8. 3 Gigabit Ethernet interfaces:这里我们可以看到设备的物理接口数量和类型。这台路由器有三个千兆以太网接口。

    9. 32768K bytes of non-volatile configuration memory.:这里显示的是设备的NVRAM(非易失性RAM),可以看到有32Mb大小。这表示可电擦除和可重新编程的,用来存储启动配置文件,保存配置文件以及配置寄存器设置。当设备电源关闭时,NVRAM的内容会保留下来。

    10. 4194304K bytes of physical memory:这里显示的是设备的物理内存。这是DRAM的总容量,共享内存的DRAM总量。(再次强调,断电时所有内容都会丢失)

    11. 3207167K bytes of flash memory at bootflash::这里显示的是设备的闪存,大约有3GB,用来存储思科IOS软件镜像文件和其他系统文件。

    12. Configuration register is 0x2102:显示配置寄存器的设置,用十六进制表示,这是出厂默认设置。这个值表示路由器会从闪存加载IOS镜像,然后在加载存储在NVRAM中的配置文件。

    备注

    当工程师忘记了设备的密码,无法访问路由器的时候,可以更改默认的引导流程,通过更改配置寄存器设置,这么做配置文件就不会在启动时从NVRAM加载了,这样工程师不需要密码就可以访问特权EXEC模式了。

    总结

    show version命令为工程师提供了路由器的基本信息,包括IOS版本,路由器启动时长以及路由器内存情况等,这些信息在排错或升级IOS时可以发挥重要的作用。

    展开全文
  • Line的配置模式及cisco常用show命令

    千次阅读 2017-11-22 20:18:21
    思科交换机 Line配置模式 在全局配置模式下,执行line vty或line console命令,将进入Line配置模式。该模式主要用于对虚拟终端(vty)和控制台端口进行配置,其配置主要是设置虚拟终端和控制台的用户级登录...

    思科交换机  Line配置模式

    在全局配置模式下,执行line vtyline console命令,将进入Line配置模式。该模式主要用于对虚拟终端(vty)和控制台端口进行配置,其配置主要是设置虚拟终端和控制台的用户级登录密码。

    Line配置模式的命令行提示符为:student1(config-line)#

    交换机有一个控制端口(console),其编号为0,通常利用该端口进行本地登录,以实现对交换机的配置和管理。为安全起见,应为该端口的登录设置密码,设置方法为:

    student1#config terminal

    student1(config)#line console 0

    student1(config-line)#?

    exit         exit from line configuration mode

    login        Enable password checking

    password     Set a password

    从帮助信息可知,设置控制台登录密码的命令是password,若要启用密码检查,即让所设置的密码生效,则还应执行login命令。退出line配置模式,执行exit命令。

    下面设置控制台登录密码为654321,并启用该密码,则配置命令为:

    student1(config-line)#password  654321

    student1(config-line)#login

    student1(config-line)#end

    student1#write

    设置该密码后,以后利用控制台端口登录访问交换机时,就会首先询问并要求输入该登录密码,密码校验成功后,才能进入到交换机的用户EXEC模式。

    交换机支持多个虚拟终端,一般为16个(015)。设置了密码的虚拟终端,就允许登录,没有设置密码的,则不能登录。如果对04条虚拟终端线路设置了登录密码,则交换机就允许同时有5telnet登录连接,其配置命令为:

    student1(config)#line vty 0 4

    student1(config-line)#password  123456

    student1(config-line)#login

    student1(config-line)#end

    student1#write

    若要设置不允许telnet登录,则取消对终端密码的设置即可,为此可执行no passwordno login来实现。

    Cisco IOS命令中,若要实现某条命令的相反功能,只需在该条命令前面加no,并执行前缀有no的命令即可。

    为了防止空闲的连接长时间的存在,通常还应给通过console口的登录连接和通过vty线路的telnet登录连接,设置空闲超时的时间,默认空闲超时的时间是10分钟。

    设置空闲超时时间的配置命令为:exec-timeout 分钟数秒数

    例如,要将vty 0-4线路和Console的空闲超时时间设置为3分钟0秒,则配置命令为:

    student1#config t

    student1(config)#line vty 0 4

    student1(config-line)#exec-timeout 3 0

    student1(config-line)#line console 0

    student1(config-line)#exec-timeout 3 0

    student1(config-line)#end

    student1#

     

     

     

     

    交换机基本状态:

    switch: ;ROM状态, 路由器是rommon>

    hostname> ;用户模式

    hostname# ;特权模式

    hostname(config)# ;全局配置模式

    hostname(config-if)# ;接口状态

     

    交换机口令设置:

    switch>enable ;进入特权模式

    switch#config terminal ;进入全局配置模式

    switch(config)#hostname  ;设置交换机的主机名

    switch(config)#enable secret xxx ;设置特权加密口令

    switch(config)#enable password xxa ;设置特权非密口令

    switch(config)#line console 0 ;进入控制台口

    switch(config-line)#line vty 0 4 ;进入虚拟终端

    switch(config-line)#login ;允许登录

    switch(config-line)#password xx ;设置登录口令xx

    switch#exit ;返回命令

    交换机VLAN设置:

    switch#vlan database ;进入VLAN设置

    switch(vlan)#vlan 2 ;建VLAN 2

    switch(vlan)#no vlan 2 ;删vlan 2

    switch(config)#int f0/1 ;进入端口1

    switch(config-if)#switchport access vlan 2 ;当前端口加入vlan 2

    switch(config-if)#switchport mode trunk ;设置为干线

    switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlan

    switch(config-if)#switchport trunk encap dot1q ;设置vlan 中继

    switch(config)#vtp domain  ;设置发vtp域名

    switch(config)#vtp password  ;设置发vtp密码

    switch(config)#vtp mode server ;设置发vtp模式

    switch(config)#vtp mode client ;设置发vtp模式

    交换机设置IP地址

    switch(config)#interface vlan 1 ;进入vlan 1

    switch(config-if)#ip address   ;设置IP地址

    switch(config)#ip default-gateway  ;设置默认网关

    switch#dir flash: ;查看闪存

    交换机显示命令:

    switch#write ;保存配置信息

    switch#show vtp ;查看vtp配置信息

    switch#show run ;查看当前配置信息

    switch#show vlan ;查看vlan配置信息

    switch#show interface ;查看端口信息

    switch#show int f0/0 ;查看指定端口信息

    2. 路由器支持的命令:

    路由器显示命令:

    router#show run ;显示配置信息

    router#show interface ;显示接口信息

    router#show ip route ;显示路由信息

    router#show cdp nei ;显示邻居信息

    router#reload     ;重新起动

    路由器口令设置:

    router>enable ;进入特权模式

    router#config terminal ;进入全局配置模式

    router(config)#hostname  ;设置交换机的主机名

    router(config)#enable secret xxx ;设置特权加密口令

    router(config)#enable password xxb ;设置特权非密口令

    router(config)#line console 0 ;进入控制台口

    router(config-line)#line vty 0 4 ;进入虚拟终端

    router(config-line)#login ;要求口令验证

    router(config-line)#password xx ;设置登录口令xx

    router(config)#(Ctrl+z) ; 返回特权模式

    router#exit ;返回命令

    路由器配置:

    router(config)#int s0/0 ;进入Serail接口

    router(config-if)#no shutdown ;激活当前接口

    router(config-if)#clock rate 64000 ;设置同步时钟

    router(config-if)#ip address   ;设置IP地址

    router(config-if)#ip address  second ;设置第二个IP

    router(config-if)#int f0/0.1 ;进入子接口

    router(config-subif.1)#ip address  ;设置子接口IP

    router(config-subif.1)#encapsulation dot1q  ;绑定vlan中继协议

    router(config)#config-register 0x2142 ;跳过配置文件

    router(config)#config-register 0x2102 ;正常使用配置文件

    router#reload ;重新引导

    路由器文件操作:

    router#copy running-config startup-config ;保存配置

    router#copy running-config tftp ;保存配置到tftp

    router#copy startup-config tftp ;开机配置存到tftp

    router#copy tftp flash: ;下传文件到flash

    router#copy tftp startup-config;下载配置文件

    ROM状态:

    Ctrl+Break ;进入ROM监控状态

    rommon>confreg 0x2142 ;跳过配置文件

    rommon>confreg 0x2102 ;恢复配置文件

    rommon>reset  ;重新引导

    rommon>copy xmodem: flash: ;从console传输文件

    rommon>IP_ADDRESS=10.65.1.2 ;设置路由器IP

    rommon>IP_SUBNET_MASK=255.255.0.0 ;设置路由器掩码

    rommon>TFTP_SERVER=10.65.1.1 ;指定TFTP服务器IP

    rommon>TFTP_FILE=c2600.bin ;指定下载的文件

    rommon>tftpdnld ;从tftp下载

    rommon>dir flash: ;查看闪存内容

    rommon>boot ;引导IOS

    静态路由:

    ip route    ;命令格式

    router(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2 ;静态路由举例

    router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2 ;默认路由举例

    动态路由:

    router(config)#ip routing ;启动路由转发

    router(config)#router rip ;启动RIP路由协议

    router(config-router)#network  ;设置发布路由

    router(config-router)#negihbor  ;点对点帧中继用。

    帧中继命令:

    router(config)#frame-relay switching ;使能帧中继交换

    router(config-s0)#encapsulation frame-relay ;使能帧中继

    router(config-s0)#fram-relay lmi-type cisco ;设置管理类型

    router(config-s0)#frame-relay intf-type DCE ;设置为DCE

    router(config-s0)#frame-relay dlci 16 ;

    router(config-s0)#frame-relay local-dlci 20 ;设置虚电路号

    router(config-s0)#frame-relay interface-dlci 16 ;

    router(config)#log-adjacency-changes ;记录邻接变化

    router(config)#int s0/0.1 point-to-point ;设置子接口点对点

    router#show frame pvc ;显示永久虚电路

    router#show frame map ;显示映射

    基本访问控制列表

    router(config)#access-list  permit|deny  

    router(config)#interface  ;default:deny any

    router(config-if)#ip access-group  in|out ;default:out

    例1:

    router(config)#access-list 4 permit 10.8.1.1

    router(config)#access-list 4 deny 10.8.1.0 0.0.0.255

    router(config)#access-list 4 permit 10.8.0.0 0.0.255.255

    router(config)#access-list 4 deny 10.0.0.0 0.255.255.255

    router(config)#access-list 4 permit any

    router(config)#int f0/0

    router(config-if)#ip access-group 4 in

    扩展访问控制列表:

    access-list  permit|deny icmp  <DESTINATIONIP

    wild>[type]

    access-list  permit|deny tcp  <DESTINATIONIP

    wild>[port]

    例3:

    router(config)#access-list 101 deny icmp any 10.64.0.2 0.0.0.0 echo

    router(config)#access-list 101 permit ip any any

    router(config)#int s0/0

    router(config-if)#ip access-group 101 in

    例3:

    router(config)#access-list 102 deny tcp any 10.65.0.2 0.0.0.0 eq 80

    router(config)#access-list 102 permit ip any any

    router(config)#interface s0/1

    router(config-if)#ip access-group 102 out

    删除访问控制例表:

    router(config)#no access-list 102

    router(config-if)#no ip access-group 101 in

    路由器的nat配置

    Router(config-if)#ip nat inside ;当前接口指定为内部接口

    Router(config-if)#ip nat outside ;当前接口指定为外部接口

    Router(config)#ip nat inside source static [p] <私有IP><公网IP> [port]

    Router(config)#ip nat inside source static 10.65.1.2 60.1.1.1

    Router(config)#ip nat inside source static tcp 10.65.1.3 80 60.1.1.1 80

    Router(config)#ip nat pool p1 60.1.1.1 60.1.1.20 255.255.255.0

    Router(config)#ip nat inside source list 1 pool p1

    Router(config)#ip nat inside destination list 2 pool p2

    Router(config)#ip nat inside source list 2 interface s0/0 overload

    Router(config)#ip nat pool p2 10.65.1.2 10.65.1.4 255.255.255.0 type rotary

    Router#show ip nat translation

    rotary 参数是轮流的意思,地址池中的IP轮流与NAT分配的地址匹配。

    overload参数用于PAT 将内部IP映射到一个公网IP不同的端口上。

    外部网关协议配置:

    routerA(config)#router bgp 100

    routerA(config-router)#network 19.0.0.0

    routerA(config-router)#neighbor 8.1.1.2 remote-as 200

    配置PPP验证:

    RouterA(config)#username  password 

    RouterA(config)#int s0

    RouterA(config-if)#ppp authentication {chap|pap}

    3.PIX防火墙命令

    Pix525(config)#nameif ethernet0 outside security0 ;命名接口和级别

    Pix525(config)#interface ethernet0 auto ;设置接口方式

    Pix525(config)#interface ethernet1 100full ;设置接口方式

    Pix525(config)#interface ethernet1 100full shutdown

    Pix525(config)#ip address inside 192.168.0.1 255.255.255.0

    Pix525(config)#ip address outside 133.0.0.1 255.255.255.252

    Pix525(config)#global (if_name) natid ip-ip ;定义公网IP区间

    Pix525(config)#global (outside) 1 7.0.0.1-7.0.0.15 ;例句

    Pix525(config)#global (outside) 1 133.0.0.1 ;例句

    Pix525(config)#no global (outside) 1 133.0.0.1 ;去掉设置

    Pix525(config)#nat (if_name) nat_id local_ip [netmark]

    Pix525(config)#nat (inside) 1 0 0

    内网所有主机(0代表0.0.0.0)可以访问global 1指定的外网。

    Pix525(config)#nat (inside) 1 172.16.5.0 255.255.0.0

    内网172.16.5.0/16网段的主机可以访问global 1指定的外网。

    Pix525(config)#route if_name 0 0 gateway_ip [metric] ;命令格式

    Pix525(config)#route outside 0 0 133.0.0.1 1 ;例句

    Pix525(config)#route inside 10.1.0.0 255.255.0.0 10.8.0.1 1 ;例句

    Pix525(config)#static (inside, outside) 133.0.0.1 192.168.0.8

    表示内部ip地址192.168.0.8,访问外部时被翻译成133.0.0.1全局地址。

    Pix525(config)#static (dmz, outside) 133.0.0.1 172.16.0.8

    中间区域ip地址172.16.0.8,访问外部时被翻译成133.0.0.1全局地址。

     

    展开全文
  • 思科CISCO常用命令汇总

    千次阅读 2021-02-19 08:44:31
    添加 ip 地址和掩码 3.router(config-if)#enca hdlc /ppp捆绑链路协议hdlc 或者 ppp 思科缺省串口封装的链路层协议 是 HDLC 所以在 show run 配置的时候接口上的配置没有,如果要封装为别的链路层协议例如PPP/...

     

    视图模式介绍

     

      1.普通视图router> 

      2.特权视图router# / 在普通模式下输入enable

      3.全局视图router(config)#/ 在特权模式下输入configt

      4.接口视图router(config-if)#/在全局模式下输入int 接口名称例如int s0 或 int e0 

     5.路由协议视图router ( config-route ) #/ 在全局模式下输入router 动态路由协议名称

     

     

     

     

     

    1基本配置:

     

    1. router>enable         / 进入特权模式

    2. router#conft         / 进入全局配置模式

    3. router(config)#hostname  xxx   

     /设置设备名称就好像给我们的计算机起个名字

    4. router(config)#enable password xxx /设置特权口令

    5.  router(config)#no ip  domain  lookup  

    /不允许路由器缺省使用DNS解析命令 

    6. router(config)#Service password-encryption

    /对所有在路由器上输入的口令进行暗文加密 

    7. router(config)#line  vty  0  4       /进入设置telnet服务模式

     router(config-line)#password   xxx    /设置  telnet 的密码

     router(config-line)#login       /使能可以登陆

    8. router(config)#line  con  0     /进入控制口的服务模式

    router(config-line)#password xxx   /要设置  console 的密码        router(config-line)#login        /使能可以登陆

     

     

     

     

     

    2接口配置

     

    1. router(config)# int  s0

    /  进入接口配置模式serial 0 端口配置 (如果是模块化的路由器前面加上槽 位编号,例如serial0/0 代表这个路由器的0 槽位上的第一个接口)

    2.router(config-if)#ip add xxx.xxx.xxx.xxx   xxx.xxx.xxx.xxx

      / 添加  ip 地址和掩码

    3.router(config-if)#enca   hdlc

     /ppp捆绑链路协议hdlc 或者  ppp 思科缺省串口封装的链路层协议 是 HDLC 所以在  show  run 配置的时候接口上的配置没有,如果要封装为别的链路层协议例如PPP/FR/X25就是看到接口下的enca ppp 或者 enca fr 4.router(config)#int  loopback    

    /建立环回口(逻辑接口 )模拟不同的本机网段

    router(config-if)#ip  add  xxx.xxx.xxx.xxx   xxx.xxx.xxx.xxx

    /  添加ip  地址和掩码给环回口在物理接口 上配置了ip 地址后用no shut 启用这个物理接口反之可以用shutdown 管理性的关闭接口

     

     

    3路由配置

     

    1.静态路由

    router(config)#ip  route  xxx.xxx.xxx.xxx  xxx.xxx.xxx.xxx  下一跳或自己的接口

    2.缺省路由

    router(config)#ip route 0.0.0.0 0.0.0.0 s0添加缺省路由

    3.动态路由rip 协议

    router(config)#router  rip    /启动 rip 协议

    router(config-router)#network  xxx.xxx.xxx.xxx   /宣告自己的网段router(config-router)#version  2   /转 换为 rip2 版本

    router(config-router)#noauto-summary  

              /关闭自动汇总功能,ripV2才有作用

    router(config-router)#passive-in 接 口 名 

     / 启 动 本 路 由 器 的 那 个 接 口 为 被 动 接 口

    router(config-router)#neixxx.xxx.xxx.xxx/广播转单播报文,指定邻居的接 ip

    4.动态路由eigrp 协议

    router(config)#router eigrp  xxx    /启动  eigrp 协议

    router(config-router)#network  xxx.xxx.xxx.xxx   /宣告自己的网段

    router(config-router)#variance   xxx     /调整倍数因子,使用不等价的负载均衡eigrp 协议

    router(config-router)#noauto-summary  /关闭自动汇总功能ospf 协议

    5.动态路由ospf协议

    router(config)router  ospf  xxx  /启动协议

    router(config-router)network xxx.xxx.xxx.xxx  xxx.xxx.xxx.xxx(反掩码)area   xxx

    / 宣告自己的接口 或网段在ospf 的区域中可以把不同接口宣告在不同区域中

     

     

    4保存当前修改/运行的配置:

     

    1.router#write

    /将 RAM 中的当前配置存储到NVRAM 中,下次路由器启动就是执行保存的配置

    2.router#Copy   running-config    startup-config   

     /命令与write 效果一样

     

     

     

    5一般常用命令

     

    1.exit命令

    router(config-if)#exit

    router(config)# router

    (config-router)#exit

    router(config)#

    router(config-line)#exit

    router(config)# router

    (config)#exit

    router#

    exit 命令 / 从接口、协议、line 等视图模式下退回到全局配置模式,或从全局配置模式退回到特权模式

    2.end命令

    router(config-if)#end 

    router(config-router)#end

    router(config-line)#end

    router#

    end 命令 / 从任何视图直接回到特权模式

    3.logout

    router#Logout

    / 退出当前路由器登陆模式相对与windows 的注销

    4.reload命令

    router#reload

    /  重新启动路由器 (热启动)冷启动就是关闭路由器再打开电源开关

    5.show 命令

    特权模式下:router#show ip route

    /查看当前的路由表router#cleariproute*/清楚当前的路由表 

    router#show ip protocol

    /查看当前路由器运行的动态路由协议情况

    router#show ip int brief

    /查看 当前的路由器的接口ip地址启用情况

    router#show running-config

    /查看当前运行配置 

    router#show startup-config

    /查看启动配置

    router#debug ip pack

    /  打开  ip 报文的调试 

    router#terminal  monitor

    /  输出到终端上显示调试信息

    router#show ip eigrp neighbors

    /查看 eigrp 协议的邻居表

    router#show ip eigrp topology

    /查看 eigrp 协议 的拓朴表

    router#show ip eigrp interface

    /查  看当然路由器运行eigrp协议的  接口情况

    router#show ip ospf neighbor

    /查看当前路由器的ospf 协议的邻居表

    router#show ip ospf interface

    /查看当然路由器运行ospf协议的接口情况

    router#clear ip ospf process

    /  清楚当然路由器ospf 协议的进程

    router#Show interfaces

    /  显示设置在路由器和访问服务器上所有接口的统计信息. 显示路由器 上配置的所有接口的状态

    router#Show interfaces serial

    /  显示关于一个串口的信息

    router#Show ip interface

    /列出一个接口的IP 信息和状态的小结,列出接口的状态和全局参数

     

     

    展开全文
  • Cisco 思科模拟器命令

    千次阅读 2021-10-15 12:35:32
    文章目录基本配置**文件操作****启动配置****接口配置****路由****EIGRP****OSPF****ACL****DHCP****HDLC****PPP****FR****ARP(默认启用)****ISDN****IS-IS****BGP****路由优化****异步连接**...R# show history 查看
  • CISCO路由器中的access-list(访问列表)最基本的有两种,分别是标准访问列表和扩展访问列表,二者的区别主要是前者是基于目标地址的数据包过滤,而后者是基于目标地址、源地址和网络协议及其端口的数据包过滤
  • ciscoshow命令[文].pdf

    2021-10-11 01:20:33
    ciscoshow命令[文].pdf
  • cisco设备一些show命令

    2014-01-05 20:46:54
    下面就给大家总结了一些供大家参考:show命令可以同时在用户模式和特权模式下运行,“show ?”命令来提供提供一个可利用的show命令列表。show interfaces:显示所有路由器端口状态,如果想要显示特定端口的状态,...
  • Cisco交换机SHOW命令详解[参考].pdf
  • 1、思科、Juniper、华为基础命令对比 Cisco – IOX XR Juniper – JUNOS Huawei – HVRP show show display exit exit / up quit run do – end exit return | include ...
  • 思科巡检命令

    千次阅读 2020-06-28 10:41:59
    1、show interface stats ;查看交换机所有接口当前接口流量 2、show running-config ;查看当前设备配置 3、show version ;查看IOS版本信息及设备正常运行时间 4、show clock ;查看设备时钟信息 5、show vtp ...
  • Cisco路由器配置命令

    2021-10-15 15:43:48
    特权模式:这一级别用户可以使用show命令进行配置查看,但是还是无法进行配置。在用户模式下输入enable进入。 一般是Router# 全局模式:这一级别下用户可以对路由器进行配置。特权模式下输入config terminal可以...
  • cisco思科交换机命令参考大全

    千次阅读 2020-12-10 09:04:14
    1.设置主机名/系统名 IOS:switch(config)# hostname "hostname" CLI:switch(enable) set system name name-string 2.设置登录口令 IOS:switch(config)# enable password level 1 password ...
  • 这里总结在路由器上的最常用的show 命令。 1 show version :查看路由器的型号,IOS的文件名、路由器接口,内存,以及配置注册号等信息 2 show running-config:查看在内存中运行的配置命令。这个命令...
  • 思科设备命令大全

    2021-12-14 21:12:48
    模式转换命令 用户模式----特权模式,使用命令"enable" 特权模式----全局配置模式,使用命令"config t" 全局配置模式----接口模式,使用命令"interface+接口类型+接口号" 全局配置模式----线控模式,...
  • Cisco Packet Tracer 命令大全基本配置文件操作启动配置密码设置接口配置CDP路由RIPIGRPEIGRPOSPFACLNAT PAT 配置负载分发DHCPHDLCPPPFRARP(默认启用)ISDNIS-ISBGP路由优化异步连接QoS 转载自:...
  • 思科路由器各种show命令的输出详解

    千次阅读 2012-05-01 00:22:50
    Catalyst 3560交换机的命令参考,REL。12.2(44)SEhttp://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_44_se/command/reference/cli2.html Show 显示运行系统信息 Show access...
  • 思科命令解析

    2018-12-17 10:00:11
    思科命令interface show 命令产生的数据中 ,各种数据的含义
  • 思科防火墙命令介绍

    千次阅读 2019-08-19 19:45:03
    1.1CISCO防火墙产品家族: PIX已经停产 ASA(Cisco AdaptiveSecurity Appliance )主流:CiscoASA产品线ASA5500系列 Cisco ASA 5510、5520、and 5540 ASA5512X系列 1.2防火墙的厂商: CISCO防火墙。...
  • CISCO交换机常用命令》 一、交换机四种基本模式 1、四种模式介绍 2.进入四种模式 (1)从用户模式进入特权模式:enable (2)从特权模式进入全局配置模式:conf t (3)从全局端口配置模式进入视图模式...
  • 、备份配置 copy running-config startup-config 2、清楚启动文件 write erase 3、查看系统相关信息 show version 4、查看硬件相关信息 show module 5、查看相关特性 ...show feature
  • 思科常用命令

    千次阅读 2018-11-30 15:35:15
    ,进入命令:enable 退出命令:disable 全局配置模式。提示符:"(config)#",进入命令:configure terminal 退出命令:exit 其他配置模式。如接口模式:提示符:"(config-if)#",进入:...
  • 8、打开RIP协议调试命令 Router #debug ip rip 9、检测PPP连接状态和协商过程 Router #debug ppp packet 10、查OSPF邻居列表 Router #show ip ospf neighbor (detail)详细 11、查链路状态数据库 Router #show ...
  • 思科(Cisco)路由器常用命令总结

    千次阅读 2021-10-02 09:27:53
    6,帧中继命令: router(config)#frame-relay switching 使能帧中继交换 router(config-s0)#encapsulation frame-relay 使能帧中继 router(config-s0)#fram-relay lmi-type cisco 设置管理类型 router(config-s0)#...
  • 思科(Cisco)交换机路由器命令大全

    千次阅读 2021-06-20 20:06:16
    思科(Cisco)路由器常用命令总结 视图模式介绍 普通视图router> 特权视图router# / 在普通模式下输入enable 全局视图router(config)#/ 在特权模式下输入configt 接口视图router(config-if)#/在全局模式下输入int ...
  • 思科设备操作命令CISCO IOS)

    千次阅读 2020-08-31 14:48:29
    cisco设备基本配置命令 基本配置 1、系统配置对话框:空配时才会出现。 Continue with configuration dialog? [yes/no]: YES:进入到一个设置向导 √ NO:直接使用命令行配置   2、配置模式转换​​​​​​...
  • 三、配置命令 做完项目要记得保存,养成习惯 两种保存配置方法 特权模式下 1、R1#write (复制更新文件覆盖启动文件) 2、R1#copy running-config startup-config 两种文件的查看方法 1、查看当前设备配置(查看...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 16,447
精华内容 6,578
关键字:

思科show命令