精华内容
下载资源
问答
  • 比较下cisco与h3c之本地登录与远程telnet登录的差异,在此我们未作管理地址的配置...Cisco之console和vty基本配置 Line console 0//进入console口 Password cisco//设置console口登陆密码 Logging synchronous//提示...
    比较下cisco与h3c之本地登录与远程telnet登录的差异,在此我们未作管理地址的配置,只是简单的介绍下二者的基本配置情况
    Ciscoconsolevty基本配置
    Line console 0     //进入console
    Password cisco    //设置console口登陆密码
    Logging synchronous  //提示信息同步,防止信息干扰输入命令
    Login
    Line vyt 0 4    //允许vty 远程连接 0 4 五个用户
    Password cisco  //设置vty口登陆密码
    Login
    一般为了安全起见,对telnet的设置都是只允许网管机器进行远程访问的,这里我们可以使用ACL作限制
    Cisco telnet ACL控制
    Line vty 0 4
    Password cisco
    Login
    Access-list 1 premit ip 192.168.1.1 255.255.255.0
    Line vty 0 4
    Access-class 1 in
     
    相对于ciscoconsolevty的配置,h3cconsolevty的配置相对复杂一点,
    h3c consolevty基本配置
    1、基于noneconsole的配置
    user-interface console 0
    authentication-mode none //采用none进行认证
    User privilege  level 3
    2、基于passwordconsole的配置
    User-interface console 0
    Authentication-mode password  //采用password进行认证
    Set authentication password simple cisco //封装密码方式采用simple方式  simple为未加密的简单密码 cipher为加密的密码
    User privilege  level 3  //等级分为0-3  数字越大 权限越高
    3、基于schemeconsole的配置
    Local-user XXX
    Password simple/cipher  h3c //密码认证方式二选一
    Service-type terminal level 3  //终端登陆等级
    User-interface console 0
    Authentication-mode scheme
     
    H3cVTY配置
    1、   基于nonevty配置
    User-interface vty 0 4
    Authentication-mode none
    telnet server enable
    User privilege  level 3
    2、   基于passwordvty配置
    User-interface vty 0 4
    Authentication-mode password
    Set authentication password simple cisco
    User privilege level 3
    telnet server enable
    3、   基于schemevty配置
    Local-user XXX
    Password cipher cisco
     
    User-interface vty 0 4
    Authentication-mode scheme
    Set authentication password cipher cisco
    Service-type telnet
    User privilege level 3
     
    附加:配置h3cWEB登陆
     
    Password-control length 5  //h3c默认密码长度为10  这里我们自定义更改为5
    Local-user admin         //设置本地登录账号
    Password cipher cisco      //设置密码
    Service-type telnet level 3
     

    本文转自lovelace521 51CTO博客,原文链接:http://blog.51cto.com/lovelace/907310,如需转载请自行联系原作者
    展开全文
  • cisco路由器vty 最近,我写了一篇文章,解释了如何使用Quagga路由套件实现开放式最短路径优先(OSPF)。 可以使用多个软件套件代替Quagga来实现不同的路由协议。 一种这样的选择是自由范围路由(FRR)。 财务报告...

    cisco路由器vty

    最近,我写了一篇文章,解释了如何使用Quagga路由套件实现开放式最短路径优先(OSPF)。 可以使用多个软件套件代替Quagga来实现不同的路由协议。 一种这样的选择是自由范围路由(FRR)。

    财务报告率

    FRR是一个路由软件套件,它是从Quagga派生的,并根据GNU GPL2许可进行分发。 与Quagga一样,它为Unix类平台提供了所有主要路由协议的实现,例如OSPF,路由信息协议(RIP),边界网关协议(BGP)和中间系统到中间系统(IS-IS)。

    建筑

    FRR是一组守护程序,它们可以共同构建路由表。 每个主要协议都在自己的守护程序中实现,这些守护程序与核心和独立于协议的守护程序Zebra对话,后者提供内核路由表更新,接口查找以及不同路由协议之间路由的重新分配。 每个特定于协议的守护程序负责运行相关协议并根据交换的信息构建路由表。

    FRR architecture

    VTY外壳

    VTYSH是FRR路由引擎的集成外壳。 它将每个守护程序中定义的所有CLI命令合并,并在单个shell中将它们呈现给用户。 它提供了类似于Cisco的模式CLI,并且许多命令类似于Cisco IOS命令。 CLI的模式不同,某些命令仅在特定模式下可用。

    建立

    在本教程中,我们将实现路由信息协议(RIP)以使用FRR配置动态路由。 我们可以通过两种方式来做到这一点-通过在编辑器中编辑协议守护程序配置文件或使用VTY Shell。 在此示例中,我们将使用VTY Shell。 我们的设置包括两个名为Alpha和Beta的CentOS 7.7主机。 这两台主机都有两个网络接口,并共享对192.168.122.0/24网络的访问。 我们将宣传10.12.11.0/24和10.10.10.0/24网络的路由。

    对于主持人Alpha:

    • eth0 IP:192.168.122.100/24
    • 网关:192.168.122.1
    • eth1 IP:10.10.10.12/24

    对于主机Beta:

    • eth0 IP:192.168.122.50/24
    • 网关:192.168.122.1
    • eth1 IP:10.12.11.12/24

    安装包

    首先,我们需要在两个主机上都安装FRR软件包。 可以按照FRR官方文档中的说明进行操作。

    启用IP转发

    对于路由,我们需要在两个主机上都启用IP转发,因为这将由Linux内核执行。

    
       
    sysctl -w net.ipv4.conf.all.forwarding = 1

    sysctl -w net.ipv6.conf.all.forwarding = 1
    sysctl -p

    启用RIPD守护程序

    安装后,所有配置文件都将存储在/ etc / frr目录中。 必须通过编辑/ etc / frr / daemons文件显式启用守护程序 。 该文件确定启动FRR服务时激活了哪些守护程序。 要启用特定的守护程序,只需将相应的“否”更改为“是”。 随后的服务重新启动应启动守护程序。

    FRR daemon restart

    防火墙配置

    由于RIP协议使用UDP作为其传输协议并分配了端口520,因此我们需要在firewalld配置中允许该端口。

    
       
    firewall-cmd --add-port = 520 / udp –permanent

    firewalld-cmd -reload

    现在,我们可以使用以下命令启动FRR服务:

     systemctl start frr 
    

    使用VTY进行配置

    现在,我们需要使用VTY Shell配置RIP。

    在主持人Alpha上:

    
       
    [ root @ alpha ~ ] # vtysh

    Hello, this is FRRouting ( version 7.2RPKI ) .
    Copyright 1996 - 2005 Kunihiro Ishiguro, et al.

    alpha# configure terminal
    alpha ( config ) # router rip
    alpha ( config-router ) # network 192.168.122.0/24
    alpha ( config-router ) # network 10.10.10.0/24
    alpha ( config-router ) # route 10.10.10.5/24
    alpha ( config-router ) # do write
    Note: this version of vtysh never writes vtysh.conf
    Building Configuration...
    Configuration saved to / etc / frr / ripd.conf
    Configuration saved to / etc / frr / staticd.conf
    alpha ( config-router ) # do write memory
    Note: this version of vtysh never writes vtysh.conf
    Building Configuration...
    Configuration saved to / etc / frr / ripd.conf
    Configuration saved to / etc / frr / staticd.conf
    alpha ( config-router ) # exit

    同样,在主机Beta中:

    
       
    [ root @ beta ~ ] # vtysh

    Hello, this is FRRouting ( version 7.2RPKI ) .
    Copyright 1996 - 2005 Kunihiro Ishiguro, et al.

    beta# configure terminal
    beta ( config ) # router rip
    beta ( config-router ) # network 192.168.122.0/24
    beta ( config-router ) # network 10.12.11.0/24
    beta ( config-router ) # do write
    Note: this version of vtysh never writes vtysh.conf
    Building Configuration...
    Configuration saved to / etc / frr / zebra.conf
    Configuration saved to / etc / frr / ripd.conf
    Configuration saved to / etc / frr / staticd.conf
    beta ( config-router ) # do write memory
    Note: this version of vtysh never writes vtysh.conf
    Building Configuration...
    Configuration saved to / etc / frr / zebra.conf
    Configuration saved to / etc / frr / ripd.conf
    Configuration saved to / etc / frr / staticd.conf
    beta ( config-router ) # exit

    完成后,如下检查两个主机上的路由:

    
       
    [ root @ alpha ~ ] # ip route show
    default via 192.168.122.1 dev eth0 proto static metric 100
    10.10.10.0 / 24 dev eth1 proto kernel scope link src 10.10.10.12 metric 101
    10.12.11.0 / 24 via 192.168.122.50 dev eth0 proto 189 metric 20
    192.168.122.0 / 24 dev eth0 proto kernel scope link src 192.168.122.100 metric 100

    我们可以看到Alpha上的路由表通过192.168.122.50包含了10.12.11.0/24的条目,该条目是通过RIP提供的。 类似地,在Beta上,该表包含通过192.168.122.100的网络10.10.10.0/24的条目。

    
       
    [ root @ beta ~ ] # ip route show
    default via 192.168.122.1 dev eth0 proto static metric 100
    10.10.10.0 / 24 via 192.168.122.100 dev eth0 proto 189 metric 20
    10.12.11.0 / 24 dev eth1 proto kernel scope link src 10.12.11.12 metric 101
    192.168.122.0 / 24 dev eth0 proto kernel scope link src 192.168.122.50 metric 100

    结论

    如您所见,设置和配置相对简单。 为了增加复杂性,我们可以向路由器添加更多的网络接口,以为更多的网络提供路由。 可以通过在编辑器中编辑配置文件来进行配置,但是使用VTY Shell在单个组合会话中为我们提供了所有FRR守护程序的前端。

    翻译自: https://opensource.com/article/20/5/vty-shell

    cisco路由器vty

    展开全文
  • cisco设备vty tacacs+认证配置

    千次阅读 2017-11-11 15:51:00
    认证部分 R1(config)#aaa new-model R1(config)#tacacs-server host 192.168.0.20 key cisco R1(config)#aaa authentication login vty group tacacs+ R1(config)#line vty 0 15 R1(config-l...

    认证部分

    R1(config)#aaa new-model

    R1(config)#tacacs-server host 192.168.0.20 key cisco



    R1(config)#aaa authentication login vty group tacacs+




    R1(config)#line vty 0 15

    R1(config-line)#login authentication vty


    ----------------------------------------------------------------------------------

    授权部分

    R2(config)#aaa authorization exec vty group tacacs+

    R2(config)#line vty 0 15

    R2(config-line)#authorization exec vty


    -----------------------------------------------------------------------------------

    privilege本地命令授权(如果不在level 5范围里的命令,必须用privilege先本地授权,并在ACS进行授权,才能最终生效。例如,show run不在level 5用户的命令范围内,必须用privilege exec level 5 show run)

    R2(config)#privilege exec level 5 configure termi  在特权模式下允许level5的用户可以输入conf t命令


    R2(config)#privilege configure all level 5 router  在全局模式下允许执行router命令下的所有子命令

    ----------------------------------------------------------------------------------

    将level 5等级用户可以键入的命令送到ACS上去授权

    R2(config)#aaa authorization commands 5 vty group tacacs+

    R2(config)#line vty 0 15

    R2(config-line)#authorization commands 5 vty

    如果在本地设备上配置过conf t 命令授权,现在想把conf t下的所有命令也在ACS上做授权,就需要明文键入一句语句。

    aaa authorization config-commands

    ------------------------------------------------------------------------------------

    测试ACS用户认证

    aaa group tacacs+ acs1 cisco new-code

    -------------------------------------------------------------------------------------


    exec审计配置

    对exec审计

    R2(config)#aaa accounting exec vty start-stop group tacacs+

    因为level 5等级用户可以调用level 0 level 1等级的命令,故要全部写上

    R2(config)#aaa accounting command 0 vty start-stop group tacacs+

    R2(config)#aaa accounting command 1 vty start-stop group tacacs+

    R2(config)#aaa accounting command 5 vty start-stop group tacacs+

    在vty线路中对审计进行调用

    R2(config)#line vty 0 15

    R2(config-line)#accounting exec vty

    R2(config-line)#accounting command 0 vty

    R2(config-line)#accounting command 1 vty

    R2(config-line)#accounting command 5 vty

    -----------------------------------------------------------------------------------

    查看ACS进程状态

    show application status acs

    停止ACS服务

    acs stop

    开始ACS进程状态

    acs start

    --------------------------------------------------------------------------------------

    配置SSH AAA认证

    http://xpvista.blog.51cto.com/420483/175410







          本文转自daniel8294 51CTO博客,原文链接:http://blog.51cto.com/acadia627/1286314,如需转载请自行联系原作者



    展开全文
  • cisco配置console 特权 VTY 密码

    千次阅读 2017-11-15 23:11:00
    配置Console口密码 sw(config)#line console 0 sw(config-line)#password cisco sw(config-line)#login 配置特权模式密码 sw(config)#enable password cisco明文 sw(config)#enable secret cisco密文 加密明文...

    配置Console口密码

    sw(config)#line console 0

    sw(config-line)#password cisco

    sw(config-line)#login


    配置特权模式密码

    sw(config)#enable password cisco 明文

    sw(config)#enable secret cisco 密文


    加密明文密码

    sw(config)#service password-encryption


    配置VTY密码

    sw(config)#line vty 0 4

    sw(config-line)#password cisco

    sw(config-line)#login










    本文转自 jin626889 51CTO博客,原文链接:http://blog.51cto.com/zuoshou/1297469,如需转载请自行联系原作者
    展开全文
  • 配置Cisco路由器VTY以允许远程访问

    千次阅读 2013-11-23 00:14:27
    设置路由器和PC的IP、路由器vty密码: Router>en Router#conf t R0(config)#int fastEthernet 0/0 R0(config-if)#ip address 10.10.10.1 255.255.255.0 R0(config-if)#no shutdown R0(config-if)#^Z R0# R0(co
  • Cisco设备SNMP配置(思科SNMP配置)

    万次阅读 2018-08-09 12:33:33
    一、Cisco设备配置SNMP命令  配置Cisco设备的SNMP代理及口令  注意:此时STRING尽量不要配置为PUBLIC或者PRIVATE  snmp-server community string [view view-name] [RO | RW] [LROwner | SystemOwner]...
  • VTY访问权限配置

    万次阅读 2013-10-21 21:05:02
    VTY(Virtual Teletype Terminal)虚拟终端,一种网络设备的连接方式(A command line interfacecreated in a router for a Telnet session. The router is able to generate a VTY dynamically. ) 2应用领域 ...
  • cisco路由器配置命令练习用cisco.exe练习软件操作(练习3—5次,熟悉思科命令输入)1. 回车进入用户模式router>2. 进入特权模式router>enablerouter#3. 进入全局模式router#configure terminalrouter(config)#4....
  • 第 1 部分:配置 ACL 并应用到 VTY 线路 步骤 1: 在配置 ACL 之前验证 Telnet 接入。 两台计算机应该能使用 Telnet 远程登录到路由器。密码是 cisco。 步骤 2: 配置编号的标准 ACL 在路由器上配置...
  • Cisco line vty 0 4命令,远程管理交换机

    千次阅读 2020-09-25 09:49:10
    在使用Cisco路由器或交换机时,您可能会遇到line vty配置。因此,本文将解释“ line vty 0 4 ”,并且进一步,我们将在Cisco路由器上配置line vty。所以,让我们开始吧! 了解线路vty 0 4配置在Cisco路由器/交换机 ...
  • 思科设备VTY认证

    2013-09-19 10:50:42
    VTY认证也就是telnet认证,telnet认证也可分为:1....密码认证:enable password ccna 配置进入特权模式密码为ccna(以密码认证的方式进入模式为等级1)line vty 0 4password cisco 密码为cisco(telnet时登录密码...
  • from: guomin
  • 1.查看在线用户 SW4507-Core-B11# Show user 2.查看tcp连接 SW4507-Core-B11#show tcp b 3.清除tcp连接 SW4507-Core-B11#clear tcp tcb 5ea272d8 4.验证 SW4507-Core-B11# Show user
  • 主机名 标语 使用 cisco 作为用户 ...cisco作为vty密码 , 加密所有密码。 enable configure terminal hostname Branch-A banner motd #Branch-A# enable password class line console 0 password cisco logi...
  • CISCO控制VTY访问

    2011-08-04 19:00:05
    CISCO控制VTY访问 实验拓扑如下: 实验目的:学习指定源IP可TELNET路由 实验要求:从FA0/0口只有192.168.2.100/24这台PC可以telnet到router上。 首先配置网络可通 --- System Configuration Dialog ---...
  • 详细介绍思科VTY

    千次阅读 2012-06-27 11:10:24
    Cisco的设备管理有很多种方式,如Console、HTTP、TTY、VTY或其他网管软件,但我们远程管理常用的一种方式肯定是VTY,使用Telnet时进入的就是Cisco设备的VTY接口(Virtual TYpe terminal:虚拟类型终端)。...
  • 我们在用console线连接好路由器和电脑后,启动路由器并用putty连接到路由器的控制台(console)后,建议先配置路由器的主机名(hostname)以方便识别,配置特权模式(enable)密码和vty(telnet)密码以保护路由器。...
  • Cisco line vty 线路使用

    2009-03-04 22:33:36
    line是进入行模式的命令,Console、AUX、VTY、TTY……都是行模式的接口,需要用line配置VTY是虚拟终端口,使用Telnet时进入的就是对方的VTY口。 路由器上有5个VTY口,分别0、1、2、3、4,如果想同时配置这5口,就...
  • 思科交换机配置【串口初始配置

    千次阅读 2021-01-13 21:28:03
    思科交换机配置【串口初始配置Cisco交换机和路由器主要使用超级终端、CRT来配置,此外还可以远程telnet来设置,ssh设置,使用浏览器设置,使用cisco的网管软件来设置,sdm软件等方式来对交换机进行管理。 ...
  • Cisco 设备清除VTY 进程

    千次阅读 2019-09-09 12:24:33
    08-15-out#show users 查看用户进程数 Line User Host(s) Idle Location 1 vty 0 switch_adm idle 00:00:00 10.61.80.40 2 vty 1 idle ...
  • firewall-cmd --add-port=520/udp –permanent firewalld-cmd -reload 现在,我们可以使用以下命令启动 FRR 服务: systemctl start frr 使用 VTY 进行配置 现在,我们需要使用 VTY Shell 配置 RIP。 在主机 Alpha ...
  • cisco思科交换机无线常用配置 1、 交换机telnet功能开启: <Sysname>enable [Sysname]conf t line vty 0 4 password XXXX login 配置说明:默认情况下所有端口都可以通过telnet进行连接。 2、 建立VLAN: 思科采用...
  • 思科SSH配置

    万次阅读 2019-01-03 14:54:00
    R1(config)#hostname R1 //配置...R1(config)#aaa new-model //默认是no aaa new-model, 如果配置为aaa new-model,line vty就不需要配置login local R1(config)#ip domain-name cisco //SSH的关键字名就是hostnam...
  • cisco ios三种模式: R1>:用户模式 R1#:特权模式 R1(config)#:全局配置模式 从用户模式到特权模式:enable 从特权模式到全局配置模式:configure terminal 注:使用exit退出当前模式 ...
  • 讲述华为交换机配置中HTTP访问和vty访问命令,有很多热心的网友对华为交换机配置问题给出了答复,不知道是不是提问者想要的答案,感谢网友对HTTP访问和vty访问命令命令的详细解答,华为交换机配置标志设置与显示:R1...
  • 思科交换机配置命令

    2012-07-10 12:12:41
    思科交换机配置命令 交换机基本状态: switch: ;ROM状态, 路由器是rommon> hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 交换机口令设置...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 6,328
精华内容 2,531
关键字:

思科vty配置