精华内容
下载资源
问答
  • cisco 思科三层交换机配置命令
    千次阅读
    2020-09-29 10:25:28

    1.交换机支持的命令
    交换机基本状态:

    hostname> ;用户模式
    hostname# ;特权模式
    hostname(config)# ;全局配置模式
    hostname(config-if)# ;接口状态
    交换机口令设置:

    switch>enable ;进入特权模式
    switch#config terminal ;进入全局配置模式
    switch(config)#hostname ;设置交换机的主机名
    switch(config)#enable secret xxx ;设置特权加密口令
    switch(config)#enable password xxa ;设置特权非密口令
    switch(config)#line console 0 ;进入控制台口
    switch(config-line)#line vty 0 4 ;进入虚拟终端
    switch(config-line)#login ;允许登录
    switch(config-line)#password xx ;设置登录口令xx
    switch#exit ;返回命令
    交换机VLAN设置:

    switch#vlan database ;进入VLAN设置
    switch(vlan)#vlan 2 ;建VLAN 2
    switch(vlan)#no vlan 2 ;删vlan 2
    switch(config)#int f0/1 ;进入端口1
    switch(config-if)#switchport access vlan 2 ;当前端口加入vlan 2
    switch(config-if)#switchport mode trunk ;设置为干线
    switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlan
    switch(config-if)#switchport trunk encap dot1q ;设置vlan 中继
    switch(config)#vtp domain ;设置发vtp域名
    switch(config)#vtp password ;设置发vtp密码
    switch(config)#vtp mode server ;设置发vtp模式
    switch(config)#vtp mode client ;设置发vtp模式
    交换机设置IP地址:

    switch(config)#interface vlan 1 ;进入vlan 1
    switch(config-if)#ip address ;设置IP地址
    switch(config)#ip default-gateway ;设置默认网关
    switch#dir flash: ;查看闪存
    交换机显示命令:

    switch#write ;保存配置信息
    switch#show vtp ;查看vtp配置信息
    switch#show run ;查看当前配置信息
    switch#show vlan ;查看vlan配置信息
    switch#show interface ;查看端口信息
    switch#show int f0/0 ;查看指定端口信息
    2.路由器支持的命令
    路由器显示命令:

    router#show run ;显示配置信息
    router#show interface ;显示接口信息
    router#show ip route ;显示路由信息
    router#show cdp nei ;显示邻居信息
    router#reload ;重新起动
    路由器口令设置:

    router>enable ;进入特权模式
    router#config terminal ;进入全局配置模式
    router(config)#hostname ;设置交换机的主机名
    router(config)#enable secret xxx ;设置特权加密口令
    router(config)#enable password xxb ;设置特权非密口令
    router(config)#line console 0 ;进入控制台口
    router(config-line)#line vty 0 4 ;进入虚拟终端
    router(config-line)#login ;要求口令验证
    router(config-line)#password xx ;设置登录口令xx
    router(config)#(Ctrl+z) ; 返回特权模式
    router#exit ;返回命令
    路由器配置:

    router(config)#int s0/0 ;进入Serail接口
    router(config-if)#no shutdown ;激活当前接口
    router(config-if)#clock rate 64000 ;设置同步时钟
    router(config-if)#ip address ;设置IP地址
    router(config-if)#ip address second ;设置第二个IP
    router(config-if)#int f0/0.1 ;进入子接口
    router(config-subif.1)#ip address ;设置子接口IP
    router(config-subif.1)#encapsulation dot1q ;绑定vlan中继协议
    router(config)#config-register 0x2142 ;跳过配置文件
    router(config)#config-register 0x2102 ;正常使用配置文件
    router#reload ;重新引导
    路由器文件操作:

    router#copy running-config startup-config ;保存配置
    router#copy running-config tftp ;保存配置到tftp
    router#copy startup-config tftp ;开机配置存到tftp
    router#copy tftp flash: ;下传文件到flash
    router#copy tftp startup-config ;下载配置文件
    ROM状态:

    Ctrl+Break ;进入ROM监控状态
    rommon>confreg 0x2142 ;跳过配置文件
    rommon>confreg 0x2102 ;恢复配置文件
    rommon>reset ;重新引导
    rommon>copy xmodem: flash: ;从console传输文件

    rommon>IP_ADDRESS=10.65.1.2 ;设置路由器IP
    rommon>IP_SUBNET_MASK=255.255.0.0 ;设置路由器掩码
    rommon>TFTP_SERVER=10.65.1.1 ;指定TFTP服务器IP
    rommon>TFTP_FILE=c2600.bin ;指定下载的文件
    rommon>tftpdnld ;从tftp下载
    rommon>dir flash: ;查看闪存内容
    rommon>boot ;引导IOS

    静态路由:

    ip route ;命令格式
    router(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2 ;静态路由举例
    router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2 ;默认路由举例
    动态路由:

    router(config)#ip routing ;启动路由转发
    router(config)#router rip ;启动RIP路由协议。
    router(config-router)#network ;设置发布路由
    router(config-router)#negihbor ;点对点帧中继用。
    帧中继命令:

    router(config)#frame-relay switching ;使能帧中继交换
    router(config-s0)#encapsulation frame-relay ;使能帧中继
    router(config-s0)#fram-relay lmi-type cisco ;设置管理类型
    router(config-s0)#frame-relay intf-type DCE ;设置为DCE
    router(config-s0)#frame-relay dlci 16 ;
    router(config-s0)#frame-relay local-dlci 20 ;设置虚电路号
    router(config-s0)#frame-relay interface-dlci 16 ;
    router(config)#log-adjacency-changes ;记录邻接变化
    router(config)#int s0/0.1 point-to-point ;设置子接口点对点
    router#show frame pvc ;显示永久虚电路
    router#show frame map ;显示映射
    基本访问控制列表:

    router(config)#access-list permit|deny
    router(config)#interface ;default:deny any
    router(config-if)#ip access-group in|out ;defaultut
    例1:

    router(config)#access-list 4 permit 10.8.1.1 router(config)#access-list 4 deny 10.8.1.0 0.0.0.255 router(config)#access-list 4 permit 10.8.0.0 0.0.255.255 router(config)#access-list 4 deny 10.0.0.0 0.255.255.255 router(config)#access-list 4 permit any router(config)#int f0/0 router(config-if)#ip access-group 4 in

    扩展访问控制列表:

    access-list permit|deny icmp [type]
    access-list permit|deny tcp [port]

    例2:

    router(config)#access-list 101 deny icmp any 10.64.0.2 0.0.0.0 echo router(config)#access-list 101 permit ip any any router(config)#int s0/0 router(config-if)#ip access-group 101 in

    例3:

    router(config)#access-list 102 deny tcp any 10.65.0.2 0.0.0.0 eq 80 router(config)#access-list 102 permit ip any any router(config)#interface s0/1 router(config-if)#ip access-group 102 out

    删除访问控制例表:

    router(config)#no access-list 102
    router(config-if)#no ip access-group 101 in
    路由器的nat配置:

    Router(config-if)#ip nat inside ;当前接口指定为内部接口
    Router(config-if)#ip nat outside ;当前接口指定为外部接口
    Router(config)#ip nat inside source static [p] [port]
    Router(config)#ip nat inside source static 10.65.1.2 60.1.1.1
    Router(config)#ip nat inside source static tcp 10.65.1.3 80 60.1.1.1 80
    Router(config)#ip nat pool p1 60.1.1.1 60.1.1.20 255.255.255.0
    Router(config)#ip nat inside source list 1 pool p1
    Router(config)#ip nat inside destination list 2 pool p2
    Router(config)#ip nat inside source list 2 interface s0/0 overload
    Router(config)#ip nat pool p2 10.65.1.2 10.65.1.4 255.255.255.0 type rotary
    Router#show ip nat translation
    rotary 参数是轮流的意思,地址池中的IP轮流与NAT分配的地址匹配。
    overload参数用于PAT 将内部IP映射到一个公网IP不同的端口上。
    外部网关协议配置:

    routerA(config)#router bgp 100
    routerA(config-router)#network 19.0.0.0
    routerA(config-router)#neighbor 8.1.1.2 remote-as 200
    配置PPP验证:

    RouterA(config)#username password
    RouterA(config)#int s0
    RouterA(config-if)#ppp authentication {chap|pap}

    更多相关内容
  • 思科三层交换机VLAN配置 内部网络全部使用10.186.x.x网段,SW2和SW3两个交换机连接两个学院, Sw2学院有电脑500台,sw3学院有电脑200台,合理分配IP地址段,避免浪费, 两个学院可以互相访问,也可以访问内网的web ...
  • 拓扑图: 2层交换机Switch0: 2层交换机Switch0配置命令: Switch>enable #进入特权模式 Switch#configure terminal #进入配置模式 Switch(config)#vlan 10 ...

    拓扑图:

    2层交换机Switch0:

    2层交换机Switch0配置命令:

    Switch>enable                                                       #进入特权模式

    Switch#configure terminal                                     #进入配置模式

    Switch(config)#vlan 10                                          #创建vlan 10 

    Switch(config-vlan)#int vlan 10                             #进入vlan 10

    Switch(config-if)#ip address 192.168.10.1            #给vlan10配置IP地址和子网掩码

    Switch(config-if)#no shutdown                              #开启端口

    三层交换机Multilayer Switch0:

     三层交换机Multilayer Switch0:

    Switch>enable                                                       #进入特权模式

    Switch#configure terminal                                     #进入配置模式

    Switch(config)#vlan 10                                          #创建vlan 10 

    Switch(config-vlan)#int vlan 10                             #进入vlan 10

    Switch(config-if)#ip address 192.168.10.1            #给vlan10配置IP地址和子网掩码

    Switch(config-if)#no shutdown                              #开启端口

    展开全文
  • Cisco思科三层交换机配置DHCP服务

    万次阅读 多人点赞 2020-01-22 16:53:01
    为什么使用三层交换机配置DHCP服务器而不用专门的服务器做DHCP服务器呢?...将三层交换机配置为DHCP服务器,为每个VLAN分配IP地址,每个VLAN有自己的网段 人事部、财务部、生产部、采购部分别属于...

    为什么使用三层交换机配置DHCP服务器而不用专门的服务器做DHCP服务器呢?

    在小型网络中直接将DHCP服务直接配置在核心三层交换机上便于网络管理员管理。在大型网络拓扑中还是建议使用单独的DHCP服务器做,可以节省网络设备的性能,另外图形界面,也方便查看。

    业务需求:
    将三层交换机配置为DHCP服务器,为每个VLAN分配IP地址,每个VLAN有自己的网段
    人事部、财务部、生产部、采购部分别属于VLAN10、VLAN20、VLAN30、VLAN40
    VLAN10: 192.168.10.0/24       网关:192.168.10.1
    VLAN20: 192.168.20.0/24       网关:192.168.20.1
    VLAN30: 192.168.30.0/24       网关:192.168.30.1
    VLAN40: 192.168.40.0/24       网关:192.168.40.1
    注意:创建DHCP地址池要将网关地址做排除。Switch5和Switch8的F0/4端口已经被管理性关闭了,开启的话会使SW0/SW5/SW8产生网络回路,引起网络风暴,下一篇博客我会写打开这个端口而如何避免这样的问题。

     

    网络拓扑:

    网络配置:

    Switch5:
    SW5#conf t
    SW5(config)#vlan 10					        //创建两个VLAN
    SW5(config-vlan)#vlan 20
    SW5(config-vlan)#int f0/2					//给端口分别划分VLAN
    SW5(config-if)#switchport mode access
    SW5(config-if)#switchport access vlan 10
    SW5(config-if)#no shutdown
    SW5(config-if)#exit
    SW5(config)#int f0/3
    SW5(config-if)#switchport mode access
    SW5(config-if)#switchport access vlan 20
    SW5(config-if)#no shutdown
    SW5(config-if)#exit
    SW5(config)#int f0/1					        //设置端口为trunk模式
    SW5(config-if)#switchport mode trunk
    SW5(config-if)#switchport trunk allowed vlan 10,20
    SW5(config-if)#no shutdown
    SW5(config-if)#exit
    
    Switch8:
    SW8#conf t
    SW8(config)#vlan 30
    SW8(config-vlan)#vlan 40
    SW8(config-vlan)#int f0/2
    SW8(config-if)#switchport mode access
    SW8(config-if)#switchport access vlan 30
    SW8(config-if)#no shutdown
    SW8(config-if)#exit
    SW8(config)#int f0/3
    SW8(config-if)#switchport mode access
    SW8(config-if)#switchport access vlan 40
    SW8(config-if)#no shutdown
    SW8(config-if)#exit
    SW8(config)#int f0/1
    SW8(config-if)#switchport mode trunk
    SW8(config-if)#switchport trunk allowed vlan 30,40
    SW8(config-if)#no shutdown
    SW8(config-if)#exit
    
    Switch0
    SW0#conf t
    SW0(config)#vlan 10					//创建4个VLAN
    SW0(config-vlan)#vlan 20
    SW0(config-vlan)#vlan 30
    SW0(config-vlan)#vlan 40
    SW0(config-vlan)#int f0/1
    SW0(config-if)#switchport mode trunk			//设置端口1为trunk模式,允许VLAN10,20,30,40的流量通过
    SW0(config-if)#switchport trunk allowed vlan 10,20,30,40
    SW0(config-if)#no shutdown
    SW0(config-if)#exit
    SW0(config)#int f0/2
    SW0(config-if)#switchport mode trunk
    SW0(config-if)#switchport trunk allowed vlan 10,20
    SW0(config-if)#no shutdown
    SW0(config-if)#exit
    SW0(config)#int f0/3
    SW0(config-if)#switchport mode trunk
    SW0(config-if)#switchport trunk allowed vlan 30,40
    SW0(config-if)#no shutdown
    SW0(config-if)#exit
    
    Multilayer Switch2
    SW2#conf t
    SW2(config)#vlan 10						//创建4个VLAN
    SW2(config-vlan)#vlan 20
    SW2(config-vlan)#vlan 30
    SW2(config-vlan)#vlan 40
    SW2(config-vlan)#int f0/1					//设置f0/1的端口模式
    SW2(config-if)#switchport trunk allowed vlan 10,20,30,40	//三层交换机不用先配置为trunk模式
    SW2(config-if)#exit
    SW2(config)#ip dhcp excluded-address 192.168.10.1		//对DHCP地址池地址做排除
    SW2(config)#ip dhcp excluded-address 192.168.20.1
    SW2(config)#ip dhcp excluded-address 192.168.30.1
    SW2(config)#ip dhcp excluded-address 192.168.40.1
    SW2(config)#int vlan 10						//设置VLAN10的IP地址。三层交换机与路由器的不同之处,不能用单臂路由,划分子端口,所以用此方法分别设置VLAN的地址作为每个DHCP地址池的网关地址
    SW2(config-if)#ip address 192.168.10.1 255.255.255.0
    SW2(config-if)#ip routing					//开启VLAN间路由的功能
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 10					//创建DHCP地址池10
    SW2(config-dhcp)#network 192.168.10.0 255.255.255.0		//设置DHCP地址池网段
    SW2(config-dhcp)#default-router 192.168.10.1			//设置默认网关地址。这里设置为VLAN10的IP地址,所有VLAN10的主机通过这个网关地址获取IP
    SW2(config-dhcp)#exit
    SW2(config)#int vlan 20						
    SW2(config-if)#ip address 192.168.20.1 255.255.255.0
    SW2(config-if)#ip routing
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 20					//创建DHCP地址池20
    SW2(config-dhcp)#network 192.168.20.0 255.255.255.0
    SW2(config-dhcp)#default-router 192.168.20.1
    SW2(config-dhcp)#exit
    SW2(config)#int vlan 30
    SW2(config-if)#ip address 192.168.30.1 255.255.255.0
    SW2(config-if)#ip routing
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 30					//创建DHCP地址池30
    SW2(config-dhcp)#network 192.168.30.0 255.255.255.0
    SW2(config-dhcp)#default-router 192.168.30.1
    SW2(config-dhcp)#exit
    SW2(config)#int vlan 40
    SW2(config-if)#ip address 192.168.30.1 255.255.255.0
    SW2(config-if)#ip routing
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 40					//创建DHCP地址池30
    SW2(config-dhcp)#network 192.168.40.0 255.255.255.0
    SW2(config-dhcp)#default-router 192.168.40.1
    SW2(config-dhcp)#exit

    本文原创,转载请注明出处。

     

    展开全文
  • 思科三层交换机配置步骤实例

    万次阅读 多人点赞 2020-06-14 16:21:18
    思科三层交换机配置步骤实例## 这篇文章适合新手看哟,文章有点长,细节有点细,嘻嘻,慢慢来,加油! 利用思科Packet Tracer 6.2组建如上图所示网络,并实现以下功能: 1.正确配置各设备端口IP地址。 2.将各部门...

    思科三层交换机配置步骤实例##

    在这里插入图片描述
    这篇文章适合新手看哟,文章有点长,细节有点细,嘻嘻,慢慢来,加油!

    利用思科Packet Tracer 6.2组建如上图所示网络,并实现以下功能:
    1.正确配置各设备端口IP地址。
    2.将各部门正确划入相应VLAN,实现各部门间的通信。
    3.要求PC0-10间能互相ping通。

    首先我们要连接好设备

    在连接过程中我们可能会出现如下一些问题:

    1. 如何为路由器添加接口;
      如图我需要两个以太网口可以点击NM-2FE2W添加
      如果需要更多接口可以选择别的(上网查吧)嘻嘻
      在这里插入图片描述

    2.注意相同设备交叉线,不同设备直通线;
    3.为每台设备配置IP地址、子网掩码、默认网关(如配置PC0)
    在这里插入图片描述在这里插入图片描述连接好、配置好的图 如下:
    在这里插入图片描述

    配置VLAN划分VLAN(重点!敲黑板啦)

    1.在二层设备(Switch1-Switch5)设置VLAN
    (比如我的Switch1连接了192.168.10.2 192.168.10.3 192.168.20.2)
    如图所示

    在这里插入图片描述Switch1的命令:
    Switch>enable
    Switch#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#vlan 10
    Switch(config-vlan)#name Vlan10
    Switch(config-vlan)#exit
    Switch(config)#vlan 20
    Switch(config-vlan)#name vlan20
    Switch(config-vlan)#exit

    Switch2的命令:
    Switch>enable
    Switch#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#vlan 10
    Switch(config-vlan)#name vlan10
    Switch(config-vlan)#exit
    Switch(config)#vlan 30
    Switch(config-vlan)#name vlan30
    Switch(config-vlan)#exit

    Switch3的命令:
    Switch>enable
    Switch#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#vlan 40
    Switch(config-vlan)#name vlan40
    Switch(config-vlan)#exit
    Switch(config)#

    Switch4的命令:
    Switch>enable
    Switch#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#vlan 50
    Switch(config-vlan)#name vlan50
    Switch(config-vlan)#exit
    Switch(config)#

    Switch5的命令:
    Switch>enable
    Switch#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#vlan 20
    Switch(config-vlan)#name vlan20
    Switch(config-vlan)#exit
    Switch(config)#vlan 40
    Switch(config-vlan)#name vlan40
    Switch(config-vlan)#exit
    Switch(config)#vlan 60
    Switch(config-vlan)#name vlan60
    Switch(config-vlan)#exit

    2.在三层设备上配置Vlan10-Vlan60,并在三层交换机上为每个vlan添加ip地址,ip地址是pc的默认网关
    首先添加Vlan10-Vlan60
    如图所示:
    在这里插入图片描述
    三层设备Multilayer Switch0的命令:
    Switch(vlan)#vlan 10 name vlan10
    VLAN 10 modified:
    Name: vlan10
    Switch(vlan)#vlan 20 name vlan20
    VLAN 20 modified:
    Name: vlan20
    Switch(vlan)#vlan 30 name vlan30
    VLAN 30 modified:
    Name: vlan30
    Switch(vlan)#vlan 40 name vlan40
    VLAN 40 modified:
    Name: vlan40
    Switch(vlan)#vlan 50 name vlan50
    VLAN 50 modified:
    Name: vlan50
    Switch(vlan)#vlan 60 name vlan60
    VLAN 60 modified:
    Name: vlan60

    然后添加为每个vlan添加pc的默认网关(192.168.10.1-192.168.60.1 6个)
    如图所示:
    在这里插入图片描述
    三层设备Multilayer Switch0的命令:
    Switch>enable
    Switch#config terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#int vlan10
    Switch(config-if)#ip add 192.168.10.1 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    Switch(config)#int vlan20
    Switch(config-if)#
    %LINK-5-CHANGED: Interface Vlan20, changed state to up

    Switch(config-if)#ip add 192.168.20.1 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    Switch(config)#int vlan30
    Switch(config-if)#
    %LINK-5-CHANGED: Interface Vlan30, changed state to up

    Switch(config-if)#ip add 192.168.30.1 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    Switch(config)#int vlan40
    Switch(config-if)#
    %LINK-5-CHANGED: Interface Vlan40, changed state to up

    Switch(config-if)#ip add 192.168.40.1 255.255.255.0
    Switch(config-if)#
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    Switch(config)#int vlan50
    Switch(config-if)#
    %LINK-5-CHANGED: Interface Vlan50, changed state to up

    Switch(config-if)#ip add 192.168.50.1 255.255.255.0
    Switch(config-if)#
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    Switch(config)#int vlan60
    Switch(config-if)#
    %LINK-5-CHANGED: Interface Vlan60, changed state to up

    Switch(config-if)#ip add 192.168.60.1 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#exit

    3.设置Trunk接口
    首先,在二层交换机和PC的接口上划分接口的Vlan,比如连接的PC为192.168.10.2 它与交换机接口的Vlan设置为Vlan10;然后在三层交换机上与二层设备的接口设置为trunk,

    第一步在二层交换机和PC的接口上划分接口的Vlan
    如图所示:
    在这里插入图片描述
    Switch1的命令:
    Switch>enable
    Switch#config terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#interface FastEthernet0/1
    Switch(config-if)#switchport access vlan 10
    Switch(config-if)#exit
    Switch(config)#interface FastEthernet0/2
    Switch(config-if)#switchport access vlan 10
    Switch(config-if)#exit
    Switch(config)#interface FastEthernet0/3
    Switch(config-if)#switchport access vlan 20
    Switch(config-if)#exit

    Switch2的命令:
    Switch>enable
    Switch#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#interface FastEthernet0/1
    Switch(config-if)#switchport access vlan 10
    Switch(config-if)#exit
    Switch(config)#interface FastEthernet0/2
    Switch(config-if)#switchport access vlan 30
    Switch(config-if)#exit

    Switch3的命令:
    Switch>enable
    Switch#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#interface FastEthernet0/1
    Switch(config-if)#
    Switch(config-if)#
    Switch(config-if)#switchport access vlan 40
    Switch(config-if)#exit

    Switch4的命令:
    Switch>enable
    Switch#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#interface FastEthernet0/1
    Switch(config-if)#switchport access vlan 50
    Switch(config-if)#exit
    Switch(config)#interface FastEthernet0/2
    Switch(config-if)#switchport access vlan 50
    Switch(config-if)#exit

    Switch5的命令:
    Switch>enable
    Switch#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#interface FastEthernet0/1
    Switch(config-if)#switchport access vlan 60
    Switch(config-if)#exit
    Switch(config)#interface FastEthernet0/2
    Switch(config-if)#switchport access vlan 20
    Switch(config-if)#exit
    Switch(config)#interface FastEthernet0/3
    Switch(config-if)#switchport access vlan 40
    Switch(config-if)#exit

    第二步在三层交换机上与二层设备的接口设置为trunk,
    不想写命令了~偷个懒吧,哈哈,
    点击三层交换机。然后把f0/24接口按照如下图的设置(然后20-24接口都要Trunk一下)
    快完成了,坚持看完鸭!
    在这里插入图片描述
    4.在三层交换机上进行最后操作
    很多小朋友前面都能做到但是发现还是ping不通,问题可能就是缺少最后这两部哟!
    1.在三层交换机上进行封装trunk链路的中继协议
    2.启动路由转发协议!!(重点!敲黑板!很重要呀,自己栽了跟头的)
    如图所示:
    在这里插入图片描述三层设备Multilayer Switch0的命令:
    Switch>enable
    Switch#config terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#int range f0/23-24
    Switch(config-if-range)#switchport trunk encapsulation dot1q
    Switch(config-if-range)#exit
    Switch(config)#ip routing
    Switch(config)#exit

    5.测试
    PC0 192.168.10.2 ping PC8 192.168.60.2
    在这里插入图片描述大功告成啦~~~~

    ---------------------------------------------------------------手动分割线--------------------------------------------------------
    这其实是我需要完成的作业的一个部分,
    女孩子嘛,尤其是我这种女孩子,遇到问题就容易脆弱,
    现在一想到自己边哭边敲着键盘的样子就觉得好好笑,嘻嘻
    希望能给大家一丢丢帮助吧~同时,感谢写博客的大佬们老板们小哥哥小姐姐们的帮助。
    加油,小朋友!

    展开全文
  • 利用CISCO三层交换机自带的DHCP功能,可以实现多VLAN的IP地址自动分配,在三层交换机上如何配置DHCP服务呢,下面由小编介绍下具体操作吧,1、首先将三层交换机开机,电脑telnet 远程连接,并进入全局模式下,如图所...
  • 三层交换机的基本配置 ip routing no shutdown 实验验证 网络拓扑图 配置端口0/1的ip地址和子网掩码 配置端口0/2的ip地址和子网掩码 开启交换机的路由功能 PC1pingPC0 ...
  • Cisco三层交换机的详细配置

    千次阅读 多人点赞 2021-04-08 17:01:58
    ** 本文适用于新手小白...文章目录一、什么是三层交换机二、配置交换机步骤1.配置二层交换机2.配置三层交换机3.配置两台路由器以及最后一台电脑 一、什么是三层交换机 1.三层交换机 = 三层路由+二层交换机 2.工作在
  • 思科三层交换机配置DHCP中继

    千次阅读 2021-03-20 11:52:04
    三层交换机配置DHCP中继 实验目的: 通过本实验掌握如何给不同网段配置DHCP,掌握DHCP中继配置。 实验拓扑: 对交换机SW1进行预配置。 Switch>en Switch#conf t Enter configuration commands, one per line. ...
  • Cisco三层交换机配置详解

    万次阅读 多人点赞 2019-05-22 17:38:53
    那么使用单臂路由技术就显得有点力不从心了,这是我们就要引入三层交换机了。 现在大多数新型的catalyst交换机都支持CEF(Cisco快速转发)多层交换,CEF是一种基于拓扑的转发模型,可预先将所有的路由选择信息加入到...
  • 思科三层交换机配置命令

    千次阅读 2019-05-21 14:29:03
    思科交换机基本状态: hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 交换机口令设置: switch>enable ;进入特权模式 switch#config ...
  • Cisco 开启三层交换机ip routing

    千次阅读 2021-05-19 08:36:10
    目录Cisco开启三层交换机ip routing一、开启三层交换机并设置vlan的ip地址二、测试PC1 ping PC2PC1访问vlan2中的服务器(192.168.2.10)www.abc.com 一、开启三层交换机并设置vlan的ip地址 对中间的三层交换机进行...
  • 通过配置三层交换机或路由器实现VLAN间的通信,通过路由器实现vlan间通信(单臂路由)在路由器与交换机的端口配置子接口,每个子接口的IP地址是每个VLAN的网关地址(也可以理解为下一跳地址),并在子接口上封装802....
  • Cisco三层交换机配置命令及解释

    千次阅读 2020-05-05 22:05:20
    2016-07-11 13:11:04 基本配置 S>...S(config)# hostname name 改变交换机名称 S(config)# enable password level level_# password 设置用户口令(level_#=1)或特权口令(level_#=15) S(con...
  • Cisco三层交换机实现vlan间路由的配置拓扑图: 一、配置要求如下: 本次测试使用cisco Packet Tracer7.0模拟器进行,请按照实验操作文件(pka)的要求完成配置任务。pka文件中的拓扑和设备命名均不许修改,终端和...
  • 三层交换机配置子网之间的通讯有一个关键的地方,就是子网网关的配置。当子网与子网之间进行通讯时,发起通讯的一方,在本子网中找不到通讯的目标时,就会将通讯的请求提交给自己子网的网关,由自己子网的网关负责...
  • 思科模拟器中三层交换机配置

    千次阅读 2019-06-01 17:54:39
    输入ip address 222.222.1.2.254将vlan 10 和目的IP地址绑定 输入no shutdown开启vlan 10 设置vlan名称 输入exit退回到配置模式(需要退出刚才的config-if模式) 输入vlan 10创建vlan 10 输入...
  • 实验目标 理解三层交换机的基本原理; 掌握三层交换机物理端口开启路由功能的配置方法; 实验背景 ... 配置三层交换机端口的路由功能 Switch (config)#interface fastEthernet 0/5 Switch ...
  • 思科模拟器 --- 交换机端口安全配置

    万次阅读 多人点赞 2019-11-15 09:34:21
    1.实验环境:对公司网络严格控制,防止公司用户的IP地址冲突和公司内部的网络攻击和破坏行为,为每一个员工分配固定的IP地址,某公司员工分配的IP地址为:192.168.2.2/24,主机的MAC地址是:0060.5C5B.3152,该主机...
  • 实验六 三层交换机配置实验报告

    千次阅读 2021-07-09 09:05:10
    实验报告实验名称三层交换机配置同组同学实验成绩一、实验目的(1)深入了解三层交换机的功能、特点及工作原理。(2)掌握三层交换机实现路由功能的方法。二、实验仪器设备及软件Packet Tracer 5.3三、实验方案按照...
  • 三层交换机配置命令

    2021-02-04 10:51:02
    三层交换机配置命令 配置一组二层端口 configure terminal 进入配置状态 interface range {port-range} 进入组配置状态 配置三层端口 configure terminal 进入配置状态 interface {{fastethernet | gigabitethernet}...
  • 展开全部cisco层交换机设置trunk:S1>enable //进入特权e5a48de588b63231313335323631343130323136353331333431356564模式S1#config terminal //进入全局配置模式S1(config)# interface vlan [vlanID] //进入...
  • 因此需要提高交换机之间的传输带宽,并实现链路冗余备份,为此网络管理员在2台交换机之间采用2根网线互连,并将相应的2个端口聚合为一个逻辑端口,现要在交换机上做适当配置来实现这一目标。 【实现功能】  1....
  • 三层交换机配置的步骤

    千次阅读 2021-09-15 13:44:03
    网管不会配置三层交换机怎么办?学啊! 交换机是企业组网的重要设备,掌握交换机配置是作为网管的必备技能。这里以三层交换机配置为例子,说一说配置的步骤。 配置管理地址 每个交换机需要配置一个...
  • Cisco交换机配置新手篇之端口配置

    万次阅读 2019-06-17 15:18:18
    上回跟大家介绍了如何正确连接交换机,今天用一些配置片段给大家介绍一下端口配置。鉴于网上大多数配置事例都是show-run出来的结果。不利于新手对命令配置过程的了解,所以笔者将配置片段和注意的地方都注明了一下...
  • 实验步骤: 1: 在两台交换机上配置IP地址 en->进入特权模式 config t->进入全局配置模式 ...2: 在三层交换机配置Telnet 在全局配置模式下: enable password 0 star->配置enable的密码 l...
  • 三层交换机配置静态路由

    万次阅读 2020-07-19 15:13:53
    一、建立拓扑图 二、配置主机IP地址、网关 主机号 IP地址 网关 PC 0 192.168.10.101 192.168.10.1 PC 1 192.168.20.101 192.168.20.1 PC 2 192.168.30.101 192.168.30.1 PC 3 192.168.40.101 192.168.40.1 、创建...
  • 预备知识:VLAN的划分解决了广播域太大而容易引起广播风暴的问题,有利于增加网络带宽,提高带宽利用率。但划分了VLAN后,VLAN之间的计算机也不能通信,信息、...三层交换机是在二层交换机的基础上添加了路由模块...
  • 二、二层交换机配置 Switch# Switch#config t Enter configuration commands, one per line. End with CNTL/Z. Switch(config)#vlan 10 Switch(config-vlan)#vlan 20 Switch(config-vlan)#exit Switch...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 11,167
精华内容 4,466
关键字:

思科三层交换机端口配置ip地址