精华内容
下载资源
问答
  • Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco...
  • 思科cisco路由器动态路由协议配置方法 配置IGRP动态路由协议 IGRP是

    思科cisco路由器动态路由协议配置方法

    •  配置 IGRP动态路由协议

          IGRP是EIGRP协议的前身,虽然现在基本被EIGRP协议所取代,但在一些特殊场合我们仍然会用到该动态路由协议。他的使用配置和EIGRP协议很相似。我们简单介绍一下。

        配置环境:

        ROUTER-A连接10.1.1.1/24和20.1.1.1/30两个网段,ROUTER-B连接20.1.1.1/30与30.1.1.1/24两个网段。如果不配置任何动态路由协议的话router-b将不知道到达10.1.1.1/24这个网段的路线,相应的A也不知道到达30.1.1.1/24这个网络。不配置IGRP协议的话PC2是不能成功PING通PC1的。下面我们在两台路由器上配置IGRP动态协议。

        配置命令:

        ROUTER-A:

        router igrp 65500    启动IGRP动态协议,并设置自治系统号为65500。

        小提示:自治系统号为1到65535的数,而且只有64512到65535可以让我们私用,其他自治系统号都用于公网中。


        network 10.0.0.0    宣告IGRP通告的网段,这里值得注意的是通告的网段要写主类形式即10.0.0.0,而不是类似OSPF一样写10.1.1.0的形式。(如图3)

        小提示:IGRP会自动在边界上归纳路由信息为主类IP地址而且自动归纳无法取消。

        ROUTER-B:

        router igrp 65500    启动IGRP动态协议,并设置自治系统号为65500,自治系统号要和A设置的一样才能正常通讯。

        network 30.0.0.0    宣告IGRP通告的网段,仍然要采用主类的方式。

        总结:配置完毕后在PC2上ping PC1计算机的IP地址是可以连通的,同理pc1也可以成功ping通PC2。这些都是因为IGRP动态协议对10.0.0.0与30.0.0.0网段宣告的结果。

    • 配置EIGRP动态路由协议

          EIGRP是结合了链路状态型和距离矢量型路由选择协议优点的CISCO专用协议。该混合协议具有快速收敛,减少带宽占用,支持多种网络层协议的特点。不过由于他是CISCO专用协议,所以其他厂商的路由器不支持该协议,他只应用于整个网络都是CISCO公司的路由器的情况。总的来说他是一种高级的距离矢量型路由选择协议,是从IGRP协议发展而来的。

        配置环境:

        ROUTER-A连接10.1.1.1/24和20.1.1.1/30两个网段,ROUTER-B连接20.1.1.1/30与30.1.1.1/24两个网段。如果不配置任何动态路由协议的话router-b将不知道到达10.1.1.1/24这个网段的路线,相应的A也不知道到达30.1.1.1/24这个网络。不配置EIGRP协议的话PC2是不能成功PING通PC1的。下面我们在两台路由器上配置EIGRP动态协议。


        配置命令:

        ROUTER-A

        router eigrp 65500    启动EIGRP动态协议,并设置自治系统号为65500。

        小提示:自治系统号为1到65535的数,而且只有64512到65535可以让我们私用,其他自治系统号都用于公网中。

        network 10.0.0.0    宣告EIGRP通告的网段,这里值得注意的是通告的网段要写主类形式即10.0.0.0,而不是类似OSPF一样写10.1.1.0的形式。

        小提示:EIGRP会自动在边界上归纳路由信息为主类IP地址,如果要想取消自动归纳则需要使用no auto-summary命令。

        ROUTER-B

        router eigrp 65500    启动EIGRP动态协议,并设置自治系统号为65500,自治系统号要和A设置的一样才能正常通讯。

        network 30.0.0.0    宣告EIGRP通告的网段,仍然要采用主类的方式。

        总结:配置完毕后在PC2上ping PC1计算机的IP地址是可以连通的,同理pc1也可以成功ping通PC2。这些都是因为EIGRP动态协议对10.0.0.0与30.0.0.0网段宣告的结果。

    • 配置OSPF动态路由协议

          OSPF协议也叫开放最短路径优先协议,他是一项链路状态型技术,与路由选择信息协议(RIP)这样的距离矢量型技术相对,OSPF协议完成各路由选择协议算法的两大主要功能是路径选择和路径交换。目前最新版本是OSPF版本2。OSPF是一种内部网关协议(IGP),也就是说他在属于同一自治系统的路由器间发布路由选择信息。

        目前OSPF是应用最广泛的动态路由协议,他不是CISCO专有的路由协议,可以互连CISCO,华为和实达等多个公司的路由器,兼容性非常不错。因此适合于中小企业路由的互连。

        配置环境:

        ROUTER-A连接10.1.1.1/24和20.1.1.1/30两个网段,ROUTER-B连接20.1.1.1/30与30.1.1.1/24两个网段。如果不配置任何动态路由协议的话router-b将不知道到达10.1.1.1/24这个网段的路线,相应的A也不知道到达30.1.1.1/24这个网络。不配置OSPF协议的话PC2是不能成功PING通PC1的。下面我们在两台路由器上配置OSPF动态协议。


        配置方法

        ROUTER-A

        router ospf 1    启动OSPF进程,进程号为1,值得注意的是进程号本地路由器有效。

        network 10.1.1.0 0.255.255.255 area 0    设置OSPF通告的网络范围,将对10.1.1.0/24这个网段通告。后头的0.255.255.255指的是反向掩码,他代表通告的网段的子网掩码是255.255.255.0。

        小提示:第二句也可以使用network 10.1.1.1 0.0.0.0 area 0代替,这样OSPF将宣告接口10.1.1.1连接的网络。


        ROUTER-B

        router ospf 1    启动OSPF进程,进程号为1。

        network 30.1.1.1 0.255.255.255 area 0    宣告30.1.1.0/24这个网段。

        小提示:第二句也可以使用network 30.1.1.1 0.0.0.0 area 0这个命令来宣告ROUTER-B上30.1.1.1这个接口连接的网段。

     
    展开全文
  • 在大型的企业中,可能在同一网内使用到多种路由协议,为了实现多种路由协议的协同工作,路由器可以使用路由重分发(route redistribution)将其学习到的一种路由协议的路由通过另一种路由协议广播出去,这样网络的...

    在大型的企业中,可能在同一网内使用到多种路由协议,为了实现多种路由协议的协同工作,路由器可以使用路由重分发(route redistribution)将其学习到的一种路由协议的路由通过另一种路由协议广播出去,这样网络的所有部分都可以连通了。 为了实现重分发,路由器必须同时运行多种路由协议,这样,每种路由协议才可以取路由表中的所有或部分其他协议的路由来进行广播。

    重分发分为两种

    • 双向重分发:在两个路由选择进程之间重分发所有路由

    • 单向重分发:将一条路由传递给一种路由选择协议,同时只将通过该路由选择协议获得网络传递给其他路由选择协议。

    重发布常用命令

    redistriute  protocol [metric metric-value]
    [match internal | external nssa-external type][route-map map-tag]
    

    路由重发布是,必须给重分布而来的路由指定的度量值被称为默认度量值(metric值)或种子度量值,它是在重分发配置期间定义的。OSPF度量值为:代价,RIP度量值为:跳数

    路由重发布案例

    在这里插入图片描述

    1、配置R1接口IP地址

    R1(config)#interface gigabitEthernet 0/0
    R1(config-if)#ip address 192.168.1.1 255.255.255.0
    R1(config-if)#no shutdown
    

    2、配置R1动态路由RIP

    R1(config)#router rip
    R1(config-router)#version 2
    R1(config-router)#network 192.168.1.0
    

    3、配置R2接口IP地址

    R2(config)#interface gigabitEthernet 0/0
    R2(config-if)#ip address 192.168.1.2 255.255.255.0
    R2(config-if)#no shutdown
    R2(config)#interface gigabitEthernet 0/1
    R2(config-if)#ip address 192.168.2.2 255.255.255.0
    R2(config-if)#no shutdown
    

    4、配置R2动态路由RIP和OSPF

    R2(config)#router rip
    R2(config-router)#version 2
    R2(config-router)#network 192.168.1.0
    R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
    R2(config-router)#router-id 2.2.2.2
    R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
    

    6、配置R3的接口地址

    R3(config)#interface gigabitEthernet 0/1
    R3(config-if)#ip address 192.168.2.3 255.255.255.0
    R3(config-if)#no shutdown
    

    7、配置R3的OSPF

    R3(config)#router ospf 1
    R3(config-router)#router-id 3.3.3.3
    R3(config-router)#network 192.168.2.0 0.0.0.255 area 0
    

    8、配置路由重发布策略

    R2(config)#router rip
    R2(config-router)#redistribute ospf 1 metric 5
    R2(config)#router ospf 1
    R2(config-router)#redistribute rip subnets
    

    9、验证
    在这里插入图片描述
    从上图可以R3已经从RIP协议中学到了路由条目了。

    展开全文
  • CISCO 路由协议

    2013-01-17 16:32:05
    网络CISCO路由协议概述,很详细。如果没有问题。
  • 思科路由协议教程,经典学习资料,学习前需要一定技术功底。
  • 思科路由协议

    2015-10-18 16:41:43
    有助于学习和更好的理解思科路由协议,回答学习过程中遇到的难点,关键点
  • CISCO--路由协议重分布

    千次阅读 2019-06-17 12:10:22
    路由重分发(Route Redistribution):指为实现同一网络内多种路由协议协同工作,利用路由重分发技术实现各路由器间共享路由信息,将一种路由协议的路由通过其他方式(可能是另一路由选择协议、静态路由或直连路由)广播...

    一、重分布

    路由重分发(Route Redistribution):指为实现同一网络内多种路由协议协同工作,利用路由重分发技术实现各路由器间共享路由信息,将一种路由协议的路由通过其他方式(可能是另一路由选择协议、静态路由或直连路由)广播出去,从而实现网络互通。

    • 注:在其他地方还有重分布、再分配等叫法,从时间先后及描述准确度上看,建议使用"路由重分发"。

    不同的路由协议默认是不可以进行互相通信的,因此需对路由协议进行重新分发。

    进行重分发之前,需要充分理解不同路由协议的管理距离及度量值,且在进行重新分发时要指定度量值,以便能够达到全网互通并且选择最优路径的目的。

    种子度量值(Seed Metric),是定义在路由重分发里的,它是一条从外部重分发进来的路由的初始度量值。每一种路由协议都有自己的度量标准,所以在进行重分布时必须转换度量标准,使得它们兼容;

    管理距离(AD,即Administrative Distance),是指一种路由协议的路由可信度。AD值越低,则它的优先级越高。对于两种不同的路由协议到一个目的地的路由信息,路由器首先根据管理距离决定相信哪一个协议。

    在重分发时设定种子metric

       协议     seed metric(种子度量)

       RIP      无限大       当其他路由注入到RIP的时候,因为RIP最大只有15跳,所有必须手工指定Metric值

       EIGRP    无限大       也必须手工指定

       OSPF     20

    一:(RIP---OSPF)

    如图所示,在路由器和PC上配置好IP

    0.在R1和R3上分别指定要通告的网络

    R1(config)#router rip

    R1(config-router)#version 2

    R1(config-router)#network 192.168.1.0

    R1(config-router)#network 12.1.1.0

     

    R3(config)#router ospf 100

    R3(config-router)#network 23.1.1.0 0.0.0.255 area 0

    R3(config-router)#network 192.168.2.0 0.0.0.255 area 0


    1.在R2上面左边G0/0方向的运行的是RIP路由协议,而右边G0/1方向的运行的是OSPF的路由协议:

    R2(config)#router rip

    R2(config-router)#version 2  

    R2(config-router)#no auto-summary

    R2(config-router)#network 12.1.1.0

     

    R2(config)#router ospf 100

    R2(config-router)#router-id 2.2.2.2

    R2(config-router)#network 23.1.1.0 0.0.0.255 area 0

     

    2.将OSPF注入到RIP:

    当把其他路由注入到RIP的时候,就要遵循RIP的的Metric值,因为在R2右方向上两条路由23网段和2.0网段的metric值都是16跳,而16跳在RIP里面却是不可达的,所有当OSPF注入到RIP的时候,R1实际上是接收不到的,所以这个时候就需要手工来指定metric值。

    R2(config)#router rip

    R2(config-router)#redistribute ospf 100 metric 5  

    当这里手工指定metric为5的时候,在R1上的路由表中就可以看到学过来的OSPF的跳数是5跳。根据具体环境来设置metric值。

    3.将RIP注入到OSPF:

    当把其他路由注入到OSPF的时候,

    如果像下面这样直接重分布的话而不加参数subnets的话,则只能把有类(没有做过子网划分)的路由注入到OSPF,而12.1.1.1/24网段的路由是做过子网划分的,所在R3里面就不会看到12网段的路由,故默认情况下的做过子网划分的路由是不会注入到OSPF的,所以要加入一个参数subnets

    R2(config)#router ospf 100

    R2(config-router)#redistributer ip subnets   

    “subnets”就是子网的意思,加上这个参数以后就可以将做过子网划分的路由正常注入到OSPF了。正常情况下都建议加上这个参数。

    *当把其他路由注入到OSPF的时候,其他路由的默认metric值都是20

     

    4.将静态路由注入到RIP:

    先在R2上配置一条静态路由:

    R2(config)#ip route 100.1.1.0 255.255.255.0 null 0  

    这里的null 0表示创建了一个空接口0。(前面将过下一跳可以用出接口表示)

    然后把这条静态路由注入到RIP,让R1上面有这条静态路由:

    R2(config)#router rip

    R2(config-router)#redistribute static     

    这样在R1上面就可以看到这条静态路由了,默认metric值是1,是不需要手工修改metric值的。

     

    5.将默认路由注入到RIP:

    先写一条默认路由:

    R2(config)#ip route 0.0.0.0 0.0.0.0 G0/1

    当配好这条默认路由的时候,再去R1上面查看,发现已经有这条默认路由了,那是因为在上面已经做过一次静态

    路由重分布,而默认路由也属于静态路由。所以重分布静态可重分布默认路由用的是一条路由命令:

    R2(config)#router rip

    R2(config-router)#redistribute static

    5.把直连路由注入到RIP

    首先先建立一个直连路由,用回环口来建。

    R2(config)#interface loopback 0

    R2(config-if)#ip address 200.1.1.2 255.255.255.0

    R2(config)#router rip

    R2(config-router)#redistribute connected

    然后所有的直连都可以注入到RIP了。

     

    6.把静态路由100.1.1.0 255.255.255.0null 0注入到OSPF:

    R2(config)#router ospf 100

    R2(config-router)#redistribute static subnets    //充分发静态路由到OSPF

    仍然需要加入这个参数。以为100网段也是做过子网划分的。

     

    7.把默认路由注入到OSPF:

    重分布静态是不能将默认路由注入到OSPF的。

    R2(config)#router ospf 100

    R2(config-router)#default-information originate    

    这样才能将默认路由注入到OSPF

     

    8.把直连路由注入到OSPF:

    R2(config)#routerospf 100

    R2(config-router)#redistribute connected subnet   //充分发直连路由到OSPF
     

    展开全文
  • R1: enable config terminal host r1 no ip domain-lookup int f0/0 ip address 10.0.1.2 255.255.255.0 no shut exit int f0/1 ip address 192.168.2.1 255.255.255.0 no shut exit router rip //rip协议,...

    一:按rip默认的version 1配置:

    1:拓扑结构图

    2:配置代码

    R1:
    enable
    config terminal
    host r1
    no ip domain-lookup
    int f0/0
    ip address 10.0.1.2 255.255.255.0
    no shut
    exit
    int f0/1
    ip address 192.168.2.1 255.255.255.0
    no shut
    exit
    router rip  //rip协议,version 1 的配置
    version 1
    network 10.0.1.0 
    network 192.168.2.0 
    exit
    
    R2:
    enable
    config terminal
    host r2
    no ip domain-lookup
    int f0/0
    ip address 192.168.2.2 255.255.255.0
    no shut
    exit
    int f0/1
    ip address 192.168.3.1 255.255.255.0
    no shut
    exit
    router rip  //rip协议,version 1 的配置
    version 1
    network 192.168.2.0 
    network 192.168.3.0 
    exit
    
    R3:
    enable
    config terminal
    host r3
    no ip domain-lookup
    int f0/0
    ip address 192.168.3.2 255.255.255.0
    no shut
    exit
    int f0/1
    ip address 10.0.2.2 255.255.255.0
    no shut
    exit
    router rip  //rip协议,version 1 的配置
    version 1
    network 192.168.3.0 
    network 10.0.2.0 
    Exit

    3:配置结果与截图

    R1#show ip route

    R2#show ip route

    R3#show ip route

    PC1:

    PC2:

    分析过程和PC1的完全一样

     

    二:按rip默认的version 2配置:

    1:拓扑结构图

    2:配置代码

    R1:
    enable
    config terminal
    host r1
    no ip domain-lookup
    int f0/0
    ip address 10.0.1.2 255.255.255.0
    no shut
    exit
    int f0/1
    ip address 192.168.2.1 255.255.255.0
    no shut
    exit
    router rip  //rip 协议 version 2 的配置
    version 2
    no auto-summary
    network 10.0.1.0 
    network 192.168.2.0 
    exit
    
    R2:
    enable
    config terminal
    host r2
    no ip domain-lookup
    int f0/0
    ip address 192.168.2.2 255.255.255.0
    no shut
    exit
    int f0/1
    ip address 192.168.3.1 255.255.255.0
    no shut
    exit
    router rip  //rip 协议 version 2 的配置
    version 2
    no auto-summary
    network 192.168.2.0 
    network 192.168.3.0 
    exit
    
    R3:
    enable
    config terminal
    host r3
    no ip domain-lookup
    int f0/0
    ip address 192.168.3.2 255.255.255.0
    no shut
    exit
    int f0/1
    ip address 10.0.2.2  255.255.255.0
    no shut
    exit
    router rip  //rip 协议 version 2 的配置
    version 2
    no auto-summary
    network 192.168.3.0 
    network 10.0.2.0 
    Exit

    3:配置结果与截图

    R1#show ip route

    R2#show ip route

    R3#show ip route

    PC1:

    PC2:过程同PC1

    展开全文
  • 华为、思科与Juniper路由协议优级级比较,涉及Direct,Static,OSPF ,RIP,BGP,ISIS
  • EIGRP全称是增强性内部网关路由协议,又称混合型路由协议Cisco私有,无类别的距离矢量协议,跨层封装到层,协议号88;组播更新224.0.0.10,支持等开销负载均衡和非等开销负载均衡; 增量更新,仅更新变化的部分...
  • 思科静态路由协议

    千次阅读 2019-09-01 16:30:17
    思科静态路由协议 ** 1.规划网段(路由是隔离网段的) 配置每个节点IP地址。 R0 Router(config)#interface f0/0 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.10.1 255.255.255.0 ...
  • cisco的私有路由协议; 快速汇聚:采用DUAL算法来实现 触发更新,按需更新; 支持多种网络协议:使用协议无关模块来实现; 使用多播和单播:224.0.0.10(多播地址) 支持 VLSM 动态路由协议分类: 1.距离矢量路由...
  • 思科动态路由协议的配置,如RIP OSPF
  • 一:层交换机和路由器上都使用RIP动态路由协议version 1; 二:把网段192.168.3.0/24的网段改为10.1.1.0/24,网段192.168.5.0/24的网段改为10.1.2.0/24,计算机和路由接口地址都相应变化,看看可达性情况; :...
  • 思科RIP路由协议配置

    千次阅读 2020-05-23 23:09:55
    是一内部网关协议(IGP),是一动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法(DistanceVectorAlgorithms),使用“跳数”(即metric)来衡量到达目标地址的路由距离。RIP...
  • Cisco路由安全配置--路由协议.docx
  • 思科动态路由协议RIP

    2019-09-01 16:36:53
    思科动态路由协议 规划网段(路由是隔离网段的) 配置每个节点IP地址。 R0 Router(config)#interface f0/0 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.10.1 255.255.255.0 ...
  • 关于OSPF路由协议在企业网络中的应用关于OSPF路由协议在企业网络中的应用关于OSPF路由协议在企业网络中的应用关于OSPF路由协议在企业网络中的应用关于OSPF路由协议在企业网络中的应用关于OSPF路由协议在企业网络中的...
  • 拓扑图: 配置代码: R1 enable config terminal ...OSPF路由协议的进程号为100,一个路由器上可启用多个OSPF进程,以进程号作为区别标志 network 192.168.1.0 0.0.0.255 area 1 router-id 192.168.1.1 !这个路
  • 《2011思科路由协议挑战100问》 第期928
  • 基于思科网络仿真软件的实验报告,核心内容是验证路由信息协议,对于正在学习网络技术的人员有很大帮助
  • 思科网络路由协议

    2007-10-19 13:02:39
    思科网络路由协议 1、思科网络路由协议 网络/路由(Network/Routing)  CGMP:思科组管理协议 (CGMP:Cisco Group Management Protocol)  EIGRP:增强的内部网关路由选择协议 (EIGRP:...
  • 路由协议OSPF距离矢量路由协议学习经验,练习1
  • 思科Cisco的十三种私有协议

    千次阅读 2020-08-17 21:58:37
    1. IGRP(Interior Gateway Routing Protocol 内部网关路由协议) ** 是基于D-V(贝尔曼-福特算法(Bellman-Ford))算法的动态路由协议,它通过和相邻路由器之间交换路由信息来建立路由器。 特点如下: a)在IGRP中...
  • 思科路由协议挑战100问,学习思科技术的好资料。
  • RIP、OSPF是公共协议,而eigrp是Cisco特有的路由协议。 rip的路由规模一般在10台以内, OSPF适合在大规模的网络中,可同时有千台路由器同时运行。 eigrp只能用在所有设备都是Cisco的情况中,规模可以比Rip大一点,但...
  • IGRP即内部网关协议,是一动态距离向量路由协议,它由Cisco公司80年代中期设计。使用组合用户配置尺度,包括延迟、带宽、可靠性和负载。缺省情况下,IGRP每90秒发送一次路由更新广播,在3个更新周期内(即270秒)...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 30,070
精华内容 12,028
关键字:

思科三种路由协议