精华内容
下载资源
问答
  • 思科交换机 DHCP 服务配置

    万次阅读 2019-01-12 15:16:04
    说明:有 3 个 VLAN,...服务器不会使用,因为实验一是演示的,部署在交换机上面,DHCP 服务器则在后续中继的过程中使用到。 地址规划 VLAN 2:20.1.1.0/24,网关 20.1.1.254,DNS 88.1.1.253 VLAN 3:30.1.1.0/24...

    在这里插入图片描述
    说明:有 3 个 VLAN,VLAN2 与 VLAN3 是用户 VLAN,而 VLAN 88 则是 DHCP 服务器的 VLAN,在实验演示一中,DHCP
    服务器不会使用,因为实验一是演示的,部署在交换机上面,DHCP 服务器则在后续中继的过程中使用到。
    地址规划
    VLAN 2:20.1.1.0/24,网关 20.1.1.254,DNS 88.1.1.253
    VLAN 3:30.1.1.0/24,网关 30.1.1.254,DNS 88.1.1.253
    VLAN 88:88.1.1.0/24,网关 88.1.1.254,DNS 88.1.1.253
    实验演示一的配置思路
    1、二层配置 VLAN,把对应的接口加入到对应的 VLAN 内
    2、二层交换机与三层交换机之间配置 trunk
    3、三层交换机上面配置 DHCP 服务
    4、验证 PC 是否能够获取到
    5、优化端口与地址排除
    具体配置
    1、二层配置 VLAN,把对应的接口加入到对应的 VLAN 内
    2、二层交换机与三层交换机之间配置 trunk
    说明:二层交换机需要配置的就是,把用户的 VLAN 2 3 创建,然后上行链路定义为 trunk,把下行接入用户的接口划入到
    对应的 VLAN 里面。
    switch-S260(config)#vlan 2
    switch-S260(config-vlan)#vlan 3
    switch-S260(config)#int f0/1
    switch-S260(config-if)#switchport mode access
    switch-S260(config-if)#switchport access vlan 2
    switch-S260(config-if)#int f0/2
    switch-S260(config-if)#switchport mode access
    switch-S260(config-if)#switchport access vlan 3
    switch-S260(config-if)#int f0/3
    switch-S260(config-if)#switchport mode trunk
    说明:其中 F0/1 与 2 是接用户的接口,F0/3 是接三层交换机的接口。
    3、三层交换机上面配置 DHCP 服务
    说明下:这里三层交换机并没有配置这两条命令
    switchport trunk encapsulation dot1q
    switchport mode trunk
    这是因为 3560 默认是 DTP 模式的 auto,只要另外一段配置了 on 或者是对应的模式会自动协商为 trunk,之前强制了二层
    交换机而 trunk,这里 3560 就自然的形成了 trunk。
    三层交换机的初始化配置
    switch-S3560(config)#vlan 2
    switch-S3560(config-vlan)#vlan 3
    switch-S3560(config-vlan)#int vlan 2
    switch-S3560(config-if)#ip address 20.1.1.254 255.255.255.0
    switch-S3560(config-if)#int vlan 3
    switch-S3560(config-if)#ip address 30.1.1.254 255.255.255.0
    说明:配置了 SVI 地址用户作为客户端的网关,后续 DHCP 也根据对应的 VLAN 找到对应的地址池分配。
    DHCP 配置
    switch-S3560(config)#service dhcp (可选,默认情况下思科大部分设备都是开启了该服务的)
    基于 VLAN2 的地址池
    switch-S3560(config)#ip dhcp pool vlan2 (创建一个地址池,命名为 VLAN2)
    switch-S3560(dhcp-config)#network 20.1.1.0 255.255.255.0 (分配的网段为 20.1.1.0/24)
    switch-S3560(dhcp-config)#default-router 20.1.1.254 (分配的网关为 20.1.1.254)
    switch-S3560(dhcp-config)#dns-server 88.1.1.253 (分配的 DNS 为 88.1.1.253,可以有 2 个)
    说明:这些是常见的配置,配置 DHCP 最基础 也最需要用到的,当然还有一些配置。
    1、lease:思科设备默认为 1 天,可以修改为自己需要的时间 lease 0 1,表示 0 天,1 小时
    2、domain-name:域名cbc.com
    3、netbios-name-server:wins 服务器
    4、Option:DHCP 的一些选项,比如语音服务器的 150,告诉 AC 地址的 option43 等
    基于 VLAN3 的地址池
    switch-S3560(config)#ip dhcp pool vlan3
    switch-S3560(dhcp-config)#network 30.1.1.0 255.255.255.0
    switch-S3560(dhcp-config)#default-router 30.1.1.254
    switch-S3560(dhcp-config)#dns-server 88.1.1.253
    4、验证 PC 是否能够获取到
    5、优化端口与地址排除
    在常见的 DHCP 部署中,很容易遇到的问题就是,当客户端接入进去,获取地址很慢,或者是获取不到地址,但是 DHCP
    是没问题的,很常见的问题就是生成树导致的,PC 接入的时候,生成树要计算,花费 30s 的时间,所以容易造成获取地址
    不到的情况,可以配置 STP 的快速端口,来解决该问题,跳过生成树的检查。
    switch-S260(config)#interface range f0/1 - 2
    switch-S260(config-if-range)#spanning-tree portfast
    地址排除问题
    地址排错的机制是为了排除掉,已经用掉的地址,比如网关,DNS 已经固定了,需要在分配的网段内排除掉,不分配个下面
    的客户端。
    switch-S3560(config)#ip dhcp excluded-address 20.1.1.254
    switch-S3560(config)#ip dhcp excluded-address 30.1.1.254
    这里就是说,排除掉已经用在网关的地址,不过现在大部分的 DHCP 服务器已经不需要排除了,有检测机制来完成.
    问题:为什么交换机能够知道 VLAN2 就分配 20.1.1.0 网段,而 VLAN3 就是 30.1.1.0 呢?
    这个跟配置的 SVI 有关,当 VLAN2 的用户发送 DHCP 请求后,三层交换机的 VLAN2 收到后,由于 VLAN2 的 SVI 对应的是 20.1.1.254,它会查找 DHCP 的配置有没有 20.1.1.0 这个网段的地址池,查找到了就通过该地址池分配一个没有使用的地址给用户,VLAN3 同理。
    在交换机里面应用 DHCP 中继功能有时候我们企业环境的 DHCP 是单独用 Windows 或者 Linux 服务器搭建的,而并不是部署在网络设备上面,那么我们就需要用到一种技术,叫做中继功能,因为 DHCP 是广播形式发送的,也就是说在同一个 VLAN 或者广播域内,DHCP 是可以响应请求,但是在跨网段也就是不是同一个广播域内,那么就没办法响应请求了,这时候需要通过中继技术,把广播转换为单播请求发送给 DHCP 服务器。修改与需要添加的配置(3560 上)

    展开全文
  • DHCP(动态主机配置协议)是一个局域网的网络协议。指的是由服务器控制一段lP地址范围,客户机登录服务器时就可以自动获得服务器分配的lP地址和子网掩码。默认情况下,DHCP作为Windows Server的一个服务组件不会被...
  • 思科交换机dhcp配置

    2021-10-13 19:55:12
    **PS: 1.sw是switchport缩写 2.m是mode缩写 3.acc是access缩写 4.all是allowed缩写 ...交换机1: Switch(config)#(在全局模式下进行) VLAN 10 VLAN 20 int f0/2 sw m acc sw acc all vlan 10 no sh ex .

    在这里插入图片描述

    **PS:
    1.sw是switchport缩写
    2.m是mode缩写
    3.acc是access缩写
    4.all是allowed缩写
    5.sh是shotdown缩写
    6.tr是trunk缩写
    7.ex是excluded-address缩写
    8.add是address缩写
    9.def是default-router缩写
    10.ex是exit缩写
    **

    交换机1:
    Switch(config)#(在全局模式下进行)
    VLAN 10
    VLAN 20
    int f0/2
    sw m acc
    sw acc vlan 10
    no sh
    ex
    int f0/3
    sw m acc
    sw acc vlan 20
    no sh
    ex
    int f0/1
    sw m tr
    sw tr all vlan 10,20
    no sh

    交换机2:
    Switch(config)#(在全局模式下进行)
    VLAN 30
    VLAN 40
    int f 0/2
    sw m acc
    sw acc vlan 30
    no sh
    ex
    int f0/3
    sw m acc
    sw acc vlan 40
    no sh
    ex
    int f0/1
    sw m tr
    sw tr all vlan 30,40
    no sh

    交换机0:
    Switch(config)#(在全局模式下进行)
    VLAN 10
    VLAN 20
    VLAN 30
    VLAN 40
    int f0/1
    sw m tr
    sw tr all vlan 10,20,30,40
    no sh
    ex
    int f0/2
    sw m tr
    sw tr all vlan 10,20
    no sh
    ex
    int f0/3
    sw m tr
    sw tr all vlan 30,40
    no sh

    MS0:(最上面的交换机)
    Switch(config)#(在全局模式下进行)
    vlan 10
    vlan 20
    vlan 30
    vlan 40
    int f0/1
    sw tr all vlan 10,20,30,40
    ex
    ip dhcp ex 192.168.10.1
    ip dhcp ex 192.168.20.1
    ip dhcp ex 192.168.30.1
    ip dhcp ex 192.168.40.1
    int vlan 10
    ip add 192.168.10.1 255.255.255.0
    ip routing
    ip dhcp pool 10
    network 192.168.10.0 255.255.255.0
    def 192.168.10.1
    ex
    int vlan 20
    ip add 192.168.20.1 255.255.255.0
    ip routing
    ip dhcp pool 20
    network 192.168.20.1 255.255.255.0
    def 192.168.20.1
    ex
    int vlan 30
    ip add 192.168.30.1 255.255.255.0
    ip routing
    ip dhcp pool 30
    network 192.168.30.0 255.255.255.0
    def 192.168.30.1
    ex
    int vlan 40
    ip add 192.168.40.1 255.255.255.0
    ip routing
    ip dhcp pool 40
    network 192.168.40.0 255.255.255.0
    def 192.168.40.1

    最后回到pc上
    单击pc0 选择Desktop
    在这里插入图片描述
    点击第一个图案(带有106的)
    在这里插入图片描述
    将Static换为DHCP
    自动分配地址
    上图是已更换的
    剩余pc配置方法一致
    最后使用pc相互ping看是否通信正常

    展开全文
  • Cisco思科三层交换机配置DHCP服务

    万次阅读 多人点赞 2020-01-22 16:53:01
    为什么使用三层交换机配置DHCP服务器而不用专门的服务器做DHCP服务器呢? 在小型网络中直接将DHCP服务直接配置在核心三层交换机上便于网络管理员管理。在大型网络拓扑中还是建议使用单独的DHCP服务器做,可以节省...

    为什么使用三层交换机配置DHCP服务器而不用专门的服务器做DHCP服务器呢?

    在小型网络中直接将DHCP服务直接配置在核心三层交换机上便于网络管理员管理。在大型网络拓扑中还是建议使用单独的DHCP服务器做,可以节省网络设备的性能,另外图形界面,也方便查看。

    业务需求:
    将三层交换机配置为DHCP服务器,为每个VLAN分配IP地址,每个VLAN有自己的网段
    人事部、财务部、生产部、采购部分别属于VLAN10、VLAN20、VLAN30、VLAN40
    VLAN10: 192.168.10.0/24       网关:192.168.10.1
    VLAN20: 192.168.20.0/24       网关:192.168.20.1
    VLAN30: 192.168.30.0/24       网关:192.168.30.1
    VLAN40: 192.168.40.0/24       网关:192.168.40.1
    注意:创建DHCP地址池要将网关地址做排除。Switch5和Switch8的F0/4端口已经被管理性关闭了,开启的话会使SW0/SW5/SW8产生网络回路,引起网络风暴,下一篇博客我会写打开这个端口而如何避免这样的问题。

     

    网络拓扑:

    网络配置:

    Switch5:
    SW5#conf t
    SW5(config)#vlan 10					        //创建两个VLAN
    SW5(config-vlan)#vlan 20
    SW5(config-vlan)#int f0/2					//给端口分别划分VLAN
    SW5(config-if)#switchport mode access
    SW5(config-if)#switchport access vlan 10
    SW5(config-if)#no shutdown
    SW5(config-if)#exit
    SW5(config)#int f0/3
    SW5(config-if)#switchport mode access
    SW5(config-if)#switchport access vlan 20
    SW5(config-if)#no shutdown
    SW5(config-if)#exit
    SW5(config)#int f0/1					        //设置端口为trunk模式
    SW5(config-if)#switchport mode trunk
    SW5(config-if)#switchport trunk allowed vlan 10,20
    SW5(config-if)#no shutdown
    SW5(config-if)#exit
    
    Switch8:
    SW8#conf t
    SW8(config)#vlan 30
    SW8(config-vlan)#vlan 40
    SW8(config-vlan)#int f0/2
    SW8(config-if)#switchport mode access
    SW8(config-if)#switchport access vlan 30
    SW8(config-if)#no shutdown
    SW8(config-if)#exit
    SW8(config)#int f0/3
    SW8(config-if)#switchport mode access
    SW8(config-if)#switchport access vlan 40
    SW8(config-if)#no shutdown
    SW8(config-if)#exit
    SW8(config)#int f0/1
    SW8(config-if)#switchport mode trunk
    SW8(config-if)#switchport trunk allowed vlan 30,40
    SW8(config-if)#no shutdown
    SW8(config-if)#exit
    
    Switch0
    SW0#conf t
    SW0(config)#vlan 10					//创建4个VLAN
    SW0(config-vlan)#vlan 20
    SW0(config-vlan)#vlan 30
    SW0(config-vlan)#vlan 40
    SW0(config-vlan)#int f0/1
    SW0(config-if)#switchport mode trunk			//设置端口1为trunk模式,允许VLAN10,20,30,40的流量通过
    SW0(config-if)#switchport trunk allowed vlan 10,20,30,40
    SW0(config-if)#no shutdown
    SW0(config-if)#exit
    SW0(config)#int f0/2
    SW0(config-if)#switchport mode trunk
    SW0(config-if)#switchport trunk allowed vlan 10,20
    SW0(config-if)#no shutdown
    SW0(config-if)#exit
    SW0(config)#int f0/3
    SW0(config-if)#switchport mode trunk
    SW0(config-if)#switchport trunk allowed vlan 30,40
    SW0(config-if)#no shutdown
    SW0(config-if)#exit
    
    Multilayer Switch2
    SW2#conf t
    SW2(config)#vlan 10						//创建4个VLAN
    SW2(config-vlan)#vlan 20
    SW2(config-vlan)#vlan 30
    SW2(config-vlan)#vlan 40
    SW2(config-vlan)#int f0/1					//设置f0/1的端口模式
    SW2(config-if)#switchport trunk allowed vlan 10,20,30,40	//三层交换机不用先配置为trunk模式
    SW2(config-if)#exit
    SW2(config)#ip dhcp excluded-address 192.168.10.1		//对DHCP地址池地址做排除
    SW2(config)#ip dhcp excluded-address 192.168.20.1
    SW2(config)#ip dhcp excluded-address 192.168.30.1
    SW2(config)#ip dhcp excluded-address 192.168.40.1
    SW2(config)#int vlan 10						//设置VLAN10的IP地址。三层交换机与路由器的不同之处,不能用单臂路由,划分子端口,所以用此方法分别设置VLAN的地址作为每个DHCP地址池的网关地址
    SW2(config-if)#ip address 192.168.10.1 255.255.255.0
    SW2(config-if)#ip routing					//开启VLAN间路由的功能
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 10					//创建DHCP地址池10
    SW2(config-dhcp)#network 192.168.10.0 255.255.255.0		//设置DHCP地址池网段
    SW2(config-dhcp)#default-router 192.168.10.1			//设置默认网关地址。这里设置为VLAN10的IP地址,所有VLAN10的主机通过这个网关地址获取IP
    SW2(config-dhcp)#exit
    SW2(config)#int vlan 20						
    SW2(config-if)#ip address 192.168.20.1 255.255.255.0
    SW2(config-if)#ip routing
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 20					//创建DHCP地址池20
    SW2(config-dhcp)#network 192.168.20.0 255.255.255.0
    SW2(config-dhcp)#default-router 192.168.20.1
    SW2(config-dhcp)#exit
    SW2(config)#int vlan 30
    SW2(config-if)#ip address 192.168.30.1 255.255.255.0
    SW2(config-if)#ip routing
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 30					//创建DHCP地址池30
    SW2(config-dhcp)#network 192.168.30.0 255.255.255.0
    SW2(config-dhcp)#default-router 192.168.30.1
    SW2(config-dhcp)#exit
    SW2(config)#int vlan 40
    SW2(config-if)#ip address 192.168.30.1 255.255.255.0
    SW2(config-if)#ip routing
    SW2(config-if)#exit
    SW2(config)#ip dhcp pool 40					//创建DHCP地址池30
    SW2(config-dhcp)#network 192.168.40.0 255.255.255.0
    SW2(config-dhcp)#default-router 192.168.40.1
    SW2(config-dhcp)#exit

    本文原创,转载请注明出处。

     

    展开全文
  • 思科交换机VLAN,DHCP配置模拟实例

    千次阅读 2020-10-10 15:15:04
    2.开始准备工作,f0/1接左边交换机,f0/2接右边交换机,实际工作中,一定要接这个口,你要是接反了或者接到其他口去,获取的IP就不对了 3.点击最上面那个交换机,开始配置(图里的交换机型号有误,应该是2960) 4....

    1.要求:
    左边的电脑自动获取IP为192.168.1.1段
    右边的电脑自动获取IP为192.168.2.1段
    在这里插入图片描述
    2.开始准备工作,f0/1接左边交换机,f0/2接右边交换机,实际工作中,一定要接这个口,你要是接反了或者接到其他口去,获取的IP就不对了
    在这里插入图片描述

    3.点击最上面那个交换机,开始配置(图里的交换机型号有误,应该是2960)
    在这里插入图片描述
    4.建立 vlan 10并分配IP地址
    Switch>
    Switch>enable
    Switch#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#interface vlan 10
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    Switch(config)#
    在这里插入图片描述
    5.配置DHCP地址池和相应参数(实际运用中你可能上不去网,改下DNS地址就行了)
    Switch(config)#ip dhcp pool 10 (建立名为 10 的地址池)
    Switch(dhcp-config)#network 192.168.1.0 255.255.255.0(网络地址)
    Switch(dhcp-config)#dns-server 192.168.1.1(DNS 地址)
    Switch(dhcp-config)#default-router 192.168.1.1(默认网关)
    Switch(dhcp-config)#exit
    Switch(config)#ip dhcp excluded-address 192.168.1.1(设置保留不分配的 IP地址)
    Switch(config)#exit
    Switch#
    在这里插入图片描述
    6.进入端口 f0/1 ,并把端口加入vlan 10
    Switch(config)#interface f0/1
    Switch(config-if)#switchport access vlan 10 (打完这个还要按一次回车,如图)
    附:删除vlan和多个端口加入vlan,这个我没有试
    在这里插入图片描述
    在这里插入图片描述
    7.查看电脑端是否能自动获取IP
    在这里插入图片描述
    在这里插入图片描述
    8.再加两台电脑,依旧正常获取IP,左边设置完成在这里插入图片描述
    9.设置右边交换机,重复456即可,依旧在最上面那个交换机里设置,全命令如下
    Switch>enable
    Switch#conf t
    Switch(config)#interface vlan 20
    Switch(config-if)#ip address 192.168.2.1 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    Switch(config)#ip dhcp pool 20
    Switch(dhcp-config)#network 192.168.2.1 255.255.255.0
    Switch(dhcp-config)#dns-server 192.168.2.1
    Switch(dhcp-config)#default-router 192.168.2.1
    Switch(dhcp-config)#exit
    Switch(config)#ip dhcp excluded-address 192.168.2.1
    Switch(config)#exit

    Switch#conf t
    Switch(config)#interface f0/2
    Switch(config-if)#switchport access vlan 20
    在这里插入图片描述
    在这里插入图片描述
    10.模拟实验完成。
    注:vlan 10和 vlan 20 是不能互通的,互通要额外的设置,这个还不会,哪天学会了补上来

    展开全文
  • 这里我们主要讲解了思科交换机配置DHCP的相关内容。我们对网络拓扑先进行一下了解,然后对于其在进行一下说明,之后对于配置的代码和命令再进行一下解析。 思科交换机配置DHCP一、网络拓扑 思科交换机配置DHCP...
  • cisco交换机DHCP分配静态IP

    千次阅读 2019-09-18 06:58:10
    这里我们以vlan31进行描述 ip dhcp pool vlan31network 172.31.255.0 255.255.255.0default-router 172.31.255.254 ...1、先将特殊IP地址从dhcp中剔除掉,以免后面造成ip地址冲突ip dhcp excluded-address 172.31.25...
  • Cisco交换机DHCP Snooping功能详解+实例

    千次阅读 2018-03-31 10:56:57
    一、采用DHCP服务的常见问题 架设DHCP服务器...但在DHCP服务的管理上存在一些问题,常见的有: ·DHCP Server的冒充 ·DHCP Server的DOS***,如DHCP耗竭***·某些用户随便指定IP地址,造成IP地址冲突 1、DHCP Ser...
  • 公司网络使用思科3650交换机(自带AP控制器)和3个3702AP来做无线热点,公司里有几台打印机,我想把这些打印机的IP在交换机DHCP服务中固定下来,通常命令是: ip dhcp pool printer-a4-hp-m277dw host 192.168.1....
  • 思科三层交换机配置DHCP中继

    千次阅读 2021-03-20 11:52:04
    三层交换机配置DHCP中继 实验目的: 通过本实验掌握如何给不同网段配置DHCP,掌握DHCP中继配置。 实验拓扑: 对交换机SW1进行预配置。 Switch>en Switch#conf t Enter configuration commands, one per line. ...
  • 一、关于DHCP的欺骗***1、一个DHCP的***者,同样可以在一个VLAN中提供SERVER服务2、DHCP***者会应答DHCP客户端的发送请求信息3、***者会分配IP地址等信息和默认网关给DHCP客户端说明:在一个VLAN中存在多个DHCP...
  • 交换机配置DHCP侦听

    2021-04-30 21:30:19
    简述思科交换机DHCP侦听设置
  • 说明:有3个VLAN,VLAN2与VLAN3是用户VLAN,而VLAN 88则是DHCP服务器的VLAN,在实验演示一中,DHCP服务器不会使用,因为实验一是演示的,部署在交换机上面,DHCP服务器则在后续中继的过程中使用到。 地址规划 VLAN...
  • IPV4 DHCP中继服务器之思科交换机配置 标题:IPV4 DHCP中继服务器配置 + 思科交换机配置 + DHCP服务器配置 一、DHCP服务器配置 网络拓扑图 DHCP服务器分配3个子网,分别为100.100.100.0/24 100.100.20.0/24 100.100....
  • DHCP中继配置(思科

    千次阅读 2020-01-18 11:35:19
    思路: 1、配置 DHCP 客户端 确保每个 PC 为 自动获取IP地址的方式; 2、配置SW1、SW2、SW3、SW4 ... 使交换机之间互相学习VLAN表(VTP思科私有协议、交换机打通trank连接后配置) 4、配置SW1、SW2、SW3 ...
  • 这些全部是我自己总结和结论,感觉我提供的知识点不错的,可以给我点个关注!也可以进行私聊讨论。 实验 注:vlan10-192.168.10.0/24 ...Vlan20-192.168.20.0/24 ...在R1上配置DHCP,在SW1上配置...
  • 思科 DHCP服务器配置及DHCP中继

    千次阅读 2018-01-15 14:00:26
    思路:1、配置 DHCP 客户端 确保每个 PC 为 自动获取IP地址的方式;2、配置 SW1 # 创建 VLAN 10 , 20 # 将相关的端口,放入到对应的 VLAN ; # 配置交换机之间的互联链路 - Trunk ;3、配置 SW # 创建 VLAN 10 ...
  • 思科DHCP中继配置实例

    2021-04-10 21:54:31
    DHCP中继代理实验 一.简介 1.什么是DHCP中继 DHCPRelay(DHCPR)DHCP中继(也叫做DHCP中继代理)是DHCP衍生出来的一个新技术,其功能是可以实现在不同子网之间处理和转发dhcp信息的功能。 2.DHCP中继工作原理 1....
  • cisco交换机开启dhcp服务

    千次阅读 2017-11-27 13:57:00
    拓扑图如下: 上述设备用途说明: 1、使用R1做dhcp server 2、使用R2和R3代替电脑做... 3、SW1用做傻瓜交换机dhcp server配置(R1配置): 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 2...
  • 思科 三层交换 DHCP 的配置

    千次阅读 2018-12-22 16:06:54
    思科 三层交换 DHCP 的配置 :   拓扑结构:   步骤: 在SW1和SW2上分别完成VLAN配置,并在VLAN中添加相应的端口成员,同时配置Trunk端口      在L3Switch 上创建VLAN10 和VLAN20 ,并配置VLAN10 的虚...
  • 思科设备配置DHCP命令

    万次阅读 多人点赞 2019-03-24 14:16:45
    DHCP(Dynamic Host Configuration Protocol)基本知识点: 1 、DHCP协议在RFC2131中定义,使用udp协议进行数据报传递,使用的端口是67(DHCP服务器)和68(DHCP客户端)。 2 、DHCP最常见的应用是,自动给终端...
  • 思科DHCP配置命令

    千次阅读 2021-09-24 10:55:45
    DHCP配置 ip dhcp pool VLAN10 //定义DHCP地址池VLAN10为vlan id network 172.16.2.0 255.255.255.0 //配置地址池的网络和掩码 ...domain-name cisco.com //域名,可选配置 dns-server 172.16.1....
  • 思科DHCP的配置和DHCP中继的配置

    千次阅读 多人点赞 2019-06-02 19:38:46
    三层设备充当DHCP服务器的配置 拓扑图 主要应用于小型企业上,直接在三层设备上开启DHCP服务,为用户分配地址 直接在三层设备(SW1)上配置 interface Vlan10 ip add 192.168.10.254 255.255.255.0 ...
  • 思科简单DHCP配置实验

    千次阅读 2019-11-29 22:57:38
    DHCP(动态主机配置协议)是一个局域网的网络协议。指的是由服务器控制一段lP地址范围,客户机登录服务器时就可以自动获得服务器分配的lP地址和子网掩码。默认情况下,DHCP作为Windows Server的一个服务组件不会被...
  • 也可以在路由器上配置DHCP,然后在三层交换机上设置DHCP中继,DHCP客户端通过三层交换机中继获取IP地址 路由器上实现dhcp的优点: 给多个三层交换机的多个相同vlan配置,不用再对每一个三层交换机进行配置 网络...
  • 思科交换机作为DHCP

    2017-12-14 02:12:49
    实验名称:交换机作为DHCP实验目的:PC1与PC2不同网段互通实验拓扑 配置思路:1.在二层交换机设置vlan10 20,与PC的端口对应为access与三层交换机对应端口为trunk2.在二层交换机设置DHCP配置,设置vlan 1 的ip与三层...
  • 思科DHCP静态绑定分发地址

    千次阅读 2017-07-01 13:37:46
    ip dhcp pool chenjia host 192.168.0.101 255.255.255.0 client-identifier 0100.1617.9003.EA default-router 192.168.0.1 dns-server 8.8.8.8 第一句话 建立一个地址池,名字叫chenjia 第二句话...
  • 三层交换机作为DHCP服务器,路由器作为DHCP中继,PC通过DHCP中继获取IP地址 实验拓扑: 配置步骤: 1. 配置路由器和三层交换机端口IP地址 Router6: R6#conf t R6(config)#int f0/0 R6(config-if)#ip address ...
  •  即在VLAN66中存在一台DHCP服务器,它除了要为本网段中的DHCP客户端分配IP地址外,还要为VLAN75网段的DHCP客户端分配IP地址。  二、P服务器上新建为VLAN75分配IP地址的作用域  如图2所示:  因为我们是实验...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,978
精华内容 1,191
关键字:

思科交换机dhcp