精华内容
下载资源
问答
  • 本文对交换机端口汇聚配置进行说明

    配置思科交换机冗余链路汇聚

     


    一、端口聚合技术(EtherChannel)

    EtherChannel是Cisco研发的,应用于交换机之间的多链路捆绑技术。

    EtherChannel的基本原理和作用是:

    1.增加带宽

    将两个设备间多条相同特性的快速以太或千兆物理链路捆绑在一起组成一条逻辑链路,从而达到带宽倍增的目的。

    2.链路冗余

    除了增加带宽外,EtherChannel还可以在多条链路上均衡分配流量,起到负载均衡的作用;当一条或多条链路故障时,只要还有链路正常,流量将转移到其他的链路上,整个过程在几毫秒内完成,从而起到链路冗余的作用,增强了网络的稳定性和安全性。在EtherChannel中,负载在各个链路上的分布可以根据源IP地址、目的IP地址、源MAP地址、目的MAC地址、源IP地址和目的IP地址组合,以及源MAC地址和目的MAC地址组合等来进行分布。


    二、端口汇聚协议

    两台交换机之间是否形成EtherChannel也可以采用协议自动协商。

    目前有两种PAgP(端口汇聚协议)和LACP(链路汇聚控制协议)协商协议。

    PAgP(端口汇聚协议,Port Aggregation Protocol)是Cisco的私有协议。

    LACP(链路汇聚控制协议,Link Aggregation Protocol)是基于IEEE802.3ad的国际标准。


    三、链路汇聚语法

    channel-group+编号+mode+auto/on/desirable

    其中,auto:被动协商,on:不协商,desirable:主动协商。


    四、配置冗余链路汇聚

    1.创建和定义port-channel端口

    swtich-core#config terminal

    swtich-core(config)#interface prot-channel 10

    swtich-core(config-if)#no switchport

    2.分配ip地址

    swtich-core(config-if)#ip address 192.168.102.1 255.255.255.0

    swtich-core(config-if)#no shutdown

    swtich-core(config-if)#exit

    4.分配端口,并启用端口汇聚

    swtich-core(config)#interface range fastEthernet 0/1-4

    swtich-core(config-if-range)#no switchport

    swtich-core(config-if-range)#no ip address

    swtich-core(config-if-range)#channel-group 10 mode on

    swtich-core(config-if-range)#no shutdown

    swtich-core(config-if-range)#exit

    5.添加路由

    swtich-core(config)#ip route 192.168.40.0 255.255.255.0 192.168.102.2

    展开全文
  • 两台主交换机配置冗余路由器,使用Cisco热备用路由器协议将虚拟IP地址连接在一起。所有设备的网关地址是各自子网之外的虚拟地址。 sw1 程序 vlan 400 name l1 exit ! vlan 500 name l2 exit ! vlan 600

    以太网设计为冗余星形。这意味着每个本地开关(Catalyst 2960)都连接到每个主开关(Catalyst 3750)。由于不同VLAN之间的路由(参见本章)是由主交换机完成的,因此在本地交换机或主交换机上的连接断开的情况下,此功能也可以工作。 两台主交换机都配置为冗余路由器,使用Cisco热备用路由器协议将虚拟IP地址连接在一起。所有设备的网关地址是各自子网之外的虚拟地址。
    请添加图片描述
    sw1 程序
    vlan 400
    name l1
    exit
    !
    vlan 500
    name l2
    exit
    !
    vlan 600
    name 13
    exit
    !
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname 1SW1
    !
    enable secret cisco
    !
    username cisco privilege 15 secret cisco
    no aaa new-model
    switch 1 provision ws-c3750g-12s

    展开全文
  • 一、交换机配置方式1、Console将配置电缆的DB-9(或DB-25)孔式插头 接到要对交换机进行配置的微机或终端的串口上。首先启动超级终端,点击windows的开始→程序→附件→通讯→超级终端,启动超级终端。根据提示输入...

    一、交换机的配置方式

    1、Console

    将配置电缆的DB-9(或DB-25)孔式插头 接到要对交换机进行配置的微机或终端的串口上。

    首先启动超级终端,点击windows的开始→程序→附件→通讯→超级终端,启动超级终端。

    根据提示输入连接描述名称后确定,在选择连接时使用相应的COM口(可通过设备管理器查看COM口)后单击"确定"按钮,在弹出的COM1属性窗口中单击"还原为默认值"按钮后单击"确定"按钮。

    17fd4bab69b29ea3dfe54963cd296490.png
    f04b0fe0c9417e1e4a1505d3c1c2ea5f.png
    fd993fad6f43eebffd74f54fda4ba811.png

    2、telnet

    switch>enable

    switch#configure terminal

    switch(conf)#enable password cisco //以cisco为特权模式密码(使用telnet必须配置特权密码)

    switch(conf)#line vty 0 4 //设置0-4个用户可以telnet远程登陆

    switch(conf-line)#login

    switch(conf-line)#password 123456

    //以123456为远程登录的用

    户密码

    以上命令打开交换机telnet功能,至此可以通过telnet命令访问并管理此交换机。

    二、设备管理

    1、配置交换机名称

    switch(conf)#hostname CoreSwitch

    CoreSwitch(conf)#

    2、保存配置

    switch#write

    或 //特权模式保存配置

    switch#copy run start

    3、交换机重启

    switch#reload

    4、恢复出厂默认恢复命令

    switch#write erase

    switch#reload

    三、端口配置

    1、端口配置

    switch (conf)#interface g1/1 //以第1块板卡的1号端口为例

    switch (conf-if)#duplexfull/half/auto //更改双工模式

    switch (conf-if)#speed 10/100/1000 //更改端口速率、

    switch (conf-if)#shutdown //关闭端口

    switch (conf-if)#no shutdown //启用端口

    2、端口聚合

    端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。由于两个交换机之间有多条冗余链路的时候,STP会将其中的几条链路关闭,只保留一条,这样可以避免二层的环路产生。但是,失去了路径冗余的优点,因为STP的链路切换会很慢,在50s左右。使用以太通道的话,交换机会把一组物理端口联合起来,做为一个逻辑的通道,也就是channel-group,这样交换机会认为这个逻辑通道为一个端口,同时提高链路带宽。

    Switch#config

    Switch (Config)#interface range g1/2-3 //进入第1块板卡的2、3号端口

    Switch (Config-Port-Range)#port-group 1 mode on //设置端口聚合方式为手动

    Switch (Config-Port-Range)#exit

    Switch (Config)#interface port-channel 1 //进入聚合端口

    Switch (Config-If-Port-Channel1)#swithport mode trunk //配置聚合端口为trunk

    Switch (Config-If-Port-Channel1)#no shutdown //启用聚合端口

    四、VLAN虚拟局域网

    VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。VLAN是一种将局域网设备从逻辑上划分成一个个网段,从而实现虚拟工作组的数据交换技术。注意:如果交换机接口处于no switchport状态属于三层接口,无法加入到vlan中,需要进入端口执行switchport命令。

    例:switch(config)# interface g1/1

    switch(config-if)# switchport

    1、配置VLAN

    switch# configure terminal //进入全局配置模式

    switch(config)# vlan 10 //配置VLAN 10

    switch(config-vlan)# name JK // VLAN命名为JK

    switch(config-vlan)#exit

    switch(config)# interface g1/1 //进入指定端口

    switch(config-if)# switchprot access vlan 10 //将端口划入VLAN

    端口选择技巧:

    switch(config)# interface range g1/1–5 //选择连续多个端口

    switch(config)# interface range g1/6-8,1/9-11,1/22  //将不连续多个端口加入到Vlan中

    2、配置TRUNK透传模式

    switch(config)# interface g1/1 //进入指定端口

    switch(config-if)# switchport mode trunk //配置接口为TRUNK模式

    //默认配置完trunk后,允许所有VLAN ID通过

    switch(config-if)# switchport trunk allowed vlan remove 20

    //配置移除trunk允许通过的VLAN ID

    switch(config-if)# switchport trunk allowed vlan add 20

    //配置添加trunk允许通过的VLAN ID

    五、IP协议配置

    1、为VLAN配置IP地址

    switch(config)#interface VLAN 233 //进入VLAN虚拟接口

    switch(config-if)#ip address 192.168.1.1 255.255.255.0 //配置IP地址及掩码

    switch(config-if)#no shutdown //启用接口

    2、添加静态路由

    switch(config)#ip route 目的地址网段 目的网络子网掩码 下一条地址

    //配置视图下配置

    例:switch(config)#ip route 192.168.6.0 255.255.255.0 192.168.2.2

    六、组播

    1、PIM-SM

    PIM-SM(Protocol Independent Multicast,Sparse Mode)即与协议无关的组播稀疏模式,属于稀疏模式的组播路由协议。PIM-SM主要用于组成员分布相对分散、范围较广、大规模的网络。

    与密集模式的扩散/剪枝不同,PIM-SM协议假定所有的主机都不需要接收组播数据包,只有主机明确指定需要时,PIM-SM路由器才向它转发组播数据包。

    PIM-SM协议中,通过设置汇聚点RP(Rendezvous Point)和自举路由器BSR(Bootstrap Router),向所有PIM-SM路由器通告组播信息,并利用路由器的加入/剪枝信息,建立起基于RP的共享树RPT(RP-rooted shared tree)。从而减少了数据报文和控制报文占用的网络带宽,降低路由器的处理开销。组播数据沿着共享树流到该组播组成员所在的网段,当数据流量达到一定程度,组播数据流可以切换到基于源的最短路径树SPT,以减少网络延迟。PIM-SM不依赖于特定的单播路由协议,而是使用现存的单播路由表进行RPF检查。

    运行PIM-SM协议,需要配置候选RP和BSR,BSR负责收集候选RP发来的信息,并把它们广播出去。

    2、PIM-DM

    PIM-DM(Protocol Independent Multicast,Dense Mode)属于密集模式的组播路由协议。PIM-DM适用于小型网络,在这种网络环境下,组播组的成员相对比较密集。PIM-DM的工作过程可以概括为:邻居发现、扩散、剪枝过程、嫁接阶段。

    3、配置举例

    1、使能组播路由

    switch(conf)#ip multicast-routing

    2、进入接口

    switch(conf)#interface Vlan233

    3、在接口上启动PIM SM或DM

    switch(conf-if)# ip pim sparse-dense-mode //稀疏密集模式

    ip pim sparse-mode//稀疏模式

    ip pim dense-mode//密集模式

    如果是二层交换机,则只需在系统视图下配置igmp-snooping即可

    七、双机热备

    switch(conf)#redundancy //进入热备配置视图

    switch(conf-red)#main-cpu //配置同步配置文件

    switch(conf-red)mode sso //配置热备模式为SSO

    八、查看交换机信息及排错常用命令

    1、Show

    switch(conf)#show run //查看当前运行配置信息

    switch(conf)#show vlan brief //显示VLAN配置信息

    switch(conf)#show ip route //显示路由表

    switch(conf)#show interface XX //显示指定端口信息

    switch(conf)#Show interfaces //显示设置在路由器和访问服务器上所有接口的统计信息

    switch(conf)#Show ip interface //列出一个接口的IP信息和状态的小结

    switch(conf)#Show version //显示系统硬件的配置,软件的版本,配置文件的名称和来源及引导映像

    switch(conf)#Show memory //显示路由器内存的大小,包括空闲内存的大小

    switch(conf)# Show processes //显示路由器的进程

    switch(conf)#Show flash //显示闪存的布局和内容信息

    2、debug

    对于路由器和交换机的故障诊断,只用一个 show 命令是远远不够的。而 debug 命令往往能够帮助我们看清楚背后的故障原因。

    Switch#debug // 显示所有可用的debug指令及简短的说明

    Switch #show debugging //显示当前各个调试开关的状态

    Switch #debug all //打开系统所有的调试开关

    Switch #undebug all //关闭所有的调试开关

    Switch #debug arp //打开ARP调试开关

    Switch #debug igmp //打开IGMP调试开关

    Switch #debug ip //打开IP调试开关

    Switch #debug multicast //打开多播数据流调试开关

    Switch #debug pim //打开PIM调试开关

    Switch #debug vlan //打开VLAN调试开关

    展开全文
  • 思科交换机基本配置 交换机是局域网中最重要的设备,交换机是基于 MAC 来进行工作的。和路由器类似,交换 机也有 IOS,IOS 的基本使用方法是一样的。本章将简单介绍交换机的一些基本配置,以及交换 机独特的密码恢复...

    思科交换机基本配置

    交换机是局域网中最重要的设备,交换机是基于 MAC 来进行工作的。和路由器类似,交换
    机也有 IOS,IOS 的基本使用方法是一样的。本章将简单介绍交换机的一些基本配置,以及交换
    机独特的密码恢复、IOS 恢复步骤。关于 VLAN、Trunk 等将在后面章节介绍。

    交换机简介

    交换机是第二层的设备,可以隔离冲突域。交换机是基于收到的数据帧中的源 MAC 地址和目的 MAC 地址来进行工作。交换机的作用主要有这么两个:一个是维护 CAM(Context Address Memory)表,该表是 MAC 地址和交换机端口的映射表;另一个是根据 CAM 来进行数据帧的转发。交换机对帧的处理有三种:交换机收到帧后,查询 CAM 表,如果能查询到目的计算机所在的端口,并且目的计算机所在的端口不是交换机接收帧的源端口,交换机将把帧从这一端口转发出去(Forward);如果该计算机所在的端口和交换机接收帧的源端口是同一端口,交换机将过滤掉该帧(Filter);如果交换机不能查询到目的计算机所在的端口,交换机将把帧从源端口以外的其他所端口上发送出去,这称为泛洪(Flood),当交换机接收到的是帧是广播帧或者多播帧,交换机也会泛洪帧。

    952608-20171031013026105-619530256.png

    三种交换方式的比较

    以太网交换机转发数据帧有三种交换方式:

    (1) 存储转发(Store-and-Forward)

    存储转发方式是先存储后转发的方式。它把从端口输入的数据帧先全部接收并存储起来;
    然后进行 CRC(循环冗余码校验)检查,把错误帧丢弃;最后才取出数据帧目的地址,查找地
    址表后进行过滤和转发。存储转发方式延迟大;但是它可以对进入交换机的数据包进行高级别
    的错误检测。这种方式可以支持不同速度的端口间的转发。

    (2) 直接转发(Cut-Through)

    交换机在输入端口检测到一个数据帧时,检查该帧的帧头,只要获取了帧的目的地址,就
    开始转发帧。它的优点是:开始转发前不需要读取整个完整的帧,延迟非常小。它的缺点是:
    不能提供错误检测能力。

    (3) 无碎片(Fragment-Free)

    这是改进后的直接转发,是介于前两者之间的一种解决方法。无碎片方法在读取数据帧的
    长前 64 个字节后,就开始转发该帧。这种方式虽然也不提供数据校验,但是能够避免大多数的
    错误。它的数据处理速度比直接转发方式慢,但比存储转发方式快许多。

    CISCO 交换机和路由器一样,本质上也是一台特殊的计算机,也有 CPU、RAM 等部件。
    也采用 IOS,所以交换机的很多基本配置(例如密码、主机名等)和路由器是类似的。

    Warning:


    如果需要进行 subnets 间的通讯必须使用{交换机|路由器}的三层接口作为网关。比如在二层交换机的 VLANS 的每个冲突域是单子网的情况下,网络是不通的;二层交换机没有 subnets 间通讯能力。

    转载于:https://www.cnblogs.com/itxdm/p/Cisco_switch_basic_configuration.html

    展开全文
  • 思科交换机防火墙配置

    千次阅读 2014-11-12 16:20:10
    一、VLAN配置
  • 9.3.6思科交换机Portfast和Uplinkfast配置 本实验的步骤很简单,只是通过反复的ping测试来验证在思科交换机上启用Portfast(端口快速)和UplinkFast(上行快速)技术前后的不同的链路状态,以达到加深对这两种技术...
  • 虚拟路由冗余协议(Virtual Router Redundancy Protocol,简称VRRP),是一个IP协议族,我们知道IP协议族里面有ICMP、OSPF,VRRP也是IP协议族的一员,协议号为112。在VRRP里面,设备有两种角色Master,Backup),其中...
  • 华为的MSTP在我看来与思科的PVST是极其相似的,PVST为思科私有的,是按vlan给局域网中的每一个vlan生成一颗树便于流量管理,有不清楚的可以看我前面的博客。 而华为用的MSTP则相对比较灵活,需要先创建一个承载区域...
  • CISCO思科交换机3650G配置命令大全

    千次阅读 2011-08-17 22:19:39
    Cisco 交换机命令 1.在基于IOS的交换机上设置主机名/系统名: switch(config)# hostname hostname 在基于CLI的交换机上设置主机名/系统名: switch(enable) set system name name-string 2.在基于IOS的交换机...
  • 思科交换机vlan

    2020-06-18 10:16:37
    Cisco 交换机不仅仅具有2 层交换功能,它还具有VLAN 等功能。VLAN 技术可以使我们很容易地控制广播域的大小。 有了VLAN,交换机之间的级联链路就需要Trunk 技术来保证该链路可以同时传输多个VLAN 的数据。同时为...
  • 思科交换机端口聚合

    千次阅读 2020-10-27 20:32:33
    端口聚合 端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。但是,失去了路径冗余的优点,因为STP的链路切换会很慢,在50s左右。...可以在组内的端口上配置,使流量可以在这些端口上自动
  • CISCO 3750交换机 配置维护手册 目 录 TOC \o "1-3" \h \z \u 1 连接设备 2 1.1 从console连接 2 1.2 远程telnet连接 4 2 基本信息配置 4 2.1 配置机器名telnet密码 4 2.2 配置snmp网管串 4 3 冗余及系统高可用性...
  • 也称作工业以太网交换机,即应用于工业控制领域的以太网交换机设备,由于...产品系列丰富,端口配置灵活,可满足各种工业领域的使用需求。产品采用宽温设计,防护等级不低于IP30,支持标准和私有的环网冗余协议。...
  • 思科交换机

    2012-04-12 18:34:00
     Cisco交换机产品以“Catalyst ”为商标,包含1900 、2800 、2900 、3500 、4000 、5000 、5500 、6000 、8500 等十多个系列。  一类是固定配置交换机 ,包括3500 及以下的大部分型号,比如1924 是24 口10M ...
  • 思科交换机堆叠

    2012-10-11 11:35:03
    思科交换机堆叠原理介绍 技术概述 思科StackWise技术可以为统一地利用一组交换机的功能提供一种创新的方法。单个交换机可以智能化地结合到一起,创建一个单一的交换单元,并具有32Gbps的交换堆叠互联。同一堆叠中...
  • 思科交换机基础命令

    千次阅读 2018-06-21 15:57:24
    enable 进入特权模式S# configure terminal 进入全局配置模式S(config)# hostname name 改变交换机名称S(config)# enable password level level_# password 设置用户口令(level_#=1)或特权口令(level_#=15)S...
  • 思科交换机端口聚合 端口聚合,顾名思义,就是将多个端口聚合在一起,使其看起来就好像是一个端口,链路的带宽是原来端口的总和。虽然,聚合在一起的端口在逻辑上属于一个channel-group,但是它们又是相互独立的。...
  • 思科交换机基础知识

    2013-05-04 23:40:36
    (1)固定配置交换机 (2)模块化交换机 (3)可堆叠交换机:使用一根背板线缆相互连接,提高带宽的吞吐量。其中堆叠交换机连接方式有:级联和堆叠。 CRC:循环冗余校验和 帧转发方式: (1)存储转发:...
  • 建立的一个计算机教室和一个校办公区,这两处的计算机网络通过两台交换机互联组成内部校园网,为了提高网络的可靠性,作为网络管理员,你要用2条链路将交换机互连,现要求在交换机上做适当配置,使网络避免环路。...
  • 识别思科交换机型号

    2011-03-02 16:13:34
    美国思科公司(Cisco System Inc.)可谓无人不知,无人不晓。凭借它的IOS(Internet Operating ...其实,除了路由器这个主打产品之外,Cisco还有全线的网络设备,包括集线器、交换机、访问服务器、软硬防火墙、网络...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,444
精华内容 977
关键字:

思科交换机冗余配置