精华内容
下载资源
问答
  • 思科交换机基本配置命令 switch>enable 进入特权模式 switch#config terminal 进入全局模式 switch(config)#hostname+xxx 设置主机名 switch(config)#enable password 明文密码 switch(config)#enable ...

    【欢迎关注微信公众号:厦门微思网络】

    微思网络(官网):https://www.xmws.cn/


    思科交换机基本配置命令

    switch>enable    进入特权模式
    
    switch#config terminal    进入全局模式
    
    switch(config)#hostname+xxx    设置主机名
    
    switch(config)#enable password   明文密码
    
    switch(config)#enable secret     密文密码
    
    switch(config)#ip default-gateway  设置网关
    
    switch#show mac-address-table  查看MAC地址
    
    switch(config)#logging synchronous     阻止控制台信息覆盖命令行上的输入
    
    switch(config)#no ip domain-lookup          关闭DNS查看功能
    
    switch(config)#exec-timeout 0 0                阻止会话退出

    使用telnet远程式管理

    switch(config)#line vty 0 4    进入虚拟终端
    
    switch(config-line)#password xx    设置登录口令
    
    switch(config-line)#login     要求口令验证

    控制台口令

    switch(config)#line console 0   进入控制台口
    
    switch(config-line)#password xx  
    
    switch(config-line)# 设置登录口令login     允许登录

    cisco发现协议(cdp)

    switch(config)#show cdp    显示cisco设备全局配置信息
    
    switch(config)#show cdp interface端口    查看cdp配置下端口信息
    
    switch(config)#show cdp neighbors          显示直连cisco设备信息
    
    switch(config)#show cdp neighbors detail  查看邻居详细信息 

    思科交换机恢复出厂配置

    witch#erase startup-config
    
    switch#delete flash: vlan.dat

    配置接口标识(区分路由器的各个接口)

    switch(config)#interface fastethernet0/1
    
    switch(config)#description this is a fast ethernet port used to connecting the company's intranet!

    vtp配置

    switch(config)#vtp domain  设置VTP域名
    
    switch(config)#vtp password xx  设置VTP密码
    
    switch(config)#vtp mode server/client/transparent  设置VTP服务模式
    
    switch(config)#vtp version     设置VTP版本
    
    switch(config)#vtp pruning   设置VTP修解  
    vlan基本配置
    switch#vlan database                       进入vlan配置模式
    
    switch(vlan)#vlan 号码 name 名称       创建vlan及vlan名
    
    switch(vlan)#vlan 号码 mtu 数值         修改MTU大小 
    
    switch(vlan)#exit                          更新vlan数据并退出
    
    switch#show vlan                           查看vlan
    
    switch#copy running-config startup-config       保存配置
    vlan中添加删除端口
    switch#conf t
    
    switch(config)#interface fastethernet0/1     进入要分配的端口
    
    switch(config-if)#switchport mode access        定义二层端口
    
    switch(config-if)#switchport access vlan号码        把端口发给一个vlan
    
    switch(config-if)#switchport mode trunk                   设置为干线
    
    switch(config-if)#switchport trunk encapsulation dotlq     设置vlan中继协议
    
    switch(config-if)#no switchport mode 或 (switchport mode access)  禁用干线
    
    switch(config-if)#switchport trunk allowed vlan add 1,2      从trunk中添加vlans
    
    switch(config-if)#switchport trunk allowed vlan remove1,2       从trunk中删除vlan
    
    switch(config-if)#switchport trunk pruning vlan remove1,2          

    配置接口为动态协商模式

    switch(config)#interface 接口号
    
    switch(config)#switchport mode dynamic desirable/auto

    生成树stp

    switch(config)#spanning-tree vlan   启用stp生成树(基于vlan)
    
    switch(config)#spanning-tree vlan root primary  指定交换机(基于vlan)
    
    switch(config)#spanning-tree vlan root secondary  指定备用根交换机(基于vlan)
    
    switch(config)#spanning-tree vlan priority<0-65535>  指定交换机优先继(基于vlan)
    
    switch(config)#no spanning-tree vlan priority      将交换机的优先级恢复默认值(基于vlan)
    
    switch(config-if)#spanning-tree vlan cost<0-200000000>   指定端口成本(起用trunk的端口模式下)
    
    switch(config-if)#spanning-tree vlan port-prioty<0-255>    指定交换机端口优先级(基于vlan)
    
    switch(config-if)#spanning-tree portfast    配置速端口(连接终端设备的端口状态)如pc机
    
    switch(config)#spanning-tree uplinkfast   配置上行速端口

    注:在配置上行速端口前要先将基于vlan上的网桥优先级,网桥成本恢复默认值。起用了该命令后在进行优先级更改。

    注:vlan为可选参数,当没有该参数时将修改所有vlan网桥的优先级\及所有的vlan端口成本

    switch#show spanning-tree summery        检测vlan生成树配置
    
    switch#show spanning-tree vlan detail    浏览详细生成树配置信息
    
    switch#show spanning-tree interface detail    浏览详细生成树端口配置信息

    以太网通道配置

    switch(config)#interface range fastemet0/1-2  将fastemet0/1和0/2口捆绑
    
    switch(config-if)#change-group 1 mode on     配置以太通道模式
    
    switch(config-if)#port-channel load-batance{dst-mac|src-mac}在链路间实现负载均衡
    
    switch#show etherchannel 1 summary      查看通道信息
    
    switch#show etherchannel load-balance    查看通道信息

    交换机显示命令

    switch#show vtp status  查看vtp配置信息 
    
    switch#show running-config  查看当前配置信息
    
    switch#show vlan     查看vlan配置信息
    
    switch#show interface  查看端口信息
    
    switch#show int f0/0  查看指定端口信息 
    
    switch#dir flash:  查看闪存
    
    switch#show version  查看当前版本信息
    
    switch#show cdp cisco  设备发现协议(可以查看聆接设备)
    
    switch#show cdp traffic  查看接收和发送的cdp包统计信息
    
    switch#show interface f0/1 switchport  查看有关switchport的配置
    
    switch#show cdp neighbors  查看与该设备相邻的cisco设备

    CISCO交换机巡检命令

    1、show interface stats  ;查看交换机所有接口当前接口流量

    2、show running-config ;查看当前设备配置

    3、show version ;查看IOS版本信息及设备正常运行时间

    4、show clock ;查看设备时钟信息

    5、show vtp status ;查看交换机vtp配置模式

    6、show vtp password ;查看交换机vtp配置口令

    7、show env all ;查看设备温度,电源和风扇运转参数及是否报警

    8、show inventory ;调取设备内部板卡出厂模块型号及序列号

    9、show spanning-tree root ;查看交换机生成树根位置

    10、show cdp neighbors ;查看邻接cisco设备基本信息

    11、show cdp neighbors detail ;查看邻接cisco设备详细信息

    12、show interface status ;查看交换机接口状态是否存在errordisable接口disable接口

    13、show interface summary` ;查看交换机所有接口当前接口流量

    14、show interface | i errors|FastEthernet|GigabitEthernet ;查看接口是否存在大量input或output errors包错误

    15、show processes cpu ;查看设备cpu负载

    16、show processes mem ;查看设备mem负载

    17、show access-list ;查看访问控制列表配置及匹配数据包数量

    18、show logging ;查看本机内部日志记录情况

    19、show ip route ;查看路由表

    20、show firewall                  ;检查防火墙的工作模式

    21、show conn count               ;检查防火墙并发数

    22、show xlate count                ;检查防火墙nat工作状态

    展开全文
  • 思科交换机的基本配置命令集:Cisco交换机基本命令集合解释;Cisco路由器交换机配置命令详解;更多类容网址
  • 思科交换机基本配置命令

    千次阅读 2018-07-03 13:32:38
    思科交换机的基本配置命令思科交换机的基本配置命令学习CISCO交换机基本配置:Console端口连接用户模式hostname# ;特权模式hostname(config)# ;全局配置模式hostname(config-if)# ;交换机口令设置:switch&gt...

    思科交换机的基本配置命令

    思科交换机的基本配置命令学习

    CISCO交换机基本配置:Console端口连接

    用户模式hostname# ;

    特权模式hostname(config)# ;

    全局配置模式hostname(config-if)# ;

    交换机口令设置:

    switch>enable ;进入特权模式

    switch#config terminal ;进入全局配置模式

    switch(config)#hostname csico ;设置交换机的主机名

    switch(config)#enable secret csico1 ;设置特权加密口令

    switch(config)#enable password csico8 ;设置特权非密口令

    switch(config)#line console 0 ;进入控制台口

    switch(config-line)#line vty 0 4 ;进入虚拟终端

    switch(config-line)#login ;虚拟终端允许登录

    switch(config-line)#password csico6 ;设置虚拟终端登录口令csico6

    switch#exit ;返回命令

    交换机VLAN创建,删除,端口属性的设置,配置trunk端口,将某端口加入vlan中,配置VTP:

    switch#vlan database ;进入VLAN设置

    switch(vlan)#vlan 2 ;建VLAN 2

    switch(vlan)#vlan 3 name vlan3 ;建VLAN 3并命名为vlan3

    switch(vlan)#no vlan 2 ;删vlan 2

    switch(config)#int f0/1 ;进入端口1

    switch(config)#speed ? 查看speed命令的子命令

    switch(config)#speed 100 设置该端口速率为100mb/s (10/auto)

    switch(config)#duplex ? 查看duplex的子命令

    switch(config)#duplex full 设置该端口为全双工(auto/half)

    switch(config)#description TO_PC1 这是该端口描述为TO_PC1

    switch(config-if)#switchport access vlan 2 ;当前端口加入vlan 2

    switch(config-if)#switchport mode trunk ;设置为trunk模式(access模式)

    switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlan

    switch(config-if)#switchport trunk encap dot1q ;设置vlan 中继

    switch(config)#vtp domain vtpserver ;设置vtp域名相同

    switch(config)#vtp password ;设置发vtp密码

    switch(config)#vtp server ;设置vtp服务器模式

    switch(config)#vtp client ;设置vtp客户机模式

    交换机设置IP地址,默认网关,域名,域名服务器,配置和查看MAC地址表:

    switch(config)#interface vlan 1 ;进入vlan 1

    switch(config-if)#ip address 192.168.1.1 255.255.255.0 ;设置IP地址

    switch(config)#ip default-gateway 192.168.1.6 ;设置默认网关

    switch(config)#ip domain-name cisco.com 设置域名

    switch(config)#ip name-server 192.168.1.18 设置域名服务器

    switch(config)#mac-address-table? 查看mac-address-table的子命令

    switch(config)#mac-address-table aging-time 100 设置超时时间为100ms

    switch(config)#mac-address-table permanent 0000.0c01.bbcc f0/3 加入永久地址在f0/3端口

    switch(config)#mac-address-table restricted static 0000.0c02.bbcc f0/6 f0/7 加入静态地址目标端口f0/6源端口f0/7

    switch(config)#end

    switch#show mac-address-table 查看整个MAC地址表

    switch#clear mac-address-table restricted static 清除限制性静态地址

    交换机显示命令:

    switch#write ;保存配置信息

    switch#show vtp ;查看vtp配置信息

    switch#show run ;查看当前配置信息

    switch#show vlan ;查看vlan配置信息

    switch#show interface ;查看端口信息

    switch#show int f0/0 ;查看指定端口信息

    switch#show int f0/0 status;查看指定端口状态

    switch#dir flash: ;查看闪存

    Cisco路由器配置命令大全网络 2010-06-26 06:43:44 阅读657 评论0 字号:大中小 订阅 .

    (1)模式转换命令

    用户模式----特权模式,使用命令"enable"

    特权模式----全局配置模式,使用命令"config t"

    全局配置模式----接口模式,使用命令"interface+接口类型+接口号"

    全局配置模式----线控模式,使用命令"line+接口类型+接口号"

    :

    用户模式:查看初始化的信息.

    特权模式:查看所有信息、调试、保存配置信息

    全局模式:配置所有信息、针对整个路由器或交换机的所有接口

    接口模式:针对某一个接口的配置

    线控模式:对路由器进行控制的接口配置

    2)配置命令

    show running config 显示所有的配置

    show versin 显示版本号和寄存器值

    shut down 关闭接口

    no shutdown 打开接口

    ip add +ip地址 配置IP地址

    secondary+IP地址 为接口配置第二个IP地址

    show interface+接口类型+接口号 查看接口管理性

    show controllers interface 查看接口是否有DCE电缆

    show history 查看历史记录

    show terminal 查看终端记录大小

    hostname+主机名 配置路由器或交换机的标识

    config memory 修改保存在NVRAM中的启动配置

    exec timeout 0 0 设置控制台会话超时为0

    service password-encryptin 手工加密所有密码

    enable password +密码 配置明文密码

    ena sec +密码 配置密文密码

    line vty 0 4/15 进入telnet接口

    password +密码 配置telnet密码

    line aux 0 进入AUX接口

    password +密码 配置密码

    line con 0 进入CON接口

    password +密码 配置密码

    bandwidth+数字 配置带宽

    no ip address 删除已配置的IP地址

    show startup config 查看NVRAM中的配置信息

    copy run-config atartup config 保存信息到NVRAM

    write 保存信息到NVRAM

    erase startup-config 清除NVRAM中的配置信息

    show ip interface brief 查看接口的谪要信息

    banner motd # +信息 + # 配置路由器或交换机的描素信息

    description+信息 配置接口听描素信息

    vlan database 进入VLAN数据库模式

    vlan +vlan号+ 名称 创建VLAN

    switchport access vlan +vlan号 为VLAN为配接口

    interface vlan +vlan号 进入VLAN接口模式

    ip add +ip地址 为VLAN配置管理IP地址

    vtp+service/tracsparent/client 配置SW的VTP工作模式

    vtp +domain+域名 配置SW的VTP域名

    vtp +password +密码 配置SW的密码

    switchport mode trunk 启用中继

    no vlan +vlan号 删除VLAN

    show spamming-tree vlan +vlan号 查看VLA怕生成树议

    2. 路由器配置命令

    ip route+非直连网段+子网掩码+下一跳地址 配置静态/默认路由

    show ip route 查看路由表

    show protocols 显示出所有的被动路由协议和接口上哪些协议被设置

    show ip protocols 显示了被配置在路由器上的路由选择协议,同时给出了在路由选择协议中使用

    的定时器

    等信息

    router rip 激活RIP协议

    network +直连网段 发布直连网段

    interface lookback 0 激活逻辑接口

    passive-interface +接口类型+接口号 配置接口为被动模式

    debug ip +协议 动态查看路由更新信息

    undebug all 关闭所有DEBUG信息

    router eigrp +as号 激活EIGRP路由协议

    network +网段+子网掩码 发布直连网段

    show ip eigrp neighbors 查看邻居表

    show ip eigrp topology 查看拓扑表

    show ip eigrp traffic 查看发送包数量

    router ospf +process-ID 激活OSPF协议

    network+直连网段+area+区域号 发布直连网段

    show ip ospf 显示OSPF的进程号和ROUTER-ID

    encapsulation+封装格式 更改封装格式

    no ip admain-lookup 关闭路由器的域名查找

    ip routing 在三层交换机上启用路由功能

    show user 查看SW的在线用户

    clear line +线路号 清除线路

    3. 三层交换机配置命令

    配置一组二层端口

    configure terminal 进入配置状态

    nterface range {port-range} 进入组配置状态

    配置三层端口

    configure terminal 进入配置状态

    interface {{fastethernet | gigabitethernet} interface-id} | {vlan vlan-id} | {port-

    channel port-channel-number} 进入端口配置状态

    no switchport 把物理端口变成三层口

    ip address ip_address subnet_mask 配置IP地址和掩码

    no shutdown 激活端口

    例:

    Switch(config)# interface gigabitethernet0/2

    Switch(config-if)# no switchport

    Switch(config-if)# ip address 192.20.135.21 255.255.255.0

    Switch(config-if)# no shutdown

    配置VLAN

    configure terminal 进入配置状态

    vlan vlan-id 输入一个VLAN号, 然后进入vlan配态,可以输入一个新的VLAN号或旧的来进行修改

    name vlan-name 可选)输入一个VLAN名,如果没有配置VLAN名,缺省的名字是VLAN号前面用0填满

    4位数,如VLAN0004是VLAN4的缺省名字

    mtu mtu-size (可选) 改变MTU大小

    Switch# configure terminal

    Switch(config)# vlan 20

    Switch(config-vlan)# name test20

    Switch(config-vlan)# end

    Switch# vlan database

    Switch(vlan)# vlan 20 name test20

    Switch(vlan)# exit

    将端口分配给一个VLAN

    configure terminal 进入配置状态

    interface interface-id 进入要分配的端口

    switchport mode access 定义二层口

    switchport access vlan vlan-id 把端口分配给某一VLAN

    Switch# configure terminal

    Enter configuration commands, one per line. End with CNTL/Z.

    Switch(config)# interface fastethernet0/1

    Switch(config-if)# switchport mode access

    Switch(config-if)# switchport access vlan 2

    Switch(config-if)# end

    Switch#

    配置VLAN trunk

    configure terminal 进入配置状态

    interface interface-Id 进入端口配置状态

    switchport trunk encapsulation {isl | dot1q | negotiate}配置trunk封装ISL 或 802.1Q 或

    自动协商

    switchport mode {dynamic {auto | desirable} | trunk} 配置二层trunk模式。

    dynamic auto—自动协商是否成为trunk

    dynamic desirable—把端口设置为trunk如果对方端口是trunk, desirable, 配置Native VLAN

    802.1q)

    或自动模式,trunk—设置端口为强制的trunk方式,而不理会对方端口是否为trunk

    switchport access vlan vlan-id 可选) 指定一个缺省VLAN, 如果此端口不再是trunk

    switchport trunk native vlan vlan-id 指定802.1Q native VLAN号

    例:

    Switch# configure terminal

    Enter configuration commands, one per line. End with CNTL/Z.

    Switch(config)# interface fastethernet0/4

    Switch(config-if)# switchport mode trunk

    Switch(config-if)# switchport trunk encapsulation dot1q

    Switch(config-if)# end

    定义TRUNK允许的VLAN

    configure terminal子 进入配置状态

    interface interface-id 进入端口配置

    switchport mode trunk 配置二层口为trunk

    switchport trunk allowed vlan {add | all | except | remove} vlan-list可选) 配置trunk允

    许的VLAN.使用add, all, except, remove关健字

    no switchport trunk allowed vlan 允许所有VLAN通过

    Switch(config)# interface fastethernet0/1

    Switch(config-if)# switchport trunk allowed vlan remove 2

    Switch(config-if)# end

    配置Native VLAN(802.1q)

    configure terminal 进入配置状态

    interface interface-id 进入配置成802.1qtrunk的端口

    switchport trunk native vlan vlan-Id 配置native VLAN号

    no switchport trunk native vlan 端口配置命令回到缺省的状态

    配置基于端口权值的负载均衡

    configure terminal 进入Switch 1配置状态

    vtp domain domain-name 配置VTP域

    vtp mode server 将Switch 1配置成VTP server.

    show vtp status 验证VTP的配置

    show vlan 验证VLAN

    configure terminal 进入配置状态

    interface fastethernet 0/1 进入F0/1端口

    switchport trunk encapsulation {isl | dot1q | negotiate}配置trunk封装

    switchport mode trunk 配置成trunk

    show interfaces fastethernet0/1 switchport 验证VLAN配置

    按以上步骤对想要负载均衡的接口进行配置

    在另一个交换机上进行此配置

    show vlan 当trunk已经起来,在switch2上验证已经学到相的vlan配置

    configure terminal 在Switch 1上进入配置状态

    interface fastethernet0/1 进入要配置的端口

    spanning-tree vlan 8 port-priority 10 将端口权值10赋与VLAN 8.

    spanning-tree vlan 9 port-priority 10 将端口权值10赋与VLAN 9.

    spanning-tree vlan 10 port-priority 10 将端口权值10赋与VLAN 10.

    interface fastethernet0/2 进入F0/2

    spanning-tree vlan 3 port-priority 10 将端口权值10赋与VLAN 3.

    spanning-tree vlan 4 port-priority 10 将端口权值10赋与VLAN 4

    spanning-tree vlan 5 port-priority 10 将端口权值10赋与VLAN 5

    spanning-tree vlan 6 port-priority 10 将端口权值10赋与VLAN 10

    end 退出

    show running-config 验证配置

    copy running-config startup-config 保存配置

    配置STP路径值的负载均衡

    Trunk1走VLAN8-10,Trunk2走VLAN2-4

    configure terminal 进入 Switch 1配置状态

    interface fastethernet 0/1 进入F0/1

    switchport trunk encapsulation {isl | dot1q | negotiate}配置封装

    switchport mode trunk 配置Trunk,缺省是ISL封装

    exit 退回

    F0/2口上重复2-4步骤

    exit 退回

    show running-config 验证配置

    show vlan验证switch1 已经学到Vlan

    configure terminal 进入配置状态

    interface fastethernet 0/1 进入F0/1

    spanning-tree vlan 2 cost 30 设置Vlan2生成树路径值为30

    spanning-tree vlan 3 cost 30 设置Vlan3生成树路径值为30

    spanning-tree vlan 4 cost 30 设置Vlan4生成树路径值为30

    end 退出

    switch1的F0/2上重复9-11步骤设置VLAN8,9,10生成树路径值为30

    end 退出

    show running-config 验证配置

    copy running-config startup-config 保存配置

    补充:CISCO命令集——路由选择协议及排障

    *ip route命令

    Router(config)# ip route <目录网络或子网号> [子网掩码] <下一路由器IP地址 | 从本地出口

    的地址> [管理距离0~255,默认为1]

    (注:静态地址配置)

    *ip default-network命令

    Router(config)# ip default-network <目标网络号>

    (注:配合路由协使用,用其中的一个动态路由号作默认路由配置)

    Router(config)# ip route 0.0.0.0 0.0.0.0 <下一路由器IP地址 | 从本地出口的地址>

    (注:只有一个公网地址时,在出口路由器上的配置)

    *内部路由选择协议

    *使用router和network命令

    Router(config)# router <路由协议rip | igrp | eigrp | ospf | is-is等> [自主系统号]

    Router(config-router)# network <直接相连的要用此路由协议的网络号>

    Router(config-router)# network <直接相连的要用此路由协议的网络号>

    *路由信息协议RIP

    Router(config)# router rip

    Router(config-router)# network <直接相连的要用rip协议的有类别网络号>

    Router# show ip protocols

    Router# show ip route

    Router# debug ip rip

    *内部网关路由协议IGRP

    Router(config)# router igrp <自主系统号>

    Router(config-router)# network <直接相连的要用igrp协议的有类别网络号>

    Router# show ip interface

    Router# show ip protocols

    Router# show ip route

    Router# debug ip rip

    *排除网络故障

    排除网络故障的一个总体模型

    Router# ping <有故障的主机 | 有故障的IP地址>

    Router# show ip route

    Router# show interface <有故障的接口>

    Router# show run

    *IP的故故障排除

    检查可用的路由

    Router# show ip route <有故障的IP地址>

    27.4.4 跟踪路由(Tracing the Route)

    SUN-A> traceroute <有故障的主机 | 有故障的IP地址>

    C:/windows/> winipcfg

    C:/windows/> ipconfig

    C:/windows/> ipconfig / all

    C:/windows/> tracert <有故障的主机 | 有故障的IP地址>

    使用扩展的ping来跟踪连接性

    Router# ping

    *其它可能的故障

    一个地址解析(ARP)的故障

    Router# show arp

    Router# show interface <有故障的接口>

    C:/windows/> arp -a

    SUN-A> arp –a

    验证终端系统的路由表

    C:/windows/> netstat –rn

    C:/windows/> route –f add 0.0.0.0 mask 0.0.0.0 <需要添加入的网关地址>

    C:/windows/> route [–f ] [[print | add | delete | change] [destination] [mask

    netmask] [gateway]]

    C:/windows/> route add mask <网络掩码> <网关ip地址>

    C:/windows/> route delete mask <网络掩码> <网关ip地址>

    C:/windows/> nbtstat <相应的参数>

    SUN-A> netstat -rn路由器

    CISCO交换机配置命令大全2009-08-13 21:131.在基于IOS的交换机上设置主机名/系统名:

    switch(config)# hostname hostname

    在基于CLI的交换机上设置主机名/系统名:

    switch(enable) set system name name-string

    2.在基于IOS的交换机上设置登录口令:

    switch(config)# enable password level 1 password

    在基于CLI的交换机上设置登录口令:

    switch(enable) set password

    switch(enable) set enalbepass

    3.在基于IOS的交换机上设置远程访问:

    switch(config)# interface vlan 1

    switch(config-if)# ip address ip-address netmask

    switch(config-if)# ip default-gateway ip-address

    在基于CLI的交换机上设置远程访问:

    switch(enable) set interface sc0 ip-address netmask broadcast-address

    switch(enable) set interface sc0 vlan

    switch(enable) set ip route default gateway

    4.在基于IOS的交换机上启用和浏览CDP信息:

    switch(config-if)# cdp enable

    switch(config-if)# no cdp enable

    为了查看Cisco邻接设备的CDP通告信息:

    switch# show cdp interface [type modle/port]

    switch# show cdp neighbors [type module/port] [detail]

    在基于CLI的交换机上启用和浏览CDP信息:

    switch(enable) set cdp {enable|disable} module/port

    为了查看Cisco邻接设备的CDP通告信息:

    switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]

    5.基于IOS的交换机的端口描述:

    switch(config-if)# description description-string

    基于CLI的交换机的端口描述:

    switch(enable)set port name module/number description-string

    6.在基于IOS的交换机上设置端口速度:

    switch(config-if)# speed{10|100|auto}

    在基于CLI的交换机上设置端口速度:

    switch(enable) set port speed moudle/number {10|100|auto}

    switch(enable) set port speed moudle/number {4|16|auto}

    7.在基于IOS的交换机上设置以太网的链路模式:

    switch(config-if)# duplex {auto|full|half}

    在基于CLI的交换机上设置以太网的链路模式:

    switch(enable) set port duplex module/number {full|half}

    8.在基于IOS的交换机上配置静态VLAN:

    switch# vlan database

    switch(vlan)# vlan vlan-num name vla

    switch(vlan)# exit

    switch# configure teriminal

    switch(config)# interface interface module/number

    switch(config-if)# switchport mode access

    switch(config-if)# switchport access vlan vlan-num

    switch(config-if)# end

    在基于CLI的交换机上配置静态VLAN:

    switch(enable) set vlan vlan-num [name name]

    switch(enable) set vlan vlan-num mod-num/port-list

    9. 在基于IOS的交换机上配置VLAN中继线:

    switch(config)# interface interface mod/port

    switch(config-if)# switchport mode trunk

    switch(config-if)# switchport trunk encapsulation {isl|dotlq}

    switch(config-if)# switchport trunk allowed vlan remove vlan-list

    switch(config-if)# switchport trunk allowed vlan add vlan-list

    在基于CLI的交换机上配置VLAN中继线:

    switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]

    Vlan-range [isl|dotlq|dotl0|lane|negotiate]

    10.在基于IOS的交换机上配置VTP管理域:

    switch# vlan database

    switch(vlan)# vtp domain domain-name

    在基于CLI的交换机上配置VTP管理域:

    switch(enable) set vtp [domain domain-name]

    11.在基于IOS的交换机上配置VTP 模式:

    switch# vlan database

    switch(vlan)# vtp domain domain-name

    switch(vlan)# vtp {sever|cilent|transparent}

    switch(vlan)# vtp password password

    在基于CLI的交换机上配置VTP 模式:

    switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password]

    12. 在基于IOS的交换机上配置VTP版本:

    switch# vlan database

    switch(vlan)# vtp v2-mode

    在基于CLI的交换机上配置VTP版本:

    switch(enable) set vtp v2 enable

    13. 在基于IOS的交换机上启动VTP剪裁:

    switch# vlan database

    switch(vlan)# vtp pruning

    在基于CL I 的交换机上启动VTP剪裁:

    switch(enable) set vtp pruning enable

    14.在基于IOS的交换机上配置以太信道:

    switch(config-if)# port group group-number [distribution {source|destination}]

    在基于CLI的交换机上配置以太信道:

    switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}

    15.在基于IOS的交换机上调整根路径成本:

    switch(config-if)# spanning-tree [vlan vlan-list] cost cost

    在基于CLI的交换机上调整根路径成本:

    switch(enable) set spantree portcost moudle/port cost

    switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]

    16.在基于IOS的交换机上调整端口ID:

    switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority

    在基于CLI的交换机上调整端口ID:

    switch(enable) set spantree portpri {mldule/port}priority

    switch(enable) set spantree portvlanpri {module/port}priority [vlans]

    17. 在基于IOS的交换机上修改STP时钟:

    switch(config)# spanning-tree [vlan vlan-list] hello-time seconds

    switch(config)# spanning-tree [vlan vlan-list] forward-time seconds

    ` switch(config)# spanning-tree [vlan vlan-list] max-age seconds

    在基于CLI的交换机上修改STP时钟:

    switch(enable) set spantree hello interval[vlan]

    switch(enable) set spantree fwddelay delay [vlan]

    switch(enable) set spantree maxage agingtiame[vlan]

    18. 在基于IOS的交换机端口上启用或禁用Port Fast 特征:

    switch(config-if)#spanning-tree portfast

    在基于CLI的交换机端口上启用或禁用Port Fast 特征:

    switch(enable) set spantree portfast {module/port}{enable|disable}

    19. 在基于IOS的交换机端口上启用或禁用UplinkFast 特征:

    switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]

    在基于CLI的交换机端口上启用或禁用UplinkFast 特征:

    switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]

    20. 为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP地址,然后使用下列命令: switch(config)# cluster enable cluster-name

    21. 为了从一条中继链路上删除VLAN,可使用下列命令:

    switch(enable) clear trunk module/port vlan-range

    22. 用show vtp domain 显示管理域的VTP参数.

    23. 用show vtp statistics显示管理域的VTP参数.

    24. 在Catalyst交换机上定义TrBRF的命令如下:

    switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]

    25. 在Catalyst交换机上定义TrCRF的命令如下:

    switch (enable) set vlan vlan-num [name name] type trcrf

    {ring hex-ring-num|decring decimal-ring-num} parent vlan-num

    26. 在创建好TrBRF VLAN之后,就可以给它分配交换机端口.对于以太网交换,可以采用如下命令给VLAN分配端口:

    switch(enable) set vlan vlan-num mod-num/port-num

    27. 命令show spantree显示一个交换机端口的STP状态.

    28. 配置一个ELAN的LES和BUS,可以使用下列命令:

    ATM (config)# interface atm number.subint multioint

    ATM(config-subif)# lane serber-bus ethernet elan-name

    29. 配置LECS:

    ATM(config)# lane database database-name

    ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address

    ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address

    ATM(lane-config-databade)# name …

    30. 创建完数据库后,必须在主接口上启动LECS.命令如下:

    ATM(config)# interface atm number

    ATM(config-if)# lane config database database-name

    ATM(config-if)# lane config auto-config-atm-address

    31. 将每个LEC配置到一个不同的ATM子接口上.命令如下:

    ATM(config)# interface atm number.subint multipoint

    ATM(config)# lane client ethernet vlan-num elan-num

    32. 用show lane server 显示LES的状态.

    33. 用show lane bus显示bus的状态.

    34. 用show lane database显示LECS数据库可内容.

    35. 用show lane client显示LEC的状态.

    36. 用show module显示已安装的模块列表.

    37. 用物理接口建立与VLAN的连接:

    router# configure terminal

    router(config)# interface media module/port

    router(config-if)# description description-string

    router(config-if)# ip address ip-addr subnet-mask

    router(config-if)# no shutdown

    38. 用中继链路来建立与VLAN的连接:

    router(config)# interface module/port.subinterface

    router(config-ig)# encapsulation[isl|dotlq] vlan-number

    router(config-if)# ip address ip-address subnet-mask

    39. 用LANE 来建立与VLAN的连接:

    router(config)# interface atm module/port

    router(config-if)# no ip address

    router(config-if)# atm pvc 1 0 5 qsaal

    router(config-if)# atm pvc 2 0 16 ilni

    router(config-if)# interface atm module/port.subinterface multipoint

    router(config-if)# ip address ip-address subnet-mask

    router(config-if)# lane client ethernet elan-num

    router(config-if)# interface atm module/port.subinterface multipoint

    router(config-if)# ip address ip-address subnet-name

    router(config-if)# lane client ethernet elan-name

    router(config-if)# …

    40. 为了在路由处理器上进行动态路由配置,可以用下列IOS命令来进行:

    router(config)# ip routing

    router(config)# router ip-routing-protocol

    router(config-router)# network ip-network-number

    router(config-router)# network ip-network-number

    41. 配置默认路由:

    switch(enable) set ip route default gateway

    42. 为一个路由处理器分配VLANID,可在接口模式下使用下列命令:

    router(config)# interface interface number

    router(config-if)# mls rp vlan-id vlan-id-num

    43. 在路由处理器启用MLSP:

    router(config)# mls rp ip

    44. 为了把一个外置的路由处理器接口和交换机安置在同一个VTP域中:

    router(config)# interface interface number

    router(config-if)# mls rp vtp-domain domain-name

    45. 查看指定的VTP域的信息:

    router# show mls rp vtp-domain vtp domain name

    46. 要确定RSM或路由器上的管理接口,可以在接口模式下输入下列命令:

    router(config-if)#mls rp management-interface

    47. 要检验MLS-RP的配置情况:

    router# show mls rp

    48. 检验特定接口上的MLS配置:

    router# show mls rp interface interface number

    49. 为了在MLS-SE上设置流掩码而又不想在任一个路由处理器接口上设置访问列表:

    set mls flow [destination|destination-source|full]

    50. 为使MLS和输入访问列表可以兼容,可以在全局模式下使用下列命令:

    router(config)# mls rp ip input-acl

    51. 当某个交换机的第3层交换失效时,可在交换机的特权模式下输入下列命令:

    switch(enable) set mls enable

    52. 若想改变老化时间的值,可在特权模式下输入以下命令:

    switch(enable) set mls agingtime agingtime

    53. 设置快速老化:

    switch(enable) set mls agingtime fast fastagingtime pkt_threshold

    54. 确定那些MLS-RP和MLS-SE参与了MLS,可先显示交换机引用列表中的内容再确定:

    switch(enable) show mls include

    55. 显示MLS高速缓存记录:

    switch(enable) show mls entry

    56. 用命令show in arp显示ARP高速缓存区的内容。

    57. 要把路由器配置为HSRP备份组的成员,可以在接口配置模式下使用下面的命令:

    router(config-if)# standby group-number ip ip-address

    58. 为了使一个路由器重新恢复转发路由器的角色,在接口配置模式下:

    router(config-if)# standy group-number preempt

    59. 访问时间和保持时间参数是可配置的:

    router(config-if)# standy group-number timers hellotime holdtime

    60. 配置HSRP跟踪:

    router(config-if)# standy group-number track type-number interface-priority

    61. 要显示HSRP路由器的状态:

    router# show standby type-number group brief

    62. 用命令show ip igmp确定当选的查询器。

    63. 启动IP组播路由选择:

    router(config)# ip muticast-routing

    64. 启动接口上的PIM:

    dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}

    65. 启动稀疏-稠密模式下的PIM:

    router# ip multicast-routing

    router# interface type number

    router# ip pim sparse-dense-mode

    66. 核实PIM的配置:

    dallasr1># show ip pim interface[type number] [count]

    67. 显示PIM邻居:

    dallasr1># show ip neighbor type number

    68. 为了配置RP的地址,命令如下:

    dallasr1># ip pim rp-address ip-address [group-access-list-number][override]

    69. 选择一个默认的RP:

    dallasr1># ip pim rp-address

    通告RP和它所服务的组范围:

    dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number

    为管理范围组通告RP的地址:

    dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1

    dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255

    设定一个RP映像代理:

    dallasr1># ip pim send-rp-discovery scope ttl

    核实组到RP的映像:

    dallasr1># show ip pim rp mapping

    dallasr1># show ip pim rp [group-name|group-address] [mapping]

    70. 在路由器接口上用命令ip multicast ttl-threshold ttl-value设定TTL阀值:

    dallasr1>(config-if)# ip multicast ttl-threshold ttl-value

    71. 用show ip pim neighbor显示PIM邻居表。

    72. 显示组播通信路由表中的各条记录:

    dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]

    73. 要记录一个路由器接受和发送的全部IP组播包:

    dallasr1> #debug ip mpacket [detail] [access-list][group]

    74. 要在CISCO路由器上配置CGMP:

    dallasr1>(config-if)# ip cgmp

    75.配置一个组播路由器,使之加入某一个特定的组播组:

    dallasr1>(config-if)# ip igmp join-group group-address

    76. 关闭 CGMP:

    dallasr1>(config-if)# no ip cgmp

    77. 启动交换机上的CGMP:

    dallasr1>(enable) set cgmp enable

    78. 核实Catalyst交换机上CGMP的配置情况:

    catalystla1>(enable) show config

    set prompt catalystla1>

    set interface sc0 192.168.1.1 255.255.255.0

    set cgmp enable

    79. CGMP离开的设置:

    Dallas_SW(enable) set cgmp leave

    80. 在Cisco设备上修改控制端口密码:

    R1(config)# line console 0

    R1(config-line)# login

    R1(config-line)# password Lisbon

    R1(config)# enable password Lilbao

    R1(config)# login local

    R1(config)# username student password cisco

    81. 在Cisco设备上设置控制台及vty端口的会话超时:

    R1(config)# line console 0

    R1(config-line)# exec-timeout 5 10

    R1(config)# line vty 0 4

    R1(config-line)# exec-timeout 5 2

    82. 在Cisco设备上设定特权级:

    R1(config)# privilege configure level 3 username

    R1(config)# privilege configure level 3 copy run start

    R1(config)# privilege configure level 3 ping

    R1(config)# privilege configure level 3 show run

    R1(config)# enable secret level 3 cisco

    83. 使用命令privilege 可定义在该特权级下使用的命令:

    router(config)# privilege mode level level command

    84. 设定用户特权级:

    router(config)# enable secret level 3 dallas

    router(config)# enable secret san-fran

    router(config)# username student password cisco

    85. 标志设置与显示:

    R1(config)# banner motd ‘unauthorized access will be prosecuted!’

    86. 设置vty访问:

    R1(config)# access-list 1 permit 192.168.2.5

    R1(config)# line vty 0 4

    R1(config)# access-class 1 in

    87. 配置HTTP访问:

    Router3(config)# access-list 1 permit 192.168.10.7

    Router3(config)# ip http sever

    Router3(config)# ip http access-class 1

    Router3(config)# ip http authentication local

    Router3(config)# username student password cisco

    88. 要启用HTTP访问,请键入以下命令:

    switch(config)# ip http sever

    89. 在基于set命令的交换机上用setCL1启动和核实端口安全:

    switch(enable) set port security mod_num/port_num…enable mac address

    switch(enable) show port mod_num/port_num

    在基于CiscoIOS命令的交换机上启动和核实端口安全:

    switch(config-if)# port secure [mac-mac-count maximum-MAC-count]

    switch# show mac-address-table security [type module/port]

    90. 用命令access-list在标准通信量过滤表中创建一条记录:

    Router(config)# access-list access-list-number {permit|deny} source-address [source-address]

    91. 用命令access-list在扩展通信量过滤表中创建一条记录:

    Router(config)# access-list access-list-number {permit|deny{protocol|protocol-keyword}}{source source-wildcard|any}{destination destination-wildcard|any}[protocol-specific options][log]

    92. 对于带内路由更新,配置路由更新的最基本的命令格式是:

    R1(config-router)#distribute-list access-list-number|name in [type number]

    93. 对于带外路由更新,配置路由更新的最基本的命令格式是:

    R1(config-router)#distribute-list access-list-number|name out [interface-name] routing-process| autonomous-system-number

    94. set snmp命令选项:

    set snmp community {read-only|ready-write|read-write-all}[community_string]

    95. set snmp trap 命令格式如下:

    set snmp trap {enable|disable}

    [all|moudle|classis|bridge|repeater| auth|vtp|ippermit|vmps|config|entity|stpx]

    set snmp trap rvcr_addr rcvr_community

    96. 启用SNMP chassis 陷阱:

    Console>(enable) set snmp trap enable chassis

    97. 启用所有SNMP chassis 陷阱:

    Console>(enable) set snmp trap enable

    98. 禁用SNMP chassis 陷阱:

    Console>(enable) set snmp trap disable chassis

    99. 给SNMP陷阱接收表加一条记录:

    Console>(enable) set snmp trap 192.122.173.42 public

    100. show snmp 输出结果。

    101. 命令set snmp rmon enable 的输出结果。

    102. 显示SPAN信息:

    Consile> show span

    一些华为路由器命令:

    删除设备配置

    reset saved-configuration

    重启

    reboot

    看当前配置文件

    display current-configuration

    改设备名

    sysname

    保存配置

    save

    进入特权模式

    sysview

    华为只有2层模式 不像cisco enale之后还要conf t

    定义acl

    acl nubmere XXXX(3000以上)进入以后

    rule permit/deny IP/TCP/UDP等 source XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX(反向)

    destination XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX(反向) eq

    注意 华为默认没有deny any any

    防火墙上端口加载ACL

    [Quidway-Ethernet0/0]firewall packet-filter 3000 inbound

    防火墙上新增加用户

    local-user XXX(用户名) password simple XXX(密码)

    local-user XXX service-type ppp

    删除某条命令

    undo(类似与cisco的no)

    静态路由

    ip route-static 0.0.0.0 0.0.0.0 XXX.XXX.XXX.XXX

    vpdn用户设置acl的接口

    inte***ce Virtual-Template1

    查看路由表

    display ip routing-table

    设定telnet密码

    user-inte***ce vty 0 4

    user privilege level 3

    set authentication password simple XXX

    启动/关闭

    启动 un shut

    关闭 shut

    动态nat设置

    acl number 3000

    rule 0 permit ip source XXX.XXX.XXX.XXX

    rule 1 permit ip source XXX.XXX.XXX.XXX

    rule 2 permit ip source XXX.XXX.XXX.XXX

    inte***ce Ethernet1/0

    des cription ====To-Internet(WAN)====

    ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX

    nat outbound 3000

    ipsec policy policy1

    利用acl来做 符合acl的IP地址可以出去(注意 此处的ACL隐含了deny any any)不符合的IP地址不可以出去

    创建vlan

    [shzb-crsw-s6506-1]vlan 100

    华为vlan不支持name

    port放入vlan

    创建了vlan后 进入vlan模式

    [shzb-crsw-s6506-1-vlan100]port GigabitEthernet 1/0/1 to GigabitEthernet 1/0/8

    表示从G1/0/1 到1/0/8放入VLAN 100

    创建trunk

    inte***ce GigabitEthernet1/0/1

    duplex full

    speed 1000

    * port link-type trunk

    * port trunk permit vlan all

    port link-aggregation group 1

    *号的是创建trunk链路的语句

    vlan地址指定

    inte***ce Vlan-inte***ce2

    des cription server

    ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX

    vrrp vrid 2 virtual-ip XXX.XXX.XXX.XXX

    vrrp vrid 2 priority 120

    vrrp vrid 2 preempt-mode timer delay 10

    其中vrrp语句指定vrrp 类似与hsrp

    使用vrrp要注意的是华为不支持pvst

    只能一台完全是主,一台完全是备份

    在主vrrp设备上要指定

    stp instance 0 root primary

    stp TC-protection enable

    stp enable

    在从vrrp设备上要指定

    stp instance 0 root secondary

    stp TC-protection enable

    stp enable

    交换机下面绑acl

    首先进入接口模式,输入qos命令

    [shzb-crsw-s6506-1-GigabitEthernet1/0/1]qos

    在输入如下命令

    [shzb-crsw-s6506-1-qoss-GigabitEthernet1/0/1]packet-filter inbound ip-group 3000

    华为交换机只能指定inbound方向

    启用ospf

    [shzb-crsw-s6506-1]ospf 100

    [shzb-crsw-s6506-1-ospf-100]area 0

    [shzb-crsw-s6506-1-ospf-100-area-0.0.0.0]network XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX

    配置ospf重发布

    [shzb-crsw-s6506-1-ospf-100-area-0.0.0.0]quit

    [shzb-crsw-s6506-1-ospf-100]import-route static

    建立link-group(类似与cisco的channel-group)

    link-aggregation group 1 mode manual

    然后进入接口

    port link-aggregation group 1

    启用VRRP之前必须输入

    vrrp ping-enable

    使得客户能ping网关

     

     

    展开全文
  • 思科交换机的配置模式基本配置命令 打开思科交换CLI,首先进入的是用户模式,如果要进行配置操作需要进入特权模式。 Switch>enable Switch# 从特权模式进入全局配置模式 Switch#configure terminal Switch...

    思科交换机的配置模式基本配置命令

    • 打开思科交换CLI,首先进入的是用户模式,如果要进行配置操作需要进入特权模式。

    Switch>enable

    Switch#

    • 从特权模式进入全局配置模式

    Switch#configure terminal

    Switch(config)#

    • 在特权模式下可以对交换机进行命名,这样在配置多台交换机时,避免将配置写错交换机。

    Switch(config)#hostname cisco-sw1

    • 配置交换端口密码,登录特权模式时需要输入该密码,避免设备被其他人使用。

    cisco-sw1(config)#enable password cisco

    ps:password表示密码为明文

    • 给交换机配置使能密码,进入特权模式时需要输入密码才能进入,避免设备可以被其他人员使用。

    cisco-sw1(config)#enable secret ciscoswitch

    ps:secret表示密码用的密文

    • 交换机配置VLAN,并给将端口加入到该VLAN:

    cisco-sw1(config)#vlan 2

    cisco-sw1(config-vlan)#name test

    cisco-sw1(config-vlan)#exit

    cisco-sw1(config)#interface  fastEthernet 0/1

    cisco-sw1(config-if)#switchport mode access

    cisco-sw1(config-if)#switchport access vlan 2

    • 进入交换机某一端口

    switch> enable

    switch#configure terminal

    switch(conf)# interface fastehernet 0/1

    switch(conf-if)#

    • show:查看命令,交换机的所有配置和其它相关信息都需要通过show命令查看。

    switch> enable

    switch# show version 察看系统中的所有版本信息

    switch#show  vlan id 1 查看交换机有关vlan配置信息

    switch#show running-configure 查看交换机当前起作用的配置信息

    switch#show interface fastethernet 0/1 察看交换机1 接口具体配置和统计信息

    switch#show mac-address-table 查看mac地址转发表

    • 交换机恢复出厂

    switch> enable

    switch# erase startup-configure

    switch# reload

    • telnet 远程登录设置:

    switch>en

    switch#configure terminal

    swich(conf)#enable password cisco 以cisco 为特权模式密码

    swich(conf)#interface vlan 1 以vlan 1端口作为远程登录的接口,其他端口亦可

    swich(conf-if)#ip address 192.168.1.1 255.255.255.0

    swich(conf-if)#no shut

    swich(conf-if)#exit

    swich(conf)line vty 0 4 设置0-4 个用户可以telnet 远程登陆

    swich(conf-line)#password 123456

    swich(conf-line)#login

    • SSH远程登录设置:

    Switch#conf t

    Enter configuration commands, one per line.  End with CNTL/Z.

    Switch(config)#hostname cisco-sw1   交换机重新命名

    cisco-sw1(config)#ip domain-name cisco.com 配置域名

    cisco-sw1(config)#line vty 0 4

    cisco-sw1(config-line)#transport input ssh 登录方式为SSH

    cisco-sw1(config-line)#exit

    cisco-sw1(config)#crypto key generate rsa 配置秘钥

    The name for the keys will be: cisco-sw1.cisco.com

    Choose the size of the key modulus in the range of 360 to 2048 for your

    General Purpose Keys. Choosing a key modulus greater than 512 may take

    a few minutes.

    How many bits in the modulus [512]: 1024 思科推荐使用1024

    % Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

    展开全文
  • CISCO交换机基本配置 switch>ena 進入特權模式 switch#erase nvram 全部清除交换机的所有配置 switch#reload 重新启动交换机(初始提示符为switch> )
  • 较全的CISCO交换机基本配置命令,用PPT制作的.很好用的.欢迎大家使用.
  • 思科交换机配置命令

    2012-07-10 12:12:41
    思科交换机配置命令 交换机基本状态: switch: ;ROM状态, 路由器是rommon> hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 交换机口令设置...
  • 思科2960交换机配置命令
  • 思科交换机常用配置命令》学习笔记(更新中)

    万次阅读 多人点赞 2018-12-09 13:21:40
    1、基本配置 Switch&gt;enable //进入特权模式 Switch# Switch#configure terminal //从特权模式进入全局配置模式 Switch(config)# Switch(config)#hostname cisco-sw1 //修改交换机名称 cisco-sw1(config)#...

    1、基本配置

    Switch>enable  //进入特权模式
    Switch#
    Switch#configure terminal  //从特权模式进入全局配置模式
    Switch(config)#
    Switch(config)#hostname cisco-sw1 //修改交换机名称
    cisco-sw1(config)#enable password cisco //配置交换机明文密码,登录特权模式时需要输入该密码
    cisco-sw1(config)#enable secret ciscoswitch  //配置交换机密文密码,登录特权模式时需要输入该密码
    

    2、交换机配置VLAN,并将端口加入到该VLAN

    cisco-sw1(config)#vlan 2
    cisco-sw1(config-vlan)#name test
    cisco-sw1(config-vlan)#exit
    cisco-sw1(config)#interface  fastEthernet 0/1
    cisco-sw1(config-if)#switchport mode access
    cisco-sw1(config-if)#switchport access vlan 2
    

    3、进入交换机某一端口

    switch> enable
    switch#configure terminal
    switch(conf)# interface fastehernet 0/1
    switch(conf-if)#
    

    4、show命令,交换机的所有配置和其它相关信息都需要通过show命令查看

    switch> enable
    switch#show version //查看系统中的所有版本信息
    switch#show  vlan id 1 //查看交换机有关vlan配置信息
    switch#show running-configure //查看交换机当前起作用的配置信息
    switch#show interface fastethernet 0/1 //查看交换机1 接口具体配置和统计信息
    switch#show mac-address-table //查看mac地址转发表
    

    5、交换机恢复出厂设置

    switch>enable
    switch#erase startup-configure
    switch# reload
    

    6、telnet远程登录设置

    switch>en
    switch#configure terminal
    swich(conf)#enable password cisco //以cisco为特权模式密码
    swich(conf)#interface vlan 1 //以vlan 1端口作为远程登录的接口,其他端口亦可
    swich(conf-if)#ip address 192.168.1.1 255.255.255.0
    swich(conf-if)#no shut
    swich(conf-if)#exit
    swich(conf)line vty 0 4 设置0-4 个用户可以telnet 远程登陆
    swich(conf-line)#password 123456
    swich(conf-line)#login
    

    7、SSH远程登录设置:

    Switch#conf t
    Switch(config)#hostname cisco-sw1   //交换机重新命名
    cisco-sw1(config)#ip domain-name cisco.com //配置域名
    cisco-sw1(config)#line vty 0 4
    cisco-sw1(config-line)#transport input ssh //登录方式为SSH
    cisco-sw1(config-line)#exit
    cisco-sw1(config)#crypto key generate rsa //配置秘钥
    
    展开全文
  • 配置MST的基本参数 启用MST的过程需要多不操作,它需要将一定的范围的VLAN映射到单个MSTI。 因为MST适用于多个VLAN的情况,所以它就比PVST+或RPVST+要求更多的其他配置。当用户通过命令:spanning-tree mode mst...
  • Cisco交换机管理配置 一般包括管理接口和默认网关配置,网速和双工配置,HTTP访问,MAC地址表管理,以及配置文件管理。 1.命令行界面模式 Cisco IOS软件讲EXEC(执行)会话分成以下两种访问级别。 用户执行:只允许...
  • 华为思科交换机基本配置 一、华为H3C配置 1.h3C交换机WEB管理用户配置 在系统试图[H3C]下,输入localuser XXX(WEB user name) XXX(WEB user password) 1(权限,当该值为0的时候只具有guest权限,1为管理员权限) ...
  • 思科交换机基本配置

    2013-07-16 10:45:28
    进入配置界面后,如果是第一次配置,则首先要进行的就是IP地址配置,这主要是为后面进行远程配置而准备。IP地址配置方法如下:在前面所出现的配置界面“Enter Selection:”后中输入“I”字母,然后单击回车键,则...
  • 华为交换机基本配置命令 华为交换机基本配置命令 一、单交换机VLAN划分命令 命令解释system 进入系统视图system-view 进入系统视图quit 退到系统视图undo vlan 20...
  • cisco思科交换机-常用命令配置

    万次阅读 多人点赞 2020-05-22 15:28:06
    switch> 用户模式 1:进入特权模式enable switch> enable switch# ...3:交换机命名hostname name 以cisco001 为例 switch> enable switch#c onfigure terminal switch(conf)#hostname cisc
  • 思科交换机配置命令大全 switch> 用户模式 1:进入特权模式enable switch> enable switch# 2:进入全局配置模式configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3...
  • Cisco 2950交换机基本配置命令

    千次阅读 2010-12-16 17:19:00
    Cisco 2950交换机基本配置命令
  • 1、基本概念介绍 IOS: 互联网操作系统,也就是交换机和路由器中用的操作系统 VLAN: 虚拟lan VTP: VLAN TRUNK PROTOCOL DHCP: 动态主机配置协议 ACL: 访问控制列表 三层交换机:具有三层路由转发能力的交换机本教程...
  • 包括了基本思科交换机和路由的配置命令,对于初学者来说很有用。
  • 思科交换机基本配置实例讲解(123)

    千次阅读 2017-12-26 10:32:00
    1、基本概念介绍 IOS: 互联网操作系统,也就是交换机和路由器中用的操作系统 VLAN: 虚拟lan VTP: VLAN TRUNK PROTOCOL DHCP: 动态主机配置协议 ACL: 访问控制列表 三层交换机:具有三层路由转发能力的...
  • 思科交换机简单的命令语句主要内容有:1查看MAC信息,2设置速率与双工模式,3 VLAN,4 Trunking的配置,5 VTP,6 以太网通道,7 生成树等。
  • 思科2960交换机 - 配置命令大全

    千次阅读 2018-11-13 15:36:47
    今天给大家分享下思科2960交换机配置命令: 一、使能口令和使能密码 1、使能口令(enable password),口令以明文显示。 2、使能密码(enbale secret), 口令以密文显示。 Switch.&gt; /*用户直行模式...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,641
精华内容 1,456
关键字:

思科交换机的基本配置命令