精华内容
下载资源
问答
  • 思科交换机iso

    2015-03-26 17:06:31
    思科交换机系统,3560 ,支持SSH..
  • 思科交换机管理(企业级思科交换机图型界面管理工具)
  • 思科交换机

    2018-12-06 23:40:00
    思科交换机配置命令大全 switch> 用户模式 1:进入特权模式 enable switch> enable switch# 2:进入全局配置模式 configure terminal switch> enable switch#c onfigure terminal switch...

                                           思科交换机配置命令大全


    switch> 用户模式
    1:进入特权模式 enable
    switch> enable
    switch#


    2:进入全局配置模式 configure terminal
    switch> enable
    switch#c onfigure terminal
    switch(conf)#


    3:交换机命名 hostname aptech2950 以 aptech2950 为例
    switch> enable
    switch#c onfigure terminal
    switch(conf)#hostname aptch-2950
    aptech2950(conf)#


    4:配置使能口令 enable password cisco 以 cisco 为例
    switch> enable
    switch#c onfigure terminal
    switch(conf)#hostname aptch2950
    aptech2950(conf)# enable password cisco


    5:配置使能密码 enable secret ciscolab 以 cicsolab 为例
    switch> enable
    switch#c onfigure terminal
    switch(conf)#hostname aptch2950
    aptech2950(conf)# enable secret ciscolab


    6:设置虚拟局域网 vlan 1 interface vlan 1
    switch> enable
    switch#c onfigure terminal
    switch(conf)#hostname aptch2950
    aptech2950(conf)# interface vlan 1
    aptech2950(conf-if)#ip address 192.168.1.1 255.255.255.0 配置交换机端口 ip 和子网掩码
    aptech2950(conf-if)#no shut 是配置处于运行中
    aptech2950(conf-if)#exit
    aptech2950(conf)#ip default-gateway 192.168.254 设置网关地址


    7:进入交换机某一端口 interface fastehernet 0/17 以 17 端口为例
    switch> enable
    switch#c onfigure terminal
    switch(conf)#hostname aptch2950
    aptech2950(conf)# interface fastehernet 0/17
    aptech2950(conf-if)#


    8:查看命令 show
    switch> enable
    switch# show version 察看系统中的所有版本信息
    show interface vlan 1 查看交换机有关 ip 协议的配置信息
    show running-configure 查看交换机当前起作用的配置信息
    show interface fastethernet 0/1 察看交换机 1 接口具体配置和统计信息
    show mac-address-table 查看 mac 地址表
    show mac-address-table aging-time 查看 mac 地址表自动老化时间


    9:交换机恢复出厂默认恢复命令
    switch> enable
    switch# erase startup-configure
    switch# reload


    10:双工模式设置
    switch> enable
    switch#c onfigure terminal
    switch2950(conf)#hostname aptch-2950
    aptech2950(conf)# interface fastehernet 0/17 以 17 端口为例
    aptech2950(conf-if)#duplex full/half/auto 有 full , half, auto 三个可选


    11:cdp 相关命令
    switch> enable
    switch# show cdp 查看设备的 cdp 全局配置信息
    show cdp interface fastethernet 0/17 查看 17 端口的 cdp 配置信息
    show cdp traffic 查看有关 cdp 包的统计信息
    show cdp nerghbors 列出与设备相连的 cisco 设备


    12:csico2950 的密码恢复
    拔下交换机电源线。
    用手按着交换机的 MODE 键,插上电源线
    在 switch:后执行 flash_ini 命令:switch: flash_ini
    查看 flash 中的文件: switch: dir flash:
    把“config.text”文件改名为“config.old”: switch: rename flash: config.text flash: config.old
    执行 boot: switch: boot
    交换机进入是否进入配置的对话,执行 no :
    进入特权模式察看 flash 里的文件: show flash :
    把“config.old”文件改名为“config.text”: switch: rename flash: config.old flash: config.text
    把 “ config.text ” 拷 入 系 统 的 “ running-configure ”: copy flash: config.text system :
    running-configure
    把配置模式重新设置密码存盘,密码恢复成功。


    13:交换机 telnet 远程登录设置:
    switch>en
    switch#c onfigure terminal
    switch(conf)#hostname aptech-2950
    aptech2950(conf)#enable password cisco 以 cisco 为特权模式密码
    aptech2950(conf)#interface fastethernet 0/1 以 17 端口为 telnet 远程登录端口
    aptech2950(conf-if)#ip address 192.168.1.1 255.255.255.0
    aptech2950(conf-if)#no shut
    aptech2950(conf-if)#exit
    aptech2950(conf)line vty 0 4 设置 0-4 个用户可以 telnet 远程登陆
    aptech2950(conf-line)#login
    aptech2950(conf-line)#password edge 以 edge 为远程登录的用户密码
    主机设置:
    ip 192.168.1.2 主机的 ip 必须和交换机端口的地址在同一网络

    netmask 255.255.255.0
    gate-way 192.168.1.1 网关地址是交换机端口地址
    运行:
    telnet 192.168.1.1
    进入 telnet 远程登录界面
    password : edge
    aptech2950>en
    password: cisco
    aptech#


    14:交换机配置的重新载入和保存
    设置完成交换机的配置后:
    aptech2950(conf)#reload
    是否保存(y/n) y: 保存设置信息 n:不保存设置信息


    1.在基于 IOS 的交换机上设置主机名/系统名:
    switch(config)# hostname hostname
    在基于 CLI 的交换机上设置主机名/系统名:
    switch(enable) set system name name-string


    2.在基于 IOS 的交换机上设置登录口令:
    switch(config)# enable password level 1 password
    在基于 CLI 的交换机上设置登录口令:
    switch(enable) set password
    switch(enable) set enalbepass


    3.在基于 IOS 的交换机上设置远程访问:
    switch(config)# interface vlan 1
    switch(config-if)# ip address ip-address netmask
    switch(config-if)# ip default-gateway ip-address
    在基于 CLI 的交换机上设置远程访问:
    switch(enable) set interface sc0 ip-address netmask broadcast-address
    switch(enable) set interface sc0 vlan
    switch(enable) set ip route default gateway


    4.在基于 IOS 的交换机上启用和浏览 CDP 信息:
    switch(config-if)# cdp enable
    switch(config-if)# no cdp enable
    为了查看 Cisco 邻接设备的 CDP 通告信息:
    switch# show cdp interface [type modle/port]
    switch# show cdp neighbors [type module/port] [detail]
    在基于 CLI 的交换机上启用和浏览 CDP 信息:
    switch(enable) set cdp {enable|disable} module/port
    为了查看 Cisco 邻接设备的 CDP 通告信息:
    switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]


    5.基于 IOS 的交换机的端口描述:
    switch(config-if)# description description-string
    基于 CLI 的交换机的端口描述:
    switch(enable)set port name module/number description-string


    6.在基于 IOS 的交换机上设置端口速度:
    switch(config-if)# speed{10|100|auto}
    在基于 CLI 的交换机上设置端口速度:
    switch(enable) set port speed moudle/number {10|100|auto}
    switch(enable) set port speed moudle/number {4|16|auto}


    7.在基于 IOS 的交换机上设置以太网的链路模式:
    switch(config-if)# duplex {auto|full|half}
    在基于 CLI 的交换机上设置以太网的链路模式:
    switch(enable) set port duplex module/number {full|half}


    8.在基于 IOS 的交换机上配置静态 VLAN:
    switch# vlan database
    switch(vlan)# vlan vlan-num name vla
    switch(vlan)# exit
    switch# configure teriminal
    switch(config)# interface interface module/number
    switch(config-if)# switchport mode access
    switch(config-if)# switchport access vlan vlan-num
    switch(config-if)# end
    在基于 CLI 的交换机上配置静态 VLAN:
    switch(enable) set vlan vlan-num [name name]
    switch(enable) set vlan vlan-num mod-num/port-list


    9. 在基于 IOS 的交换机上配置 VLAN 中继线:
    switch(config)# interface interface mod/port
    switch(config-if)# switchport mode trunk
    switch(config-if)# switchport trunk encapsulation {isl|dotlq}
    switch(config-if)# switchport trunk allowed vlan remove vlan-list
    switch(config-if)# switchport trunk allowed vlan add vlan-list
    在基于 CLI 的交换机上配置 VLAN 中继线:
    switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]
    Vlan-range [isl|dotlq|dotl0|lane|negotiate]


    10.在基于 IOS 的交换机上配置 VTP 管理域:
    switch# vlan database
    switch(vlan)# vtp domain domain-name
    在基于 CLI 的交换机上配置 VTP 管理域:
    switch(enable) set vtp [domain domain-name]


    11.在基于 IOS 的交换机上配置 VTP 模式:
    switch# vlan database
    switch(vlan)# vtp domain domain-name
    switch(vlan)# vtp {sever|cilent|transparent}
    switch(vlan)# vtp password password
    在基于 CLI 的交换机上配置 VTP 模式:
    switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password
    password]


    12. 在基于 IOS 的交换机上配置 VTP 版本:
    switch# vlan database
    switch(vlan)# vtp v2-mode
    在基于 CLI 的交换机上配置 VTP 版本:
    switch(enable) set vtp v2 enable


    13. 在基于 IOS 的交换机上启动 VTP 剪裁:
    switch# vlan database
    switch(vlan)# vtp pruning
    在基于 CL I 的交换机上启动 VTP 剪裁:
    switch(enable) set vtp pruning enable


    14.在基于 IOS 的交换机上配置以太信道:
    switch(config-if)# port group group-number [distribution {source|destination}]
    在基于 CLI 的交换机上配置以太信道:
    switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}


    15.在基于 IOS 的交换机上调整根路径成本:
    switch(config-if)# spanning-tree [vlan vlan-list] cost cost
    在基于 CLI 的交换机上调整根路径成本:
    switch(enable) set spantree portcost moudle/port cost
    switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]


    16.在基于 IOS 的交换机上调整端口 ID:
    switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority
    在基于 CLI 的交换机上调整端口 ID:
    switch(enable) set spantree portpri {mldule/port}priority
    switch(enable) set spantree portvlanpri {module/port}priority [vlans]


    17. 在基于 IOS 的交换机上修改 STP 时钟:
    switch(config)# spanning-tree [vlan vlan-list] hello-time seconds
    switch(config)# spanning-tree [vlan vlan-list] forward-time seconds
    ` switch(config)# spanning-tree [vlan vlan-list] max-age seconds
    在基于 CLI 的交换机上修改 STP 时钟:
    switch(enable) set spantree hello interval[vlan]
    switch(enable) set spantree fwddelay delay [vlan]
    switch(enable) set spantree maxage agingtiame[vlan]


    18. 在基于 IOS 的交换机端口上启用或禁用 Port Fast 特征:
    switch(config-if)#spanning-tree portfast
    在基于 CLI 的交换机端口上启用或禁用 Port Fast 特征:
    switch(enable) set spantree portfast {module/port}{enable|disable}


    19. 在基于 IOS 的交换机端口上启用或禁用 UplinkFast 特征:
    switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]
    在基于 CLI 的交换机端口上启用或禁用 UplinkFast 特征:
    switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]


    20. 为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个 IP 地址,然后使
    用下列命令: switch(config)# cluster enable cluster-name


    21. 为了从一条中继链路上删除 VLAN,可使用下列命令:
    switch(enable) clear trunk module/port vlan-range


    22. 用 show vtp domain 显示管理域的 VTP 参数.


    23. 用 show vtp statistics 显示管理域的 VTP 参数.


    24. 在 Catalyst 交换机上定义 TrBRF 的命令如下:
    switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]


    25. 在 Catalyst 交换机上定义 TrCRF 的命令如下:
    switch (enable) set vlan vlan-num [name name] type trcrf
    {ring hex-ring-num|decring decimal-ring-num} parent vlan-num


    26. 在创建好 TrBRF VLAN 之后,就可以给它分配交换机端口.对于以太网交换,可以采用如
    下命令给 VLAN 分配端口:
    switch(enable) set vlan vlan-num mod-num/port-num


    27. 命令 show spantree 显示一个交换机端口的 STP 状态.


    28. 配置一个 ELAN 的 LES 和 BUS,可以使用下列命令:
    ATM (config)# interface atm number.subint multioint
    ATM(config-subif)# lane serber-bus ethernet elan-name


    29. 配置 LECS:
    ATM(config)# lane database database-name
    ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address
    ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address
    ATM(lane-config-databade)# name …


    30. 创建完数据库后,必须在主接口上启动 LECS.命令如下:
    ATM(config)# interface atm number
    ATM(config-if)# lane config database database-name
    ATM(config-if)# lane config auto-config-atm-address


    31. 将每个 LEC 配置到一个不同的 ATM 子接口上.命令如下:
    ATM(config)# interface atm number.subint multipoint
    ATM(config)# lane client ethernet vlan-num elan-num


    32. 用 show lane server 显示 LES 的状态.


    33. 用 show lane bus 显示 bus 的状态.


    34. 用 show lane database 显示 LECS 数据库可内容.


    35. 用 show lane client 显示 LEC 的状态.


    36. 用 show module 显示已安装的模块列表.


    37. 用物理接口建立与 VLAN 的连接:
    router# configure terminal
    router(config)# interface media module/port
    router(config-if)# description description-string
    router(config-if)# ip address ip-addr subnet-mask
    router(config-if)# no shutdown


    38. 用中继链路来建立与 VLAN 的连接:
    router(config)# interface module/port.subinterface
    router(config-ig)# encapsulation[isl|dotlq] vlan-number
    router(config-if)# ip address ip-address subnet-mask


    39. 用 LANE 来建立与 VLAN 的连接:
    router(config)# interface atm module/port
    router(config-if)# no ip address
    router(config-if)# atm pvc 1 0 5 qsaal
    router(config-if)# atm pvc 2 0 16 ilni
    router(config-if)# interface atm module/port.subinterface multipoint
    router(config-if)# ip address ip-address subnet-mask
    router(config-if)# lane client ethernet elan-num
    router(config-if)# interface atm module/port.subinterface multipoint
    router(config-if)# ip address ip-address subnet-name
    router(config-if)# lane client ethernet elan-name
    router(config-if)# …


    40. 为了在路由处理器上进行动态路由配置,可以用下列 IOS 命令来进行:
    router(config)# ip routing
    router(config)# router ip-routing-protocol
    router(config-router)# network ip-network-number
    router(config-router)# network ip-network-number


    41. 配置默认路由:
    switch(enable) set ip route default gateway


    42. 为一个路由处理器分配 VLANID,可在接口模式下使用下列命令:
    router(config)# interface interface number
    router(config-if)# mls rp vlan-id vlan-id-num


    43. 在路由处理器启用 MLSP:
    router(config)# mls rp ip


    44. 为了把一个外置的路由处理器接口和交换机安置在同一个 VTP 域中:
    router(config)# interface interface number
    router(config-if)# mls rp vtp-domain domain-name


    45. 查看指定的 VTP 域的信息:
    router# show mls rp vtp-domain vtp domain name


    46. 要确定 RSM 或路由器上的管理接口,可以在接口模式下输入下列命令:
    router(config-if)#mls rp management-interface


    47. 要检验 MLS-RP 的配置情况:
    router# show mls rp


    48. 检验特定接口上的 MLS 配置:
    router# show mls rp interface interface number


    49. 为了在 MLS-SE 上设置流掩码而又不想在任一个路由处理器接口上设置访问列表:
    set mls flow [destination|destination-source|full]


    50. 为使 MLS 和输入访问列表可以兼容,可以在全局模式下使用下列命令:
    router(config)# mls rp ip input-acl


    51. 当某个交换机的第 3 层交换失效时,可在交换机的特权模式下输入下列命令:
    switch(enable) set mls enable


    52. 若想改变老化时间的值,可在特权模式下输入以下命令:
    switch(enable) set mls agingtime agingtime


    53. 设置快速老化:
    switch(enable) set mls agingtime fast fastagingtime pkt_threshold


    54. 确定那些 MLS-RP 和 MLS-SE 参与了 MLS,可先显示交换机引用列表中的内容再确定:
    switch(enable) show mls include


    55. 显示 MLS 高速缓存记录:
    switch(enable) show mls entry


    56. 用命令 show in arp 显示 ARP 高速缓存区的内容。


    57. 要把路由器配置为 HSRP 备份组的成员,可以在接口配置模式下使用下面的命令:
    router(config-if)# standby group-number ip ip-address


    58. 为了使一个路由器重新恢复转发路由器的角色,在接口配置模式下:
    router(config-if)# standy group-number preempt


    59. 访问时间和保持时间参数是可配置的:
    router(config-if)# standy group-number timers hellotime holdtime


    60. 配置 HSRP 跟踪:
    router(config-if)# standy group-number track type-number interface-priority


    61. 要显示 HSRP 路由器的状态:
    router# show standby type-number group brief


    62. 用命令 show ip igmp 确定当选的查询器。


    63. 启动 IP 组播路由选择:
    router(config)# ip muticast-routing


    64. 启动接口上的 PIM:
    dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}


    65. 启动稀疏-稠密模式下的 PIM:
    router# ip multicast-routing
    router# interface type number
    router# ip pim sparse-dense-mode


    66. 核实 PIM 的配置:
    dallasr1># show ip pim interface[type number] [count]


    67. 显示 PIM 邻居:
    dallasr1># show ip neighbor type number


    68. 为了配置 RP 的地址,命令如下:
    dallasr1># ip pim rp-address ip-address [group-access-list-number][override]


    69. 选择一个默认的 RP:
    dallasr1># ip pim rp-address
    通告 RP 和它所服务的组范围:
    dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number
    为管理范围组通告 RP 的地址:
    dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1
    dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255
    设定一个 RP 映像代理:
    dallasr1># ip pim send-rp-discovery scope ttl
    核实组到 RP 的映像:
    dallasr1># show ip pim rp mapping
    dallasr1># show ip pim rp [group-name|group-address] [mapping]


    70. 在路由器接口上用命令 ip multicast ttl-threshold ttl-value 设定 TTL 阀值:
    dallasr1>(config-if)# ip multicast ttl-threshold ttl-value


    71. 用 show ip pim neighbor 显示 PIM 邻居表。


    72. 显示组播通信路由表中的各条记录:
    dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]


    73. 要记录一个路由器接受和发送的全部 IP 组播包:
    dallasr1> #debug ip mpacket [detail] [access-list][group]


    74. 要在 CISCO 路由器上配置 CGMP:
    dallasr1>(config-if)# ip cgmp


    75.配置一个组播路由器,使之加入某一个特定的组播组:
    dallasr1>(config-if)# ip igmp join-group group-address


    76. 关闭 CGMP:
    dallasr1>(config-if)# no ip cgmp


    77. 启动交换机上的 CGMP:
    dallasr1>(enable) set cgmp enable


    78. 核实 Catalyst 交换机上 CGMP 的配置情况:
    catalystla1>(enable) show config
    set prompt catalystla1>
    set interface sc0 192.168.1.1 255.255.255.0
    set cgmp enable


    79. CGMP 离开的设置:
    Dallas_SW(enable) set cgmp leave


    80. 在 Cisco 设备上修改控制端口密码:
    R1(config)# line console 0
    R1(config-line)# login
    R1(config-line)# password Lisbon
    R1(config)# enable password Lilbao
    R1(config)# login local
    R1(config)# username student password cisco


    81. 在 Cisco 设备上设置控制台及 vty 端口的会话超时:
    R1(config)# line console 0
    R1(config-line)# exec-timeout 5 10
    R1(config)# line vty 0 4
    R1(config-line)# exec-timeout 5 2


    82. 在 Cisco 设备上设定特权级:
    R1(config)# privilege configure level 3 username
    R1(config)# privilege configure level 3 copy run start
    R1(config)# privilege configure level 3 ping
    R1(config)# privilege configure level 3 show run
    R1(config)# enable secret level 3 cisco


    83. 使用命令 privilege 可定义在该特权级下使用的命令:
    router(config)# privilege mode level level command


    84. 设定用户特权级:
    router(config)# enable secret level 3 dallas
    router(config)# enable secret san-fran
    router(config)# username student password cisco


    85. 标志设置与显示:
    R1(config)# banner motd ‘unauthorized access will be prosecuted!’


    86. 设置 vty 访问:
    R1(config)# access-list 1 permit 192.168.2.5
    R1(config)# line vty 0 4
    R1(config)# access-class 1 in


    87. 配置 HTTP 访问:
    Router3(config)# access-list 1 permit 192.168.10.7
    Router3(config)# ip http sever
    Router3(config)# ip http access-class 1
    Router3(config)# ip http authentication local
    Router3(config)# username student password cisco


    88. 要启用 HTTP 访问,请键入以下命令:
    switch(config)# ip http sever


    89. 在基于 set 命令的交换机上用 setCL1 启动和核实端口安全:
    switch(enable) set port security mod_num/port_num…enable mac address
    switch(enable) show port mod_num/port_num
    在基于 CiscoIOS 命令的交换机上启动和核实端口安全:
    switch(config-if)# port secure [mac-mac-count maximum-MAC-count]
    switch# show mac-address-table security [type module/port]


    90. 用命令 access-list 在标准通信量过滤表中创建一条记录:
    Router(config)# access-list access-list-number {permit|deny} source-address [source-address]


    91. 用命令 access-list 在扩展通信量过滤表中创建一条记录:
    Router(config)# access-list access-list-number {permit|deny{protocol|protocol-keyword}}{source
    source-wildcard|any}{destination destination-wildcard|any}[protocol-specific options][log]


    92. 对于带内路由更新,配置路由更新的最基本的命令格式是:
    R1(config-router)#distribute-list access-list-number|name in [type number]


    93. 对于带外路由更新,配置路由更新的最基本的命令格式是:
    R1(config-router)#distribute-list access-list-number|name out [interface-name] routing-process|
    autonomous-system-number


    94. set snmp 命令选项:
    set snmp community {read-only|ready-write|read-write-all}[community_string]


    95. set snmp trap 命令格式如下:
    set snmp trap {enable|disable}
    [all|moudle|classis|bridge|repeater| auth|vtp|ippermit|vmps|config|entity|stpx]
    set snmp trap rvcr_addr rcvr_community


    96. 启用 SNMP chassis 陷阱:
    Console>(enable) set snmp trap enable chassis


    97. 启用所有 SNMP chassis 陷阱:
    Console>(enable) set snmp trap enable
    …………以下由 about 于 2002 年 12 月 6 日增加…………


    98. 禁用 SNMP chassis 陷阱:
    Console>(enable) set snmp trap disable chassis
    99. 给 SNMP 陷阱接收表加一条记录:
    Console>(enable) set snmp trap 192.122.173.42 public


    100. show snmp 输出结果。


    101. 命令 set snmp rmon enable 的输出结果。


    102. 显示 SPAN 信息:
    Consile> show spanCISCO 交换机配置命令大全

    展开全文
  • 思科交换机7200镜像

    2020-08-26 10:56:23
    思科交换机7200镜像,可在小凡模拟器(模拟交换机)或者是cisco模拟起上加载使用,方便大家下载使用。
  • 思科交换机 2960 ISO

    2011-11-17 13:13:05
    思科交换机 2960系统ISO文件,可以用来配合模拟器做各种实验。
  • 思科交换机C3550 ISO

    2011-11-17 13:14:38
    思科交换机 3550系统ISO文件,可以用来配合模拟器做各种实验。
  • 思科2950交换机系统

    2016-02-23 11:48:42
    思科2950交换机系统包,用于重装交换机系统
  • 思科交换机 C3750 ISO

    2011-11-17 13:16:07
    思科交换机 C3750系统ISO文件,可以用来配合模拟器做各种实验。
  • 思科交换机9200L系列破解密码、开机不加载系统、堆叠 1、console连接设备与电脑,加电按住(10-15S)交换机“接口面”左上角Mode键,进入BIOS模式Switch:。 2、进入BIOS模式,其实也干不了啥,能查看dir flash文件...

    思科交换机9200L系列破解密码、开机不加载系统、堆叠

    1、console连接设备与电脑,加电按住(10-15S)交换机“接口面”左上角Mode键,进入BIOS模式Switch:。
    在这里插入图片描述


    2、进入BIOS模式,其实也干不了啥,能查看dir flash文件、arp、ping、ping6、set、unset、boot等,功能比较少,delete都干不了。
    如果你单纯的想跳过密码,只需要输入
    Switch:SWITCH_IGNORE_STARTUP_CFG=1
    然后在输入boot加载启动镜像就可以了
    Switch:boot


    3、交换机正常启动,重置密码
    Switch>
    Switch>en
    Switch#
    将startup配置恢复到运行的running下,因为你已经进入特许权模式,所以就不需要密码了。
    Switch#copy startup-config running-config
    重置密码
    Switch#conf t
    Switch(config)#enable password 7 xxxxxxxxxx
    Switch(config)#username xxx priority 15 secret xxx
    切记修改完密码,一定修改启动项加载模式,保存
    Switch(config)#no system ignore startupconfig switch all
    Switch(config)#exit
    Switch#write


    注意:BIOS模式下,虽然别的操作做不了,但是可以通过输入Switch:set,进行部署环境变量,有兴趣的小伙伴可以尝试一般按照里面的模式可以进行类似赋值操作,unset进行删除。

    如果交换机每次开机启动都不加载系统,而是直接进入BIOS(Switch:)可以考虑以下两点:
    1、检查系统IOS是否正常;

    2、检查引导文件是否正确;
    Switch:set / 其中有一项
    BOOT=flash:文件名
    如果不正确,有两种方法:
    可以unset删除,在set设置上
    或者boot加载镜像,全局模式下boot system flash:IOS文件名
    删除该文件bootper.log(记不清单词了,大致是这个)
    保存

    3、初步判断寄存器值有问题,修改成0x2102
    修改方法:
    正常配置模式下,全局模式Switch(config)#config-register 0x2102,保存,重启;
    BIOS模式下,confreg 0x2102
    boot启动加载镜像。

    堆叠设备最好将堆叠模式取消(断掉堆叠线)在进行恢复。

    展开全文
  • 思科交换机及路由器升级失败恢复方法 思科交换机及路由器升级失败恢复方法
  • 思科交换机进入rommon模式 交换机进入rommon的方法
  • 思科交换机命令

    2019-06-28 14:09:39
    交换机模拟器实验六 2.查看端口名字 SWA#sh vlan default Active F0/1, F0/2, F0/3, F0/4, F0/5, F0/6, F0/7, F0/8 f是端口名子 default Active Gi/1, Gi0/2, Gi0/3, Gi0/4, Gi0/5, Gi0/6, Gi0/7...

    1.不同的vlan

    不同vlan需要路由
    在路由的端口设置多个IP段
    交换机模拟器实验六

    2.查看端口名字

    SWA#sh vlan
    default Active F0/1, F0/2, F0/3, F0/4, F0/5, F0/6, F0/7, F0/8
    f是端口名子
    default Active Gi/1, Gi0/2, Gi0/3, Gi0/4, Gi0/5, Gi0/6, Gi0/7, Gi0/8
    Gi是端口名字

    3.创建动态链路聚合

    Switch(config)#interface range g0/21-22
    Switch(config-if-range)#channel-group 1 mode active
    Switch(config-if-range)#exit

    4.创建端口的链路类型

    以太网端口有三种链路类型:Access、Hybrid、Trunk。Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;Trunk 类型的端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;Hybrid类型的端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。Hybrid端口和Trunk端口的不同之处在于Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

    表1-9 设置以太网端口的链路类型

    操作
    命令

    设置端口为Access端口
    Switch(config)#interface range g0/21-22
    Switch(config)#switchport mode access

    设置端口为Hybrid端口
    Switch(config)#interface range g0/21-22
    Switch(config)#switchport mode hybrid

    设置端口为Trunk端口
    Switch(config)#interface range g0/21-22
    Switch(config)#switchport mode trunk

    恢复端口的链路类型为缺省的Access端口
    undo port link-type

    三种类型的端口可以共存在一台以太网交换机上,但Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其他类型端口。例如:Trunk端口不能直接被设置为Hybrid端口,只能先设为Access端口,再设置为Hybrid端口。

    缺省情况下,端口为Access端口。

    需要注意的是:Access端口加入的VLAN必须已经存在并且不能是缺省VLAN;Hybrid端口加入的VLAN必须已经存在;Trunk端口加入的VLAN不能是缺省VLAN。

    执行了本配置,当前以太网端口就可以转发指定VLAN的报文。Hybrid端口和Trunk端口可以加入到多个VLAN中,从而实现本交换机上的VLAN与对端交换机上相同VLAN的互通。Hybrid端口还可以设置哪些VLAN的报文打上标签,哪些不打标签,为实现对不同VLAN报文执行不同处理流程打下基础

    5.交换机显示命令

    思科重启

    思科所有的重启命令都是reload

    交换机显示命令:

    switch#write ;保存配置信息
    switch#show vtp ;查看vtp配置信息
    switch#show run ;查看当前配置信息
    switch#show vlan ;查看vlan配置信息
    switch#show interface ;查看端口信息
    switch#show int f0/0 ;查看指定端口信息
    switch#show cdp nei ;查看端口上行设备及连接的对应端口信息
    switch#show ip int bir 查看端口VLAN IP 开启状态总览
    switch#show int status 查看端口状态总览
    switch#show inventory 查看光模块显信
    switch#sh int etherchannel sum 查看“端口聚合/链路捆绑
    switch#sh int port-channel 查看“端口聚合/链路捆绑
    switch#show spanning-tree 查看生成树状态
    switch#show access-list 查看规则状态
    switch#show history 查看历史输入命令
    switch#show errdisable recovery 查看哪些保护会在超时后可自动恢复
    switch#show errdisable detect​查看 err-disabled 状态的原因

    6.配置vlan的IP
    s(config)#int vlan 6
    s(config-vlan)#no shu
    s(config-vlan)#ip add 10.2.20.1 255.255.255.254
    SWA#wr
    7.配置交换机的IP和网关

    配置交换机网关:Switch(config)#ip default-gateway 网关

    switch(config)#int vlan 1
    设置ip地址和掩码:
    switch(config-if)#ip address 10.65.1.3 255.255.0.0
    设置switch的网关:
    switch(config)#ip defaule-gateway 10.65.1.9
    查看当前配置:
    switch#sh run

    8.清除思科所有配置

    SWA#del vlan.dat
    SWA#reload

    9.删除动态链接

    Switch(config)#interface range g0/21-22
    Switch(config-if-range)#no channel-group 1
    Switch(config-if-range)#exit

    10.设置vtp

    switch(config)#vtp domain ;设置发vtp域名
    switch(config)#vtp password ;设置发vtp密码
    switch(config)#vtp mode server ;设置发vtp模式
    switch(config)#vtp mode client ;设置发vtp模式

    11.设置思科交换机的IP和子网掩码

    switch#conf t
    进入默认VLAN状态:
    switch(config)#int vlan 1
    设置ip地址和掩码:
    switch(config-if)#ip address 10.65.1.3 255.255.0.0
    设置switch的网关:
    switch(config)#ip defaule-gateway 10.65.1.9
    查看当前配置:
    switch#sh run
    SWA#write

    12.思科telnet登陆方法

    开始–cmd—telnet

    13.思科保存方法

    在全局配置模式下
    Router#copy running-config startup-config //保存当前的配置

    Router#write
    也行

    14.思科查看vlan

    SWA#sh vlan

    15.思科查看当前配置

    查看当前配置:
    switch#sh run

      16.思科恢复出厂设置
    

    Switch#erase startup-config

    Switch#reload

    有提示要保存配置 就选择no

    17.思科将端口加入vlan
    

    SWA(config)#int f0/5 (f是端口号sh vlan可以看端口号,端口号是不一样的我们的是Gi)
    SWA(config-if)#switchport access vlan 2
    SWA(config-if)#int f0/6
    SWA(config-if)#switchport access vlan 2
    SWA(config-if)#int f0/7
    SWA(config-if)#switchport access vlan 2
    SWA(config-if)# end
    SWA#sh vlan
    SWA#wr(保存)

    18.思科和电脑接法
    

    首先这个软件不能连接真实设备:
    选择一台PC,一个设备(交换机,路由器都行)
    连接PC和设备,线缆选择蓝色线缆,英文应该是console—控制台的意思。连接是,PC上选择RS232接口,设备上选择CONSOLE接口
    连接好之后,双击PC图标,打开一个窗口,点击桌面(desktop),再选择终端(terminal),点击OK,就可以了!

    19.思科进入
    

    Switch>enable
    Switch#

    20.思科模式

    呵呵终于找到一个关于cisco的问题了。

    朋友你好,我就用我自己的语言表达了哈,有点长哈,但一定帮你学懂哈。思科的路由器的用户界面有以下几种:
    1.用户执行模式(User EXEC Mode)
    2.特权执行模式(Privileged EXEC Mode)
    3.全局配置模式(Global Configuration Mode)
    4.监控模式(ROM Monitor Mode) 安ctrl + break
    5.安装模式(Setup Mode) 先进入特权模式 在setup 就行
    6.Boot模式(RXBoot Mode)

    常用的是1、2和3。下面我就来正式回答你问的。

    路由器一开机,进去的那个界面提示符是“>”,比如像这样子哈,“Router>”这个就是用户执行模式,也是最低级别的模式,它只允许有限数量的基本监视命令,该模式下不允许任何会改变路由器配置的命令。

    那我们要配置路由器时该咋弄呢,这时就必须先得进入到“特权执行模式”了(也就是在用户执行模式下输入“enable”命令)。出现像这样的提示符“#”,比如“Router#”。相比用户执行模式,它提供更多的命令和权限,比如debug命令,和更为细致的测试等。

    至于“全局配置模式”,是配置(全局)系统和相应的具体细节配置(比如接口ip、路由协议这些)时进入的界面,在此配置的东东是影响全局的。全局配置模式的提示符是这样的“(config)#”,比如我这里举的例就该是“Router(config)#”。

    而要配置具体的东东就得从全局配置模式下进入到相应的子配置模式下。比如:
    Router(config-if)# //具体的接口配置
    Router(config-line)# //line模式配置,比如console和vty这些哈
    Router(config-router)# //路由器模式,比如配置路由协议时

    百度知道不能回帖功能不够强大,不然我可以重新更漂亮的排版和标记,好让朋友更加容易理解。

    简单总结下你的问题就是,特权执行模式主要是用来调试的,全局配置模式是用来配置的。而且他们的关系,要到达全局配置模式,你必须先得处在特权执行模式哈。

    而相应的命令见下面哈:

    Router>
    Router>enable //将从用户执行模式进入到特权执行模式
    Password: //如果对特权执行模式设置了密码的话,进入时还得输入密码哈
    Router#
    Router#exit //将从特权执行模式退回到用户执行模式
    Router>

    //下面我演示如何从用户执行模式一步步到达全局配置模式哈:
    Router>enable
    Router#
    Router#configure terminal
    Router(config)#

    21.思科配置vlan并保存

    SWA#vlan database
    SWA(vlan)#vlan 2
    SWA(vlan)#vlan 3
    SWA(vlan)#exit
    SWA#write

    22.思科配置远程登录

    111(config)# line vty 0 4 进入虚拟线程配置模式,在这个模式里可对
    telnet功能进行配置
    111(config-line)# login
    111(config-line)# password XXX 配置telnet密码,默认的网络设备telnet的功能是
    关闭的,配了密码之后会自动打开
    111(config)# enable password XXX 配置进入enable模式的密码, 区分大小写
    111(config)# enable secret XXX 配置进入enable模式的密码,是加密的密码,show
    run是看不见的
    111(config)# line console 0
    111(config-line)# login
    111(config-line)# password XXX 配置进入用户模式的密码
    111(config-line)# logging synchronous 输入同步
    111(config-line)# exec-timeout 0 0 禁止因为一段时间没有输入而跳出
    111#SWA#write保存配置
    23.思科批处理登陆

    off
    echo set sh=WScript.CreateObject(“WScript.Shell”) >telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “open 你的网络设备telnet登录IP” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “{ENTER}” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “你的用户名{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “你的密码{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “conf{ENTER}”>>telnet_tmp.vbs
    start telnet
    cscript //nologo telnet_tmp.vbs
    del telnet_tmp.vbs
    24.思科删除vlan

    jjf{cinfig}#no vlan 10 删除vlan10
    jjf{cinfig}#end 回到特权模式
    jjf{cinfig}sh vlan 查看vlan
    SWA#write

                              25.思科设置trunk干线
    

    设置干线trunk
    将连接两个交换机的端口设置成trunk。
    SWA(config)#int f0/8
    SWA(config-if)#switchport mode trunk
    SWA(config-if)#switchport trunk allowed vlan 1,2,3(只允许vlan 1 2 3 在这条个trunk链路上走,这个就是vlan修剪。)
    SWA(config-if)#switchport trunk encap dot1q(可以不要dot1q是vlan中继协议(802.1q)一般交换机都是自带的)
    SWA(config-if)#end
    SWA#sh run

    SWB(config)#int f0/1
    SWB(config-if)#switchport mode trunk
    SWB(config-if)#switchport trunk allowed vlan 1,2,3
    SWB(config-if)#switchport trunk encap dot1q
    SWB(config-if)#end
    SWB#sh run
    26.思科型号

    Cisco Catalyst 2960G-24TC-L 24个以太网10/100/1000端口,其中有4个为两用端口

                                  26.思科远程登陆pingIP地址(可做批处理)
    

    off
    echo set sh=WScript.CreateObject(“WScript.Shell”) >telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “open 登陆交换机IP地址” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “{ENTER}” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “用户名{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “登录密码{ENTER}”>>telnet_tmp.vbs
    echo sh.SendKeys “ping 192.168.0.2{ENTER}” >>telnet_tmp.vbs
    start telnet
    cscript //nologo telnet_tmp.vbs
    echo del telnet_tmp.vbs
    27.思科远程交换机登陆配置

    1.进入vlan 1接口模式
    switch(config)#interface vlan 1
    2.打开vlan 1端口
    switch(config-if)#no shutdown
    3.配置vlan 1的IP地址
    switch(config-if)#ip address 172.16.10.99 255.255.255.0
    三、配置交换机Telnet登录
    1.在全局配置模式下设置特权模式口令
    switch(config)#enable password cisco
    2.在全局配置模式下设置虚拟终端(Virtual terminal)的线路号
    switch(config)#line vty 0 4
    switch(config-line)#
    3.在线路配置模式下设置通过虚拟终端登录的用户口令为net(必须设置口令才能使用管理IP远程登录交换机)
    switch(config-line)#password net
    4.在线路配置模式下使用login命令测试是否可以远程登录
    switch(config-line)#login
    switch(config-line)#
    如果没有出现提示,说明设置成功,如果出现五行提示,说明设置有误。
    四、使用PC1机远程登录交换机
    1.将PC1用直通线连接到交换机的FastEthernet0/3端口。
    2.打开PC1的“桌面”上的“IP配置”,选择静态配置,设置IP地址为172.16.10.100,子网掩码为255.255.255.0。
    3.打开PC1的“桌面”上的“命令提示符”。
    4. 在命令提示符中使用telnet命令远程登录交换机(交换机管理IP地址为172.16.10.99)
    PC>telnet 172.16.10.99
    Trying 172.16.10.99 …
    User Access Verification
    Password:
    在接下来出现的password提示文字后输入前面交换机上设定的telnet登录口令net(该口令输入时不会显示任何符号),即可进入交换机的用户配置模式。
    5.输入特权模式口令进入全局配置模式
    在用户配置模式下输入enable命令,再后输入所配置的特权模式口令cisco(该口令输入时不会显示任何符号)即可进入全局配置模式进行后续网络设置。
    Switch>enable
    Password:
    28. 思科重启

    思科所有的重启命令都是reload

                                   29.           远程登录交换机可做批处理
    

    off
    echo set sh=WScript.CreateObject(“WScript.Shell”) >telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “open 192.168.6.100” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “{enter}” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “root{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “jjf1{ENTER}”>>telnet_tmp.vbs

    start telnet
    cscript //nologo telnet_tmp.vbs
    echo del telnet_tmp.vbs

    Translating “enb”…domain server (255.255.255.255) 快捷键
    ctrl shift + 6 no ip domain

    明天的你会感谢今天拼命奋斗的自己1.不同的vlan

    不同vlan需要路由
    在路由的端口设置多个IP段
    交换机模拟器实验六

    2.查看端口名字

    SWA#sh vlan
    default Active F0/1, F0/2, F0/3, F0/4, F0/5, F0/6, F0/7, F0/8
    f是端口名子
    default Active Gi/1, Gi0/2, Gi0/3, Gi0/4, Gi0/5, Gi0/6, Gi0/7, Gi0/8
    Gi是端口名字

    3.创建动态链路聚合

    Switch(config)#interface range g0/21-22
    Switch(config-if-range)#channel-group 1 mode active
    Switch(config-if-range)#exit

    4.创建端口的链路类型

    以太网端口有三种链路类型:Access、Hybrid、Trunk。Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;Trunk 类型的端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;Hybrid类型的端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。Hybrid端口和Trunk端口的不同之处在于Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

    表1-9 设置以太网端口的链路类型

    操作
    命令

    设置端口为Access端口
    Switch(config)#interface range g0/21-22
    Switch(config)#switchport mode access

    设置端口为Hybrid端口
    Switch(config)#interface range g0/21-22
    Switch(config)#switchport mode hybrid

    设置端口为Trunk端口
    Switch(config)#interface range g0/21-22
    Switch(config)#switchport mode trunk

    恢复端口的链路类型为缺省的Access端口
    undo port link-type

    三种类型的端口可以共存在一台以太网交换机上,但Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其他类型端口。例如:Trunk端口不能直接被设置为Hybrid端口,只能先设为Access端口,再设置为Hybrid端口。

    缺省情况下,端口为Access端口。

    需要注意的是:Access端口加入的VLAN必须已经存在并且不能是缺省VLAN;Hybrid端口加入的VLAN必须已经存在;Trunk端口加入的VLAN不能是缺省VLAN。

    执行了本配置,当前以太网端口就可以转发指定VLAN的报文。Hybrid端口和Trunk端口可以加入到多个VLAN中,从而实现本交换机上的VLAN与对端交换机上相同VLAN的互通。Hybrid端口还可以设置哪些VLAN的报文打上标签,哪些不打标签,为实现对不同VLAN报文执行不同处理流程打下基础

    5.交换机显示命令

    思科重启

    思科所有的重启命令都是reload

    交换机显示命令:

    switch#write ;保存配置信息
    switch#show vtp ;查看vtp配置信息
    switch#show run ;查看当前配置信息
    switch#show vlan ;查看vlan配置信息
    switch#show interface ;查看端口信息
    switch#show int f0/0 ;查看指定端口信息
    switch#show cdp nei ;查看端口上行设备及连接的对应端口信息
    switch#show ip int bir 查看端口VLAN IP 开启状态总览
    switch#show int status 查看端口状态总览
    switch#show inventory 查看光模块显信
    switch#sh int etherchannel sum 查看“端口聚合/链路捆绑
    switch#sh int port-channel 查看“端口聚合/链路捆绑
    switch#show spanning-tree 查看生成树状态
    switch#show access-list 查看规则状态
    switch#show history 查看历史输入命令
    switch#show errdisable recovery 查看哪些保护会在超时后可自动恢复
    switch#show errdisable detect​查看 err-disabled 状态的原因

    6.配置vlan的IP
    s(config)#int vlan 6
    s(config-vlan)#no shu
    s(config-vlan)#ip add 10.2.20.1 255.255.255.254
    SWA#wr
    7.配置交换机的IP和网关

    配置交换机网关:Switch(config)#ip default-gateway 网关

    switch(config)#int vlan 1
    设置ip地址和掩码:
    switch(config-if)#ip address 10.65.1.3 255.255.0.0
    设置switch的网关:
    switch(config)#ip defaule-gateway 10.65.1.9
    查看当前配置:
    switch#sh run

    8.清除思科所有配置

    SWA#del vlan.dat
    SWA#reload

    9.删除动态链接

    Switch(config)#interface range g0/21-22
    Switch(config-if-range)#no channel-group 1
    Switch(config-if-range)#exit

    10.设置vtp

    switch(config)#vtp domain ;设置发vtp域名
    switch(config)#vtp password ;设置发vtp密码
    switch(config)#vtp mode server ;设置发vtp模式
    switch(config)#vtp mode client ;设置发vtp模式

    11.设置思科交换机的IP和子网掩码

    switch#conf t
    进入默认VLAN状态:
    switch(config)#int vlan 1
    设置ip地址和掩码:
    switch(config-if)#ip address 10.65.1.3 255.255.0.0
    设置switch的网关:
    switch(config)#ip defaule-gateway 10.65.1.9
    查看当前配置:
    switch#sh run
    SWA#write

    12.思科telnet登陆方法

    开始–cmd—telnet

    13.思科保存方法

    在全局配置模式下
    Router#copy running-config startup-config //保存当前的配置

    Router#write
    也行

    14.思科查看vlan

    SWA#sh vlan

    15.思科查看当前配置

    查看当前配置:
    switch#sh run

      16.思科恢复出厂设置
    

    Switch#erase startup-config

    Switch#reload

    有提示要保存配置 就选择no

    17.思科将端口加入vlan
    

    SWA(config)#int f0/5 (f是端口号sh vlan可以看端口号,端口号是不一样的我们的是Gi)
    SWA(config-if)#switchport access vlan 2
    SWA(config-if)#int f0/6
    SWA(config-if)#switchport access vlan 2
    SWA(config-if)#int f0/7
    SWA(config-if)#switchport access vlan 2
    SWA(config-if)# end
    SWA#sh vlan
    SWA#wr(保存)

    18.思科和电脑接法
    

    首先这个软件不能连接真实设备:
    选择一台PC,一个设备(交换机,路由器都行)
    连接PC和设备,线缆选择蓝色线缆,英文应该是console—控制台的意思。连接是,PC上选择RS232接口,设备上选择CONSOLE接口
    连接好之后,双击PC图标,打开一个窗口,点击桌面(desktop),再选择终端(terminal),点击OK,就可以了!

    19.思科进入
    

    Switch>enable
    Switch#

    20.思科模式

    呵呵终于找到一个关于cisco的问题了。

    朋友你好,我就用我自己的语言表达了哈,有点长哈,但一定帮你学懂哈。思科的路由器的用户界面有以下几种:
    1.用户执行模式(User EXEC Mode)
    2.特权执行模式(Privileged EXEC Mode)
    3.全局配置模式(Global Configuration Mode)
    4.监控模式(ROM Monitor Mode) 安ctrl + break
    5.安装模式(Setup Mode) 先进入特权模式 在setup 就行
    6.Boot模式(RXBoot Mode)

    常用的是1、2和3。下面我就来正式回答你问的。

    路由器一开机,进去的那个界面提示符是“>”,比如像这样子哈,“Router>”这个就是用户执行模式,也是最低级别的模式,它只允许有限数量的基本监视命令,该模式下不允许任何会改变路由器配置的命令。

    那我们要配置路由器时该咋弄呢,这时就必须先得进入到“特权执行模式”了(也就是在用户执行模式下输入“enable”命令)。出现像这样的提示符“#”,比如“Router#”。相比用户执行模式,它提供更多的命令和权限,比如debug命令,和更为细致的测试等。

    至于“全局配置模式”,是配置(全局)系统和相应的具体细节配置(比如接口ip、路由协议这些)时进入的界面,在此配置的东东是影响全局的。全局配置模式的提示符是这样的“(config)#”,比如我这里举的例就该是“Router(config)#”。

    而要配置具体的东东就得从全局配置模式下进入到相应的子配置模式下。比如:
    Router(config-if)# //具体的接口配置
    Router(config-line)# //line模式配置,比如console和vty这些哈
    Router(config-router)# //路由器模式,比如配置路由协议时

    百度知道不能回帖功能不够强大,不然我可以重新更漂亮的排版和标记,好让朋友更加容易理解。

    简单总结下你的问题就是,特权执行模式主要是用来调试的,全局配置模式是用来配置的。而且他们的关系,要到达全局配置模式,你必须先得处在特权执行模式哈。

    而相应的命令见下面哈:

    Router>
    Router>enable //将从用户执行模式进入到特权执行模式
    Password: //如果对特权执行模式设置了密码的话,进入时还得输入密码哈
    Router#
    Router#exit //将从特权执行模式退回到用户执行模式
    Router>

    //下面我演示如何从用户执行模式一步步到达全局配置模式哈:
    Router>enable
    Router#
    Router#configure terminal
    Router(config)#

    21.思科配置vlan并保存

    SWA#vlan database
    SWA(vlan)#vlan 2
    SWA(vlan)#vlan 3
    SWA(vlan)#exit
    SWA#write

    22.思科配置远程登录

    111(config)# line vty 0 4 进入虚拟线程配置模式,在这个模式里可对
    telnet功能进行配置
    111(config-line)# login
    111(config-line)# password XXX 配置telnet密码,默认的网络设备telnet的功能是
    关闭的,配了密码之后会自动打开
    111(config)# enable password XXX 配置进入enable模式的密码, 区分大小写
    111(config)# enable secret XXX 配置进入enable模式的密码,是加密的密码,show
    run是看不见的
    111(config)# line console 0
    111(config-line)# login
    111(config-line)# password XXX 配置进入用户模式的密码
    111(config-line)# logging synchronous 输入同步
    111(config-line)# exec-timeout 0 0 禁止因为一段时间没有输入而跳出
    111#SWA#write保存配置
    23.思科批处理登陆

    off
    echo set sh=WScript.CreateObject(“WScript.Shell”) >telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “open 你的网络设备telnet登录IP” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “{ENTER}” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “你的用户名{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “你的密码{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “conf{ENTER}”>>telnet_tmp.vbs
    start telnet
    cscript //nologo telnet_tmp.vbs
    del telnet_tmp.vbs
    24.思科删除vlan

    jjf{cinfig}#no vlan 10 删除vlan10
    jjf{cinfig}#end 回到特权模式
    jjf{cinfig}sh vlan 查看vlan
    SWA#write

                              25.思科设置trunk干线
    

    设置干线trunk
    将连接两个交换机的端口设置成trunk。
    SWA(config)#int f0/8
    SWA(config-if)#switchport mode trunk
    SWA(config-if)#switchport trunk allowed vlan 1,2,3(只允许vlan 1 2 3 在这条个trunk链路上走,这个就是vlan修剪。)
    SWA(config-if)#switchport trunk encap dot1q(可以不要dot1q是vlan中继协议(802.1q)一般交换机都是自带的)
    SWA(config-if)#end
    SWA#sh run

    SWB(config)#int f0/1
    SWB(config-if)#switchport mode trunk
    SWB(config-if)#switchport trunk allowed vlan 1,2,3
    SWB(config-if)#switchport trunk encap dot1q
    SWB(config-if)#end
    SWB#sh run
    26.思科型号

    Cisco Catalyst 2960G-24TC-L 24个以太网10/100/1000端口,其中有4个为两用端口

                                  26.思科远程登陆pingIP地址(可做批处理)
    

    off
    echo set sh=WScript.CreateObject(“WScript.Shell”) >telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “open 登陆交换机IP地址” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “{ENTER}” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “用户名{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “登录密码{ENTER}”>>telnet_tmp.vbs
    echo sh.SendKeys “ping 192.168.0.2{ENTER}” >>telnet_tmp.vbs
    start telnet
    cscript //nologo telnet_tmp.vbs
    echo del telnet_tmp.vbs
    27.思科远程交换机登陆配置

    1.进入vlan 1接口模式
    switch(config)#interface vlan 1
    2.打开vlan 1端口
    switch(config-if)#no shutdown
    3.配置vlan 1的IP地址
    switch(config-if)#ip address 172.16.10.99 255.255.255.0
    三、配置交换机Telnet登录
    1.在全局配置模式下设置特权模式口令
    switch(config)#enable password cisco
    2.在全局配置模式下设置虚拟终端(Virtual terminal)的线路号
    switch(config)#line vty 0 4
    switch(config-line)#
    3.在线路配置模式下设置通过虚拟终端登录的用户口令为net(必须设置口令才能使用管理IP远程登录交换机)
    switch(config-line)#password net
    4.在线路配置模式下使用login命令测试是否可以远程登录
    switch(config-line)#login
    switch(config-line)#
    如果没有出现提示,说明设置成功,如果出现五行提示,说明设置有误。
    四、使用PC1机远程登录交换机
    1.将PC1用直通线连接到交换机的FastEthernet0/3端口。
    2.打开PC1的“桌面”上的“IP配置”,选择静态配置,设置IP地址为172.16.10.100,子网掩码为255.255.255.0。
    3.打开PC1的“桌面”上的“命令提示符”。
    4. 在命令提示符中使用telnet命令远程登录交换机(交换机管理IP地址为172.16.10.99)
    PC>telnet 172.16.10.99
    Trying 172.16.10.99 …
    User Access Verification
    Password:
    在接下来出现的password提示文字后输入前面交换机上设定的telnet登录口令net(该口令输入时不会显示任何符号),即可进入交换机的用户配置模式。
    5.输入特权模式口令进入全局配置模式
    在用户配置模式下输入enable命令,再后输入所配置的特权模式口令cisco(该口令输入时不会显示任何符号)即可进入全局配置模式进行后续网络设置。
    Switch>enable
    Password:
    28. 思科重启

    思科所有的重启命令都是reload

                                   29.           远程登录交换机可做批处理
    

    off
    echo set sh=WScript.CreateObject(“WScript.Shell”) >telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “open 192.168.6.100” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “{enter}” >>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “root{ENTER}”>>telnet_tmp.vbs
    echo WScript.Sleep 300 >>telnet_tmp.vbs
    echo sh.SendKeys “jjf1{ENTER}”>>telnet_tmp.vbs

    start telnet
    cscript //nologo telnet_tmp.vbs
    echo del telnet_tmp.vbs

    Translating “enb”…domain server (255.255.255.255) 快捷键
    ctrl shift + 6 no ip domain

    明天的你会感谢今天拼命奋斗的自己

    展开全文
  • 思科交换机常用命令汇总 show version show running-config show vlan brief show ip interface brief show running-config interface f0/1 show ip route show inventory //显示设备SN、设备名 更换MAC地址 在...

    思科交换机常用命令汇总

    show version
    show running-config
    show vlan brief
    show ip interface brief
    show running-config interface f0/1
    show ip route
    show inventory			//显示设备SN、设备名
    

    更换MAC地址

    在网管服务器上找到相应的报警信息,记录下交换机的IP地址及端口号。
    telnet交换机的IP地址(这里使用CRT)

    #show running-configuration interface f0/1
    右键标记,选择有MAC地址的那行命令,回车
    conf t
    interface f0/1
    no 右键粘贴			//删除原先绑定的MAC地址,这个端口会自动学习到新的MAC
    end
    show run interface f0/1
    wr				   //一定要保存配置MAC地址绑定才能生效
    

    更改业务

    show vlan brie
    conf t
    interface f0/1
    switchport access vlan 2	//把端口加入新的VLAN中
    end
    show run interface f0/1
    wr
    

    新增端口

    conf t
    show run interface f0/1
    switchport port-security
    switchport port-security violation restrict
    switchport port-security mac-address sticky
    
    如果没有配置过,则打开一个配置过的端口
    复制除VLAN和绑定MAC地址以外的命令行
    
    switchport access vlan 2
    no shutdown
    end
    show run interface f0/1
    看到端口在VLAN2中,已经学到MAC地址
    wr
    

    清除MAC记录

    no switchport port-security mac-address sticky XXXX.XXXX.XXXX vlan access
    

    关闭端口

    清除MAC地址
    interface f0/1
    shutdown
    

    关闭端口安全

    interface f0/1
    no switchport port-security
    

    备份配置

    copy run tftp
    Address or name of remote host []? 192.168.32.1
    Destination filename [config.text]?TEST-3560-1 
    

    恢复配置

    copy tftp: run
    Address or name of remote host []? 192.168.32.1
    Source filename []? test.text
    Destination filename [running-config]? 
    

    清除配置

    清除交换机配置命令:write erase
    	当然也可以使用erase startup-config就可以实现清除了
    删除VLAN信息:delete flash:vlan.dat
    

    IOS升级

    1.确保路由器与服务器的连通性(路由器配IP地址)
    
    2.从服务器更新IOS镜像
    #copy tftp flash
    []192.168.1.100					服务器的地址
    []c1841-advipservicesk9-mz.124-15.Tw.bin	新IOS的名称,注意大小写
    []						复制过来后的名称
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!...!!!!!!	开始复制文件
    
    3.察看并删除旧的IOS(在需要更新的路由器上进行操作)
    #show flash				察看要删除的镜像名称
    #delete flash
    []c1841-ipbasek9-mz.124-12.bin		输入删除的镜像名称,注意大小写
    
    4.重新配置系统并重启
    (c)#no boot system flash 旧镜像名	不让系统从旧的镜像启动
    (c)#boot system flash 新镜像名称	让系统以新镜像启动
    #copy running-config startup-config	将新的配置写到NVROM5.重启
    #reload
    
    展开全文
  • 思科交换机查看配置及日常维护命令,方便日常维护查询
  • 思科交换机基本配置手册: 1.在基于IOS的交换机上设置主机名/系统名: switch(config)# hostname hostname 在基于CLI的交换机上设置主机名/系统名: switch(enable) set system name name-string 2.在基于...
  • 思科交换机端口聚合

    千次阅读 2020-10-27 20:32:33
    端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。但是,失去了路径冗余的优点,因为STP的链路切换会很慢,在50s左右。使用以太通道的话,交换机会把一组物理端口联合起来,做为一个逻辑的通道...
  • 思科交换机指示灯全解

    千次阅读 2019-06-24 17:08:45
    思科交换机指示灯全解 交换机前面板有几个指示灯,用于监控系统的活动和性能,这些指示灯称之为发光二极管(LED)。前面板上的指示灯包括:系统指示灯、远程电源供应指示灯、端口模式指示灯、端口状态指示灯。 1....
  • 好用的思科交换机路由器模拟器 方便地放置交换机路由器终端等。 真实模拟系统操作命令。 帮你通过思科认证
  • 思科交换机的基本配置命令

    千次阅读 2018-07-03 13:32:38
    思科交换机的基本配置命令思科交换机的基本配置命令学习CISCO交换机基本配置:Console端口连接用户模式hostname# ;特权模式hostname(config)# ;全局配置模式hostname(config-if)# ;交换机口令设置:switch&gt...
  • 思科交换机Cisco交换机中的flash,Rom,RAM,nvram的区别 Flash内存,也叫闪存,是路由器当中常用的一种内存类型。它是可读写的存储器,在系统重新启动或关机之后仍能保存数据。Flash中存放着当前使用中 的IOS...
  • 一.... >enable #configure trminal ...(confing)#line console 0←...①(config-line)#password (cisco)←密码 (config-line)#login ← 一定不能少的. console密码设置完成 exit 二:设置全局密码 ena
  • 思科交换机密码设置

    千次阅读 2012-05-23 14:40:52
    思科交换机密码配置 一.设置console密码 >enable #configure trminal (confing)#line console 0←console口 ①(config-line)#password (cisco)←密码 (config-line)#login ← 一定不能少的. console密码设置...
  • 对于思科交换机来说,主要有2种配置途径:其一,使用交换机自带的Console线缆连接到计算机的COM口,然后利用计算机的超级终端软件直接配置,首次配置通常使用这种方式;其二,通过telnet方式远程访问、配置交换机,...
  • 思科交换机的配置模式基本配置命令 打开思科交换CLI,首先进入的是用户模式,如果要进行配置操作需要进入特权模式。 Switch>enable Switch# 从特权模式进入全局配置模式 Switch#configure terminal Switch...
  • 思科交换机的安装方法介绍

    千次阅读 2018-07-16 17:39:39
    交换机 ,简单的来说就是一种“开关”,是一种...但是大家可能对思科交换机的安装不太了解,一起来看看吧。 思科交换机安装的方法 当我们在安装交换机之前,我们应该保持机房里面是干燥的,并且机房要是比较通风...
  • 思科交换机N7K升级具体过程,cisco nexus 7010 升级到cisco推荐的稳定版本,以后打算一直用,没事尽量不升版本,cisco搜索nexus 7000 upgrade 有各种文档,很长的,介绍各种方法,原理,其中有如何升完一个引擎,再...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 9,662
精华内容 3,864
关键字:

思科交换机系统