精华内容
下载资源
问答
  • 个人收藏,适合初学者。一些基本的例子.喜欢的就下,适合与初学者。本人初学者,有志者多多交流
  • 配置环境:EVE-NG 拓扑: /// #配置链路聚合 #设置主机名 Switch(config)#hostname hxjh1 #配置vlan接口ip地址 hxjh1(config)#interface vlan 1 hxjh1(config-if)#ip address 192.168.0.1 255.255.255.0 hxjh1...

    配置环境:EVE-NG
    拓扑:
    在这里插入图片描述
    ///
    #配置链路聚合
    #设置主机名
    Switch(config)#hostname hxjh1
    #配置vlan接口ip地址
    hxjh1(config)#interface vlan 1
    hxjh1(config-if)#ip address 192.168.0.1 255.255.255.0
    hxjh1(config)#interface vlan 2
    hxjh1(config-if)#ip address 192.168.2.1 255.255.255.0
    hxjh1(config-if)#no shutdown
    #定义聚合组,配置聚合组
    hxjh1(config)#interface port-channel 10
    hxjh1(config-if)#description test
    hxjh1(config-if)#switchport mode trunk
    Command rejected: Po10 not a switching port.
    hxjh1(config-if)#switchport trunk encapsulation dot1q
    hxjh1(config-if)#switchport mode trunk
    hxjh1(config-if)#switchport trunk allowed vlan all
    hxjh1(config-if)#no shutdown
    #接口加入聚合组
    hxjh1(config)#interface e0/2
    hxjh1(config-if)#no shutdown
    hxjh1(config-if)#channel-group 10 mode active
    #接口加入聚合组
    hxjh1(config-if)#interface e0/3
    hxjh1(config-if)#no shutdown
    hxjh1(config-if)#channel-group 10 mode active
    #查看聚合组状态
    hxjh1# show etherchannel detail
    ///
    ///
    #登录配置
    #配置console口密码
    hxjh1(config)#line console 0
    hxjh1(config-line)#login
    % Login disabled on line 0, until ‘password’ is set
    hxjh1(config-line)#password admin
    #配置enable密码
    hxjh1(config)#enable secret admin
    #配置本地用户登录方式
    hxjh1(config)#line vty 0 4
    hxjh1(config-line)#login local
    #配置登录用户
    hxjh1(config)#username admin privilege 15 secret admin
    #配置本地域名
    hxjh1(config)#ip domain-name test.com
    #生成秘钥对
    hxjh1(config)#crypto key generate rsa
    #配置ssh登录认证次数
    hxjh1(config)#ip ssh authentication-retries 3
    #配置认证超时时间
    hxjh1(config)#ip ssh time-out 120
    #查看SSH状态信息
    hxjh1#show ip ssh
    SSH Enabled - version 1.5
    Authentication timeout: 120 secs; Authentication retries: 3
    ///
    ///

    #交换机1完整配置
    hxjh1#show running-config
    Building configuration...
    
    Current configuration : 1269 bytes
    !
    version 15.0
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname hxjh1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    enable secret 5 $1$N2IH$EJ46qTQz2G5PP1r834fr2.
    !
    username admin privilege 15 secret 5 $1$k3NR$tvKHhIm.5NY2yHOJ13IXB.
    no aaa new-model
    clock timezone EET 2
    !
    ip cef
    ip domain-name test.com
    !
    no ipv6 cef
    !
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    ip ssh version 1
    !
    !
    !
    !
    !
    !
    interface Port-channel10
     description test
     switchport
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface Ethernet0/0
     duplex auto
    !
    interface Ethernet0/1
     duplex auto
    !
    interface Ethernet0/2
     switchport trunk encapsulation dot1q
     switchport mode trunk
     duplex auto
     channel-group 10 mode active
    !
    interface Ethernet0/3
     switchport trunk encapsulation dot1q
     switchport mode trunk
     duplex auto
     channel-group 10 mode active
    !
    interface Vlan1
     ip address 192.168.0.1 255.255.255.0
    !
    interface Vlan2
     ip address 192.168.2.1 255.255.255.0
    !
    !
    ip forward-protocol nd
    no ip http server
    !
    !
    !
    !
    !
    control-plane
    !
    !
    line con 0
     password admin
     logging synchronous
     login
    line aux 0
    line vty 0 4
     login local
     transport input all
    !
    end
    

    ///
    ///

    #交换机2完整配置
    hxjh2#show running-config
    Building configuration...
    
    Current configuration : 1257 bytes
    !
    version 15.0
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname hxjh2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    enable secret 5 $1$aPzQ$M7suR.LH9sTDB/dyr1TT8/
    !
    username admin privilege 15 secret 5 $1$KZID$jtdZKHRjhfEsn1diUXidQ.
    no aaa new-model
    clock timezone EET 2
    !
    ip cef
    ip domain-name test.com
    !
    no ipv6 cef
    !
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    ip ssh version 1
    !
    !
    !
    !
    !
    !
    interface Port-channel10
     description test
     switchport
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface Ethernet0/0
     duplex auto
    !
    interface Ethernet0/1
     switchport access vlan 2
     switchport mode access
     duplex auto
    !
    interface Ethernet0/2
     switchport trunk encapsulation dot1q
     switchport mode trunk
     duplex auto
     channel-group 10 mode active
    !
    interface Ethernet0/3
     switchport trunk encapsulation dot1q
     switchport mode trunk
     duplex auto
     channel-group 10 mode active
    !
    interface Vlan1
     ip address 192.168.0.2 255.255.255.0
    !
    !
    ip forward-protocol nd
    no ip http server
    !
    !
    !
    !
    !
    control-plane
    !
    !
    line con 0
     password admin
     logging synchronous
     login
    line aux 0
    line vty 0 4
     login
     transport input all
    !
    end
    

    ///
    查看链路聚合:

    hxjh2#show etherchannel summary
    Flags:  D - down        P - bundled in port-channel
            I - stand-alone s - suspended
            H - Hot-standby (LACP only)
            R - Layer3      S - Layer2
            U - in use      N - not in use, no aggregation
            f - failed to allocate aggregator
    
            M - not in use, no aggregation due to minimum links not met
            m - not in use, port not aggregated due to minimum links not met
            u - unsuitable for bundling
            d - default port
    
            w - waiting to be aggregated
    Number of channel-groups in use: 1
    Number of aggregators:           1
    
    Group  Port-channel  Protocol    Ports
    ------+-------------+-----------+-----------------------------------------------
    10     Po10(SU)        LACP      Et0/2(P)       Et0/3(P)
    

    验证ssh登录:

    hxjh2#ssh -l admin 192.168.0.1
    Password:
    

    验证连通性:

    VPCS> ping 192.168.0.1
    
    84 bytes from 192.168.0.1 icmp_seq=1 ttl=255 time=0.335 ms
    84 bytes from 192.168.0.1 icmp_seq=2 ttl=255 time=0.516 ms
    84 bytes from 192.168.0.1 icmp_seq=3 ttl=255 time=4.029 ms
    84 bytes from 192.168.0.1 icmp_seq=4 ttl=255 time=0.445 ms
    84 bytes from 192.168.0.1 icmp_seq=5 ttl=255 time=1.579 ms
    
    展开全文
  • 本文将介绍一些生成树相关的知识以及如何在思科交换机上使用 MSTP。二、知识普及2.1 传统生成树协议的缺陷我们都知道,公有的 STP 和 RSTP 都只能在一台交换机上创建一个生成树实例(这个实例叫做 CST,即公用生成树...

    一、前言

    MSTP 的全称是多生成树协议(Multiple Spanning Tree Protocol),它是目前最完美而且兼容性最好的公有生成树协议。

    本文将介绍一些生成树相关的知识以及如何在思科交换机上使用 MSTP。

    二、知识普及

    2.1 传统生成树协议的缺陷

    我们都知道,公有的 STP 和 RSTP 都只能在一台交换机上创建一个生成树实例(这个实例叫做 CST,即公用生成树)。

    虽然这样可以节省交换机的系统资源,但由于冗余链路是完全不转发数据的,所以会造成严重的带宽浪费。

    针对这一点,思科开发了 PVST+ 和 Rapid-PVST+ 两款私有的生成树协议。这两款生成树协议会为每一个 VLAN 创建一个生成树实例,每个 VLAN 也都会有自己独立的根桥。

    这样做虽然不会浪费带宽资源,但是生成树实例数会随着 VLAN 数的的增加而增加。当交换机存在大量 VLAN 时,大量的系统资源都会被浪费在生成树的计算上。并且,PVST+ 和 Rapid-PVST+ 都只能用在思科设备上,兼容性差。

    2.2 MSTP 简介

    MSTP 是 IEEE 基于 RSTP,结合 Rapid-PVST+ 的优点开发的公有生成树协议。

    MSTP 最大的特点是可以根据实际需要创建任意多个生成树实例,并且每个生成树实例都可以跟一个或多个 VLAN 绑定。

    MSTP 完全消除了传统生成树协议的缺陷,并且还是公有协议。所以 MSTP 是目前主流的生成树协议。

    MSTP 有域的概念,它可将整个运行 MSTP 的网络分为多个不同的域。域间使用的是公共生成树(CST),域内使用的是内部生成树(IST)。在公共生成树(CST)中,每个域都可看作是一台逻辑交换机,且不同域间只能通过实例 0 进行互操作。

    MSTP 的架构如下图:

    b4be52657caa92ff896fab47c8cfbf56.png

    不过多域 MSTP 一般很少使用,基本上只用于支持 MSTP 的交换机与不支持 MSTP 交换机的互操作。

    如果想让所有交换机都处在同一个域中,必须满足以下几点:
    1. 所有交换机的域名必须相同。
    2. 所有交换机的修订版本必须相同。
    3. 所有交换机 VLAN 到实例的映射必须相同。

    在默认情况下,交换机的所有 VLAN 都会被映射到实例 0 中。并且实例 0 不可被删除。

    三、网络拓扑图及说明

    470b1709df3046d01d1c7b1fb7b4b5d7.png

    如图,整网有 6 台交换机。现在要求 Switch1 做 VLAN 10、20、30 的根桥,Switch2 做 VLAN 40、50、60 的根桥。整网使用单域的 MSTP,域名为 cisco,修订版本为 1

    下面只讲与 MSTP 相关的配置。

    四、配置方法

    4.1 Switch1

    进入 MSTP 配置模式:

    Switch1(config)#spanning-tree mst configuration

    设置域名为 cisco

    Switch1(config-mst)#name cisco

    设置修订版本为 1

    Switch1(config-mst)#revision 1

    将 VLAN 10、20、30 绑定到实例 1 上:

    Switch1(config-mst)#instance 1 vlan 10, 20, 30

    将 VLAN 40、50、60 绑定到实例 2 上:

    Switch1(config-mst)#instance 2 vlan 40, 50, 60

    退出 MSTP 配置模式:

    Switch1(config-mst)#exit

    将本交换机设为 MSTP 实例 1(VLAN 10、20、30)的根桥:

    Switch1(config)#spanning-tree mst 1 root primary

    将本交换机设为 MSTP 实例 2(VLAN 40、50、60)的备份根桥:

    Switch1(config)#spanning-tree mst 2 root secondary

    4.2 Switch2

    进入 MSTP 配置模式:

    Switch2(config)#spanning-tree mst configuration

    设置域名为 cisco

    Switch2(config-mst)#name cisco

    设置修订版本为 1

    Switch2(config-mst)#revision 1

    将 VLAN 10、20、30 绑定到实例 1 上:

    Switch2(config-mst)#instance 1 vlan 10, 20, 30

    将 VLAN 40、50、60 绑定到实例 2 上:

    Switch2(config-mst)#instance 2 vlan 40, 50, 60

    退出 MSTP 配置模式:

    Switch2(config-mst)#exit

    将本交换机设为 MSTP 实例 2(VLAN 40、50、60)的根桥:

    Switch2(config)#spanning-tree mst 2 root primary

    将本交换机设为 MSTP 实例 1(VLAN 10、20、30)的备份根桥:

    Switch2(config)#spanning-tree mst 1 root secondary

    4.3 Switch3

    进入 MSTP 配置模式:

    Switch3(config)#spanning-tree mst configuration

    设置域名为 cisco

    Switch3(config-mst)#name cisco

    设置修订版本为 1

    Switch3(config-mst)#revision 1

    将 VLAN 10、20、30 绑定到实例 1 上:

    Switch3(config-mst)#instance 1 vlan 10, 20, 30

    将 VLAN 40、50、60 绑定到实例 2 上:

    Switch3(config-mst)#instance 2 vlan 40, 50, 60

    退出 MSTP 配置模式:

    Switch3(config-mst)#exit

    4.4 Switch4

    进入 MSTP 配置模式:

    Switch4(config)#spanning-tree mst configuration

    设置域名为 cisco

    Switch4(config-mst)#name cisco

    设置修订版本为 1

    Switch4(config-mst)#revision 1

    将 VLAN 10、20、30 绑定到实例 1 上:

    Switch4(config-mst)#instance 1 vlan 10, 20, 30

    将 VLAN 40、50、60 绑定到实例 2 上:

    Switch4(config-mst)#instance 2 vlan 40, 50, 60

    退出 MSTP 配置模式:

    Switch4(config-mst)#exit

    4.5 Switch5

    进入 MSTP 配置模式:

    Switch5(config)#spanning-tree mst configuration

    设置域名为 cisco

    Switch5(config-mst)#name cisco

    设置修订版本为 1

    Switch5(config-mst)#revision 1

    将 VLAN 10、20、30 绑定到实例 1 上:

    Switch5(config-mst)#instance 1 vlan 10, 20, 30

    将 VLAN 40、50、60 绑定到实例 2 上:

    Switch5(config-mst)#instance 2 vlan 40, 50, 60

    退出 MSTP 配置模式:

    Switch5(config-mst)#exit

    4.6 Switch6

    进入 MSTP 配置模式:

    Switch6(config)#spanning-tree mst configuration

    设置域名为 cisco

    Switch6(config-mst)#name cisco

    设置修订版本为 1

    Switch6(config-mst)#revision 1

    将 VLAN 10、20、30 绑定到实例 1 上:

    Switch6(config-mst)#instance 1 vlan 10, 20, 30

    将 VLAN 40、50、60 绑定到实例 2 上:

    Switch6(config-mst)#instance 2 vlan 40, 50, 60

    退出 MSTP 配置模式:

    Switch6(config-mst)#exit

    五、验证结果

    下面我们来看一下 Switch1 和 Switch2 MST 实例 12 的信息。

    5.1 Switch1 的 MST 信息

    实例 1

    Switch1#show spanning-tree mst 1
    
    ##### MST1    vlans mapped:   10,20,30 <-- VLAN 10,20,30 映射到了该实例中
    Bridge        address 5001.0001.0000  priority      24577 (24576 sysid 1)
    Root          this switch for MST1 <-- 本交换机是该实例的根桥
    
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Gi0/0            Desg FWD 20000     128.1    P2p 
    Gi0/1            Desg FWD 20000     128.2    P2p 
    Gi0/2            Desg FWD 20000     128.3    P2p 
    Gi0/3            Desg FWD 20000     128.4    P2p 
    Gi1/0            Desg FWD 20000     128.5    P2p 
    Gi1/1            Desg FWD 20000     128.6    P2p 

    实例 2

    Switch1#show spanning-tree mst 2
    
    ##### MST2    vlans mapped:   40,50,60 <-- VLAN 40,50,60 映射到了该实例中
    Bridge        address 5001.0001.0000  priority      28674 (28672 sysid 2)
    Root          address 5001.0002.0000  priority      24578 (24576 sysid 2)
                  port    Gi1/0           cost          20000     rem hops 19
    
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Gi0/0            Desg FWD 20000     128.1    P2p 
    Gi0/1            Desg FWD 20000     128.2    P2p 
    Gi0/2            Desg FWD 20000     128.3    P2p 
    Gi0/3            Desg FWD 20000     128.4    P2p 
    Gi1/0            Root FWD 20000     128.5    P2p 
    Gi1/1            Altn BLK 20000     128.6    P2p 

    5.2 Switch2 的 MST 信息

    实例 1

    Switch2#show spanning-tree mst 1
    
    ##### MST1    vlans mapped:   10,20,30 <-- VLAN 10,20,30 映射到了该实例中
    Bridge        address 5001.0002.0000  priority      28673 (28672 sysid 1)
    Root          address 5001.0001.0000  priority      24577 (24576 sysid 1)
                  port    Gi1/0           cost          20000     rem hops 19
    
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Gi0/0            Desg FWD 20000     128.1    P2p 
    Gi0/1            Desg FWD 20000     128.2    P2p 
    Gi0/2            Desg FWD 20000     128.3    P2p 
    Gi0/3            Desg FWD 20000     128.4    P2p 
    Gi1/0            Root FWD 20000     128.5    P2p 
    Gi1/1            Altn BLK 20000     128.6    P2p 

    实例 2

    Switch2#show spanning-tree mst 2
    
    ##### MST2    vlans mapped:   40,50,60 <-- VLAN 40,50,60 映射到了该实例中
    Bridge        address 5001.0002.0000  priority      24578 (24576 sysid 2)
    Root          this switch for MST2 <-- 本交换机是该实例的根桥
    
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Gi0/0            Desg FWD 20000     128.1    P2p 
    Gi0/1            Desg FWD 20000     128.2    P2p 
    Gi0/2            Desg FWD 20000     128.3    P2p 
    Gi0/3            Desg FWD 20000     128.4    P2p 
    Gi1/0            Desg FWD 20000     128.5    P2p 
    Gi1/1            Desg FWD 20000     128.6    P2p 

    可以看出,Switch1 是 VLAN 10、20、30 的根桥,Switch2 是 VLAN 40、50、60 的根桥,达到预期效果!

    展开全文
  • 1、基本概念介绍IOS: 互联网操作系统,也就是交换机和路由器中用的操作系统VLAN: 虚拟lanVTP: VLAN TRUNK PROTOCOLDHCP: 动态...2、密码、登陆等基本配置本节介绍的内容为cisco路由器或者交换机的基本配置,在目前...

    1、基本概念介绍

    IOS:       互联网操作系统,也就是交换机和路由器中用的操作系统

    VLAN:    虚拟lan

    VTP:       VLAN TRUNK PROTOCOL

    DHCP:    动态主机配置协议

    ACL:    访问控制列表

    三层交换机:具有三层路由转发能力的交换机

    本教程中“#”后的蓝色文字为注释内容。

    2、密码、登陆等基本配置

    本节介绍的内容为cisco路由器或者交换机的基本配置,在目前版本的cisco交换机或路由器上的这些命令是通用的。本教程用的是cisco的模拟器做的介绍,一些具体的端口显示或许与你们实际的设备不符,但这并不影响基本配置命令的执行。

    Cisco 3640 (R4700) processor (revision 0xFF) with 124928K/6144K bytes of memory.

    Processor board ID00000000R4700 CPU at 100MHz, Implementation33, Rev 1.2

    2Ethernet interfaces8Serial interfaces

    DRAM configurationis 64bits wide with parity enabled.

    125K bytes of NVRAM.

    8192K bytes of processor board System flash (Read/Write)--- System Configuration Dialog ---Would you like to enter the initial configuration dialog? [yes/no]: n

    # 此处我们选择no,不进入他的初始化配置向导

    Press RETURN to get started!

    # 选择no以后,提示你按回车键开始,此处我们需要按回车键

    *Mar 1 00:43:56.591: %IP-5-WEBINST_KILL: Terminating DNS process*Mar 1 00:43:58.379: %SYS-5-RESTART: System restarted --Cisco IOS Software,3600 Software (C3640-JK9O3S-M), Version 12.3(14)T7, RELEASE SOFTWARE (fc2)

    Technical Support: http://www.cisco.com/techsupport

    Copyright (c)1986-2006by Cisco Systems, Inc.

    Compiled Wed22-Mar-06 21:46by pwade*Mar 1 00:43:58.411: %SNMP-5-COLDSTART: SNMP agent on host Router is undergoing a cold start

    Router>    # 等显示稳定后,出现最初的提示符,注意提示符是“>”,目前所处的状态称为用户模式。

    Router>en    # 如果在当前状态下没有重复的命令,我们可以用“TAB”键来补齐这条命令,主要目的是为了便于阅读

    Router>enable# 从用户模式(user mode)进入到特权模式(exec mode),注意提示符的变化,提示符变为“#”

    Router#configure terminal(说明:#在特权模式下输入configure terminal进入全局配置模式(global configuration mode),在这之下输入的命令叫做全局命令,一旦输入,将对整个router产生即时影响。如下,注意提示符的变化:)

    Router(config)#exit                    # 请注意提示符发生了改变,当前的模式据叫做全局配置模式。

    Router#conf

    *Mar  1 00:44:26.491: %SYS-5-CONFIG_I: Configured from console by console t      # 在输入命令的过程中,IOS会出现一些即时提示。

    Enter configuration commands, one per line.  End with CNTL/Z.

    Router(config)#exit               # 退出当前的全局配置模式的命令是exit

    Router#conf t              # 重新进入到全局配置模式

    Enter configuration commands, one per line.  End with CNTL/Z.

    Router(config)#

    *Mar  1 00:44:35.591: %SYS-5-CONFIG_I: Configured from console by consolehos

    # 这行是路由器(交换机)出现的一些即时提示。

    Router(config)#hostname test   # 这条命令用来更改当前设备的名字(名字中可包含设备的楼层、用途等信息),主要是为了将来便于区分设备。

    test(config)#       # 回车后我们就会发现,但前的设备的名字已经发生了改变,变成了test了。

    test(config)#enable pass

    # 这条命令用来配置设备的登陆密码,用tab键补齐后,再下一行显示完整命令。

    test(config)#enable password cisco     # 我们输入这台设备的登陆密码为 cisco

    test(config)#end                              # 我们退回到全局配置模式,校验一下刚才输入的密码

    test#sh r   # 此命令的完整写法是show running-start,此处的sh r用的是省略的写法,因无其他重复的命令所以可以被执行。

    Building configuration...

    Current configuration :1559bytes!version12.3service timestamps debug datetime msec

    service timestamps log datetime msec

    no service password-encryption!hostname test # 注意此处显示的是我们配置的设备的名字!boot-start-marker

    boot-end-marker!enable password cisco

    # 此处显示的是刚才我们配置的enable密码,注意此时是用明文显示的,有点不安全。!no aaanew-model!resource policy!memory-size iomem 5ip subnet-zero!

    # 到这一行其实并未全部显示完配置的内容,我们可以按键盘上的任意键来终止继续显示。在显示的过程中通过按回车键可以逐行显示,按空格键可以一页一页的显示。这些操作可在实际的设备中体会。

    test#conf t                                                     # 重新进入到全局配置模式

    test(config)#service password-encryption           # 利用这条命令给密码加密显示。

    test(config)#end

    test#sh r                                                         # 退出到全局配置模式后,验证刚才的配置。

    Building configuration...

    Current configuration : 1565bytes!version12.3service timestamps debug datetime msec

    service timestamps log datetime msec

    service password-encryption!hostname test!boot-start-marker

    boot-end-marker!enable password7070C285F4D06

    # 注意此处刚才明文显示的密码已经变成加密显示了,这样从一定程度上保证了密码的安全。!no aaanew-model!resource policy!memory-size iomem 5ip subnet-zero!# 验证完毕后按任何一个键中断显示,下面的内容说明终端登陆密码的配置。

    test#conf t

    Enter configuration commands, one per line.  End with CNTL/Z.

    test(config)#no service password-encryption

    # 可利用这条命令(前面加no)来去掉密码加密功能,cisco的所有命令都可以通过这种方式来禁止。

    test(config)#line con

    test(config)#line console 0            # 利用这条命令来配置用超级终端登陆时的一些参数。

    test(config-line)#pass

    test(config-line)#password cisco    # 添加密码,此处我们配置的密码为cisco

    test(config-line)#logging ?

    # 在任何情况下如果你忘记了命令的相关参数可以用?来获得提示和帮助

    synchronous  Synchronized message output

    test(config-line)#logging sy

    test(config-line)#logging synchronous

    # 在我们进行配置时,IOS会产生一些即时的提示信息,而这些信息会冲乱我们的光标显示,用这条命令可以将光标规矩在下一行,即使出现了一些即时的提示。

    test(config-line)#exit                  # 退出当前console口的参数配置

    test(config)#line vt?                     #  telnet登陆时相关参数的配置,此处用了?来寻求提示。

    <0-134>First Line number

    aux Auxiliary line

    console Primary terminal line

    tty Terminal controller

    vty Virtual terminal

    x/y Slot/Port for Modems

    test(config)#line vty 0 4      # 我们配置虚拟终端的0到4,也就是同时允许5个用户可以telnet到这台设备上来。

    test(config-line)#password cisco   # 我们配置telnet时的密码为cisco,如果此处我们不设置密码,那么用telnet来登陆的时候并不会以空密码登陆,而是会给你提示说:相关密码没有设置,禁止登陆。所以我们为了能远程telnet到这台设备,此处的密码一定要设置好。

    test(config-line)#login                 # 这条命令是允许通过telnet来登录

    test(config-line)#exit                 # 退出当前配置模式到全局配置模式。

    test#conf s            # 我们在做配置的时候,会出现输入错误的情况,在这种情况下ios会以为你输入的是一个域名

    Translating "s"...domain server (255.255.255.255)     # 那么ios会做长时间的搜寻,试图找到这个域名对应的ip地址.......

    Translating "s"...domain server (255.255.255.255)    # 这段时间是比较长的,那么我们如何禁用它的这个功能呢?

    % Unknown command or computer name, or unable to find computer address

    test#conf t

    Enter configuration commands, one per line.  End with CNTL/Z.

    test(config)#no ip domain-lookup       # 在全局配置模式下,将ip域名的搜寻功能关闭就可以了。

    test(config)#end

    test#conf

    *Mar  1 01:40:46.895: %SYS-5-CONFIG_I: Configured from console by console

    test#conf x            # 将上述功能关闭以后,再有输入错误的情况会直接提示你输入错误。

    ^

    % Invalid input detected at '^' marker.

    test(config)#ip domain-name 202.102.128.68 # 如果有必要将设备配置上DNS功能的话就用这条命令。

    ### 基本配置完毕后我们验证一下所有的配置###

    test#sh run

    Building configuration...

    Current configuration :1693bytes!version12.3service timestamps debug datetime msec

    service timestamps log datetime msec

    service password-encryption # 密码加密显示功能打开!hostname test!boot-start-marker

    boot-end-marker!enable password7070C285F4D06 # 密码被加密显示了!no aaanew-model!resource policy!memory-size iomem 5ip subnet-zero!

    !ip cef

    no ip domain lookup # 关闭了域名查找功能

    no ip dhcp use vrf connected!

    !no ip ips deny-action ips-interface

    !no ftp-server write-enable!no crypto isakmp ccm!(略……)

    ip http server

    no ip http secure-server

    ip classless!control-plane!line con0exec-timeout 0 0password7094F471A1A0A # 用超级终端登陆的密码,也同样被加密显示

    logging synchronous

    line aux0line vty0 4password700071A150754 # 用telnet登陆的密码,也同样被加密显示

    login!

    !end

    3、cisco设备端口配置详解

    User Access Verification

    # 从dos提示符下运行telnet ip地址,就会连接到相应的交换机或者路由器

    Password:                   # 输入配置号的telnet密码,也就是上节提到的vtp中的密码

    test>en                      # 进入特权模式

    Password:                    # 输入特权模式密码,也就是上节提到的enable密码。注意这些密码在输入的时候屏幕是不显示的。

    test#

    test#

    test#sh ip int brief       # 查看当前所有端口状态,包括vlan和实际的物理接口状态

    Interface              IP-Address      OK? Method Status                Protocol

    # 这行列示的各种状态的名称

    FastEthernet1            unassigned      YES NVRAM  down                  down

    Vlan1                  192.168.113.254  YES NVRAM  up                    up

    # vlan1的状态是active

    Vlan2 172.16.0.2YES NVRAM up up

    Vlan10192.168.101.254YES NVRAM up up

    Vlan20192.168.102.254YES NVRAM up up

    Vlan30192.168.103.254YES NVRAM up up

    Vlan40192.168.104.254YES NVRAM up up

    Vlan50192.168.105.254YES NVRAM up up

    Vlan60192.168.106.254YES NVRAM up up

    Vlan70192.168.107.254YES NVRAM up up

    Vlan80192.168.108.254YES NVRAM up up

    Vlan100192.168.110.254YES NVRAM up up

    Vlan110192.168.111.254YES NVRAM up up

    Vlan120192.168.112.254YES NVRAM up up

    Vlan150192.168.100.254YES NVRAM up up

    Vlan160192.168.115.254YES NVRAM up up

    GigabitEthernet1/1 unassigned YES unset up up

    # 物理接口gi1/1也是active状态

    GigabitEthernet1/2unassigned YES unset down down

    GigabitEthernet1/3unassigned YES unset down down

    GigabitEthernet1/4unassigned YES unset down down

    GigabitEthernet1/5unassigned YES unset down down

    GigabitEthernet1/6unassigned YES unset down down

    GigabitEthernet1/7unassigned YES unset down down

    GigabitEthernet1/8unassigned YES unset down down

    GigabitEthernet1/9 unassigned YES unset down down

    View Code

    # 说明:通过上述命令即可以查看当前设备所有状态的情况也可以查看端口的表示方式。在此例中我们登陆的是一台cisco4503的三层交换机;其中GigabitEthernet1/1,表示的是这台交换机上的第1块业务板的第1个端口,并且此端口是个千兆端口;而GigabitEthernet3/19表示的是这台交换机上的第3块业务版的第19个端口,并且此端口也是一个千兆端口,其他的端口以此类推。千兆端口的名称为:GigabitEthernet,百兆端口的名称为:FastEthernet。

    test# conf t

    # 进入到全局配置模式。要想对端口、vlan、路由等操作一定要到全局配置模式中来。

    Enter configuration commands, one per line.  End with CNTL/Z.

    test(config)#inter

    test(config)#interface gi1/2

    # 通过此命令可进去端口配置模式,此处我们进入的是GigabitEthernet1/2口,gi1/2为简写。

    test(config-if)#?

    #回车后进入到端口配置模式,注意提示符的变化,输入?寻求在这个模式着那个的帮助。

    Interface configuration commands:

    access-group Access group configuration

    arp Set arp type (arpa, probe, snap) or timeout

    auto Configure Automation

    backup Modify backup parameters

    bandwidth Set bandwidth informational parameter

    bgp-policy Apply policy propogated by bgp community stringcarrier-delay Specify delay for interfacetransitions

    cdp CDPinterfacesubcommands

    channel-group Etherchannel/port bundling configuration

    channel-protocol Select the channel protocol (LACP, PAgP)

    dampening EnableeventdampeningdefaultSet a command to its defaults

    delay Specifyinterfacethroughput delay

    description Interface specific description

    dot1x Interface Config Commandsfor 802.1x

    duplex Configure duplex operation.

    exit Exitfrom interfaceconfiguration mode

    flow-sampler Attach flow sampler to the interfaceflowcontrol Configure flow operation.

    help Description of the interactive help system

    ip Interface Internet Protocol config commands

    isis IS-IS commands

    iso-igrp ISO-IGRP interfacesubcommands

    keepalive Enable keepalive

    l2protocol-tunnel Tunnel Layer2 protocols

    lacp LACPinterfacesubcommands

    load-interval Specify interval for load calculation for an interfacelogging Configure loggingfor interfaceloopback Configureinternal loopback on an interfacemac MACinterfacecommands

    macro Command macro

    max-reserved-bandwidth Maximum Reservable Bandwidth on an Interface

    mtu Set theinterfaceMaximum Transmission Unit (MTU)

    no Negate a command orsetits defaults

    pagp PAgPinterfacesubcommands

    power Power configuration

    qos QoS configuration

    rmon Configure Remote Monitoring on aninterfaceservice-policy Configure QoS Service Policy

    shutdown Shutdown the selectedinterfacesnmp Modify SNMPinterfaceparameters

    spanning-tree Spanning Tree Subsystem

    speed Configure speed operation.

    storm-control storm configuration

    switchport Set switching mode characteristics

    timeout Define timeout valuesfor this interfacetransmit-interface Assign a transmit interface to a receive-only interfacetx-queue Configure interfacetransmit queue

    udld Configure UDLD enabled or disabled and ignoreglobalUDLD setting

    vlan-range config vlan

    View Code

    test(config-if)#speed ?

    # 我们可指定这个端口的速度,比如这个端口接的是一个百兆的收发器,我们就可以强制将此端口设置成100M

    10    Force 10 Mbps operation                    # 强制此端口为10M

    100   Force 100 Mbps operation                  # 强制此端口为100M

    1000  Force 1000 Mbps operation                # 强制此端口为1000M

    auto  Enable AUTO speed configuration        # 允许速度自动协商

    test(config-if)#speed 100

    # 通过此命令就可将此端口强制设成100M,默认的状态下是auto。

    test(config-if)#duplex ? # 用此命令可配置此端口的双工模式,有3个选项供选择。

    auto  Enable AUTO duplex configuration       # 自动配置此端口的双工模式

    full  Force full duplex operation                   # 强制此端口为全双工模式

    half  Force half-duplex operation                 # 强制此端口为半双工模式

    test(config-if)#duplex auto

    test(config-if)#end        # 用end命令可直接退回到特权模式,用exit是一层一层的退出。

    test#terminal monitor   # 打开终端监控。当用telnet登陆的时候默认是不显示各端口的实时变化情况的,打开这个功能就能实时的看到这台交换机上哪个端口up,哪个端口down,这对于排错的时候是很有帮助的。

    test#conf t

    Enter configuration commands, one per line.  End with CNTL/Z.

    test(config)#int gi1/2    # 重新回到端口配置模式

    test(config-if)#shut      # 此命令可手工关闭此端口

    test(config-if)#no shut   # 此命令为打开此端口

    test(config-if)#switchport access vlan ? # 这条命令可配置此端口属于哪个vlan,当然此vlan要事先建好。

    <1-4094>  VLAN ID of the VLAN when this port is in access mode

    dynamic   When in access mode, this interfaces VLAN is controlled by VMPS

    test(config-if)#switchport access vlan 100# 我们配置此端口属于vlan100,如果此端口事先属于其他vlan那么,会从其他vlan退出

    test(config-if)#exit

    多端口一起配置 使用以下命令

    test(config)#int rang                    # 亦可成批的配置端口,利用这个命令

    test(config)#int range gi 1/1 - 5   # 表示同时对gi1/1到gi1/5这5个端口进行操作,注意命令“1 - 5”,之间有空格。

    test(config-if-range)#switchport access vlan 100         # 可同时配置这5个端口属于vlan100

    test(config-if-range)#shutdown                                 # 可同时关闭这5个端口

    test(config-if-range)#no shutdown                           # 可同时启用这5个端口

    test(config-if-range)#exit

    test(config-if)#end

    test#sh int gi1/2                                                  # 在特权模式中,可查看单个端口的状态

    GigabitEthernet1/2 is down, line protocol isdown (notconnect)

    # 这行说明此端口当前的状态是down的

    Hardwareis GigabitEthernetPort, address is001a.6db4.a3c1 (bia 001a.6db4.a3c1)

    # 此端口的MAC地址

    MTU1500 bytes, BW 1000000 Kbit, DLY 10usec,

    reliability255/255, txload 1/255, rxload 1/255Encapsulation ARPA, loopback notsetKeepaliveset (10sec)

    Auto-duplex, Auto-speed, link type is auto, media type is 10/100/1000-TX

    # 此端口的模式为10/100/1000-TX

    input flow-control is off, output flow-control isoff

    ARP type: ARPA, ARP Timeout04:00:00Last input never, output never, output hang never

    Last clearing of"show interface"counters never

    Input queue:0/2000/0/0 (size/max/drops/flushes); Total output drops: 0Queueing strategy: fifo

    Output queue:0/40 (size/max)5 minute input rate 0 bits/sec, 0 packets/sec5 minute output rate 0 bits/sec, 0 packets/sec0 packets input, 0 bytes, 0no buffer

    Received0 broadcasts (0multicast)0 runts, 0 giants, 0throttles0 input errors, 0 CRC, 0 frame, 0 overrun, 0ignored0input packets with dribble condition detected0 packets output, 0 bytes, 0underruns0 output errors, 0 collisions, 0 interfaceresets0 babbles, 0 late collision, 0deferred0 lost carrier, 0no carrier0 output buffer failures, 0 output buffers swapped outtest#shint gi1/1GigabitEthernet1/1 is up, line protocol isup (connected)

    # 这行表明此端口是up的,并且连有网线。

    Hardwareis GigabitEthernetPort, address is001a.6db4.a3c0 (bia 001a.6db4.a3c0)

    MTU1500 bytes, BW 1000000 Kbit, DLY 10usec,

    reliability255/255, txload 1/255, rxload 1/255Encapsulation ARPA, loopback notsetKeepaliveset (10sec)

    Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000-TX

    input flow-control is off, output flow-control isoff

    ARP type: ARPA, ARP Timeout04:00:00Last input never, output never, output hang never

    Last clearing of"show interface"counters never

    Input queue:0/2000/0/0 (size/max/drops/flushes); Total output drops: 0Queueing strategy: fifo

    Output queue:0/40 (size/max)5 minute input rate 1293000 bits/sec, 426 packets/sec5 minute output rate 2410000 bits/sec, 528 packets/sec273591244 packets input, 142285545179 bytes, 0no buffer

    Received0 broadcasts (0multicast)0 runts, 0 giants, 0throttles0 input errors, 0 CRC, 0 frame, 0 overrun, 0ignored # 没有输入错误,表明链路状态良好0input packets with dribble condition detected335026620 packets output, 223732323465 bytes, 0underruns # 输出数据包统计0 output errors, 0 collisions, 0 interfaceresets0 babbles, 0 late collision, 0deferred0 lost carrier, 0no carrier0 output buffer failures, 0 output buffers swapped out

    View Code

    test#wr           # 保存刚才的配置结果

    展开全文
  • 本文将介绍一些生成树相关的知识以及如何在思科交换机上使用 MSTP。二、知识普及2.1 传统生成树协议的缺陷我们都知道,公有的 STP 和 RSTP 都只能在一台交换机上创建一个生成树实例(这个实例叫做 CST,即公用生成树...

    一、前言

    MSTP 的全称是多生成树协议(Multiple Spanning Tree Protocol),它是目前最完美而且兼容性最好的公有生成树协议。

    本文将介绍一些生成树相关的知识以及如何在思科交换机上使用 MSTP。

    二、知识普及

    2.1 传统生成树协议的缺陷

    我们都知道,公有的 STP 和 RSTP 都只能在一台交换机上创建一个生成树实例(这个实例叫做 CST,即公用生成树)。

    虽然这样可以节省交换机的系统资源,但由于冗余链路是完全不转发数据的,所以会造成严重的带宽浪费。

    针对这一点,思科开发了 PVST+ 和 Rapid-PVST+ 两款私有的生成树协议。这两款生成树协议会为每一个 VLAN 创建一个生成树实例,每个 VLAN 也都会有自己独立的根桥。

    这样做虽然不会浪费带宽资源,但是生成树实例数会随着 VLAN 数的的增加而增加。当交换机存在大量 VLAN 时,大量的系统资源都会被浪费在生成树的计算上。并且,PVST+ 和 Rapid-PVST+ 都只能用在思科设备上,兼容性差。

    2.2 MSTP 简介

    MSTP 是 IEEE 基于 RSTP,结合 Rapid-PVST+ 的优点开发的公有生成树协议。

    MSTP 最大的特点是可以根据实际需要创建任意多个生成树实例,并且每个生成树实例都可以跟一个或多个 VLAN 绑定。

    MSTP 完全消除了传统生成树协议的缺陷,并且还是公有协议。所以 MSTP 是目前主流的生成树协议。

    MSTP 有域的概念,它可将整个运行 MSTP 的网络分为多个不同的域。域间使用的是公共生成树(CST),域内使用的是内部生成树(IST)。在公共生成树(CST)中,每个域都可看作是一台逻辑交换机,且不同域间只能通过实例 0 进行互操作。

    MSTP 的架构如下图:

    0de030afc226cef0f30a777265371dcd.png

    不过多域 MSTP 一般很少使用,基本上只用于支持 MSTP 的交换机与不支持 MSTP 交换机的互操作。

    如果想让所有交换机都处在同一个域中,必须满足以下几点:
    1. 所有交换机的域名必须相同。
    2. 所有交换机的修订版本必须相同。
    3. 所有交换机 VLAN 到实例的映射必须相同。

    在默认情况下,交换机的所有 VLAN 都会被映射到实例 0 中。并且实例 0 不可被删除。

    三、网络拓扑图及说明

    fa42c0ab73370fa0e759bc8848c53c47.png

    如图,整网有 6 台交换机。现在要求 Switch1 做 VLAN 10、20、30 的根桥,Switch2 做 VLAN 40、50、60 的根桥。整网使用单域的 MSTP,域名为 cisco,修订版本为 1

    下面只讲与 MSTP 相关的配置。

    四、配置方法

    4.1 Switch1

    进入 MSTP 配置模式:

    Switch1(config)#spanning-tree mst configuration

    设置域名为 cisco

    Switch1(config-mst)#name cisco

    设置修订版本为 1

    Switch1(config-mst)#revision 1

    将 VLAN 10、20、30 绑定到实例 1 上:

    Switch1(config-mst)#instance 1 vlan 10, 20, 30

    将 VLAN 40、50、60 绑定到实例 2 上:

    Switch1(config-mst)#instance 2 vlan 40, 50, 60

    退出 MSTP 配置模式:

    Switch1(config-mst)#exit

    将本交换机设为 MSTP 实例 1(VLAN 10、20、30)的根桥:

    Switch1(config)#spanning-tree mst 1 root primary

    将本交换机设为 MSTP 实例 2(VLAN 40、50、60)的备份根桥:

    Switch1(config)#spanning-tree mst 2 root secondary

    4.2 Switch2

    进入 MSTP 配置模式:

    Switch2(config)#spanning-tree mst configuration

    设置域名为 cisco

    Switch2(config-mst)#name cisco

    设置修订版本为 1

    Switch2(config-mst)#revision 1

    将 VLAN 10、20、30 绑定到实例 1 上:

    Switch2(config-mst)#instance 1 vlan 10, 20, 30

    将 VLAN 40、50、60 绑定到实例 2 上:

    Switch2(config-mst)#instance 2 vlan 40, 50, 60

    退出 MSTP 配置模式:

    Switch2(config-mst)#exit

    将本交换机设为 MSTP 实例 2(VLAN 40、50、60)的根桥:

    Switch2(config)#spanning-tree mst 2 root primary

    将本交换机设为 MSTP 实例 1(VLAN 10、20、30)的备份根桥:

    Switch2(config)#spanning-tree mst 1 root secondary

    4.3 Switch3

    进入 MSTP 配置模式:

    Switch3(config)#spanning-tree mst configuration

    设置域名为 cisco

    Switch3(config-mst)#name cisco

    设置修订版本为 1

    Switch3(config-mst)#revision 1

    将 VLAN 10、20、30 绑定到实例 1 上:

    Switch3(config-mst)#instance 1 vlan 10, 20, 30

    将 VLAN 40、50、60 绑定到实例 2 上:

    Switch3(config-mst)#instance 2 vlan 40, 50, 60

    退出 MSTP 配置模式:

    Switch3(config-mst)#exit

    4.4 Switch4

    进入 MSTP 配置模式:

    Switch4(config)#spanning-tree mst configuration

    设置域名为 cisco

    Switch4(config-mst)#name cisco

    设置修订版本为 1

    Switch4(config-mst)#revision 1

    将 VLAN 10、20、30 绑定到实例 1 上:

    Switch4(config-mst)#instance 1 vlan 10, 20, 30

    将 VLAN 40、50、60 绑定到实例 2 上:

    Switch4(config-mst)#instance 2 vlan 40, 50, 60

    退出 MSTP 配置模式:

    Switch4(config-mst)#exit

    4.5 Switch5

    进入 MSTP 配置模式:

    Switch5(config)#spanning-tree mst configuration

    设置域名为 cisco

    Switch5(config-mst)#name cisco

    设置修订版本为 1

    Switch5(config-mst)#revision 1

    将 VLAN 10、20、30 绑定到实例 1 上:

    Switch5(config-mst)#instance 1 vlan 10, 20, 30

    将 VLAN 40、50、60 绑定到实例 2 上:

    Switch5(config-mst)#instance 2 vlan 40, 50, 60

    退出 MSTP 配置模式:

    Switch5(config-mst)#exit

    4.6 Switch6

    进入 MSTP 配置模式:

    Switch6(config)#spanning-tree mst configuration

    设置域名为 cisco

    Switch6(config-mst)#name cisco

    设置修订版本为 1

    Switch6(config-mst)#revision 1

    将 VLAN 10、20、30 绑定到实例 1 上:

    Switch6(config-mst)#instance 1 vlan 10, 20, 30

    将 VLAN 40、50、60 绑定到实例 2 上:

    Switch6(config-mst)#instance 2 vlan 40, 50, 60

    退出 MSTP 配置模式:

    Switch6(config-mst)#exit

    五、验证结果

    下面我们来看一下 Switch1 和 Switch2 MST 实例 12 的信息。

    5.1 Switch1 的 MST 信息

    实例 1

    Switch1#show spanning-tree mst 1
    
    ##### MST1    vlans mapped:   10,20,30 <-- VLAN 10,20,30 映射到了该实例中
    Bridge        address 5001.0001.0000  priority      24577 (24576 sysid 1)
    Root          this switch for MST1 <-- 本交换机是该实例的根桥
    
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Gi0/0            Desg FWD 20000     128.1    P2p 
    Gi0/1            Desg FWD 20000     128.2    P2p 
    Gi0/2            Desg FWD 20000     128.3    P2p 
    Gi0/3            Desg FWD 20000     128.4    P2p 
    Gi1/0            Desg FWD 20000     128.5    P2p 
    Gi1/1            Desg FWD 20000     128.6    P2p 

    实例 2

    Switch1#show spanning-tree mst 2
    
    ##### MST2    vlans mapped:   40,50,60 <-- VLAN 40,50,60 映射到了该实例中
    Bridge        address 5001.0001.0000  priority      28674 (28672 sysid 2)
    Root          address 5001.0002.0000  priority      24578 (24576 sysid 2)
                  port    Gi1/0           cost          20000     rem hops 19
    
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Gi0/0            Desg FWD 20000     128.1    P2p 
    Gi0/1            Desg FWD 20000     128.2    P2p 
    Gi0/2            Desg FWD 20000     128.3    P2p 
    Gi0/3            Desg FWD 20000     128.4    P2p 
    Gi1/0            Root FWD 20000     128.5    P2p 
    Gi1/1            Altn BLK 20000     128.6    P2p 

    5.2 Switch2 的 MST 信息

    实例 1

    Switch2#show spanning-tree mst 1
    
    ##### MST1    vlans mapped:   10,20,30 <-- VLAN 10,20,30 映射到了该实例中
    Bridge        address 5001.0002.0000  priority      28673 (28672 sysid 1)
    Root          address 5001.0001.0000  priority      24577 (24576 sysid 1)
                  port    Gi1/0           cost          20000     rem hops 19
    
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Gi0/0            Desg FWD 20000     128.1    P2p 
    Gi0/1            Desg FWD 20000     128.2    P2p 
    Gi0/2            Desg FWD 20000     128.3    P2p 
    Gi0/3            Desg FWD 20000     128.4    P2p 
    Gi1/0            Root FWD 20000     128.5    P2p 
    Gi1/1            Altn BLK 20000     128.6    P2p 

    实例 2

    Switch2#show spanning-tree mst 2
    
    ##### MST2    vlans mapped:   40,50,60 <-- VLAN 40,50,60 映射到了该实例中
    Bridge        address 5001.0002.0000  priority      24578 (24576 sysid 2)
    Root          this switch for MST2 <-- 本交换机是该实例的根桥
    
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Gi0/0            Desg FWD 20000     128.1    P2p 
    Gi0/1            Desg FWD 20000     128.2    P2p 
    Gi0/2            Desg FWD 20000     128.3    P2p 
    Gi0/3            Desg FWD 20000     128.4    P2p 
    Gi1/0            Desg FWD 20000     128.5    P2p 
    Gi1/1            Desg FWD 20000     128.6    P2p 

    可以看出,Switch1 是 VLAN 10、20、30 的根桥,Switch2 是 VLAN 40、50、60 的根桥,达到预期效果!

    展开全文
  • 带拓扑图,完整版交换机路由工程配置,谢谢支持,大家多多指教。
  • VLAN是一种比较新的'技术,工作在OSI参考模型的第2...那么在思科交换机上怎么划分vlan,一起来看看吧!//添加vlanSwitch>enableSwitch#vlan dataSwitch(vlan)#vlan 10 name v1VLAN 10 added:Name: v1Switch(vlan)#...
  • 1、基本概念介绍 IOS: 互联网操作系统,也就是交换机和路由器中用的操作系统 VLAN: 虚拟lan VTP: VLAN TRUNK PROTOCOL DHCP: 动态主机配置协议 ACL: 访问控制列表 三层交换机:具有三层路由转发能力的交换机本教程...
  • 1、基本概念介绍 IOS: 互联网操作系统,也就是交换机和路由器中用的操作系统 VLAN: 虚拟lan ... DHCP: 动态主机配置协议 ACL: 访问控制列表 三层交换机:具有三层路由转发能力的交换机 本教程中“...
  • 最近做了一个小项目,是思科MDS9124存储交换机的。因为没有经验,只能一边找资料,一边测试着做了。具体情形如下。 拓扑图: 如上图所示,Server-1和Server-2分别通过光纤连接到MDS9124交换机的Fc 1/1和Fc 1...
  • 背景:如图,东湖机房-钻探机房-数字机房之间只有一根光纤(2芯),而这三个地方都要使用到两个不同的网络即10.63.57.0和192.168.192.0 ...配置: 东湖机房C3550 vlan 57 name lan vlan 192 name...
  • 思科三层交换机配置步骤实例

    千次阅读 多人点赞 2020-06-14 16:21:18
    思科三层交换机配置步骤实例## 这篇文章适合新手看哟,文章有点长,细节有点细,嘻嘻,慢慢来,加油! 利用思科Packet Tracer 6.2组建如上图所示网络,并实现以下功能: 1.正确配置各设备端口IP地址。 2.将各部门...
  • 关注我,你的眼睛会怀孕镜像口就是把思科交换机上的其他口的数据流量全部转到一个口或者两个口上,通常被用作排查问题或者获取数据流量。下面简单介绍下怎么配置源目的镜像口吧。1、使用telnet或者ssh连接到交换机上...
  • 1.要求: 左边的电脑自动获取IP为192...3.点击最上面那个交换机,开始配置(图里的交换机型号有误,应该是2960) 4.建立 vlan 10并分配IP地址 Switch> Switch>enable Switch#conf t Enter configuration command
  • 思科交换机 3560配置

    2012-07-17 14:02:11
    思科3560交换机配置实例 前提准备工作 第一步:建立本地配置环境,只需将计算机(或终端)的串口通过标准RS-232电缆与此Catalyst 3560设备的Console口连接 第二步:在计算机上运行终端仿真程序(如WinXP的超级...
  • trunk:主要是为了不同交换机的相同vlan相互通信配置静态VLAN的步骤:************************************1.创建VLAN1)VLAN数据库配置模式:Switch#vlandatabaseSwitch(vlan)#vlanvlan-id[namevlan-name]Sw...
  • Cisco交换机下,该如何进行QOS限速配置?如何限制BT下载?本博文将用详细实例为您详解。实例1:思科交换机上QOS限速问题用于交换机上对专线用户的带宽进行控制,交换机平时都是10/100/1000、三种速率的,对于其它的...
  • 接下来将用实例带小伙伴们一起来了解思科交换机和路由器的配置 交换机的配置 交换机端口的隔离 实例:将交换机的1—5号端口划分在VLAN 10中,10—15号端口划分在VLAN20中,并分别为其命名为test10和test20。 结果:...
  • 配置MST的基本参数 启用MST的过程需要多不操作,它需要将...当用户通过命令:spanning-tree mode mst启用MST之后,就可以利用其他配置命令配置区域和实例: 步骤1 进入MST配置子模式来配置MST: spanning-tree m...
  • 思科C3550交换机配置作为DHCP服务器工程实例
  • 思科6509核心交换机和各种二层汇聚交换机路由器网络配置实例大全,HSRP、OSPF、EIGRP等。
  • 思科SNMP配置实例

    2018-10-10 00:32:38
    本文档介绍了如何在 Cisco交换机或路由器上配置SNMP。本文档的目标不是涵盖所有的 SNMP功能,而是对主要的命令加以介绍并提供一些示例和指南。

空空如也

空空如也

1 2 3 4 5 6
收藏数 103
精华内容 41
关键字:

思科交换机配置实例