精华内容
下载资源
问答
  • 这里我们主要讲解了思科交换机配置DHCP的相关内容。我们对网络拓扑先进行一下了解,然后对于其在进行一下说明,之后对于配置的代码和命令再进行一下解析。 思科交换机配置DHCP一、网络拓扑 思科交换机配置DHCP...

    这里我们主要讲解了思科交换机配置DHCP的相关内容。我们对网络拓扑先进行一下了解,然后对于其在进行一下说明,之后对于配置的代码和命令再进行一下解析。

    思科交换机配置DHCP一、网络拓扑

     

    思科交换机配置DHCP二、说明

    1、拓扑说明:汇聚层交换机为CATALYST4506,核心交换机为CATALYST6506,接入层交换机为CATALYST2918。4506上启用IP DHCP SNOOPING和DAI以及IPSG,4506上连和下连的端口均配置为TRUNKING;6506上配置VLAN路由和DHCP服务器;2918配置基于端口的VLAN。

    2、DHCP SNOOPING就像一个工作在非信任端口(连接主机或网络设备)和信任端口(连接DHCP SERVER或者网络设备)之间的防火墙,其DHCP SNOOPING BINDING DATABASE中保存着非信任端口下所连设备的MAC address, the IP address, the lease time, the binding type, the VLAN number, and the interface information等信息,但不保存信任端口所连设备的信息;在交换机上开启IP DHCP SNOOPING后,接口将工作在二层桥接状态,截取和保护通往二层VLAN的DHCP消息;在VLAN上开启IP DHCP SNOOPING后,交换机将工作在同一个VLAN域内的二层桥接状态。

    3、思科交换机在全局配置模式下开启IP DHCP SNOOPING后,所有端口默认处于DHCP SNOOPING UNTRUSTED模式下,非信任端口接收到的DHCP OFFER、DHCP ACK、DHCP NAK、DHCP LEASEQUERY报文将被丢弃;信任端口正常接收转发,不进行监测。

    4、交换机在RELOAD或重启后会丢失DHCP SNOOPING BINDING数据库,因此要将此表保存在交换机的FLASH或者保存在一个TFTP服务器中,使交换机在RELOAD或重启后可以从中读取信息,重新形成DHCP SNOOPING BINDING数据库。比如下面这条命令:renew ip dhcp snoop data tftp://192.169.200.1/snooping.dat。

    5、思科交换机在全局配置模式下开启IP DHCP SNOOPING后,所有的DHCP RELAY INFORMATION OPTION功能全部关闭。

    6、根据思科的英文资料来看,说一个汇聚层交换机开启DHCP SNOOPING后,当其下连一个具有嵌入DHCP option-82 information的边缘交换机,且下连端口为非信任端口时,汇聚层交换机将丢弃从此端口接收到的具有option-82 information的DHCP报文;但当在汇聚层交换机上开启IP DHCP SNOOPING INFORMATION OPTION ALLOW-UNTRUSTED功能后,此时下连边缘交换机的端口虽然仍为非信任端口,但可以正常从此端口接收具有option-82 information的DHCP报文。

    根据上面的分析,我理解如下,不知道对不对:思科交换机在全局配置模式下开启IP DHCP SNOOPING后,所有端口默认处于DHCP SNOOPING UNTRUSTED模式下,但DHCP SNOOPING INFORMATION OPTION功能默认是开启的,此时DHCP报文在到达一个SNOOPING UNTRUSTED端口时将被丢弃。因此,必须在4506配置IP DHCP SNOOPING INFORMATION OPTION ALLOW-UNTRUSTED命令(默认关闭),以允许4506从DHCP SNOOPING UNTRUSTED端口接收带有OPTION 82的DHCP REQUEST报文。建议在交换机上关闭DHCP INFORMATION OPTION,即全局配置模式下NO IP DHCP SNOOPING INFORMATION OPTION。

    7、对于允许手工配置IP地址等参数的客户端,可以手工添加绑定条目到DHCP SNOOPING BINDING数据库中。ip dhcp snooping binding 00d0.2bd0.d80a vlan 100 222.25.77.100 interface gig1/1 expiry 600表示手工添加一条MAC地址为00d0.2bd0.d80a,IP地址为222.25.77.100,接入端口为GIG1/1,租期时间为600秒的绑定条目。

    8、IPSG即IP SOURCE GUARD是在DHCP SNOOPING功能的基础上,形成IP SOURCE BINDING表,只作用在二层端口上。启用IPSG的端口,会检查接收到所有IP包,只转发与此绑定表的条目相符合的IP包。默认IPSG只以源IP地址为条件过滤IP包,如果加上以源MAC地址为条件过滤的话,必须开启DHCP SNOOPING INFORMAITON OPTION 82功能。

    9、DAI即DYNAMIC ARP INSPECTION也是以DHCP SNOOPING BINDING DATABASE为基础的,也区分为信任和非信任端口,DAI只检测非信任端口的ARP包,可以截取、记录和丢弃与SNOOPING BINDING中IP地址到MAC地址映射关系条目不符的ARP包。如果不使用DHCP SNOOPING,则需要手工配置ARP ACL。

    思科交换机配置DHCP三、配置

    1、2918

    Switch# configure terminal //全局配置模式

    Switch(config)# interface range fa0/1 - 12

    Switch(config-if-range)# switchport access vlan 100

    Switch(config-if-range)# interface range fa0/13 - 24

    Switch(config-if-range)# switchport access vlan 200

    Switch(config-if-range)# interface gig0/1 //上连4506的端口

    Switch(config-if)# //这里可不做配置,也可手工配置TRUNK

    2、4506

    Switch# configure terminal

    Switch(config)# vtp version 2

    Switch(config)# vtp mode client

    Switch(config)# vtp domain gzy

    Switch(config)# vtp password gzy123

    Switch(config)# vlan 100

    Switch(config)# vlan 200

    Switch(config)# ip dhcp snooping //开启交换机的dhcp snooping功能

    Switch(config)# ip dhcp snooping vlan 100,200 //在VLAN100和200中开启dhcp snooping功能

    Switch(config)# no ip dhcp snooping information option //禁止在DHCP报文中嵌入和删除option 82信息

    Switch(config)# ip dhcp snooping database tftp://192.168.200.1/snooping.dat

    //将dhcp snooping database保存在tftp服务器(IP地址192.168.200.1)的snooping.dat文件中

    Switch(config)# ip arp inspection vlan 100,200 //在VLAN100和200中开启DAI功能

    Switch(config)# ip arp inspection validate src-mac ip //以源MAC和IP检测ARP包是否合法

    Switch(config)# interface gig1/1 //上连6506的端口

    Switch(config-if)# switchport trunk encapsulation dot1q

    Switch(config-if)# switchport mode trunk

    Switch(config-if)# ip dhcp snooping trust

    Switch(config-if)# ip arp inspection trust

    Switch(config-if)# interface gig2/2 //下连2918的端口

    Switch(config-if)# switchport trunk encapsulation dot1q

    Switch(config-if)# switchport mode trunk

    Switch(config-if)# ip arp inspection limit none

    Switch(config-if)# ip verify source vlan dhcp-snooping

    Switch(config-if)# end

    Switch(config)# copy run start

    思科交换机配置DHCP四、备注

    写到后面越来越懒了,基本上就是这样了。6506上的配置不写了,很简单。因为2918不支持上述功能,因此只能在4506上做,但这样就只能在4506下连2918的端口上来启用这些功能,在2918上发生的欺骗就无法防止了。没办法,思科的做法很奇怪。现在很多国内厂家的接入层交换机都可以实现这些功能,比如Quidway、H3C、神洲数码、锐捷等。由于水平有限,写的不对的地方请高手指正。

    转载于:https://www.cnblogs.com/guozhiping/p/5868328.html

    展开全文
  • IPV4 DHCP中继服务器之思科交换机配置 标题:IPV4 DHCP中继服务器配置 + 思科交换机配置 + DHCP服务器配置 一、DHCP服务器配置 网络拓扑图 DHCP服务器分配3个子网,分别为100.100.100.0/24 100.100.20.0/24 100.100....

    IPV4 && IPV6 DHCP中继服务器之思科交换机配置

    标题:IPV4 &&IPV6 DHCP中继服务器配置 + 思科交换机配置 + DHCP服务器配置
    在这里插入图片描述

    一、DHCP服务器配置

    网络拓扑图
    DHCP服务器分配3个子网,分别为100.100.100.0/24 100.100.20.0/24 100.100.30.0/24
    DHCP服务器:100.100.100.100/24 默认网关:100.100.100.1
    大家都知道的不同VLAN之间的计算机不能互相访问的,如果要为3个VLAN划分不同的网段需要3个dhcp server,而dhcp中继功能解决了只需要配置一个dhcp server,通过交换机的中继功能也能划分不同网段。我的实验环境如下:
    默认网关设置在思科交换机VLAN1,VLAN2,VLAN3。
    VLAN1:接口1-12 IP V4 ADDRESS:100.100.100.1 IPV6 2020:0:0:1::1 /64
    VLAN2:接口13-24 IP V4 ADDRESS:100.100.20.1 IPV6 2020:0:0:2::1 /64
    VLAN3:接口25-36 IP V4 ADDRESS:100.100.30.1 IPV6 2020:0:0:3::1 /64

    1.1 IPV4 IPV6 DHCP网口配置

    配置网口-----与交换机直连
    [root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcfg-enp59s0f1
    TYPE=Ethernet
    BOOTPROTO=none
    DEFROUTE=yes
    IPV4_FAILURE_FATAL=no
    IPV6INIT=yes #开启接口IPV6
    IPV6_AUTOCONF=yes #开启接口IPV6
    IPV6_DEFROUTE=yes #开启接口IPV6
    IPV6_FAILURE_FATAL=no
    NAME=enp59s0f1
    UUID=3efbc07c-7439-4a05-afa7-ab079d2cd5c3
    DEVICE=enp59s0f1
    ONBOOT=yes #每次开机自动link up 接口
    IPV6ADDR=2020:0:0:1::2/64 #IPV6 地址
    IPV6_DEFAULTGW=2020:0:0:1::1#IPV6 默认网关
    IPADDR=100.100.100.100 #确保IPV4地址在DHCP配置文件的IP池中
    PREFIX=24 #IPV4 掩码
    GATEWAY=100.100.100.1 #IPV4 默认网关

    开启网口
    [root@localhost ~]# ifup enp59s0f1

    1.2 DHCP服务配置和开启

    安装dhcp服务
    CentOS
    RPM 安装:rpm -ivh dhcp-4.2.5-42.el7.x86_64
    YUM源安装:yum -y install dhcp
    配置yum源方式如下:
    [root@localhost ~]# cat /etc/yum.repos.d/rhel.repo
    [CentOS]
    name=CentOS
    #baseurl=http://x.x.x.x/CentOS/Packages/ #使用http源
    baseurl=f"ile:///mnt/CentOS" #使用本地镜像源
    gpgcheck=0
    enabled=1

    安装dhcp服务后,在/etc/dhcpd/目录下生成2个配置文件,
    [root@localhost ~]# ls /etc/dhcp/
    dhclient.d dhcpd6.conf dhcpd.conf
    其中
    dhcpd6.conf 配置IPV6 , IPV6国家倡导发展大趋势,大家可以尝试下。
    dhcpd.conf配置IPV4

    租约释放时间设置注意:default-lease-time 默认释放时间,不要设置太短,也不建议设置2周以上,IP被霸占着不释放,导致IP池资源紧张,一般设置可根据业务使用情况合理设定。
    dhcp-rebinding-time 租约期满续订失败,重新请求续约IP时间
    dhcp-renewal-time 租约部分过期重新续订IP时间

    配置文件分别如下:

    [root@localhost dhcp]# cat dhcpd.conf 
    # dhcpd.conf
    option domain-name "example.org";
    option domain-name-servers ns1.example.org, ns2.example.org;
    default-lease-time 86400;
    max-lease-time 172800;
    # This is a very basic subnet declaration.
    subnet 100.100.100.0 netmask 255.255.255.0 {
      range 100.100.100.100 100.100.100.105;
      option routers 100.100.10.1;
    }
    subnet 100.100.20.0 netmask 255.255.255.0 {
      range 100.100.20.100 100.100.20.200;
      option routers 100.100.20.1;
    }
    subnet 100.100.30.0 netmask 255.255.255.0 {
      range 100.100.30.100 100.100.30.200;
      option routers 100.100.30.1;
    }
    [root@localhost dhcp]# cat dhcpd6.conf 
    default-lease-time 86400;
    
    preferred-lifetime 43200;
    
    option dhcp-renewal-time 30000;
    
    option dhcp-rebinding-time 30000;
    
    option dhcp6.domain-search "localhost.localdomain";
    
    option dhcp6.name-servers 2020::10:2;
    
    #option dhcpd6.bootfile-url code 59 = string;
    
    DHCPDARGS="enp59s0f1";
    
    allow leasequery;
    allow booting;
    allow bootp;
    option dhcp6.info-refresh-time 21600;
    
    option dhcp6.bootfile-url code 59 = string;
    
    option dhcp6.client-arch-type code 61 = array of unsigned integer 16;
    
    #dhcpv6-lease-file-name "/var/lib/dhcpd/dhcpd6.leases"; 
    
    subnet6 2020:0:0:1::0/64 {
    
        option dhcp6.bootfile-url "tftp://[2020::10:2]/BOOTX64.efi";
        #range for clients
        range6 2020:0:0:1::3 2020:0:0:1::ffff;
        #prefix range for delefation to sub-routers
        prefix6 2020:0:0:1:: 2020:0:0:3:: /64;
    
        #range6 2020:0:0:1::0 temporary;
    
    }
    subnet6 2020:0:0:2::0/64 {
    
            range6 2020:0:0:2::2 2020:0:0:2::ffff;
    
     	prefix6 2020:0:0:1:: 2020:0:0:3:: /64;
    }
    subnet6 2020:0:0:3::0/64 {
    
    	range6 2020:0:0:3::2 2020:0:0:3::ffff;
    
    	prefix6 2020:0:0:1:: 2020:0:0:3:: /64;
    
    }
    #开启dhcp ipv4服务
    [root@localhost dhcp]#systemctl start dhcpd.service
    #开启dhcp ipv6服务
    [root@localhost dhcp]#systemctl start dhcpd6.service
    

    二、思科交换机配置DHCP中继

    2.1 思科交换机IPV4 dhcp中继设置

    admin#  configure 
    Configuring from terminal, memory, or network [terminal]? 
    Enter configuration commands, one per line.  End with CNTL/Z.
    #创建vlan 2 (port口13-24划到vlan2)
    admin(config)#vlan 2
    admin(config-vlan)#interface range gigabitEthernet 1/0/13-24
    admin(config-if-range)#switchport access vlan 2                 
    admin(config-if-range)#exit
    #创建vlan 3 (port口25-36划到vlan3)
    admin(config)#vlan 3
    admin(config-vlan)#interface range gigabitEthernet 1/0/25-36
    admin(config-if-range)#switchport access vlan 3                 
    admin(config-if)#no shutdown
    admin(config-if-range)#exit
    #vlan 2 设置ip地址和dhcp中继访问地址
    admin(config-vlan)#int vlan 2
    admin(config-if)#ip address 100.100.20.1 255.255.255.0
    admin(config-if)#ip helper-address 100.100.100.100
    admin(config-if)#no shutdown
    admin(config-if)#exit
    #vlan 3 设置ip地址和dhcp中继访问地址
    admin(config)#int vlan 3                           
    admin(config-if)#ip address 100.100.30.1 255.255.255.0
    admin(config-if)#ip helper-address 100.100.100.100    
    admin(config-if)#no shutdown
    admin(config-if)#exit
    #开启三层route 不同网段可以互相访问
    admin(config)#ip routing
    #show arp 地址
    admin#show arp            
    Protocol  Address          Age (min)  Hardware Addr   Type   Interface
    Internet  100.100.20.1            -   70d3.79aa.fc41  ARPA   Vlan2
    Internet  100.100.30.1            -   70d3.79aa.fc42  ARPA   Vlan3
    Internet  100.100.100.1           -   70d3.79aa.fc40  ARPA   Vlan1
    Internet  100.100.100.100         0   5820.b102.b31f  ARPA   Vlan1
    

    2.2 思科交换机IPV6 dhcp中继设置

    #IPV6 交换机设置config文件如下:
    admin#  configure 
    Configuring from terminal, memory, or network [terminal]? 
    Enter configuration commands, one per line.  End with CNTL/Z.
    admin(config)#vlan 2
    admin(config-vlan)#ipv6 address 2020:0:0:2::1/64
    admin(config-vlan)#ipv6 dhcp relay destination 2020:0:0:1::2
    admin(config-vlan)#ipv6 enable
    admin(config)#vlan 3
    admin(config-vlan)#ipv6 address 2020:0:0:3::1/64
    admin(config-vlan)#ipv6 dhcp relay destination 2020:0:0:1::2
    admin(config-vlan)#ipv6 enable
    admin(config)#vlan 1
    admin(config-vlan)#ipv6 address 2020:0:0:1::1/64
    admin(config-vlan)#ipv6 enable
    admin(config)#end
    
    查看已获取到IPV6地址
    admin#show ipv6 neighbors 
    IPv6 Address                              Age Link-layer Addr State Interface
    2020:0:0:1::2                               0 5820.b102.b31f  REACH Vl1
    2020::1:5A20:B1FF:FE02:B31F                10 5820.b102.b31f  STALE Vl1
    FE80::5A20:B1FF:FE02:B31F                   0 5820.b102.b31f  REACH Vl1
    2020:0:0:2::D3                             10 a4ae.120e.d8a8  STALE Vl2
    2020::2:A6AE:12FF:FE0E:D8A8                10 a4ae.120e.d8a8  STALE Vl2
    FE80::A6AE:12FF:FE0E:D8A8                  10 a4ae.120e.d8a8  STALE Vl2
    2020::3:320E:D5FF:FEFF:1FEC                10 300e.d5ff.1fec  STALE Vl3
    FE80::320E:D5FF:FEFF:1FEC                   0 300e.d5ff.1fec  REACH Vl3
    
    

    添加静态路由

    DHCP server 要访问其他vlan或跨网段的IP地址,需配置路由表信息。
    DHCP server 隶属vlan1 ipv6地址:2020:0:0:1::2
    节点2 隶属vlan 2 ipv6地址:2020::2:A6AE:12FF:FE0E:D8A8
    节点3 隶属vlan 3 ipv6地址:2020::3:320E:D5FF:FEFF:1FEC
    想访问节点2&& 节点3的网段,添加如下路由信息:

    [root@localhost ~]# ip -6 route add  2020:0:0:3::0/64 via  2020:0:0:1::1
    [root@localhost ~]# ip -6 route add  2020:0:0:2::0/64 via  2020:0:0:1::1
    [root@localhost Desktop]# ip -6 route
    2020::1 dev enp59s0f1  proto static  metric 100 
    2020:0:0:1::1 dev enp59s0f1  metric 0 
        cache 
    2020:0:0:1::/64 dev enp59s0f1  proto kernel  metric 256 
    2020:0:0:2::/64 via 2020:0:0:1::1 dev enp59s0f1  metric 1024 
    2020:0:0:3::/64 via 2020:0:0:1::1 dev enp59s0f1  metric 1024 
    
    访问实例:
    [root@localhost ~]# ipmitool -6 -H 2020::3:320E:D5FF:FEFF:1FEC -U admin -P admin mc info
    Device ID                 : 32
    Device Revision           : 1
    Firmware Revision         : 1.55
    IPMI Version              : 2.0
    Manufacturer ID           : 0
    Manufacturer Name         : Unknown
    Product ID                : 514 (0x0202)
    Product Name              : Unknown (0x202)
    Device Available          : yes
    Provides Device SDRs      : no
    Additional Device Support :
        Sensor Device
        SDR Repository Device
        SEL Device
        FRU Inventory Device
        IPMB Event Receiver
        IPMB Event Generator
        Chassis Device
    Aux Firmware Rev Info     : 
        0x01
        0x00
        0x00
        0x00
    
    
    展开全文
  • (交换机)简单的思科交换机配置命令

    千次阅读 多人点赞 2018-09-11 14:47:55
    今天有机会配置了一波思科交换机配置思路和华为交换机区别有限。 趁此机会做个学习总结。 我是用串口线直连交换机进行配置,由于经常出现断开连接的情况,所以进入虚拟终端设置了一下超时时间。 一,起手式 ...

    今天有机会配置了一波思科交换机,配置思路和华为交换机区别有限。 趁此机会做个学习总结。
    我是用串口线直连交换机进行配置,由于经常出现断开连接的情况,所以进入虚拟终端设置了一下超时时间。

    一,起手式

    提示符 操作 命令
    switch> 进入特权模式 enable
    switch# 进入全局配置模式 config t
    switch# 查看当前运行的配置 show run
    switch# 保存当前配置到下次启动 copy run startup
    switch# 返回命令 exit

    虚拟终端设置(一般远程登录用)

    提示符 操作 命令
    switch# 进入虚拟终端 line vty 0 4
    switch(config-line)# 设置超时时间为10分0秒 exec-timeout 10 0
    switch(config-line)# 虚拟终端允许登录 login ##实际未配置
    switch(config-line)# 设置虚拟终端登录口令csico6 password csico6 #实际未配置
    switch(config-line)# 返回命令 exit

    二,VLAN创建,删除,端口属性的设置,配置trunk端口,将某端口加入vlan中

    提示符 操作 命令
    switch# vlan database 进入VLAN设置 实际未配置,可能是比较老的版本需要
    switch(vlan)# vlan 2 建VLAN 2
    switch(vlan)# no vlan 2 删vlan 2
    switch(config)# int f0/1 进入端口f0/1,参照着写,比如,int g1/0/12
    switch(config)# description TO_PC1 这是该端口描述为TO_PC1
    switch(config-if)# switchport access vlan 2 当前端口加入vlan 2
    switch(config-if)# switchport mode trunk 设置为trunk模式(access模式)
    switch(config-if)# switchport trunk allowed vlan 1,2 设置允许通过的vlan
    switch(config-if)# switchport trunk allowed vlan all 设置允许通过所有vlan

    三,设置IP地址,默认网关,配置静态MAC地址表

    提示符 命令 配置
    switch(config)# interface vlan 1 进入vlan 1
    switch(config-if)# ip address 192.168.1.1 255.255.255.0 设置IP地址
    switch(config-if)# exit 返回命令
    switch(config)# ip default-gateway 192.168.1.6 设置默认网关
    switch(config)# ip routing 开启交换机三层路由
    switch(config)# mac-address-table? 查看mac-address-table的子命令
    switch(config)# mac-address-table aging-time 100 设置超时时间为100ms
    switch(config)# mac-address-table permanent 0000.0c01.bbcc f0/3 加入永久地址在f0/3端口
    switch(config)# mac-address-table restricted static 0000.0c02.bbcc f0/6 f0/7 加入静态地址目标端口f0/6源端口f0/7
    switch(config)# end 回到特权模式
    switch# show mac-address-table 查看整个MAC地址表 ##查看mac的信息有时会非常有用
    switch# clear mac-address-table restricted static 清除限制性静态地址

    四,交换机查看命令

    命令 说明
    show run 查看当前运行的配置
    show run interfaces 查看端口更具体的信息,可以敲“?”号查看
    show vlan 查看vlan的配置信息
    show int 查看端口信息
    show int ? 查看端口更具体的信息,可以敲“?”号查看
    show ip interfaces brief 查看包括ip信息在内的端口简要状态信息
    dir flash 查看闪存

    五,恢复出厂设置命令

    提示符 命令
    switch> enable
    switch# erase startup-configure
    switch# reload
    展开全文
  • 思科交换机配置笔记

    2020-04-03 16:05:33
    取消设置 取消设置只需要在前面加个no,如下: sw2960(config-if-range)#no ...在配置模式中查看接口状态需要加 do 前缀 sw2960(config)#do show ip interface brief Interface IP-Address OK? Method Status ...

    取消设置

    取消设置只需要在前面加个no,如下:
    sw2960(config-if-range)#no switchport access vlan 10
    

    在配置模式中查看接口状态需要加 do 前缀

    sw2960(config)#do show ip interface brief
    Interface              IP-Address      OK? Method Status                Protocol
    Vlan1                  unassigned      YES NVRAM  up                    down    
    FastEthernet0/1        unassigned      YES unset  up                    up      
    FastEthernet0/2        unassigned      YES unset  down                  down    
    FastEthernet0/3        unassigned      YES unset  down                  down    
    FastEthernet0/4        unassigned      YES unset  down                  down    
    FastEthernet0/5        unassigned      YES unset  up                    up      
    FastEthernet0/6        unassigned      YES unset  down                  down           
     --More-- 
    

    使用 end 命令退出到普通模式

    sw2960(config)#end
    sw2960#
    

    设置名字

    Switch>enable  //进入特权模式
    Switch#
    Switch#configure terminal  //从特权模式进入全局配置模式
    Switch(config)#
    Switch(config)#hostname sw1 //修改交换机名称
    

    进入交换机某一端口

    switch> enable
    switch#configure terminal
    switch(conf)# interface fastehernet 0/1
    switch(conf-if)#
    

    设置密码

    sw1(config)#enable password cisco //配置交换机明文密码,登录特权模式时需要输入该密码
    sw1(config)#enable secret ciscoswitch  //配置交换机密文密码,登录特权模式时需要输入该密码
    

    创建VLAN并命名

    sw1(config)#vlan 2
    sw1(config-vlan)#name test
    sw1(config-vlan)#exit
    

    单个端口导入VLAN并设置端口类型

    sw1(config)#interface  fastEthernet 0/1
    sw1(config-if)#switchport mode access
    sw1(config-if)#switchport access vlan 2
    

    多个端口导入VLAN并设置端口类型

    sw2960(config)#interface range f0/2-10 
    sw2960(config-if-range)#switchport mode access
    sw2960(config-if-range)#switchport access vlan 10
    

    show命令,交换机的所有配置和其它相关信息

    switch> enable
    switch#show version //查看系统中的所有版本信息
    switch#show  vlan id 1 //查看交换机有关vlan配置信息
    switch#show running-configure //查看交换机当前起作用的配置信息
    switch#show interface fastethernet 0/1 //查看交换机1 接口具体配置和统计信息
    switch#show mac-address-table //查看mac地址转发表
    

    交换机恢复出厂设置

    switch>enable
    switch#erase startup-configure
    switch# reload
    

    telnet远程登录设置

    switch>en
    switch#configure terminal
    swich(conf)#enable password cisco //以cisco为特权模式密码
    swich(conf)#interface vlan 1 //以vlan 1端口作为远程登录的接口,其他端口亦可
    swich(conf-if)#ip address 192.168.1.1 255.255.255.0
    swich(conf-if)#no shut
    swich(conf-if)#exit
    swich(conf)line vty 0 4 设置0-4 个用户可以telnet 远程登陆
    swich(conf-line)#password 123456
    swich(conf-line)#login
    
    

    SSH配置

    Switch(config)#hostname cisco-sw1   //交换机重新命名
    cisco-sw1(config)#ip domain-name cisco.com //配置域名
    cisco-sw1(config)#line vty 0 4
    cisco-sw1(config-line)#transport input ssh //登录方式为SSH
    cisco-sw1(config-line)#exit
    cisco-sw1(config)#crypto key generate rsa //配置秘钥
    

    DHCP设置

    swich(conf)#interface vlan 10
    swich(conf-if)#ip address 192.168.10.254 255.255.255.0
    
    #############开启dhcp server 功能
    R1(config)#service dhcp
    R1(config)#ip dhcp pool R123
     
    R1(dhcp-config)#network 192.168.10.0 255.255.255.0
     
    #############将客户端的网关指向 dhcp server 接口的IP
    R1(dhcp-config)#default-router 192.168.10.254
     
    #############将客户端的DNS指向 dhcp server 接口的IP
    R1(dhcp-config)#dns-server 123.1.1.1
     
    #############设置租期为101R1(dhcp-config)#lease 1 0 1
     
    #############配置域名为cisco.com
    R1(dhcp-config)#domain-name cisco.com
    

    静态路由和默认路由

    1,静态路由
    ip route 192.168.10.0 255.255.255.0 192.168.20.1
    
    2,默认路由
    二层交换机,如思科2960系列不支持静态路由,只能配置默认路由:
    sw2960(config)#ip default-gateway 192.168.88.1
    

    端口镜像

    设置源镜像口,设置15口为源镜像,其中gigabitEthernet1/0/1表示千兆端口1,如果是百兆的话就换成fastEthernet,这条命令的-10之间有空格的。both,默认监听双向数据,10后面加上rx只监听接收数据,10后面加tx只监听发送数据:
    
    Switch(config)#monitor session 1 source interface fastEthernet 0/1- 10
    
    配置目的镜像口,使端口48为目的镜像口:
    
    Switch(config)#monitor session 1 destination interface fastEthernet 0/48
    
    查看配置:
    
    Switch(config)#do show monitor
    Session 1
    ---------
    Type                   : Local Session
    Source Ports           : 
        Both               : Fa0/1-10
    Destination Ports      : Fa0/48
        Encapsulation      : Native
              Ingress      : Disabled
    
    如果配置错误,删除方法:
    
    Switch(config)#no monitor session 1
    Switch(config)#do show monitor     
     No SPAN configuration is present in the system. 
    

    常用巡检命令

    show logging 查看日志
    show processes cpu | e 0.00% 查看cpu使用率(排除含0.00%的行)
    show processes memory | i Use 查看内存使用率(只包含Use的行)
    show ip route 查看路由
    show vlan brief 查看vlan信息
    show ip interface brief 查看各个端口
    

    acl

    ACL 类型
    标准ACL: access-list-number编号1~99之间的整数,只针对源地址进行过滤。
    扩展ACL: access-list-number编号100~199之间的整数,可以同时使用源地址和目标地址作为过滤条件,还可以针对不同的协议、协议的特征、端口号、时间范围等过滤。可以更加细微的控制通信量。
    动态ACL
    自反ACL
    基于时间的ACL
    
    对某个网段进行过滤。命令如下:access-list 10 deny 192.168.1.0 0.0.0.255
    
    例子:禁止端口f0/5访问IP211.84.160.6的网站
    Switch(config)#access-list 110 deny tcp any host 211.84.160.6 eq www
    Switch(config)#access-list 110 permit ip any any
    Switch(config)#interface fastEthernet 0/5
    Switch(config-if)#ip access-group 110 in 
    

    备份

    Switch#copy running-config tftp:					//选择tftp方式
    Address or name of remote host []? 192.168.10.2   //tftp服务器IP地址
    Destination filename [switch-confg]? test		//备份名字
    !!
    2617 bytes copied in 1.258 secs (2080 bytes/sec)
    

    升级

    先把本机电脑和交换机配到一个网段,ping通继续下面操作(备份好就bin)
    
    1,删除就bin腾出空间:
    Switch#delete flash:/c2960-lanbase-mz.122-50.SE/c2960-lanbase-mz.122-50.SE.bin 
    Delete filename [/c2960-lanbase-mz.122-50.SE/c2960-lanbase-mz.122-50.SE.bin]? 
    Delete flash:/c2960-lanbase-mz.122-50.SE/c2960-lanbase-mz.122-50.SE.bin? [confirm]
    Switch#dir flash:/c2960-lanbase-mz.122-50.SE/c2960-lanbase-mz.122-50.SE.bin
    %Error opening flash:/c2960-lanbase-mz.122-50.SE/c2960-lanbase-mz.122-50.SE.bin (No such file or directory)
    Switch#dir flash:/c2960-lanbase-mz.122-50.SE/                              
    Directory of flash:/c2960-lanbase-mz.122-50.SE/
    
        4  drwx        4800   Mar 1 1993 00:03:37 +00:00  html
      554  -rwx         518   Mar 1 1993 00:05:37 +00:00  info
    
    32514048 bytes total (29056000 bytes free)
    
    
    2,复制tftp下载好的bin升级包到flash
    Switch#copy tftp://192.168.80.2/c2960-lanbasek9-mz.150-2.SE5.bin fla       
    Switch#$lanbasek9-mz.150-2.SE5.bin flash:/c2960-lanbase-mz.122-50.SE/        
    Destination filename [/c2960-lanbase-mz.122-50.SE/c2960-lanbasek9-mz.150-2.SE5.bin]? 
    Accessing tftp://192.168.80.2/c2960-lanbasek9-mz.150-2.SE5.bin...
    Loading c2960-lanbasek9-mz.150-2.SE5.bin from 192.168.80.2 (via Vlan80): !... [timed out]
    
    %Error reading tftp://192.168.80.2/c2960-lanbasek9-mz.150-2.SE5.bin (Timed out)
    Switch#$lanbasek9-mz.150-2.SE5.bin flash:/c2960-lanbase-mz.122-50.SE/
    Destination filename [/c2960-lanbase-mz.122-50.SE/c2960-lanbasek9-mz.150-2.SE5.bin]? 
    Accessing tftp://192.168.80.2/c2960-lanbasek9-mz.150-2.SE5.bin...
    Loading c2960-lanbasek9-mz.150-2.SE5.bin from 192.168.80.2 (via Vlan80): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    [OK - 11787969 bytes]
    
    11787969 bytes copied in 191.981 secs (61402 bytes/sec)
    
    3,检查是否成功
    Switch#dir flash:c2960-lanbase-mz.122-50.SE 
    Directory of flash:/c2960-lanbase-mz.122-50.SE/
    
        4  drwx        4800   Mar 1 1993 00:03:37 +00:00  html
      553  -rwx    11787969   Mar 1 1993 00:21:30 +00:00  c2960-lanbasek9-mz.150-2.SE5.bin
      554  -rwx         518   Mar 1 1993 00:05:37 +00:00  info
    
    32514048 bytes total (17267200 bytes free)
    
    4,reload重启
    
    展开全文
  • 思科交换机配置

    2021-06-22 09:59:54
    一、思科交换机基本配置命令 1:进入特权模式 enable switch> enable switch# 2:进入全局配置模式 configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3:交换机...
  • 思科交换机配置命令大全 switch> 用户模式 1:进入特权模式enable switch> enable switch# 2:进入全局配置模式configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3...
  • 思科交换机查看配置及日常维护命令,方便日常维护查询
  • 思科交换机配置命令大全!

    千次阅读 2012-11-22 15:26:46
    1. 交换机支持的命令: 交换机基本状态: switch: ;ROM状态, 路由器是rommon> ...全局配置模式 hostname(config-if)# ;接口状态 交换机口令设置: switch>enable ;进入特权模式
  • 思科交换机配置命令大全,真的很全 CISCO, 大全, 交换机, 命令1.在基于IOS的交换机上设置主机名/系统名: switch(config)# hostname hostname 在基于CLI的交换机上设置主机名/系统名: switch(enable) set system name...
  • 批量下发华为、思科设备配置 通常我们对较多交换机进行配置变更的时候,都是通过人为 Login 设备,将需要变更的指令输入进去。这不仅效率低,容易出错,而且对做重复事情的厌恶情绪会直接影响变更的过程。 由此本文...
  • 思科交换机的基本配置命令

    千次阅读 2018-07-03 13:32:38
    思科交换机的基本配置命令思科交换机的基本配置命令学习CISCO交换机基本配置:Console端口连接用户模式hostname# ;特权模式hostname(config)# ;全局配置模式hostname(config-if)# ;交换机口令设置:switch&gt...
  • 思科交换机 Line配置模式

    万次阅读 2012-08-28 11:11:51
    思科交换机  Line配置模式 在全局配置模式下,执行line vty或line console命令,将进入Line配置模式。该模式主要用于对虚拟终端(vty)和控制台端口进行配置,其配置主要是设置虚拟终端和控制台的用户级登录密码...
  • 思科交换机

    2018-12-06 23:40:00
    思科交换机配置命令大全 switch> 用户模式 1:进入特权模式 enable switch> enable switch# 2:进入全局配置模式 configure terminal switch> enable switch#c onfigure terminal switch...
  • 配置环境:EVE-NG 拓扑: /// #配置链路聚合 #设置主机名 Switch(config)#hostname hxjh1 #配置vlan接口ip地址 hxjh1(config)#interface vlan 1 hxjh1(config-if)#ip address 192.168.0.1 255.255.255.0 hxjh1...
  • 一、网络拓扑 二、说明 1、拓扑说明:汇聚层交换机为CATALYST4506,核心交换机为CATALYST6506,接入层交换机为CATALYST2918。4506上启 用IP DHCP SNOOPING和DAI以及IPSG,4506上连和下连的端口均配置为TRUNKING;...
  • Cisco交换机管理配置 一般包括管理接口和默认网关配置,网速和双工配置,HTTP访问,MAC地址表管理,以及配置文件管理。 1.命令行界面模式 Cisco IOS软件讲EXEC(执行)会话分成以下两种访问级别。 用户执行:只允许...
  • 思科交换机 DHCP 服务配置

    万次阅读 2019-01-12 15:16:04
    说明:有 3 个 VLAN,...服务器不会使用,因为实验一是演示的,部署在交换机上面,DHCP 服务器则在后续中继的过程中使用到。 地址规划 VLAN 2:20.1.1.0/24,网关 20.1.1.254,DNS 88.1.1.253 VLAN 3:30.1.1.0/24...
  • ㈠网络设备的初始化配置可网管交换机(三层交换机除外)无需配置即可作为傻瓜交换机使用,但是没有配置交换机将不能发挥其功能和安全性。没有配置的路由器无法实现网络之间的通信。2,网络设备的管理方式外置配置源...
  • 配置交换机时间 2. 设置主机名及密码 Switch#congfig t Switch(config)#hostname 6506a 6506a(config)#enable password cisco 6506a (config)#enable secret cisco 6506a (config)#line con 0 6506a (config-line)#...
  • cisco思科交换机端口限速配置

    万次阅读 2018-07-05 12:37:11
    1 实验目的1....对此,网络管理员进行了调查,发现某台交换机的某些端口的数据流量很大,严重影响了网络性能,于是决定对这台交换机的进行速率限制,从而改进网络性能,提高网络效率。3 实验环境 ...
  • cisco思科交换机-常用命令及配置

    万次阅读 多人点赞 2020-05-22 15:28:06
    switch> 用户模式 1:进入特权模式enable switch> enable switch# ...3:交换机命名hostname name 以cisco001 为例 switch> enable switch#c onfigure terminal switch(conf)#hostname cisc
  • 思科交换机基本配置命令 switch>enable 进入特权模式 switch#config terminal 进入全局模式 switch(config)#hostname+xxx 设置主机名 switch(config)#enable password 明文密码 switch(config)#enable ...
  • 思科交换机领命

    2019-06-28 14:09:51
    思科交换机的基本配置命令学习小结 【火热量贩】半价囤好货 大包装 超实惠 思科交换机的基本配置命令学习 CISCO交换机基本配置:Console端口连接 用户模式hostname# ; 特权模式hostname(config)# ; 全局配置模式...
  • 9.3.6思科交换机Portfast和Uplinkfast配置 本实验的步骤很简单,只是通过反复的ping测试来验证在思科交换机上启用Portfast(端口快速)和UplinkFast(上行快速)技术前后的不同的链路状态,以达到加深对这两种技术...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,950
精华内容 2,380
关键字:

思科交换机配置时间