精华内容
下载资源
问答
  • SPAN:本地设备端口监控,当所有被监听的源端口与目的端口同处于一台交换机上,SPAN会话被称为本地SPAN。 Switch(config)#monitor session 1 source interface fastEthernet 0/0 tx //后面参数tx意思是监控0/0接口...

    SPAN:本地设备端口监控,当所有被监听的源端口与目的端口同处于一台交换机上,SPAN会话被称为本地SPAN。

    Switch(config)#monitor session 1 source interface fastEthernet 0/0 tx   //后面参数tx意思是监控0/0接口发送的流量,默认为both,即监控收发的流量

    Switch(config)#monitor session 1 destination interface fastEthernet 0/1   //把session 1里面接口(fastEthernet 0/0)的流量复制一份发送到fastEthernet 0/1,destination fa0/1接口不能正常收发流量,只能接收镜像过来的流量

     

    RSPAN:远端的设备端口口监控;源端口和目的端口不在同一台交换机上。

     

    在源端口交换机上配置:

    Switch1(config)#vlan100   //vlan号必须独立于现网使用的vlan,不能和业务vlan相同,

    Switch1(config-vlan)#name SPAN-VLAN   //为vlan 100名字配置为SPAN-VLAN

    Switch1(config-vlan)#remote-span   //模式改成RSPAN,特殊vlan用来做端口镜像

    Switch1(config)#monitor session 2 source interface Gig 0/1   //配置要抓取原端口的流量

    Switch1(config)#monitor session 2 destination remote vlan 100   //目的端口配置为SPAN的vlan

     

    在目的端口交换机上配置:

    Switch2(config)#vlan100   //vlan要和被抓取流量端口的交换机vlan要一致

    Switch2(config-vlan)#name SPAN-VLAN   //为vlan 100名字配置为SPAN-VLAN

    Switch2(config-vlan)#remote-span   //模式改成RSPAN,特殊vlan用来做端口镜像

    Switch2(config)#monitor session 3 destination interface Gig 0/2   //配置要抓取原端口的流量,这里的session 号不需要和Switch1的一致

    Switch1(config)#monitor session 3 source remote vlan 100   //目的端口配置为SPAN的vlan号

     

    Switch#show monitor   //查看端口镜像配置

     

    参考思科官网:https://www.cisco.com/c/zh_cn/support/docs/switches/catalyst-6500-series-switches/10570-41.html

    展开全文
  • 思科交换机相关配置 一、基础操作 进入交换机界面为一般用户模式 switch> 输入命令 enable进入特权用户模式 switch# 输入命令config terminal进入全局配置模式 switch(config)# 输入命令int xxx可进入端口或者...

    思科交换机相关配置
    一、基础操作
    进入交换机界面为一般用户模式 switch>
    输入命令 enable进入特权用户模式 switch#
    输入命令config terminal进入全局配置模式 switch(config)#
    输入命令int xxx可进入端口或者vlan的全局配置子模式switch(config-if)#

    特权用户模式可输入show命令查看相关设置,命令后输入?可查询帮助
    可用no 命令撤销已经设置的配置

    二、Telnet远程登录设置
    1.交换机配置IP地址
    进入vlan 1 //int vlan 1
    启用 //no shutdown
    设置ip地址 ///ip address ip地址 子网掩码
    2.设置交换机用户名和密码
    useename xxx
    password/secret xxx
    设置enable密码
    enable password xxx
    3.设置访问数量
    line vty 0 x(x是数量,最小为1)
    password xxx
    login
    也可以直接调用上面设置的本地用户名密码
    line vty 0 x
    login local
    4.console口的密码设置也相似
    line console 0
    login local

    三、SSH远程登录
    1.基础设置与Telnet类似
    2.设置访问数量
    line vty 0 x
    3.选择ssh方式
    transport input ssh
    4.更改hostname
    hostname xxx
    5.设置域名
    ip domain-name xxx.com
    6.设置rsa加密密钥
    crypto key generate rsa
    [512]:在360-2048中选择即可
    7.PC端登录命令
    ssh -l username ip地址

    四、交换机中划分vlan
    1.创建vlan
    vlan x(数字)
    可以使用name命令改名
    2.进入端口,分配vlan
    int f0/1
    switchport access vlan x
    3.交换机之间相连需要在连接端口做trunk
    进入连接端口
    int f0/24
    创建trunk
    switchport mode trunk

    五、核心交换机中划分vlan
    1.创建vlan
    vlan x1
    vlan x2

    2.vlan 中设置网关,vlan下的pc终端也要设置相同网关
    int vlan x
    ip address xxx xxx
    3.三层交换机与交换机相连端口做trunk
    封装dot1q协议
    switchport trunk encapsulation dot1q
    创建trunk
    switchport mode trunk
    4.如有需要,可以开启路由功能
    ip routing

    六、本地端口镜像
    1.设置源端口
    monitor session 1 source int f0/1
    2.设置目的端口
    monitor session 1 destination f0/2

    七、远程端口镜像
    1.设置远程专用vlan
    vlan 100
    开启远程端口镜像功能
    remote-span
    2.被监视交换机中
    设置源端口
    monitor session 1 source int f0/1
    设置目的端口
    monitor session 1 destination remote vlan 100 reflector-port f0/1
    3.另一台监视交换机
    同上,创建vlan,开启远程镜像
    设置源端口
    monitor session 2 source remote vlan 100
    设置目的端口
    monitor session 2 destination int f0/3

    八、PVST配置,负载均衡
    1.打开pvst功能
    spanning-tree mode pvst
    2.进入交换机全局配置模式
    配置主根
    spainning-tree vlan x1 priority 4096
    配置次根
    spanning- tree vlan x2 priority 8192
    3.进入另一个交换机
    配置主根
    spainning-tree vlan x2 priority 4096
    配置次根
    spanning- tree vlan x1 priority 8192
    3.进入另一个交换机

    九、链路聚合lacp
    1.进入需要配置的端口
    int range f0/21-24
    2.选择lacp协议
    channel-protocol lacp
    2.开启
    channel-group 1 mode active
    3.如果链路聚合需要做trunk,可以执行以下操作
    int port- channel 1
    switchport mode trunk

    展开全文
  • cisco思科交换机-常用命令配置

    万次阅读 多人点赞 2020-05-22 15:28:06
    switch> 用户模式 1:进入特权模式enable switch> enable switch# ...3:交换机命名hostname name 以cisco001 为例 switch> enable switch#c onfigure terminal switch(conf)#hostname cisc

    连接步骤:

    双击SecureCRT 打开软件;
    选择快速连接;
    协议:SSH2,主机名:IP地址,点击连接;(Cisco设备使用telnet登陆);

    视图模式介绍

    1.普通视图router>

    2.特权视图router# / 在普通模式下输入enable

    3.全局视图router(config)#/ 在特权模式下输入configt

    4.接口视图router(config-if)#/在全局模式下输入int 接口名称例如int s0 或 int e0

    5.路由协议视图router ( config-route ) #/ 在全局模式下输入router 动态路由协议名称
    switch> 用户模式
    工作模式:
    在这里插入图片描述
    命令大致划分:
    v 用户模式下大多都是对设备IOS系统进行操作配置的一些命令。
    v 特权模式下大多都是Show查看类命令。
    v 全局模式下大多都是配置类命令。
    v 接口模式下大多都是对于接口的配置命令。
    CSICO基础常用命令

    展开全文
  • 思科交换机配置命令

    2009-03-09 19:59:00
    思科交换机配置命令1.在基于IOS的交换机上设置主机名/系统名: switch(config)# hostname hostname 在基于CLI的交换机上设置主机名/系统名: switch(enable) set system name name-string 2.在基于IOS的交换机上设置...

    思科交换机配置命令
    1.在基于IOS的交换机上设置主机名/系统名:

    switch(config)# hostname hostname

    在基于CLI的交换机上设置主机名/系统名:

    switch(enable) set system name name-string

    2.在基于IOS的交换机上设置登录口令:

    switch(config)# enable password level 1 password

    在基于CLI的交换机上设置登录口令:

    switch(enable) set password

    switch(enable) set enalbepass

    3.在基于IOS的交换机上设置远程访问:

    switch(config)# interface vlan 1

    switch(config-if)# ip address ip-address netmask

    switch(config-if)# ip default-gateway ip-address

    在基于CLI的交换机上设置远程访问:

    switch(enable) set interface sc0 ip-address netmask broadcast-address

    switch(enable) set interface sc0 vlan

    switch(enable) set ip route default gateway

    4.在基于IOS的交换机上启用和浏览CDP信息:

    switch(config-if)# cdp enable

    switch(config-if)# no cdp enable

    为了查看Cisco邻接设备的CDP通告信息:

    switch# show cdp interface [type modle/port]

    switch# show cdp neighbors [type module/port] [detail]

    在基于CLI的交换机上启用和浏览CDP信息:

    switch(enable) set cdp {enable|disable} module/port

    为了查看Cisco邻接设备的CDP通告信息:

    switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]

    5.基于IOS的交换机的端口描述:

    switch(config-if)# description description-string

    基于CLI的交换机的端口描述:

    switch(enable)set port name module/number description-string

    6.在基于IOS的交换机上设置端口速度:

    switch(config-if)# speed{10|100|auto}

    在基于CLI的交换机上设置端口速度:

    switch(enable) set port speed moudle/number {10|100|auto}

    switch(enable) set port speed moudle/number {4|16|auto}

    7.在基于IOS的交换机上设置以太网的链路模式:

    switch(config-if)# duplex {auto|full|half}

    在基于CLI的交换机上设置以太网的链路模式:

    switch(enable) set port duplex module/number {full|half}

    8.在基于IOS的交换机上配置静态VLAN:

    switch# vlan database

    switch(vlan)# vlan vlan-num name vla

    switch(vlan)# exit

    switch# configure teriminal

    switch(config)# interface interface module/number

    switch(config-if)# switchport mode access

    switch(config-if)# switchport access vlan vlan-num

    switch(config-if)# end


    在基于CLI的交换机上配置静态VLAN:

    switch(enable) set vlan vlan-num [name name]

    switch(enable) set vlan vlan-num mod-num/port-list

    9. 在基于IOS的交换机上配置VLAN中继线:

    switch(config)# interface interface mod/port

    switch(config-if)# switchport mode trunk

    switch(config-if)# switchport trunk encapsulation {isl|dotlq}

    switch(config-if)# switchport trunk allowed vlan remove vlan-list

    switch(config-if)# switchport trunk allowed vlan add vlan-list

    在基于CLI的交换机上配置VLAN中继线:

    switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]

    Vlan-range [isl|dotlq|dotl0|lane|negotiate]

    10.在基于IOS的交换机上配置VTP管理域:

    switch# vlan database

    switch(vlan)# vtp domain domain-name

    在基于CLI的交换机上配置VTP管理域:

    switch(enable) set vtp [domain domain-name]

    11.在基于IOS的交换机上配置VTP 模式:

    switch# vlan database

    switch(vlan)# vtp domain domain-name

    switch(vlan)# vtp {sever|cilent|transparent}

    switch(vlan)# vtp password password


    在基于CLI的交换机上配置VTP 模式:

    switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password]

    12. 在基于IOS的交换机上配置VTP版本:

    switch# vlan database

    switch(vlan)# vtp v2-mode

    在基于CLI的交换机上配置VTP版本:

    switch(enable) set vtp v2 enable

    13. 在基于IOS的交换机上启动VTP剪裁:

    switch# vlan database

    switch(vlan)# vtp pruning

    在基于CL I 的交换机上启动VTP剪裁:

    switch(enable) set vtp pruning enable

    14.在基于IOS的交换机上配置以太信道:

    switch(config-if)# port group group-number [distribution {source|destination}]

    在基于CLI的交换机上配置以太信道:

    switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}

    15.在基于IOS的交换机上调整根路径成本:

    switch(config-if)# spanning-tree [vlan vlan-list] cost cost

    在基于CLI的交换机上调整根路径成本:

    switch(enable) set spantree portcost moudle/port cost

    switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]


    16.在基于IOS的交换机上调整端口ID:

    switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority

    在基于CLI的交换机上调整端口ID:

    switch(enable) set spantree portpri {mldule/port}priority

    switch(enable) set spantree portvlanpri {module/port}priority [vlans]

    17. 在基于IOS的交换机上修改STP时钟:

    switch(config)# spanning-tree [vlan vlan-list] hello-time seconds

    switch(config)# spanning-tree [vlan vlan-list] forward-time seconds

    switch(config)# spanning-tree [vlan vlan-list] max-age seconds

    在基于CLI的交换机上修改STP时钟:

    switch(enable) set spantree hello interval[vlan]

    switch(enable) set spantree fwddelay delay [vlan]

    switch(enable) set spantree maxage agingtiame[vlan]

    18. 在基于IOS的交换机端口上启用或禁用Port Fast 特征:

    switch(config-if)#spanning-tree portfast

    在基于CLI的交换机端口上启用或禁用Port Fast 特征:

    switch(enable) set spantree portfast {module/port}{enable|disable}

    19. 在基于IOS的交换机端口上启用或禁用UplinkFast 特征:

    switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]

    在基于CLI的交换机端口上启用或禁用UplinkFast 特征:

    switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]

    20. 为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP地址,然后使用下列命令: switch(config)# cluster enable cluster-name cv

    展开全文
  • 对于交换机不是很了解,别人问的“端口配置信息”,具体含义不太清楚,目前的理解是服务端口信息,类似于操作系统中开启了哪些服务端口,目前...还有思科交换机的查到show tcp 命令,有没有更明确的命令以及UDP的命令
  • (交换机)简单的思科交换机配置命令

    千次阅读 多人点赞 2018-09-11 14:47:55
    今天有机会配置了一波思科交换机配置思路和华为交换机区别有限。 趁此机会做个学习总结。 我是用串口线直连交换机进行配置,由于经常出现断开连接的情况,所以进入虚拟终端设置了一下超时时间。 一,起手式 ...
  • 思科交换机配置命令大全 switch> 用户模式 1:进入特权模式enable switch> enable switch# 2:进入全局配置模式configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3...
  • CISCO交换机常用命令》 一、交换机四种基本模式 1、四种模式介绍 2.进入四种模式 (1)从用户模式进入特权模式:enable (2)从特权模式进入全局配置模式:conf t (3)从全局端口配置模式进入视图模式...
  • 思科交换机配置命令大全!

    千次阅读 2012-11-22 15:26:46
    1. 交换机支持的命令交换机基本状态: switch: ;ROM状态, 路由器是rommon> hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 ...
  • 思科交换机配置【串口初始配置】

    千次阅读 2021-01-13 21:28:03
    思科交换机配置【串口初始配置】 Cisco交换机和路由器主要使用超级终端、CRT来配置,此外还可以远程telnet来设置,ssh设置,使用浏览器设置,使用cisco的网管软件来设置,sdm软件等方式来对交换机进行管理。 ...
  • 思科交换机配置

    2013-08-02 09:57:24
    介绍了端口的一些基本配置和注意事项。在以后推出的交换机中级篇配置VLAN将会大量运用,虽然都是一些简单的命令,但如果要达到专业水平,就要求能到达熟练运用的阶段。
  • 思科交换机的基本配置命令

    千次阅读 2018-07-03 13:32:38
    思科交换机的基本配置命令思科交换机的基本配置命令学习CISCO交换机基本配置:Console端口连接用户模式hostname# ;特权模式hostname(config)# ;全局配置模式hostname(config-if)# ;交换机口令设置:switch&gt...
  • 思科交换机配置模式基本配置命令 打开思科交换CLI,首先进入的是用户模式,如果要进行配置操作需要进入特权模式。 Switch>enable Switch# 从特权模式进入全局配置模式 Switch#configure terminal Switch...
  • 思科交换机配置命令大全,真的很全 CISCO, 大全, 交换机, 命令1.在基于IOS的交换机上设置主机名/系统名: switch(config)# hostname hostname 在基于CLI的交换机上设置主机名/系统名: switch(enable) set system name...
  • 思科交换机常用配置命令》学习笔记(更新中)

    万次阅读 多人点赞 2018-12-09 13:21:40
    1、基本配置 Switch>enable //进入特权模式 Switch# Switch#configure terminal //从特权模式进入全局配置模式 ...cisco-sw1(config)#enable password cisco //配置交换机明文密码,登录特...
  • cisco思科交换机端口限速配置

    万次阅读 2018-07-05 12:37:11
    1 实验目的1....对此,网络管理员进行了调查,发现某台交换机的某些端口的数据流量很大,严重影响了网络性能,于是决定对这台交换机的进行速率限制,从而改进网络性能,提高网络效率。3 实验环境 ...
  • 下面是配置端口模式access,trunk,hybrid等 [Huawei]vlan batch 10 20 30 //创建多个vlan [Huawei]port-group 1 //创建组 1 [Huawei-port-group-1]group-member G 0/0/1 G 0/0/2 //端口号 [Huawei-port-group-1]...
  • 思科交换机-常用命令配置

    万次阅读 多人点赞 2017-09-06 12:17:48
    switch> 用户模式 1:进入特权模式enable switch> enable switch#   2:进入全局配置模式configure terminal switch> enable ...3:交换机命名hostname name 以cisco001 为例 switch> enable
  • 思科的CatOS交换机 上, 有一条命令 – set port host对连接 到 终端的端口进行优化配置 。这 条命令 会将端口的 channel模式关闭;在端口上激活生成树(spanning tree)的快速启动(portfast)特性 – ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 6,011
精华内容 2,404
关键字:

思科交换机配置端口命令