精华内容
下载资源
问答
  • cisco 动态路由RIP配置

    2017-11-12 02:39:00
    动态路由RIP运用在一个较大的企业网络,在有多个路由器的时候. 动态路由就是网络中路由器之间互相通信,传递路由信息,利用收到的路由信息更新路由表的过程. 动态路由协议分类: 距离矢量路由协议 根据跳数来...

      动态路由RIP运用在一个较大的企业网络,在有多个路由器的时候.

      动态路由就是网络中路由器之间互相通信,传递路由信息,利用收到的路由信息更新路由表的过程.

     

      动态路由协议分类:
      距离矢量路由协议 根据跳数来选择路由 如RIP IGRP
      链路状态路由协议 根据度量值选择路由 如OSPF IS-IS

     

    RIP使用跳数作为唯一的度量值,最多的跳数为15,16跳视为不可达。

     

    配置过程:

    1. 配置pc的ip

    PC1

    wKioL1XRa1bweYGvAACSVWmu62U840.jpg

    PC2

    wKiom1XRaUzCp1JuAACf5Pfhqro180.jpg

     

    测试PC1和PC2的连接情况,发现不通

    wKioL1XRa1aT4jeTAAE7kphSzdw108.jpg

     

    router1配置RIP

    wKiom1XRaUyiSp2wAAATJhi35fQ261.jpg

    wKiom1XRaUyw6IFpAABRVPFu5sU452.jpg

     

    查看rip配置情况

    wKioL1XRa9-BU9BaAAHHrFftMhE949.jpg

     

    router2配置rip

    wKioL1XRa9_TACC8AAB7o7_kqd8306.jpg

     

    router3配置rip

    wKiom1XRadXQQ_GNAAB3efrclGw783.jpg

     

    查看路由表

    wKioL1XRa9-yJ3T8AAHOmuCakzw346.jpg

     

    PC1发现可以ping通PC2了

    wKiom1XRadWx7bEtAAEr_8wJoww098.jpg

     

    到此RIP配置完成!


    本文转自 红色的菠萝 51CTO博客,原文链接:http://blog.51cto.com/10460741/1685195


    展开全文
  • 思科动态路由RIP实验

    2017-11-27 17:42:00
    S3650配置: 上图更改: R1配置: R2配置: 补充(此步骤不能少否则不通): 结果自己测试。 本文转自 zhuxtqw 51CTO博客,原文链接:http://blog.51cto.com/1054054/1251512,如需转载请自行联系原作者... ...

    175911413.png

    S3650配置:

    180318102.png

    上图更改:

    180434889.png

    180434206.png

    R1配置:

    180510816.png

    R2配置:

    180537527.png

    补充(此步骤不能少否则不通):

    180617145.png

    结果自己测试。



    本文转自 zhuxtqw 51CTO博客,原文链接:http://blog.51cto.com/1054054/1251512,如需转载请自行联系原作者

    展开全文
  • 思科模拟器上怎么配置动态路由RIP动态路由会自主选择最佳路径的,不像静态路由某个节点瘫痪了,整个网络就都瘫痪了,下面我们来看看思科模拟器上配置动态路由RIP的图文教程
  • Cisco Packet Tracer 动态路由RIP配置

    千次阅读 2019-04-03 15:52:06
    Cisco Packet Tracer 动态路由RIP配置 一、拓扑图 二、PC、路由IP配置 PC0: PC1: route0配置: Router>en Router#conf t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#...

    Cisco Packet Tracer 动态路由RIP配置

    一、拓扑图

    二、PC、路由IP配置

    PC0:

    PC1:

    route0配置:

    Router>en
    Router#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#hostname route0
    route0(config)#int f0/0
    route0(config-if)#ip ad 192.168.1.1 255.255.255.0
    route0(config-if)#no sh

    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

    route0(config-if)#int s2/0
    route0(config-if)#ip ad 192.168.2.1 255.255.255.0
    route0(config-if)#no sh

    %LINK-5-CHANGED: Interface Serial2/0, changed state to down

    route1配置:

    route1(config)#int s2/0
    route1(config-if)#ip ad 192.168.2.2 255.255.255.0
    route1(config-if)#no sh

    %LINK-5-CHANGED: Interface Serial2/0, changed state to up

    route1(config-if)#int s3/0
    route1(config-if)#ip ad 192.168.3.1 255.255.255.0
    route1(config-if)#no sh

    route2配置:

    Router>en
    Router#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#hostname route2
    route2(config)#int f0/0
    route2(config-if)#ip ad 192.168.4.1 255.255.255.0
    route2(config-if)#no sh

    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

    route2(config-if)#int s3/0
    route2(config-if)#ip ad 192.168.3.2 255.255.255.0
    route2(config-if)#no sh

    %LINK-5-CHANGED: Interface Serial3/0, changed state to up

    route2(config-if)#exit


    设置动态路由:

    route0(config)#route rip
    route0(config-router)#network 192.168.1.0
    route0(config-router)#network 192.168.2.0
    route0(config-router)#version 2
    route0(config-router)#no auto-summary
    route0(config-router)#exit


    route1(config)#router rip
    route1(config-router)#network 192.168.2.0
    route1(config-router)#network 192.168.3.0
    route1(config-router)#version 2
    route1(config-router)#no auto-summary
    route1(config-router)#exit


    route2(config)#router rip
    route2(config-router)#network 192.168.3.0
    route2(config-router)#network 192.168.4.0
    route2(config-router)#version 2
    route2(config-router)#no auto-summary
    route2(config-router)#exit

    测试网络:

    OK网络连接正常!

    展开全文
  • 动态路由RIP协议配置

    2018-12-07 18:50:20
    动态路由RIP协议配置 网络工程与技术课的实验报告,有需要的小伙伴可以下载
  • 思科五台路由rip配置Hi, today we will look for some networking stuff. Up to now, I have not written any routing-related technical post. In this article, I am gonna show you some simple dynamic routing ...
    思科五台路由rip配置

    思科五台路由rip配置

    Hi, today we will look for some networking stuff. Up to now, I have not written any routing-related technical post. In this article, I am gonna show you some simple dynamic routing with RIP protocol. Routing is divided into two part which one is static. In static routing, routes are configured in the router by typing every detail of the route and all things configured are used in routing. But in dynamic routing, we configure the general rules and then let the network generate specific rules according to the config.

    嗨,今天我们将寻找一些联网的东西。 到目前为止,我还没有写任何与路由相关的技术文章。 在本文中,我将向您展示一些使用RIP协议的简单动态路由。 路由分为两个部分,其中一个是静态的。 在静态路由中,通过键入路由的每个详细信息在路由器中配置路由,并且在路由中使用所有已配置的内容。 但是在动态路由中,我们配置通用规则,然后让网络根据配置生成特定规则。

    For example, if you need to statically route A, B, C  networks through D network you should write separate route all of the three networks in each router. But in dynamic routing, you should only write three route in one router. Other routers get theses routes with dynamic routing protocols. Now let start typing commands.

    例如,如果需要通过D网络静态路由A,B,C网络,则应在每个路由器中为所有三个网络编写单独的路由。 但是在动态路由中,您只应在一台路由器中写入三个路由。 其他路由器通过动态路由协议获得这些路由。 现在开始输入命令。

    设置接口的静态IP地址 (Set Static IP Addresses For Interfaces)

    First, we need to configure the IP address of the interfaces that play in routing.

    首先,我们需要配置路由中使用的接口的IP地址。

    R1#configure
    Configuring from terminal, memory, or network [terminal]?
    Enter configuration commands, one per line. End with CNTL/Z.
    R1(config)#interface ethernet 0/0
    R1(config-if)#ip address 10.1.0.1 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#exit
    
    R2#configure
    Configuring from terminal, memory, or network [terminal]?
    Enter configuration commands, one per line. End with CNTL/Z.
    R2(config)#interface ethernet 0/1
    R2(config-if)#ip address 10.2.0.2 255.255.255.0
    R2(config-if)#no shutdown
    R2(config-if)#exit
    
    R3#configure
    Configuring from terminal, memory, or network [terminal]?
    Enter configuration commands, one per line. End with CNTL/Z.
    R3(config)#interface ethernet 0/0
    R3(config-if)#ip add 10.1.0.2 255.255.255.0
    R3(config-if)#no shutdown
    R3(config-if)#exit
    
    R3#configure
    Configuring from terminal, memory, or network [terminal]?
    Enter configuration commands, one per line. End with CNTL/Z.
    
    R3(config)#interface ethernet 0/1
    R3(config-if)#ip address 10.2.0.1 255.255.255.0
    R3(config-if)#no shutdown
    R3(config-if)#exit
    

    检查连通性 (Check Connectivity)

    Now we should check the L3 connectivity. One direction check is enough

    现在我们应该检查L3连接。 一个方向检查就足够了

    R1>ping 10.1.0.2
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.0.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
    
    R3#ping 10.2.0.2
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.2.0.2, timeout is 2 seconds:
    .!!!!
    Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms
    

    启用RIP路由服务 (Enable RIP Routing Service)

    Now we can start describing networks for routing. With network command, we specify network that will be used for rip routing. There are two main effects of this command. First, we specify that this network will be used for rip routing which means this network address will be learned by other routers. Second the interface this network belongs to start to rip communication like sending and receiving rip packets. Auto-summary command makes routing classfull which is generally not used today so we disable it with no auto-summary command. If you have problem with rip routing look first this auto-summary option.

    现在我们可以开始描述用于路由的网络。 使用network命令,我们指定将用于rip路由的网络。 此命令有两个主要作用。 首先,我们指定此网络将用于rip路由,这意味着该网络地址将被其他路由器学习。 其次,该网络所属的接口开始进行rip通信,例如发送和接收rip数据包。 自动汇总命令使路由类已满,今天通常不使用它,因此我们不使用自动汇总命令将其禁用。 如果您在翻录路由方面遇到问题,请首先查看此自动摘要选项。

    R1(config)#router rip 
    R1(config-router)#network 10.1.0.0
    R1(config-router)#no auto-summary 
    R1(config-router)#exit
    

    对RIP协议进行故障排除 (Troubleshoot RIP Protocol)

    To see that rip protocol works we can debug rip packets with debug IP route command. We see that rip is sending packets but not receiving yet because we didn’t configure other routers.

    要查看rip协议是否有效,我们可以使用debug IP route命令调试rip数据包。 我们看到rip正在发送数据包,但尚未收到,因为我们没有配置其他路由器。

    R1#debug ip rip 
    RIP protocol debugging is on
    R1#
    *Oct 11 04:05:58.871: RIP: sending v1 update to 255.255.255.255 via Ethernet0/0 (10.1.0.1)
    *Oct 11 04:05:58.871: RIP: build update entries - suppressing null update
    

    配置接口上的RIP (Configure RIP On Interface)

    Now it is time to configure R3. so we can set neighbor-ship with R1 and see the RIP in work. As you can see after describing network R3 created neighbor-ship with R1

    现在该配置R3了。 因此我们可以使用R1设置邻居关系,并查看RIP的工作情况。 如您所见,描述网络R3后与R1创建了邻居关系

    R3(config)#router rip 
    R3(config-router)#network 10.1.0.0
    *Oct 11 04:08:25.865: RIP: sending request on Ethernet0/0 to 255.255.255.255
    *Oct 11 04:08:25.865: RIP: sending request on Ethernet0/1 to 255.255.255.255
    R3(config-router)#no auto-summary
    *Oct 11 04:08:27.863: RIP: sending v1 flash update to 255.255.255.255 via Ethernet0/0 (10.1.0.2)
    *Oct 11 04:08:27.864: RIP: build flash update entries
    *Oct 11 04:08:27.864: subnet 10.2.0.0 metric 1
    *Oct 11 04:08:27.864: RIP: sending v1 flash update to 255.255.255.255 via Ethernet0/1 (10.2.0.1)
    *Oct 11 04:08:27.864: RIP: build flash update entries
    *Oct 11 04:08:27.864: subnet 10.1.0.0 metric 1
    R3(config-router)#exit
    

    打印/列出RIP配置和信息 (Print/List RIP Configuration and Information)

    If you look to rip database and routing table you will see a new route is added. The new route id sends from R3 to R1. The new route is the et0/1 interface and network of R3. Then we ping to the IP of the new route. sh ip rip database command shows rip database. show ip route command shows routing table.

    如果您要翻录数据库和路由表,则会看到已添加新路由。 新的路由ID从R3发送到R1。 新路由是R3的et0 / 1接口和网络。 然后我们ping到新路由的IP。 sh ip rip database命令显示rip数据库。 show ip route命令显示路由表。

    R1#sh ip rip database 
    10.0.0.0/8 auto-summary
    10.1.0.0/24 directly connected, Ethernet0/0
    10.2.0.0/24
    [1] via 10.1.0.2, 00:00:18, Ethernet0/0
    
    R1#show ip route 
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
    a - application route
    + - replicated route, % - next hop override
    
    Gateway of last resort is not set
    
    10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
    C 10.1.0.0/24 is directly connected, Ethernet0/0
    L 10.1.0.1/32 is directly connected, Ethernet0/0
    R 10.2.0.0/24 [120/1] via 10.1.0.2, 00:00:24, Ethernet0/0
    
    R1#ping 10.2.0.0
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.2.0.0, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
    
    LEARN MORE  QEMU Tutorial with Examples
    通过示例了解更多QEMU教程

    翻译自: https://www.poftut.com/configure-rip-routing-cisco-ios/

    思科五台路由rip配置

    展开全文
  • Re:CCNA_CCNP 思科网络认证 动态路由 RIP 协议 ====================== # RIP 协议中 network的作用 rip协议种network的应该怎么写 作用network 用来配置路由器:哪些接口参与到RIP协议中,功能如下: 接口能够发送...
  • 思科动态路由协议RIP

    2019-09-01 16:36:53
    思科动态路由协议 规划网段(路由是隔离网段的) 配置每个节点IP地址。 R0 Router(config)#interface f0/0 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.10.1 255.255.255.0 ...
  • if)#ip address 10.1.1.1 255.255.255.0 启用接口:R1(config-if)#no shutdown 进去全局模式:R1(config-if)#exit 进入rip配置:R1(config)#router rip 设置rip版本:R1(config-router)#version 2 关闭路由自动汇总 ...
  • 动态路由RIP

    2020-11-08 12:16:52
    动态路由RIP一.动态路由的概述(1).动态路由的特点(2).动态路由协议概述(3).度量值(4).按照路由执行的算法分类(1).距离矢量路由协议(2).链路状态路由协议二.RIP路由协议及工作原理(1)RIP的概述(2)...
  • 网络拓扑图: Router3配置: Router1配置: Multilayer Switch0配置: Switch0配置: Switch1配置: 主机PC0配置: 202.199.1.2 255.255.255.0 202.199.1.1 主机PC1配置: 202.199.2.2 ...255....
  • 使用思科的YDT-RouteSim路由模拟器设计的RIP动态路由配置,教会你如何使用思科路由配置你的网络!
  • 动态路由RIP OSPF

    2021-09-12 20:11:18
    文章目录一、动态路由1.静态路由动态路由的对比2.ASA.什么是ASB.根据AS分类二、RIP1.什么是RIP2.RIP协议的核心3.RIP的版本4.RIP数据包5.**RIP的计时器**6.RIP的**破环机制**7.RIP的配置8.拓展配置三、OSPF追加知识...
  • 华为HCNA实验学习--RIP配置HCNA 动态路由RIP配置实验1.动态路由的概念2.静态路由的配置思路 HCNA 动态路由RIP配置实验 本章内容意在学习静态路由协议相关知识。通过本章的学习,你将掌握以下内容: 1.动态路由的概念...
  • Cisco动态路由rip

    2019-05-04 11:11:00
    Cisco静态路由,讨论一下Cisco动态路由。 实验环境布置 命令布置动态路由 Router0: Router>enable Router#configure terminal Router(config)#interface fastEthernet 0/0 Router(config-if)#no shutdown...
  • Cisco---动态路由rip2

    2019-04-11 15:56:40
    3.为路由器添加动态路由协议rip2 Router#show ip route //查看路由表  10.0.0.0/24 is subnetted, 1 subnets C 10.1.2.0 is directly connected, FastEthernet0/0 C 192.168.2.0/24 is directly ...
  • 动态路由协议RIP router(config)#router rip 启动RIP进程 router(config-router)#network 1.0.0.0 宣告主网络号 router(config-router)#version 2使用版本v2 router(config-router)#no auto-summary 关闭路由汇总功...
  • 动态路由RIP协议

    2019-11-15 19:21:50
    动态路由协议简介 1·路由协议是路由器之间交互信息的一种语言。 2·路由协议共享网络状态和...RIP:Routing Information Protocol,路由信息协议。 OSPF:Open Shortest Path First,开放式最短路径优先。 I...
  • CISCO 动态路由RIP

    2018-12-23 15:55:00
    RIP路由信息协议):是一种内部网关协议(IGP),是一种动态路由选择协议,基于距离矢量算法(DistanceVectorAlgorithms),使用“跳数”(即metric)来衡量到达目标地址的路由距离。 优点:配置简单 缺点: 1、...
  • 配置动态路由RIP协议

    2020-03-22 12:16:14
    一、网络结构 (1) 交换机与PC机、交换机与路由器的连接由以太网接口用直连线连接即可(每个...【如何为思科模拟器添加串口(serial口):https://www.mainblog.cn/126.html】 二、实验过程 1、终端配置 P...
  • 动态路由RIP协议一、动态路由协议基础1.1 概述1.2 度量值1.3收敛1.4动态路由分类二、RIP工作原理2.1 基本原理2.2 路由环路2.3水平分割2.4 毒性逆转三、RIP v1和RIP v2的区别 一、动态路由协议基础 1.1 概述 相较于...
  • Cisco 动态路由协议(RIP)的配置 目录Cisco 动态路由协议(RIP)的配置1.线的连接2.Ip、封装等设置3.设置动态路由 1.线的连接 路由器间采用背对背的连接方式连接,一条DCE电缆和一条DTE电缆一组。 需要给路由器添加...
  • 计算机综合实验–动态路由RIP协议实验 模拟软件:Cisco Packet Tracer 7.0 图Router3 -r1 Router>en Router#conf t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#ho r1 r1...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 10,386
精华内容 4,154
关键字:

思科动态路由rip