精华内容
下载资源
问答
  • 思科动态路由协议的配置,如RIP OSPF
  • 思科动态路由协议RIP

    2019-09-01 16:36:53
    思科动态路由协议 规划网段(路由是隔离网段的) 配置每个节点IP地址。 R0 Router(config)#interface f0/0 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.10.1 255.255.255.0 ...

    思科动态路由协议

    1. 规划网段(路由是隔离网段的)
      

    在这里插入图片描述

    1. 配置每个节点IP地址。
      

    R0
    Router(config)#interface f0/0
    Router(config-if)#no shutdown
    Router(config-if)#ip address 192.168.10.1 255.255.255.0
    Router(config-if)#exit
    Router(config)#interface f0/1
    Router(config-if)#ip address 192.168.20.1 255.255.255.0
    Router(config-if)#no shutdown
    R1
    Router(config)#interface f0/0
    Router(config-if)#no shutdown
    Router(config-if)#ip address 192.168.20.2 255.255.255.0
    Router(config-if)#exit
    Router(config)#interface f0/1
    Router(config-if)#no shutdown
    Router(config-if)#ip address 192.168.30.1 255.255.255.0
    Router(config-if)#exit
    R2
    Router(config)#interface f0/0
    Router(config-if)#no shut
    Router(config-if)#ip address 192.168.30.2 255.255.255.0
    Router(config-if)#exit
    Router(config)#interface f0/1
    Router(config-if)#no shutdown
    Router(config-if)#ip address 192.168.40.1 255.255.255.0

    动态路由协议(RIP):
    配置起来相当简单。
    查看自已的路由表,然后把自已带C的网段添加rip就可以了。
    R0
    Router#show ip route
    C 192.168.10.0/24 is directly connected, FastEthernet0/0
    C 192.168.20.0/24 is directly connected, FastEthernet0/1
    Router#conf t
    Router(config)#
    Router(config)#router rip
    Router(config-router)#network 192.168.10.0
    Router(config-router)#network 192.168.20.0
    R1
    Router#show ip route
    C 192.168.20.0/24 is directly connected, FastEthernet0/0
    C 192.168.30.0/24 is directly connected, FastEthernet0/1
    Router#conf t
    Router(config)#router rip
    Router(config-router)#network 192.168.20.0
    Router(config-router)#network 192.168.30.0
    R2
    Router#show ip route
    C 192.168.30.0/24 is directly connected, FastEthernet0/0
    C 192.168.40.0/24 is directly connected, FastEthernet0/1
    Router#conf t
    Router(config)#router rip
    Router(config-router)#network 192.168.30.0
    Router(config-router)#network 192.168.40.0
    不管是静路由协议还是动态路由协议最终的目的都是为了让每台三层设备都有所有的网段。

    展开全文
  • Cisco 动态路由协议(RIP)的配置 目录Cisco 动态路由协议(RIP)的配置1.线的连接2.Ip、封装等设置3.设置动态路由 1.线的连接 路由器间采用背对背的连接方式连接,一条DCE电缆和一条DTE电缆一组。 需要给路由器添加...

    Cisco 动态路由协议(RIP)的配置

    1.线的连接

    在这里插入图片描述

    • 路由器间采用背对背的连接方式连接,一条DCE电缆和一条DTE电缆一组。
    • 需要给路由器添加模块,再连接。
      模块:WIC-2T
      在这里插入图片描述
      路由间的线:serial DCE(串行DCE)
      在这里插入图片描述
      注意:路由需要手动开启

    2.Ip、封装等设置

    设置ip、对s端口进行ppp封装、配置时钟速率
    Bandwidth 命令设置将接口的带宽值与高级协议交流的信息参数

    • 对三个路由器分别执行以下操作(以此类推这里仅展示其中一个路由的配置):
    Router>en
    Router#conf t
    Router(config)#hostname cisco-2621
    Cisco-2621(config)#no logg on
    Cisco-2621(config)#int fa0/0
    Cisco-2621(config-if)#ip addr 172.16.1.10 255.255.255.0
    Cisco-2621(config-if)#no shut
    Cisco-2621(config-if)#int s0/0
    Cisco-2621(config-if)#ip addr 172.16.12.1 255.255.255.0
    Cisco-2621(config-if)#encapsulation ppp
    Cisco-2621(config-if)#clockrate 64000
    Cisco-2621(config-if)#bandwidth 64
    Cisco-2621(config-if)#no shut
    Cisco-2621(config-if)#int s0/1
    Cisco-2621(config-if)#ip addr 172.16.13.1 255.255.255.0
    Cisco-26201(config-if)#encapsulation ppp
    Cisco-2621(config-if)#clockrate 64000
    Cisco-2621(config-if)#bandwidth 64
    Cisco-2621(config-if)#no shut
    Cisco-2621(config-if)#exit
    Cisco-2621(config)#exit
    Cisco-2621#wr
    
    • 需要给PC设置网关 在这里插入图片描述

    注意:IP设置时,同根线上网段是一样的。

    3.设置动态路由

    • 这样设置后,三台PC还不能互相发送信息,还需要设置动态路由(以此类推这里仅展示其中一个路由的配置):
    Cisco-2621#config t
    Cisco-2621(config)#router rip
    Cisco-2621(config-router)#version 2
    Cisco-2621(config-router)#network 172.16.1.0
    Cisco-2621(config-router)#network 172.16.12.0
    Cisco-2621(config-router)#network 172.16.13.0
    Cisco-2621(config-router)#no auto-summary
    Cisco-2621(config-router)#end
    Cisco-2620#wr
    

    这样三台PC就可以互ping了。

    展开全文
  • 动态路由协议RIP router(config)#router rip 启动RIP进程 router(config-router)#network 1.0.0.0 宣告主网络号 router(config-router)#version 2使用版本v2 router(config-router)#no auto-summary 关闭路由汇总功...

    动态路由协议RIP

    router(config)#router rip  启动RIP进程

    router(config-router)#network 1.0.0.0  宣告主网络号


    router(config-router)#version 2 使用版本v2

    router(config-router)#no auto-summary  关闭路由汇总功能











    本文转自 jin626889 51CTO博客,原文链接:http://blog.51cto.com/zuoshou/1297601,如需转载请自行联系原作者
    展开全文
  • Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco...
  • 思科cisco路由器动态路由协议配置方法 配置IGRP动态路由协议 IGRP是

    思科cisco路由器动态路由协议配置方法

    •  配置IGRP动态路由协议

          IGRP是EIGRP协议的前身,虽然现在基本被EIGRP协议所取代,但在一些特殊场合我们仍然会用到该动态路由协议。他的使用配置和EIGRP协议很相似。我们简单介绍一下。

        配置环境:

        ROUTER-A连接10.1.1.1/24和20.1.1.1/30两个网段,ROUTER-B连接20.1.1.1/30与30.1.1.1/24两个网段。如果不配置任何动态路由协议的话router-b将不知道到达10.1.1.1/24这个网段的路线,相应的A也不知道到达30.1.1.1/24这个网络。不配置IGRP协议的话PC2是不能成功PING通PC1的。下面我们在两台路由器上配置IGRP动态协议。

        配置命令:

        ROUTER-A:

        router igrp 65500    启动IGRP动态协议,并设置自治系统号为65500。

        小提示:自治系统号为1到65535的数,而且只有64512到65535可以让我们私用,其他自治系统号都用于公网中。


        network 10.0.0.0    宣告IGRP通告的网段,这里值得注意的是通告的网段要写主类形式即10.0.0.0,而不是类似OSPF一样写10.1.1.0的形式。(如图3)

        小提示:IGRP会自动在边界上归纳路由信息为主类IP地址而且自动归纳无法取消。

        ROUTER-B:

        router igrp 65500    启动IGRP动态协议,并设置自治系统号为65500,自治系统号要和A设置的一样才能正常通讯。

        network 30.0.0.0    宣告IGRP通告的网段,仍然要采用主类的方式。

        总结:配置完毕后在PC2上ping PC1计算机的IP地址是可以连通的,同理pc1也可以成功ping通PC2。这些都是因为IGRP动态协议对10.0.0.0与30.0.0.0网段宣告的结果。

    • 配置EIGRP动态路由协议

          EIGRP是结合了链路状态型和距离矢量型路由选择协议优点的CISCO专用协议。该混合协议具有快速收敛,减少带宽占用,支持多种网络层协议的特点。不过由于他是CISCO专用协议,所以其他厂商的路由器不支持该协议,他只应用于整个网络都是CISCO公司的路由器的情况。总的来说他是一种高级的距离矢量型路由选择协议,是从IGRP协议发展而来的。

        配置环境:

        ROUTER-A连接10.1.1.1/24和20.1.1.1/30两个网段,ROUTER-B连接20.1.1.1/30与30.1.1.1/24两个网段。如果不配置任何动态路由协议的话router-b将不知道到达10.1.1.1/24这个网段的路线,相应的A也不知道到达30.1.1.1/24这个网络。不配置EIGRP协议的话PC2是不能成功PING通PC1的。下面我们在两台路由器上配置EIGRP动态协议。


        配置命令:

        ROUTER-A

        router eigrp 65500    启动EIGRP动态协议,并设置自治系统号为65500。

        小提示:自治系统号为1到65535的数,而且只有64512到65535可以让我们私用,其他自治系统号都用于公网中。

        network 10.0.0.0    宣告EIGRP通告的网段,这里值得注意的是通告的网段要写主类形式即10.0.0.0,而不是类似OSPF一样写10.1.1.0的形式。

        小提示:EIGRP会自动在边界上归纳路由信息为主类IP地址,如果要想取消自动归纳则需要使用no auto-summary命令。

        ROUTER-B

        router eigrp 65500    启动EIGRP动态协议,并设置自治系统号为65500,自治系统号要和A设置的一样才能正常通讯。

        network 30.0.0.0    宣告EIGRP通告的网段,仍然要采用主类的方式。

        总结:配置完毕后在PC2上ping PC1计算机的IP地址是可以连通的,同理pc1也可以成功ping通PC2。这些都是因为EIGRP动态协议对10.0.0.0与30.0.0.0网段宣告的结果。

    • 配置OSPF动态路由协议

          OSPF协议也叫开放最短路径优先协议,他是一项链路状态型技术,与路由选择信息协议(RIP)这样的距离矢量型技术相对,OSPF协议完成各路由选择协议算法的两大主要功能是路径选择和路径交换。目前最新版本是OSPF版本2。OSPF是一种内部网关协议(IGP),也就是说他在属于同一自治系统的路由器间发布路由选择信息。

        目前OSPF是应用最广泛的动态路由协议,他不是CISCO专有的路由协议,可以互连CISCO,华为和实达等多个公司的路由器,兼容性非常不错。因此适合于中小企业路由的互连。

        配置环境:

        ROUTER-A连接10.1.1.1/24和20.1.1.1/30两个网段,ROUTER-B连接20.1.1.1/30与30.1.1.1/24两个网段。如果不配置任何动态路由协议的话router-b将不知道到达10.1.1.1/24这个网段的路线,相应的A也不知道到达30.1.1.1/24这个网络。不配置OSPF协议的话PC2是不能成功PING通PC1的。下面我们在两台路由器上配置OSPF动态协议。


        配置方法

        ROUTER-A

        router ospf 1    启动OSPF进程,进程号为1,值得注意的是进程号本地路由器有效。

        network 10.1.1.0 0.255.255.255 area 0    设置OSPF通告的网络范围,将对10.1.1.0/24这个网段通告。后头的0.255.255.255指的是反向掩码,他代表通告的网段的子网掩码是255.255.255.0。

        小提示:第二句也可以使用network 10.1.1.1 0.0.0.0 area 0代替,这样OSPF将宣告接口10.1.1.1连接的网络。


        ROUTER-B

        router ospf 1    启动OSPF进程,进程号为1。

        network 30.1.1.1 0.255.255.255 area 0    宣告30.1.1.0/24这个网段。

        小提示:第二句也可以使用network 30.1.1.1 0.0.0.0 area 0这个命令来宣告ROUTER-B上30.1.1.1这个接口连接的网段。

     
    展开全文
  • R1: enable config terminal host r1 no ip domain-lookup int f0/0 ip address 10.0.1.2 255.255.255.0 no shut exit int f0/1 ip address 192.168.2.1 255.255.255.0 no shut exit router rip //rip协议,...
  • 拓扑图: 配置代码: R1 enable config terminal ...OSPF路由协议的进程号为100,一个路由器上可启用多个OSPF进程,以进程号作为区别标志 network 192.168.1.0 0.0.0.255 area 1 router-id 192.168.1.1 !这个路
  • 网络拓扑图: 代码: R1: En Conf t Host r1 No ip domain-lookup Int g0/0 Ip address 192.168.3.1 255.255.255.252 No shut Int g0/1 Ip address 192.168.1.254 255.255.255.0 ...Ip address 192.168.3....
  • 动态路由协议

    2021-03-19 14:08:30
    内容概要1、动态路由协议1、动态路由协议基础2、动态路由协议分类2、RIP路由协议1、RIP路由协议的工作原理2、路由表的形成3、RIP度量值与更新时间4、水平分割5、RIP命令 1、动态路由协议 1、动态路由协议基础 动态...
  • 动态路由协议 路由往邻居上发包,然后互相学习。 不同的路由协议有不同的值,有的路由协议会定期发送给邻居,有些路由协议是触发性发送,就是当自己的网段发生改变或者增加时,会发送给相邻的路由,让他们学习。 ...
  • EIGRP—思科私有动态路由协议 一、基本概念 EIGRP全称是增强性内部网关路由协议,又称混合型路由协议Cisco私有,无类别的距离矢量协议,跨层封装到三层,协议号88;组播更新224.0.0.10,支持等开销负载均衡和非...
  • 学习笔记:动态路由协议,距离矢量路由协议RIP(原理及配置) 1.动态路由 基于某种路由协议实现 特点: 减少了管理任务 占用了网络带宽 1.1基础 动态路由协议概述 路由器之间用来交换信息的语言 度量值 跳数...
  • 动态路由协议RIP

    2021-03-22 22:05:54
    动态路由协议动态路由动态路由特点动态路由协议概述度量值收敛静态路由与动态路由的比较按照路由执行的算法分类距离矢量路由协议链路状态路由协议路由表的形成RIP的基本概念执行水平分割可以阻止路由环路的发生 ...
  • 路由的基本概念: 1 路由:判断从源主机到目标主机所经过的最佳路径,从而实现数据的转发,这就是路由技术。 2 路由表:在每个路由器中都有一张路由表,路由表包含了该路由器掌握的所有目的地的网络地址,以及通过此...
  • 文章目录CCNA3:RIP:路由信息协议一、动态路由协议:二、RIP:路由信息协议1、RIP协议的特点:2、V1和V2的区别:3、RIP的工作原理:4、RIP的破环机制:5、RIP如果没有破环机制会怎么样?三、RIP的配置:1、基本配置...
  • 一、动态路由协议分类 动态路由协议包括IGP(内部网关协议)和EGP(外部网关协议)。 1.IGP IGP又包括距离向量路由协议和链路状态路由协议。 (1)距离向量路由协议典型代表:RIP (2)链路状态路由协议典型...
  • 文章目录动态路由协议1.1 概述1.2 分类1.3 RIP1.3.1 概述1.3.2 更新机制1.3.3 防环机制1.3.4 汇总1.3.5 Cisco、Huawei区别1.4 OSPF 动态路由协议 1.1 概述 动态路由协议:各台路由器上运行相同的协议,这些协议会让...
  • 动态路由协议 各台路由器上运行相同的协议,这些协议会让设备间进行沟通,学习来获取未知的路由条目信息,最终实行全网可达。 动态路由协议的障碍: 1.安全 2.选路不佳——最严重出现环路 3.对硬件资源的占用 动态...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 30,090
精华内容 12,036
关键字:

思科动态路由协议