精华内容
下载资源
问答
  • 思科单臂路由实验

    2015-07-30 16:31:23
    实验拓扑图:pc1和pc2分别接入同一交换机的不同vlan,交换机一端口配置trunk与路由器一端口对接,路由器开启dhcp功能,pc1和pc2分别能够获取到ip,并且通过路由的网关ip实现pc1和pc2互通。在交换机做配置1.配置vlanR...

    实验拓扑图:

        wKioL1W54OLjKgxsAADERA9B6s4179.jpgpc1和pc2分别接入同一交换机的不同vlan,交换机一端口配置trunk与路由器一端口对接,路由器开启dhcp功能,pc1和pc2分别能够获取到ip,并且通过路由的网关ip实现pc1和pc2互通。


    在交换机做配置

    1.配置vlan

    R2-SW#vlan database

    R2-SW(vlan)#vlan 10

    VLAN 10 modified:

    R2-SW(vlan)#vlan 20

    VLAN 20 modified:

    R2-SW(vlan)#exit

    R2-SW#conf t


    与pc对接的端口分别接入vlan10,vlan20

    R2-SW(config)#interface FastEthernet1/1

    R2-SW(config-if)#switchport mode access

    R2-SW(config-if)#switchport access vlan 10

     

    R2-SW(config)#interface FastEthernet1/2

    R2-SW(config-if)#switchport mode access

    R2-SW(config-if)#switchport access vlan 20


    配置trunk口

    R2-SW(config)#int f1/15

    R2-SW(config-if)#switchport mode trunk

    R2-SW(config-if)#switchport trunk encapsulation dot1q

    R2-SW(config-if)#switchport trunk allowed vlan all





    配置路由器

    配置子接口ip,并且子接口需要封装vlan标示

    R1(config)#ip routing

    R1(config)#interface FastEthernet0/1.1

    R1(config-subif)#encapsulation dot1Q 10

    R1(config-subif)#ip address 192.168.10.1 255.255.255.0

    R1(config)#interface FastEthernet0/1.2

    R1(config-subif)#encapsulation dot1Q 20

    R1(config-subif)#ip address 192.168.20.1 255.255.255.0


    开启该端口

    R1(config)#interface FastEthernet0/1

    R1(config)#no shutdown



    分别配置两个dhcp,分发ip地址

    R1(config)#ip dhcp pool vlan10

    R1(dhcp-config)#network 192.168.10.0

    R1(dhcp-config)#network 192.168.10.0 255.255.255.0

    R1(dhcp-config)#default-router 192.168.10.1

    R1(dhcp-config)#exit

    R1(config)#ip dhcp pool vlan20

    R1(dhcp-config)#network 192.168.20.0

    R1(dhcp-config)#network 192.168.20.0 255.255.255.0

    R1(dhcp-config)#default-router 192.168.20.1



    验证结果

    wKiom1W54MXyHJRKAACowmEiZqU812.jpg

    转载于:https://blog.51cto.com/dragon123/1680184

    展开全文
  • 单臂路由配置 实验设备:路由器、交换机、两台PC(pc1/pc2)  pc1的配置:IP:192.168.2.10 网关:192.168.2.1  pc2的配置:IP:192.168.3.10 网关:192.168.3.1 交换机的配置如:...................

    这个是我进入企业后开始做的第一个网络实验,以前是学的编程,没想到最后干的是运维。

    既然做这行了,就努力学吧!

    单臂路由配置

    实验设备:路由器、交换机、两台PC(pc1/pc2)

     pc1的配置:IP:192.168.2.10 网关:192.168.2.1

     pc2的配置:IP:192.168.3.10 网关:192.168.3.1

    交换机的配置如:..............................交换机里面固有一个vlan 1

    Switch>enable

    创建虚拟局域网

    Switch#vlan database

    Switch(vlan)#vlan 2 name test01  

    VLAN 2 added:

    Name: test01

    Switch(vlan)#vlan 3 name test02

    VLAN 3 added:

    Name: test02

    Switch(vlan)#exit

    APPLY completed.

    Exiting....

    端口和虚拟局域网的配置

    Switch#config

    Configuring from terminal, memory, or network [terminal]?

    Enter configuration commands, one per line. End withCNTL/Z.

    Switch(config)#interface fa0/2 ...........................配置接口fa0/2

    Switch(config-if)#switchport access vlan 2 ...........................vlan 2 里面的PC从此接口进入

    Switch(config-if)#exit


    Switch(config)#interface fa0/3

    Switch(config-if)#switchport access vlan 3

    Switch(config-if)#exit


    Switch(config)#interface fa0/1

    Switch(config-if)#switchport mode trunk ..................打开trunk模式(将fa0/1设置为主端口)

    Switch(config-if)#switchport trunk allowed vlan all ..................所有vlan都能从这个主端口通过

    Switch(config-if)#exit

    Switch(config)#end

    %SYS-5-CONFIG_I: Configured from console by console

    Switch#write memory

    Building configuration...

    路由的配置:

    Router>enable

    Router#config

    Configuring from terminal, memory, or network [terminal]?

    Enter configuration commands, one per line. End withCNTL/Z. .................进入全局配置模式


    Router(config)#interface fa0/0...........配置fa0/0接口

    Router(config-if)#no shutdown................激活该端口

    Router(config-if)#exit……………返回上层


    Router(config)#interface fa0/0.1...........配置子接口这是配置单臂路由的关键,这个接口是个逻辑接口,并不是实际存在的物理接口,但是功能却和物理接口是一样的。

    Router(config-subif)#encapsulationdot1q 2 ...为这个接口配802.1Q协议

    Router(config-subif)#ip address192.168.2.1 255.255.255.0 .....为该接口划分网关地址。

    Router(config-subif)#exit


    Router(config)#interface fa0/0.2.....进入第2个子接口,进行配置

    Router(config-subif)#encapsulationdot1q 3 .........配置802.1Q协议

    Router(config-subif)#ip address 192.168.3.1 255.255.255.0 ......划分网关地址和子网掩码

    Router(config-subif)#end

    分别对两台机子互相ping的测试,能够ping通,说明实验成功。

     

    展开全文
  • 配置参数如图:PC1 vlan 20 20.1.1.1 网关20.1.1.254PC2 vlan 30 20.1.1.1 网关30.1.1.254PC3 vlan 40 40.1.1.1 网关40.1.1.254R1配置以下3个子接口地址:g0/0.1 20.1.1.254g0/0.2 30.1.1.254g0/0.3 40.1.1.254-----...

    QQ截图20180613212516.png

    配置参数如图:

    PC1 vlan 20 20.1.1.1 网关20.1.1.254

    PC2 vlan 30 20.1.1.1 网关30.1.1.254

    PC3 vlan 40 40.1.1.1 网关40.1.1.254


    R1配置以下3个子接口地址:

    g0/0.1 20.1.1.254

    g0/0.2 30.1.1.254

    g0/0.3 40.1.1.254

    -----------------分割线------------------------

    1.首先配置PC1~3 ip及网关

    2.对SW1进行如下配置:

    Switch>en

    Switch#conf t

    Switch(config)#hos SW1

    SW1(config)#vlan 20

    SW1(config-vlan)#vlan 30

    SW1(config-vlan)#vlan 40

    SW1(config-vlan)#exit


    SW1(config)#int f0/1

    SW1(config-if)#switchport mode acc

    SW1(config-if)#switchport acc vlan 20


    SW1(config-if)#int f0/2

    SW1(config-if)#sw m acc

    SW1(config-if)#sw acc vlan 30


    SW1(config-if)#int f0/3

    SW1(config-if)#sw m acc

    SW1(config-if)#sw acc vlan 40


    SW1(config-if)#int g0/1

    SW1(config-if)#sw m tr


    3.接下来我们对R1进行配置

    Router>en

    Router#conf t


    Router(config)#int g0/0.1

    Router(config-subif)#encapsulation dot1Q 20

    Router(config-subif)#ip add 20.1.1.254 255.255.255.0


    Router(config-subif)#int g0/0.2

    Router(config-subif)#en d 30

    Router(config-subif)#ip add 30.1.1.254 255.255.255.0


    Router(config-subif)#int g0/0.3

    Router(config-subif)#en d 40

    Router(config-subif)#ip add 40.1.1.254 255.255.255.0


    Router(config-subif)#int g0/0

    Router(config-if)#no sh


    好了现在三台PC可以跨vlan通讯了!

    转载于:https://blog.51cto.com/13745037/2129089

    展开全文
  • 概述:单臂路由的作用就是一台路由器允许多个vlan互相通信 单臂路由的结构是二层交换机、路由器 连接设备 交换机配置 Switch>enable Switch#config terminal //进入全局配置模式 Enter configuration commands,...

    概述:单臂路由的作用就是一台路由器允许多个vlan互相通信

    单臂路由的结构是二层交换机、路由器

    连接设备
    在这里插入图片描述
    交换机配置

    
    Switch>enable
    Switch#config terminal  //进入全局配置模式
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#hostname W1    //更改交换机名称
    W1(config)#
    W1(config)#vlan 2    //创建vlan 2
    W1(config-vlan)#exit
    W1(config)#vlan 3      //创建vlan 3
    W1(config-vlan)#exit
    W1(config)#
    //配置交换机接口模式
    f0/1,f0/2分别连接pc0 and netbook
    W1(config)#int f0/1      //进入f0/1 接口
    W1(config-if)#switchport mode access  //配置接口模式为access,access只允许一个vlan通过
    W1(config-if)#switchport access vlan 2  //允许vlan 2 通过
    W1(config-if)#
    W1(config-if)#int f0/2    //进入f0/2接口
    W1(config-if)#switchport mode access   //配置接口模式为access
    W1(config-if)#switchport access vlan 3  //允许vlan 3 通过
    W1(config-if)#
    W1(config-if)#exit
    W1(config)#int f0/3  //进入f0/3
    W1(config-if)#switchport mode trunk  //配置接口模式为trunk  ,trunk允许多个vlan通过
    

    配置路由器

    R1(config)#interface fastEthernet0/0.1  # 进入到F0/0.1接口
    
      R1(config-subif)#encapsulation dot1Q 2   # 将vlan2封装在F0/0.1接口
    
      R1(config-subif)#ip address 192.168.2.1 255.255.255.0  # 配置接口的ip地址,该ip地址作为vlan 2内的电脑的网关
    
      R1(config-subif)#exit  # 退出F0/0.1接口
    
      R1(config)#interface fastEthernet 0/0.2  # 进入到F0/0.1接口
    
      R1(config-subif)#encapsulation dot1Q 3  # 将vlan3封装在F0/0.2接口
    
      R1(config-subif)#ip address 192.168.4.1 255.255.255.0  # 配置ip地址,该ip地址作为vlan3内的电脑的网关
    

    ping 一下
    在这里插入图片描述

    展开全文
  • 思科单臂路由+动态NAT实验学习笔记 实验拓扑如下:IP配置信息PC1:ip-192.168.1.100/24 gw-192.168.1.254 PC2:ip-192.168.2.100/24 gw-192.168.2.254SW1:VLAN 100、200R3:F0/0.1 ip-192.168.1.254/24 F0/0.2 ip-192....
  • 实验拓扑 VLAN共计:VLAN10、VLAN20、VLAN30、VLAN40,如上图所示。 实验要求:全网互通 sw1配置相应接口 划分VLAN10、VLAN20,将接口f0/1加入到VLAN10,f0/2加入到VLAN20 g0/1设置为trunk Switch(config)#hostname ...
  • 思科单臂路由的配置

    2016-06-29 18:59:10
    实验拓扑 因为跨VLAN通信,所以交换机出口要设置trunk。路由器也要设置子接口并封装帧。 路由器关键配置: interface GigabitEthernet0/0.10 encapsulation dot1Q 10 ip address 192.168...
  • 单臂路由 实验步骤

    2019-05-22 12:43:19
    单臂路由:(实验步骤) 使用思科模拟器,进行单臂路由配置,并在相同VLAN下相互访问。整体拓扑图如下: 整体有一个网络v1,添加两个新的VLAN,VLAN10 和 VLAN20 。一台路由器 Router0 。两台交换机 Switch0 和 ...
  • 思科单臂路由实验拓扑:步骤:一,为PC配置IP地址(使用VPCS)二,在交换机划VLAN,并以access方式将各接口加入到vlan中SW1:SW2:三,在路由器上划分子接口做各vlan的网关做单臂路由R1:四,测试各vlan的PC间通信,...
  • 路由 器的 配置 : Router > Router> Router>en Router#config t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#int f0/0 Router(config-if)#no shutdown Router(config-if)#int f0...
  • 单臂路由实验: 目的:实现不同VLAN通过路由器通信 实现方法: 1.在交换机上配置好VLAN,将相应的端口添加到VLAN中 2.交换机和路由器相连接的那个端口,即交换机的上联端口要配置为Trunk 3.在路由器的接口上进入“子...
  • 思科单臂路由

    2018-05-10 10:13:00
    1.什么是单臂路由?  是指在路由器的一个接口上通过配置子接口(或“逻辑接口”,并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通。 2.实验如下(思科模拟器)  拓扑图...
  • 思科vlan单臂路由

    2017-05-31 16:30:46
    思科vlan单臂路由一.拓扑图: 二.实验目标:1.不同vlan成员可以通信;2.全网互通。三.实验环境: VLAN 1的IP段是192.168.0.0/24成员SW1和SW2其IP分别为:192.168.0.2和192.168.0.3;成员网关是192.168.0.1。 VLAN...
  • 今天给大家带来一个小型网络构建实验,主要是思科设备单臂路由和DHCP的结合运用。 知识点: 一、单臂路由 &单臂路由 的定义及作用 单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接口(或...
  • 作者:最铁头的网工 来源:CSDN 文章属性:自创,如有抄袭必究 ...感谢关注铁头娃技术,联系QQ:3473067134 ...3、RA和RB上配置静态路由实现总部和分部之间相互通信 一、交换机基本配置 Switch(config)#hostname
  • 实验名称:简单的单臂路由的 配置实验思科实验拓扑: 实验需要:1、按图中所示配置设网络备vlan,IP地址2、能够使各pc互相ping通。 实验步骤: 1、配置终端设备: pc1-pc5按照拓扑图中所示配置各个pc的ip地址...
  • 一、实验拓扑:二、实验要求:1、R1部署单臂路由技术,为实现不同vlan间的通信:f0/0配置子接口f0/0.10、f0/0.20,封装dot1q(ISL:Inter-Switch Link,思科交换链路内协议,Cisco专有的Trunk封装方式);...

空空如也

空空如也

1 2 3 4 5
收藏数 95
精华内容 38
关键字:

思科单臂路由实验