精华内容
下载资源
问答
  • 本文实例讲述了思科cisco路由器dhcp动态分配ip地址实现方法。分享给大家供大家参考,具体如下:一、拓扑图Router1 F0/0 Switch5 F0/0Router1 E1/0 VPCS V0/5Switch5 F0/1 Switch1 F0/0Switch5 F0/2 Switch2 F0/0...

    本文实例讲述了思科cisco路由器dhcp动态分配ip地址实现方法。分享给大家供大家参考,具体如下:

    一、拓扑图

    Router1 F0/0 Switch5 F0/0

    Router1 E1/0 VPCS V0/5

    Switch5 F0/1 Switch1 F0/0

    Switch5 F0/2 Switch2 F0/0

    Switch5 F0/3 Switch3 F0/0

    Switch5 F0/4 Switch4 F0/0

    Switch1 F0/1 VPCS V0/1

    Switch2 F0/1 VPCS V0/2

    Switch3 F0/1 VPCS V0/3

    二、dhcp服务器就是通过主机分配ip的一项服务。路由是通过那个口来分配的。接几个分配几个。要使客户机能从用作DHCP Server的路由器中自动获得IP地址。

    三、实验要求:

    1、vlan之间的通信通过三层交换机来实现

    2、路由器为4个vlan来分配ip地址

    3、pc1 - 4分别属于4个部门,能够自动得到ip地址

    4、pc1 - 5直接可以ping通

    四、实验思路:

    1、首先配置二层交换机上的vlan、trunk并把接口加入vlan

    2、三层交换中配置vlan、trunk并启用ip routing路由功能

    3、三层交换中配置vlan ip地址,三层交换机是带有三层路由功能的交换机,也就是这台交换机的端口既有三层路由功能,

    也具有二层交换功能。三层交换机端口默认为二层口,

    如果需要启用三层功能就需要在此端口输入no switchport命令。运行router rip协议(其他协议也行)查看路由表 show ip router

    4、配置路由器dhcp服务 建立地址持ip dhcp pool apple(apple为地址池名称可以随便起)运行router rip协议

    5、保存设置:在全局配置模式下 Router#copy running-config startup-config //保存当前的配置 或 Router#write 也行

    6、查看!

    五、实验过程:

    1、配置二层交换机valn  trunk 并将接口加入vlan

    sw1#vlan data

    sw1#vlan database

    sw1(vlan)#vlan 10

    VLAN 10 added:

    Name: VLAN0010

    sw1(vlan)#exit

    APPLY completed.

    Exiting....

    sw1#conf t

    Enter configuration comman

    sw1(config)#interface f0/0

    sw1(config-if)#sw m t

    sw1(config-if)#interface f0/1

    sw1(config-if)#sw ac vlan 10

    sw1(config-if)#exit

    sw1(config)#exit

    sw1#show vlan-switch

    sw2 - 4相同配置

    2、配置三层交换(vlan、trunk、vlan ip)

    sw3-1#vlan da

    sw3-1(vlan)#vlan 10

    VLAN 10 added:

    Name: VLAN0010

    sw3-1(vlan)#vlan 20

    VLAN 20 added:

    Name: VLAN0020

    sw3-1(vlan)#vlan 30

    VLAN 30 added:

    Name: VLAN0030

    sw3-1(vlan)#vlan 40

    VLAN 40 added:

    Name: VLAN0040

    sw3-1(config)#ip routing 在三层交换中启动路由功能

    sw3-1(config)#interface vlan 10

    sw3-1(config-if)#ip ad 192.168.1.1 255.255.255.0 配置vlan ip

    sw3-1(config-if)#no shut

    sw3-1(config-if)#exit

    sw3-1(config)#interface vlan 20

    sw3-1(config-if)#ip ad 192.168.2.1 255.255.255.0

    sw3-1(config-if)#no shut

    sw3-1(config-if)#exit

    sw3-1(config)#interface vlan 30

    sw3-1(config-if)#ip address 192.168.3.1 255.255.255.0

    sw3-1(config-if)#no shut

    sw3-1(config-if)#interface vlan 40

    sw3-1(config-if)#ip ad 192.168.4.1 255.255.255.0

    sw3-1(config-if)#no shut

    sw3-1(config-if)#exit

    sw3-1(config)#interface rang f0/1 - 4 配置trunk

    sw3-1(config-if-range)#sw m t

    sw3-1(config-if-range)#exit

    sw3-1(config)#interface f0/0

    sw3-1(config-if)#no switchport 启动三层接口

    sw3-1(config)#interface f0/0

    sw3-1(config-if)#ip address 10.0.0.1 255.0.0.0 配置接口ip

    sw3-1(config-if)#no shut

    sw3-1(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.3 配置默认路由

    sw3-1(config)#router rip 启用rip协议

    sw3-1(config-router)#network 192.168.1.0

    sw3-1(config-router)#network 192.168.2.0

    sw3-1(config-router)#network 192.168.3.0

    sw3-1(config-router)#network 192.168.4.0

    sw3-1(config-router)#network 10.0.0.0

    查看路由表

    3、配置dhcp路由器

    dhcp(config)#interface f0/0

    dhcp(config-if)#ip address

    dhcp(config-if)#ip address 10.0.0.3 255.0.0.0

    dhcp(config-if)#interface 192.168.237.1 255.255.255.0

    dhcp(config)#inte e1/0

    dhcp(config-if)#ip add 192.168.237.1 255.255.255.0

    dhcp(config-if)#no shut

    dhcp(config-if)#exit

    dhcp(config)#router rip

    dhcp(config-router)#network 10.0.0.0

    dhcp(config-router)#network 192.168.237.0

    show ip route 同上

    dhcp(config)#ip dhcp pool apple 建立地址池

    dhcp(dhcp-config)#network 192.168.0.0 255.255.0.0

    4、在三层交换指定dhcp服务器即路由器的ip 地址。

    sw3-1(config)#interface vlan 10

    sw3-1(config-if)#ip helper-address 10.0.0.3

    sw3-1(config-if)#interface vlan 20

    sw3-1(config-if)#ip helper-address 10.0.0.3

    sw3-1(config-if)#interface vlan 30

    sw3-1(config-if)#ip helper-address 10.0.0.3

    sw3-1(config-if)#inter vlan 40

    sw3-1(config-if)#ip helper-address 10.0.0.3

    5、配置pc5的ip地址为192.168.237.2  255.255.255.0 gateway 192 .168.237.1

    结果:pc5都能ping通pc1 - 4

    展开全文
  • 拓扑图 实验过程 (1)路由器IP地址分配 (2)DHCP协议 (3)查看PC分配结果

    拓扑图
    在这里插入图片描述
    实验过程
    (1)路由器IP地址的分配
    在这里插入图片描述
    (2)DHCP协议
    在这里插入图片描述
    (3)查看PC分配结果
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • Switch#configure terSwitch#configure terminalEnter configuration commands, one per line. End with CNTL/Z.Switch(config)#intSwitch(config)#interface fasSwitch(config)#interface fastEthernet 0/1Switc...

    Switch#configure ter

    Switch#configure terminal

    Enter configuration commands, one per line. End with CNTL/Z.

    Switch(config)#int

    Switch(config)#interface fas

    Switch(config)#interface fastEthernet 0/1

    Switch(config-if)#swi

    Switch(config-if)#switchport acc

    Switch(config-if)#switchport access vlan 1

    Switch(config-if)#exit

    Switch(config)#int

    Switch(config)#interface fas

    Switch(config)#interface fastEthernet 0/2

    Switch(config-if)#sw

    Switch(config-if)#switchport acc

    Switch(config-if)#switchport access vl

    Switch(config-if)#switchport access vlan 1

    Switch(config-if)#exit

    Switch(config)#exit

    Switch#

    %SYS-5-CONFIG_I: Configured from console by console

    Switch#ena

    Switch#enable

    Switch#con

    Switch#conf

    Switch#configure ter

    Switch#configure terminal

    Enter configuration commands, one per line. End with CNTL/Z.

    Switch(config)#vlan 2

    Switch(config-vlan)#exit

    Switch(config)#exit

    Switch#

    %SYS-5-CONFIG_I: Configured from console by console

    show vlan

    VLAN Name Status Ports

    ---- -------------------------------- --------- -------------------------------

    1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4

    Fa0/5, Fa0/6, Fa0/7, Fa0/8

    Fa0/9, Fa0/10, Fa0/11, Fa0/12

    Fa0/13, Fa0/14, Fa0/15, Fa0/16

    Fa0/17, Fa0/18, Fa0/19, Fa0/20

    Fa0/21, Fa0/22, Fa0/23, Fa0/24

    2 VLAN0002 active

    1002 fddi-default act/unsup

    1003 token-ring-default act/unsup

    1004 fddinet-default act/unsup

    1005 trnet-default act/unsup

    VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

    1 enet 100001 1500 - - - - - 0 0

    2 enet 100002 1500 - - - - - 0 0

    1002 fddi 101002 1500 - - - - - 0 0

    1003 tr 101003 1500 - - - - - 0 0

    1004 fdnet 101004 1500 - - - ieee - 0 0

    Switch#nt

    Switch#conf

    Switch#configure ter

    Switch#configure terminal

    Enter configuration commands, one per line. End with CNTL/Z.

    Switch(config)#int

    Switch(config)#interface fas

    Switch(config)#interface fastEthernet 0/3

    Switch(config-if)#swi

    Switch(config-if)#switchport mod

    Switch(config-if)#switchport mode acc

    Switch(config-if)#switchport mode access

    Switch(config-if)#siw

    Switch(config-if)#swi

    Switch(config-if)#switchport acc

    Switch(config-if)#switchport access vl

    Switch(config-if)#switchport access vlan 2

    Switch(config-if)#exit

    Switch(config)#int

    Switch(config)#interface fas

    Switch(config)#interface fastEthernet 0/4

    Switch(config-if)#swi

    Switch(config-if)#switchport mo

    Switch(config-if)#switchport mode acc

    Switch(config-if)#switchport mode access

    Switch(config-if)#swi

    Switch(config-if)#switchport acc

    Switch(config-if)#switchport access 0/4

    ^

    % Invalid input detected at '^' marker.

    Switch(config-if)#switchport access vlan 2

    Switch(config-if)#exit

    Switch(config)#

    %LINK-5-CHANGED: Interface FastEthernet0/3, changed state to down

    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down

    %LINK-5-CHANGED: Interface FastEthernet0/3, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up

    Switch con0 is now available

    Press RETURN to get started.

    Switch>enab

    Switch>enable

    Switch#conf

    Switch#configure ter

    Switch#configure terminal

    Enter configuration commands, one per line. End with CNTL/Z.

    Switch(config)#int

    Switch(config)#interface fast

    Switch(config)#interface fastEthernet 0/1

    Switch(config-if)#ip ad

    Switch(config-if)#ip ad

    Switch(config-if)#ip add

    Switch(config-if)#ip addr

    Switch(config-if)#ip addre

    Switch(config-if)#ip address 192.168.1.10 255.255.255.0

    ^

    % Invalid input detected at '^' marker.

    Switch(config-if)#ip addr

    Switch(config-if)#ex

    Switch(config-if)#exit

    Switch(config)#int

    Switch(config)#interf vl

    Switch(config)#interf vlan 1

    Switch(config-if)#ip add

    Switch(config-if)#ex

    Switch(config-if)#exit

    Switch(config)#interf vlan 1

    Switch(config-if)#ip add

    Switch(config-if)#ip address 192.168.1.10/24

    ^

    % Invalid input detected at '^' marker.

    Switch(config-if)#ex

    Switch(config-if)#exit

    Switch(config)#vlan 1

    Switch(config-vlan)#ip add

    Switch(config-vlan)#ex

    Switch(config-vlan)#exit

    Switch(config)#int

    Switch(config)#interface fas

    Switch(config)#interface fastEthernet 0/1

    Switch(config-if)#ip add

    Switch(config-if)#exit

    Switch(config)#int

    Switch(config)#interf vlan 1

    Switch(config-if)#ip add

    Switch(config-if)#ip address 192.168.1.10 255.255.255.0

    Switch(config-if)#no sh

    Switch(config-if)#no shutdown

    Switch(config-if)#

    %LINK-5-CHANGED: Interface Vlan1, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

    Switch(config-if)#exit

    Switch(config)#use

    Switch(config)#username a

    Switch(config)#pa

    Switch(config)#pass

    Switch(config)#user

    Switch(config)#username a pass

    Switch(config)#username a password b

    Switch(config)#Li

    Switch(config)#Line vty 0 9

    Switch(config-line)#log

    Switch(config-line)#login lo

    Switch(config-line)#login local

    Switch(config-line)#exit

    Switch(config)#ena

    Switch(config)#enable pas

    Switch(config)#enable password c

    Switch(config)#

    h.jpg

    h.jpg

    参考文献:

    展开全文
  • 计算机都提供了修改IP地址的方法,所以用户可以随意更改自己的IP地址,IP地址的随意修改势必影响其他用户的正常上网,所以推行IP地址和MAC地址绑定,每一个分配的IP地址都要绑定到用户自己的注册的MAC地址上,保证了...

    为什么mac地址和IP地址要绑定?

    提高局域网安全,防止arp攻击和欺骗
    计算机都提供了修改IP地址的方法,所以用户可以随意更改自己的IP地址,IP地址的随意修改势必影响其他用户的正常上网,所以推行IP地址和MAC地址绑定,每一个分配的IP地址都要绑定到用户自己的注册的MAC地址上,保证了用户的合法IP不被盗用和滥用,有效地保证了网络的安全和通信质量。

    绑定的方式有很多种,可以在电脑上绑定,也可以在交换机上绑定

    思科交换机绑定配置
    INTERNAL-CORE-1> enable                       进入特权模式
    INTERNAL-CORE-1# configure terminal            进入配置模式
    INTERNAL-CORE-1(config)# arp 10.65.165.11 f8-b1-56-d1-b2-67 arpa       配置IP地址与mac地址绑定
    INTERNAL-CORE-1(config)# no arp 10.65.165.11 f8-b1-56-d1-b2-67 arpa    删除IP地址和mac地址绑定
    INTERNAL-CORE-1# show running-config           查看交换机当前配置
    
    华为交换机配置
    <internal-CBSYD-core-switch>sys   用户模式进入配置模式
    [internal-CBSYD-core-switch] arp static 10.66.164.21 0009-6bdd-6f4a   配置IP地址与MAC地址绑定
    [internal-CBSYD-core-switch] undo arp static 10.66.164.21 0009-6bdd-6f4a 删除IP地址和mac地址绑定
    <internal-CBSYD-core-switch> save  保存配置
    [internal-CBSYD-core-switch] dis cu         查看当前配置
    
    注意:绑定了电脑就不能随便更改IP地址,不然会引起电脑无法上网。
    
    
    展开全文
  • 一、DHCP server功能:DHCP可以动态的为其管辖下的主机分配地址。DHCP协议报文是UDP报文,DHCP使用67(客户端)和68(服务器)端口。首先,客户端(例如我们PC的网卡)在其所在广播域广播发送discover报文;当此广播域的...
  • 使用cisco的2621路由器作为DHCP服务器,给下面链接的PC 机分配IP地址,默认DHCP服务时开启的,W是使用PT模拟器来做的,可能和cisco的标准配置的命令有点不同:DHCP实验拓扑:IP地址规划:R0---F0/0=192.168.1.1/24.....
  • show ip dhcp conflict //查看检冲突导致ip而不会被分配的地址 ...show ip dhcp binding //查看地址分配情况 clear ip dhcp binding * //清除所有dhcp地址分配地址记录 clear ip dhcp conflict //清除conflict ...
  • 思科实验

    2019-09-18 06:51:15
    本想录制动画的在配置6个路由3个交换机分配12个网络地址 自己被搞脑乱加上又困经常把IP看错搞了大半天晕懒得录了 这个虽然有点复杂但并不难只是重复分配些IP只是看错就会配错呵呵6个路由还...
  • 理解:思科设备上的网络地址翻译功能(NAT)功能现在全世界的IPv4地址已经被宣布彻底耗尽,所以为全世界的计算机都分配一个被公共网络认可的IP地址,这将是不可能的事实!所有RFC1918定义了一个属于私有地址的空间...
  • Cisco路由器上建立一个名为zw246的DHCP地址池,地址池的IP地址是176.115.246.0/24,其中不用于动态分配地址有176.115.246.2~176.115.246.10,缺省网关为176.115.246.1,域名为tj.edu.cn,域名服务器地址为176....
  • 单项选择题在Cisco路由器上建立一个名为zw100的DHCP地址池,地址池的IP地址是176.115.100.0/24,其中不用于动态分配地址有176.115.100.2-176.115.100.10,默认网关为176.115.100.1,域名为tj.edu.cn,域名服务器...
  •  你是某公司的网络管理员,公司办公网需要接入互联网,公司只向ISP申请了一条专线,该专线分配了一个公司IP地址,配置实现全公司的主机都能访问外网。 技术原理  NAT将网络划分为内部网络和外部网络两部分,...
  • 但是,动态分配 IPv6 全局单播地址有两种方法: 如图所示,无状态地址自动配置 (SLAAC) IPv6 的动态主机配置协议(有状态 DHCPv6) 一.SLAAC SLAAC 是一种可以在没有 DHCPv6 服务器服务的情况下获取 IPv6 全局...
  • 思科ei ccie网工一定要了解的网络地址转换NAT-动态NAT的使用范围和配置,什么是动态NAT? 使用公有地址池,并以先到先得的原则分配这些地址。当具有私有IP地址的主机请求访问 Internet 时,动态 NAT 从地址池中选择...
  •  非盈利组织互联网协会的首席技术执行官莱斯利·戴格勒(Leslie Daigle)表示,这其实简单的数字问题,以分配给不同网络和个人电脑的IP地址为32位来计算,允许的IP地址总数量大约为42亿个。  ...
  • 思科华为DHCP实验

    2020-07-14 17:02:28
    1.给内部网络或网络服务供应商自动分配IP地址2.给用户或者内部网络管理员作为对所有计算机作中央管理的手段 DHCP的过程原理: 1、client向server发送请求,发向广播地址 2、server向client回应一个IP,发向单播地址 ...
  • 思科CISCO)TRUNK简单配置

    千次阅读 2019-05-12 10:28:35
    思科TRUNK配置 一、项目背景 需要 TRUNK 才能在交换机之间传递 VLAN 信息。交换机上的端口可以是接入端口,或者是 TRUNK 端口。接入端口传输来自分配给该端口的特定 VLAN 的流量。...地址分配表 设备 接...
  • 思科防止dhcp攻击

    2020-05-11 00:06:59
    什么是DHCP?...集中的管理、分配IP地址,使client动态的获得IP地址、Gateway地址、DNS服务器地址等信息,并能够提升地址的使用 率。简单来说,DHCP就是一个不需要账号密码登录的、自动给内网机器分.
  • 思科 配置静态NAT

    千次阅读 2019-05-16 18:48:15
    在其他ISP那里,即使是拥有几百台计算机的大型局域网用户,当他们申请IP地址时,所分配地址也不过只有几个或十几个IP地址。显然,这样少的IP地址根本无法满足网络用户的需求。 1)在R1上将192...
  • TFTP软件下载:(备份与还原需要使用到的软件) ...一台电脑通过console端口连接到cisco 2960交换机,配置一个VLAN 10并分配IP地址和网关,电脑设置固定IP地址连接到cisco 2960交换机,确认交换机ping通这台电脑的IP...
  • 思科dhcp配置

    2012-08-24 21:54:23
    ip dhcp excluded-address 192.168.1.0 192.168.1.50 排除dhcp分配的ip地址 ip domain-name puzzled 此命令是为路由器设置一个域名,也可以认为这个路由器是属于哪个域 ip dhcp pool puzzled 定义dhcp地址池名 ...
  • 1、请根据企业所分配的公有IP地址拓扑中网段与主机的信息(注:交换机均为二层交换机,其配置为默认配置),使用VLSM方式进行IP地址的划分,要求: 1)网段2分配的IP网络号为划分的子网中第一个的子网;网段3分配的...
  • Sw2学院有电脑500台,sw3学院有电脑200台,合理分配IP地址段,避免浪费, 两个学院可以互相访问,也可以访问内网的web server, 分别对两个学院进行vlan设置, 各个交换机避免形成环路, RT1和RT2两个路由器运行RIP...
  • 思科设备配置DHCP命令

    万次阅读 2019-03-24 14:16:45
    DHCP(Dynamic Host Configuration Protocol)基本知识点: ...2 、DHCP最常见的应用是,自动给终端设备分配IP地址,掩码,默认网关,但是DHCP也同样可以给终端设备自动配置其他options,比如DNS server,tim...
  • 思科-OSPF多区域实验

    2018-01-17 20:50:12
    实验名称:思科OSPF多区域实验实验拓扑: 实验目的:通过OSPF技术...目前各路由器已经对端口及回环端口进行IP地址分配实验步骤:router1Router#confConfiguring from terminal, memory, or network [terminal]? Ente...
  • NAT思科实验

    千次阅读 2009-07-30 20:57:00
    使用PAT后,所有通过地址转换设备的机器都拥有了分配给它们相同IP地址,因此源端口号用来区分不同的连接。实验要求:1. 使用PAT实现使用一个公网IP让192.168.1.0这个网段的所有PC上网2. 外界主动访问ip地址为202...

空空如也

空空如也

1 2 3 4 5 ... 8
收藏数 154
精华内容 61
关键字:

思科地址分配