精华内容
下载资源
问答
  • 思科如何配置路由协议
    千次阅读
    2021-11-29 14:59:03

    步骤一:基本配置

    PC 1:

    IP地址 172.16.1.2

    子网掩码 255.255.255.0

    网关地址 172.16.1.1

    PC 2:

    IP地址 172.16.2.2

    子网掩码 255.255.255.0

    网关地址 172.16.2.1

    PC 3:

    IP地址 172.16.3.2

    子网掩码 255.255.255.0

    网关地址 192.168.3.1

    R1

    R1(config)#int fa0/0
    R1(config-if)#no shutdown
    R1(config-if)#ip address 172.16.1.1 255.255.255.0
    R1(config-if)#exit
    R1(config)#int serial 0/1/0
    R1(config-if)#clock rate 64000
    R1(config-if)#no shutdown
    R1(config-if)#ip address 192.168.2.2 255.255.255.0
    R1(config-if)#exit
    R1(config)#int serial 0/1/1
    R1(config-if)#clock rate 64000
    R1(config-if)#no shutdown
    R1(config-if)#ip address 192.168.3.1 255.255.255.0

     R2

    R2(config)#int fa0/0
    R2(config-if)#no shutdown
    R2(config-if)#ip address 172.16.2.1 255.255.255.0
    R2(config-if)#exit
    R2(config)#int serial 0/1/0
    R2(config-if)#clock rate 64000
    R2(config-if)#no shutdown
    R2(config-if)#ip address 192.168.3.2 255.255.255.0
    R2(config-if)#exit
    R2(config)#int serial 0/1/1
    R2(config-if)#clock rate 64000
    R2(config-if)#no shutdown
    R2(config-if)#ip address 192.168.1.1 255.255.255.0

    R3

    R3(config)#int fa0/0
    R3(config-if)#no shutdown
    R3(config-if)#ip address 172.16.3.1 255.255.255.0
    R3(config-if)#exit
    R3(config)#int serial 0/1/0
    R3(config-if)#clock rate 64000
    R3(config-if)#no shutdown
    R3(config-if)#ip address 192.168.2.1 255.255.255.0
    R3(config-if)#exit
    R3(config)#int serial 0/1/1
    R3(config-if)#clock rate 64000
    R3(config-if)#no shutdown
    R3(config-if)#ip address 192.168.1.2 255.255.255.0

    步骤二:配置RIPV2协议

    R1

    R1(config)#router rip
    R1(config-router)#network 192.168.2.0
    R1(config-router)#network 192.168.3.0
    R1(config-router)#network 172.16.1.2
    R1(config-router)#version 2//启用RIPV2

    R2

    R2(config)#router rip
    R2(config-router)#network 192.168.1.0
    R2(config-router)#network 192.168.3.0
    R2(config-router)#network 172.16.2.2
    R2(config-router)#version 2//启用RIPV2

    R3

    R3(config)#router rip
    R3(config-router)#network 192.168.1.0
    R3(config-router)#network 192.168.2.0
    R3(config-router)#network 172.16.3.2
    R3(config-router)#version 2//启用RIPV2

    步骤三:查看路由表 检查网络是否连通

    R1

     R2

     R3

    看到路由表这样就是配置成功了,如果出错就根据路由表继续排错 

    更多相关内容
  • 单臂路由,即在路由器上设置多个逻辑子接口,每个子接口对应一个vlan。在每个子接口的数据在物理链路上传递都要标记封装。Cisco设备支持ISL和802.1q(dot1Q)协议。华为只支持802.1q
  • 思科RIP路由协议配置

    千次阅读 2020-05-23 23:09:55
    思科路由器RIP协议配置 (供自己参考学习) RIP简介 RIP(Routing Information protocol) 路由信息协议. 是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议...

    思科路由器RIP协议的配置
    (供自己参考学习)

    RIP简介

    RIP(Routing Information protocol) 路由信息协议.
    是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法(DistanceVectorAlgorithms),使用“跳数”(即metric)来衡量到达目标地址的路由距离。RIP通过UDP报文进行路由信息交换,使用的端口号为520.

    RIP包括RIP-v1和RIP-v2两个版本

    RIPV1和RIPV2比较

    RIPV1RIPV2
    有类路由协议无类路由协议
    不支持VLSM支持VLSM
    广播更新255.255.255.255组播更新224.0.0.9

    实验
    在这里插入图片描述

    1. 首先配置PC2  PC3的IP地址
      PC1 192.168.10.2 MAC 255.255.255.0
      PC2 192.168.20.2 MAC 255.255.255.0
    2. R1的IP 10.0.0.1 255.255.255.252
    3. R2的IP 10.0.0.2 255.255.255.252
    4. 配置路由R1
      在这里插入图片描述
      Router>enable
      Router#conf t
      Router(config)#int g0/0(进入G0/0端口)
      Router(config-if)#no shutdown
      Router(config-if)#ip add 192.168.10.1 255.255.255.0 (配置G0/0端口的的IP地址)
      Router(config-if)#int g0/1
      Router(config-if)#no shutdown (开启端口)
      Router(config-if)#ip add 10.0.0.1 255.255.255.252
      Router(config)#route rip
      Router(config-router)#version 2
      Router(config-router)#network 192.168.10.0
      Router(config-router)#network 10.0.0.0
      Router(config-router)#no auto-summary
      Router(config-router)#ex
      在这里插入图片描述
      Router(config)#route rip (开启RIP协议)
      Router(config-router)#version 2 (启用RIPv2 )
      Router(config-router)#network 192.168.10.0 (宣告网段)
      Router(config-router)#network 10.0.0.0 (宣告网段)
      Router(config-router)#no auto-summary (关闭自动汇总)
      5.show ip route 查看路由信息
      6.配置R2
      在这里插入图片描述
      (全部同上)
      Router>en
      Router#conf t
      Router(config)#int g0/0
      Router(config-if)#no shutdown
      Router(config-if)#int g0/0
      Router(config-if)#ip add 192.168.20.1 255.255.255.0
      Router(config-if)#int g0/1
      Router(config-if)#no shutdown
      Router(config-if)#ip add 10.0.0.2 255.255.255.252
      Router(config-if)#ex
      Router(config)#route rip
      Router(config-router)#version 2
      Router(config-router)#ne
      Router(config-router)#network 192.168.20.0
      Router(config-router)#net
      Router(config-router)#network 10.0.0.2
      Router(config-router)#no au
      Router(config-router)#no auto-summary
      Router(config-router)#ex
      7.验证:PC
      在这里插入图片描述
    展开全文
  • Cisco 动态路由协议(RIP)的配置

    千次阅读 2021-06-20 21:49:22
    Cisco 动态路由协议(RIP)的配置 目录Cisco 动态路由协议(RIP)的配置1.线的连接2.Ip、封装等设置3.设置动态路由 1.线的连接 路由器间采用背对背的连接方式连接,一条DCE电缆和一条DTE电缆一组。 需要给路由器添加...

    Cisco 动态路由协议(RIP)的配置

    1.线的连接

    在这里插入图片描述

    • 路由器间采用背对背的连接方式连接,一条DCE电缆和一条DTE电缆一组。
    • 需要给路由器添加模块,再连接。
      模块:WIC-2T
      在这里插入图片描述
      路由间的线:serial DCE(串行DCE)
      在这里插入图片描述
      注意:路由需要手动开启

    2.Ip、封装等设置

    设置ip、对s端口进行ppp封装、配置时钟速率
    Bandwidth 命令设置将接口的带宽值与高级协议交流的信息参数

    • 对三个路由器分别执行以下操作(以此类推这里仅展示其中一个路由的配置):
    Router>en
    Router#conf t
    Router(config)#hostname cisco-2621
    Cisco-2621(config)#no logg on
    Cisco-2621(config)#int fa0/0
    Cisco-2621(config-if)#ip addr 172.16.1.10 255.255.255.0
    Cisco-2621(config-if)#no shut
    Cisco-2621(config-if)#int s0/0
    Cisco-2621(config-if)#ip addr 172.16.12.1 255.255.255.0
    Cisco-2621(config-if)#encapsulation ppp
    Cisco-2621(config-if)#clockrate 64000
    Cisco-2621(config-if)#bandwidth 64
    Cisco-2621(config-if)#no shut
    Cisco-2621(config-if)#int s0/1
    Cisco-2621(config-if)#ip addr 172.16.13.1 255.255.255.0
    Cisco-26201(config-if)#encapsulation ppp
    Cisco-2621(config-if)#clockrate 64000
    Cisco-2621(config-if)#bandwidth 64
    Cisco-2621(config-if)#no shut
    Cisco-2621(config-if)#exit
    Cisco-2621(config)#exit
    Cisco-2621#wr
    
    • 需要给PC设置网关 在这里插入图片描述

    注意:IP设置时,同根线上网段是一样的。

    3.设置动态路由

    • 这样设置后,三台PC还不能互相发送信息,还需要设置动态路由(以此类推这里仅展示其中一个路由的配置):
    Cisco-2621#config t
    Cisco-2621(config)#router rip
    Cisco-2621(config-router)#version 2
    Cisco-2621(config-router)#network 172.16.1.0
    Cisco-2621(config-router)#network 172.16.12.0
    Cisco-2621(config-router)#network 172.16.13.0
    Cisco-2621(config-router)#no auto-summary
    Cisco-2621(config-router)#end
    Cisco-2620#wr
    

    这样三台PC就可以互ping了。

    展开全文
  • 当所有的Router都连接在一起的时候,其中同一网段内是可以实现互相访问的,但是我们如何才能够让不同网段之间的路由也可以互相...那就是静态路由配置,可能有的朋友会问怎么不用动态路由协议呢?下面我们一起来看一下
  • 思科模拟器上怎么配置动态路由RIP?动态路由会自主选择最佳路径的,不像静态路由某个节点瘫痪了,整个网络就都瘫痪了,下面我们来看看思科模拟器上配置动态路由RIP的图文教程
  • 快速实现rip路由全网通

    Cisco:RIP路由协议配置实验

    目的:实现全网通



    拓扑图

    在这里插入图片描述
    配置过程:配置每一台PC机的IP地址,配置路由器相应的接口配置好对应的IP地址,配置路由协议,使得每一台主机之间可以进行通信(ping通)


    PC配置

    PC0

    在这里插入图片描述在这里插入图片描述
    相同的方式配置PC1,PC2,
    (在cmd命令界面使用ipconfig /all进行IP地址配置查看)
    在这里插入图片描述

    R0路由配置

    Router>enable
    Router#configure terminal
    Router(config)#interface g0/0/0  //进入接口
    Router(config-if)#ip address 10.1.1.1 255.255.255.0  //配置IP地址
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#interface g0/0/1
    Router(config-if)#ip address 192.168.1.1 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#route rip		//配置rip协议
    Router(config-router)#version 2	//版本为2(所有的版本都为2才会互相连通)
    Router(config-router)#network 10.1.1.0  //向外宣告有哪些主网络网段,此网段的所在接口将向外宣告RIP路由信息,并同时接收RIP更新信息
    Router(config-router)#network 192.168.1.0
    Router(config-router)#no auto-summary 
    Router(config-router)#end
    Router#show running-config //查看接口配置信息
    

    R1路由配置

    	R1的配置与R0的配置相差不多,注意IP地址的配置以及宣告的网段就行
    
    Router>enable
    Router#configure terminal
    Router(config)#interface g0/0/0  //进入接口
    Router(config-if)#ip address 10.1.2.1 255.255.255.0  //配置IP地址
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#interface g0/0/1
    Router(config-if)#ip address 192.168.1.2 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#route rip		//配置rip协议
    Router(config-router)#version 2	//版本为2(所有的版本都为2才会互相连通)
    Router(config-router)#network 10.1.2.0  //向外宣告有哪些主网络网段,此网段的所在接口将向外宣告RIP路由信息,并同时接收RIP更新信息
    Router(config-router)#network 192.168.1.0
    Router(config-router)#no auto-summary 
    Router(config-router)#end
    Router#show running-config //查看接口配置信息
    

    R2路由配置

    	R2的配置与R0的配置相差不多,注意IP地址的配置以及宣告的网段就行
    
    Router>enable
    Router#configure terminal
    Router(config)#interface g0/0/0  //进入接口
    Router(config-if)#ip address 192.168.1.3 255.255.255.0  //配置IP地址
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#interface g0/0/1
    Router(config-if)#ip address 192.168.2.1 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#route rip		//配置rip协议
    Router(config-router)#version 2	//版本为2(所有的版本都为2才会互相连通)
    Router(config-router)#network 192.168.2.0  //向外宣告有哪些主网络网段,此网段的所在接口将向外宣告RIP路由信息,并同时接收RIP更新信息
    Router(config-router)#network 192.168.1.0
    Router(config-router)#no auto-summary 
    Router(config-router)#end
    Router#show running-config //查看接口配置信息
    

    R3默认路由配置

    默认路由的主要作用:当存在末梢网络时,默认路由会大大简化路由器的配置,减轻管理员的工作负担,提高网络性能。默认路由是一种特殊的静态路由,指的是当路由表中与包的目的地址之间没有匹配的表项时路由器能够做出的选择,如果没有默认路由器,那么目的地址在路由表中没有匹配表项的包将被丢弃。主机里的默认路由通常被称作默认网关。默认网关通常会是一个有过滤功能的设备,如防火墙和代理服务器。

    Router>enable
    Router#configure terminal
    Router(config-if)#interface g0/0/0
    Router(config-if)#ip address 172.16.0.1 255.255.0.0
    Router(config-if)#no shutdown 
    Router(config-if)#exit
    Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1 //配置默认路由
    Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2
    Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.3
    Router(config)#end
    Router#show running-config //查看端口配置信息
    

    测试一下连通性,这里我们用PC0来ping各个接口

    1:PC0 ping 网关

    在这里插入图片描述

    2:PC0 ping 路由器0外接口g0/0/1

    在这里插入图片描述在这里插入图片描述

    3:PC0 ping 路由器1接口外接口g0/0/1

    在这里插入图片描述

    4:PC0 ping PC1

    在这里插入图片描述

    5:PC0 ping PC2

    在这里插入图片描述

    总结

    这里我们就已经实现了全网通,如果内容有所问题,请尽情的私信!下面是我们的文件链接。

    https://download.csdn.net/download/qq_45345433/85164649

    展开全文
  • 思科动态路由协议配置,如RIP OSPF
  • 基于思科网络仿真软件的实验报告,核心内容是验证路由信息协议,对于正在学习网络技术的人员有很大帮助
  • 2.掌握OSPF路由配置方法。 二、实验内容 1.安装CISCO模拟器; 2.对CISCO模拟器进行汉化; 3.画出网络拓扑图; 4.进行OSPF路由配置; 5.测试网络的通信效果。 三、实验材料与工具 1.电脑一台。 四、实验原理...
  • PC1 IP: 192.168.1.2 Submask: 255.255.255.0 Gateway: 192.168.1.1 PC2 IP: 192.168.2.2 Submask: 255.255.255.0 Gateway: 192.168.2.1 S3560 en conf t vlan 10 exit ...switchpo...
  • 路由信息协议(RIP) 是内部网关协议IGP中最先得到使用的协议。RIP是一种分布式的基于距离矢量的路由选择协议,是因特网的标准协议,其最大优点就是实现简单,开销较小。但RIP的缺点也较多。首先,其限制了网络的规模...
  • 思科路由配置路由协议重发布策略

    千次阅读 2020-03-15 14:56:22
    在大型的企业中,可能在同一网内使用到多种路由协议,为了实现多种路由协议的协同工作,路由器可以使用路由重分发(route redistribution)将其学习到的一种路由协议的路由通过另一种路由协议广播出去,这样网络的...
  • 网络Cisco实验-动态路由协议配置

    万次阅读 多人点赞 2017-12-10 19:33:31
    6.router0设置动态路由 Router(config)#route rip Router(config-router)#network 192.168.1.0 //路由器的端口连接的网络号(有几个就写几个) Router(config-router)#network 192.168.3.0 Router(config-...
  • RIP(routing information ...RIP路由协议配置 配置语法如下 Route(config)#router rip//启用RIP协议 Router(config-router)#network network-address//在指定的接口上启用RIP进程并通告直连路由 (network-addres
  • 思科OSPF路由配置

    2022-06-06 15:41:57
    思科OSPF路由配置
  • 拓扑图: 配置代码: R1 enable config terminal ...OSPF路由协议的进程号为100,一个路由器上可启用多个OSPF进程,以进程号作为区别标志 network 192.168.1.0 0.0.0.255 area 1 router-id 192.168.1.1 !这个路
  • CCNA-第七篇-思科私有路由协议-EIGRP 首先呢这个EIGRP之前呢, 路由协议是分几种的 一个叫距离向量协议RIP,IGRP(都过时了) 一个觉链路状态协议OSPF,IS-IS这些 还有个叫混合型的EIGRP 但是呢,这些只是书本上的定义,...
  • cisco pkt
  • CISCO实验教程之五IGRP动态路由协议配置 一路由表功能介绍 所谓路由表指的是路由器或者其他互联网网络设备上存储的表该表中存有到达特定网络终端的路径在某些情况下还有一些与这些路径相关的度量 路由器的主要工作...
  • 一、网络拓扑搭建 二、命令配置 命令配置都是大同小异,这里我们简单看一下和pc4连接的路由器是怎么配置的 ...R2(config)#router rip(进入rip协议配置) R2(config-router)#version 2 (启...
  • 思科网院第二阶段课程路由交换技术中文授课ppt,制作精良。。。。。。。
  • Cisco路由安全配置--路由协议.docx
  • 路由协议一般工作在OSI参考模型的传输层或者应用层,常见的路由协议有RIP、OSPF、BGP(Border Gateway Protocol,边界网关协议)等。 可路由协议:又称为被路由协议,指可以被路由器在不同逻辑网段间路由的协议。可...
  • 主要为大家介绍了Cisco网络协议中EIGRP向本区域下放默认路由的设置方法与步骤,EIGRP是加强型内部网关路由协议,需要的朋友可以参考下
  • Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco路由协议Cisco...
  • Cisco配置动态路由ospf

    千次阅读 2021-10-02 16:50:46
    文章目录1、拓扑图2、R1配置3、R2配置4、R3配置5、测试 1、拓扑图 2、R1配置 进入特权模式:Router>en 进入全局模式:Router#conf t 修改设备名称:Router(config)#hostname R1 进入接口:R1(config)#int g0/0 ...
  • 各厂商路由协议管理距离值,学习CISCO、HUAWEI网络技术必备资料。
  • 本次实验通过设置动态路由协议RIPv2,实现PC可经由路由器转发ping通不同网段的...主要步骤有建立网络拓扑、三层交换机的端口设置(创建VLAN、分配VLAN端口、配置网关IP/SM)、配置路由协议(三层交换机、路由器)。
  • 计算机网络实验-RIP路由协议配置

    千次阅读 2021-12-21 12:14:08
    计算机网络实验-RIP路由协议配置,完整实验报告,包含目的,实验原理

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 33,112
精华内容 13,244
关键字:

思科如何配置路由协议