精华内容
下载资源
问答
  • 思科CISCO常用命令汇总
    千次阅读
    2021-02-19 08:44:31

     

    视图模式介绍

     

      1.普通视图router> 

      2.特权视图router# / 在普通模式下输入enable

      3.全局视图router(config)#/ 在特权模式下输入configt

      4.接口视图router(config-if)#/在全局模式下输入int 接口名称例如int s0 或 int e0 

     5.路由协议视图router ( config-route ) #/ 在全局模式下输入router 动态路由协议名称

     

     

     

     

     

    1基本配置:

     

    1. router>enable         / 进入特权模式

    2. router#conft         / 进入全局配置模式

    3. router(config)#hostname  xxx   

     /设置设备名称就好像给我们的计算机起个名字

    4. router(config)#enable password xxx /设置特权口令

    5.  router(config)#no ip  domain  lookup  

    /不允许路由器缺省使用DNS解析命令 

    6. router(config)#Service password-encryption

    /对所有在路由器上输入的口令进行暗文加密 

    7. router(config)#line  vty  0  4       /进入设置telnet服务模式

     router(config-line)#password   xxx    /设置  telnet 的密码

     router(config-line)#login       /使能可以登陆

    8. router(config)#line  con  0     /进入控制口的服务模式

    router(config-line)#password xxx   /要设置  console 的密码        router(config-line)#login        /使能可以登陆

     

     

     

     

     

    2接口配置

     

    1. router(config)# int  s0

    /  进入接口配置模式serial 0 端口配置 (如果是模块化的路由器前面加上槽 位编号,例如serial0/0 代表这个路由器的0 槽位上的第一个接口)

    2.router(config-if)#ip add xxx.xxx.xxx.xxx   xxx.xxx.xxx.xxx

      / 添加  ip 地址和掩码

    3.router(config-if)#enca   hdlc

     /ppp捆绑链路协议hdlc 或者  ppp 思科缺省串口封装的链路层协议 是 HDLC 所以在  show  run 配置的时候接口上的配置没有,如果要封装为别的链路层协议例如PPP/FR/X25就是看到接口下的enca ppp 或者 enca fr 4.router(config)#int  loopback    

    /建立环回口(逻辑接口 )模拟不同的本机网段

    router(config-if)#ip  add  xxx.xxx.xxx.xxx   xxx.xxx.xxx.xxx

    /  添加ip  地址和掩码给环回口在物理接口 上配置了ip 地址后用no shut 启用这个物理接口反之可以用shutdown 管理性的关闭接口

     

     

    3路由配置

     

    1.静态路由

    router(config)#ip  route  xxx.xxx.xxx.xxx  xxx.xxx.xxx.xxx  下一跳或自己的接口

    2.缺省路由

    router(config)#ip route 0.0.0.0 0.0.0.0 s0添加缺省路由

    3.动态路由rip 协议

    router(config)#router  rip    /启动 rip 协议

    router(config-router)#network  xxx.xxx.xxx.xxx   /宣告自己的网段router(config-router)#version  2   /转 换为 rip2 版本

    router(config-router)#noauto-summary  

              /关闭自动汇总功能,ripV2才有作用

    router(config-router)#passive-in 接 口 名 

     / 启 动 本 路 由 器 的 那 个 接 口 为 被 动 接 口

    router(config-router)#neixxx.xxx.xxx.xxx/广播转单播报文,指定邻居的接 ip

    4.动态路由eigrp 协议

    router(config)#router eigrp  xxx    /启动  eigrp 协议

    router(config-router)#network  xxx.xxx.xxx.xxx   /宣告自己的网段

    router(config-router)#variance   xxx     /调整倍数因子,使用不等价的负载均衡eigrp 协议

    router(config-router)#noauto-summary  /关闭自动汇总功能ospf 协议

    5.动态路由ospf协议

    router(config)router  ospf  xxx  /启动协议

    router(config-router)network xxx.xxx.xxx.xxx  xxx.xxx.xxx.xxx(反掩码)area   xxx

    / 宣告自己的接口 或网段在ospf 的区域中可以把不同接口宣告在不同区域中

     

     

    4保存当前修改/运行的配置:

     

    1.router#write

    /将 RAM 中的当前配置存储到NVRAM 中,下次路由器启动就是执行保存的配置

    2.router#Copy   running-config    startup-config   

     /命令与write 效果一样

     

     

     

    5一般常用命令

     

    1.exit命令

    router(config-if)#exit

    router(config)# router

    (config-router)#exit

    router(config)#

    router(config-line)#exit

    router(config)# router

    (config)#exit

    router#

    exit 命令 / 从接口、协议、line 等视图模式下退回到全局配置模式,或从全局配置模式退回到特权模式

    2.end命令

    router(config-if)#end 

    router(config-router)#end

    router(config-line)#end

    router#

    end 命令 / 从任何视图直接回到特权模式

    3.logout

    router#Logout

    / 退出当前路由器登陆模式相对与windows 的注销

    4.reload命令

    router#reload

    /  重新启动路由器 (热启动)冷启动就是关闭路由器再打开电源开关

    5.show 命令

    特权模式下:router#show ip route

    /查看当前的路由表router#cleariproute*/清楚当前的路由表 

    router#show ip protocol

    /查看当前路由器运行的动态路由协议情况

    router#show ip int brief

    /查看 当前的路由器的接口ip地址启用情况

    router#show running-config

    /查看当前运行配置 

    router#show startup-config

    /查看启动配置

    router#debug ip pack

    /  打开  ip 报文的调试 

    router#terminal  monitor

    /  输出到终端上显示调试信息

    router#show ip eigrp neighbors

    /查看 eigrp 协议的邻居表

    router#show ip eigrp topology

    /查看 eigrp 协议 的拓朴表

    router#show ip eigrp interface

    /查  看当然路由器运行eigrp协议的  接口情况

    router#show ip ospf neighbor

    /查看当前路由器的ospf 协议的邻居表

    router#show ip ospf interface

    /查看当然路由器运行ospf协议的接口情况

    router#clear ip ospf process

    /  清楚当然路由器ospf 协议的进程

    router#Show interfaces

    /  显示设置在路由器和访问服务器上所有接口的统计信息. 显示路由器 上配置的所有接口的状态

    router#Show interfaces serial

    /  显示关于一个串口的信息

    router#Show ip interface

    /列出一个接口的IP 信息和状态的小结,列出接口的状态和全局参数

     

     

    更多相关内容
  • 喜欢网络,励志成为网络达人
  • 原标题:软考网络工程师华为、思科指令大全华为命令大全一、配置交换机的名称和密文密码: //用户视图system-view //进入系统视图配置[Huawei] //系统视图[Huawei]quit 或 return //退出系统视图模式[Huawei]sysname...

    原标题:软考网络工程师华为、思科指令大全

    华为命令大全

    一、配置交换机的名称和密文密码:

    //用户视图

    system-view //进入系统视图配置

    [Huawei] //系统视图

    [Huawei]quit 或 return //退出系统视图模式

    [Huawei]sysname DTWLXY //设置主机名

    [Huawei]user-interface console 0 //进入控制台

    [Huawei-ui-console0]authentication-mode password

    [Huawei-ui-console0]set authentication password cipher huawei //配置密文密码

    二、配置交换机 VLAN 相关命令:

    [Huawei]vlan 10 或 [Huawei]vlan 20 //创建 VLAN

    [Huawei-vlan10]deion dtwlxy //VLAN 描述

    [Huawei]vlan batch 30 40 //创建多个 VLAN

    [Huawei]int g0/0/1 //进入接口

    [Huawei-g0/0/1]port link-type access //访问口

    [Huawei-g0/0/1]port default vlan 10 //加入 VLAN

    [Huawei-g0/0/2]port link-type trunk //干道口

    [Huawei-g0/0/2]port trunk allow-pass vlan 10 20 允许

    [Huawei-g0/0/2]port trunk allow-pass vlan all //所有

    [Huawei]int e0/0/2 //进入接口

    [Huawei-E0/0/2]port link-type hybrid //混合口模式

    [Huawei-E0/0/2]undo port default vlan //删除默认 vlan

    [Huawei-E0/0/2]port hybrid untagged vlan 20//去标签

    [Huawei-E0/0/2]port hybrid pvid vlan 2//设置默认 vlan

    [Huawei-E0/0/2]port trunk allow-pass vlan 10 to 100

    [Huawei]dis port vlan //查看 vlan

    [Huawei]display vlan //查看 vlan

    三、配置交换机 VLAN 一致性 GVRP:

    Normal 模式:(类似 cisco 交换机服务器模式)

    [Huawei]gvrp //开启 gvrp 也是默认模式

    Fixed 模式:(类似 cisco 交换机客户机模式)

    [Huawei-g0/0/2]gvrp registration fixed

    Forbidden 模式:(类似 cisco 交换机透明模式)

    [Huawei-g0/0/3]gvrp registration forbidden

    dis vlan summary //查看 vlan 汇总

    dis gvrp status //查看 gvrp 状态 1

    四、配置路由器 RIP 协议:RIPv1 RIPv2

    [Huawei]rip //启用 RIP 默认 v1

    [Huawei-rip-1]network 192.168.1.0 //发布直连网段

    [Huawei-rip-1]version 2 //配置 v2 版本

    [Huawei]dis rip //查看 rip

    [Huawei]dis rip database //查看 rip 数据库

    [Huawei]dis ip routing-table //查看路由表

    五、配置静态路由

    [Huawei]ip route-static 192.168.50.0 24 10.0.12.2

    [Huawei]ip route-static 192.168.10.0 24 serial 0/0/1

    [Huawei]ip route-static 0.0.0.0 0 192.168.2.1 //默认

    [Huawei]dispaly ip routing-table //查看路由表

    六、配置路由器 OSPF 协议:

    [Huawei]ospf 1 //启用 OSPF 默认是进程 1

    [Huawei-ospf-1]area 0 //进入区域 0

    [Huawei-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255 //发布直连网段

    [Huawei-ospf-1]silent-interface g0/0/2 //被动接口

    [Huawei]dis ospf interface //查看 ospf 通告

    [Huawei]dis ospf peer //查看 ospf 邻居

    [Huawei]dis ip routing-table //查看路由表

    [Huawei]dis ospf routing //查看 ospf 路由表

    七、配置基于全局的 DHCP 协议:

    [Huawei]dhcp enable //开启 dhcp

    [Huawei]ip pool dtwlxy //地址池名

    [Huawei-ip-pool-dtwlxy]network 192.168.1.0 //地址池

    [Huawei-ip-pool-dtwlxy]lease day 2 //租约默认 1

    [Huawei-ip-pool-dtwlxy]gateway-list 192.168.1.254 //网关

    [Huawei-ip-pool-dtwlxy]excluded-ip-address192.168.1.250 192.168.1.253 //排除 IP 范围

    [Huawei-ip-pool-dtwlxy]dns-list 8.8.8.8 //DNS 服务器

    [Huawei-G0/0/0]dhcp select global //基于全局

    八、配置基于接口的 DHCP 协议:

    [Huawei]dhcp enable //开启 dhcp

    [Huawei]int g0/0/1 //进入接口

    [Huawei-G0/0/1]dhcp select interface //基于接口

    [Huawei-G0/0/1]dhcp server lease day 2 //租约默认 1

    [Huawei-G0/0/1]dhcp serverexcluded-ip-address 192.168.1.1 192.168.1.10 //排除 IP 范围

    [Huawei-G0/0/1]dhcp server dns-list 8.8.8.8 //DNS

    [Huawei]dis ip pool //查看 dhcp

    九、配置路由器基本 ACL:2000-2999

    [Huawei]acl 2000 //配置基本 acl

    [Huawei-acl-basic-2000]rule 5 permit source 1.1.1.1 0 //允许源 IP(注意反掩码 0,默认步长 5)

    [Huawei-acl-basic-2000]rule 10 deny any //拒绝任意

    [Huawei]user-interface vty 0 4 //进入接口

    [Huawei-ui-vty0-4]acl 2000 inbound //应用 acl

    [Huawei]dis acl all //查看所有 acl

    [Huawei]dis acl 2000 //查看 acl 2000

    十、配置路由器高级 ACL:3000-3999

    [Huawei]acl 3000 //配置高级 acl

    [Huawei-acl-adv-3000]rule permit ip source 1.1.1.1 0 destination 4.4.4.4 0 //允许访问

    [Huawei]user-interface vty 0 4 //进入虚拟接口

    [Huawei-ui-vty0-4]acl 3000 outbound //应用 acl

    [Huawei]int g0/0/1 //进入接口

    [Huawei-G0/0/1]traffic-filter inbound acl 3000 //应用

    [Huawei]dis acl all //查看所有 acl

    十一、静态 NAT 配置:

    system-view

    [huawei]interface Ethernet 0/0/1 //进入端口视图

    [huawei-Ethernet0/0/1]ip address 192.1.1.1 30 //设置端口 IP 地址,网络号 30 位

    [huawei-Ethernet0/0/1]nat static global 192.1.1.2 inside 10.1.1.2 //静态 NAT 映射,私有地址 10.1.1.2和公有地址 192.1.1.2 建立映射关系动态 NAT 配置:

    [huawei]nat address-group 1 192.1.1.2 192.1.1.4 //定义公有地址池

    [huawei]acl 2000

    [huawei-acl-basic-2000]rule permit source 10.1.1.0 0.0.0.255

    [huawei-acl-basic-2000]quit

    [huawei]interface Ethernet 0/0/1

    [huawei-Ethernet0/0/1]nat outbound 2000 address-group 1 //实现 ACL2000 中定义的 IP 可以与地址池中的地址进行 NAT 转换,这里默认配置的是 NAPT,是多对一的关系,要配置 Basic NAT,则需要加选项no-pat

    十二、配置三层交换机 VLAN 间路由:首先基本配置,IP、VLAN 等。

    [Huawei]int vlanif 10 //进入接口

    [Huawei-Vlanif10]ip add 192.168.1.254 24 //配 IP

    [Huawei]int vlanif 20 //进入接口

    [Huawei-Vlanif20]ip add 192.168.2.254 24 //配 IP

    [Huawei]dis ip interface brief //接口简略信息

    [Huawei]dis port vlan //接口 vlan 信息

    [Huawei]dis vlan //查看 vlan 信息

    十三、配置单臂路由 VLAN 间通信:首先基本配置,IP、VLAN 等。

    [Huawei-G0/0/1.1]ip add 192.168.1.254 24 //配置 IP

    [Huawei-G0/0/1.1]dot1q termination vid 10 //封装

    [Huawei-G0/0/1.1]arp broadcast enable //开启 arp

    [Huawei]dis ip interface brief //查看接口

    [Huawei]dis ip routing-table //查看路由表

    [Huawei]display current-configuration //查看配置

    十四、配置交换机的远程管理 IP 地址:

    [Huawei]interface Vlanif 1 //进入 VLAN1

    [Huawei-Vlanif1]ip add 192.168.1.254 24 //配置 IP

    [Huawei-Vlanif1]undo shutdown //开启接口

    [Huawei]dns domain dtwlxy.com //设置域名

    [Huawei]dns server 192.168.254.254 //设置域名 IP dis vlan 显示 vlan save 保存配置

    dis curr 显示当前配置 reboot 重启设备

    undo terminal monitor //取消提示信息

    十五、配置交换机端口速率、双工、ARP:

    [Huawei]int g0/0/1 //进入接口

    [Huawei-g0/0/1]deion dtwlxy //端口描述

    [Huawei-g0/0/1]undo negotiation auto //取消协商

    [Huawei-GigabitEthernet0/0/1]duplex full //全双工

    [Huawei-GigabitEthernet0/0/1]auto duplex full //自动

    [Huawei-GigabitEthernet0/0/1]speed 10 //速率 10M

    [Huawei-GigabitEthernet0/0/1]auto speed 100 //自动

    [Huawei]arp static 192.168.1.8 5489-98cf-2603//绑定

    [Huawei]dis arp [Huawei]dis arp all //查看 ARP11

    十六、配置路由器接口 IP:

    [Huawei]int g0/0/1 //进入接口

    [Huawei-g0/0/1]ip add 192.168.1.6 24 //配 IP 地址

    [Huawei-GigabitEthernet0/0/1]undo shutdown //开启

    dis cur 或 [Huawei]dis cur //查看 ARP

    思科命令大全

    一、常规配置

    1.创建 VLAN:S1(config)#vlan 100

    2.给 VLAN 命名:S1(config-vlan)#name vlan100

    3.删除 VLAN:S1(config)#no vlan 100

    4.分配端口到 VLAN 中:S1(config)#interface f0/1

    S1(config-if)#switchport access vlan 100

    5.VLAN TRAN 的配置:

    S1(config)#interface f0/2

    S1(config-if)#switchport mode trunk //设置端口为 trunk 端口

    S1(config-if)#switchport trunk allowed vlan100,2 //允许 vlan 100 和 vlan 2 通过

    S1(config-if)# switchport trunk

    二、路由器的基本配置

    1.从用户模式进入特权模式:R1>enable

    2.从特权模式进入全局配置模式:R1#configure terminal

    3.设置主机名:R1(config)#hostname R1

    4. 退出到特权模式:R1(config)#end

    5.退出到用户模式:R1#disable

    6.退出控制台线路:R1>quit

    7.通过 console 进入控制台口线路:R1(config)#line console {number}

    8.显示路由器的当前时间:R1#show clock

    9.进入接口配置模式:R1(config)#interface {type} {number}

    10.显示某个接口的配置信息:

    R1#show running-config interface {type}{number}

    11. 设置特权模式进入密码

    R1(config)#enable password {password} //该密码是基于明文的(通过 show running-config 可见)

    R1(config)#enable secret {password} // 该密码是基于 MD5 加密的

    注:密码是区分大小写的;如果同时设置了两种认证密码,只用后者生效

    12.进入控制台口线路

    R1(config)#line console {number} //通过 console 线方式进入控制台

    R1(config)#line aux {number} //通过辅助接口(AUX)线路进入控制台

    R1(config)#line vty {start-number}{end-number} //通过虚拟终端线路(VTY)进入控制台

    注:虚拟终端线路(VTY)是为 telnet 会话所用

    13.设置控制台端口的密码

    R1(config-line)#password {password}

    注:这里的登录密码是明文方式保存在 DRAM(running-config)文件中

    R1(config-line)#login //启动登陆

    14.关闭 DNS 查询功能:R1(config)#no ip domain lookup

    注:默认情况下,路由器的 DNS 查询是启用的,当输入一条 Cisco IOS 无法识别的命令时,路由器会把这个命令当成主机名,然后向 DNS 服务器进行查询。

    15.ping 测试:R1#ping {ip-address}

    16.telnet 测试:R1#telnet {ip-address}

    注:在 telnet 到远端路由器的时候,如果对方的 VTY 线路没有设置密码和启动登陆,将拒绝本地路由器 telnet。

    解决方案:在远端路由器设置 VTY 线路的密码和启动登陆,如下配置:

    R1(config)#line vty {start-num} {end-number} //进入 VTY 线路

    R1(config-line)#password {password} //设置密码

    R1(config-line)#login // 启动登陆

    R1(config-line)#end // 退出 VTY 线路

    17.创建静态的 IP 地址到主机名的映射

    R1(config)#ip host {hostname} {ip-address}

    三、静态路由配置

    1.配置静态路由

    R1(config)#iproute {network} {mask} {next-hop-address|exit-interface} [distance] network:目标网络号

    mask:目标网络的子网掩码

    next-hop-address:下一跳地址

    exit-interfac:下一跳路由器的接口

    注:选择下一跳地址和选择下一调路由器的接口作为目标网络的出口的区别在于管理距离。选择前者,管理距离为 1;选择后者,管理距离为 0。还可以在定义静态路由的时候指定管理距离。

    2.配置默认路由

    R1(config)#iproute 0.0.0.0 0.0.0.0 {next-hop-address|exit-interface}[distance] next-hop-address:下一跳地址

    exit-interfac:下一跳路由器的接口

    注:0.0.0.0 0.0.0.0 代表所有的网络。选择下一跳地址和选择下一调路由器的接口作为目标网络的出口的区别在于管理距离。选择前者,管理距离为 1;选择后者,管理距离为 0。还可以在定义静态路由的时候指定管理距离。

    3.显示静态路由的配置

    R1#showip route static

    RIP(距离矢量路由协议)基本设置

    三、配置 RIP

    1.启动 RIP:R1(config)#routerip

    2.定义要宣告的直连主类网络号

    R1(config-route)#network{network-number}

    注:启动了 RIP 路由协议之后,只需要宣告主类直连网络号,即可完成 RIP 的配置

    3.查看 RIP 信息:R1#showip route rip

    四、OSPF(链路状态路由协议)基本配置

    配置单区域 OSPF

    1.启动 OSPF 进程:

    R1(config)#routeospf {process-id}

    注:OSPF 进程 ID 可以使用 1 到 65535 中的任意一个整数,该 ID 只是本地的一个标识,即一个 OSPF网络,每台 OSPF 路由器的进程 ID 是否一样,和 OSPF 网络能否正常运行无关。

    2.定义参与 OSPF 进程的接口和网络

    R1(config-route)#network{ip-address} {wildcard-mask} area {area-id}

    ip-address:直连网络地址

    wildcard-mask:直连网络的反掩码

    area-id:区域号

    注:在定义 OSPF 路由器要宣告的区域时,反掩码用来控制要宣告的范围,0 表示精确匹配,255 表示任意匹配。OSPF 网络中骨干区域为区域 0,因此必须有区域 0。

    3.查看 OSPF 信息

    R1#showip route ospf // 查看所有的 OSPF 信息

    R1#showip route ospf 1 //查看进程 ID 为 1 的 OSPF 信息

    R1#showip ospf database //查看 OSPF 链路状态数据库的信息

    R1#showip ospf neighbor // 显示一个邻居列表,

    4.配置多区域 OSPF

    1.启动 OSPF 进程

    R1`(config)#routeospf {process-id}

    注:OSPF 进程 ID 可以使用 1 到 65535 中的任意一个整数,该 ID 只是本地的一个标识,即一个 OSPF网络,每台 OSPF 路由器的进程 ID 是否一样,和 OSPF 网络能否正常运行无关。

    2.定义参与 OSPF 进程的接口和网络

    R1(config-route)#network{ip-address} {wildcard-mask} area {area-id}

    ip-address:直连网络地址

    wildcard-mask:直连网络的反掩码

    area-id:区域号

    注:在定义 OSPF 路由器要宣告的区域时,反掩码用来控制要宣告的范围,0 表示精确匹配,255 表示任意匹配。OSPF 网络中骨干区域为区域 0,因此必须有区域 0。多区域的设计,才是 OSPF 网络的精髓。

    3.查看 OSPF 信息

    R1#showip route ospf // 查看所有的 OSPF 信息

    R1#showip route ospf 1 //查看进程 ID 为 1 的 OSPF 信息

    R1#showip ospf database //查看 OSPF 链路状态数据库的信息

    R1#showip ospf neighbor // 显示一个邻居列表

    五、EIGRP(混合型路由协议) 基本配置

    配置 EIGRP

    1.定义自制系统(AS)号并启用 EIGRP

    R1(config)#routeeigrp {AS-number}

    2.宣告直连主类网络号

    R1(config-route)#network{network-number}

    注:EIGRP 做为 IGRP 的扩展,它同时集合了距离矢量和链路状态路由协议的特色,参与同一 EIGRP进程的 EIGRP 路由器必须处于相同的 AS 里,接下来只需要宣告直连的主类网络号即可。

    3.查看 EIGRP 信息

    R1#showip eigrp neighbors

    R1#showip route eigrp

    五、关闭 EIGRP 的自动汇总

    1.定义自制系统(AS)号并启用 EIGRP

    R1(config)#routeeigrp {AS-number}

    2.宣告直连主类网络号

    R1(config-route)#network{network-number}

    注:EIGRP 做为 IGRP 的扩展,它同时集合了距离矢量和链路状态路由协议的特色,参与同一 EIGRP进程的 EIGRP 路由器必须处于相同的 AS 里,接下来只需要宣告直连的主类网络号即可。

    3.关闭自动汇总

    R1(config-route)#noauto-summary

    注:当路由更新主类网络边界的时候,他会自动向主类网络号进行汇总,路由自动汇总特性是 EIGRP默认的操作。EIGRP 可以关闭该特性。

    4.查看 EIGRP 信息

    R1#showip eigrp neighbors

    R1#showip route eigrp

    六、交换机基础配置

    1.从用户模式进入特权模式:S1>enable

    2.从特权模式进入全局配置模式:S1#configure terminal

    3.设置主机名:S1(config)#hostnameR1

    4. 退出到特权模式:S1(config)#end

    5.退出到用户模式:S1#disable

    6.查看 MAC 地址表:S1#show mac-address-table

    7.开启 http 服务(部分交换机可用):S1(onfig)#ip http server

    8.配置超级用户口令

    S1(config)#enable password 123456 //不加密密码

    S1(config)#enable password 7 123456 //加密密码(7 是选择的加密方式)

    S1(config)#enable secret 123456 //加密密码

    S1(config)#enable secret 5 123456 //加密密码(5 是选择的加密方式)

    9.显示路由器的当前时间:R1#show clock

    10.设置系统时间(部分可用)

    S1(config)#clock set hh:mm:ss day month year

    S1(config)#clock set 12:00:00 28 August 2013

    11.配置设备管理 IP 地址

    S1(config)#interface VLAN1

    S1(config-if)#ip address 192.168.1.1255.255.255.0

    S1(config-ip)#exit

    注:VLAN 1 是用于设备管理的默认 VLAN

    12.配置默认路由

    S1(config)#ip default-gateway 192.168.1.254

    备考软考可关注微信小程序【软考备考学习助手】

    责任编辑:

    展开全文
  • cisco 指令參考

    2013-01-21 17:56:22
    cisco 交換機,路由器常用的指令參考
  • Cisco思科常用指令

    2021-03-07 20:33:19
    常用指令

    前言

    文章的内容是博主在学习的过程中总结的,有错误的话敬请指出。

    一、模式介绍

    不同的指令,需要在特定的模式下才能执行。
    下方的Router是设备名

    模式前缀
    用户模式Router>
    特权模式Router#
    全局配置模式Router(config)#
    接口模式Router(config-if)#
    Line模式Router(config-line)#

    在这里插入图片描述

    二、常用指令

    以下指令省略前面的前缀名。

    [1]. 用户模式

    指令介绍
    enable进入特权执行模式

    [2]. 特权模式

    指令介绍
    exit或disable退回用户模式
    config terminal进入全局配置模式
    show ip route查看路由表
    copy running-config startup-config保存路由器配置

    [3]. 全局配置模式

    指令介绍
    exit或end退回特权模式
    interface [接口类型] [接口]进入对应接口的接口模式
    hostname [名称]设置路由器名称
    no ip domain-lookup禁用DNS查找
    enable password [密码]配置进入特权模式的口令
    enable secret [密码]配置进入特权模式的加密口令
    no enable password删除进入特权模式的口令
    line vty 0 4进入Line模式,0和4表示着5条不同的vty(Virtual Teletype Terminal)线路,最多支持同时5个用户登录设备

    [4]. 接口模式

    指令介绍
    exit退回全局配置模式
    ip address [IP地址] [子网掩码]设置接口的IP地址
    not shutdown激活该接口
    description [描述]设置接口的描述

    [5]. Line模式

    指令介绍
    password [密码]设置远程登录路由器的密码
    展开全文
  • CISCO路由器中的access-list(访问列表)最基本的有两种,分别是标准访问列表和扩展访问列表,二者的区别主要是前者是基于目标地址的数据包过滤,而后者是基于目标地址、源地址和网络协议及其端口的数据包过滤
  • 思科路由指令汇总

    2014-06-02 16:58:20
    思科路由指令汇总
  • 思科设备命令大全

    2021-12-14 21:12:48
    configure terminal 进入配置模式 interface g0/0 进入千兆以太网接口模式 ip address 172.16.0.1 255.255.0.0 配置接口的ip 地址 no shutdown 打开接口 line vty 0 4 进入虚拟终端vty 0 - vty 4 password CISCO ...

    模式转换命令

    • 用户模式----特权模式,使用命令"enable"

    • 特权模式----全局配置模式,使用命令"config t"

    • 全局配置模式----接口模式,使用命令"interface+接口类型+接口号"

    • 全局配置模式----线控模式,使用命令"line+接口类型+接口号"

    注:

    • 用户模式:查看初始化的信息.

    • 特权模式:查看所有信息、调试、保存配置信息

    • 全局模式:配置所有信息、针对整个路由器或交换机的所有接口

    • 接口模式:针对某一个接口的配置

    • 线控模式:对路由器进行控制的接口配置

     基本配置命令

    命令描述
    enable从用户模式进入特权模式
    configure terminal进入配置模式
    interface g0/0进入千兆以太网接口模式
    ip address 172.16.0.1 255.255.0.0配置接口的ip 地址
    no shutdown打开接口
    line vty 0 4进入虚拟终端vty 0 - vty 4
    password CISCO配置密码
    login用户要进入路由器,需要先进行登录
    exit退回到上一级模式
    enable password CISCO配置进入特权模式的密码,密码不加密
    end直接回到特权模式
    show int g0/0显示g0/0 接口的信息
    hostname Terminal-Server配置路由器的主机名
    enable secret ccielab配置进入特权模式的密码,密码加密
    no ip domain-lookup路由器不使用DNS 服务器解析主机的IP 地址
    logging synchronous路由器上的提示信息进行同步,防止信息干扰我们输入命令
    no ip routing关闭路由器的路由功能
    ip default-gateway 10.1.14.254配置路由器访问其他网段时所需的网关
    show line显示各线路的状态
    line 33 48进入33-48 线路模式
    transport input all允许所有协议进入线路
    int loopback0进入loopback0 接口
    ip host R1 2033 1.1.1.1为1.1.1.1 主机起一个主机名
    alias exec cr1 clear line 33为命令起一个别名
    privilege exec level 0 clear line把命令clear line 的等级改为0,在用户模式下也可以执行它
    banner motd设置用户登录路由器时的提示信
    clock set设置路由器的时间
    show clock显示路由器的时间
    show history显示历史命令
    terminal no editing关闭CLI 的编辑功能
    terminal editing打开CLI 的编辑功能
    terminal history size 50修改历史命令缓冲区的大小
    copy running-config startup-config把内存中的配置文件保存到NVRAM 中
    clock rate 128000配置串口上的时钟(DCE 端)
    show version显示路由器的IOS 版本等信息
    show running-config显示内存中的配置文件
    show startup-config显示NVRAM 中的配置文件
    show interface s0/0/0显示接口的信息
    show flash显示flash 的有关信息
    show controllers s0/0/0显示s0/0/0 的控制器信息
    show ip arp显示路由器中的arp 表
    copy running-config tftp把内存中的配置文件拷贝到tftp 服务器上
    copy tftp running-config把tftp 服务器上的配置文件拷贝到内存中
    copy flash:c2800nm-adventerprisek9-mz.124-11.T1.bin tftp把flash 中的IOS 拷贝到tftp 服务器上
    confreg 0x2142在rommon 模式下修改配置寄存器值
    i在rommon 模式下重启路由器
    copy startup-config running-config把NVRAM 中的配置文件拷贝到内存中
    config-register 0x2102修改配置寄存器值
    reload重启路由器
    delete flash:c2800nm-adventerprisek9-mz.124-11.T1.bin删除flash 中的IOS
    copy tftp flash从tftp 服务器上拷贝IOS 到flash 中
    tftpdnldrommon 模式下,从tftp 服务器下载IOS
    show cdp显示CDP 运行信息
    show cdp interface显示CDP 在各接口的运行情况
    show cdp neighbors显示CDP 邻居信息
    show cdp entry R2显示CDP 邻居R2 的详细信息
    clear cdp table清除CDP 邻居表
    no cdp enable接口下关闭CDP
    no cdp run/ cdp run关闭/打开整个路由器的CDP
    cdp timer 30 CDP每30 秒发送一次
    cdp holdtime 120让邻居为本设备发送的CDP 消息保持120 秒

    静态路由相关配置

    命令描述
    ip route X.X.X.X 掩码 接口或者下一条ip地址配置静态路由
    show ip route查看路由表
    ip classless/ no ip classless打开/关闭有类路由功能
    ping 2.2.2.2 source loopback 0指定源端口进行ping 测试

     

    RIP命令汇总

    命令描述
    show ip route查看路由表
    show ip protocols查看IP 路由协议配置和统计信息
    show ip rip database查看RIP 数据库
    debug ip rip动态查看RIP 的更新过程
    clear ip route *清除路由表
    router rip启动RIP 进程
    network通告网络
    version定义RIP 的版本
    no auto-summary关闭自动汇总
    ip rip send version配置RIP 发送的版本
    ip rip receive version配置RIP 接收的版本
    passive-interface配置被动接口
    neighbor配置单播更新的目标
    ip summary-address rip配置RIP 手工汇总
    key chain定义钥匙链
    key key-id配置Key ID
    key-string配置Key ID 的密匙
    ip rip triggered配置触发更新
    ip rip authentication mode配置认证模式
    ip rip authentication key-chain配置认证使用的钥匙链
    timers basic配置更新的计时器
    maximum-paths配置等价路径的最大值
    ip default-network向网络中注入默认路由

    EIGRP相关配置命令

    命令描述
    show ip eigrp neighbors查看EIGRP 邻居表
    show ip eigrp topology查看EIGRP 拓扑结构数据库
    show ip eigrp interface查看运行EIGRP 路由协议的接口的状况
    show ip eigrp traffic查看EIGRP 发送和接收到的数据包的统计情况
    debug eigrp neighbors查看EIGRP 动态建立邻居关系的情况
    debug eigrp packets显示发送和接收的EIGRP 数据包
    ip hello-interval eigrp配置EIGRP 的HELLO 发送周期
    ip hold-time eigrp配置EIGRP 的HELLO hold 时间
    router eigrp XX启动EIGRP 路由进程
    no auto-summary关闭自动汇总
    ip authentication mode eigrp配置EIGRP 的认证模式
    ip authentication key-chain eigrp在接口上调用钥匙链
    variance配置非等价负载均衡
    delay配置接口下的延迟
    bandwidth配置接口下的带宽
    ip summary-address eigrp手工路由汇总

    OSPF相关配置命令

    命令描述
    show ip route查看路由表
    show ip ospf neighbor查看OSPF 邻居的基本信息
    show ip ospf database查看OSPF 拓扑结构数据库
    show ip ospf interface查看OSPF 路由器接口的信息
    show ip ospf查看OSPF 进程及其细节
    debug ip ospf adj显示OSPF 邻接关系创建或中断的过程
    debug ip ospf events显示OSPF 发生的事件
    debug ip ospf packet显示路由器收到的所有的OSPF 数据包
    router ospf启动OSPF路由进程
    router-id配置路由器ID
    network通告网络及网络所在的区域
    ip ospf network配置接口网络类型
    ip ospf cost配置接口cost 值
    ip ospf hello-interval配置hello 间隔
    ip ospf dead-interval配置OSPF 邻居的死亡时间
    ip ospf priority配置接口优先级
    auto-cost reference-bandwidth配置参考带宽
    clear ip ospf process清除OSPF 进程
    area area-id authentication启动区域简单口令认证
    ip ospf authentication-key  cisco配置认证密码
    area area-id authentication message-digest启动区域MD5 认证
    area area-id range区域间路由汇总
    area area-id stub把某区域配置成末节区域
    area area-id stub no-summary把某区域配置成完全末节区域
    area area-id nssa把某区域配置成NSSA 区域
    area area-id virtual-link配置虚链路
    ip ospf message-digest-key key-id md5 key配置key ID 及密匙
    ip ospf authentication启用链路简单口令认证
    ip ospf authentication message-digest启用链路MD5 认证
    default-information originate 向OSPF区域注入默认路由
    show ip route查看路由表
    show ip ospf neighbor查看OSPF 邻居的基本信息
    show ip ospf database查看OSPF 拓扑结构数据库
    show ip ospf interface查看OSPF 路由器接口的信息
    show ip ospf查看OSPF 进程及其细节
    show ip ospf database router查看类型1 的LSA 的全部信息
    redistribute路由协议重分布
    summary-address外部路由汇总
    encapsulation frame-relay接口封装帧中继
    no frame-relay inverse-arp关闭帧中继逆向ARP 解析
    frame-relay interface-dlci帧中继映射
    frame-relay map ip帧中继映射

    IS-IS基本配置命令

    命令描述
    show clns neighbors查看CLNS 邻居
    show clns protocols查看CLNS 路由协议相关的信息
    show clns interface查看CLNS 接口状态的信息
    show clns route查看CLNS L2 路由
    clear clns route清除CLNS 路由表
    clear isis *清除IS-IS 链路状态数据库
    show clns traffic查看CLNS 协议的统计信息
    show isis hostname查看主机名和系统ID 的动态对应关系
    show isis database查看IS-IS 链路状态数据库
    show isis topology查看IS-IS 拓扑结构信息
    show isis route查看CLNS L1 的路由表
    show frame-relay map查看帧中继映射
    show ip protocols查看和IP 路由协议相关的信息
    router isis启动IS-IS 路由进程
    net配置NET 地址
    ip router isis接口下启用IS-IS
    is-type配置IS-IS 路由器类型
    area-password配置区域认证
    isis password配置邻居认证
    domain-password domain配置域认证
    default-information originate向IS-IS 网络注入默认路由
    summary-address配置区域间路由汇总
    isis circuit-type配置接口电路类型
    frame-relay map clns配置CLNS 映射

    BGP基本配置命令

    命令描述
    show tcp brief查看TCP 连接信息摘要
    show ip bgp neighbors查看邻居的TCP 和BGP 连接的详细信息
    show ip bgp summary查看BGP 连接的摘要信
    show ip bgp查看BGP 表的信息
    show ip bgp community查看BGP 团体属性
    clear ip bgp *重置BGP 连接
    router bgp启动BGP 进程
    no synchronization关闭同步
    synchronization打开同步
    bgp router-id配置BGP 路由器ID
    neighbor ip-address remote-as配置邻居路由器及所在的AS
    neighbor ip-address update-source指定更新源
    neighbor ip-address next-hop-self配置下一跳自我
    route-reflector-client配置RR 客户端
    network通告网络
    aggregate-address配置地址聚合
    ip prefix-list配置前缀列表
    set origin egp设置起源代码为EGP
    set as-path prepend配置追加AS-PATH
    set local-preference设置本地优先级属性值
    bgp default local-preference设置默认本地优先级属性值
    bgp confederation identifier配置联邦ID
    bgp confederation peers配置联邦EBGP 对等的成员
    set community local-AS设置团体属性
    neighbor ip-address send-community开启发送团体属性的能力

    二层链路封装

    命令描述
    encapsulation hdlc把接口的封装改为hdlc
    encapsulation ppp把接口的封装改为ppp
    ppp pap sent-username R1 password 123456 pap认证时,向对方发送用户名R1 和密码123456
    ppp authentication papPPP 的认证方式为pap
    username R1 password 123456为对方创建用户R1,密码为123456
    debug ppp authentication打开ppp 的认证调试过程
    ppp authentication chapPPP 的认证方式为chap

    帧中继相关配置命令

    命令描述
    frame-relay switching把路由器当成帧中继交换机
    encapsulation frame-relay接口封装成帧中继
    frame-relay lmi-type cisco配置LMI 的类型
    frame-relay intf-type dce配置接口是帧中继的DCE 还是DTE
    frame-relay route配置帧中继交换表
    show frame-relay route显示帧中继交换表
    show frame pvc显示帧中继PVC 状态
    show frame lmi显示帧中继LMI 信息
    show frame-relay map查看帧中继映射
    no frame-relay inverse-arp关闭帧中继自动映射
    ip split-horizon打开水平分割
    int s0/0/0.1 multipoint创建点到多点子接口
    int s0/0/0.3 point-to-point创建点到点子接口
    frame-relay interface-dlci 104在点到点子接口上配置DLCI

    ACL 相关配置命令

    命令描述
    show ip access-lists查看所定义的IP 访问控制列表
    clear access-list counters将访问控制列表计数器清零
    access-list定义ACL
    ip access-group在接口下应用ACL
    access-class在vty 下应用ACL
    ip access-list定义命名的ACL
    time-range time定义时间范围
    username username password password建立本地数据库
    autocommand定义自动执行的命令

    DHCP 相关配置命令

    命令描述
    show ip dhcp pool查看DHCP 地址池的信息
    show ip dhcp binding查看DHCP 的地址绑定情况
    show ip dhcp database查看DHCP 数据库
    show ip interface查看接口信息
    debug ip dhcp server events动态查看DHCP 服务器的事件
    service dhcp开启DHCP 服务
    no ip dhcp conflict logging关闭DHCP 冲突日志
    ip dhcp pool配置DHCP 分配的地址池
    network DHCP服务器要分配的网络和掩码
    default-router默认网关
    domain-name域名
    netbios-name-serverWINS 服务器
    dns-server域名服务器
    option 150 ipFTP 服务器
    lease配置租期
    ip dhcp excluded-address排除地址段
    ip helper-address 配置DHCP中继的地址

    NAT 相关配置命令

    命令描述
    clear ip nat translation *清除动态NAT 表
    show ip nat translation查看NAT 表
    show ip nat statistics查看NAT 转换的统计信息
    debug ip nat动态查看NAT 转换过程
    ip nat inside source static配置静态NAT
    ip nat inside配置NAT 内部接口
    ip nat outside配置NAT 外部接口
    ip nat pool配置动态NAT 地址池
    ip nat inside source list access-list-number pool name配置动态NAT
    ip nat inside source list access-list-number pool name overload配置PAT

    交换机基本配置命令

    命令描述
    duplex { full | half | auto }配置以太口的双工属性
    speed { 10 | 100 | 1000 | auto }配置以太口的速率
    ip default-gateway 172.16.0.254配置缺省网关
    switch mode access把端口改为访问模式
    switch port-securitiy打开交换机的端口安全功能
    switch port-securitiy maximum 1允许该端口下的MAC 条目最大数量为1
    switch port-securitiy violation{ protect | shutdown | restrict }配置交换机端口安全
    switchport port-security mac-address  0019.5535.b828允许MAC 为0019.5535.b828 的设备接入本接口show mac-address-table 显示MAC 地址表
    mac-address 12.12.12改变接口的MAC 地址
    rename flash:config.text flash:config.old把flash 中的文件改名
    copy xmodem:flash:c2950-i6q4l2-mz.121-22.EA5a.bin通过Xmodem 模式把文件拷贝到flash 中
    boot重启交换机

    VLAN与VTP配置命令

    命令描述
    vlan database进入到vlan database 配置模式
    vlan 2 name VLAN2创建vlan 2
    switch access vlan 2把端口划分到VLAN 2 中
    interface range f0/2 - 3批量配置接口的属性
    show vlan查看VLAN 的信息
    switchport trunk encanpsulation配置trunk 链路的封装类型
    switch mode trunk把接口配置为trunk
    show interface f0/13 trunk查看交换机端口的trunk 状态
    switchport nonegotiate Trunk链路上不发送trunk 协商包
    vtp mode server配置交换机为VTP server
    vtp domain VTP-TEST配置VTP 域名
    vtp password cisco配置VTP 的密码
    vtp mode client配置交换机为VTP client
    vtp transparent配置交换机为VTP transparent
    show vtp status显示vtp 的状态
    vtp pruning启用VTP 修剪
    vtp version 2VTP 版本为2
    interface port-channel 1创建以太通道
    channel-group 1 mode on把接口加入到以太网通道中,并指明以太通道模式
    port-channel load-balance dst-mac配置etherChannel 的负载平衡方式
    show etherchannel summary查看etherchannel 的简要信息

    生成树STP配置命令

    命令描述
    show spanning-tree查看STP 树信息
    spanning-tree vlan 1 priority 4096配置VLAN1 的桥优先级
    spanning-tree portfast配置接口为portfast,当有设备接入时立即进入转发状态
    spanning-tree uplinkfast配置uplinkfast 特性
    spanning-tree backbonefast配置backbonefast 特性
    spanning-tree mode rapid-pvst把STP 的运行模式设为RSTP+PVST
    spanning-tree link-type point-to-point把接口的链路类型改为点对点
    spanning-tree mode mst把生成树的模式改为MST
    spanning-tree mst configuration进入MST 的配置模式
    name TEST-MST命名MST 的名字
    revision 1配置MST 的revision 号
    instance 1 vlan 1-2把VLAN 1 和VLAN 2 的生成树映射到实例1
    spanning-tree guard root在接口上配置root guard 特性
    spanning-tree bpduguard enable在接口上配置bpduguard 特性

    trunk基本配置

    命令描述
    int g0/0.1创建子接口
    encapture dot1q 1 native指明子接口承载哪个VLAN 的流量以及封装类型,同时该VLAN 是native vlan
    ip routing打开路由功能
    no switchport接口不作为交换机接口
    ip cef开启CEF 功能

    HSRP 基本配置命令

    命令描述
    standby 1 ip 192.168.13.254启用 HSRP 功能,并设置虚拟IP 地址
    standby 1 priority 120配置本路由器的HSRP 优先级
    standby 1 preempt配置HSRP 抢占
    standby 1 timers 3 10设置HSRP 的HELLO time 和HOLD time
    standby 1 authentication md5 key-string  cisco配置HSRP 认证密码,认证方式为MD5
    show standby brief查看HSRP 的简要情况
    standby 1 track Serial0/0/0 30跟踪s0/0/0 接口,当接口故障时,HSRP 优先级降低30
    vrrp 1 ip 192.168.13.254启用 VRRP 功能,并设置虚拟IP 地址
    vrrp 1 priority 120配置本路由器的VRRP 优先级
    vrrp 1 preempt配置VRRP 抢占
    vrrp 1 authentication md5 key-stringcisco 配置VRRP 认证密码,认证方式为MD5
    track 100 interface Serial0/0/0定义一个跟踪目标号,被跟踪对象为s0/0/0
    line-protocol接口
    vrrp 1 track 100 decrement 30跟踪目标100,当目标故障时,优先级降低30
    show vrrp brief查看VRRP 的简要情况
    glbp 1 ip 192.168.1.254启用 GLBP 功能,并设置虚拟IP 地址
    glbp 1 priority 200配置本路由器的GLBP 优先级
    glbp 1 preempt配置GLBP 抢占
    glbp 1 authentication md5 key-string  cisco配置GLBP 认证密码,认证方式为MD5
    show glbp查看GLBP 情况

    重分布

    命令描述
    show ip route查看路由表
    show ip protocols查看和路由协议相关的信息
    redistribute配置路由协议重分布
    default-metric配置默认种子度量值  ip prefix-list 定义前缀列表
    distance eigrp配置EIGRP 默认管理距离
    router-map基本配置命令
    show ip policy查看策略路由及作用的接口
    show route-map查看定义的所有路由策略及路由策略匹配的情况
    debug ip policy动态查看策略路由的匹配情况
    passive-interface配置被动接口
    distribute-list配置分布控制列表
    route-map定义路由策略
    match定义匹配的条件
    set定义对符合匹配条件的语句采取的行为
    ip policy route-map应用路由策略
    ip local policy route-map本地应用路由策略

    IPv6基本配置命令

    命令描述
    show ipv6 route查看IPv6 路由表
    show ipv6 interface查看IPv6 接口信息
    show ipv6 protocols查看和IPv6 路由协议相关的信息
    show ipv6 rip next-hops查看RIPng 的下一跳地址
    show ipv6 rip database查看RIPng 的数据库
    show ipv6 ospf neighbor查看OSPFv3 邻居的基本信息
    show ipv6 ospf interface查看OSPFv3 路由器接口的信息
    show ipv6 ospf database查看OSPFv3 拓扑结构数据库
    show ipv6 ospf查看OSPFv3 进程及其细节
    show ipv6 route eigrp查看IPv6 EIGRP 的路由
    show ipv6 eigrp topology查看IPv6 EIGRP 的拓扑结构信息
    show ipv6 eigrp neighbors查看IPv6 EIGRP 的邻居
    debug ipv6 rip动态查看RIPng 的更新
    ipv6 unicast-routing启动IPv6 流量转发
    ipv6 address在接口下配置IPv6 地址
    ipv6 route配置IPv6 静态路由
    ipv6 router rip启动IPv6 RIPng 进程
    split-horizon启用水平分割
    poison-reverse启用毒化反转
    ipv6 rip tag enable在接口上启用RIPng
    ipv6 rip tag default-information originate向IPv6 RIPng 区域注入一条默认路由
    ipv6 router ospf启动OSPFv3 路由进程
    router-id配置路由器ID
    default-information originate向OSPFv3 网络注入一条默认路由
    ipv6 ospf process-id area area-id接口上启用OSPFv3,并声明接口所在区域
    ipv6 router eigrp配置IPv6 EIGRP 路由协议
    ipv6 eigrp接口下启用IPv6 EIGRP
    maximum-paths配置能支持的等价路径的条数

    组播相关命令

    命令描述
    ip multicast-routing启用组播路由功能
    ip pim dense在接口上运行pim dense 协议
    ip igmp join-group 237.0.0.1该接口加入到237.0.0.1 组中
    show ip pim neighbor显示了pim 邻居
    show ip mroute显示组播路由表
    show ip igmp groups显示组成员
    ip igmp snooping在交换机上配置IGMP Snopping 功能
    show ip igmp snooping显示交换机上的IGMP Snooping 运行情况
    show ip igmp snooping groups交换机上显示各组的成员在什么接口上
    ip pim sparse-dense在接口上运行pim sparse-dense 协议
    ip pim spt-threshold infinity静止从基于RP 的树切换到基于源的树
    ip pim send-rp-discovery loopback 0scope 255把路由器设为映射代理,其Loopback0 为代理地址
    ip pim send-rp-announce Loopback0 scope255把路由器设为候选RP,其Loopback0 为RP地址

    QOS相关命令

    命令描述
    priority-list 1 protocol ip high tcp telnet创建优先级队列,标号为1。把telnet 流量放在高优先级队列中
    priority-list 1 queue-limit 20 30 40 50定义优先级队列高、中、普通、低队列中的长度
    priority-group 1把定义好的优先级队列应用接口上
    show queueing priority查看优先级队列情况
    debug priority调试优先级队列
    queue-list 1 protocol ip 1 tcp telnet创建自定义队列,标号为1。把telnet 流量放在队列1 中
    queue-list 1 queue 1 limit 40定义队列1 的深度为40,
    custom-queue-list 1把定义好的自定义队列应用接口上
    fair-queue 512 1024 10在接口上启用WFQ,512 是丢弃值,1024 是最大的会话数,10 是RSVP 可预留队列
    class-map match-any CLASS-MAP1定义class-map,名为CLASS-MAP1
    match protocol http匹配http 协议
    bandwidth 10配置CLASS-MAP 流量的带宽为60K
    service-policy output MY-POLICY把定义好的策略应用在接口的output 方向上
    show class-map显示class-map 信息
    show policy-map显示policy-map 信息
    show policy-map interface s0/0/0显示接口s0/0/0 上的policy-map 配置
    priority 15配置LLQ,带宽为15k
    random-detect在接口上启用WRED
    random-detect precedence 0 18 42 12配置WRED,对于IP 优先级为0 的队列,最低阀值为18,最大阀值为42,按照1/12 的最大比例丢弃数据包
    show queueing random-detect显示WRED 的配置情况
    show interfaces rate-limit显示各接口上CAR 的情况
    drop丢弃数据包
    variance配置IPv6 EIGRP 非等价负载均衡

     

    本文授权转自微信公众号:网络技术干货圈(id: wljsghq)

    禁止二次转载,请联系作者授权

    展开全文
  • cisco路由器配置命令练习

    千次阅读 2021-07-15 02:04:24
    cisco路由器配置命令练习用cisco.exe练习软件操作(练习3—5次,熟悉思科命令输入)1. 回车进入用户模式router>2. 进入特权模式router>enablerouter#3. 进入全局模式router#configure terminalrouter(config)#4....
  • 收录最常用的Cisco命令分类如下: cisco命令大全 switch配置命令 (1)模式转换命令 用户模式----特权模式,使用命令"enable" 特权模式----全局配置模式,使用命令"config t" 全局配置模式----接口模式,使用命令...
  • 思科交换机常用指令

    千次阅读 2020-11-23 12:19:39
    title: 思科交换机常用指令(持续更新) tags: 教程 author: caijinbo date: 2019-11-19 思科交换机常用指令 vlan设置 console>enable //进入特权模式 console#configure //进入配置视图 console(config)#vlan ...
  • 思科交换机的基本配置命令学习CISCO交换机基本配置:Console端口连接交换机口令设置:switch>enable;进入特权模式switch#configterminal;进入全局配置模式switch(config)#hostnamecsico;设置交换机的主机名...
  • Cisco 思科模拟器命令

    千次阅读 2021-10-15 12:35:32
    文章目录基本配置**文件操作****启动配置****接口配置****路由****EIGRP****OSPF****ACL****DHCP****HDLC****PPP****FR****ARP(默认启用)****ISDN****IS-IS...R# logout (或exit) 退出Cisco设备 R# show history 查看
  • ##网络与交换技术笔记## 1.交换网络管理技术 交换机的管理方式 带外管理:PC和交换机直接相连进行管理 带内管理:通过Telent/web/SNMP对交换机进行远程管理 Console口:RJ45(水晶头)、DB9(长得很像VGA) ...
  • cisco命令大全

    万次阅读 多人点赞 2016-10-29 13:48:05
    :CISCO 命令集 —— 路由选择协议及排障  *ip route 命令   Router(config)#ip route < 目录网络或子网号 > [ 子网掩码 ] < 下一路由器 IP 地址 | 从本地出口的地址 > [ 管理距离 0~255 ,默认为 1] ...
  • 1、hostname指令 作用:操作服务器的主机名(读取、设置) 语法1:#hostname 含义:表示输出完整的主机名 语法2:#hostname-f 含义:表示输出当前主机名中的FQDN(全限定域名) 2、id指令 作用:查看一个用户...
  • 路由引入—思科命令

    2022-02-18 12:37:17
    在R3上: R3(config)#router ospf 1 R3(config-router)#redistribute rip subnets tag 10 在R2上(因为cisco packet tracer 7.3版本不支持route-map,所以后面的几条命令不能在虚拟机上完成了): route-map tag ...
  • 思科Packet Tracer---基本指令操作

    千次阅读 2020-05-06 22:30:54
    -------命令 指令 解释 查看指令
  • Ifconfig 三大指令与CISCO指令的对应 Ifconfig -a 相当于show ip int brief Ifconfig int up/down 相当于no shutdown Ifconfig int address netmask … ifconfig lo 127.0.0.1 相当于ip ...
  • 配置 console口密码:进入CON接口模式: password XXXX;(密码) login(使密码生效) 配置特权模式密码:进入全局配置模式: enable password XXX; (系统明文密码) 配置秘密特权模式密码:进入......
  • Cisco作为网络界的领军人物,公司相应的设备和模拟器功能也十分强大。今天我就来简单介绍一下思科的帮助系统和一些简单的配置方法。 Cisco Packet Tracer(下面简称为“PKT”)这款模拟器是每个初学网络的人都会...
  • 使用Cisco进行虚拟局域网划分

    千次阅读 2018-09-15 12:25:46
    那么下面我们开始使用Cisco进行实验 首先 划分VLAN 进入交换机命令行界面 进入特权模式: Switch>enable 缩写:en 进入全局配置模式:Switch#config termianl 缩写:conf t 进入接口配置模式:Switch(config)...
  • mkdir 新建文件夹名称【DOS 指令】 列出 目录内容 ls 【list】 列出 目录内容 dir【DOS 指令】 更改目录 cd 目录 /盘符 【change document】【盘符切换的格式:?待填充】 返回 上一目录 cd …【是两个 英文...
  • 路由表的添加:全局模式:ip route 需要路由的网络ip_子网掩码_目标端口 远程telnet的路由挂起:ctrl+shift+6 松开以后按x 查看挂起的路由:特权模式:show sessions ...返回挂起的路由:特权模式:resume+挂起...
  • cisco思科交换机命令参考大全

    千次阅读 2020-12-10 09:04:14
    1.设置主机名/系统名 IOS:switch(config)# hostname "hostname" CLI:switch(enable) set system name name-string 2.设置登录口令 IOS:switch(config)# enable password level 1 password ...
  • 思科(Cisco)交换机路由器命令大全

    千次阅读 2021-06-20 20:06:16
    思科(Cisco)路由器常用命令总结 视图模式介绍 普通视图router> 特权视图router# / 在普通模式下输入enable 全局视图router(config)#/ 在特权模式下输入configt 接口视图router(config-if)#/在全局模式下输入int ...
  • 本文目录系列文章目录前言一、Cisco操作系统IOS简介二、Cisco操作系统的操作模式三、Cisco不同操作模式的常用命令四、Cisco操作系统的常用操作最后 前言 互联网时代,我们面临的网络安全威胁一般有信息泄露、网络...
  • 思科交换机同一台3560,不同VLAN 实现互通 switch#conf t switch(config)#vlan 192 //定义vlan switch(config-vlan)#int f0/1 //配置端口 switch(config-if)#switchport access vlan 192 switch(config)#int vlan ...
  • 原标题:cisco(思科)交换机管理方式选择及基本命令配置感谢大家阅读本文章,本作者文章主要以实训的目的进行讲解。如在阅读本文中有什么不了解的地方尽可关注留言,我将第一时间为您解答疑惑。有大神看出了问题也请...
  • cisco packet tracer常用指令

    千次阅读 2013-05-28 18:00:22
    最近由于在上网络方面的课程,做实验要用到cisco packet tracer这个软件,所以无耻的从别人那盗了个常用指令过来,点击打开链接,感谢这篇文章的博主,希望对大家有帮助。

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 8,367
精华内容 3,346
关键字:

思科指令