精华内容
下载资源
问答
  • 思科路由器IP地址 远程登录配置
    千次阅读
    2018-01-18 09:09:06

    配置路由器IP地址

    然后用命令ip address x.x.x.x x.x.x.x配置IP地址。具体命令如下:
    Router2800>enable (进入特权模式)
    Router2800#configure termial (进入全局配置模式)
    Router2800(config)#int f0/1 (进入接口配置模式)
    Router2800(config-if)#ip address 192.168.0.1 255.255.255.0 (为接口分配IP地址和掩码)
    Router2800(config-if)#no shutdown (启用接口)
    Router2800(config-if)#ex (退出接口模式)

    远程登录配置

    首先路由器要设置远程登录密码(在被远程的路由器上设置)
    line vty 0 4 (允许5台设备登录)
    passwork +密码
    login
    其次全局模式下也要键入配置密码
    enable password +密码 (这个密码不安全)

    最后才能实现远程登录
    telnet + 远程登录的地址

    如果要设置一个安全的密码,如下

    R2# en
    R2#conf t
    R2(config)#enable secret 密码

    转载于:https://blog.51cto.com/13242922/2062304

    更多相关内容
  • IP地址欺骗可以应用在多种不同的攻击方式中,例如TCP SYN flooding、UDP flooding、ICMP flooding等,伪造的源地址可以是不存在的地址,或者是最终攻击目标的地址
  • Cisco路由器IP地址配置.pdf
  • 路由器IP地址配置基础知识常用命令实验流程1.设计拓扑2.配置路由器IP地址3.查看路由表4.激活端口5.查看路由表6.验证主机连通 基础知识 ip地址是网络层中使用的地址,网络层依靠IP地址和路由协议将数据报送到目的IP...

    基础知识

    ip地址是网络层中使用的地址,网络层依靠IP地址和路由协议将数据报送到目的IP主机。

    路由器是互联网的核心设备,它在IP网络间转发数据报,这使得路由器的每个接口都连接一个或多个网络,而两个接口却不可以代表一个网络,路由器的一个配置了IP地址的接口所在的网络就是路由器的直连网络,路由器不需要额外的配置路由,当接口被激活后,路由器就会自动将直连网络加入到路由表中。

    常用命令

    命令格式含义
    ip address IP地址 子网掩码在接口模式下配置当前接口的IP地址
    show ip route特权模式下查看路由器的路由表
    do show ip route非特权模式下查看路由表
    no shutdown接口模式下激活该接口

    实验流程

    开始
    设计拓扑
    配置ip
    未激活情况下查看路由表
    激活情况下查看路由表
    验证主机连通
    结束

    1.设计拓扑

    在这里插入图片描述

    2.配置路由器IP地址

    Router>enable
    Router#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#interface g0/0
    Router(config-if)#ip address 192.168.1.1 255.255.255.0
    Router(config-if)#exit
    Router(config)#interface g0/1
    Router(config-if)#ip address 192.168.2.1 255.255.255.0
    Router(config-if)#end
    Router#
    %SYS-5-CONFIG_I: Configured from console by console
    
    Router#
    

    3.查看路由表

    Router#show ip route
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
    

    4.激活端口

    Router#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#interface g0/0
    Router(config-if)#no shutdown
    
    Router(config-if)#
    %LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
    
    Router(config-if)#exit
    Router(config)#interface g0/1
    Router(config-if)#no shutdown
    
    Router(config-if)#
    %LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
    
    Router(config-if)#
    

    5.查看路由表

    Router#show ip route
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.1.0/24 is directly connected, GigabitEthernet0/0
    L       192.168.1.1/32 is directly connected, GigabitEthernet0/0
         192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.2.0/24 is directly connected, GigabitEthernet0/1
    L       192.168.2.1/32 is directly connected, GigabitEthernet0/1
    

    6.验证主机连通

    这里验证p0和p2的连通性,打开主机p0终端

    C:\>ping 192.168.2.11
    
    Pinging 192.168.2.11 with 32 bytes of data:
    
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    
    Ping statistics for 192.168.2.11:
        Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)
    C:\>
    

    等等,忘记配置每个主机的IP,子网掩码,网关了
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    再来

    C:\>ping 192.168.2.11
    
    Pinging 192.168.2.11 with 32 bytes of data:
    
    Request timed out.
    Reply from 192.168.2.11: bytes=32 time<1ms TTL=127
    Reply from 192.168.2.11: bytes=32 time<1ms TTL=127
    Reply from 192.168.2.11: bytes=32 time=1ms TTL=127
    
    Ping statistics for 192.168.2.11:
        Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 1ms, Average = 0ms
    
    C:\>
    

    已经可以证明两者可以互相通信了,其它的同样也可以就不做验证了。

    此时再看一下拓扑图
    在这里插入图片描述
    之前的红点已经变成了绿色。

    绿色:代表连通
    红色:代表未连接
    黄色:代表阻塞

    注意:路由器端口所连接的不能是同一个网络,否者会出现端口重叠的现象。

    展开全文
  • 有好几种方法可用来配置Cisco路由器。配置可以由TFTP服务器通过网络来完成;可以通过启动时提供的菜单界面来完成;并且可以由运行setup命令所提供的菜单界面来完成;还可以由保存到内存中的配置来完成。本教程不会...
  • 本文实例讲述了思科cisco路由器dhcp动态分配ip地址实现方法。分享给大家供大家参考,具体如下:一、拓扑图Router1 F0/0 Switch5 F0/0Router1 E1/0 VPCS V0/5Switch5 F0/1 Switch1 F0/0Switch5 F0/2 Switch2 F0/0...

    本文实例讲述了思科cisco路由器dhcp动态分配ip地址实现方法。分享给大家供大家参考,具体如下:

    一、拓扑图

    Router1 F0/0 Switch5 F0/0

    Router1 E1/0 VPCS V0/5

    Switch5 F0/1 Switch1 F0/0

    Switch5 F0/2 Switch2 F0/0

    Switch5 F0/3 Switch3 F0/0

    Switch5 F0/4 Switch4 F0/0

    Switch1 F0/1 VPCS V0/1

    Switch2 F0/1 VPCS V0/2

    Switch3 F0/1 VPCS V0/3

    二、dhcp服务器就是通过主机分配ip的一项服务。路由是通过那个口来分配的。接几个分配几个。要使客户机能从用作DHCP Server的路由器中自动获得IP地址。

    三、实验要求:

    1、vlan之间的通信通过三层交换机来实现

    2、路由器为4个vlan来分配ip地址

    3、pc1 - 4分别属于4个部门,能够自动得到ip地址

    4、pc1 - 5直接可以ping通

    四、实验思路:

    1、首先配置二层交换机上的vlan、trunk并把接口加入vlan

    2、三层交换中配置vlan、trunk并启用ip routing路由功能

    3、三层交换中配置vlan ip地址,三层交换机是带有三层路由功能的交换机,也就是这台交换机的端口既有三层路由功能,

    也具有二层交换功能。三层交换机端口默认为二层口,

    如果需要启用三层功能就需要在此端口输入no switchport命令。运行router rip协议(其他协议也行)查看路由表 show ip router

    4、配置路由器dhcp服务 建立地址持ip dhcp pool apple(apple为地址池名称可以随便起)运行router rip协议

    5、保存设置:在全局配置模式下 Router#copy running-config startup-config //保存当前的配置 或 Router#write 也行

    6、查看!

    五、实验过程:

    1、配置二层交换机valn  trunk 并将接口加入vlan

    sw1#vlan data

    sw1#vlan database

    sw1(vlan)#vlan 10

    VLAN 10 added:

    Name: VLAN0010

    sw1(vlan)#exit

    APPLY completed.

    Exiting....

    sw1#conf t

    Enter configuration comman

    sw1(config)#interface f0/0

    sw1(config-if)#sw m t

    sw1(config-if)#interface f0/1

    sw1(config-if)#sw ac vlan 10

    sw1(config-if)#exit

    sw1(config)#exit

    sw1#show vlan-switch

    sw2 - 4相同配置

    2、配置三层交换(vlan、trunk、vlan ip)

    sw3-1#vlan da

    sw3-1(vlan)#vlan 10

    VLAN 10 added:

    Name: VLAN0010

    sw3-1(vlan)#vlan 20

    VLAN 20 added:

    Name: VLAN0020

    sw3-1(vlan)#vlan 30

    VLAN 30 added:

    Name: VLAN0030

    sw3-1(vlan)#vlan 40

    VLAN 40 added:

    Name: VLAN0040

    sw3-1(config)#ip routing 在三层交换中启动路由功能

    sw3-1(config)#interface vlan 10

    sw3-1(config-if)#ip ad 192.168.1.1 255.255.255.0 配置vlan ip

    sw3-1(config-if)#no shut

    sw3-1(config-if)#exit

    sw3-1(config)#interface vlan 20

    sw3-1(config-if)#ip ad 192.168.2.1 255.255.255.0

    sw3-1(config-if)#no shut

    sw3-1(config-if)#exit

    sw3-1(config)#interface vlan 30

    sw3-1(config-if)#ip address 192.168.3.1 255.255.255.0

    sw3-1(config-if)#no shut

    sw3-1(config-if)#interface vlan 40

    sw3-1(config-if)#ip ad 192.168.4.1 255.255.255.0

    sw3-1(config-if)#no shut

    sw3-1(config-if)#exit

    sw3-1(config)#interface rang f0/1 - 4 配置trunk

    sw3-1(config-if-range)#sw m t

    sw3-1(config-if-range)#exit

    sw3-1(config)#interface f0/0

    sw3-1(config-if)#no switchport 启动三层接口

    sw3-1(config)#interface f0/0

    sw3-1(config-if)#ip address 10.0.0.1 255.0.0.0 配置接口ip

    sw3-1(config-if)#no shut

    sw3-1(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.3 配置默认路由

    sw3-1(config)#router rip 启用rip协议

    sw3-1(config-router)#network 192.168.1.0

    sw3-1(config-router)#network 192.168.2.0

    sw3-1(config-router)#network 192.168.3.0

    sw3-1(config-router)#network 192.168.4.0

    sw3-1(config-router)#network 10.0.0.0

    查看路由表

    3、配置dhcp路由器

    dhcp(config)#interface f0/0

    dhcp(config-if)#ip address

    dhcp(config-if)#ip address 10.0.0.3 255.0.0.0

    dhcp(config-if)#interface 192.168.237.1 255.255.255.0

    dhcp(config)#inte e1/0

    dhcp(config-if)#ip add 192.168.237.1 255.255.255.0

    dhcp(config-if)#no shut

    dhcp(config-if)#exit

    dhcp(config)#router rip

    dhcp(config-router)#network 10.0.0.0

    dhcp(config-router)#network 192.168.237.0

    show ip route 同上

    dhcp(config)#ip dhcp pool apple 建立地址池

    dhcp(dhcp-config)#network 192.168.0.0 255.255.0.0

    4、在三层交换指定dhcp服务器即路由器的ip 地址。

    sw3-1(config)#interface vlan 10

    sw3-1(config-if)#ip helper-address 10.0.0.3

    sw3-1(config-if)#interface vlan 20

    sw3-1(config-if)#ip helper-address 10.0.0.3

    sw3-1(config-if)#interface vlan 30

    sw3-1(config-if)#ip helper-address 10.0.0.3

    sw3-1(config-if)#inter vlan 40

    sw3-1(config-if)#ip helper-address 10.0.0.3

    5、配置pc5的ip地址为192.168.237.2  255.255.255.0 gateway 192 .168.237.1

    结果:pc5都能ping通pc1 - 4

    展开全文
  • 拓扑图:2台任意的路由器 R1配置命令: R1:

    拓扑图:R1配置命令:

    R1:Router>enable                                                                      #进入特权模式

    Router#configure terminal                                                          #进入配置模式

    Router(config)#interface fastEthernet 0/0                                  #进入F0/0接口

    Router(config-if)#ip address 192.168.10.1 255.255.255.0        #给这个接口配置IP地址和子网掩码

    Router(config-if)#no shutdown                                                   #打开这个接口

    R2配置命令:

    R2:Router>enable                                                                      #进入特权模式

    Router#configure terminal                                                          #进入配置模式

    Router(config)#interface fastEthernet 0/0                                  #进入F0/0接口

    Router(config-if)#ip address 192.168.10.2 255.255.255.0        #给这个接口配置IP地址和子网掩码

    Router(config-if)#no shutdown                                                   #打开这个接口

    展开全文
  • cisco路由器配置命令练习

    千次阅读 2021-07-15 02:04:24
    cisco路由器配置命令练习用cisco.exe练习软件操作(练习3—5次,熟悉思科命令输入)1. 回车进入用户模式router>2. 进入特权模式router>enablerouter#3. 进入全局模式router#configure terminalrouter(config)#4....
  • 思科路由器配置IP方法

    千次阅读 2021-07-15 02:04:42
    思科路由器配置IP方法2019-04-131、 IP地址分类IP地址分为网络地址和主机地址二个部分,A类地址前8位为网络地址,后24位为主机地址,B类地址16位为网络地址,后16位为主机地址,C类地址前24位为网络地址,后8位为...
  • 该Python脚本将允许您输入单个IP或CIDR网络范围,并从核心Cisco路由器/交换机到边缘交换机端口跟踪关联的MAC地址。 它将输出目标IP地址,MAC地址,边缘交换机名称,端口名称,端口描述,接口模式(访问或中继),...
  • 许多有关TCP/IP的文献曾经把网络层使用的路由器称为网关,在今天很多局域网采用都是路由来接入网络,因此通常指的网关就是路由器IP! 我们打开路由器的CLL来对路由器的接口进行ip配置 在全局配置模式进入到...
  • (2)掌握路由器端口IP地址的配置方法。 (3)理解路由器的直连网络。 (4)理解ARP协议的作用。 (5)理解ARP协议的工作方式。 二、实验仪器 1、装有Cisco Packet Tracer的Windows10...
  • 思科路由器如何设置,cisco路由器的配置方法 思科路由器如何设置,cisco路由器的配置方法
  • Cisco路由器上配置DHCP全程详解

    千次阅读 2021-02-05 09:20:33
    配置DHCP服务器实例网络环境:一台2811路由,一台2950交换机,一台3560交换机,三台自动获取IP地址的PC。划分三个vlan1,vlan2,vlan3。拓扑如下配置命令及步骤如下:第一步:配置路由成为DHCP服务器1、设置地址池 /*...
  • 利用CISCO路由器的NAT解决IP地址短缺问题.pdf
  • Csico 路由器有时需要定位到某个高流量的IP地址,但是交换机模块的端口是没办法查看到具体IP,只能通过出口来进行流量查看
  • 如何在思科路由器屏蔽指定的IP地址,有需要的可以学习下。
  • 为您分配的P地址块为192.168.23.0 /24,您必须支持现有的网络,同时还要考虑未来的发展。 子网的具体情况为(假设已启用ip subnet-zero) : ·第1个子网为现有的学生LAN(未连接路由器R2-Central),最多支持60台主机;·...
  • 教您如何修改路由器LAN端口的IP地址

    千次阅读 2021-06-25 12:41:44
    目前,大多数品牌或非品牌的有线或无线路由器通常将192.168.1.1或192.168.0.1网段用作LAN端口地址,... 作者将教您如何修改路由器的LAN端口IP地址.1. 设置计算机的IP地址以自动获取.2. 打开IE浏览器,在地址栏中输入...
  • 思科路由器如何配置VLAN的IP

    千次阅读 2021-07-20 02:25:01
    我们的思科路由器如何配置VLAN的IP呢?想必很多网络技术的新手都不清楚,所以小编这里就推荐下配置VLAN的IP方法和介绍VLAN给你们认识认识。VLAN:英文全称为Virtual Local Area Network,中文称虚拟局域网,VLAN其实...
  • 思科路由器配置NAT地址转换

    千次阅读 2021-11-25 21:14:08
    静态NAT转换 采用如图所示的结构,每个端口配置如下的ip 首先得理解这个结构,r4的s2/0端口和r6和pc8共同组成外网 r4的f0/0和交换机s2以及pc6 pc7组成内网, 因此配完ip后,还得保证...r4和pc8由于是直接连接在路由器
  • 思科(Cisco)路由器常用命令总结

    千次阅读 2021-10-02 09:27:53
    1,路由器口令设置: router>enable 进入特权模式 router#config terminal 进入全局配置模式 router(config)#hostname 设置交换机的主机名 router(config)#enable secret xxx 设置特权加密口令 router(config)#...
  • 三层交换机作为DHCP服务器,路由器作为DHCP中继,PC通过DHCP中继获取IP地址 实验拓扑: 配置步骤: 1. 配置路由器和三层交换机端口IP地址 Router6: R6#conf t R6(config)#int f0/0 R6(config-if)#ip address ...
  • 思科路由器--nat

    千次阅读 2017-12-04 14:09:49
    思科路由器上做nat技术
  • 如图所示,准备一台电脑,用网线连接设备上最小的业务接口,然后用console线将设备和电脑连接上,通过xshell或者CRT等连接器连接到命令行,以cisco1841为例:
  • 可以看到,现在直接进入路由器是需要密码的,那么我们就需要进行密码的破解,但是在破解密码的过程中,我们不能清除里面的配置,也就是说,一会儿密码破解完成,再进去的时候,这个ip地址应该是存在的,
  • CISCO路由器配置IP地址映射

    千次阅读 2008-12-30 16:06:00
    "telnet_ip" /连接设备,出现提示后输入用户和密码/提示符为#时输入中"conf_ter" /进入特权配置模式/提示符为#输入"ip_nat_inside_source_static_tcp_内网IP_端口_公网IP_端口" /设置地址映射/输入"exit" 
  • 三层交换机配置: switch (config)#interface vlan1 (配置VLAN1) switch (config-if)#ip helper-address 192.168.11.4(指定DHCP服务器的地址,即路由器地址) switch (config)#interface vlan2 ...
  • Cisco思科路由器端口的配置

    千次阅读 2020-12-14 18:25:52
    Cisco思科路由器端口的配置 小编都是喜欢借助实验写博客 一、拓扑图 结合图可以知道我们一共有四个网段(四个vlan) 1.vlan 1 ip:192.168.1.0网段 自带的vlan不需要在路由器添加的 2.vlan 2 ip:192.168.2.0...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 33,703
精华内容 13,481
关键字:

思科路由器ip地址