精华内容
下载资源
问答
  • 思科路由器常用配置命令大全 思科路由器常用配置命令大全思科路由器常用配置命令大全
  • CISCO路由器常用配置命令大全,CISCO路由器常用配置命令大全
  • cisco路由器常用配置

    2011-07-15 12:50:08
    路由配置命令,包括命名,接口IP,路由等配置
  • 思科路由器常用配置命令大全word版本,供初学者方便查询使用。
  • 思科路由器常用配置命令大全 Access-enable 允许路由器在动态访问列表中创建临时访问列表入口  Access-group 把访问控制列表(ACL)应用到接口上  Access-list 定义一个标准的IP ACL  Access-template 在...
  • 【笔记】思科路由器常用配置命令

    千次阅读 2017-02-07 13:13:26
    用TFTP工具进行路由器配置的备份及还原。 下载Cisco TFTP工具 开启TFTP软件,设定好备份路径 确定计算机与路由器是否连通 用copy running-config tftp 将运行配置文件备份至TFTPServer,...
    




    TFTP工具进行路由器配置的备份及还原。


    1. 下载Cisco TFTP工具

    2. 开启TFTP软件,设定好备份路径

    3. 确定计算机与路由器是否连通

    4. copy running-config tftp 将运行配置文件备份至TFTPServer,我的TFTP Server IP192.168.1.2

      显示已经成功了

    5. 还原将顺序反过来即可 copy tftp running-config


     


    CDP协议:


    思科用于发现相邻设备的协议,可查看相邻端口所连接的设备。


    Show cdp neighbors



     


    配置允许远程接入设定


    配置模式下输入 line vty 0 4


    设定登入密码:password 123


    设定登录:login


     


    路由器静态路由设定规则:


    1. 不包含本网段的地址

    2. 带宽优先


     


    RIP 设定


    开启RIP


    Router rip


    配置直连路由


    Network IP地址


     


    查看路由运行的协议:


    Show ip protocols


     


    修改RIP定时器默认值


    基本命令格式


    Timers basic 更新定时器时间 失效定时器时间 抑制定时器时间 刷新定时器时间


     


    设置RIP最大6条负载均衡路径


    Router rip


    Maximum-paths 6


     


    负载均衡


    分组交换快速交换(默认)


    关闭快速交换


    No ip cef


     


    水平分割(防止产生环路)


    Show ip inter f0/0


    关闭 no ip split-horizon


     


    被动接口配置


    关闭还回口RIP更新


    Router rip


    Passive-interface 端口


     


    单播更新


    Passive-interface default 将直连路由全部配置成被动借口配置


    Neighbor 邻近路由IP


     


     


    RIP默认路由


    Router rip


    Network IP


    1. Default-information originate 声明R2 是默认路由的起源,这样R2就会向其他RIP路由宣告自己是默认路由

    2. Ip default-network 23.0.0.0 配置默认网络,仅支持有类网络


     


    浮动静态路由


    Ip route 193.1.2.0 255.255.255.0 21.1.1.2130


    静态路由默认管理距离是0或者1


    130是管理路由 RIP的管理路由是120


    VLSM可变长度子网掩码


     


    IP地址借用


    Ip unnumbered f0/0


    Ip route 去往的路由地址 掩码 本机出口(S1/0


     


    RIPv2路由关闭自动汇总


    Router rip


    Ver 2


    No auto-summary


     


    RIPv2 手工汇总


    Int s1/1


    IP summary-address rip 192.168.1.0255.255.255.192


     


    RiP v2 路由验证


    RIP验证模式2 test(明文)和MD5


    MD5验证


    Int s1/1


    Ip rip authentication mode md5


    --------------------------------------------------------------------------------------------------------------




    配置路由器远程登录密码

    Line vty 0 4

    Password cisco

    Login

    Enable secret sisco

    Service password-encryption

     

    配置交换机VTP协议

    Vtp domain ccna

    Vtp mode client

    Int f0/0

    Switchport mode trunk

     

    配置STP生成树协议,为根交换机

    Spanning-tree vlan 1,2,3 priority 4096

     

    配置DHCP

    Ip dhcp excluded-address 192.168.1.1

    Ip dhcp pool vlan

    Network 192.168.1.0 0.0.0.255

    Default-router 192.168.1.1

    Dns-server 218.1.1.2

     

    配置OSPF

    Route ospf 1

    Network 12.1.1.0 0.0.0.255 area 0

     

    配置ppp协议

    Username R2 password cisco

    Int s0/0

    Encapsutation ppp

    Ppp authentication chap

     

    配置NAT

    Int f0/0

    Ip nat inside

    Int s0/0

    Ip nat outside

    Access-list 1 permit 192.168.1.0 0.0.0.255

    Ip nat inside source list 1 int s0/0overload

     

    配置静态NAT可以从外部telnet访问内部设备

    Int f0/0

    Ip nat inside

    Ip nat inside source static tcp 192.168.1.223 12.1.1.1 2323

    Access-list 1 permit tcp 192.168.1.00.0.0.255

     

    配置访问控制列表禁止访问web服务

    Access-list 100 deny 192.168.1.0 0.0.0.255host 218.1.1.2 eq www

    Access-list 100 permit ip any any

    Int f0/0

    Ip access-group 100 in

    展开全文
  • Access-enable 允许路由器在动态访问列表中创建临时访问列表入口 Access-group 把访问控制列表(ACL)应用到接口上 Access-list 定义一个标准的IP ACL Access-template 在连接的路由器上手动替换临时访问列表...
    Access-enable  允许路由器在动态访问列表中创建临时访问列表入口
       Access-group  把访问控制列表(ACL)应用到接口上
       Access-list  定义一个标准的IP ACL
       Access-template  在连接的路由器上手动替换临时访问列表入口
       Appn  向APPN子系统发送命令
       Atmsig   执行ATM信令命令
       B   手动引导操作系统
       Bandwidth   设置接口的带宽
       Banner motd   指定日期信息标语
       Bfe   设置突发事件手册模式
       Boot system   指定路由器启动时加载的系统映像
       Calendar   设置硬件日历
       Cd   更改路径
       Cdp enable   允许接口运行CDP协议
       Clear   复位功能
       Clear counters   清除接口计数器
       Clear interface   重新启动接口上的件逻辑
       Clockrate   设置串口硬件连接的时钟速率,如网络接口模块和接口处理器能接受的速率
       Cmt   开启/关闭FDDI连接管理功能
       Config-register   修改配置寄存器设置
       Configure   允许进入存在的配置模式,在中心站点上维护并保存配置信息
       Configure memory   从NVRAM加载配置信息
       Configure terminal   从终端进行手动配置
       Connect   打开一个终端连接
       Copy   复制配置或映像数据
       Copy flash tftp   备份系统映像文件到TFTP服务器
       Copy running-config startup-config   将RAM中的当前配置存储到NVRAM
       Copy running-config tftp   将RAM中的当前配置存储到网络TFTP服务器上
       Copy tftp flash   从TFTP服务器上下载新映像到Flash
       Copy tftp running-config   从TFTP服务器上下载配置文件
       Debug   使用调试功能
       Debug dialer   显示接口在拨什么号及诸如此类的信息
       Debug ip rip   显示RIP路由选择更新数据
       Debug ipx routing activity   显示关于路由选择协议(RIP)更新数据包的信息
       Debug ipx sap   显示关于SAP(业务通告协议)更新数据包信息
       Debug isdn q921   显示在路由器D通道ISDN接口上发生的数据链路层(第2层)的访问过程
       Debug ppp   显示在实施PPP中发生的业务和交换信息
       Delete   删除文件
       Deny   为一个已命名的IP ACL设置条件
       Dialer idle-timeout   规定线路断开前的空闲时间的长度
       Dialer map   设置一个串行接口来呼叫一个或多个地点
       Dialer wait-for-carrier-time   规定花多长时间等待一个载体
       Dialer-group   通过对属于一个特定拨号组的接口进行配置来访问控制
       Dialer-list protocol   定义一个数字数据接受器(DDR)拨号表以通过协议或ACL与协议的组合来控制控制拨号
       Dir   显示给定设备上的文件
       Disable   关闭特许模式
       Disconnect   断开已建立的连接
       Enable   打开特许模式
       Enable password   确定一个密码以防止对路由器非授权的访问Enable password   设置本地口令控制不同特权级别的访问
       Enable secret   为enable password命令定义额外一层安全性 (强制安全,密码非明文显示)
       Encapsulation frame-relay   启动帧中继封装
       Encapsulation novell-ether   规定在网络段上使用的Novell独一无二的格式
       Encapsulation PPP   把PPP设置为由串口或ISDN接口使用的封装方法
       Encapsulation sap   规定在网络段上使用的以太网802.2格式Cisco的密码是sap
       End   退出配置模式
       Erase   删除闪存或配置缓存
       Erase startup-config   删除NVRAM中的内容
       Exec-timeout   配置EXEC命令解释器在检测到用户输入前所等待的时间
       Exit   退出所有配置模式或者关闭一个激活的终端会话和终止一个EXEC
       Exit   终止任何配置模式或关闭一个活动的对话和结束EXEC
       format   格式化设备
       Frame-relay local-dlci   为使用帧中继封装的串行线路启动本地管理接口(LMI)
       Help   获得交互式帮助系统

       History   查看历史记录
       Hostname   使用一个主机名来配置路由器,该主机名以提示符或者缺省文件名的方式使用
       Interface   设置接口类型并且输入接口配置模式
       Interface   配置接口类型和进入接口配置模式
       Interface serial   选择接口并且输入接口配置模式
       Ip access-group   控制对一个接口的访问
       Ip address   设定接口的网络逻辑地址
       Ip address   设置一个接口地址和子网掩码并开始IP处理
       Ip default-network   建立一条缺省路由
       Ip domain-lookup   允许路由器缺省使用DNS
       Ip host   定义静态主机名到IP地址映射
       Ip name-server   指定至多6个进行名字-地址解析的服务器地址
       Ip route   建立一条静态路由
       Ip unnumbered   在为给一个接口分配一个明确的IP地址情况下,在串口上启动互联网协议(IP)的处理过程
       Ipx delay   设置点计数
       Ipx ipxwan   在串口上启动IPXWAN协议
       Ipx maximum-paths   当转发数据包时设置Cisco IOS软件使用的等价路径数量
       Ipx network   在一个特定接口上启动互联网数据包交换(IPX)的路由选择并且选择封装的类型(用帧封装)
       Ipx router   规定使用的路由选择协议
       Ipx routing   启动IPX路由选择
       Ipx sap-interval   在较慢的链路上设置较不频繁的SAP(业务广告协议)更新
       Ipx type-20-input-checks   限制对IPX20类数据包广播的传播的接受
       Isdn spid1   在路由器上规定已经由ISDN业务供应商为B1信道分配的业务简介号(SPID)
       Isdn spid2   在路由器上规定已经由ISDN业务供应商为B2信道分配的业务简介号(SPID)
       Isdntch-type   规定了在ISDN接口上的中央办公区的交换机的类型
       Keeplive   为使用帧中继封装的串行线路LMI(本地管理接口)机制
       Lat   打开LAT连接
       Line   确定一个特定的线路和开始线路配置
       Line concole   设置控制台端口线路
       Line vty   为远程控制台访问规定了一个虚拟终端
       Lock   锁住终端控制台
       Login   在终端会话登录过程中启动了密码检查
       Login   以某用户身份登录,登录时允许口令验证
       Logout   退出EXEC模式
       Mbranch   向下跟踪组播地址路由至终端
       Media-type   定义介质类型
       Metric holddown   把新的IGRP路由选择信息与正在使用的IGRP路由选择信息隔离一段时间
       Mrbranch   向上解析组播地址路由至枝端
       Mrinfo   从组播路由器上获取邻居和版本信息
       Mstat   对组播地址多次路由跟踪后显示统计数字
       Mtrace   由源向目标跟踪解析组播地址路径
       Name-connection   命名已存在的网络连接
       Ncia   开启/关闭NCIA服务器
       Network   把一个基于NIC的地址分配给一个与它直接相连的路由器把网络与一个IGRP的路由选择的过程联系起来在IPX路由器配置模式下,在网络上启动加强的IGRP
       Network   指定一个和路由器直接相连的网络地址段
       Network-number   对一个直接连接的网络进行规定
       No shutdown   打开一个关闭的接口
       Pad   开启一个X.29 PAD连接
       Permit   为一个已命名的IP ACL设置条件
       Ping   把ICMP响应请求的数据包发送网络上的另一个节点检查主机的可达性和网络的连通性对网络的基本连通性进行诊断
       Ping   发送回声请求,诊断基本的网络连通性
       Ppp   开始IETF点到点协议
       Ppp   authentication 启动Challenge握手鉴权协议(CHAP)或者密码验证协议(PAP)或者将两者都启动,并且对在接口上选择的CHAP和PAP验证的顺序进行规定
       Ppp chap hostname   当用CHAP进行身份验证时,创建一批好像是同一台主机的拨号路由器
       Ppp chap password   设置一个密码,该密码被发送到对路由器进行身份验证的主机命令对进入路由器的用户名/密码的数量进行了限制
       Ppp pap sent-username   对一个接口启动远程PAP支持,并且在PAP对同等层请求数据包验证过程中使用sent-username和password
       Protocol   对一个IP路由选择协议进行定义,该协议可以是RIP,内部网关路由选择协议(IGRP),开放最短路径优先(OSPF),还可以是加强的IGRP
       Pwd   显示当前设备名Reload   关闭并执行冷启动;重启操作系统
       Rlogin   打开一个活动的网络连接
       Router   由第一项定义的IP路由协议作为路由进程,例如:router rip 选择RIP作为路由协议
       Router igrp   启动一个IGRP的路由选择过程
       Router rip   选择RIP作为路由选择协议
       Rsh   执行一个远程命令
       Sdlc   发送SDLC测试帧
       Send   在tty线路上发送消息
       Service password-encryption   对口令进行加密
       Setup   运行Setup命令
       Show   显示运行系统信息
       Show access-lists   显示当前所有ACL的内容
       Show buffers   显示缓存器统计信息
       Show cdp entry   显示CDP表中所列相邻设备的信息
       Show cdp interface   显示打开的CDP接口信息
       Show cdp neighbors   显示CDP查找进程的结果
       Show dialer   显示为DDR(数字数据接受器)设置的串行接口的一般诊断信息
       Show flash   显示闪存的布局和内容信息
       Show frame-relay lmi   显示关于本地管理接口(LMI)的统计信息
       Show frame-relay map   显示关于连接的当前映射入口和信息
       Show frame-relay pvc   显示关于帧中继接口的永久虚电路(pvc)的统计信息
       Show hosts   显示主机名和地址的缓存列表
       Show interfaces   显示设置在路由器和访问服务器上所有接口的统计信息
       Show interfaces   显示路由器上配置的所有接口的状态
       Show interfaces serial   显示关于一个串口的信息
       Show ip interface   列出一个接口的IP信息和状态的小结
       Show ip interface   列出接口的状态和全局参数
       Show ip protocols   显示活动路由协议进程的参数和当前状态
       Show ip route   显示路由选择表的当前状态
       Show ip router   显示IP路由表信息
       Show ipx interface   显示Cisco IOS软件设置的IPX接口的状态以及每个接口中的参数
       Show ipx route   显示IPX路由选择表的内容
       Show ipx servers   显示IPX服务器列表
       Show ipx traffic   显示数据包的数量和类型
       Show isdn active   显示当前呼叫的信息,包括被叫号码、建立连接前所花费的时间、在呼叫期间使用的自动化操作控制(AOC)收费单元以及是否在呼叫期间和呼叫结束时提供AOC信息
       Show isdn ststus   显示所有isdn接口的状态、或者一个特定的数字信号链路(DSL)的状态或者一个特定isdn接口的状态
       Show memory   显示路由器内存的大小,包括空闲内存的大小
       Show processes   显示路由器的进程
       Show protocols   显示设置的协议
       Show protocols   显示配置的协议。这条命令显示任何配置了的第3层协议的状态
       Show running-config   显示RAM中的当前配置信息
       Show spantree   显示关于虚拟局域网(VLAN)的生成树信息
       Show stacks   监控和中断程序对堆栈的使用,并显示系统上一次重启的原因
       Show startup-config   显示NVRAM中的启动配置文件
       Show ststus   显示ISDN线路和两个B信道的当前状态
       Show version   显示系统硬件的配置,软件的版本,配置文件的名称和来源及引导映像
       Shutdown   关闭一个接口
       Telnet   开启一个telect连接
       Term ip   指定当前会话的网络掩码的格式
       Term ip netmask-format   规定了在show命令输出中网络掩码显示的格式
       Timers basic   控制着IGRP以多少时间间隔发送更新信息
       Trace   跟踪IP路由
       Username password   规定了在CHAP和PAP呼叫者身份验证过程中使用的密码
       Verify   检验flash文件
       Where   显示活动连接
       Which-route   OSI路由表查找和显示结果
       Write   运行的配置信息写入内存,网络或终端
       Write erase   现在由copy startup-config命令替换
       X3   在PAD上设置X.3参数
       Xremote   进入XRemote模式

    转载于:https://blog.51cto.com/winter82/194424

    展开全文
  • 思科路由器常用配置命令》学习笔记(更新中)

    千次阅读 多人点赞 2018-12-09 13:18:32
    router(config)#int s0 //进入接口配置模式 serial 0 端口配置(如果是模块化的路由器前面加上槽位编号,例如serial0/0 代表这个路由器的0槽位上的第一个接口) router(config-if)#ip address xxx.xxx.xxx.xxx xxx....

    1、视图模式介绍

    router> //用户模式
    router#  //特权模式,在普通模式下输入enable
    router(config)#  //全局模式,在特权模式下输入configure terminal
    router(config-if)# //接口视图,在全局模式下输入int 接口名称 例如 int s0 或 int e0
    router(config-route)# //路由协议视图,在全局模式下输入router 动态路由协议名称
    

    2、基本配置

    router>enable //进入特权模式
    router#configure terminal //进入全局配置模式
    router(config)#hostname xxx //设置设备名称
    router(config)#no ip domain-lookup //不允许路由器缺省使用DNS解析命令
    
    router(config)#enable password  //设置特权口令
    router(config)# Service password-encrypt //对所有在路由器上输入的口令进行暗文加密
    router(config)#line vty 0 4 //进入设置telnet服务模式
    router(config-line)#password xxx //设置telnet的密码
    router(config-line)#login //使能可以登陆
    router(config)#line con 0 //进入控制口的服务模式
    router(config-line)#password xxx //要设置console的密码
    router(config-line)#login //使能可以登陆
    

    3、接口配置

    router(config)#int s0 //进入接口配置模式 serial 0 端口配置(如果是模块化的路由器前面加上槽位编号,例如serial0/0 代表这个路由器的0槽位上的第一个接口)
    router(config-if)#ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx  //添加ip 地址和掩码
    router(config-if)#no shutdown //开启端口
    
    router(config-if)#enca hdlc/ppp 捆绑链路协议 hdlc 或者 ppp 思科缺省串口封装的链路层协议是HDLC所以在show run配置的时候接口上的配置没有,如果要封装为别的链路层协议例如PPP/FR/X25就是看到接口下的enca ppp或者enca fr
    router(config)#int loopback //建立环回口(逻辑接口)模拟不同的本机网段
    router(config-if)#ip add xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx  //添加ip 地址和掩码给环回口
    router(config-if)#no shutdown //在物理接口上配置了ip地址后用no shutdown启用这个物理接口反之可以用shutdown管理性的关闭接口
    

    4、静态路由配置

    router(config)#ip route xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx //下一条或自己的接口
    router(config)#ip route 0.0.0.0 0.0.0.0 s 0 //添加缺省路由
    

    5、RIP动态路由协议

    router(config)#router rip //启动rip协议
    router(config-router)#network xxx.xxx.xxx.xxx //宣告自己的网段
    router(config-router)#version 2 // 转换为rip 2版本
    router(config-router)#no auto-summary //关闭自动汇总功能,rip V2才有作用
    router(config-router)# passive-int 接口名 //启动本路由器的那个接口为被动接口
    router(config-router)# nei xxx.xxx.xxx.xxx //广播转单播报文,指定邻居的接ip
    

    6、IGRP动态路由协议

    igrp协议-----内部网关路由协议(IGRP:Interior Gateway Routing Protocol)
    router(config)#router igrp xxx //启动igrp协议
    router(config-router)#network xxx.xxx.xxx.xxx //宣告自己的网段
    router(config-router)#variance xxx //调整倍数因子,使用不等价的负载均衡
    

    7、EIGRP动态路由协议

    //eigrp---Enhanced Interior Gateway Routing Protocol(增强网关内部路由线路协议)
    router(config)#router eigrp xxx //启动协议
    router(config-router)#network xxx.xxx.xxx.xxx //宣告自己的网段
    router(config-router)#variance xxx //调整倍数因子,使用不等价的负载均衡
    router(config-router)#no auto-summary //关闭自动汇总功能
    router#show ip eigrp neighbors //查看eigrp协议的邻居表
    router#show ip eigrp top  //查看eigrp协议的拓朴表
    router#show ip eigrp interface //查看当前路由器运行eigrp协议的接口情况
    

    8、OSPF动态路由协议

    router(config)#router ospf xxx //启动协议启动一个OSPF协议进程
    router(config-router)#network xxx.xxx.xxx.xxx area xxx //宣告自己的接口或网段在ospf的区域中,可以把不同接口
    宣告在不同区域中
    router(config-router)#router-id xxx.xxx.xxx.xxx //配置路由的id
    router(config-router)#area xxx stub //配置xxx区域为末梢区域,加入这个区域的路由器全部要配置这个条命令
    router(config-router)#area xxx stub no-summary //配置xxx区域为完全末梢区域,只在ABR上配置
    router(config-router)#area xxx nssa //配置xxx区域为非纯末梢区域,加入这个区域的路由器全部要配置这个条命令
    router(config-router)#area xxx nssa no-summary  //配置xxx区域为完全非纯末梢区域,只在ABR上配置,并发布缺省路由信息进入这个区域内的路由器
    router#show ip ospf neighbor //查看当前路由器的ospf协议的邻居表
    router#show ip ospf interface //查看当前路由器运行ospf协议的接口情况
    router#clear ip ospf process //清楚当前路由器ospf协议的进程
    

    9、保存当前修改//运行的配置

    router#write //将RAM中的当前配置存储到NVRAM中,下次路由器启动就是执行保存的配置
    router#Copy running-config startup-config //命令与write效果一样
    

    10、exit命令:从接口、协议、line等视图模式下退回到全局配置模式,或从全局配置模式退回到特权模式

    router(config-if)#exit
    router(config)#
    router(config-router)#exit
    router(config)#
    router(config-line)#exit
    router(config)#
    router(config)#exit
    router#
    

    11、end命令:从任何视图直接回到特权模式

    router(config-if)#end
    router(config-router)#end
    router(config-line)#end
    router#
    

    12、注销和热启动命令

    router#Logout //退出当前路由器登陆模式相对与windows的注销
    router#reload //重新启动路由器(热启动)冷启动就是关闭路由器再打开电源开关
    

    13、查看当前路由表

    router#show ip route //查看当前的路由表
    router#clear ip route * //清除当前的路由表
    router#show ip protocol //查看当前路由器运行的动态路由协议情况
    router#show ip int brief //查看当前的路由器的接口ip地址启用情况
    router#show running-config //查看当前运行配置
    router#show startup-config //查看启动配置
    router#debug ip pack //打开ip报文的调试
    router#terminal monitor //输出到终端上显示调试信息
    router#Show interfaces //显示设置在路由器和访问服务器上所有接口的统计信息. 显示路由器上配置的所有接口的状态
    router#Show interfaces serial //显示关于一个串口的信息
    router#Show ip interface //列出一个接口的IP信息和状态的小结, 列出接口的状态和全局参数
    

    14、show命令

    router#show running config //显示所有的配置
    router#show versin //显示版本号和寄存器值
    router#show interface+接口类型+接口号 //查看接口管理性
    router#show controllers interface //查看接口是否有 DCE 电缆
    router#show history //查看历史记录
    router#show terminal //查看终端记录大小
    router#show ip interface brief //查看接口的谪要信息
    router#show spamming-tree vlan +vlan号 //查看 VLAN生成树议
    

    15、接口配置

    shutdown //关闭接口
    no shutdown //打开接口
    ip add +ip地址 //配置 IP 地址
    secondary+IP地址 //为接口配置第二个 IP 地址
    hostname+主机名 //配置路由器或交换机的标识
    config memory //修改保存在 NVRAM 中的启动配置
    exec timeout 0 0 //设置控制台会话超时为 0
    no ip address //删除已配置的 IP 地址
    

    16、密码设置

    service password-encryptin //手工加密所有密码
    enable password +密码 //配置明文密码
    ena sec +密码 //配置密文密码
    line vty 0 4/15 //进入 telnet 接口
    password +密码 //配置 telnet 密码
    line aux 0 //进入 AUX 接口
    password +密码 //配置密码
    line con 0 //进入 CON 接口
    password +密码 //配置密码
    bandwidth+数字 //配置带宽
    

    17、在Cisco设备上修改控制端口密码

    R1(config)# line console 0
    R1(config-line)# login
    R1(config-line)# password Lisbon
    R1(config)# enable password Lilbao
    R1(config)# login local
    R1(config)# username student password cisco
    

    18、在Cisco设备上设置控制台及vty端口的会话超时

    R1(config)# line console 0
    R1(config-line)# exec-timeout 5 10
    R1(config)# line vty 0 4
    R1(config-line)# exec-timeout 5 2
    

    19、NVRAM

    show startup config 查看 NVRAM 中的配置信息
    copy run-config atartup config 保存信息到 NVRAM
    write 保存信息到 NVRAM
    erase startup-config 清除 NVRAM 中的配置信息
    description+信息 配置接口听描素信息
    

    19、三层交换机配置命令

    Switch# configure terminal
    Switch(config)# vlan 20
    Switch(config-vlan)# name test20
    Switch(config-vlan)# end
    
    Switch# vlan database
    Switch(vlan)# vlan 20 name test20
    Switch(vlan)# exit
    
    Switch# configure terminal
    Switch(config)# interface fastethernet0/1
    Switch(config-if)# switchport mode access
    Switch(config-if)# switchport access vlan 2
    Switch(config-if)# end
    Switch#
    
    Switch# configure terminal
    Switch(config)# interface fastethernet0/4
    Switch(config-if)# switchport mode trunk
    Switch(config-if)# switchport trunk encapsulation dot1q
    Switch(config-if)# end
    
    Switch(config)# interface fastethernet0/1
    Switch(config-if)# switchport trunk allowed vlan remove 2
    Switch(config-if)# end
    
    展开全文
  • Access-enable 允许路由器在动态访问列表中创建临时访问列表入口 Access-group 把访问控制列表(ACL)应用到接口上 Access-list 定义一个标准的IPACL Access-template 在连接的路由器上手动替换临时访问列表入口 ...
    Access-enable  允许路由器在动态访问列表中创建临时访问列表入口 

       Access-group  把访问控制列表(ACL)应用到接口上 

       Access-list  定义一个标准的IP ACL 

       Access-template  在连接的路由器上手动替换临时访问列表入口 

       Appn  向APPN子系统发送命令 

       Atmsig   执行ATM信令命令 

       B   手动引导操作系统 

       Bandwidth   设置接口的带宽 

       Banner motd   指定日期信息标语 

       Bfe   设置突发事件手册模式 

       Boot system   指定路由器启动时加载的系统映像 

       Calendar   设置硬件日历 

       Cd   更改路径 

       Cdp enable   允许接口运行CDP协议 

       Clear   复位功能 

       Clear counters   清除接口计数器 

       Clear interface   重新启动接口上的件逻辑 

       Clockrate   设置串口硬件连接的时钟速率,如网络接口模块和接口处理器能接受的速率 

       Cmt   开启/关闭FDDI连接管理功能 

       Config-register   修改配置寄存器设置 

       Configure   允许进入存在的配置模式,在中心站点上维护并保存配置信息 

       Configure memory   从NVRAM加载配置信息 

       Configure terminal   从终端进行手动配置 

       Connect   打开一个终端连接 

       Copy   复制配置或映像数据 

       Copy flash tftp   备份系统映像文件到TFTP服务器 

       Copy running-config startup-config   将RAM中的当前配置存储到NVRAM 

       Copy running-config tftp   将RAM中的当前配置存储到网络TFTP服务器上 

       Copy tftp flash   从TFTP服务器上下载新映像到Flash 

       Copy tftp running-config   从TFTP服务器上下载配置文件 

       Debug   使用调试功能 

       Debug dialer   显示接口在拨什么号及诸如此类的信息 

       Debug ip rip   显示RIP路由选择更新数据 

       Debug ipx routing activity   显示关于路由选择协议(RIP)更新数据包的信息 

       Debug ipx sap   显示关于SAP(业务通告协议)更新数据包信息 

       Debug isdn q921   显示在路由器D通道ISDN接口上发生的数据链路层(第2层)的访问过程 

       Debug ppp   显示在实施PPP中发生的业务和交换信息 

       delete   删除文件 

       Deny   为一个已命名的IP ACL设置条件 

       Dialer idle-timeout   规定线路断开前的空闲时间的长度 

       Dialer map   设置一个串行接口来呼叫一个或多个地点 
    Dialer wait-for-carrier-time   规定花多长时间等待一个载体 

       Dialer-group   通过对属于一个特定拨号组的接口进行配置来访问控制 

       Dialer-list protocol   定义一个数字数据接受器(DDR)拨号表以通过协议或ACL与协议的组合来控制控制拨号 

       Dir   显示给定设备上的文件 

       Disable   关闭特许模式 

       Disconnect   断开已建立的连接 

       Enable   打开特许模式 

       Enable password   确定一个密码以防止对路由器非授权的访问 

      Enable password   设置本地口令控制不同特权级别的访问 

       Enable secret   为enable password命令定义额外一层安全性 (强制安全,密码非明文显示) 

       Encapsulation frame-relay   启动帧中继封装 

       Encapsulation novell-ether   规定在网络段上使用的Novell独一无二的格式 

       Encapsulation PPP   把PPP设置为由串口或ISDN接口使用的封装方法 

       Encapsulation sap   规定在网络段上使用的以太网802.2格式Cisco的密码是sap 

       End   退出配置模式 

       Erase   删除闪存或配置缓存 

       Erase startup-config   删除NVRAM中的内容 

       Exec-timeout   配置EXEC命令解释器在检测到用户输入前所等待的时间 

       Exit   退出所有配置模式或者关闭一个激活的终端会话和终止一个EXEC 

       Exit   终止任何配置模式或关闭一个活动的对话和结束EXEC 

       format   格式化设备 

       Frame-relay local-dlci   为使用帧中继封装的串行线路启动本地管理接口(LMI) 

       Help   获得交互式帮助系统 

       History   查看历史记录 

       Hostname   使用一个主机名来配置路由器,该主机名以提示符或者缺省文件名的方式使用 

       Interface   设置接口类型并且输入接口配置模式 

       Interface   配置接口类型和进入接口配置模式 

       Interface serial   选择接口并且输入接口配置模式 

       Ip access-group   控制对一个接口的访问 

       Ip address   设定接口的网络逻辑地址 

       Ip address   设置一个接口地址和子网掩码并开始IP处理 

       Ip default-network   建立一条缺省路由 

       Ip domain-lookup   允许路由器缺省使用DNS 

       Ip host   定义静态主机名到IP地址映射 

       Ip name-server   指定至多6个进行名字-地址解析的服务器地址 

       Ip route   建立一条静态路由 

       Ip unnumbered   在为给一个接口分配一个明确的IP地址情况下,在串口上启动互联网协议(IP)的处理过程 

    转载于:https://blog.51cto.com/491985yuan/163364

    展开全文

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 9,478
精华内容 3,791
关键字:

思科路由器常用配置