精华内容
下载资源
问答
  • 在做路由图实验时候因为TOPU中设计到路由的均衡负载,如: |---R3--------| R1--R2-| R5 |---R4--------| 其中启用RIP路由协议,一切就绪,且R2路由表到R5的路由也是两条。 在R1上tracertoute命令会发现,...

    在做路由图实验时候因为TOPU中设计到路由的均衡负载,如:
                |---R3--------|
         R1--R2-|             R5
                |---R4--------|

    其中启用RIP路由协议,一切就绪,且R2路由表到R5的路由也是两条。
    在R1上tracertoute命令会发现,它一直走R3;
    在R1上开两个Loop口,L1为源地址的时候就走R3,L2为源地址的时候就走R4
    猛然想起路由器实现均分负载的时候有个cache的什么东西会记录上一次转发情况从而实现快速转发。
    赶紧查资料,哦~Cisco路由器在缺省情况下为快速交换(Fast Switching)模式,路由器将使用这种负载均衡方式。

    快速交换(Fast Switching):当路由器为第一个去往特定目标的报文进行交换处理时,路由器将执行路由路由表查询并选择出站接口。然后获取有关被选接口的数据链路信息(如从ARP表),这些信息对成帧是必须的,最后封装报文并发送。前面获取的路由和数据链路信息被输入到快速交换的高速缓存中,一旦有源地址一样且去往想通目标的数据包进入路由器,则不再查找路由表和ARP高速缓存,而是立即交换报文。
    在端口中使用命令“no ip route-cache”关闭快速交换,改为过程交换(Process Switching:即每次转发
        看作一个过程,单独要执行全部转发所需手续。)

    转载于:https://blog.51cto.com/1291834/730550

    展开全文
  • Cisco路由器下线路负载均衡技术的实现.pdf
  • HSRP负载均衡的配置By Jackie on March 20, 2009 4:45 PM |1 Comment | Previous | Next | EDITHSRP负载均衡的实验拓扑:HSRP负载均衡的实验要求: R1、R3上...要求实现2组负载均衡:R1作为HSRP组1的Active路由器虚 ...

    HSRP负载均衡的配置

    | 1 Comment | Previous | Next | EDIT
    HSRP负载均衡的实验拓扑:
    HSRP, 负载均衡, 实验拓扑, 拓扑
    HSRP负载均衡的实验要求:
         R1、R3上分别做NAT,使得内网的PC能够访问外网,并在此基础上实现HSRP。要求实现2组负载均衡:R1作为HSRP组1的Active 路由器虚 拟IP为:172.20.10.100. 并且作为HSRP组2的standby 路由器虚拟IP为172.20.10.200. 同理:R2作为HSRP组1的standby路由器虚拟IP为:172.20.10.100. 并且作为HSRP组2的Active路由器虚拟IP为172.20.10.200. 此外设置:PC1的默认网关为:172.20.10.100. PC2的默认网关为:172.20.10.200。
          R1上的配置:
          先是配置R1上的默认路由,访问控制列表以及NAT的配置:
    R1(config)#ip route 0.0.0.0 0.0.0.0 s0/1
    R1(config)#access-list 1 permit any
    R1(config)#ip nat inside source list 1 interface s0/1
    R1(config)#int f1/0
    R1( config-if)#ip nat i
    R1(config-if)#int s0/1
    R1(config-if)#ip nat o
    R1(config-if)#end
          R1上的HSRP的配置:
    R1(config)#int f1/0
    R1(config-if)#standby 1 ip 172.20.10.100
    R1(config-if)#standby 1 priority 105
    R1(config-if)#standby 1 preempt
    R1(config-if)#standby 1 track s0/1
    R1(config-if)#standby 2 ip 172.20.10.200
    R1(config-if)#standby 2 priority 95
    R1(config-if)#standby 2 preempt
    R1(config-if)#standby 2 track s0/1
    R1(config-if)#end
          R3上的默认路由和访问控制列表以及NAT的配置:
    R3(config)#ip route 0.0.0.0 0.0.0.0 s0/2
    R3(config)#access-list 1 permit any
    R3(config)#ip nat inside source list 1 interface s0/2
    R3(config)#int s0/2
    R3(config-if)#ip nat o
    R3(config-if)#int f1/0
    R3(config-if)#ip nat i
    R3(config-if)#end
          R3上的HSRP的配置:
    R3(config)#int f1/0
    R3(config-if)#standby 1 ip 172.20.10.100
    R3(config-if)#standby 1 priority 95
    R3(config-if)#standby 1 preempt
    R3(config-if)#standby 1 track s0/2
    R3(config-if)#standby 2 ip 172.20.10.200
    R3(config-if)#standby 2 priority 105
    R3(config-if)#standby 2 preempt
    R3(config-if)#standby 2 track s0/2
    R3(config-if)#end
          实验的验证:
          在R1上sh standby的显示:
    R1#sh standby
    FastEthernet1/0 - Group 1
    State is Active
        2 state changes, last state change 00:29:03
    Virtual IP address is 172.20.10.100
    Active virtual MAC address is 0000.0c07.ac01
        Local virtual MAC address is 0000.0c07.ac01 (default)
    Hello time 3 sec, hold time 10 sec
        Next hello sent in 2.836 secs
    Preemption enabled
    Active router is local
    Standby router is 172.20.10.253, priority 95 (expires in 8.972 sec)
    Priority 105 (configured 105)
        Track interface Serial0/1 state Up decrement 10
    IP redundancy name is "hsrp-Fa1/0-1" (default)
    FastEthernet1/0 - Group 2
    State is Standby
        4 state changes, last state change 00:28:52
    Virtual IP address is 172.20.10.200
    Active virtual MAC address is 0000.0c07.ac02
        Local virtual MAC address is 0000.0c07.ac02 (default)
    Hello time 3 sec, hold time 10 sec
        Next hello sent in 1.184 secs
    Preemption enabled
    Active router is 172.20.10.253, priority 105 (expires in 9.172 sec)
    Standby router is local
    Priority 95 (configured 95)
        Track interface Serial0/1 state Up decrement 10
    IP redundancy name is "hsrp-Fa1/0-2" (default)
          PC1上traceroute 2.2.2.2的显示:
     1 172.20.10.252 104 msec 104 msec 76 msec
    2 12.12.12.2 136 msec *  140 msec
          当断开R1上的F1/0口后再traceroute 2.2.2.2的显示:
     1 172.20.10.253 156 msec 104 msec 68 msec
    2 23.23.23.2 68 msec *  40 msec
          在实验的时候,PC1的网关是172.20.10.100,PC2的网关是172.20.10.200,使用的都是虚拟网关。
          根据本实验的例子,当S0/1down掉之后,standby 1 的优先级会减10,此时和在R3上的优先级一样,但是R1上还是active,因为 抢占是在优先级不一样的时候才有效,当优先级一样的情况下,原来哪个是active的,还是active,就像本实验一样,当s0/1down之后,对PC1来说,active的还是R1,但是R1上的s0/1端了,所以还是ping不通的。 当hsrp刚启动的时候,加入R1和R3上的优先级一样,那么就会比IP地址,因为R3上的的F1/0端口的IP比R1上的F1/0要高,所以此时会选择R3会active
          当R1上的s0/1上断了之后,在R1上的standby 1和standby 2都会减小10,如果此时你在上面配 standby 1 priority 150,但是在show standby brief中显示是140。
          当下面的网络有VLAN的时候,网关路由器又是单臂路由器,我们可以在子接口下配置HSRP,此时一个子接口只能通过一个网段,以此图为例,R1上的.10子接口和R3上的.10子接口进行冗余,R1上的.20子接口和R3上的.20子接口进行冗余。


    转载于:https://blog.51cto.com/cisco130/1224821

    展开全文
  • 思科路由器配置ospf等价负载均衡

    千次阅读 2011-08-04 13:52:56
    R5; enable config t hostname R5 int s1/1 ip add 192.168.56.1 255.255.255.0 no shutdown exit int s1/2 ip add 192.168.57.1 255.255.255.0 no shutdown exit router ospf 100 ...ne...

     

     

    R5;
    enable
    config t
    hostname R5
    int s1/1
    ip add 192.168.56.1 255.255.255.0
    no shutdown
    exit
    int s1/2
    ip add 192.168.57.1 255.255.255.0
    no shutdown
    exit
    router ospf 100
    network 192.168.57.0 0.0.0.255 area 0
    network 192.168.56.0 0.0.0.255 area 0
    end

    R6:

    enable
    config t
    hostname R6
    int s1/0
    ip add 192.168.56.2 255.255.255.0
    no shutdown
    exit
    int s1/2
    ip add 192.168.67.1 255.255.255.0
    no shutdown
    exit
    router ospf 100
    network 192.168.56.0 0.0.0.255 area 0
    network 192.168.67.0 0.0.0.255 area 0
    end

    R7

    enable
    config t
    hostname R7
    int s1/4
    ip add 192.168.57.2 255.255.255.0
    no shutdown
    exit
    int s1/5
    ip add 192.168.67.2 255.255.255.0
    no shutdown
    exit
    router ospf 100
    network 192.168.57.0 0.0.0.255 area 0
    network 192.168.67.0 0.0.0.255 area 0
    end


     

     

    转载于:https://blog.51cto.com/sdqaurora/631011

    展开全文
  • cisco 负载均衡实验

    2013-02-21 18:36:37
    cisco 交换机 路由器负载均衡实验
  • 思科端口负载均衡

    2013-06-26 16:58:54
    思科负载均衡技术,交换机配置、负载调优
  • 好久没有cisco了, 有些知识点都忘记了, 利用Cisco路由器做双光纤线路冗余,负载均衡,是很早以前做过的,那个时候是热点 ,现在不知怎样了 , 不管怎样 , 希望对关注这块的朋友,有些许的帮助。 以下为简单的...

           好久没有cisco了, 有些知识点都忘记了, 利用Cisco路由器做双光纤线路冗余,负载均衡,是很早以前做过的,那个时候是热点 ,现在不知怎样了 , 不管怎样 , 希望对关注这块的朋友,有些许的帮助。

          以下为简单的网络图:
         


           以下为路由器配置:
    ######################################################
    Router#show run
    Building configuration...
    Current configuration : 1664 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    no aaa new-model
    memory-size iomem 5
    ip cef
    !

    no ip domain lookup
    !
    multilink bundle-name authenticated
    !
    !
    !
    track 111 rtr 1 reachability
    !
    track 222 rtr 2 reachability
    !
    !
    !
    interface FastEthernet0/0
    ip address 59.x.x.195 255.255.255.248
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 61.x.x..2 255.255.255.252
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    interface FastEthernet1/0
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    ip route 0.0.0.0 0.0.0.0 59.x.x.193 track 111
    ip route 0.0.0.0 0.0.0.0 61.x.x.1 track 222
    !
    !
    ip http server
    no ip http secure-server
    ip nat inside source route-map 163 interface FastEthernet0/1 overload
    ip nat inside source route-map cn2 interface FastEthernet0/0 overload
    !
    ip access-list extended allip
    permit ip any any
    !
    ip sla 1
    icmp-echo 59.x.x.193
    timeout 1200
    frequency 3
    ip sla schedule 1 life forever start-time now
    ip sla 2
    icmp-echo 61.x.x.1
    timeout 1200
    frequency 3
    ip sla schedule 2 life forever start-time now
    access-list 1 permit 59.x.x.193
    access-list 2 permit 61.x.x.1
    !
    !
    route-map 163 permit 10
    match ip address allip
    match ip next-hop 2
    !
    route-map cn2 permit 10
    match ip address allip
    match ip next-hop 1
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end
    Router#
    #######################################################
    可以实现负载均衡,在一条线断掉后,所有流量走另外一根线 ,实现冗余。

    转载于:https://blog.51cto.com/terryyw/387006

    展开全文
  • 总结:我的上一篇文章《NAT转换实验过程详解》的考核点是如何把内部源地址(source)转换为外部全局地址(发起方通常是内部),以实现内部PC通过一个公网IP共同上网,今天的实验《路由器NAT负载均衡实验过程详解》...
  • Cisco路由器转发数据包时常用的五种交换方式进程交换(Process Switching)这是一种最基本的交换模式,在这种模式下,一条数据流(Flow)中的第一个包(Packet)将被置入系统缓存(System Buffer)。其目的地址将会拿到...
  • 思科路由器配置ospf等价负载均衡 2011-08-04 13:52:56 标签:ospf 思科路由器 思科 路由器 R5; enable config t hostname R5 int s1/1 ip add 192.168.56.1 255.255.255.0 no shutdown exit ...
  • cisco负载均衡

    2013-04-27 23:38:51
    1.负载均衡的介绍 软/硬件负载均衡 软件负载均衡解决方案,是指在一台或多台服务器相应的操作系统上,安装一个或多个附加软件来实现负载均衡,如DNS 负载均衡等。它的优点是基于特定环境、配置简单、使用灵活、...
  • CISCO NAT负载均衡

    千次阅读 2014-03-16 01:48:28
    下面以实例介绍一下Cisco路由器NAT负载均衡的配置:  现有一台有一个串行接口和一个Ethernet接口的路由器,Ethernet口连接到内部网络,内部网络上有三台web服务器,但都只是低端配置,为了处理好来自Internet上...
  • 思科设备负载均衡配置(热备份)

    千次阅读 2018-04-09 22:51:40
    3560_1(config)#interface range g1/1-2 //进入接口组 g1g2(千兆接口)3560_1(config-if)#switch trunk enc dot1q //(g1g2)接口封装模式设置802.1q3560_1(config-if)#switch mode trunk //(g1g2)接口模式...
  • 一、Cisco路由器转发数据包时常用的五种交换方式 (1) 进程交换(Process Switching) 这是一种最基本的交换模式,在这种模式下,一条数据流(Flow)中的第一个包(Packet)将被置入系统缓存(System Buffer)。其目的地址...
  • 我们都知道思科路由器NAT是用来转换ip地址的,但是很少有人知道Cisco路由器是采用哪种转换方式,只认为它可以采用非注册ip地址转换成注册的公网地址。这其实是很片面的,NAT不仅可以把一个或者多个内部网络IP地址...
  • 以下信息描述解决,Cisco 2600 cpu高负载的问题,查看高负载的命令如下: arp-wuke#sh processes cpu sorted | exclude 0.00 CPU utilization for five seconds: 99%/44%; one minute: 99%; five minutes: 99% P...
  • VRRP负载均衡模式在VRRP提供的虚拟网关冗余备份功能基础上,增加了负载均衡功能。其实现原理为:将一个虚拟IP地址与多个虚拟MAC地址对应,VRRP备份组中的每个路由器都对应一个虚拟MAC地址,使得每个路由器都能转发...
  • 支持LAN/WAN切换,负载均衡默认双WAN口,支持LAN/WAN切换,便于多运营商接入,提高出口上网速率,最多支持4个WAN口。支持负载均衡,可以让用户根据线路实际带宽分配网络流量,达到充分利用带宽的目的。...
  • Web负载均衡

    2018-06-01 10:51:00
    摘要:负载均衡(Load Balance)是集群技术(Cluster)的一种应用。负载均衡可以将工作任务分摊到多个处理单元,从而提高并发处理能力。目前最常见的负载均衡应用是Web负载均衡。根据实现的原理不同,常见的web负载...
  • 负载均衡

    2017-04-03 17:05:45
    负载均衡(Load Balance) 定义:将大量的并发请求分担到多个处理节点。由于单个处理节点的故障不影响整个服务,负载均衡集群同时也实现了高可用性。 原理:任何的负载均衡技术都要想办法建立某种一对多的映射机制...
  • 0x00概要 负载均衡(Load Balance)是集群技术...根据实现的原理不同,常见的web负载均衡技术包括:DNS轮询、IP负载均衡和CDN。其中IP负载均衡可以使用硬件设备或软件方式来实现。 0x01什么是web负载均衡 服...
  • EIGRP负载均衡

    千次阅读 2018-03-26 22:39:59
    EIGRP负载均衡 等价负载均衡 非等价负载均衡 EIGRP负载均衡 EIGRP可以使用通往同一个目的网络的多条路径发送流量,从而增加贷款,这叫做负载均衡。EIGRP支持在相同开销的路径上进行等价负载均衡和在不同...
  • 文章目录路由器通过路由表转发数据一、路由表内容二、路由分组转发过程路由器在网络中所扮演的角色路由器说明路由器和交换机的一些主要区别特征路由器的硬件组成路由器的两大功能介绍路由表中路由的生成方式为了路由...
  • 负载均衡器可以根据实际的响应时间制定优先级交付决策,从而实现高性能、智能化流量管理,达到最佳的服务器群性能。采用第七层应用控制还可以减少通信高峰期的错误讯息,因为差错控制和流量管理技术可以侦测到一些...
  • 现代网络负载均衡与代理 什么是网络负载均衡与代理? 负载均衡 vs 代理 L4(连接 /session)负载均衡 L7(应用层)负载均衡 L7 负载均衡和 OSI 模型 负载均衡器的功能 服务发现 健康检查 负载均衡 粘性 session...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 6,383
精华内容 2,553
关键字:

思科路由器负载均衡