精华内容
下载资源
问答
  • 然后用命令ip address x.x.x.x x.x.x.x配置IP地址。具体命令如下:Router2800>enable (进入特权模式)Router2800#configure termial (进入全局配置模式)Router2800(config)#int f0/1 (进入接口配置模式)Router2800...

    配置路由器IP地址

    然后用命令ip address x.x.x.x x.x.x.x配置IP地址。具体命令如下:
    Router2800>enable (进入特权模式)
    Router2800#configure termial (进入全局配置模式)
    Router2800(config)#int f0/1 (进入接口配置模式)
    Router2800(config-if)#ip address 192.168.0.1 255.255.255.0 (为接口分配IP地址和掩码)
    Router2800(config-if)#no shutdown (启用接口)
    Router2800(config-if)#ex (退出接口模式)

    远程登录配置

    首先路由器要设置远程登录密码(在被远程的路由器上设置)
    line vty 0 4 (允许5台设备登录)
    passwork +密码
    login
    其次全局模式下也要键入配置密码
    enable password +密码 (这个密码不安全)

    最后才能实现远程登录
    telnet + 远程登录的地址

    如果要设置一个安全的密码,如下

    R2# en
    R2#conf t
    R2(config)#enable secret 密码

    转载于:https://blog.51cto.com/13242922/2062304

    展开全文
  • 思科路由器配置

    2013-10-16 21:47:55
    路由器接口配置另一篇博文 思科交换机的配置基础 中有一些基础的操作前言交换机总体而言是用于同一网段内...路由器接口Ipv4地址配置R1#show ip interface briefR1#config terminalR1(config)#interface f0/0R1(confi...

    路由器接口配置

    另一篇博文 思科交换机的配置基础 中有一些基础的操作

    前言

    交换机总体而言是用于同一网段内转发数据通信,而路由器则是用来在不同子网或网络间路由,转发数据包,所以路由器要连接多个子网或网络。

    路由器接口Ipv4地址配置

    R1#show ip interface brief

    R1#config terminal

    R1(config)#interface f0/0

    R1(config-if)#ip address 172.16.2.1 255.255.0.0

    R1(config-if)#no shutdown

    R1(config-if)#end

    R1#copy running-config startup-config

    214237861.png

    路由器接口从IP地址的配置步骤

    R1(config)#interface f0/0

    R1(config-if)#ip address 172.16.2.1 255.255.0.0

    R1(config-if)#ip address 172.16.3.1 255.255.0.0 secondary

    R1(config-if)#end

    214238137.png

    无编号IP地址的配置步骤

    如果子网或者网络IP地址数量有限,而在网络中又有点对点WAN连接,这时可以使用无编号IP接口功能来在点对点WAN接口(如路由器的串行接口)启用IP连接,借用其他物理接口的IP地址,无需实际地为这些点对点连接的WAN接口分配IP地址。这样就相当于多个接口共享IP地址,而且可以是多个无编号IP地址接口共享一个IP地址。

    无编号IP地址功能的应用将受到以下限制:

    无编号IP地址功能仅支持点对点接口,不支持以太网接口和帧中继,X.25等这类多路访问接口。

    不能通过使用无编号IP地址功能来网络启动Cisco IOS映像

    R2#show ip interface brief

    R2#config terminal

    R2(config)#interface f0/0

    R2(config-if)#ip address 172.16.2.1 255.255.0.0

    R2(config-if)#no shutdown

    R2(config-if)#exit

    R2(config)#interface s0/0

    R2(config-if)#ip unnumbered f0/0

    R2(config-if)#no shutdown

    R2(config-if)#end

    31位地址前缀的IP地址配置步骤

    通过在点对点WAN接口上使用31位地址前缀的IP地址可减少路由器建立IP网络连接所使用的IP子网数量,因为它可以充分利用每个子网中的每一个IP地址。因为在默认情况下,当地址前缀也就是网络ID为31位时,主机ID就只有一位。这时就仅有两个IP地址,即主机ID为0,或者主机ID为1.而在这种情况下,这两个IP地址就相当于子网的网络地址和广播地址,默认是不能分配给设备使用的,在一定程度上说是一种IP地址资源的浪费。

    在为点对点接口配置带有31位地址前缀的IP地址前,必须在设备上配置无类别IP地址,也就是CIDR

    R2#config terminal

    R2(config)#ip classless

    R2(config)#interface s0/1

    R2(config-if)#ip address 192.168.100.2 255.255.255.254

    R2(config-if)#no shutdown


    查看路由器当前连接的网络

    R2#show ip route connected

    C 172.16.0.0/16 is directly connected,FastEthernet0/0


    无分类编址

    (待续)

    全零子网的配置步骤

    在IOS12.0版本以后版本默认可以全面使用全0和全1子网,在12.0以前版本,必须配置

    IP subnet-zero 全局配置命令。

    R2(config)#ip subnet-zero

    R2(config)#interface f0/1

    R2(config-if)#interface f0/1

    R2(config-if)#ip address 172.20.15.1 255.255.240.0

    R2(config-if)#no shutdown

    214239371.png


    CISCO路由器几种特殊接口配置

    Loopback接口

    Loopback接口是一个虚拟接口,通常为它分配的是路由器的管理IP地址,提供默认路由信息。可以通过该接口IP远程Telnet登陆来管理路由器。因为它是虚拟接口,只要IOS系统不失效,它就呈激活状态,每个路由器至少可以创建一个Loopback接口。

    Loopback接口主要用于以下几种情况:

    用于模拟实验:

    我们在进行路由器模拟实验时通常是在一台路由器上创建多个Loopback接口,然后为每个Loopback接口分配一个不同网段的IP地址(通常还是直接使用32位子网掩码的IP地址分配方式,如1.1.1.1255.255.255.255)。这样就相当于在该路由器上连接了多个不同网络,可以模拟实际连接多个物理网络的情形与其他路由器间进行各种路由配置。

    作为一台路由器的管理地址

    作为OSPF,BGP的路由器ID

    动态路由协议OSPF,BGP在运行过程中需要指定一个Router-ID作为此路由器的唯一标识,并要求在整个自制系统内唯一。由于路由器ID是一个32位的无符号整数,这一点与IP地址十分相像。而且在同一个网络中,IP地址是不会出现重复现象的,所以通常将IP地址作为路由器的Router-ID(通常是采用IP地址最大的Loopback接口IP地址作为Router-ID),但实际上所取得的作用并不是IP地址作用。

    作为BGP建立TCP连接的源地址

    在BGP协议中,两个运行BGP的路由器之间建立连接关系是通过TCP建立连接完成的。在配置邻居时通常指定Loopback接口作为与邻居路由器间建立TCP连接的源地址。


    虚拟模板接口(Virtual-Template)

    http://www.yesky.com/66/79066.shtml


    Router(config)# interface loopback 0

    Router(config-if)# ip address 10.10.10.100 255.255.255.0

    Router(config-if)# ip nat outside

    Router(config-if)# exit

    Router(config)# interface Virtual-Template 1

    Router(config-if)# ip unnumbered loopback0

    Router(config-if)# no ip directed-briadcast

    Router(config-if)# ip nat outside

    Router# show ip interface loopback 0


    配置NULL接口

    NULL接口是一个虚拟接口,永远呈活跃状态,不能配置IP地址,也不转发路由通信,而是把所有到达它的数据包丢弃,一个路由器只有一个空接口null0

    在NULL接口上,仅可以使用IPunreachables 命令来进行配置,使它产生ICMP不可达消息,其他大多数命令都不能在这个接口上配置。如果空接口接收到一个不可识别的非广播包,它将发送ICMP不可达消息到包发送源。如果空接口接收到一个因为没有适当路由,不能传递到最终目的地的包,它将以一个ICMP主机不可达消息响应发送源。

    Router# config terminal

    Router(config)# interface null 0

    Router(config-if)# ipv4 unreachable

    Router(config-if)# end

    Router#show interface null 0


    配置子接口

    子接口是一个物理接口(包括串行接口和以太网接口)的逻辑表现形式。物理接口成为父接口。一个父接口可以配置多个子接口,而且各子接口是相互独立的。这些虚拟子接口共用一个物理接口的物理层参数,又可以分别配置各自的链路层和网络层的参数。子接口只支持三层转发,不支持二层转发,同一个父接口下的不同子接口按照802.1q值进行区分(同一个物理接口的不同子接口的802.1q标记必须不同),可以配置不同网段的IP地址和子网掩码。子接口在路由器或三层交换机上的单臂路由中应用广泛。子接口号的标记是在父接口号后通过小圆点(.)然后带一个子接口号,如f0/0.1 ,

    s0/0.1


    Router#config terminal

    Router#interface f0/1.1

    Router(config-subif)#ip address 192.168.1.1 255.255.255.0

    Router#interface f0/0.2

    Router(config-subif)#ip address 192.168.2.1 255.255.255.0


    单臂路由配置


    配置Tunnel接口

    路由器借助Tunnel接口实现隧道功能,允许利用传输协议(如IP)来传送任意协议的网络数据包。同其他逻辑接口一样,Tunnel接口也是系统虚拟的接口。Tunnel接口并不特别指定传输协议或负载协议,它提供的是一个用来实现标准的点对点的传输模式。由于Tunnel实现的是点对点的传输链路,所以,对于每一个单独的链路必须设置一个Tunnel接口。

    Tunnel传输适合于以下情况:

    允许运行非IP协议的本地网络之间通过一个单一的网络(IP网络)通信,因为Tunnel支持多种不同的负载协议。允许通过单一的网络(IP网络)连接间断子网。

    允许在广域网上提供×××(virtual private network)功能.。

    Tunnel接口配置操作如下。


    第1步 创建Tunnel接口并进入该接口的配置模式。

    Router(config)#interface tunneltunnel-number

    或者,删除已创建的Tunnel接口

    Router(config)#no interface tunneltunnel-number


    第2步 设置Tunnel接口的源地址。一个Tunnel接口需要明确配置隧道的源地址和目的地址,为了保证隧道接口的稳定性,一般将Loopback地址作为隧道的源地址和目的地址。在tunnel接口正常工作之前,需要确认源地址和目的地址的连通性。

    Router(config-if)#tunnel source {ip-address |interface-name interface-number}

    或者,取消Tunnel接口源地址设置。

    Router(config-if)#no tunnel source


    第3步 设置Tunnel接口目的地址

    Router(config-if)#tunnel destination {ip-address |host-name}

    或者取消Tunnel接口目的地址设置

    Router(config-if)#no tunnel destination


    第4步 设置Tunnel封装格式。Tunnel的封装格式就是Tunnel的载体协议。Tunnel接口的默认封装格式是GRE,当然,用户也可以根据实际使用情况来决定Tunnel接口的封装格式

    Router(config-if)#tunnel mode {dvmrp |gre|ipip |nos}

    或者,取消Tunnel接口封装格式设置,恢复默认值

    Router(config-if)#no tunnel mode


    第5步 设置Tunnel校验。有些情况下,需要使用Tunnel校验来提供数据完整性的保证。默认情况下,Tunnel接口不进行校验。

    Router(config-if)#tunnel checksum

    或者,取消Tunnel校验

    Router(config-if)#no tunnel checksum


    第6步 设置Tunnel接口的Key。设置Tunnel接口的Key在一定程度上可以确保Tunnel两端的安全性,同时也可以防范来自外部的恶意探测和***。只有在Tunnel封装格式为GRE的情况下,Tunnel接口的Key设置才起作用,因为此时在每一个GRE数据包中都会包含设置的Tunnel接口Key。

    Router(config-if)#tunnel key key-value

    或者,取消Tunnel接口的Key设置

    Router(config-if)#no tunnel key key-value


    第7步 设置Tunnel接收规则

    如果负载协议在维护数据包有序方面的功能不足(比如基于LLC2的协议)路由器允许设置Tunnel接收规则来丢弃接收到的无序数据包。这项设置将有助于实现网络数据包的有序传输。

    Router(config-if)#tunnel sequence-datagrams

    或者,unnel按序接收设置

    Router(config-if)#no tunnel sequence-datagrams


    第8步 返回至特权模式。

    Router(config-if)#end


    监视Tunnel接口

    Router#show interface tunnel tunnel-number


    打开Tunnel调试开关

    Router#debug tunnel

    关闭 Tunnel调试开关

    Router#no debug tunnel


    配置同步串行接口

    由于同步串行接口广泛应用于与其他网络的高速连接,因此往往是路由器必备的接口类型

    第1步

    Router#config terminal

    Enterconfiguration commands, one per line. End with CNTL/Z.

    Router(config)#interface s0/0


    第2步,设置同步串口的链路封装协议。封装协议是同步串口传输的链路层数据格式,路由器支持5种封装协议,即PPP, 帧中继(Frame-Relay),LAPB,X.25以及HDLC

    Router(config-if)#encap?

    encapsulation

    Router(config-if)#encapsulation ?

    atm-dxi ATM-DXI encapsulation

    frame-relay Frame Relay networks

    hdlc Serial HDLC synchronous

    lapb LAPB (X.25 Level 2)

    ppp Point-to-Point protocol

    smds Switched Megabit Data Service (SMDS)

    x25 X.25


    第3步 设置链路数据的压缩传输。链路压缩(也称为按接口的压缩)是对数据包(包括包头和负载)进行整体压缩。它与包头压缩不同,链路压缩是独立协议的。链路压缩使用STAC或者Predictor算法来压缩另一链路层(如PPP或者LAPB)上的数据流,以进行压缩纠正和数据包排序(在HDLC协议上只使用STAC压缩),它们都是基于字典的数据压缩技术。

    广域网络将无法得到包头中的交换信息,因此,链路压缩适用于有限跳数路径的点对点环境,如专线或者ISDN。当同步口使用PPP或者HDLC作为链路封装协议时,可以使用命令compress stac实现链路数据压缩从而提高传输效率。


    Router(config-if)#compress [stac|predictor]

    Router(config-if)#no compress [stac |predictor]


    第4步 设置线路编解码方式。线路编码方式有两种,即不归零方式和反向不归零方式(NRZI).同步串口的默认值线路编码方式为不归零方式(NRZ)


    设置同步串口使用NRZI线路编码方式

    Router(config-if)#nrzi-encoding

    第5步 设置同步串口(DCE)时钟速率。同步串口有两种工作方式,即DTE和DCE,不同的工作方式则选择不同的时钟。如果同步串口作为DCE设备,需要向DCE设备提供时钟,需要配置时钟,如果同步串口作为DTE设备,需要接受DCE设备提供的时钟,不需配置时钟。默认情况下同步串口没有时钟设置。

    Router(config-if)#clock rate clockrate


    第6步 设置反转时钟。在某些特殊情况下,时钟在线路上会产生半个周期的延时,这将导致两端设备对接不上或报文被大量丢弃。这时可以将DTE侧设备同步串口的接收时钟信号反转以消除时延的影响。如果同步串口作为DCE设备,路由器系统将禁止反转时钟。同步串口的默认值设置为禁止反转时钟。

    Router(config-if)#invert txclock

    或者取消同步串口(DTE)反转时钟


    第7步 忽略DCD信号。默认值状态下,同步串口工作在DTE模式下,此时它通过监视DCD(DataCarrier Detect)信号来检测线路状态变化。相应地这种情况下对端DCE设备会发送DCD信号来协同工作,当DTE检测到DCD信号后就改变同步串口的线路状态。在某些情况下,比如X.21协议的物理接口,在信号线上并没有DCD信号,因此可能用DTS或者DSR来代替,此时就需要使用ignore-dcd 命令忽略DCD信号,也就是允许同步串口不检测线路的载波信号,而依靠监测其他信号来监视线路状态。同步串口的默认值为必须监测线路的载波信号

    Router(config-if)#ignore-dcd


    第8步

    设置DTP脉冲信号时间,当同步口线路断开(比如由于同步信号丢失导致线路断开等),同步串口硬件将会处于非激活状态。对于一些以DTR信号作为同步依据的特殊设备(如加密或者类似的设备),可以根据需要设置DTR在重置期间的脉冲。同步串口的默认值不设置DTR脉冲信号时间。

    Router(config-if)#pluse-timepluse-in-seconds


    设置MTU。同步串口的最大传输单元MTU影响IP报文在该接口上传输拆包和组包。MTU单位为字节,默认值为1500.

    Router(config-if)#mtu mtu-size


    第10步 同步串口监控和维护

    Router#show controllers serialserial-number

    Router#show interface serial serial-number


    配置静态路由

    直连路由

    直接连接路由器接口的子网被称为直连子网。路由器会自动将到达这些子网的路由加入路由表,称为直连路由。当借口被启用并配置了IP地址时,路由器会自动将这条路由加入至路由表

    静态路由

    静态路由是指使用配置命令添加至路由器中的路由。

    R3(config)#ip route 192.168.10.0 255.255.255.0 f0/0

    103830788.png

    默认路由

    对于静态路由而言,由于不可能穷举并列出所有可能的路由,因此,那些目的地址不能与路由表相匹配的数据包就将被丢弃。默认路由:当数据包的目的地址不与路由表中任何路由相匹配时,将根据默认路由发送。

    Router(config)#ip route 0.0.0.0 0.0.0.0 192,168,20,1

    或者

    Router(config)#ip route 0.0.0.0 0.0.0.0 s0/0


    转载于:https://blog.51cto.com/lddxfs/1309927

    展开全文
  • 思科路由器配置笔记

    2019-07-17 10:48:00
    路由器(Router),是连接因特网中各局域网、广域网的设备,它会根据信道的情况自动选择和设定路由,以最佳路径,按前后顺序发送信号,路由器工作在网络层,用来跨网段通信,路由器具有判断网络地址和选择IP路径的功能,它能在...

    路由器(Router),是连接因特网中各局域网、广域网的设备,它会根据信道的情况自动选择和设定路由,以最佳路径,按前后顺序发送信号,路由器工作在网络层,用来跨网段通信,路由器具有判断网络地址和选择IP路径的功能,它能在多网络互联环境中,建立灵活的连接,可用完全不同的数据分组和介质访问方法连接各种子网,路由器只接受源站或其他路由器的信息,属网络层的一种互联设备,因此路由器是互联网中必不可少的网络设备之一.


    路由器,其最重要的功能就是路由,路由是指路由器接收到数据时选择最佳路径将数据穿过网络传输到目标地址的行为,每个路由器负责自己的本地数据的路由或转发,通过多个路由器依次接力将数据最终传递到目标主机,路由的工作流程包括路由选择路由转发两个方面.

    路由基本配置

    路由器与交换机不同,交换机不需要配置也可以正常工作,但是路由器必须经过配置后才可以正常使用,路由器的登陆方式基本和交换机保持一致,下面将用一个实例实现路由器的基本配置,包括配置路由器的主机名称,密码,控制台端口,WAN接口和LAN接口等,来实现一个基本的路由结构.

    首先我们准备两台路由器(1841型号),需要注意的是设备之间的连接所选用的线路类型,一般情况下路由器和PC之间使用交叉线,两台路由器相连接使用串行线,配置成以下拓扑结构即可:

    1379525-20190717104712792-1817256991.jpg

    但在实际连接两个路由器时,发现没有Serial接口,这是因为该型号的路由器默认没有提供串口,我们可以在思科模拟器上选择WIC-2T模块,并将其拖入空的插槽处,重启交换机即可完成配置.

    1379525-20190717104723550-514996228.jpg

    接着来看一下网络拓扑结构中,每个设备的具体配置参数,包括类型,IP地址,默认网关等信息.

    [设备名称]   [设备接口]         [IP地址]           [默认网关]
       PC1         ---          192.168.1.2/24      192.168.1.1
       PC2         ---          192.168.2.2/24      192.168.2.1
    
     Router0      Fa0/0         192.168.1.1/24         ---
                  Serial0/0/0   10.10.10.10/24         ---
    
     Router1      Fa0/0         192.168.2.1/24         ---
                  Serial0/0/0   10.10.10.20/24         ---

    开启路由远程登陆: 这里我们将启用Router1路由器的远程登陆功能,并设置一个登陆密码为lyshark.

    Router# enable
    Router# configure terminal
    
    Router(config)# hostname Router0             // 配置主机名为Router0
    Router0(config)# enable secret lyshark       // 配置特权模式密码为lyshark
    
    Router0(config)# line console 0              // 启用控制台
    Router0(config-line)# password lyshark       // 设置控制台登录密码
    Router0(config-line)# login                  // 允许用户登录
    Router0(config-line)# exit
    
    Router0(config)# line vty 0 2                // 配置序号为0-2的3个虚拟登陆终端
    Router0(config-line)# password lyshark       // 配置终端登录密码
    Router0(config-line)# login                  // 启用登陆终端

    配置WAN接口: 路由器通过WAN接口接入到互联网上,而常见的WAN接口都是串行接口用Serial表示,首先可以使用show controller 命令判断Serial 0/0/0是否为DCE端,然后决定是否要配置.

    Router0> show controller Serial0/0/0
    
    Interface Serial0/0/0
    Hardware is PowerQUICC MPC860
    DCE V.35, clock rate 2000000       // 此处判断是DEC端

    根据上述标注显示内容Srial0/0/0为DCE端口,下面需要对两台路由分别配置时钟频率.

    #----在Router0上操作-------------------------
    Router0> enable
    Router0# configure terminal
    Router0(config)# interface Serial0/0/0                    // 选择串行接口Srial0/0/0
    Router0(config-if)# ip address 10.10.10.10 255.255.255.0  // 配置外网IP地址
    Router0(config-if)# clock rate 64000                      // 配置始终频率为6400
    Router0(config-if)# no shutdown                           // 开启端口
    
    #----在Router1上操作-------------------------
    Router1> enable
    Router1# configure terminal
    Router1(config)# interface Serial0/0/0
    Router1(config-if)# ip address 10.10.10.20 255.255.255.0
    Router1(config-if)# clock rate 64000
    Router1(config-if)# no shutdown

    配置LAN接口: LAN接口用来指定内网通讯的地址,接下来分别对两台路由器做配置.

    #----在Router0上操作-------------------------
    Router0> enable
    Router0# configure terminal
    Router0(config)# interface fa0/0                        // 选择以太网接口fa0/0
    Router0(config)# ip address 192.168.1.1 255.255.255.0
    Router0(config)# no shutdown
    
    #----在Router1上操作-------------------------
    Router1> enable
    Router1# configure terminal
    Router1(config)# interface fa0/0
    Router1(config)# ip address 192.168.2.1 255.255.255.0
    Router1(config)# no shutdown

    查配置信息: 最后可以使用show ip route命令,查看路由器的路由信息,确定网络是否正确连接.

    Router0# show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 1 subnets
    C    10.10.10.0 is directly connected, Serial0/0/0            // 外网地址
    C    192.168.1.0/24 is directly connected, FastEthernet0/0    // 内网地址

    查接口信息: 也可以使用show ip interface brief命令,查看路由器的接口信息.

    Router0# show ip interface brief
    
    Interface              IP-Address      OK? Method Status                Protocol 
    FastEthernet0/0        192.168.1.1     YES manual up                    up
    Serial0/0/0            10.10.10.10     YES manual up                    up
    Serial0/0/1            unassigned      YES unset  administratively down down
    Vlan1                  unassigned      YES unset  administratively down down

    最后测试通信: 在路由器Route0上可以ping通Route1,每个主机也可以ping通自己网段的路由器.

    Router0# ping 10.10.10.20
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.10.10.20, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/6 ms

    上述小实验到这里就算配置成功了,但是这里留下了一个疑问,那就是PC0PingPC1无法通信,这就涉及到路由器没有相应的路由条目的问题,这些问题将在后面小实验中做解释.

    配置静态路由

    静态路由需要管理员根据实际需求一条条自己手动配置,路由器不会自动生成所需的静态路由,静态路由中包括目标节点或目标网络的IP地址,还可以包括下一跳IP地址,以及在本路由器上使用该静态路由时的数据包出接口等,但是手动配置静态路由需要管理员非常了解网络的拓扑结构才能够完成配置,在网络规模较大时还需要耗费大量的经历和时间去维护,所以并不是所有的网络都适合配置静态路由.

    一般情况下以下几种情况可以考虑使用静态路由

    1.网络的拓扑结构相对较简单,比如就一台路由器和交换机的情况,可使用静态路由.
    2.网络保密性要求较高,网络管理员需要控制链路或者控制路由表,则可使用静态路由.
    3.网络仅通过单个ISP接入Internet,则该ISP就是网络唯一的出口,所以不需要配置静态路由.
    4.路由资源有限,无法运行路由选择协议,在这种情况下,需要手动配置路由条目来更新路由表数据.

    接下来以一个实例具体介绍静态路由的配置流程,在思科模拟器中选择2台1841路由器,按照以下网络拓扑结构构建网路,然后为每台路由器配置静态路由,实现不同网络间的数据互通.

    1379525-20190717104742257-1706793788.jpg

    配置客户主机: 首先我们根据上图的配置要求配置好IP地址网关等数据,下面的参数是具体的地址规划.

    [设备名称]   [设备接口]         [IP地址]           [默认网关]
       PC0         ---          192.168.1.2/24      192.168.1.1
       PC1         ---          192.168.1.3/24      192.168.1.1
    
       PC2         ---          192.168.2.2/24      192.168.2.1
       PC3         ---          192.168.2.3/24      192.168.2.1
    
     Router0      Fa0/0         192.168.1.1/24         ---
                  Serial0/0/0   10.10.10.10/24         ---
    
     Router1      Fa0/0         192.168.2.1/24         ---
                  Serial0/0/0   10.10.10.20/24         ---

    配置路由器: 接着我们分别给路由器配置好地址参数,在这里fa0/0端口是内网IP地址,serial0/0/0端口则是外网IP地址,配置是应注意次序,如果配反了则看不到效果.

    #----在Router0上操作-------------------------
    Router0> enable
    Router0# configure terminal
    
    Router0(config)# interface fa0/0                          // 配置内网地址
    Router0(config-if)# ip address 192.168.1.1 255.255.255.0
    Router0(config-if)# no shutdown
    
    Router0(config)# interface serial0/0/0                    // 配置外网地址
    Router0(config-if)# clock rate 64000
    Router0(config-if)# ip address 10.10.10.10 255.255.255.0
    Router0(config-if)# no shutdown
    
    #----在Router1上操作-------------------------
    Router0> enable
    Router0# configure terminal
    
    Router1(config)# interface fa0/0                          // 配置内网地址
    Router1(config-if)# ip address 192.168.2.1 255.255.255.0
    Router1(config-if)# no shutdown
    
    Router1(config)# interface serial0/0/0                    // 配置外网地址
    Router1(config-if)# clock rate 64000
    Router1(config-if)# ip address 10.10.10.20 255.255.255.0
    Router1(config-if)# no shutdown

    检测路由配置: 当配置好上面的步骤以后,PC0与PC1主机是可通信的,Route0与Route1也可通信,但PC0无法与PC3通信,原因就是因为路由器没有配置静态路由的关系,这一步我们只需要确保同一个网段内能通信即可.

    #----在PC0上操作-------------------------
    PC0> ping 192.168.1.1
    PC0> ping 192.168.1.2
    PC0> ping 192.168.1.3
    Pinging 192.168.1.3 with 32 bytes of data:
    Reply from 192.168.1.3: bytes=32 time=0ms TTL=128
    
    #----在Route0上操作----------------------
    Router0#ping 10.10.10.20
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.10.10.20, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/7/12 ms

    配置静态路由: 接下来我们需要在两台路由器上分别配置路由条目,使用ip route命令配置,如果想要删除路由可使用no ip route命令即可删除指定路由条目.

    #----在Router0上操作-------------------------
    Router0> enable
    Router0# configure terminal
    
                               [目的网络]    [目的掩码]         [下一跳地址]
    Router0(config)# ip route 192.168.2.0  255.255.255.0      10.10.10.20
    
    #----在Router1上操作-------------------------
    Router1> enable
    Router1# configure terminal
    Router1(config)# ip route 192.168.1.0 255.255.255.0 10.10.10.10        // 指定返回时的路由
    
    #----检查配置参数情况-------------------------
    Router0# show ip interface brief          // 显示端口ip
    Router0# show ip route                    // 检查路由参数
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
         10.0.0.0/24 is subnetted, 1 subnets
    C    10.10.10.0 is directly connected, Serial0/0/0
    C    192.168.1.0/24 is directly connected,FastEthernet0/0
    S    192.168.2.0/24 [1/0] via 10.10.10.20

    最后的测试: 当配置好路由条目以后,我们在PC0主机上Ping检测PC3的连通性,会发现原来无法连通的两个网段,现在可以正常通信了,也就说明我们的路由配置生效了.

    PC0> ping 192.168.2.2
    
    Pinging 192.168.2.2 with 32 bytes of data:
    
    Reply from 192.168.2.2: bytes=32 time=12ms TTL=126
    
    Ping statistics for 192.168.2.2:
        Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 12ms, Maximum = 12ms, Average = 12ms

    以上的路由配置方法,适用于小型网络环境,在大型网络环境中这种静态路由的配置方式很不适合维护,一旦设备过多,则可能自己都搞不清头绪,所以在生产环境中,我们会使用动态路由的方式来实现路由器的配置,接下来继续学习动态路由的配置方式吧.

    RIP 动态路由

    动态路由是基于某种协议实现的,常见的路由协议有内内部网关协议(IGP)边界网关协议(BGP),其中内部网关协议又分为路由信息协议(RIP)开放式最短路径优先协议(OSPF)协议.

    其中RIP(路由信息协议)是最先被广泛应用的内部网关路由协议,RIP使用跳数来衡量到达目标地址的距离,跳数是指数据从源地址到达目标地址之间经过的路由器个数.从路由器到直接连接的网络的跳数定义为1,每经过一个路由器则数值会增加1,RIP允许的最大跳数是15跳,超过15跳的网络将无法到达,因此RIP适合用于小型的网络环境中.

    RIP协议默认会每隔30秒就会与其他相连的网络广播自己的路由表,收到广播的路由器会将收到的信息与自己路由表进行比较,判断是否将其中的路由条目加入到自己的路由表中,目前RIP共有3中版本,RIPv1,RIPv2,RIPng,其中RIPng应用于IPv6网络环境中,RIPv1是有类路由协议,RIPv2则是无类路由协议.

    1379525-20190717104756822-835350204.jpg

    配置参数简介: 首先我们根据上图的配置要求配置好路由器各种基本参数,下面的参数是具体的地址规划.

    [设备名称]     [设备接口]        [IP地址]          [默认网关]
    
     Router1     Serial0/0/0    192.168.10.1/24         ---
    
     Router2     Serial0/0/0    192.168.10.2/24         ---
                 Serial0/0/1    192.168.20.1/24         ---
    
     Router3     Serial0/0/0    192.168.20.2/24         ---
                 Serial0/0/1    192.168.30.1/24         ---
    
     Router4     Serial0/0/0    192.168.30.2/24         ---

    配置路由器: 根据上表的结构配置好路由器的各种参数,主要配置路由器的接口IP地址.

    Router>enable
    Router#configure terminal
    
    #----在Router1上操作-------------------------
    Router1(config)# interface Serial0/0/0
    Router1(config-if)# ip address 192.168.10.1 255.255.255.0
    Router1(config-if)# no shutdown
    
    #----在Router2上操作-------------------------
    Router2(config)# interface Serial0/0/0
    Router2(config-if)# ip address 192.168.10.2 255.255.255.0
    Router1(config-if)# no shutdown
    Router2(config)# interface Serial0/0/1
    Router2(config-if)# ip address 192.168.20.1 255.255.255.0
    Router1(config-if)# no shutdown
    
    #----在Router3上操作-------------------------
    Router3(config)# interface Serial0/0/0
    Router3(config-if)# ip address 192.168.20.2 255.255.255.0
    Router1(config-if)# no shutdown
    Router3(config)# interface Serial0/0/1
    Router3(config-if)# ip address 192.168.30.1 255.255.255.0
    Router1(config-if)# no shutdown
    
    #----在Router4上操作-------------------------
    Router4(config)#interface Serial0/0/0
    Router4(config-if)#ip address 192.168.30.2 255.255.255.0
    Router1(config-if)# no shutdown

    配置并启用RIP路由: 在每台路由器上启用并配置好RIP动态路由.

    Router>enable
    Router#configure terminal
    #----在Router1上启用RIP路由协议并配置-------------------
    Router1(config)# router rip                   // 启用RIP路由
    Router1(config-router)# version 2             // 指定使用RIP版本为RIPv2
    Router1(config-router)# network 192.168.10.0  // 声明与Router1直连的网络号
    Router1(config-router)# exit
    
    #----在Router2上启用RIP路由协议并配置-------------------
    Router2(config)# router rip
    Router2(config-router)# version 2
    Router2(config-router)# network 192.168.10.0  // 声明与Router2直连的网络号
    Router2(config-router)# network 192.168.20.0  // 声明与Router3直连的网络号
    Router2(config-router)# exit
    
    #----在Router3上启用RIP路由协议并配置-------------------
    Router3(config)# router rip
    Router3(config-router)# version 2
    Router3(config-router)# network 192.168.20.0  // 声明与Router3直连的网络号
    Router3(config-router)# network 192.168.30.0  // 声明与Router4直连的网络号
    Router3(config-router)# exit
    
    #----在Router4上启用RIP路由协议并配置-------------------
    Router4(config)# router rip
    Router4(config-router)# version 2
    Router4(config-router)# network 192.168.30.0  // 声明与Router4直连的网络号
    Router4(config-router)# exit

    检查配置信息: 配置完成后,在Router1上执行show ip route 命令查看RIP配置结果,如下.

    Router1#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
    C    192.168.10.0/24 is directly connected, Serial0/0/0
    R    192.168.20.0/24 [120/1] via 192.168.10.2, 00:00:01, Serial0/0/0   // R表示当前是RIP路由
    R    192.168.30.0/24 [120/2] via 192.168.10.2, 00:00:01, Serial0/0/0   // 路由条目是RIP自动生成的

    测试连通性: 此时我们在Router1路由器上Ping路由器Router4是可以通信的,说明配置成功了.

    Router1#ping 192.168.30.2
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.30.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 3/15/27 ms


    OSPF 动态路由

    在上面的配置试验中我们通过使用RIP协议完成了一个路由器之间的数据通信,但是RIP协议最大仅仅支持15个路由节点,虽然在中小型网络中这些节点足够使用了,但是在一些大型企业中往往需更多的跳数,就是因为这种需求我们的OSPF协议就由此诞生啦.

    OSPF(开放式最短路径优先),该协议是基于链路状态的协议规范,因此也可以称为链路状态协议,和RIP协议相同,OSPF协议同样使用跳数计量路径开销,但是与RIP不同的是,OSPF协议不受物理跳数的限制,其路径开销与网络中的链路开销等相关.

    OSPF协议采用了FPS算法来计算最短路径数,SPF算法将每一个路由作为根(ROOT),来计算其数据包到达每一个目标路由器之间的距离,每个路由器根据一个统一的数据库LSDB计算出路由域的拓扑结构图,该结构很像是一颗树,所以就叫做最短路径树.

    OSPF协议的优点

    1.OSPF采用了SPF算法,从而可以很好的避免路由器环路的产生.
    2.OSPF协议虽然也使用跳数作为计量单位,但不受物理跳数的限制.
    3.当网络链路状态发生变化时,OSPF能够迅速捕捉并应用,收敛快,路由信息流量小.
    4.OSPF路由协议支持路由认证体系,且还可以定义不同的认证方式,提高了网络安全性.
    5.OSPF协议提供了较好的负载均衡性,其数据更新比较智能,相应的减小了网络流量的带宽.

    在配置OSPF路由之前还有一个小知识点需要补充,在下面的配置试验中你会看到例如0.0.0.255这样的网络号,这种网络号被称作通配符掩码,通常情况下通配符掩码可由,255.255.255.255(广播地址)减去当前的255.255.255.0(子网掩码),来获得,此处小实验的通配符掩码为0.0.0.255 area 0.

    接下来开始步入正题,我们还是使用RIP路由的拓扑结构及IP地址的配置都相同,但是这里在配置动态路由的时候,我们使用OSPF的方式来配置,过程如下:

    配置路由器: 首先更具上表的结构配置好路由器的各种参数.

    Router>enable
    Router#configure terminal
    
    #----在Router1上操作-------------------------
    Router1(config)# interface Serial0/0/0
    Router1(config-if)# ip address 192.168.10.1 255.255.255.0
    Router1(config-if)# no shutdown
    
    #----在Router2上操作-------------------------
    Router2(config)# interface Serial0/0/0
    Router2(config-if)# ip address 192.168.10.2 255.255.255.0
    Router1(config-if)# no shutdown
    Router2(config)# interface Serial0/0/1
    Router2(config-if)# ip address 192.168.20.1 255.255.255.0
    Router1(config-if)# no shutdown
    
    #----在Router3上操作-------------------------
    Router3(config)# interface Serial0/0/0
    Router3(config-if)# ip address 192.168.20.2 255.255.255.0
    Router1(config-if)# no shutdown
    Router3(config)# interface Serial0/0/1
    Router3(config-if)# ip address 192.168.30.1 255.255.255.0
    Router1(config-if)# no shutdown
    
    #----在Router4上操作-------------------------
    Router4(config)# interface Serial0/0/0
    Router4(config-if)# ip address 192.168.30.2 255.255.255.0
    Router1(config-if)# no shutdown

    配置并启用OSPF路由: 在每台路由器上启用并配置好OSPF动态路由.

    Router>enable
    Router#configure terminal
    
    #----在Router1上启用OSPF路由协议并配置-------------------
    Router1(config)# router ospf 1                                 // 启用OSPF路由,并设置进程号为1
    Router1(config-router)# router-id 1.1.1.1                      // 为Router1配置RID编号
    Router1(config-router)# network 192.168.10.0 0.0.0.255 area 0  // 配置路由记录
    Router1(config-router)# exit
    
    #----在Router2上启用OSPF路由协议并配置-------------------
    Router2(config)# router ospf 1                                 // 启用OSPF路由,并设置进程号为1
    Router2(config-router)# router-id 2.2.2.2                      // 为Router2配置RID编号
    Router2(config-router)# network 192.168.10.0 0.0.0.255 area 0  // 配置路由记录
    Router2(config-router)# network 192.168.20.0 0.0.0.255 area 0
    Router2(config-router)# exit
    
    #----在Router3上启用OSPF路由协议并配置-------------------
    Router3(config)# router ospf 1                                 // 启用OSPF路由,并设置进程号为1
    Router3(config-router)# router-id 3.3.3.3                      // 为Router3配置RID编号
    Router3(config-router)# network 192.168.20.0 0.0.0.255 area 0
    Router3(config-router)# network 192.168.30.0 0.0.0.255 area 0
    Router3(config-router)# exit
    
    #----在Router4上启用OSPF路由协议并配置-------------------
    Router3(config)# router ospf 1                                 // 启用OSPF路由,并设置进程号为1
    Router3(config-router)# router-id 4.4.4.4                      // 为Router4配置RID编号
    Router3(config-router)# network 192.168.30.0 0.0.0.255 area 0
    Router3(config-router)# exit

    检查配置信息: 配置完成后,在Router1上执行show ip route 命令查看OSPF配置结果,如下.

    Router#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
    C    192.168.10.0/24 is directly connected, Serial0/0/0                    // C表示是本机默认路由
    O    192.168.20.0/24 [110/128] via 192.168.10.2, 00:02:25, Serial0/0/0     // O表示当前是OSPF路由
    O    192.168.30.0/24 [110/192] via 192.168.10.2, 00:01:55, Serial0/0/0     // 路由条目是OSPF自动生成的

    测试连通性: 此时我们在Router1路由器上Ping路由器Router4是可以通信的,说明配置成功了.

    Router1#ping 192.168.30.2
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.30.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 3/15/27 ms


    实战:配置RIP企业环境

    接下来,我们通过使用三层交换机配合路由器,来实现一个跨网段通信的案例,其配置流程是,首先配置三层交换机并划分好VLAN的层次,接着在配置Router0这里不需要配置VLAN,原因是三层交换机与Router0共享VLAN,最后在配置外网口的Router1路由器,其拓扑结构如下图所示:

    1379525-20190717104813555-1168503306.jpg

    配置三层交换: 首先先来配置三层交换机,创建3个VLAN,并划分成三个VLAN虚拟局域网.

    Switch> enable
    Switch# configure terminal
    
    #----配置三层交换的VLAN10并把端口fa0/1加入到VLAN-------------------
    Switch(config)# vlan 10                              // 创建VLAN10
    Switch(config-vlan)# interface fa0/1                 // 将Fa1俩端口加入到VLAN10
    Switch(config-if-range)# switchport mode access
    Switch(config-if-range)# switchport access vlan 10   // 把端口加入到VLAN10
    Switch(config-if-range)# no shutdown                 // 启用端口
    Switch(config-if-range)# exit
    
    #----配置三层交换的VLAN20并把端口fa0/2加入到VLAN-------------------
    Switch(config)# vlan 20
    Switch(config-vlan)# interface fa0/2
    Switch(config-if-range)# switchport mode access
    Switch(config-if-range)# switchport access vlan 20
    Switch(config-if-range)# no shutdown
    Switch(config-if-range)# exit
    
    #----配置三层交换的VLAN30并把端口fa0/3加入到VLAN-------------------
    Switch(config)# vlan 30
    Switch(config-vlan)# interface fa0/3
    Switch(config-if)# switchport mode access
    Switch(config-if)# switchport access vlan 30
    Switch(config-if)# no shutdown
    Switch(config-if)# exit

    配置三层交换IP地址: 给上面分配好的三个VLAN虚拟局域网一个IP地址,这里指定为各自的网关地址就好.

    Switch> enable
    Switch# configure terminal
    
    #----给三层交换的VLAN10内的主机添加网关-------------------
    Switch(config)# interface vlan 10                            // 选择vlan10接口
    Switch(config-if)# ip address 192.168.1.1 255.255.255.0      // 配置网关地址
    Switch(config-if)# no shutdown                               // 开启端口
    Switch(config-if)# exit
    
    #----给三层交换的VLAN20内的主机添加网关-------------------
    Switch(config)# interface vlan 20                            // 选择vlan20接口
    Switch(config-if)# ip address 192.168.2.1 255.255.255.0      // 配置网关地址
    Switch(config-if)# no shutdown                               // 开启端口
    Switch(config-if)# exit
    
    #----给三层交换的VLAN30内的主机添加网关-------------------
    Switch(config)# interface vlan 30                            // 选择vlan30接口
    Switch(config-if)# ip address 192.168.3.1 255.255.255.0      // 配置网关地址
    Switch(config-if)# no shutdown                               // 开启端口
    Switch(config-if)# exit

    配置路由器Router0: 配置好网关后,接着配置路由器Router0,配置接口IP地址,注意在DCE接口需要配置时钟.

    Router> enable
    Router# configure terminal
    
    #----配置路由fa0/0端口的IP地址-------------------
    Router0(config)# interface fa0/0
    Router0(config-if)# ip address 192.168.3.2 255.255.255.0
    Router0(config-if)# no shutdown
    Router0(config-if)# exit
    
    #----配置路由fa0/1端口的IP地址-------------------
    Router0(config)# interface fa0/1
    Router0(config-if)# ip address 192.168.4.1 255.255.255.0
    Router0(config-if)# no shutdown
    Router0(config-if)# exit
    
    #----配置路由se0/0/0连接外网端口IP----------------
    Router0(config)# interface se0/0/0
    Router0(config-if)# ip address 1.1.1.1 255.0.0.0
    Router0(config-if)# no shutdown
    Router0(config-if)# exit

    配置路由器Router1: 最后配置外网与内网的衔接路由器Router1,配置好外网口IP地址以及内网口地址.

    Router> enable
    Router# configure terminal
    
    #----配置路由器1的内网口地址-------------------
    Router1(config)# interface se0/0/0
    Router1(config-if)# ip address 1.1.1.2 255.0.0.0
    Router1(config-if)# no shutdown
    Router1(config-if)# exit
    
    #----配置路由器1的外网口地址-------------------
    Router1(config)# interface fa0/0
    Router1(config-if)# ip address 10.10.10.10 255.0.0.0
    Router1(config-if)# no shutdown

    开启三层交换机路由: 开启三层交换机路由功能,并配置RIP动态路由,指明每个路由器的网段地址.

    Switch(config)# ip routing
    Switch(config)# router rip
    
    Switch(config-router)# network 192.168.1.0
    Switch(config-router)# network 192.168.2.0
    Switch(config-router)# network 192.168.3.0
    Switch(config-router)# network 192.168.4.0

    配置二层路由器RIP: 最后还需要分别配置两个路由器并开启其路由功能.

    #----配置路由器Router0-------------------
    Router0(config)# router rip
    Router0(config-router)# network 192.168.3.0
    Router0(config-router)# network 192.168.4.0
    
    #----配置路由器Router1-------------------
    Router1(config)# route rip
    Router1(config-router)# network 192.168.3.0
    Router1(config-router)# network 192.168.4.0
    Router1(config-router)# network 192.168.4.0
    Router1(config-router)# network 1.1.1.1

    以上配置流程就是全部的实验配置过程,在配置完成功能后,我们首先通过使用ping命令来测试内部主机是否能够Ping通,最后的实验结果是,内网主机均可以实现通信,外网主机无法和内网主机通信.

    转载于:https://www.cnblogs.com/LyShark/p/11199543.html

    展开全文
  • 思科路由器配置ipsec

    2016-08-25 20:31:42
    一,参考配置 ×××参数及配置模板如下,请项目组这边确定我端的服务器IP和访问端口,谢谢!对端公网IP:183.63.82.98对端内网IP:11.0.223.25 ,端口 13054本端公网:113.106.93.211 本端服务器地址:192.168.2.220...

    一,参考配置


       ×××参数及配置模板如下,请项目组这边确定我端的服务器IP和访问端口,谢谢!

    对端公网IP:183.63.82.98

    对端内网IP:11.0.223.25 ,端口 13054

    本端公网:113.106.93.211

    本端服务器地址:192.168.2.220

    加密算法:

     encr 3des;   hash sha; group 2;mode tunnel;lifetime 86400

    加密算法:

    第一阶段:encr 3des;   hash sha; group 2;mode tunnel,lifetime 86400
    第二阶段:esp-3des esp-sha-hmac  

    预共享密钥:ycsf@gdnybank

    对端配置参考:

    interface Loopback1  -内网口
     ip address 190.190.190.22 255.255.255.255
     
     
    interface Fa stEthernet0/0--外网口
    description internet_int
    ip address 219.132.79.34 255.255.255.240
    ip virtual-reassembly
    duplex auto
    speed auto
    crypto map zjbank
     
    crypto isakmp key  ycsf@gdnybank address 183.63.82.98

    crypto ipsec transform-set ycsf-set esp-3des esp-sha-hmac

    crypto map zjbank 110 ipsec-isakmp
       
    set peer 183.63.82.98
    set transform-set ycsf-set
    match address 110
     
    access-list 110 permit ip host 190.190.190.22 host 11.0.223.25
     
    crypto isakmp policy 110
    encr 3des
    hash md5
    authentication pre-share
    group 2




    转载于:https://blog.51cto.com/hhslinux/1842624

    展开全文
  • Router(config-if)#ip add 1.1.1.1 255.255.255.0 给环回口配置地址 Router(config-if)#no shutdown 打开环回口 Router#show ip route 查看路由器的路由表 二、NAT技术配置 1、静态N
  • 思科路由器登录IP地址说明: 要登录和配置思科路由器,我们需要先知道两件事。 1.思科路由器的登录IP地址 2.思科路由器默认登录用户名和密码 本指南说明将为你带来两种设备如何登录和配置思科路由器步骤一:找出思科...
  • 实验拓扑: 需求分析: 在R1/R2/R3/R4之间配置OSPF协议,分别建立Area0/Area1/Area2,Area0为骨干区域。...1. 配置路由器端口IP地址 R1: R1(config)#int loopback1 R1(config-if)#ip address 1.1.1.1 255.2...
  • 配置 DHCP 服务器 ...Cisco IOS DHCP 服务器从路由器内的指定地址池分配 IP 地址给 DHCP 客户端,并管理这些 IP 地址。 定义 DHCP 在分配地址时的排除范围: R1(config)#ip dhcp excluded-ad...
  • 一、 GRE配置 ...1、实验拓扑 ...R1(config-if)#ip address 10.1.1.1 255.255.255.0 配置环回口地址当接入PC用 R1(config)#int e0/0 R1(config-if)#ip address 202.1.1.1 255.255.255.0 R1(config-if)#n
  • 需求: 两台路由器之间配置OSPF认证,只有...1. 配置各端口的IP地址 R1: R1(config)#int loopback1 R1(config-if)#ip address 1.1.1.1 255.255.255.0 R1(config-if)#exit R1(config)#int e0/0 R1(config-if)#ip addr...
  • 项目背景: 最近做的一个项目中需要总公司和分公司之间内网互通; 总公司内网段:192.168.0.0/16 ...1. 配置路由器端口IP地址,使相邻路由器相互ping通 R1: R1(config)#int e0/0 R1(config-if)#ip...
  • 思科路由器基本配置

    2020-12-10 16:43:07
    接口模式:命令提示符为“Router(config-if)#”,可以对接口进行配置,如ip地址。 Line配置模式:命令提示符为“Router(config-line)#”,可以对虚拟终端(vty)和控制台端口进行配置。 进入各种模式的命令 进入特权...
  • Hello大家好,这次我们来讲述大学网络工程之思科路由器RIP配置,供各大专院校学生与老师参考,如需转载,需注原创。 接下来,我们来进行思科路由器RIP实验 首先,我们按照要求,选取相应的器材并进行连接: 第一步...
  • 路由器IP地址配置基础知识常用命令实验流程1.设计拓扑2.配置路由器IP地址3.查看路由表4.激活端口5.查看路由表6.验证主机连通 基础知识 ip地址是网络层中使用的地址,网络层依靠IP地址和路由协议将数据报送到目的IP...
  • 思科路由器导入配置

    2020-07-16 14:14:52
    这是针对同网段有多个地址的设备:全局配置模式下输入:ip tftp source-interface (int name) ,指定tftp源端口,端口选择能通电脑的那个 关闭防火墙 1,电脑网口配192.168.1.2/24 ,tftp开启,选网口,设置目录 2,#...
  • 三层交换机配置: switch (config)#interface vlan1 (配置VLAN1) switch (config-if)#ip helper-address 192.168.11.4(指定DHCP服务器的地址,即路由器地址) switch (config)#interface vlan2 ...
  • 一个PC机,一个路由器,记得设置IP地址192.168.1.1 255.255.255.0 然后打开路由器 先消除配置文件,然后打开CLI界面,输入这些命令 到此路由器配置完成 接下来是远程登录 打开pc机的命令提示符界面 上图为查看...
  • 思科路由器查看配置命令showrun//看运行状况showiproute//看路由表showint//看断口*showipintbr//看端口ip地址showcdpnei//察看cdp邻居showippro//察看ip协议查看配置信息用show命令,该命令可以在用户模式和特权...
  • NAT是将IP数据报报头中的IP...本文为大家介绍一个思科路由器的NAT配置实例,把内网地址转换成公网地址,并通过ACL控制,有选择地对内网地址段进行NAT转换,从而灵活控制可以上网的用户。 一、组网结构和需求 ...
  • 这一篇我们来讲述如何配置思科路由器 第一步,我们先选择一台PC和一台路由器进行连接,连接用到了配置线和交叉线 第二步,我们进行设置PC的ip地址,子网掩码和网关 第三步,配置路由器的管理的IP地址,并为Telnet...
  • Cisco思科模拟器路由器各个端口IP地址配置及路由协议RIP的配置 入门详解 - 精简归纳 JERRY_Z. ~ 2020 / 11 / 21 转载请注明出处!❤️ 附: 交流方式: ❤️ ❤️ ❤️ QQ: ...
  • NATvpdn enable no vpdn logging 由于ADSL的PPPoE应用是通过虚拟拨号来实现的所以在路由器中需要使用VPDN的功能 ! vpdn-group pppoe 为PPPoE启动了VPDN的进程 request-dialin protocol pppoe 设置拨号协议为PPPoE!...
  • NAT是一种把内部私有网络地址翻译成合法公网IP地址的技术。简单地说,假如局域网内部地址要与外部网络进行通讯时,NAT技术可以将内部地址替换成公网地址,从而在外部公网上正常使用。反过来,当外网需要访问局域网...
  • 思科路由器DHCP基础配置 实验要求:clinet向server请求IP地址1、client配置2、server配置定义地址池调试命令问题:前面不是设置192.168.1.1到192.168.1.5不参与动态分配,这里为什么没生效呢??解决办法:(1)先将...
  • 拓扑图实验步骤及要求:1、配置各台路由器IP地址,并且使用ping命令确认各路由器的直连口的互通性。2、在三台路由配置EIGRP自治系统编号为50。3、登录到R2路由器,作如下配置(其它路由器参照其进行配置):R2#...
  • 第一:配置外网接口IP地址 easytouch(config)#int f0/0 easytouch(config-if)#ip add 58.56.152.100 255.255.255.252 easytouch(config-if)#no sh 第二:配置内网接口IP地址 easytouch(config)#int f0/1 easytouch...
  • 思科路由器基本联网配置

    千次阅读 2018-04-30 19:55:25
    工作以来也没有笔记的习惯,总是用到哪就差到哪,感觉很浪费时间。...第一:配置外网接口IP地址easytouch(config)#int f0/0easytouch(config-if)#ip add 58.56.152.100 255.255.255.252easytouch(...
  • 配置路由器ip地址Router> :用户模式Router>enable :特权模式Router#conf terminal :进入全局模式Rou...
  • 拓扑图 进行命令配置 ...Router(config-if)#ip address 192.168.1.1 255.255.255.0 //设置IP地址 Router(config-if)#no sh //启用接口 Router(config)#int fa0/1 //进入fa0/1接口 Router(confi

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 400
精华内容 160
关键字:

思科路由器配置ip地址