精华内容
下载资源
问答
  • 1. 实验目的通过本实验,读者可以掌握如下技能:(1) 熟悉TFTP 服务器的使用(2) 熟悉备份路由器配置文件(3) 掌握备份路由器的IOS2. 实验拓扑3. 实验步骤(1) 步骤1:TFTP SERVER 软件的安装、准备Tftp ...

    1. 实验目的
    通过本实验,读者可以掌握如下技能:
    (1) 熟悉TFTP 服务器的使用
    (2) 熟悉备份路由器配置文件
    (3) 掌握备份路由器的IOS
    2. 实验拓扑

    1319512A2-0.jpg

    3. 实验步骤
    (1) 步骤1:TFTP SERVER 软件的安装、准备

    13195114G-1.jpg

    Tftp 服务器软件有各种各样,本书以SolarWinds TFTP Server 软件为例,该软件可以从http://solarwinds.net  上免费下载。下载后安装后,运行该软件,如图2-7。从【File】→【Configure】菜单打开配置窗口,如图2-8。在“TFTP Root  Directory”选项卡中,可以看到TFTP 的主目录为c:\tftp-root,TFTP Server  接收到的文件将存放在该目录,也从该目录查找要发送的文件。如图2-9,在“Security”选项卡中,配置该TFTP 可以接收和发送文件。

    1319516402-2.jpg

    131951GH-3.jpg

    (2) 步骤2:路由器和计算机间的IP 可达
    首先确保S1 交换机为出厂配置,如果不是的话,请执行以下命令:
    Switch>enable
    Switch#delete flash:vlan.dat
    Switch#erase startup-config
    其次在PC 机上配置IP 地址为172.16.0.100/16。
    R2(config)#int g0/0
    R2(config-if)#no shutdown
    R2(config-if)#ip address 172.16.0.2 255.255.0.0
    R2(config-if)#exit
    //以上在路由器的以太网接口配置IP 地址,并启用接口
    R2#ping 172.16.0.100

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.0.100, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
    //测试从R2 到PC(TFTP 服务器)的IP 可达
    (3) 步骤3:备份配置文件到TFTP 服务器
    R2#copy running-config tftp:
    //把内存中的配置文件备份到TFTP 服务器上
    Address or name of remote host []? 172.16.0.100 //回答TFTP 服务器的IP 地址
    Destination filename [r2-confg]? //回答文件名,默认时为“路由器名-confg”
    !!
    1381 bytes copied in 0.452 secs (3055 bytes/sec)
    //备份成功,共1381 字节,可以在c:\tftp-root 目录下找到该文件,是一个纯文本的文件。可以用写字板打开,而用记事本打开则格式会出现问题
    (4) 步骤4:采用“复制、粘贴”备份配置文件
    使用TFTP 服务器备份配置文件很是麻烦,我们也可以简单地在终端窗口中,执行“showrunning-config”命令显示当前的配置,在终端窗口中复制全部配置,粘贴到某文本文件中。

    【提示】如果是在Windows 自带的超级终端窗口中复制、粘贴配置,会有“---more---”等
    字样,要记得删除这些字符。
    (5) 步骤5:备份配置IOS 到TFTP 服务器
    R2#show flash:
    CompactFlash directory:
    File Length Name/status
    1 41205996 c2800nm-adventerprisek9-mz.124-11.T1.bin
    [41206060 bytes used, 23019216 available, 64225276 total]
    62720K bytes of ATA CompactFlash (Read/Write)
    //先查看flash 中的IOS 大小,文件名等
    R2#copy flash:c2800nm-adventerprisek9-mz.124-11.T1.bin tftp:
    //把IOS 备份到TFTP 服务器上
    Address or name of remote host []? 172.16.0.100 //回答TFTP 服务器的IP 地址
    Destination filename [c2800nm-adventerprisek9-mz.124-11.T1.bin]?
    //回答文件名。默认时和源文件名是一样的,不建议修改文件名,因为IOS 文件名包含了IOS 的版本、特征等信息

    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!(此处省略)
    //备份成功可以在c:\tftp-root 目录下找到该文件。


    转载于:https://blog.51cto.com/cisco130/1266587

    展开全文
  • 今天小编就和大家一起来探讨一下怎样备份思科路由器配置文件呢?关于备份思科路由器相关的配置文件,这一个部分究竟有多么的重要,相信就算小编不用多说,大家都应该知道了吧。其实在路由器的配置过程里面,大家...

    路由器(Router,又称路径器)是一种计算机网络设备,而配置文件就是对于不一样的对象进行不一样配置的文件。今天小编就和大家一起来探讨一下怎样备份思科路由器的配置文件呢?

    关于备份思科路由器相关的配置文件,这一个部分究竟有多么的重要,相信就算小编不用多说,大家都应该知道了吧。其实在路由器的配置过程里面,大家常常都会使用到COPY这一个命令的。那么在这一篇教程里面,小编就为大家详细的介绍一下:究竟怎样使用COPY这一个命令来进行备份cisco路由器的配置文件吧。除此之外,小编还会和大家继续探讨一下究竟怎样从TFTP服务器里面复制备份cisco路由器配置文件。现在我们就一起来看看吧。

    第一个命令

    首先小编要为大家介绍的是copyrunning-configstartup-config,那么这以个命令主要的作用就是把存储在RAM(随机存取存储器,random Access memory,RAM)又称作"随机存储器",是与CPU直接交换数据的内部存储器,也叫主存)的正确配置复制到路由器的NVRAM里面。这样子的话,大家在下一次启动的时候,cisco路由器就会自动的使用这一个正确的配置了。

    第二个命令

    接下来小编要为大家介绍的是copy running-configt ftp,这一个命令的功能就是把RAM里面正确的配置文件复制到TFTP服务器上面。在这里的话,小编强烈推荐网络管理员应该按照下面这样子做,因为假如说路由器不可以从NVRAM里面正常的装载配置文件,那么大家都能够通过从TFTP里面复制到正确的配置文件。

    当网络管理员成功的输入命令并且键入回车按钮以后,那么路由器就会要求大家输入TFTP(简单文件传输协议)服务器的IP地址(IP地址是IP协议提供的一种统一的地址格式,它为互联网上的每一个网络和每一台主机分配一个逻辑地址,以此来屏蔽物理地址的差异。)了。当大家在正确的键入服务器IP地址以后,另外路由器还会要求网络管理员提供所需要备份cisco路由器配置文件名字。一般情况下,小编都会建议大家使用网络管理员比较容易记住的文件名字。这个时候路由器都会提示网络管理员按下YES按钮来确认操作的。

    第三个命令

    最后小编为大家介绍的是copyt ftp running-config这一条命令,爱计入说路由器的配置文件不小心出现了一些问题,那个这个时候大家就能够通过从TFTP服务器里面复制备份cisco路由器配置文件。有人就会问小编,应该怎样设置呢?具体配置如下:

    小编结语:

    以上是今天考试认证的教程了,为大家探讨一下怎样备份思科路由器的配置文件呢?希望这对你有所帮助。如果你也有这样的需要,那就赶快来学习一下吧。如果大家喜欢课课家教育的话,不妨可以推荐更多的朋友来哟!

    展开全文
  • 思科路由器备份

    2011-06-11 21:51:28
    思科路由器备份 实验要求: R1,R3上分别起NAT,使R1,R3以太网口所连接的网络能访问外网,并在此基础上配置HSRP,要求实现两组负载均衡(即当R1的以太网线路断了的时候,立即启用R3的线路,R1连接的局域网不会...

    思科路由器热备份

    实验要求:
    R1,R3上分别起NAT,使R1,R3以太网口所连接的网络能访问外网,并在此基础上配置HSRP,要求实现两组负载均衡(即当R1的以太网线路断了的时候,立即启用R3的线路,R1连接的局域网不会因为线路断了而无法与外网通信,同理R3也是如此)



    实验配置:
    一、外网配置:
    配置R1:
    Router>en
    Router#conf t
    Router(config)#hostname R1
    R1(config)#int S0
    R1(config-if)#ip add 12.1.1.1 255.255.255.252
    R1(config-if)#no shut
    R1(config-if)#int E0
    R1(config-if)#ip add 192.168.10.100 255.255.255.0
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#ip route 0.0.0.0 0.0.0.0 S0
    R1#sh run


    配置R2:
    Router>en
    Router#conf t
    Router(config)#hostname R2
    R2(config)#int S0
    R2(config-if)#ip add 12.1.1.2 255.255.255.252
    R2(config-if)#no shut
    R2(config-if)#clock rate 64000
    R2(config-if)#int S1
    R2(config-if)#ip add 23.1.1.2 255.255.255.248
    R2(config-if)#no shut
    R2(config-if)#clock rate 64000
    R2(config-if)#end
    R2#sh run


    配置R3:
    Router>en
    Router#conf t
    Router(config)#hostname R3
    R3(config)#int S0
    R3(config-if)#ip add 23.1.1.3 255.255.255.248
    R3(config-if)#no shut
    R3(config-if)#int E0
    R3(config-if)#ip add 192.168.20.200 255.255.255.0
    R3(config-if)#no shut
    R3(config-if)#exit
    R3(config)#ip route 0.0.0.0 0.0.0.0 S0
    R3#sh run


    二、配置NAT:
    R1#conf t
    R1(config)#access-list 10 permit 192.168.10.0 255.255.255.0
    R1(config)#ip nat inside source list 10 interface S0 overload
    R1(config)#end
    R1#sh run


    R3#conf t
    R3(config)#access-list 20 permit 192.168.20.0 255.255.255.0
    R3(config)#ip nat inside source list 20 interface S0 overload
    R3(config)#end
    R3#sh run


    三、配置HSRP多组负载均衡:
    R1#conf t
    R1(config)#int E0
    R1(config-if)#standby 1 ip add 192.168.10.254 //激活HSRP,设置R1连接的内网的虚拟网关
    R1(config-if)#standby 1 priority 120 //用于设定端口的HSRP优先级,具有最高备份优先级的HSRP成员将成为激活路由器
    R1(config-if)#standby 1 preempt //表明当本地路由器的备份优先级超过当前激活路由器时,它就将接管控制权,成为激活路由器也就是抢占
    R1(config-if)#standby 1 track serial 0 40 //用于设置允许路由器端口根据另一端口的可用性而修改自己的HSRP优先级值(即监视端口状态)
    R1(config-if)#standby use-bia //启用HSRP多组均衡负载
    R1(config-if)#standby 2 ip add 192.168.20.254
    R1(config-if)#standby 2 preempt


    R3#conf t
    R3(config)#int E0
    R3(config-if)#standby 2 ip add 192.168.20.254 //激活HSRP,设置R3连接的内网的虚拟网关
    R3(config-if)#standby 2 priority 120 //用于设定端口的HSRP优先级,具有最高备份优先级的HSRP成员将成为激活路由器
    R3(config-if)#standby 2 preempt //表明当本地路由器的备份优先级超过当前激活路由器时,它就将接管控制权,成为激活路由器
    R3(config-if)#standby 2 track serial 0 40 //用于设置允许路由器端口根据另一端口的可用性而修改自己的HSRP优先级值
    R3(config-if)#standby use-bia //启用HSRP多组均衡负载
    R3(config-if)#standby 1 ip add 192.168.10.254
    R3(config-if)#standby 1 preempt


    配置PC机:
    PC1:设置本地连接的TCP/IP属性:ip:192.168.10.10 掩码:255.255.255.0 网关:192.168.10.254
    PC2设置本地连接的TCP/IP属性:ip:192.168.20.20 掩码:255.255.255.0 网关:192.168.20.254
    分别在PC1和PC2上ping外网,在R1,R3上分别开启地址转换信息显示和HSRP信息显示,可以观察看你想看到的信



    实验总结:
    1.在一个HSRP组内的多个路由器共用一个虚拟的物理地址和IP地址,该地址被作为局域网内所有主机的缺省网关地址。HSRP协议决定哪个路由器被激活,该被激活的路由器接收发过来的数据包并进行路由。
    2.相关命令:
    •standby ip: 用于激活HSRP。
    •standby priority: 用于设定端口的HSRP优先级,具有最高备份优先级的HSTP成员将成为激活路由器(假设设置为优先权方式)。
    • standby timers: 用于设定hello包之间的时间间隔(hello time)以及路由器在多长一个时间段内没有从HSRP邻居收到hello包就判定该邻居已关闭(hold time)。
    • standby preempt: 表明当本地路由器的备份优先级超过当前激活路由器时,它就将接管控制权,成为激活路由器。
    • standby track: 用于设置允许路由器端口根据另一端口的可用性而修改自己的HSRP优先级值
    3.配置HSRP步骤:
    ①创建虚拟IP,用作内网网关
    ②抢占线路优先级
    ③提高组优先级
    ④监视端口(监视的端口down掉后,自动下降所设的优先级值,默认自动下降10)
    4.一个路由器可以同时属于多个HSRP组,该特性允许网络管理员在提供冗余能力的同时对各路由器进行负载平衡。在上图中,两台PC使用不同的缺省网关,主机1以HSRP组1的虚拟IP地址192.168.10.254为缺省网关,而主机2以组2的虚拟IP地址192.168.20.254为缺省网关。
    在正常工作状态下,局域网的数据流量在两台路由器之间均分;一旦发生故障,备份路由器被激活,所有流量被路由至该路由器的端口。上图中的两台路由器均同时属于两个HSRP组,路由器1是组1的激活路由器及组2的备份路由器,路由器3是组2的激活路由器及组1的备份路由器。


    转载于:https://blog.51cto.com/hhb2050/586228

    展开全文
  • 1、copyrunning-configstartup-config这个命令是将存储在RAM的正确配置拷贝到路由器的NVRAM中。这样,在下一次启动时,路由器就会使用这个正确的配置。2、copyrunning-configtftp这个命令是将RAM中正确的配置文件...

    1

    copy running-config startup-config

    这个命令是将存储在

    RAM

    的正确配置拷贝到路由器的

    NVRAM

    中。

    这样,

    在下一次启动时,

    路由器就会使用这个正确的配置。

    2

    copy running-config tftp

    这个命令是将

    RAM

    中正确的配置文件拷贝到

    TFTP

    服务器上,我们强烈推荐网络管理员这

    样做,因为如果路由器不能从

    NVRAM

    中正常装载配置文件,我们可以通过从

    TFTP

    中拷

    贝正确的配置文件。

    it168#copy running-config tftp

    address or name of remote host

    []?129.0.0.3

    destination file name [it168-confg]?

    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    624 bytes copied in 7.05 secs

    it168#

    当网络管理员输入命令并键入回车后,路由器会要求输入

    TFTP

    服务器的

    IP

    地址,在正确

    的键入服务器

    IP

    地址后,路由器还要求网络管理员提供需要备份的配置文件名。一般我们

    建议使用管理员容易记忆的文件名。这时路由器会提示管理员按

    YES

    确认操作。

    3

    copy tftp running-config

    如果路由器的配置文件出现问题,

    这时我们就可以通过从

    TFTP

    服务器中拷贝备份的配置文

    件。具体配置如下:

    it168#copy tftp running-config

    address or name of remote host[]?

    129.0.0.3

    source filename []?it168-confg

    destination file name [running-config]?

    accessing tftp://129.0.0.3/it168-confg

    loading it168-confg from 129.0.0.3

    (via fastethernet 0/0):

    !!!!!!!!!!!!!!!!!!!!!!!

    展开全文
  • 下面我们就为大家介绍如何使用COPY命令备份配置文件,以及如何从TFTP服务器拷贝备份配置文件。1、copyrunning-configstartup-config这个命令是将存储在RAM的正确配置拷贝到路由器的NVRAM中。这样,在下一次启动时,...
  • 思科路由器配置通过TFTP备份 首先:从网上下载tftp serverA.将路由器FLASH中的文件copy出来的步骤:1、首先在PC机上运行TFTP server,TFTP server的地址为本PC机的IP地址192.168.100.25;2、一旦我们启用了一个...
  • 对于普通用户来讲,学习如何进行备份Cisco路由器配置文件是很有必要的,能够保证我们的路由器安全。备份思科路由器配置文件是一种非常好的习惯,就像我们备份系统一样,在遇到不可挽回的错误的时候,我们通过还原...
  • 思科路由器IOS系统和配置文件的备份、删除及还原 续上篇讲的思科路由器的密码重置,本篇讲一下思科路由器iOS系统的备份、删除 还原。在生产情况下,很少有iOS文件的丢失的,大多是人为的删除,可能是为了安全,也有...
  • 如何备份思科cisco路由器配置文件 本资料之提供大家参考学习^*^ 有什么不懂的地方在博客中留言 QQ:569535658发布时间:2009-4-08 15:52:13 发布人:fengyifan 在路由器的配置过程中,经常会用到COPY这个命令。...
  • 1.CISCO 与华为 3COM 路由器配置差别分析 本文主要从配置性能,远程配置,备份中心,配置帧中继(Frame-Relay 等区别,详细的向 大家说明了配置的差别,下面文章将给出详细介绍 华为路由器与同档次的 CISCO 路由器在功能...
  • Cisco路由器配置信息在Unix下的备份、恢复与更新 安装配置—路由器的硬件连接二(组图) 把Windows Server 2003配置为NAT路由器 华为路由器简单配置详解 华为家用SOHO路由器配置指南 路由器交换机VLAN配置实例 解决...
  • 首先:从网上下载tftp server A.将路由器FLASH中的文件copy出来的步骤: 1、首先在PC机上运行TFTP server,TFTP server的地址为本PC机的IP地址192.168.100.25;...3、我们还应该在本地路由器上查看一下fl...
  • 【笔记】思科路由器常用配置命令

    千次阅读 2017-02-07 13:13:26
    用TFTP工具进行路由器配置备份及还原。 下载Cisco TFTP工具 开启TFTP软件,设定好备份路径 确定计算机与路由器是否连通 用copy running-config tftp 将运行配置文件备份至TFTPServer,...
  • 先按照拓扑把基本的IP配置好,名字也要改。 R1-gw配置 Router>en Router#conf t Router(config)#ho R1-gw R1-gw(config)#int g0/0 R1-gw(config-if)#ip add 192.168.1.252 255.255.255.0 R1-gw(config-if)#no sh ...
  • 2、一旦启用了一个TFTP Server,那么在路由器上用PING命令来确保该TFTP Server可以到达;3、还应该在本地路由器上查看一下flash的容量大小及其中IOS操作系统的文件名,可以使用命令show flash:来查看;4、在路由器...
  • 思科IOS配置文件的自动备份与回退需要使用到IOS的archive归档配置模式功能,般来说,只有IOS的版本号在12.3(4) 与其之后的版本才带有归档配置模式功能
  • 思科路由器基本配置命令 一、单臂路由配置 二、静态路由配置 三、ospf动态路由配置 四、路由器上DHCP配置 五、ACL访问控制列表配置 六、NAT配置 七、HSRP热备份配置
  • 首先亮出必备命令来: 配置HSRP的成员: Router(config-if)#standby备份组号 ip 备份组虚拟IP地址 配置HSRP优先级: Router(config-if)#standby备份组号priority 优先级...配置端口跟踪:活跃路由器配置 ...
  • 本人测试了SecureCRT脚本批量执行备份cisco交换机或者路由器配置文件的功能。 测试通过(成功批量备份200台交换机,时间小于10分钟)。 此脚本可以根据你的需要修改,改成其他功能。 使用SecureCRT对所有交换机...
  • 设备的管理是维护设备正常运行的基本条件,所以这里我们就来了解一下思科路由器和交换机的一些基本管理命令和方法。 管理路由器和交换机的方法以及命令主要分为一下几个方面: 1、了解命令行的模式。 2、配置接口的...
  • 1、网络设备(含华为路由器、交换机、思科交换机)每天对配置进行一次备份备份配置后,发送邮件2、假如你的设备华为设备管理地址为:10.1.1.1-40 , 思科设备为 10.2.1.1-40 ,需要分别对其进行备份。可以建一个...
  • “一点通路由模拟软件”是在分析了国外同类产品的基础上设计的路由模似软件,在功能上具有建立网络图、交换机和路由器的初始化、升级、备份、划分VLAN、静态路由、默认路由、动态路由的配置,练习写访问控制列表。...
  • HSRP的作用是指能够将多台路由器作为备份使用,指的是当正常工作的路由器出现故障的时候,备份路由器能够顶替它进行工作,既是由备份路由器变为主路由器。 一 简单配置HSRP(热备份路由选择协议)步骤 1,进入接口...
  • 在现网网络工程项目中,往往需要对路由器、交换机设备的操作系统、配置文件进行备份、升级,这时候,就需要搭建tftp或者ftp进行传输。(1)首先来演示一下用tftp与思科设备进行连接,首先要下载一款tftpd32.exe这款...
  • 前几天做了一下思科2611路由器IOS的备份工作,这里贴出来与大家分享一下经验: 因为大部分思科2611路由器IOS不支持VPN功能,所以鉴于工作需求,要更换路由器的IOS. 环境: 一台笔记本,一台CISCO 2611XM路由器,一根...

空空如也

空空如也

1 2 3 4 5 6
收藏数 106
精华内容 42
关键字:

思科路由器配置备份