精华内容
下载资源
问答
  • Cisco路由器中的静态路由配置

    千次阅读 多人点赞 2019-10-17 15:03:52
    静态路由配置实验网路拓扑图 一 实验环境:GNS3,Windows10操作系统,SecureCRT8.0 二 实验目的:实现不同网段中主机的通信 三 实验过程: 1 对R1路由器的配置: 配置接口ip: conf t int f 0/1 ip...

    在日常生生活中,我们互相通信时,大家并不在同一网段。主要就是靠路由器的转发数据的功能。这次将在Cisco路由器上面,通过配置静态路由来实现不同网段的通信。
    在这里插入图片描述
    静态路由配置实验网路拓扑图

    一 实验环境:GNS3,Windows10操作系统,SecureCRT8.0

    二 实验目的:实现不同网段中主机的通信

    三 实验过程:

    1 对R1路由器的配置:
    配置接口ip:
    conf t
    int f 0/1
    ip add 192.168.2.1 255.255.255.0
    no shu
    int f 0/0
    ip add 192.168.1.1 255.255.255.0
    no shu
    end
    查看接口信息:
    sh ip int b
    在这里插入图片描述
    2 对R2路由器的配置:
    配置接口ip:
    conf t
    int f 0/1
    ip add 192.168.2.2 255.255.255.0
    no shu
    int f 0/0
    ip add 192.168.3.1 255.255.255.0
    no shu
    end
    查看接口信息:
    sh ip int b
    在这里插入图片描述

    3 配置两台VPC上面的ip
    PC1:ip 192.168.1.100 192.168.1.1(为该主机的默认网关)
    PC2:ip 192.168.3.100 192.168.3.1(为该主机的默认网关)

    4 配置R1,R2的路由信息:
    Tips:如果不配置静态路由信息,两网段的是无法ping通的,两端如果都配置了默认路由之后会造成路由环路,一端配置默认路由 0.0.0.0 0.0.0.0,也可以ping通。
    R1的静态路由配置:
    conf t
    ip route 192.168.3.0 255.255.255.0 192.168.2.2

    R2的静态路由配置:
    conf t
    ip route 192.168.1.0 255.255.255.0 192.168.2.1

    5 查看R1,R2路由表
    R1:sh ip route
    R2:sh ip route
    在这里插入图片描述
    在这里插入图片描述
    四 实验结果:
    在PC1机上面pingPC2:
    在这里插入图片描述
    在PC2机上面pingPC2:
    在这里插入图片描述
    结论: PC1与PC2均可以ping通。

    Tips:第一次PC1pingPC2时会发生少量丢包事件是正常事件,因为第一次数据在路由器转发过程中会丢包。

    展开全文
  • 华为路由器配置静态路由&默认路由

    万次阅读 多人点赞 2020-01-06 15:35:24
    1、路由器基本配置 R1: <Huawei>system-view [Huawei]sysname R1 [R1]interface g0/0/0 [R1-GigabitEthernet0/0/0]ip address 10.10.10.1 255.255.255.0 [R1-GigabitEthernet0/0/0]interface g0/0/1 [R1-...

    1、路由器基本配置 

    R1:
    <Huawei>system-view 
    [Huawei]sysname R1
    [R1]interface g0/0/0
    [R1-GigabitEthernet0/0/0]ip address 10.10.10.1 255.255.255.0
    [R1-GigabitEthernet0/0/0]interface g0/0/1
    [R1-GigabitEthernet0/0/1]ip address 11.11.11.1 255.255.255.0
    
    R2:
    <Huawei>system-view 
    [Huawei]sysname R2
    [R2]interface g0/0/0
    [R2-GigabitEthernet0/0/0]ip address 10.10.10.2 255.255.255.0
    [R2-GigabitEthernet0/0/0]interface g0/0/1
    [R2-GigabitEthernet0/0/1]ip address 12.12.12.254 255.255.255.0
    
    R3:
    <Huawei>system-view 
    [Huawei]sysname R3
    [R3]interface g0/0/0
    [R3-GigabitEthernet0/0/0]ip address 11.11.11.2 255.255.255.0
    [R3-GigabitEthernet0/0/0]interface g0/0/1
    [R3-GigabitEthernet0/0/1]ip address 13.13.13.254 255.255.255.0

    2、静态路由

    R1
    [R1]ip route-static 12.12.12.0 255.255.255.0 10.10.10.2
    [R1]ip route-static 13.13.13.0 255.255.255.0 11.11.11.2
    
    R2
    [R2]ip route-static 11.11.11.0 255.255.255.0 10.10.10.1
    [R2]ip route-static 13.13.13.0 255.255.255.0 10.10.10.1
    
    R3
    [R3]ip route-static 10.10.10.0 255.255.255.0 11.11.11.1
    [R3]ip route-static 12.12.12.0 255.255.255.0 11.11.11.1
    

    3、默认路由

    R1
    [R1]ip route-static 0.0.0.0 0.0.0.0 10.10.10.2
    [R1]ip route-static 0.0.0.0 0.0.0.0 11.11.11.2
    
    R2
    [R2]ip route-static 0.0.0.0 0.0.0.0 10.10.10.1
    [R2]ip route-static 0.0.0.0 0.0.0.0 10.10.10.1
    
    R3
    [R3]ip route-static 0.0.0.0 0.0.0.0 11.11.11.1
    [R3]ip route-static 0.0.0.0 0.0.0.0 11.11.11.1

     

    Cisco 模拟器中静态路由和默认路由设置请参考:https://blog.csdn.net/qq_34889607/article/details/103782200

    展开全文
  • 思科路由器静态路由配置

    千次阅读 2019-11-03 00:46:08
    目的二:掌握静态路由的默认路由配置 目的三:掌握路由诊断方法,会使用ping和trace等命令进行路由测试 实验设备与条件 (1)2811路由器两台,2960交换机两台,计算机若干,同异步串口连接线,网线。 (2)Cisco ...

    路由器的基本配置

    实验目的
    目的一:理解路由表的原理和工作
    目的二:掌握静态路由的默认路由配置
    目的三:掌握路由诊断方法,会使用ping和trace等命令进行路由测试 实验设备与条件
    (1)2811路由器两台,2960交换机两台,计算机若干,同异步串口连接线,网线。
    (2)Cisco Packet Tracer模拟软件
    (3)实验拓扑图。本实验拓扑图如图10-1所示。
    (4)实验设备名称和接口IP规划如表11-1所示。

    在这里插入图片描述
    在这里插入图片描述
    (一)网络拓扑和路由器基本配置
    步骤一
    首先按拓扑图10-1所示连接好各设备。其中,两个路由器之间用DCE串口线连接,其他设置之间用直通线连接;各设备的连接端口参考表10-1所示。此外,如果是在Cisco Packet Tracer模拟软件中进行操作,连接前需要参考实验八为路由器添加串口模块。
    步骤二
    配置RouterA的设备名称,以及配置其Serial1/0和FastEthernet0/0端口的IP地址、子网掩码等。其中,配置Serial1/0时需要配置时钟频率。配置命令如图10-2所示。
    在这里插入图片描述
    步骤三
    配置无误后,利用show ip route命令查看路由表信息,如图10-3所示。
    在这里插入图片描述
    步骤四
    同样,对RouterB的设备名称和端口IP进行配置。配置命令如图10-4所示。
    在这里插入图片描述
    同样配置无误后,使用show ip route命令查看路由表信息,如图10-5所示在这里插入图片描述
    这是根据两个路由器显示的路由表信息,分别在RA和RB上执行ping命令测试网络连通性,我们可以看到路由器A无法到达192.168.2.0的网络,路由器B无法到192.168.1.0的网络。
    接下来我们应该给两个路由器配置静态路由。
    步骤1
    首先为RA添加静态路由,命令格式为:ip route 目的网络 子网掩码 下一跳接口IP地址。本实验中,根据拓扑图所知只需要添加一条静态路由。
    RA(config)#ip route 192.168.2.0 255.255.255.0 172.25.1.2 //手动添加静态路由信息。此时我们再次查看路由器RA的路由表信息,(sh ip route)这时我们会发现路由表显示多了一项“S”信息,**注意:(在RA做完静态路由配置之后,要给RB配置相同的配置才会显示路由表多了一项“S”信息)**此时说明静态路由添加成功,再次执行ping命令测试,
    同样为RB添加一条静态路由,格式如下:RB(config)#ip route 192.168.1.0 255.255.255.0 172.25.1.1,再次查看路由器RA的路由表信息,(sh ip route)
    步骤2
    根据表8-1所示的IP规划设置各PC的IP、子网掩码和网关
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    最后一步,在PC上执行ping命令和tracert命令进行连通性测试和路由追踪,分别如图10-14和图10-15所示
    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • CISCO路由器基础配置配置静态路由

    万次阅读 多人点赞 2018-05-01 16:38:32
    学习Cisco的基础网络配置下载可以用Cisco公司开发的模拟器:Cisco packet tracer。本文的配置也都是用此模拟器配置的。 路由器 路由器的功能主要有以下几点: 1.实现网络互连,路由器支持各种局域网和广域网...

    学习Cisco的基础网络配置下载可以用Cisco公司开发的模拟器:Cisco packet tracer。本文的配置也都是用此模拟器配置的。

    路由器

    路由器的功能主要有以下几点:

    1.实现网络互连,路由器支持各种局域网和广域网接口,主要用于互连局域网和广域网,实现不同网络互相通信;     
    2.进行数据处理,提供包括分组过滤、分组转发、优先级、复用、加密、压缩和防火墙等功能; 
    3.网络管理,路由器提供包括配置管理、性能管理、容错管理和流量控制等功能;
    

    注:本文讲的配置为Cisco公司路由器的配置方法,不同公司的设备配置指令略有不同,有些路由协议也是只限于协议的开发公司所生产的设备使用的(如Cisco公司的动态路由协议EIGRP协议)。下图为Cisco公司生产的一款路由器,和在家里用家用路由器不同,其性能也比家用路由器强很多。
    这里写图片描述

    路由器配置

    说配置之前提一下,Cisco路由器设备使用的操作系统为IOS系统。此系统有四个模式,每个模式所能对路由器进行的操作不同:

    用户模式:用电脑连接进入路由器系统就是用户模式,只能查看路由器的一些基本信息不能对路由器进行任何配置。如下图就是进入路由器的界面,"Router>"表示的就是用户模式。
    

    这里写图片描述

    特权模式:此模式可以查看路由器的所有信息,以及对路由器进行一些简单的配置。在用户模式中输入命令"enable"进入特权模式。"Router#"表示的是特权模式。如下图进入特权模式。
    

    这里写图片描述

    全局配置模式:此模式可以对全局进行所有的配置。在特权模式中输入命令"configure terminal"进入全局配置模式。"Router(config)#"表示的是全局配置模式。如下图进入全局配置模式。
    

    这里写图片描述

    接口模式:此模式可以对路由器的接口进行配置。在全局配置模式中输入"interface + 接口名称"进入想要配置的接口。"Router(config-if)#"表示的是接口模式。如下图进入Fasthernet 0/0接口。
    

    这里写图片描述

    线路模式:此模式可以对console接口进行配置。console接口是一个特殊的接口,是对路由器进行配置时工程师用电脑连接的接口。如果在真机上配置路由器就要将电脑连接上这个接口。在全局配置模式下输入"line console 0"进入线路模式。"Router(config-line)#"表示的就是线路模式。如下图进入线路模式。
    

    这里写图片描述

    注:1)如果想从当前模式退到上一个模式,输入"exit"命令即可;有一个特殊的命令"end"输入此命令可直接退到特权模式。
        2)在IOS系统中输入命令的前几个字母之后按键盘上的"TAB"键可自动补全命令。
        3)当你只记得起命令的一半的时候可以输入一半的命令在后面输入一个"?"可查看以这些字母开头的所有命令
        如下图演示
    

    这里写图片描述

    路由器的预配置命令

    预配置是在开始进行路由配置之前对路由器进行的配置操作,如下。
    更改设备名称:

     在全局配置模式下输入"hostname + 要改的名字"。
    

    这里写图片描述

    关闭域名解析:当你在路由器中输入一些错误指令的时候,路由器中没有这些指令会把你输入的内容当作域名,会在系统中查找域名,这会使路由器有几分钟的卡顿时间,如果路由器进行了域名解析只能等它解析完才能继续进行配置很浪费时间。所以,可以在配置之前关闭域名解析。

    在全局配置模式下输入"no ip domain-lookup"。
    

    这里写图片描述
    日志同步:进行了日至同步之后,路由器的一些信息会显示在屏幕上。如有人ping此路由器时会显示在屏幕上。(ping是测试连通性协议:使用此命令可向目标网络设备发送数据包,看是否接到对方的回包。如接收到证明两设备网络连通。)

    在线路模式下输入"logging synchronous"
    

    这里写图片描述
    永不超时:当配置了日志同步之后,路由器的信息会显示在屏幕,而你只能看完了日志内容才能继续进行配置,而永不超时就是让你在显示日志的时候也可以进行配置。

    在线路模式中数入"exec-timeout  0 0"
    

    这里写图片描述
    设备加密:此加密是对刚进入路由器时加密 注:在IOS系统中输入密码时屏幕不显示密码

    在线路模式下输入"password + 密码" 再输入"login"
    

    这里写图片描述
    这里写图片描述

    设置用户名密码:

    在全局配置模式下输入"username + 用户名 password(secret密文加密) + 密码"并在线路模式下输入"login local"
    

    这里写图片描述
    这里写图片描述
    给用户权限:给设置的用户设置权限等级最高为15

    在全局配置模式下输入"username 用户名 privilege 等级数 password 密码"
    

    这里写图片描述
    给设备的特权模式加密:

    在全局配置模式下输入"enable secret 密码"
    

    这里写图片描述
    这里写图片描述
    保存指令:当配置完路由器的时候需要保存,不然重启路由器后所有命令都消失。

    特权模式下输入"copy running-config startup-config"
    

    这里写图片描述
    删除指令:删除路由器储存的所有指令。删除后需要重启路由器。

    在特权模式下输入"erase startup-config"
    

    这里写图片描述

    路由器的基本配置

    给接口配置IP地址:路由器的接口需要配置IP地址才能进行路由,该接口下所有主机都与此接口地址属于一个网段,对端路由器的接口IP也属于此网段。路由器接口地址为该接口网段的网关。

    在接口模式下给路由器配置Ip地址。输入:IP address 地址 子网掩码
      输入IP地址后需要输入"no shutdown"来打开接口。
    

    这里写图片描述
    查看接口信息:查看此路由器所有接口的信息。

    在特权模式下输入:show ip interface brief
    

    这里写图片描述
    DHCP动态主机配置协议:

    通过该协议给内部网络自动分配一些配置信息。具体配置如下图。
    注:下图的Cisco为dhcp池塘的名称可以随便设置
        network后面输入的是网段
        default-router后面输入的是网关(路由器接口地址)
        dns-server是dns服务器地址
    

    这里写图片描述
    排除地址:排除后该地址不会被自动分配给设备。上面为单个,下面为一段。

     R1(config)#ip dhcp excluded-address 172.16.1.254
     R1(config)#ip dhcp excluded-address 172.16.1.100 172.16.1.200
    

    静态路由配置

    路由表:查看本路由器的路由信息
    这里写图片描述
    路由器能进行路由需要在路由表中有路由信息,默认路由器只有直连路由的路由信息。未直连的的未知网段需要静态编辑或者动态学习。
    静态路由:
    在路由表中增加路由信息,下面为两种加表方法。
    第一种是路由网段后面写数据将要从本路由器出去的接口名称。
    第二种是路由网段后面写下一跳地址(下一个接手该数据的路由器同本路由器直连接口的IP地址)。

    R1(config)#ip route 172.16.4.0 255.255.255.0 fastEthernet 1/0
    R1(config)#ip route 172.16.4.0 255.255.255.0 172.16.3.2
    

    负载均衡:当到达同一目的地,拥有多条相似的路径时,可使数据拆分同时从多条路径传输。如下图两路经就是负载均衡。
    这里写图片描述

    路由汇总:将路由汇总后也可写在路由表中,但是路由汇总后会出现路由黑洞。

    路由黑洞:汇总后,汇总地址中部分包含的地址不存在,导致流量有去无回。

    空接口路由:可以有效解决路由黑洞。

    R1(config)#ip route 172.16.0.0 255.255.252.0 null 0
    

    缺省路由(默认路由):一条不限定目标的路径;在路由表中使用 * 标示,查表先查看设备上的所有静态、动态、直连路由后,依然没有可达路径才使用该条目。一般用于局域网连接外网。

    R1(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 1/0
    
    展开全文
  • 思科静态路由配置简单命令

    千次阅读 2020-05-16 22:00:58
    路由器配置IP en 进入用户模式 config interface f+tab键 || interface s+tab键 启用接口模式 紧跟着写上端口号0/0 || 1/0 ip address <子网掩码> 配置IP no shutdown 配置IP route en 进入用户模式 config ip...
  • 本人计算机网络课程的实验,兴许对大家有帮助,内含实验报告一份,还有Cisco的工程文件,静态路由和动态路由都以配置好。
  • 当所有的Router都连接在一起的时候,其中同一网段内是可以实现互相访问的,但是我们如何才能够让不同网段之间的路由也可以互相...那就是静态路由配置,可能有的朋友会问怎么不用动态路由协议呢?下面我们一起来看一下
  • 版权声明:如果对大家有帮助,大家可以自行转载的。...生成路由表主要有两种方法:手工配置和动态配置,即静态路由协议配置和动态路由协议配置静态路由是指有网络管理员手工配置的路由信息。静态路由的一...
  • 文章目录1、拓扑图2、R1配置3、R2配置4、R3配置 1、拓扑图 2、R1配置 进入特权模式:Router>en 进入全局模式:Router#conf t 修改设备名称:Router(config)#hostname R1 进入接口:R1(config)#int g0...配置静态
  • 两台路由器之间静态路由配置

    千次阅读 2020-03-20 09:03:19
    两台路由器之间静态路由配置 实验拓扑: 路由器0配置: Press RETURN to get started! Router>en Router#config Configuring from terminal, memory, or network [terminal]? Enter con...
  • 静态路由是指由网络管理员手工配置的路由信息,默认路由是一种特殊的静态路由,本文下面就带来了使用Cisco模拟器进行静态路由和默认路由的配置的教程,希望对大家有所帮助
  • 多个路由器配置静态路由 简单

    千次阅读 2018-01-10 15:27:00
    路由器配置中管理距离什么意思 管理距离缩写:AD 管理距离是指一种路由协议的路由可信度。每一种路由协议按可靠性从高到低,依次分配一个信任等级,这个信任等级就叫管理距离。 对于两种不同的路由协议到一个...
  • 思科静态路由配置

    2014-10-15 14:32:07
    思科静态路由配置
  • 使用思科模拟器配置静态路由

    万次阅读 多人点赞 2019-12-08 12:38:45
    在总结步骤之前,我想先讲下静态路由和rip动态路由的区别,专业解释是:静态路由是非自适应性路由计算协议,是由管理人员手动配置的,不能够根据网络拓扑的变化而改变。而动态路由是能够根据网络拓扑的变化而自动...
  • 设置浮动静态路由的目的就是为了防止因为一条线路故障而引起网络故障。言外之意就是说浮动静态路由实际上是主干路由的备份。例如下图: 假如我们设路由器之间的串口(seria)为浮动静态路由(管理距离为100),设...
  • 小伙伴们大家好,本期我们来讲解大学科目网络工程钟的思科路由器中的路由静态配置实验! 首先我们先对静态路由简单的做些了解: (1)路由器属于网络层设备,能够根据IP包头的信息,选择一条最佳路径,将数据包转发...
  • 思科模拟器 --- 路由器静态路由配置

    千次阅读 2019-10-31 16:04:42
    学习目标:掌握静态路由配置方法,通过静态路由的方式实现网络通信 1.静态路由的特点 ①路由器是根据路由表进行选路和转发的,静态路由具有简单、高效、可靠、保密性高等优点。 ②生成路由表主要有两种方法:...
  • 多个路由器设置静态路由 不同网段可以互相访问

    万次阅读 多人点赞 2016-12-12 13:01:53
    随着宽带接入的普及,很多家庭和小企业都组建了局域网来共享宽带接入。...可是如果是多网段,又想实现不同网段电脑互访,设置静态路由就要掌握方法了。  本文作为一篇初级入门类文章,会以几个简单实
  • 网络是一个大型的拓扑结构,在路由表中,最重要的是管理距离和度量值 管理距离 管理距离用来确定路由的优先级。管理距离的范围是0-255之间的整数值。...静态路由 假比如我们有如下一个网络拓扑图 ...
  • cisco 命令行(静态路由 配置)CCNA

    千次阅读 2017-12-05 21:54:41
    Router> Router>en Router>enable Router#conf Router#configure t Router#configure terminal Enter configuration commands, one per line....Router(config)#int g0/1 Router(config-if)#ip ad
  • 静态路由是指由用户或网络管理员手工配置的路由信息。当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息。静态路由信息在缺省情况下是私有的,不会传递给其他的路由器。...
  • CISCO 3台路由器静态路由

    千次阅读 2015-03-09 11:37:00
    CISCO 3台路由器静态路由 实验目的: 源:LO:192.168.0.1 ping 目的:LO:192.168.3.1 拓扑 接口配置 R1 interface Loopback0  ipaddress 192.168.0.1 255.255.255.0 interface Serial1/0  ip...
  • 思科静态路由设置

    千次阅读 2019-10-18 18:38:39
    GNS3实验|静态路由设置(三台虚拟机通过四台路由器进行互联互通) 首先,我们打开GNS3系统,进入编辑界面: [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-1j2bTLiy-1571395091233)(C:\...
  • 华为路由器静态路由配置

    千次阅读 2017-03-15 10:53:53
    关于出现多个###的问题:将包含eNSP的程序项全部允许防火墙通过,同时“公用”下对应的选择框也需要√;重新启动eNSP后,再打开路由器的CLI界面后恢复正常。2、华为路由基础命令进入系统视图命令:sys...
  • 在Packet Tracer 思科模拟器中,进行默认路由器静态路由的相关配置,在三层路由实现不同vlan间的通信的基础之上,测试多台pc机的连通性。
  • 路由器静态路由配置

    2021-09-07 11:52:11
    路由器静态路由配置 二、实验目的 1、掌握静态路由的配置方法和技巧; 2、掌握通过静态路由方式实现网络的连通性; 3、熟悉广域网线缆的链接方式; 三、实验内容和要求 1、实验背景: 学校有新旧两个校区,每...
  • 思科路由器配置命令(一)

    千次阅读 2020-09-29 16:01:46
    一、路由器基本配置命令 R1>enable 进入特权模式 R1#disable 退出特权模式 R1> R1#configure terminal 进入全局配置命令 R1(config)#no ip domain-lookup 关闭域名解析 R1(config)#hostname SW1 ...
  • 特权模式:enable Router1 # show running-config Router1 # show ip route Router # show ip interface brief Switch # show vlan Switch # show ip ...配置模式:configure terminal console密码...
  • 静态路由配置实现不同网段通信——实验一 实验拓扑 PC1经过R1和R2两个路由访问PC2,两台PC处于不同网段,进行通信互访,这里我们使用静态路由的方式进行模拟配置实验 1.配置R1和R2接口ip地址 R1>enable R1#...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 11,593
精华内容 4,637
关键字:

思科路由器配置静态路由命令