精华内容
下载资源
问答
  • 不同于用于匹配流量的IP访问列表,IP前缀列表主要是用来指定具体的网络可达的。前缀列表用来匹配前缀(网段)和前缀长度(子网掩码)。...name为任意的名字或者数字,prefix是指定的路由前缀(网段),le...

    不同于用于匹配流量的IP访问列表,IP前缀列表主要是用来指定具体的网络可达的。前缀列表用来匹配前缀(网段)和前缀长度(子网掩码)。前缀列表有两个参数很难理解。

    下面是普通的前缀列表的参数:

    ip prefix-list [name] [permit | deny] [prefix]/[len]
    name为任意的名字或者数字,prefix是指定的路由前缀(网段),len是指定的前缀长度(子网掩码)。例子如下:

    ip prefix-list LIST permit 1.2.3.0/24

    上面的例子中指定匹配网段1.2.3.0,并且指定子网掩码为255.255.255.0,这个列表不匹配1.2.0.0/24,也不匹配1.2.3.4/32

    ip prefix-list LIST permit 0.0.0.0/0

    上面的例子指定匹配网段0.0.0.0和子网掩码0.0.0.0。这个列表用来匹配默认路由。

    通常情况下,在使用前缀列表的时候加上“GE”(大于或等于)和“LE”(小于或等于)时比较容易发生混淆。这是因为当使用“GE”和“LE”时,列表的长度(len)发生了改变。

    另外一种前缀列表的参数:

    ip prefix-list [name] [permit | deny] [prefix]/[len] ge [min_length] le [max_length]

    name为任意的名字或者数字,prefix是将要进行比较的路由前缀(网段),len是指从最左边开始的比特位,min_length为最小的子网掩码的值,max_length为最大的子网掩码的值

    使用GE和LE,必须满足下面的条件:

    len < GE <= LE

    上面的参数很容易混淆,简单的说就是一个匹配前缀或子网的地址的范围。

    看下面的例子:

    ip prefix-list LIST permit 1.2.3.0/24 le 32

    上面的例子表示前缀1.2.3.0前面的24位必须匹配。此外,子网掩码必须小于或等于32位

    ip prefix-list LIST permit 0.0.0.0/0 le 32

    上面的例子意味着0位需要匹配,此外子网掩码必须小于或等于32位。一位所有的网段的掩码都小于或等于32位,并且一位都不用匹配,所以这句话等于permit any

    ip prefix-list LIST permit 10.0.0.0/8 ge 21 le 29

    上面的例子说明网段10.0.0.0的前8位必须匹配,此外子网掩码必须在21位和29位之间。

    注意:

    使用前缀列表不能像访问列表那样匹配具体的应用流。
    前缀列表也不能用来具体匹配奇数或偶数的前缀,或什么可以被15整除的前缀
    在前缀列表中,比特位必须是连续的,并且从左边开始
    ip prefix-list fuck permit 0.0.0.0/0 ge 1            表示除了默认路由外的所有路由
    ip prefix-list test16 seq 5 permit 0.0.0.0/1 ge 8 le 8                配置A类地址
    ip prefix-list test16 seq 10 permit 128.0.0.0/2 ge 16 le 16      配置B类地址
    ip prefix-list test16 seq 15 permit 192.0.0.0/3 ge 24 le 24      配置C类地址

    ---------------------------------------------------------------------------------------------

    Exercises:

    1. Construct a prefix list that permits only the 192.168.1.0/24 network.

    ip prefix-list test1 seq 5 permit 192.168.1.0/24

    2. Construct a prefix list that denies network 119.0.0.0, and permits all other prefixes (including all subnets of 119.0.0.0).

    ip prefix-list test2 seq 5 deny 119.0.0.0/8
    ip prefix-list test2 seq 10 permit 0.0.0.0/0 le 32

    3. Construct a prefix list that permits only the default route.

    ip prefix-list test3 seq 5 permit 0.0.0.0/0

    4. Construct a prefix list the permits everything except the default route.

    ip prefix-list test4 seq 5 deny 0.0.0.0/0
    ip prefix-list test4 seq 10 permit 0.0.0.0/0 le 32

    5. Construct a prefix list that permits network 172.16.0.0 and any of its subnets, and denies all other prefixes.

    ip prefix-list test5 seq 5 permit 172.16.0.0/16 le 32

    6. Construct a prefix list that permits only the following prefixes:
    10.2.8.32/27
    10.2.8.32/28
    10.2.8.32/29
    10.2.8.32/30

    ip prefix-list test6 seq 5 permit 10.2.8.32/27 le 30

    7. Construct a prefix list that:

    Permits 197.25.94.128/25
    Denies 197.25.94.192/26
    Permits 197.25.94.224/27
    Denies 197.25.94.240/28
    Permits 197.25.94.248/29
    Denies 197.25.94.252/30
    Permits all other prefixes, except for 198.82.0.0/16

    ip prefix-list test7 seq 5 deny 197.25.94.192/26
    ip prefix-list test7 seq 10 deny 197.25.94.240/28
    ip prefix-list test7 seq 15 deny 197.25.94.252/30
    ip prefix-list test7 seq 20 deny 198.82.0.0/16
    ip prefix-list test7 seq 25 permit 0.0.0.0/0 le 32

    8. Construct a prefix list that permits any prefix matching the first 20 bits of 175.29.64.0 which has a mask of at least /26 but not exceeding /29, and denies all other prefixes.

    ip prefix-list test8 seq 5 permit 175.29.64.0/20 ge 26 le 29

    9. Construct a prefix list that denies any prefix matching the first 19 bits of 15.26.96.0 with any mask up to and including /32, and permits any other prefix.

    ip prefix-list test9 seq 5 deny 15.26.96.0/19 le 32
    ip prefix-list test9 seq 10 permit 0.0.0.0/0 le 32

    10. Construct a prefix list that denies the RFC 1918 private networks and any of their subnets, and permits everything else.

    ip prefix-list test10 seq 5 deny 10.0.0.0/8 le 32
    ip prefix-list test10 seq 10 deny 172.16.0.0/12 le 32
    ip prefix-list test10 seq 15 deny 192.168.0.0/16 le 32
    ip prefix-list test10 seq 20 permit 0.0.0.0/0 le 32

    11. Construct a prefix list that permits any subnet of network 15.0.0.0 (but not the network), and denies everything else. Your router lies within AS 65011. Place the prefix list in service in the inbound direction with BGP neighbor 1.2.3.4.

    ip prefix-list test11 seq 5 permit 15.0.0.0/8 ge 9

    To place it in service:
    router bgp 65011
    neighbor 1.2.3.4 prefix-list test11 in

    12. Construct a prefix list that denies 162.56.0.0/16 and all of its subnets (with the exception of 162.56.209.208/29, which is permitted), and permits all other prefixes. Your router lies within AS 65012. Place the prefix list in service in the outbound direction with its BGP neighbor having address 5.6.7.8.

    ip prefix-list test12 seq 5 permit 162.56.209.208/29
    ip prefix-list test12 seq 10 deny 162.56.0.0/16 le 32
    ip prefix-list test12 seq 15 permit 0.0.0.0/0 le 32

    To place it in service:
    router bgp 65012
    neighbor 5.6.7.8 prefix-list test12 out

    13. Construct a prefix list that permits the CIDR block containing the thirty-two class C networks beginning with 200.202.160.0/24, and denies everything else. Your router is within AS 65013. Place the prefix list in service in the inbound direction with BGP peer-group "Lucky_13".

    ip prefix-list test13 seq 5 permit 200.202.160.0/19

    To place it in service:
    router bgp 65013
    neighbor Lucky_13 prefix-list test13 in

    14. Construct a prefix list that denies any prefix for which the most-significant four bits are "0110", and permits everything else.

    ip prefix-list test14 seq 5 deny 96.0.0.0/4 le 32
    ip prefix-list test14 seq 10 permit 0.0.0.0/0 le 32

    15. Construct a prefix list that permits the host address of "CatSpace", and denies everything else.

    ip prefix-list test15 seq 5 permit 64.82.100.67/32

    16. Construct a prefix list that permits only classful networks, and denies everything else.

    ip prefix-list test16 seq 5 permit 0.0.0.0/1 ge 8 le 8
    ip prefix-list test16 seq 10 permit 128.0.0.0/2 ge 16 le 16
    ip prefix-list test16 seq 15 permit 192.0.0.0/3 ge 24 le 24

    17. Construct a prefix list that denies only supernets, and permits everything else.

    ip prefix-list test17 seq 5 deny 0.0.0.0/1 le 7
    ip prefix-list test17 seq 10 deny 128.0.0.0/2 le 15
    ip prefix-list test17 seq 15 deny 192.0.0.0/3 le 23
    ip prefix-list test17 seq 20 permit 0.0.0.0/0 le 32

    18. Construct a prefix list that permits only subnets, and denies everything else.

    ip prefix-list test18 seq 5 permit 0.0.0.0/1 ge 9
    ip prefix-list test18 seq 10 permit 128.0.0.0/2 ge 17
    ip prefix-list test18 seq 15 permit 192.0.0.0/3 ge 25

    19. Construct a prefix list that permits only CIDR blocks encompassing at least 32 class-C equivalents.

    ip prefix-list test19 seq 5 deny 0.0.0.0/0
    ip prefix-list test19 seq 10 permit 0.0.0.0/0 le 19

    20. Construct a prefix list that permits only the RFC 1918 private networks and their subnets, and configure RIP to use this prefix list for outbound routing advertisements.

    ip prefix-list test20 seq 5 permit 10.0.0.0/8 le 32
    ip prefix-list test20 seq 10 permit 172.16.0.0/12 le 32
    ip prefix-list test20 seq 15 permit 192.168.0.0/16 le 32

    To place it in effect for outbound RIP updates:
    router rip
    distribute-list prefix test20 out

    转载于:https://blog.51cto.com/1841cisco/1110482

    展开全文
  • 在大型的企业中,可能在同一网内使用到多种路由协议,为了实现多种路由协议的协同工作,路由器可以使用路由重分发(route redistribution)将其学习到的一种路由协议的路由通过另一种路由协议广播出去,这样网络的...

    在大型的企业中,可能在同一网内使用到多种路由协议,为了实现多种路由协议的协同工作,路由器可以使用路由重分发(route redistribution)将其学习到的一种路由协议的路由通过另一种路由协议广播出去,这样网络的所有部分都可以连通了。 为了实现重分发,路由器必须同时运行多种路由协议,这样,每种路由协议才可以取路由表中的所有或部分其他协议的路由来进行广播。

    重分发分为两种

    • 双向重分发:在两个路由选择进程之间重分发所有路由

    • 单向重分发:将一条路由传递给一种路由选择协议,同时只将通过该路由选择协议获得网络传递给其他路由选择协议。

    重发布常用命令

    redistriute  protocol [metric metric-value]
    [match internal | external nssa-external type][route-map map-tag]
    

    路由重发布是,必须给重分布而来的路由指定的度量值被称为默认度量值(metric值)或种子度量值,它是在重分发配置期间定义的。OSPF度量值为:代价,RIP度量值为:跳数

    路由重发布案例

    在这里插入图片描述

    1、配置R1接口IP地址

    R1(config)#interface gigabitEthernet 0/0
    R1(config-if)#ip address 192.168.1.1 255.255.255.0
    R1(config-if)#no shutdown
    

    2、配置R1动态路由RIP

    R1(config)#router rip
    R1(config-router)#version 2
    R1(config-router)#network 192.168.1.0
    

    3、配置R2接口IP地址

    R2(config)#interface gigabitEthernet 0/0
    R2(config-if)#ip address 192.168.1.2 255.255.255.0
    R2(config-if)#no shutdown
    R2(config)#interface gigabitEthernet 0/1
    R2(config-if)#ip address 192.168.2.2 255.255.255.0
    R2(config-if)#no shutdown
    

    4、配置R2动态路由RIP和OSPF

    R2(config)#router rip
    R2(config-router)#version 2
    R2(config-router)#network 192.168.1.0
    R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
    R2(config-router)#router-id 2.2.2.2
    R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
    

    6、配置R3的接口地址

    R3(config)#interface gigabitEthernet 0/1
    R3(config-if)#ip address 192.168.2.3 255.255.255.0
    R3(config-if)#no shutdown
    

    7、配置R3的OSPF

    R3(config)#router ospf 1
    R3(config-router)#router-id 3.3.3.3
    R3(config-router)#network 192.168.2.0 0.0.0.255 area 0
    

    8、配置路由重发布策略

    R2(config)#router rip
    R2(config-router)#redistribute ospf 1 metric 5
    R2(config)#router ospf 1
    R2(config-router)#redistribute rip subnets
    

    9、验证
    在这里插入图片描述
    从上图可以R3已经从RIP协议中学到了路由条目了。

    展开全文
  • 思科 华为 路由重发布 网络拓扑图如下: R1的配置 R1(config)#inte0/0 R1(config-if)#ipadd192.168.1.1255.255.255.0 R1(config-if)#noshu R1(config-if)#ints1/0 R1(config-if)#ipadd192.168.2.1255.255.....

    思科 华为 路由重发布

    网络拓扑图如下:

     

    R1 的配置

    R1(config)#int e0/0

    R1(config-if)#ip add 192.168.1.1 255.255.255.0

    R1(config-if)#no shu

    R1(config-if)#int s1/0

    R1(config-if)#ip add 192.168.2.1 255.255.255.0

    R1(config-if)#no shut

    R1(config-if)#exit

    R1(config)#router rip

    R1(config-router)#netw 192.168.1.0 

    R1(config-router)#netw 192.168.2.0 

    R1(config-router)#exit

    R1(config)#exit

    R1#show ip rout

    R2的配置

    R2(config)#int s0/0

    R2(config-if)#ip add 192.168.2.2 255.255.255.0

    R2(config-if)#no shu

    R2(config-if)#int s0/1                        

    R2(config-if)#ip add 192.168.3.1 255.255.255.0

    R2(config-if)#no shu

    R2(config-if)#exit

    R2(config)#router rip

    R2(config-router)#network 192.168.2.0

    R2(config-router)#redistribute ospf 1 met 1 

    R2(config-router)#redistribute connected 

    R2(config)#router ospf 1

    R2(config-router)#network 192.168.3.0 0.0.0.255 area 0

    R2(config)#router ospf 1

    R2(config-router)#re

    R2(config-router)#redistribute rip

    % Only classful networks will be redistributed

    R2(config-router)#redistribute connected

    R3的配置

    R3(config-if)#ip add 192.168.4.2 255.255.255.0

    R3(config-if)#exit

    R3(config)#router ospf 1

    R3(config-router)#network 192.168.3.0 0.0.0.255 area 0

    R3(config-router)#network 192.168.4.0 0.0.0.255 area 0
    华为 在ensp 模拟上与实际做的命令不太相同 配置ospf 很大都是不同

    对于R1配置  

    [R1]rip 

    [R1-rip-1]un sum

    [R1-rip-1]network 192.168.1.0

    [R1-rip-1]network 192.168.2.0

    [R1-Ethernet0/0/0]ip add 192.168.1.1 24

    hernet0/0/0]rip ver 2

    [R1-rip-1]int s0/0/0

    [R1-Serial0/0/0]rip ver 2

    [R1-Serial0/0/0]ip add 192.168.2.1 24

    [R1-Serial0/0/0]sh

    [R1-Serial0/0/0]un sh

    [R1]dis ip rout

    对于R2配置

    [R2]rip

    [R2-rip-1]netw 192.168.2.0

    [R2-rip-1]im ospf 1 

    [R2]int s0/0/0

    [R2-Serial0/0/0]ip add 192.168.2.2 24

    [R2-Serial0/0/0]rip ver 2

    [R2-Serial0/0/0]sh

    [R2-Serial0/0/0]un sh

    [R2]rip

    [R2-rip-1]netw 192.168.2.0 

    [R2-rip-1]import ospf 1 

    [R2-rip-1]int s0/0/1

    int s0/0/1

    [R2-Serial0/0/1]ip add 192.168.3.1 24

    [R2]ospf

    [R2-ospf-1]import-route rip

    [R2-ospf-1]area 0

    [R2-ospf-1-area-0.0.0.0]netw 192.168.3.0 0.0.0.255 

    对于R3

    [R3]int s0/0/0

    int s0/0/0

    [R3-Serial0/0/0]ip add 192.168.3.2 24

    [R3-Serial0/0/0]sh

    [R3-Serial0/0/0]un sh

    [R3-Ethernet0/0/0]ip add 192.168.4.1 24

    [R3-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255

    [R3-ospf-1-area-0.0.0.0]network 192.168.4.0 0.0.0.255

    #有点像三层交换机

    验证:

    R1

     

     

    注:实际的华为设备ospf协议命令如下:

    [Huawei]int s0/0/0

    [Aweigh-Serial0/0/0]ospf enable area 0

    进入端口配置协议

    转载于:https://blog.51cto.com/dg123/1069145

    展开全文
  • GNS3是一款优秀的具有图形化界面可以运行在多平台,那么怎么用GNS3配置RIP与OSPF路由重发布?下面脚本之家的小编带大家一起学习一下,用GNS3配置RIP与OSPF路由重发布的步骤
  • 1.路由重分发 理解路由重分发 一个单一P路由协议是管理网络中IP路由的首选方案 Cisco OS能执行多个路由协议,每... Cisco lOS使用路由重分发特性以交换由不同协议创建的路由信息 路由重分发的考虑: 度量值 ...

    1.路由重分发

    • 理解路由重分发

           一个单一P路由协议是管理网络中IP路由的首选方案

          Cisco OS能执行多个路由协议,每一个路由协议和该路由协议所服务的网络属于同一个自治系统

          Cisco lOS使用路由重分发特性以交换由不同协议创建的路由信息

    • 路由重分发的考虑:

                                  度量值

                                  管理距离

    • OSPF重分发路由

    重分发到OSPF域中路由的路径类型

           类型1的外部路径(Tvpe1 external path,E1)

           类型2的外部路径(Tvpe2 external path,E2)

    • 路由器A有两条到达外部目的网络10.1.2.0的路径

                             E1类型                                                                      E2类型

               路径A-B-D的代价是35(5+20+10)·                              路径A-B-D的代价是30(20+10

               路径A-C-D代价为50(30+10+10)·                                路径A-C-D的代价为20(10+1

    2.路由重发布配置

    • 路由重分发配置命令

    Router(config-router)#redistribute protocol [metric metric-value] [metric-type type-valuel [subnets]

    • OSPF与RIP重分发配置实例

    router rip

           redistribute ospf 1 metric 10

    router ospf 1

           redistribute rip metric 200 subnets

    • OSPF重分发静态路由配置实例

    router ospf 1

          redistribute static metric 100 subnets metric-type 2

    • OSPF重分发默认路由配置实例

    router ospf 1

          network  192.168.0.0  0.0.0.255  area 0

          default-information originate metric 10 metric-type 1

    ip route  0.0.0.0  0.0.0.0  10.0.1.1

    3. 路由重发布配置实例

    • 需求分析

           公司网络中运行了多种路由协议

           配置重分发实现公司内部网络互通

           总公司R1上重分发默认路由实现全网访问Internet

          7个路由值在70以上即可

    拓扑图如下:

    • 配置路由IP地址、路由、ospf、RIP配置

    R1

    R2

    R3

    R4

    R5

    R6

    R7

    • 将静态路由注入到OSPF协议中

    • R4学到了这个路径  E2是外部路径

    • 将直连路由注入到OSPF协议中

    • R3上的路由重发布

    • 指定类型为E1  *表示默认路由

    • 将RIP注入到OSPF协议中

    • 将OSPF协议学习到的路由注入到RIP中去

    • 测试连通性

    OSPF总结

    • 常见的6种LSA

    LSA1、LSA2、LSA3、LSA4、LSA5、LSA7

    • 每一种区域中允许泛洪的LSA

    • 0SPF的路径类型

    区域内路径、区域外路径、类型1的外部路径和类型2的外部路径

    • OSPF的路径类型的优先级

    区域内路径     优先级1

    区域间路径:     优先级2

    E1外部路径     优先级3

    E2外部路径     优先级4

    1表示最高的优先级,4表示最低的优先级

    • 0SPF地址汇总

    OSPF地址汇总的作用:

                                        地址汇总也是通过减少泛洪的LSA数量节省资源

                                        可以通过屏蔽一些网络不稳定的细节来节省资源

                                        减少路由表中的路由条目

    • 区域间路由汇总配置

    Router(config-router)farea area-id range ip-address mask(在区域边界路由器上做)

    • 外部路由汇总配置

    Router(config-router)#summary-address ip-address mask

    展开全文
  • 1::给R10/1R20/10/0look0R30/0配置OSPF放入aren12:给R30/0look0R40/1配置OSPF放入aren03:给R40/0look0R50/0look0放入aren24:给R10/0look0R60/0look0放入version35:给R6R1配rip6:给...
  • 简介:IS-IS协议同标准协议OSPF一样,是一种链路状态动态路由协议,但是它比...进行路由重发布,实现R5、R6互通3.实现域间和外部路由汇总实验步骤:1.在R1到R6上做基本配置,以及环回口。(略)2.运行IS-IS协议和RIP...
  • 这两个重发布的路由器上,指定将OSPF重发布进入RIP中时度量值为1 为什么要是1? 这样做了后,会有路由回馈的问题,下面将详细分析 此时,查看R4的路由表 去往R1 R2的环回、12网段走的是OSPF 产生原因:...
  • 将链路的IP地址、路由协议配置完成后,按照如下顺序进行重发布 重发布步骤: 1.将R6环回重发布到EIGRP,指定度量值 2.R2上将EIGRP重发布到OSPF 3.R4上将OSPF重发布到EIGRP,指定与步骤1相同的度量值 4.最后,R2...
  • 我是艺博东,是一个思科...双点双向重发布(OSPF、IS-IS)文章目录一、拓扑二、底层配置三、双点双向一、拓扑二、底层配置OSPFAR2[Huawei]sysname AR2[AR2]int g0/0/0[AR2-GigabitEthernet0/0/0]ip address 10.1.12.2 ...
  • 简介:IS-IS协议同标准协议OSPF一样,是一种链路状态动态路由协议,但是它比ospf做了很多优化,减少了路由类型、LSA的泛洪,在现网...进行路由重发布,实现R5、R6互通 3.实现域间和外部路由汇总实验步骤:1.在R1到R6...
  • 路由引入技术总结

    2017-10-07 17:34:42
    不同路由域的路由协议间是无法进行路由学习的,为了解决不同路由域不同路由协议间的路由的学习,提出了路由引入技术,思科网络中将此称之为路由重发布技术。一、路由引入的方法1、 单边界路由引入单边界路由引入是指...
  • 思科OSPF

    2013-03-29 09:35:21
    实验目的:掌握不同路由协议之间重发布的配置方法 实验要求:全网互通,不能使用静态路由以及缺省路由 实验步骤:步骤1 按LAB 2 的配置方法做好底层配置, 步骤2 在R1上起RIP v2, R2上起RIP ,EIGRP ,OSPF ...
  • 上一篇讲了RIP和OSPF路由,这篇讲一讲路由重发布
  • 上一篇讲了路由重发布,这篇讲一讲三层间VLAN互通+DHCP✨
  • 目录 各类LSA 普通区域 五类LSA 四类LSA 特殊区域 stub区域 totally stub区域 ...首先在R6上进行重发布,即将外部路由(EIGRP)引入进OSPF域内 Subents:将主网与子网全部通告 在R6上将EIG...
  • 思科表示其FabricPath技术可以满足这三大愿望,它使数据中心交换机之间的连接比传统的生成树协议(STP)更好,在这个独家测试中,我们评估了FabricPath在提高带宽,整问题路由和简化网络管理方面的能力,在这三个...
  • BGP简述-双平面

    2018-10-20 22:47:09
    BGP 一:BGP的11条属性 (入向可以做任何属性) 1、weight 思科私有属性,主要用于影响本地去往其他AS 本台路由器产生的默认值为32768;学习到的为0越大越优;...3表示其他手段如:重发布。 3、AS pa...
  • BGP总结

    2018-11-27 20:17:47
    一.BGP的属性 BGP的11条属性 (入向可以做任何属性) 1、weight思科私有属性,主要用于影响本地去往其他AS 本台路由器产生的默认值为32768;学习到的为0越大越优;...3表示其他手段如:重发布。 3、AS ...

空空如也

空空如也

1 2
收藏数 27
精华内容 10
关键字:

思科路由重发布