精华内容
下载资源
问答
  • 思科交换机配置远程登录命令

    千次阅读 2020-07-20 21:14:16
    首先我们给每台交换机配置ip地址。 sw1(config)#interface vlan 1 sw1(config-if)#no shutdown sw1(config-if)#ip address 192.168.1.1 255.255.255.0 sw1(config-if)#exit sw1(config)#username cisco password 123...

    一、拓扑图在这里插入图片描述
    首先我们给每台交换机配置ip地址。
    sw1(config)#interface vlan 1
    sw1(config-if)#no shutdown
    sw1(config-if)#ip address 192.168.1.1 255.255.255.0
    sw1(config-if)#exit
    sw1(config)#username cisco password 123
    sw1(config)#enable password 123
    sw1(config)#line vty 0 4
    sw1(config-line)#login local //登录本地用户名密码
    sw1(config-line)#exit

    sw2(config)#interface vlan 1
    sw2(config-if)#no shutdown
    sw2(config-if)#ip address 192.168.1.2 255.255.255.0
    sw2(config-if)#exit
    sw2(config)#username cisco password 123
    sw2(config)#enable password 123
    sw2(config)#line vty 0 4
    sw2(config-line)#login local //登录本地用户名密码
    sw2(config-line)#exit

    sw2#telnet 192.168.1.1 //sw2 远程登录sw1
    Trying 192.168.1.1 …Open

    User Access Verification

    Username: ciscoUsername: //sw1本地用户名 cisco
    Password: //密码123
    sw1>en
    sw1>enable
    Password: //特权模式密码123
    sw1#

    展开全文
  • 思科交换机相关配置 一、基础操作 进入交换机界面为一般用户模式 switch> 输入命令 enable进入特权用户模式 switch# ...二、Telnet远程登录设置 1.交换机配置IP地址 进入vlan 1 //int vlan 1 启用 //

    思科交换机相关配置
    一、基础操作
    进入交换机界面为一般用户模式 switch>
    输入命令 enable进入特权用户模式 switch#
    输入命令config terminal进入全局配置模式 switch(config)#
    输入命令int xxx可进入端口或者vlan的全局配置子模式switch(config-if)#

    特权用户模式可输入show命令查看相关设置,命令后输入?可查询帮助
    可用no 命令撤销已经设置的配置

    二、Telnet远程登录设置
    1.交换机配置IP地址
    进入vlan 1 //int vlan 1
    启用 //no shutdown
    设置ip地址 ///ip address ip地址 子网掩码
    2.设置交换机用户名和密码
    useename xxx
    password/secret xxx
    设置enable密码
    enable password xxx
    3.设置访问数量
    line vty 0 x(x是数量,最小为1)
    password xxx
    login
    也可以直接调用上面设置的本地用户名密码
    line vty 0 x
    login local
    4.console口的密码设置也相似
    line console 0
    login local

    三、SSH远程登录
    1.基础设置与Telnet类似
    2.设置访问数量
    line vty 0 x
    3.选择ssh方式
    transport input ssh
    4.更改hostname
    hostname xxx
    5.设置域名
    ip domain-name xxx.com
    6.设置rsa加密密钥
    crypto key generate rsa
    [512]:在360-2048中选择即可
    7.PC端登录命令
    ssh -l username ip地址

    四、交换机中划分vlan
    1.创建vlan
    vlan x(数字)
    可以使用name命令改名
    2.进入端口,分配vlan
    int f0/1
    switchport access vlan x
    3.交换机之间相连需要在连接端口做trunk
    进入连接端口
    int f0/24
    创建trunk
    switchport mode trunk

    五、核心交换机中划分vlan
    1.创建vlan
    vlan x1
    vlan x2

    2.vlan 中设置网关,vlan下的pc终端也要设置相同网关
    int vlan x
    ip address xxx xxx
    3.三层交换机与交换机相连端口做trunk
    封装dot1q协议
    switchport trunk encapsulation dot1q
    创建trunk
    switchport mode trunk
    4.如有需要,可以开启路由功能
    ip routing

    六、本地端口镜像
    1.设置源端口
    monitor session 1 source int f0/1
    2.设置目的端口
    monitor session 1 destination f0/2

    七、远程端口镜像
    1.设置远程专用vlan
    vlan 100
    开启远程端口镜像功能
    remote-span
    2.被监视交换机中
    设置源端口
    monitor session 1 source int f0/1
    设置目的端口
    monitor session 1 destination remote vlan 100 reflector-port f0/1
    3.另一台监视交换机
    同上,创建vlan,开启远程镜像
    设置源端口
    monitor session 2 source remote vlan 100
    设置目的端口
    monitor session 2 destination int f0/3

    八、PVST配置,负载均衡
    1.打开pvst功能
    spanning-tree mode pvst
    2.进入交换机全局配置模式
    配置主根
    spainning-tree vlan x1 priority 4096
    配置次根
    spanning- tree vlan x2 priority 8192
    3.进入另一个交换机
    配置主根
    spainning-tree vlan x2 priority 4096
    配置次根
    spanning- tree vlan x1 priority 8192
    3.进入另一个交换机

    九、链路聚合lacp
    1.进入需要配置的端口
    int range f0/21-24
    2.选择lacp协议
    channel-protocol lacp
    2.开启
    channel-group 1 mode active
    3.如果链路聚合需要做trunk,可以执行以下操作
    int port- channel 1
    switchport mode trunk

    展开全文
  • 然后用命令ip address x.x.x.x x.x.x.x配置IP地址。具体命令如下:Router2800>enable (进入特权模式)Router2800#configure termial (进入全局配置模式)Router2800(config)#int f0/1 (进入接口配置模式)Router2800...

    配置路由器IP地址

    然后用命令ip address x.x.x.x x.x.x.x配置IP地址。具体命令如下:
    Router2800>enable (进入特权模式)
    Router2800#configure termial (进入全局配置模式)
    Router2800(config)#int f0/1 (进入接口配置模式)
    Router2800(config-if)#ip address 192.168.0.1 255.255.255.0 (为接口分配IP地址和掩码)
    Router2800(config-if)#no shutdown (启用接口)
    Router2800(config-if)#ex (退出接口模式)

    远程登录配置

    首先路由器要设置远程登录密码(在被远程的路由器上设置)
    line vty 0 4 (允许5台设备登录)
    passwork +密码
    login
    其次全局模式下也要键入配置密码
    enable password +密码 (这个密码不安全)

    最后才能实现远程登录
    telnet + 远程登录的地址

    如果要设置一个安全的密码,如下

    R2# en
    R2#conf t
    R2(config)#enable secret 密码

    转载于:https://blog.51cto.com/13242922/2062304

    展开全文
  • 很多时候我们都是通过远程登录的方式来管理设备,因此我们必须要知道登录的方法,并且当无法登录时知道从哪几个方面来排查问题,本篇文章从华为华三和思科三种设备来阐述登录方法。 华为设备配置命令: 拓扑图: ...

    很多时候我们都是通过远程登录的方式来管理设备,因此我们必须要知道登录的方法,并且当无法登录时知道从哪几个方面来排查问题,本篇文章从华为华三和思科三种设备来阐述登录方法。

    华为设备配置命令:

    拓扑图:

    方法1. 无密码登录:

    user-interface vty 0 4

       authentication-mode none

       user privilege level 15        (也可以只给用户一个最低权限,然后在设备上面通过super命令来配置特权模式命令,方便用户操作)

    方法2. telnet密码登录:

    user-interface vty 0 4

    authentication-mode password

       set authentication password cipher k4}WW;{A6uqcXT}k'OI~o3#

    (密码认证模式有simple和cipher两种模式。simple在配置文件里为明文显示,cipher为密文显示)

    方法3.telnet账号密码登录:

    user-interface vty 0 4

       authentication-mode aaa

    aaa

    local-user admin password cipher XJUN8<9N-:5NZPO3JBXBHA!!

       local-user admin privilege level 15

       local-user admin service-type telnet

    方法4.ssh登录:

    user-interface vty 0 4

       authentication-mode aaa

       protocol inbound ssh           (华为默认绑定telnet登录)

    aaa

       local-user admin password cipher "=LP!6$^-IYNZPO3JBXBHA!!

       local-user admin privilege level 15

       local-user admin service-type ssh

    stelnet server enable          (记得开启服务)

    ssh user admin

    ssh user admin authentication-type password

    ssh user admin service-type stelnet       (设置服务类型)

    华三设备配置命令:

    拓扑图:

    方法1.无密码登录:

    line vty 0 4

       authentication-mode none

       user-role level-15

       user-role network-operator

    telnet server enable                (记得开启服务)

    方法2. telnet密码登录:

    user-interface  vty  0 4

    authentication-mode password

    user-role level-15

       user-role network-operator

       set authentication password simple admin123

    telnet server enable

    方法3.telnet账号密码登录:

    local-user admin class manage

    password simple admin123

       service-type telnet

       authorization-attribute user-role level-15

       authorization-attribute user-role network-operator

    user-interface  vty  0 4

    authentication-mode scheme

       user-role network-operator

       protocol inbound telnet

    telnet server enable

    方法4.ssh登录:

    local-user admin class manage

    password simple admin123

       service-type ssh

       authorization-attribute user-role level-15

       authorization-attribute user-role network-operator

    user-interface  vty  0 4

    authentication-mode scheme

       user-role network-operator

       protocol inbound ssh

    ssh server enable

    思科设备配置命令:

    拓扑图:

    方法1.无密码登录:

     line vty 0 4

       no login

    方法2. telnet密码登录:

    line vty 0 4

       password admin123

       login

       privilege level 15

    方法3.telnet账号密码登录:

    username admin privilege 15 password 0 admin123

    line vty 0 4

       login local

    方法4.ssh登录:

    hostname r0           (不改名字无法和其它设备区别,否则不能生成密钥)

    username admin privilege 15 secret 5 admin123

    ip domain-name abc                  (配置域名)

    crypto key generate rsa             (生成密钥)

    line vty 0 4

      login local

       transport input ssh            (绑定ssh登录)

    登录方式为ssh -l + 用户名 + 地址

     

    总结

      在配置远程登录管理设备时,经常忘记的就是开启服务,对于不同厂商设备,默认开启的服务不相同,因此在设置完成后无论哪种厂商设备都先开启下服务;对于ssh登录来说,需要一个绑定协议的过程,比telnet配置稍微复杂一些。

    展开全文
  • SSH远程登录设置:Switch#conf tEnter configuration commands, one per line. End with CNTL/Z.Switch(config)#hostname cisco-sw1 交换机重新命名cisco-sw1(config)#ip domain-name cisco.com 配置域名cisco-sw1...
  • 开始做实验 一个PC机,一个路由器,记得设置IP地址192.168.1.1 255.255.255.0 ...接下来是远程登录 打开pc机的命令提示符界面 上图为查看信息和测试,然后 这就算远程登录成功,试验完成!!! ...
  • 配置命令如下图; 最重要的是权限: 访问级(0级)、监控级(1级)、系统级(2级)和管理级(3级) 在以上基础上,做了一个远程配置方式,通过一台,修改其他的设备配置信息。 思科产品的远程登录设置:...
  • 全局调试在配置Cisco路由器时,全局和接口命令的界限是十分明显的。在这种情况下,我们使用“全局”来标识那些不能用于接口调试或者特定的传输介质类型和协议调试的命令。例如,在2500系列路由器中,就可以使用调试...
  • Telnet协议是TCP/IP协议族中的一员,是Internet远程登录服务的标准协议和主要方式。它为用户提供了在本地计算机上完成远程主机工作的能力。在终端使用者的电脑上使用telnet程序,用它连接到服务器。终端使用者可以在...
  • 全局调试在配置Cisco路由器时,全局和接口命令的界限是十分明显的。在这种情况下,我们使用“全局”来标识那些不能用于接口调试或者特定的传输介质类型和协议调试的命令。例如,在2500系列路由器中,就可以使用调试...
  • 远程登录: [R1]user-interface vty 0 4 [R1-ui-vty0-4]authentication-mode password 选择加密模式为密码加密 [R1-ui-vty0-4]set authentication password cipher(密文加密)/simple(明文加密) XXX 加密类型以及...
  • 全局调试在配置Cisco路由器时,全局和接口命令的界限是十分明显的。在这种情况下,我们使用“全局”来标识那些不能用于接口调试或者特定的传输介质类型和协议调试的命令。例如,在2500系列路由器中,就可以使用调试...
  • 实验名称:PC、交换机、路由通信实验拓扑:实验步骤:PC配置IP、交换机配置IP网关开启用户远程登录、路由器配置IP开启远程登录实验总结:Ping正常,Telnet正常。ip default-gateway 192.168.1.254实验命令:Switch&...
  • 3.配置远程登录的认证模式aaa和远程登录的协议ssh3.配置aaa的本地用户用户supadmin(设置密码、命令级别、服务类型);4.配置SSH用户supadmin认证类型为password和服务类型为STelnet;systelnet server enablersa local-...
  • 众所周知,telnet是一个远程登录的网络协议。那么在思科路由器中,能否使用这种虚拟终端协议呢?答案是肯定的。如下图所示,输入Telent命令,然后输入?帮助符,就可以看到这个命令的相关帮助。在这篇文章中,笔者结合...
  • 1.需要用到的命令: ... switch(config-if)#line vty 0 4 #配置远程,允许同时远程该交换机的电脑数最大为4个。 switch(config-if)#login local #用本地的账户密码登录。 switch(config)#username 账...
  • 华为交换机配置snmp:snmp-agent community read publicsnmp-agent sys-info version all思科交换机配置snmp:snmp-server community snailgame RO华为交换机配置远程登录:service Telnet enableuser-interface vty...
  • 全局调试在配置Cisco路由器时,全局和接口命令的界限是十分明显的。在这种情况下,我们使用“全局”来标识那些不能用于接口调试或者特定的传输介质类型和协议调试的命令。例如,在2500系列路由器中,就可以使用调试...
  • 在Smart Install Client代码中发现了基于堆栈的缓冲区溢出漏洞,该漏洞攻击者无需身份验证登录即可远程执行任意代码。cisco Smart Install是一种“即插即用”的配置和图像管理功能,可为新的交换机提供简易的部署。...
  • telnet协议是TCP/IP协议族中的一员,用于Internet远程登录服务的标准协议和主要实现方式。它使用TCP协议的23号端口完成工作,为用户提供在本地计算机上完成配置远程主机、路由器、交换机等网络设备的能力。思科的IOS...
  • 华三防火墙远程telnet登录设置

    千次阅读 2017-11-15 18:54:00
    IT行业的每个人差不多都是每天提心吊胆,严重者配置一条命令可能会让公司损失几百万。弄得不好还得追究法律责任。 本来我是做系统的,就顺便管理一下公司的网络。上周四因为一次误操作把防火墙重启,周五的时候研发...
  • 思科路由器全局、接口、协议调试 全局调试 在配置Cisco路由器时,全局和接口命令的界限是十分明显的。在这种情况下,我们使用“全局”来标识那些不能用于接口调试或者特定...我们通过telnet远程登录到路由器。在缺...
  • 思科路由器全局、接口、协议调试(上)全局调试 在配置Cisco路由器时,全局和接口命令的界限是十分明显的。在这种情况下,我们使用“全局”来标识那些不能用于接口调试或者特定的传输介质类型和协议调试的命令。例如...
  • 一、实验拓扑:二、实验要求:1、放行Outside去往...4、R2开启http secure-server服务(https服务),R1远程登录R2的443端口,查看ASA是否有提示? 三、命令部署:1、R1、R2、R3分别配置默认路由,下一跳为对应的ASA...

空空如也

空空如也

1 2
收藏数 37
精华内容 14
关键字:

思科远程登录配置命令