精华内容
下载资源
问答
  • 思科基础命令

    2020-03-24 02:27:26
    2.从特权模式进入全局配置模式 R1#configure terminal 3.设置主机名 R1(config)#hostname R1 4. 退出到特权模式 R1(config)#end 5.退出到用户模式 R1#disable 6.退出控制台线路 R1>quit 7.通过console进入控制...

    版权声明:本文为CSDN博主「陈小子」的原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。
    原文链接:https://blog.csdn.net/chentiefeng521/article/details/51746733

    路由器

    路由器的基本配置
    1.从用户模式进入特权模式

    R1>enable
    

    2.从特权模式进入全局配置模式

    R1#configure terminal
    

    3.设置主机名

     R1(config)#hostname R1
    

    4. 退出到特权模式

    R1(config)#end
    

    5.退出到用户模式

    R1#disable
    

    6.退出控制台线路

    R1>quit
    

    7.通过console进入控制台口线路

    R1(config)#line console {number}
    

    8.启动光标跟随

    R1(config-line)#logging synchronous
    

    9.设置键盘多久无动作,自动被弹出到用户模式以外,即退出
    (如果设置为0分0秒代表永不超时)

    R1(config-line)#exec-timeout {minute}{second}
    

    10.显示路由器的当前时间

    R1#show clock
    

    11.设置标语信息

    R1(config)#banner login # {text} # //这个banner配置一些登陆前的提示

    R1(config)#banner motd # {text} # //这个banner配置一些成功登陆游的提示信息

    12.进入接口配置模式

    R1(config)#interface {type} {number}
    

    13.为接口设置描述信息

    R1(config-if)#description {text}
    

    14.显示某个接口的配置信息

    R1#show running-config interface {type}{number}
    

    15. 设置特权模式进入密码

    R1(config)#enable password {password} //该密码是基于明文的(通过show
    running-config可见)

    R1(config)#enable secret {password} // 该密码是基于MD5加密的

    注:密码是区分大小写的;如果同时设置了两种认证密码,只用后者生效
    16.进入控制台口线路

    R1(config)#line console {number} //通过console线方式进入控制台

    R1(config)#line aux {number} //通过辅助接口(AUX)线路进入控制台

    R1(config)#line vty {start-number}{end-number} //通过虚拟终端线路(VTY)进入控制台

    注:虚拟终端线路(VTY)是为telnet会话所用

    17.设置控制台端口的密码

    R1(config-line)#password {password}  
    

    注:这里的登录密码是明文方式保存在DRAM(running-config)文件中

    R1(config-line)#login   //启动登陆
    

    18.关闭DNS查询功能

    R1(config)#no ip domain lookup
    

    注:默认情况下,路由器的DNS查询是启用的,当输入一条Cisco IOS无法识别的命令时,路由器会把这个命令当成主机名,然后向DNS服务器进行查询。

    19.ping测试

    R1#ping {ip-address}
    

    20.telnet测试

    R1#telnet {ip-address}
    

    注:在telnet到远端路由器的时候,如果对方的VTY线路没有设置密码和启动登陆,将拒绝本地路由器telnet。
    解决方案:在远端路由器设置VTY线路的密码和启动登陆,如下配置:

    R1(config)#line vty {start-num} {end-number} //进入VTY线路

    R1(config-line)#password {password} //设置密码

    R1(config-line)#login // 启动登陆

    R1(config-line)#end // 退出VTY线路

    21.创建静态的IP地址到主机名的映射

    R1(config)#ip host {hostname} {ip-address}
    

    22.关闭CDP协议

    R1(config)#no cdp run /*关闭CDP协议,不然会一直出现双工不匹配的提示*/
    
    R3(config)#no cdp run /*以后的实验,只要涉及到以太网接口,就关闭CDP*/
    

    重启路由器

    1.重启路由器

    R1#reload
    

    2.计划性重启路由器

    R1#reload [at {hh:mm day year} |in {minutes}][text]
    

    注:可以定义路由器,立即重启或者在多少分钟后,或在具体的时间里重启,还可以制定重启原因。如果重启之前,路由器的配置文件被修改过,系统会提醒你是否保存修改。
    3.查看重启信息

    R1#show reload
    

    接口设置

    1进入接口配置模式

    R1(config)#interface {type} {number}
    

    2.为接口设置描述信息

    R1(config-if)#description {text}
    

    3.设置接口的IP地址信息

    R1(config-if)#ip address {ip-address} {mask}
    

    4.如果为串行接口,要为DCE端设置时钟频率

    R1(config-if)#clock rate {speed}
    

    5.开启接口

    R2(config-if)#no shutdown
    

    6.显示某个接口的配置信息

    R1#show running-config interface {type}{number}

    7.恢复接口配置到出厂模式

    R1(config)#default interface {type} {number}

    静态路由配置

    1.配置静态路由

    R1(config)#iproute {network} {mask} {next-hop-address|exit-interface}
    [distance]

         network:目标网络号
    
         mask:目标网络的子网掩码
    
         next-hop-address:下一跳地址
    
         exit-interfac:下一跳路由器的接口
    

    注:选择下一跳地址和选择下一调路由器的接口作为目标网络的出口的区别在于管理距离。选择前者,管理距离为1;选择后者,管理距离为0。还可以在定义静态路由的时候指定管理距离。

    2.配置默认路由

    > R1(config)#iproute 0.0.0.0  0.0.0.0
    > {next-hop-address|exit-interface}[distance]
    
         next-hop-address:下一跳地址
    
         exit-interfac:下一跳路由器的接口
    

    注:0.0.0.0 0.0.0.0代表所有的网络。选择下一跳地址和选择下一调路由器的接口作为目标网络的出口的区别在于管理距离。选择前者,管理距离为1;选择后者,管理距离为0。还可以在定义静态路由的时候指定管理距离。

    3.显示静态路由的配置

    R1#showip route static

    RIP(距离矢量路由协议)基本设置

    配置RIP

    1.启动RIP

    R1(config)#routerip

    2.定义要宣告的直连主类网络号

    R1(config-route)#network{network-number}

    注:启动了RIP路由协议之后,只需要宣告主类直连网络号,即可完成RIP的配置
    3.查看RIP信息

    R1#showip route rip

    配置RIPv2

    1.启动RIP

    R1(config)#routerip

    2.启动RIP版本2(RIPv2)

    R1(config-route)#version2

    3.定义要宣告的直连主类网络号

    R1(config-route)#network{network-number}

    注:启动了RIPv2路由协议之后,只需要宣告主类直连网络号,即可完成RIPv2的配置
    4.查看RIP信息

    R1#showip route rip

    OSPF(链路状态路由协议)基本配置

    配置单区域OSPF

    1.启动OSPF进程:

    R1(config)#routeospf {process-id}

    注:OSPF进程ID可以使用1到65535中的任意一个整数,该ID只是本地的一个标识,即一个OSPF网络,每台OSPF路由器的进程ID是否一样,和OSPF网络能否正常运行无关。

    2.定义参与OSPF进程的接口和网络

    R1(config-route)#network{ip-address} {wildcard-mask} area {area-id}

         ip-address:直连网络地址
    
         wildcard-mask:直连网络的反掩码
    
         area-id:区域号
    

    注:在定义OSPF路由器要宣告的区域时,反掩码用来控制要宣告的范围,0表示精确匹配,255表示任意匹配。OSPF网络中骨干区域为区域0,因此必须有区域0。

    3.查看OSPF信息

    R1#showip route ospf // 查看所有的OSPF信息

    R1#showip route ospf 1 //查看进程ID为1的OSPF信息

    R1#showip ospf database //查看OSPF链路状态数据库的信息

    R1#showip ospf neighbor // 显示一个邻居列表,

    配置多区域OSPF

    1.启动OSPF进程

    R1`(config)#routeospf {process-id}

    注:OSPF进程ID可以使用1到65535中的任意一个整数,该ID只是本地的一个标识,即一个OSPF网络,每台OSPF路由器的进程ID是否一样,和OSPF网络能否正常运行无关。

    2.定义参与OSPF进程的接口和网络

    R1(config-route)#network{ip-address} {wildcard-mask} area {area-id}

         ip-address:直连网络地址
    
         wildcard-mask:直连网络的反掩码
    
         area-id:区域号
    

    注:在定义OSPF路由器要宣告的区域时,反掩码用来控制要宣告的范围,0表示精确匹配,255表示任意匹配。OSPF网络中骨干区域为区域0,因此必须有区域0。多区域的设计,才是OSPF网络的精髓。

    3.查看OSPF信息

    R1#showip route ospf // 查看所有的OSPF信息

    R1#showip route ospf 1 //查看进程ID为1的OSPF信息

    R1#showip ospf database //查看OSPF链路状态数据库的信息

    R1#showip ospf neighbor // 显示一个邻居列表,

    EIGRP(混合型路由协议) 基本配置

    配置EIGRP
    1.定义自制系统(AS)号并启用EIGRP

    R1(config)#routeeigrp {AS-number}

    2.宣告直连主类网络号

    R1(config-route)#network{network-number}

    注:EIGRP做为IGRP的扩展,它同时集合了距离矢量和链路状态路由协议的特色,参与同一EIGRP进程的EIGRP路由器必须处于相同的AS里,接下来只需要宣告直连的主类网络号即可。
    3.查看EIGRP信息

    R1#showip eigrp neighbors

    R1#showip route eigrp

    关闭EIGRP的自动汇总

    1.定义自制系统(AS)号并启用EIGRP

    R1(config)#routeeigrp {AS-number}

    2.宣告直连主类网络号

    R1(config-route)#network{network-number}

    注:EIGRP做为IGRP的扩展,它同时集合了距离矢量和链路状态路由协议的特色,参与同一EIGRP进程的EIGRP路由器必须处于相同的AS里,接下来只需要宣告直连的主类网络号即可。

    3.关闭自动汇总

    R1(config-route)#noauto-summary

    注:当路由更新主类网络边界的时候,他会自动向主类网络号进行汇总,路由自动汇总特性是EIGRP默认的操作。EIGRP可以关闭该特性。

    4.查看EIGRP信息

    R1#showip eigrp neighbors

    R1#showip route eigrp

    交换机
    基础配置
    1.从用户模式进入特权模式

    S1>enable

    2.从特权模式进入全局配置模式

    S1#configure terminal

    3.设置主机名

    S1(config)#hostnameR1

    4. 退出到特权模式

    S1(config)#end

    5.退出到用户模式

    S1#disable

    6.查看MAC地址表

    S1#show mac-address-table

    7.开启http服务(部分交换机可用)

    S1(onfig)#ip http server

    8.配置超级用户口令

    S1(config)#enable password 123456 //不加密密码

    S1(config)#enable password 7 123456 //加密密码(7是选择的加密方式)

    S1(config)#enable secret 123456 //加密密码

    S1(config)#enable secret 5 123456 //加密密码(5是选择的加密方式)

    7.显示路由器的当前时间

    R1#show clock

    8.设置系统时间(部分可用)

    S1(config)#clock set hh:mm:ss day month year

    S1(config)#clock set 12:00:00 28 August 2013

    9.配置设备管理IP地址

    S1(config)#interface VLAN1

    S1(config-if)#ip address 192.168.1.1255.255.255.0

    S1(config-ip)#exit

    注:VLAN 1是用于设备管理的默认VLAN

    10.配置默认路由

    S1(config)#ip default-gateway 192.168.1.254

    VlAN的配置
    常规配置
    1.创建VLAN

    S1(config)#vlan 100

    2.给VLAN命名

    S1(config-vlan)#name vlan100

    3.删除VLAN

    S1(config)#no vlan 100

    进入VLAN数据库配置
    1.进入VLAN数据库

    S1#vlan database

    2.创建VLAN

    S1(vlan)#vlan 100 name vlan100

    3.删除VLAN

    S1(vlan)#no vlan 100

    4.修改VLAN

    S1(vlan)#vlan 100 name v100

    分配端口到VLAN中

    S1(config)#interface f0/1

    S1(config-if)#switchport access vlan 100

    VLAN TRAN的配置

    S1(config)#interface f0/2

    S1(config-if)#switchport mode trunk //设置端口为trunk端口

    S1(config-if)#switchport trunk allowed vlan100,2 //允许vlan 100和vlan 2通过

    S1(config-if)# switchport trunk

    展开全文
  • 思科常用命令

    千次阅读 2018-11-30 15:35:15
    全局配置模式。提示符:"(config)#",进入命令:configure terminal 退出命令:exit 其他配置模式。如接口模式:提示符:"(config-if)#",进入:interface type number 退出:exit 常用...

    操作模式

    1. 用户模式。提示符:">",进入命令:初始模式。
    2. 特权模式。提示符:"#",进入命令:enable 退出命令:disable
    3. 全局配置模式。提示符:"(config)#",进入命令:configure terminal 退出命令:exit
    4. 其他配置模式。如接口模式:提示符:"(config-if)#",进入:interface type number 退出:exit

    常用命令

    设置系统日历:R1#clock set 8:43:00 12 june 2008
           R1(config)#clock timezone GMT +8 (设置时区为北京时间东八区)

    命令行帮助:任何情况输入“?”获取帮助。
    测试网络连通性:ping ip地址
    测试中间经过设备:traceroute ip地址

    查看硬件软件信息:R1>show version
    查看运行配置文件:R1# show run
    查看保存的配置文件:R1# show startup-config
    查看接口状态: R1# show interface
    查看接口与IP相关的信息:R1# show ip interface
           R1# show ip interface brief
    查看路由表:R1# show ip route
    查看路由协议:R1# show ip protocols
    配置保存:
    保存运行配置文件:R1# copy running-config startup
           或者R1# write(用运行配置文件覆盖启动配置文件)
    删除启动配置文件:R1#erase startup-config


    配置路由器

    配置路由器密码:
    (1)配置Console端口密码:
       R1(config)# line console 0
       R1(config-line)# password cisco
       R1(config-line)# login
    (2)配置从用户模式切换到特权模式的使能密码:
       R1(config)# enable password cisco
       R1(config)# enable secret cisco123 (另外可以配置秘密使能密码)
    (3)配置远程登录密码(VTY,虚拟终端类型)默认不允许远程访问
       R1(config)#line vty 0 4
       R1(config-line)#password cisco
       R1(config-line)#login

    配置路由器接口IP:
    R1(config)# interface s1/1
    R1(config-if)# ip address 12.1.1.1 255.255.255.0
    R1(config-if)# no shutdown
    R1(config-if)# exit
    配置路由器接口secondary地址:
    R1(config)# interface s1/1
    R1(config-if)# ip address 12.1.1.1 255.255.255.0
    R1(config-if)# ip address 13.1.1.1 255.255.255.0 secondary
    R1(config-if)# no shutdown
    R1(config-if)# exit
    取消接口的多个IP地址:R1(config-if)# no ip address [ip] [子网掩码]
    删除接口下的所有IP:R1(config-if)# no ip address

    配置主机名列表:
    R1(config)#ip host abc 12.1.1.2 (配置完后远程登录可以用telnet abc代替主机IP)
    查看路由器上配置的主机名列表: show host
    配置DNS服务器:ip name-server dns 服务器的IP地址

    配置静态路由
    R1(config)#ip route 目标网络 掩码 下一跳路由器直连接口的IP或本路由器外出接口 管理距离 [permanent]
    使用permanent参数,不管发生什么意外情况,该静态路由不会从路由表消失。
    前面加no删除该静态路由。

    默认路由:用来转发不在路由列表中列出的远端目的网络的数据包
    R1(config)#ip route 0.0.0.0 0.0.0.0 下一跳路由地址

    动态路由
    1. RIPv1协议配置
    R1(config)# router rip  启动路由选择进程
    R1(config-router)#network 11.0.0.0  宣告各接口的直连网络
    R1(config-router)#network 12.0.0.0

    配置默认路由(默认网关):R1(config)# ip route 0.0.0.0 0.0.0.0 23.1.1.3
                 R1(config)# ip default-network 23.0.0.0  默认网络,仅支持有类网络后面要写网络的主类地址

    负载均衡:R1(config-router)#maximum-paths 6
    关闭快速交换使用进程交换:R1(config)#no ip cef

    禁用水平分割:R1(config-if)# no ip split-horizon


    2. RIPv2协议配置
    R1(config)# router rip
    R1(config-router)# version 2
    R1(config-router)#network 主类网络号


    3. OSPF协议配置
    R1(config)#router ospf 1
    R1(config-router)#network IP子网 反掩码 area 0


    配置DHCP服务器

    R1(config)#ip dhcp excluded-address 192.168.1.1 把网关排出地址池
    R1(config)#ip dhcp pool poolname 配置DHCP地址池名字
    R1(dhcp-config)#network 192.168.1.0/24 分配网段地址
    R1(dhcp-config)#default-router 192.168.1.1 指定网关
    R1(dhcp-config)#dns-server 202.102.3.141 指定DNS服务器
    R1(dhcp-config)#lease 8 IP地址租期是8天,默认无限期
    R1(dhcp-config)#domain-name test.com 设定主机域名,可不设此项
    R1(dhcp-config)#exit

    配置DHCP中继:
    R3(config)#int fa 0/0 配置与DHCP客户端最近的以太网接口
    R3(config-if)#ip helper-address 23.1.1.2 把收到的DHCP广播包装发给DHCP服务器23.1.1.2

    常用:ipconfig/release释放先前获取的IP
      ipconfig/renew重新获取IP


    配置NAT

    配置静态NAT:
    (1) 指定外部端口。端口设置状态下输入:ip nat outside
    (2) 指定内部端口。端口设置状态下输入:ip nat inside
    (3) 在内部本地地址与内部合法地址之间建立静态地址转换。全局配置状态下输入:
    ip nat inside source static 内部本地地址 内部合法地址

    配置动态NAT:
    (1) 指定外部端口。端口设置状态下输入:ip nat outside
    (2) 指定内部端口。端口设置状态下输入:ip nat inside
    (3) 全局配置模式下定义内部合法地址池:ip nat pool 地址池名称 起始IP地址 终止IP地址 子网掩码
    (4) 全局配置模式下定义一个access-list规则以允许哪些内部地址可以进行动态地址转换:
    access-list 表号 permit 源地址 通配符
    (5) 全局配置模式下,将由access-list指定的内部本地地址与内部合法地址池进行地址转换:
    ip nat inside source list ACL表号 pool 内部合法地址池名字 [overload] 加上overload参数表示配置NAT超载

    **配置端口映射:
    将外网对218.1.1.1的TCP80端口的访问转换成对内部IP192.168.1.1的80端口访问:
    **R1(config)#ip nat inside source static tcp 192.168.1.1 80 218.1.1.1 80
    外网端为动态IP时的NAT配置:
    R1(config)#ip nat inside source list 1 int fa0/0 overload 不用创建地址池,直接借用接口fa0/0的IP,默认路由还是需要配的


    交换机基本配置

    配置默认网关:SW1(config)# ip default-gateway 1.1.1.1

    开启http服务:SW1(config)# ip http server
    关闭http服务:SW1(config)#no ip http server

    查看ARP表:show arp
    查看MAC地址表:show mac-address-table

    vlan配置:参考思科交换机VLAN配置
    查看vlan:show vlan

    访问控制列表ACL:参考思科交换机ACL配置

    展开全文
  • 4-0思科命令行基础

    千次阅读 2018-07-03 18:31:35
    用户模式:R1>enable //进入特权模式特权模式R1#conf t //进入全局模式 全局模式:R1(config)#exit //退出至上一级 ...
    用户模式:R1>enable //进入特权模式

    特权模式R1#conf t //进入全局模式

    全局模式:R1(config)#exit //退出至上一级
    R1(config)#end //退回特权模式

    接口模式:R1(config-if)#

    子接口模式R1(config-subif)#

    行模式R1(config-line)#

    查看命令:?

    补全命令:Tab

    删除命令 :no

    配置enbale密码:
    • R1(config)#hostname CCIE //修改主机名
    • CCIE(config)#enable password sovand //设置明文密码
    • CCIE(config)#enable secret sovand //设置密文密码

    console口配置:
    • R1(config)#line console 0
    • R1(config-line)#password cisco //设置登入密码
    • R1(config-line)#login //密码生效

    加密配置命令:
    • R1(config)#username cisco password sovand
    • R1(config)#service password-encryption //加密所有口令,不可逆

    vty链路配置:
    • R2(config)#line vty 0 4 //开通远程登录虚拟通道,0-4个通道
    • R2(config-line)#password cisco
    • R2(config-line)#login

    telnet远程登录设备:
    • R1#telnet 12.12.12.2 //远程登录12.12.12.2这台设备
    • R1#show sessions //检查telnet连接
    • R1#show users //检查telnet用户
    • ctrl+shift+6 X //关闭telnet

    配置接口IP地址:
    • R1(config)#int 【接口类型+端口号】 //进入接口
    • R1(config-if)#ip add 【IP地址】 【子网掩码】 //配置IP地址
    • R1(config-if)#no sh //打开接口

    远程测试设备连通性:R1#ping 【IP地址】
    R1#traceroute 【IP地址】

    查看路由配置:R1#show running-config

    保存配置:R1#wr

    重新加载路由器:R1#reload

    查询ARP缓存:R1#show ip arp

    查看一、二层状态:R1#show int

    查看路由表:R1#show ip route

    查看三层接口信息:R1#show ip int

    查看总接口信息:R1#show ip int b

    查看接口协议:R1#show protocols

    查看物流接口信息:R1#show controllers

    查看版本信息:R1#show version

    查看邻居设备:R1#show cdp neighbors

    排错命令:debug、show processes

    静态路由配置:R1(config)#ip route 【目标网段网络号】 【掩码】 【转发接口】/【下一跳地址】

    默认路由:R1(config)#0.0.0.0/0 【出接口】/【下一跳】

    回环口的配置
    • R1(config)#int loopback1 //创建了回环口1,并进入接口模式
    • R1(config-if)#ip add 【IP地址】【子网掩码】

    PC配置:模拟器中用路由器模拟PC,所以要关闭路由功能 才能配置网关
    • PC1#conf t
    • PC1(config)#no ip routing //关闭路由功能,才能配置网关
    • PC1(config)#ip default-gateway 【网关】 //配置网关ip地址,直连路由器的接口ip地址
    • PC1(config)#int 【接口】
    • PC1(config-if)#ip add 【IP地址】【子网掩码】
    • PC1(config-if)#no sh

    RIP配置:
    • R1(config)#router rip //全局模式下,用该命令开启RIP,进入RIP配置进程
    • R1(config-router)#version 2 //修改RIP版本为v2,默认是版本v1
    • R1(config-router)#network 172.16.0.0 //用来通告直连网段,以直连网段所属的主类网段来通告,效果是,network出来的网段会更新给直连路由器,RIP更新报文只会往network的接口上更新
    • R1(config-router)#network 172.17.0.0
    • R1(config-router)#no auto-summary //关闭自动汇总功能,默认v2版本是开启自动汇总
    • R1(config-if)#ip summary-address rip 172.16.0.0 255.255.252.0
    //手动汇总:在更新路由条目的出接口上配置,配置完后更新的条目就会被汇总成所配置的网段信息
    • R1#clear ip route * //手动刷新路由表,不需要等待路由老化时间
    • R1#debug ip rip //显示出所有的rip报文。关闭方法:no debug ip rip ,undebug all

    RIP认证的配置:双方配置的认证,不管是认证方式,还是认证密码一定要一致,否则不能学习到对方的路由信息
    • R2(config)#key chain 【goktech】 //定义密钥集合名字为本地定义,比如:goktech
    • R2(config-keychain)#key 1 //密钥编号,双方一定要一致
    • R2(config-keychain-key)#key-string 【cisco】 //密码,双方也要一致,比如为:cisco
    • R2(config-keychain-key)#exit
    • R2(config-keychain)#exit
    • R2(config)#int f0/1 //认证的开始需要在接口下完成,影响是这个接口下的直连路由器
    • R2(config-if)#ip rip authentication mode 【md5/text】 //设置认证的类型,有明文(text)和md5两种认证可选
    • R2(config-if)#ip rip authentication key-chain 【goktech】 //调用密钥集合,调用的是之前定义的goktech

    OSPF配置
    • R1(config)#router ospf 1
    • R1(config-router)#network 10.1.1.1 0.0.0.0 area 0
    //反掩码,0置为要跟前面的对应前缀数值相同,1置为的不匹配
    • R1#show ip ospf neighbor //查看邻居(邻接)关系
    • R1(config)#router ospf 1
    • R1(config-router)#router-id 200.1.1.1
    //配置router-id,本路由器还没有形成ospf邻居前,router-id是可以随时修改的,直接生效。 如果已经形成了邻居关系,修改router-id,必须重启进程来重置所有的本地邻居关系,以新的router-id去建立邻居关系,才能生效。
    • R2#clear ip ospf process //重置ospf进程的命令
    • Reset ALL OSPF processes? [no]: y
    • R2(config)#int f0/0
    • R2(config-if)#ip ospf priority 10
    //修改接口优先级,影响DR/BDR选举。注意不抢占的特点,需要重新建立邻居关系才会有影响

    点到点路由:
    • R4(config-router)#int loopback 1
    • R4(config-if)#ip ospf network point-to-point

    改cost值
    • R2(config)#int f0/1
    • R2(config-if)#ip ospf cost 64
    //修改接口cost,通过修改接口cost值来影响ospf路由条目的度量值,决定路由条目加表,最终影响选路

    明文认证:
    • R1(config)#int f0/0
    • R1(config-if)#ip ospf authentication
    • R1(config-if)#ip ospf authentication-key 【密码】

    MD5认证:
    • R1(config)#int f0/0
    • R1(config-if)#ip ospf authentication message-digest
    • R1(config-if)#ip ospf message-digest-key 1 md5 【密码】

    展开全文
  • 思科基础命令大全

    万次阅读 多人点赞 2016-06-23 21:06:19
    2.从特权模式进入全局配置模式 R1#configure terminal 3.设置主机名  R1(config)#hostname R1 4. 退出到特权模式 R1(config)#end 5.退出到用户模式 R1#disable 6.退出控制台线路 R1>quit 7.通过console...

    路由器

    路由器的基本配置

    1.从用户模式进入特权模式

    R1>enable

    2.从特权模式进入全局配置模式

    R1#configure terminal

    3.设置主机名

     R1(config)#hostname R1

    4. 退出到特权模式

    R1(config)#end

    5.退出到用户模式

    R1#disable

    6.退出控制台线路

    R1>quit

    7.通过console进入控制台口线路

    R1(config)#line console {number}

    8.启动光标跟随

    R1(config-line)#logging synchronous

    9.设置键盘多久无动作,自动被弹出到用户模式以外,即退出

    (如果设置为0分0秒代表永不超时)

    R1(config-line)#exec-timeout {minute}{second}

    10.显示路由器的当前时间

    R1#show clock

    11.设置标语信息

    R1(config)#banner login # {text} #    //这个banner配置一些登陆前的提示

    R1(config)#banner motd  # {text} #   //这个banner配置一些成功登陆游的提示信息

    12.进入接口配置模式

    R1(config)#interface {type} {number}

    13.为接口设置描述信息

    R1(config-if)#description {text}

    14.显示某个接口的配置信息

    R1#show running-config interface {type}{number}

    15. 设置特权模式进入密码

    R1(config)#enable password {password}  //该密码是基于明文的(通过show running-config可见)

    R1(config)#enable secret {password}    //  该密码是基于MD5加密的

    注:密码是区分大小写的;如果同时设置了两种认证密码,只用后者生效

    16.进入控制台口线路

    R1(config)#line console {number}  //通过console线方式进入控制台

    R1(config)#line aux {number}       //通过辅助接口(AUX)线路进入控制台

    R1(config)#line vty {start-number}{end-number} //通过虚拟终端线路(VTY)进入控制台

    注:虚拟终端线路(VTY)是为telnet会话所用

    17.设置控制台端口的密码

    R1(config-line)#password {password}  

    注:这里的登录密码是明文方式保存在DRAM(running-config)文件中

    R1(config-line)#login   //启动登陆

    18.关闭DNS查询功能

    R1(config)#no ip domain lookup

    注:默认情况下,路由器的DNS查询是启用的,当输入一条Cisco IOS无法识别的命令时,路由器会把这个命令当成主机名,然后向DNS服务器进行查询。

    19.ping测试

    R1#ping {ip-address}

    20.telnet测试

    R1#telnet {ip-address}

    注:在telnet到远端路由器的时候,如果对方的VTY线路没有设置密码和启动登陆,将拒绝本地路由器telnet。

    解决方案:在远端路由器设置VTY线路的密码和启动登陆,如下配置:

    R1(config)#line vty {start-num} {end-number} //进入VTY线路

    R1(config-line)#password {password}    //设置密码

    R1(config-line)#login  // 启动登陆

    R1(config-line)#end  // 退出VTY线路

    21.创建静态的IP地址到主机名的映射

    R1(config)#ip host {hostname} {ip-address}

    22.关闭CDP协议

    R1(config)#no cdp run /*关闭CDP协议,不然会一直出现双工不匹配的提示*/

    R3(config)#no cdp run /*以后的实验,只要涉及到以太网接口,就关闭CDP*/

     

    重启路由器

    1.重启路由器

    R1#reload

    2.计划性重启路由器

    R1#reload [at {hh:mm day year} |in {minutes}][text]

    注:可以定义路由器,立即重启或者在多少分钟后,或在具体的时间里重启,还可以制定重启原因。如果重启之前,路由器的配置文件被修改过,系统会提醒你是否保存修改。

    3.查看重启信息

    R1#show reload

    接口设置

    1进入接口配置模式

    R1(config)#interface {type} {number}

    2.为接口设置描述信息

    R1(config-if)#description {text}

    3.设置接口的IP地址信息

    R1(config-if)#ip address {ip-address} {mask}

    4.如果为串行接口,要为DCE端设置时钟频率

    R1(config-if)#clock rate {speed}

    5.开启接口

    R2(config-if)#no shutdown

    6.显示某个接口的配置信息

    R1#show running-config interface {type}{number}

    7.恢复接口配置到出厂模式

    R1(config)#default interface {type} {number}

    静态路由配置

    1.配置静态路由

    R1(config)#iproute {network} {mask} {next-hop-address|exit-interface} [distance]

             network:目标网络号

             mask:目标网络的子网掩码

             next-hop-address:下一跳地址

             exit-interfac:下一跳路由器的接口

    注:选择下一跳地址和选择下一调路由器的接口作为目标网络的出口的区别在于管理距离。选择前者,管理距离为1;选择后者,管理距离为0。还可以在定义静态路由的时候指定管理距离。

    2.配置默认路由

    R1(config)#iproute 0.0.0.0  0.0.0.0 {next-hop-address|exit-interface}[distance]

             next-hop-address:下一跳地址

             exit-interfac:下一跳路由器的接口

    注:0.0.0.0  0.0.0.0代表所有的网络。选择下一跳地址和选择下一调路由器的接口作为目标网络的出口的区别在于管理距离。选择前者,管理距离为1;选择后者,管理距离为0。还可以在定义静态路由的时候指定管理距离。

    3.显示静态路由的配置

    R1#showip route static

    RIP(距离矢量路由协议)基本设置

    配置RIP

    1.启动RIP

    R1(config)#routerip

    2.定义要宣告的直连主类网络号

    R1(config-route)#network{network-number}

    注:启动了RIP路由协议之后,只需要宣告主类直连网络号,即可完成RIP的配置

    3.查看RIP信息

    R1#showip route rip

    配置RIPv2

    1.启动RIP

    R1(config)#routerip

    2.启动RIP版本2(RIPv2)

    R1(config-route)#version2

    3.定义要宣告的直连主类网络号

    R1(config-route)#network{network-number}

    注:启动了RIPv2路由协议之后,只需要宣告主类直连网络号,即可完成RIPv2的配置

    4.查看RIP信息

    R1#showip route rip

    OSPF(链路状态路由协议)基本配置

    配置单区域OSPF

    1.启动OSPF进程:

    R1(config)#routeospf {process-id}

    注:OSPF进程ID可以使用1到65535中的任意一个整数,该ID只是本地的一个标识,即一个OSPF网络,每台OSPF路由器的进程ID是否一样,和OSPF网络能否正常运行无关。

    2.定义参与OSPF进程的接口和网络

    R1(config-route)#network{ip-address} {wildcard-mask} area {area-id}

             ip-address:直连网络地址

             wildcard-mask:直连网络的反掩码

             area-id:区域号

    注:在定义OSPF路由器要宣告的区域时,反掩码用来控制要宣告的范围,0表示精确匹配,255表示任意匹配。OSPF网络中骨干区域为区域0,因此必须有区域0。

    3.查看OSPF信息

    R1#showip route ospf    // 查看所有的OSPF信息

    R1#showip route ospf 1   //查看进程ID1OSPF信息

    R1#showip ospf database   //查看OSPF链路状态数据库的信息

    R1#showip ospf neighbor    //  显示一个邻居列表,

    配置多区域OSPF

    1.启动OSPF进程

    R1`(config)#routeospf {process-id}

    注:OSPF进程ID可以使用1到65535中的任意一个整数,该ID只是本地的一个标识,即一个OSPF网络,每台OSPF路由器的进程ID是否一样,和OSPF网络能否正常运行无关。

    2.定义参与OSPF进程的接口和网络

    R1(config-route)#network{ip-address} {wildcard-mask} area {area-id}

             ip-address:直连网络地址

             wildcard-mask:直连网络的反掩码

             area-id:区域号

    注:在定义OSPF路由器要宣告的区域时,反掩码用来控制要宣告的范围,0表示精确匹配,255表示任意匹配。OSPF网络中骨干区域为区域0,因此必须有区域0。多区域的设计,才是OSPF网络的精髓。

    3.查看OSPF信息

    R1#showip route ospf    // 查看所有的OSPF信息

    R1#showip route ospf 1   //查看进程ID1OSPF信息

    R1#showip ospf database   //查看OSPF链路状态数据库的信息

    R1#showip ospf neighbor    //  显示一个邻居列表,

    EIGRP(混合型路由协议) 基本配置

    配置EIGRP

    1.定义自制系统(AS)号并启用EIGRP

    R1(config)#routeeigrp {AS-number}

    2.宣告直连主类网络号

    R1(config-route)#network{network-number}

    注:EIGRP做为IGRP的扩展,它同时集合了距离矢量和链路状态路由协议的特色,参与同一EIGRP进程的EIGRP路由器必须处于相同的AS里,接下来只需要宣告直连的主类网络号即可。

    3.查看EIGRP信息

    R1#showip eigrp neighbors

    R1#showip route eigrp

    关闭EIGRP的自动汇总

    1.定义自制系统(AS)号并启用EIGRP

    R1(config)#routeeigrp {AS-number}

    2.宣告直连主类网络号

    R1(config-route)#network{network-number}

    注:EIGRP做为IGRP的扩展,它同时集合了距离矢量和链路状态路由协议的特色,参与同一EIGRP进程的EIGRP路由器必须处于相同的AS里,接下来只需要宣告直连的主类网络号即可。

    3.关闭自动汇总

    R1(config-route)#noauto-summary

    注:当路由更新主类网络边界的时候,他会自动向主类网络号进行汇总,路由自动汇总特性是EIGRP默认的操作。EIGRP可以关闭该特性。

    4.查看EIGRP信息

    R1#showip eigrp neighbors

    R1#showip route eigrp

    交换机

    基础配置

    1.从用户模式进入特权模式

    S1>enable

    2.从特权模式进入全局配置模式

    S1#configure terminal

    3.设置主机名

     S1(config)#hostnameR1

    4. 退出到特权模式

    S1(config)#end

    5.退出到用户模式

    S1#disable

    6.查看MAC地址表

    S1#show mac-address-table

    7.开启http服务(部分交换机可用)

    S1(onfig)#ip http server

    8.配置超级用户口令

    S1(config)#enable password 123456 //不加密密码

    S1(config)#enable password 7 123456 //加密密码(7是选择的加密方式)

    S1(config)#enable secret 123456  //加密密码

    S1(config)#enable secret 5 123456  //加密密码(5是选择的加密方式)

    7.显示路由器的当前时间

    R1#show clock

    8.设置系统时间(部分可用)

    S1(config)#clock set hh:mm:ss day month year

    S1(config)#clock set 12:00:00 28 August 2013

    9.配置设备管理IP地址

    S1(config)#interface VLAN1

    S1(config-if)#ip address 192.168.1.1255.255.255.0

    S1(config-ip)#exit

    注:VLAN 1是用于设备管理的默认VLAN

    10.配置默认路由

    S1(config)#ip default-gateway 192.168.1.254

    VlAN的配置

    常规配置

    1.创建VLAN

    S1(config)#vlan 100

    2.给VLAN命名

    S1(config-vlan)#name vlan100

    3.删除VLAN

    S1(config)#no vlan 100

    进入VLAN数据库配置

    1.进入VLAN数据库

    S1#vlan database

    2.创建VLAN

    S1(vlan)#vlan 100 name vlan100

    3.删除VLAN

    S1(vlan)#no vlan 100

    4.修改VLAN

    S1(vlan)#vlan 100 name v100

    分配端口到VLAN中

    S1(config)#interface f0/1

    S1(config-if)#switchport access vlan 100

    VLAN TRAN的配置

    S1(config)#interface f0/2

    S1(config-if)#switchport mode trunk  //设置端口为trunk端口

    S1(config-if)#switchport trunk allowed vlan100,2 //允许vlan 100vlan 2通过

    S1(config-if)# switchport trunk


     

     

    展开全文
  • 思科路由器基本命令

    2017-02-09 20:06:00
    用户模式: Router>...enableRouter#configure terminal由特权模式进入全局配置模式:Router(config)#在全局配置模式下可以操作的:修改用户名:Router(config)#hostname coolbreezeR1(config)#关闭域名解析...
  • 思科Telnet配置操作

    2020-07-24 17:32:21
    通过vlan 1命令,设置vlan 1,通过exit命令退出valn配置模式, 在全局配置模式下,通过interface vlan 1进入Vlan 1配置模式, 通过ip address x.x.x.x 255.x.x.x配置该Vlan1接口的IP地址, 通过no shutdown开启当前...
  • 思科模拟器操作 ...全局模式 往下进 int f 0/1 接口模式 退出到上层模式 exit 退回特权 ctrl +z 配置交换机 特权模式下 show version 查看系统版本号 show arp 查看arp缓存表 show int f0/1 查看0/1...
  • 思科单臂路由配置

    2020-06-07 21:54:43
    en 特权模式 Switch#conf t 全局配置 Enter configuration commands, one per line. End with CNTL/Z. Switch(config)#vlan 10 创建vlan Switch(config-vlan)#vlan 20 Switch(config-vlan)#ex 退出 Switch(config)#...
  • 当你忘记密码时,就把路由器关机并重启,然后快速按下【Ctrl+Break】键中断路由器的启动过程,进入 rommon 模式。 看到有很多#####就按下ctrl+break ,就可进入 rommon 模式 ...然后就可以进入全局模式重新设置密码了。
  • R1#disable 退出特权模式 R1> R1#configure terminal 进入全局配置命令 R1(config)#no ip domain-lookup 关闭域名解析 R1(config)#hostname SW1 更改主机名为SW1 R1(config)#enable password CISCO 配置...
  • #进入全局模式 Router#configure terminal #进入0/0端口 Router(config)#interface gigabitEthernet 0/0 #配置IP地址 Router(config-if)#ip address 192.168.1.3 255.255.255.0 #开启端口 Router(config-if)#n
  • 文章目录基础命令集模式辅助工具进入和退出特权保存、清除配置改名配ip地址查看修改时间管理登录console 口配置telent 配置SSH 配置访问权限操作系统主流大类:启动步骤:设备升级设备升级的方式:密码破解总结: ...
  • 思科模拟器中配置单区域OSPF

    千次阅读 2019-06-21 15:34:13
    思考模拟器中配置单区域OSPF ...Switch#conf #全局配置模式 Switch(config)#hostname SW1 #改名SW1 SW1(config)#vlan 10 #划分VLAN 10 SW1(config-vlan)#ex #退出 exit SW1(config)#inter...
  • 华为和cisco初级HCIA HCNA命令基本整合,RIP VLAN OSPF 单臂路由 思科:用户模式 enable 特权模式 conf t 全局模式 exit /end 特权模式 exit 用户模式 exit 退出登录 改名字:全局模式下 HOSTNAME XX 华为:用户视图...
  • 思科 简介:Cisco的网际操作系统(IOS:Internetwork operating system),IOS配置通常是通过基于文本的命令行接口进行的。 路由器基本操作 操作模式 ...从特权模式进去,在全局配置模式中,一旦作
  • 模拟器的基本配置

    2021-01-30 17:10:13
    全局模式 可以进行查询; 特权模式(查询和测试) 全局模式 (所有的进行修改的查询就是在这个的模式下) e 以太网口 f 快速以太网口 s 串口 配置IP地址:ip address IP地址 掩码 配置完成后切记打开接口; no shutdown ...
  • terminal length 0 //特权模式下使用,只针对本次登录有效,退出后重新进入会失效 length 0 //配置模式相应线路下配置 ASA防火墙 pager line 0 //配置模式全局命令 注:将0改成相应的数字可控制显示行数。 .....
  •  ROBYN SANDS 思科公司的软件工程师,为思科的客户设计开发嵌入式Oracle数据库产品。从1996年开始使用Oracle,在应用开发、大型系统实现以及性能评估方面具有丰富的经验。她是OakTable的成员,同时是Expert ...
  •  ROBYN SANDS 思科公司的软件工程师,为思科的客户设计开发嵌入式Oracle数据库产品。从1996年开始使用Oracle,在应用开发、大型系统实现以及性能评估方面具有丰富的经验。她是OakTable的成员,同时是Expert ...

空空如也

空空如也

1 2
收藏数 22
精华内容 8
关键字:

思科退出全局模式