精华内容
下载资源
问答
  • 思科路由器配置EIGRP

    2011-08-04 13:36:46
    ip summary-address eigrp 100 192.168.1.0 255.255.255.0 exit int s1/1 ip address 192.168.45.1 255.255.255.0 bandwidth 1000 no shutdown exit router eigrp 100 network 192.168.1.32 0.0.0.31 ...

     

    R4:
    enable
    config t
    hostname R4
    int fa0/0
    no shutdown
    int fa0/0.1
    enca dot1q 1
    ip address 192.168.1.33 255.255.255.224
    no shutdown
    exit
    int fa0/0.2
    enca dot1q 2
    ip address 192.168.1.65 255.255.255.224
    no shutdown
    exit
    int fa0/0.3
    enca dot1q 3
    ip address 192.168.1.97 255.255.255.224
    no shutdown
    exit
    int s1/2
    ip address 192.168.47.1 255.255.255.0
    no shutdown
    ip summary-address eigrp 100 192.168.1.0 255.255.255.0
    exit
    int s1/1
    ip address 192.168.45.1 255.255.255.0
    bandwidth 1000
    no shutdown
    exit
    router eigrp 100
    network 192.168.1.32 0.0.0.31
    network 192.168.1.64 0.0.0.31
    network 192.168.1.96 0.0.0.31
    network 192.168.47.0 0.0.0.255
    network 192.168.45.0 0.0.0.255
    no auto-summary
    variance 2
    traffic-share balanced
    exit
    key chain 45
    key 1
    key-string miwen
    exit
    exit
    int s1/1
    ip authen mode eigrp 100 md5
    ip authen key-chain eigrp 100 45
    end

    R5:
    enable
    config t
    hostname R5
    int s1/0
    ip address 192.168.45.2 255.255.255.0
    no shutdown
    exit
    int s1/2
    ip address 192.168.57.1 255.255.255.0
    no shutdown
    exit
    router eigrp 100
    network 192.168.57.0 0.0.0.255
    network 192.168.45.0 0.0.0.255
    exit
    key chain 45
    key 1
    key-string miwen
    exit
    exit
    int s1/0
    ip authen mode eigrp 100 md5
    ip authen key-chain eigrp 100 45
    end


    R7:
    enable
    config t
    hostname R7
    int s1/3
    ip address 192.168.47.2 255.255.255.0
    no shutdown
    exit
    int s1/4
    ip address 192.168.57.2 255.255.255.0
    no shutdown
    exit
    int s1/5
    ip address 192.168.67.2 255.255.255.0
    no shutdown
    exit
    ip route 0.0.0.0 0.0.0.0 s1/5
    router eigrp 100
    network 192.168.47.0 0.0.0.255
    network 192.168.57.0 0.0.0.255
    network 192.168.67.0 0.0.0.255
    network 0.0.0.0 0.0.0.0
    exit
    key chain 67
    key 1
    key-string mingwen
    exit
    exit
    int s1/5
    ip authen mode eigrp 100 md5
    ip authen key-chain eigrp 100 67
    end

    R6:
    enable
    config t
    hostname R6
    int s1/2
    ip address 192.168.67.1 255.255.255.0
    no shutdown
    exit
    int lo1
    ip address 192.168.6.1 255.255.255.0
    no shutdown
    exit
    router eigrp 100
    network 192.168.67.0 0.0.0.255
    exit
    key chain 67
    key 1
    key-string mingwen
    exit
    exit
    int s1/2
    ip authen mode eigrp 100 md5
    ip authen key-chain eigrp 100 67
    exit
    end

     

     

     

    转载于:https://blog.51cto.com/sdqaurora/630999

    展开全文
  • 配置EIGRP 与IGRP自动重新分配(AS号相同即可):按照拓扑给出的信息,实现网络全连性,即每台 路由器都拥有完整的路由更新表。
  • cisco路由器EIGRP基础配置命令

    千次阅读 2020-04-12 11:47:38
    2.配置EIGRP协议 R1(config)#router eigrp 1 启用EIGRP路由选择协议进程,AS号为1 R1(config-router)#network 172.16.1.0 0.0.0.255 宣告网段,子网+反掩码的形式 R1(config-router)#network 192.168.1.4 0.0.0.3 R1...

    在这里插入图片描述
    1.IP地址等基本配置自行配置

    2.配置EIGRP协议
    R1(config)#router eigrp 1 启用EIGRP路由选择协议进程,AS号为1
    R1(config-router)#network 172.16.1.0 0.0.0.255 宣告网段,子网+反掩码的形式
    R1(config-router)#network 192.168.1.4 0.0.0.3
    R1(config-router)#network 12.1.1.0 0.0.0.255
    R1(config-router)#no auto-summary 需要关闭自动汇总
    R2(config)#router eigrp 1
    R2(config-router)#network 192.168.1.4 0.0.0.3
    R1(config-router)#network 12.1.1.0 0.0.0.255
    R2(config-router)#network 10.10.10.0 0.0.0.255
    R2(config-router)#no auto-summary 需要关闭自动汇总

    3.查看路由器信息
    R1#show ip protocols 查看路由协议
    R1#show ip eigrp neighbors 查看邻居列表
    R1#show ip eigrp topology 查看拓扑结构数据库
    R1#show ip eigrp interfaces 查看运行EIGRP协议的接口状况
    R1#show ip eigrp traffic 报告EIGRP发送和接收到的数据包的统计情况
    R1#debug eigrp packets 显示发送和接收的EIGRP数据包
    R1#debug eigrp neighbors 查看邻居关系的建立情况 (PT模拟器没有该命令)
    R1#debug ip eigrp 监测IP EIGRP路由事件信息 (PT模拟器没有该命令)

    展开全文
  • Cisco-EIGRP的简单配置

    2020-07-16 15:02:59
    EIGRP结合了链路状态和距离矢量型路由选择协议的Cisco专用协议,采用弥散修正算法(DUAL)来实现快速收敛,可以不发送定期的路由更新信息以减少带宽的占用。 拓扑图 给设备改名 (config)#hostname 想要修改的名称 ...

    EIGRP

    1. 简介
      EIGRP:Enhanced Interior Gateway Routing Protocol 即 增强内部网关路由线路协议。EIGRP是Cisco公司的私有协议。EIGRP结合了链路状态和距离矢量型路由选择协议的Cisco专用协议,采用弥散修正算法(DUAL)来实现快速收敛,可以不发送定期的路由更新信息以减少带宽的占用。
    2. 拓扑图拓扑图
    3. 给设备改名

    (config)#hostname 想要修改的名称
    改名

    1. 给路由器接口配IP地址
      R1

    (config)#int loop 0
    ip add 1.1.1.1 255.255.255.0
    R1接口
    R2
    R2接口R3
    R3接口

    1. 配置路由
      R1

    (config)# router eigrp 50
    network 192.168.12.0
    R1路由
    R2R2路由
    R3
    R3路由
    查看R1路由表
    show ip route
    R1路由表
    R3pingR1的环回口,Ping通,则R1与R3可以互访
    ping 3.3.3.3
    Ping测试

    展开全文
  • 配置EIGRP

    2007-03-02 09:10:00
    配置EIGRP EIGRP是结合了链路状态和距离矢量型路由选择协议优点的Cisco专用协议 EIGRP的特点: l快速收敛---EIGRP采用弥散修正算法(DUAL)来实现快速收敛。 l减少带宽占用---EIGRP不发送定期的路由更新信息。 l...
    配置EIGRP <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

    EIGRP是结合了链路状态和距离矢量型路由选择协议优点的Cisco专用协议

    EIGRP 的特点:
    l
    快速收敛---EIGRP采用弥散修正算法(DUAL)来实现快速收敛。

    l
    减少带宽占用---EIGRP不发送定期的路由更新信息。

    l
    支持多种网络层协议---AppletalkIpNevellNetware

    EIGRP是源于距离矢量型路由选择协议。容易进行配置并能适合各种网络拓朴结构。它增加了几种链路状态特性,比如动态邻居发现,这使它成为一种高级的距离矢量型路由选择协议。

    EIGRP 比传统的距离矢量型路由选择协议提供了更多的好处,最重要的好处之一是对带宽的使用方面。采用EIGRP时,路由运行数据流主要是通过多目组播方式而不是广播,其结果是,未端站点不受路由更新或查询信息的影响。
    EIGRP
    采用IGRP中的算法来计算度量值,但该值是以32比特的格式来表示,EIGRP的度量值是将IGRP的度量值乘以256EIGRP的一个重要优点是它支持非等度量值负载均衡,从而允许管理员能够在网络中更好地分布数据流。载有E IPRP信息的IP数据包在它们的头部中使用协议号88

    EIGRP是被设计来同时在局域网和广域网环境中运行的,邻居关系是通过可靠的多目组播方式来形成和维护的,它同时支持体系化IP编址。E IGRP也支持VLSM,这促进了IP地址的有效分配,缺省地,EIGRP在主网络边界进行路由归纳,EIGRP支持超级网络(supernet)的创建或聚合的地址块。

    EIGRP 相关术语:
    l
    邻居表---每台EIGRP路由器都维护着一个列有相邻路由器的路由表。该表与OSPF所使用的邻居(毗邻关系)数据库是可比的。

    l
    拓朴结构表---EIGRP路由器为所配置的第种网络协议都有维护着一个拓朴结构表

    l
    路由表---EIGRP从拓朴结构表中选择到目的地的最佳路径,并将这些路由放到路由表中。

    l
    后继路由器(successor---这是用来到期达目的地的主要路由器。

    l
    可行后继路由器(Feasible Successor , FS---一条到达目的地的备份路由。

    EIGRP 采用下面的五种类型数据包:
    lHELLO---HELLO
    数据包用地发现邻居。

    l
    更新---更新信息被发送来通告已被某台路由器认为达到收敛的路由

    l
    查询---当路由器进行路由计算但没能发现可行的后继路由时,它就向他邻居发送一个查询数据包以询问它们是否有一个到目的地的可行后继路由。

    l
    答复---答复数据包是用于对查询数据包进行应答。

    l
    确认(ACK---确认是用来确认更新、查询和答复的。


    EIGRP
    的可靠性:
    EIGRP
    的可靠性技术确保了到期相邻路由器的关键路由信息的传输。这些信息是EIGRP维护无环路拓朴结构所需要的。所有传递路由信息(更新、查询和答复)的数据都被可靠地发送。

    可靠传输协议RTP,负责EIGRP数据包到所有邻居的有保证和按顺序的传输。它支持多目组播或单点传送数据包的混合传输。出于对效率的考虑,只有某些E IGRP数据包被保证可靠传输。

    RTP
    确保在相邻路由器间正在进行的通信能够被维持。因此,它为第个邻居维护了一张重传表。该表指示还没有被邻居确认的数据包。未确认的可靠数据包最多可以被重传1 6次或直到保持时间超时,以它们当中时间更长的那个为限。

    EIGRP所使用的多目组播地址是224.0.0.10

    通过HELLO协议,EIGRP路由器可以动态地发现直接与它相连的其它路由器。

    查看IP邻居表:
    show ip eigrp neighbors
    查看拓朴结构表中所有IP条目:

    show ip eigrp topology all-links
    显示IP路由的后继路由和可行后继路由

    show ip eigrp topology

    EIGRP 路由选择过程与其它路由选择协议不同,它具有如下特点:
    lEIGRP
    选择主路由与备份路由,并将这些路由加到期拓朴结构表中(每个目的地最多有6个)然后将主路由放到期路由表中。

    lEIGRP
    度量值是IGRP度量值乘以256。该度量值的计算可以使用下面5个变量

    ----
    带宽:源和目的地间最少带宽;

    ----
    延时:路径上的累积接口延时;

    ----
    可靠性:根据keepalive信息的源与目的地间的最差可靠性;

    ----
    负载:在源和目的地之间链路上的最重负载;

    ----
    最大传输单元(MTU):路径中最小MTU

    lEIGRP
    采用DUAL算法计算到目的地的最佳路由。

    备份路径中的下一跳路由器也被子称为可行后继路由器(FS)。


    配置EIGRP

    配置EIGRP的步骤:
    1
    .启用EIGRP,并定义自治系统。

    Router(config)#Router eigrp autonomous-system-number
    2.
    说明哪些网络中EIGRP自治系统的一部分

    Router(config-router)#network network-number

    3. 定义链路的带宽
    router(config-if)#bandwidth kilobits

    配置归纳
    关闭自动归纳:

    router(config-router)#no auto-summary
    创建一条路由归纳:

    router(config-if)#ip summary-address eigrp as-number address mask
    Ip summary-address eigrp
    命令描述

    As-numberEIGRP
    自治系统号

    Address
    作为归纳地址被通告的IP地址

    Mask
    被用来创建归纳地址的IP掩码

    EIGRP 对链路带宽的使用:
    缺省的EIGRP将使用在接口或子接口上宣布的最多50%的带宽。这个百分比可以通过下面的接口命令在接口上进行调整:

    Router(config-if)#ip bandwidth-percent eigrp as-number percent

    核验EIGRP的运行:
    核验EIGRP运行的命令

    命令描述

    Show ip eigrp neighbors
    显示EIGRP所发现的邻居

    Show ip eigrp topology
    显示EIGRP拓朴结构表

    Show ip route eigrp
    显示当前在路由表中的EIGRP条目

    Show ip protocols
    显示活跃路由选择协议进程的参数和当前状态

    Show ip eigrp traffic
    显示发送和接收的EIGRP数据包数量

    DEBUG 命令
    命令描述
    Debug eigrp packets
    显示发送和接收的 EIGRP 数据包类型
    Debug eigrp neighbors
    显示 EIGRP 所发现的邻居和 HELLO 数据包的内容
    Debug ip eigrp
    显示在接口上发送和接收的 EIGRP 数据包
    Debug ip eigrp summary
    显示 EIGRP 活动的归纳信息
    __________________
    喜欢和所有爱好网络的朋友交流!当然,我还很菜……

    转载于:https://blog.51cto.com/312585753/18958

    展开全文
  • 思科EIGRP配置及基本讲解

    千次阅读 2020-11-20 11:29:29
    思科EIGRP配置及基本讲解 什么是EIGRP EIGRP全称 [增强型内部网关路由选择协议] 是思科自主研发的动态路由选择协议,按类型划分是一款IGP协议,距离矢量协议,是一款基于传闻的协议。 EIGRP思科的私有协议,直到...
  • CISCO EIGRP 特性 1/手工路由汇总 2 /eigrp默认路由 3/非等价负载均衡 4/eigrp认证(防止路由欺骗) 5/末节区域
  • 思科EIGRP高级配置

    千次阅读 2016-06-27 19:48:07
    ip authentication key-chain eigrp 1 cisco clock rate 2000000 ! interface Serial0/0/1 ip address 192.168.10.5 255.255.255.252 clock rate 2000000 ! interface Vlan1 no ip address ...
  • 面是以前我在一家isp工作时维护的一个客户路由器上的配置,这个客户租了我们12条IP*...对于爱好网络技术的朋友是一个学习cisco技术的难得的参考。有兴趣的朋友可以分析一下,注:一般IP-×××专线其实就是DDN加IP×...
  • 配置Eigrp 验证,汇总

    2008-10-18 22:59:25
    配置Eigrp 验证,汇总 环境:三台路由器串口相连,其它接口配置如图 要求:1.配置EIGRP关闭自动路由汇总2.在R1的三个LOOP口进行EIGRP手工路由汇总3.R2、R3配置EIGRP接口密文验证4.验证并测试结果 步骤一: 配置三...
  • Cisco配置动态路由,可以使用EIGRP(增强型内部网关路由选择协议)进行配置EIGRP支持:快速收敛:使用DUAL(弥散更新算法)来实现快速收敛.带宽的有效利用:发送部分、增量的路由更新而不是发送整个路由表,从而实现带宽...
  • 实验一、配置Eigrp 验证,汇总 环境:三台路由器串口相连,其它接口配置如图 要求:1.配置EIGRP关闭自动路由汇总 2.在R1的三个LOOP口进行EIGRP手工路由汇总 3.R2、R3配置EIGRP接口密文验证 4.验证并测试结果 ...
  • 实验十 配置EIGRP协议

    2010-07-01 20:21:37
    实验十 配置EIGRP协议 实验目的:1、了解混合路由选择协议的工作原理,使用的度量值, 2、了解EIGRP协议的优点,掌握eigrp路由协议的配置方法。 实验设备:三台cisco路由器,三台pc,三根双绞线,两根serial连线。 ...
  • 实验、配置Eigrp 验证,汇总 环境:三台路由器串口相连,其它接口配置如图 要求:1.配置EIGRP关闭自动路由汇总 2.在R1的三个LOOP口进行EIGRP手工路由汇总 3.R2、R3配置EIGRP接口密文验证 4.验证并测试结果 ...
  • 思科CCNA EIGRP

    2017-07-31 20:00:00
    EIGRP协议特点EIGRP思科私有协议,只能运行在思科设备上EIGRP标准的距离矢量协议EIGRP使用带宽/延迟作为路径选择的标准 metric=256*{(10^7/bandwith)+(delay/10)} ---带宽(kb):沿途入向接口最小带宽 ---延迟(us)...
  • EIGRP(Enhanced Interior Gateway Routing Protocol ) 高级距离矢量路由协议,metric衡量的参数比较多 ...·EIGRPCisco私有的路由协议,采用DUAL(扩散更新算法)。 ·EIGRP属于IGP,是Hybr...
  • CISCO 配置实验--EIGRP

    2010-07-17 11:37:00
    EIGRP 增强型内部网关路由协议 ...配置EIGRP r1(config)#router eigrp 1 r1(config-router)# network 10.0.0.0 r1(config-router)# network 192.168.10.0 r1(config-router)# network 192.168.60.0 r2...
  • 传送门
  • CISCO CCNA EIGRP

    2018-01-03 14:42:35
    EIGRP结合了链路状态和距离矢量型路由选择协议的Cisco专用协议,采用弥散修正算法(DUAL)来实现快速收敛,可以不发送定期的路由更新信息以减少带宽的占用,同时在EIGRP中有三张表:邻居关系表(以建立的邻居关系)...
  • cisco eigrp

    2013-03-20 14:06:56
    EIGRP配置文件,没什么技术含量,不懂的人可以下载看看!
  • 构建可扩展的思科互联网络----配置EIGRP    前几天有网友给我发信息想需要一些关于路由技术方面的文章,但由于最近我的工作比较忙,现将我以前授课的讲义共享给大家,希望能给大家带来一些帮助,过段时间我工作...
  • Ciscoeigrp协议

    2010-02-28 15:58:35
    Cisco之eigrp协议 实验目的:了解在cisco路由上运行eigrp协议的...通过配置eigrp协议使得两个局域网可以通信 实验的拓扑图如下 实验步骤: 1:进入第一台路由配置如下 Router>en Router # config t Ro...
  • CCNA实验三:配置EIGRP

    2013-04-22 21:42:27
    %DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 12.12.12.1 (Serial0/0) is up: new adjacency   R2(config-router)#network 2.2.2.0 0.0.0.255 R2(config-router)#network 23.23.23.0 0.0.0.255  ...
  • CiscoEIGRP应用

    2018-08-25 08:45:42
    R2/R3/R4/R5/R6/R7/R8建立EIGRP环境;R1为ISP(运营商) 拓扑要求: (1)R1与R2之间使用PPP封装,CHAP认证,R1为主认证方 (2)IPV4地址范围为172.16.0.0/16 (3)保障更新安全,减少更新量 (4)R4到R2...
  • CCNP之BSCI实验5:配置EIGRP非等价负载均衡 实验目的: 1.掌握EIGRP的非等价负载均衡的条件 2.掌握EIGRP的METRIC值修改方法 3.掌握EIGRP的AD,FD,FC,SUCCESSOR,FS 实验拓扑: 实验步骤: 1.按拓扑图配置IP,...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,839
精华内容 2,335
关键字:

思科配置eigrp