精华内容
下载资源
问答
  • GNS3是一款优秀的具有图形化界面可以运行在多平台,那么怎么用GNS3配置RIP与OSPF路由重发布?下面脚本之家的小编带大家一起学习一下,用GNS3配置RIP与OSPF路由重发布的步骤
  • ospf动态路由配置

    2018-03-10 19:57:24
    利用三层交换机和ospf协议来实现实现动态路由。有完整的拓扑图和命令
  • Hello大家好,本篇博文讲述的是大学网络工程思科路由器之ospf路由配置实验,供各大专院校学生与老师参考,如需转载,需注原创 接下来,我们来讲一讲,如何进行OSPF路由配置实验 首先,我们选好进行实验的器材:分别...

    Hello大家好,本篇博文讲述的是大学网络工程思科路由器之ospf路由配置实验,供各大专院校学生与老师参考,如需转载,需注原创
    接下来,我们来讲一讲,如何进行OSPF路由配置实验
    首先,我们选好进行实验的器材:分别是两台PC,一台交换机和两台路由器
    在这里插入图片描述
    接着我们对选好的器材进行连接:
    在这里插入图片描述
    注意:编者所示的接口为Fa0/10和Fa0/20,(路由器哪里来的Se0/3/0接口?是在路由器的物理界面添加配置得到的接口,可以参考编者上一篇有关静态路由的博文)
    连接如图所示的模型之后,我们来进行OSPF配置实验
    第一步:分别配置两台PC的IP地址,子网掩码和默认网关
    在这里插入图片描述
    第二步,在交换机上配置接口IP,配备vlanIP地址,并进行ospf配置。这一步的内容比较多,大家在配置的时候一定要注意,不要心急写错代码!
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    第三步,在路由器上配置接口IP和OSPF配置:
    在这里插入图片描述
    在这里插入图片描述
    注意,两台路由器一定要处于同一时钟频率才可以相互通信
    第四步,我们通过两台PC进行Ping来证明实验的成功与否
    在这里插入图片描述
    OK,本篇文章到这里就结束啦!
    如果有疑问,可以在文章下面进行留言评论哦!
    谢谢大家,觉得有帮助的可以点个赞!

    展开全文
  • OSPF动态路由配置Cisco

    万次阅读 多人点赞 2019-01-17 00:54:03
    在路由器上配置OSPF路由 配置静态默认路由 在多路访问网络上配置OSPF 掌握OSPF协议的配置方法   二、实验环境  •思科3560三层交换机一台。 •计算机4台(已安装 Windows Server 2003 操作系统)...

    一、实验目标   

    • 根据拓扑图完成网络电缆连接      
    • 删除路由器启动配置并将其重新启动到默认状态
    • 在路由器上执行基本配置任务
    • 配置并激活接口
    • 在路由器上配置OSPF路由
    • 配置静态默认路由
    • 在多路访问网络上配置OSPF
    • 掌握OSPF协议的配置方法

     

    二、实验环境  

    思科3560三层交换

    •计算机4台(已安装 Windows Server 2003 操作系统)。

    •组网用直通双绞线网线6根、交叉线2根。

    •配置用直通双绞线两根。

    •或用Cisco Packet Tracer 模拟所有设备(本实验采用)

     

    三、实验内容  

    • 在指定拓扑结构的多个路由器上配置OSPF路由;
    • 使用OSPF路由的常用查看和测试命令;
    • 实现网络互通。

     

    四、实验过程及结果

    拓扑图:

     

    地址表:

    设备

    接口

    IP地址

    子网掩码

    网关

    Switch0VLAN2192.168.0.1255.255.255.0/
    Switch0VLAN3192.168.1.1255.255.255.0/
    Switch0F0/3192.168.2.2255.255.255.0/

    Router0

    S2/0

    172.16.0.1

    255.255.255.0

    /

    Router1

    S3/0

    172.16.0.2

    255.255.255.0

    /

    Router1

    S2/0

    172.16.1.1

    255.255.255.0

    /

    Router1

    F0/0

    172.16.2.1

    255.255.255.0

    /

    Router2

    S3/0

    172.16.1.2

    255.255.255.0

    /

    Router2

    F0/0

    172.16.3.1

    255.255.255.0

    / 

    PC0

    网卡

    192.168.0.2

    255.255.255.0

    192.168.0.1

    PC1

    网卡

    192.168.1.2

    255.255.255.0

    192.168.1.1

    PC2

    网卡

    172.16.2.2

    255.255.255.0

    172.16.2.1

    PC3

    网卡

    172.16.3.2

    255.255.255.0

    172.16.3.1

     

    任务1:执行基本网络连接及配置

    (1)如图所示进行连接,注意:路由器和路由器之间用DCE线连接,路由器和主机、交换机之间用Cross-Over线连接,三层交换机和主机之间用直通线连接。

     

    (2)分别配置路由器Router0、Router1和Router2主机名为R0、R1和R2,配置特权模式密文密码为123。

     

    任务2:执行三层交换机配置

    (1)配置交换机Switch0主机名为S0,配置特权模式密文密码为123。

    (2)在交换机S0上创建VLAN2和VLAN3:

    (3)检验在交换机S0上创建的VLAN:

    (4)在交换机S0上将交换机端口分配给VLAN:

    ①switchport mode access:强制接口成为access接口,并且可以与对方主动进行协商,诱使对方成为access模式。

    ②switchport access vlan number:给端口配置不同的VLAN。

    (5)在交换机S0上定义VLAN2和VLAN3的IP地址:

    (6)在交换机S0上启用IP路由:

    ip routing:在三层交换机上打开路由功能(默认是关闭的),使不同VLAN间能够实现相互通信。


    (7)在交换机S0上配置f0/3的IP地址:

    no switchport:启用交换机的三层路由功能(三层交换机端口默认为二层口)。

     

    (8)在路由器R0上配置f0/0的IP地址和RIP v2路由协议:

    (9)在交换机S0上配置RIP v2路由协议:

    启用RIP路由协议第二版并宣布其直连网络,关闭自动汇总功能。

     

    任务3:启动OSPF路由进程,使整个网络互通

    (1)给PC0、PC1、PC2和PC3配置IP地址:

                        

                         

    (2)在路由器R0上给s2/0配置端口IP地址:

     

    (3)分别给路由器R1、R2各端口配置IP地址:

    R1:

    R2:

     

    (4)分别在路由器R0、R1、R2上配置OSPF:

    R0有一个直连网络:

    R1有三个直连网络:

     

    R2有两个直连网络:

     

    (5)在路由器R0上配置NAT协议:

    建立一个分配范围为172.16.0.10到172.16.0.254的地址池。

    建立访问列表允许该网络访问。

    设置f0/0为进入端、s2/0为发出端。

     

    (6)路由器R0静态路由配置:

    要去目标网络地址为192.168.0.0的数据包下一IP地址为192.168.2.2。

     

    (7)三层交换机Switch0静态路由配置:

     

    任务3:验证实验结果

    (1)配置之前PC1无法ping通PC3:

    (2)配置之后PC1可以ping通PC3:

    展开全文
  • Cisco配置动态路由ospf

    2021-10-02 16:50:46
    文章目录1、拓扑图2、R1配置3、R2配置4、R3配置5、测试 1、拓扑图 2、R1配置 进入特权模式:Router>en 进入全局模式:Router#conf t 修改设备名称:Router(config)#hostname R1 进入接口:R1(config)#int g0/0 ...

    1、拓扑图

    在这里插入图片描述

    2、R1配置

    1. 进入特权模式:Router>en
    2. 进入全局模式:Router#conf t
    3. 修改设备名称:Router(config)#hostname R1
    4. 进入接口:R1(config)#int g0/0
    5. 配置ip:R1(config-if)#ip add 192.168.1.1 255.255.255.0
    6. 开启接口:R1(config-if)#no shutdown
    7. 进入全局模式:R1(config-if)#exit
    8. 配置ospf:R1(config)#router ospf 1
    9. 宣告网段与区域:R1(config-router)#network 192.168.1.0 0.0.0.255 area 1
    10. 进入特权模式: R1(config-router)#end
    11. 保存:R1#wr

    3、R2配置

    1. 进入特权模式:Router>en
    2. 进入全局模式:Router#conf t
    3. 修改设备名称:Router(config)#hostname R2
    4. 进入接口:R2(config)#int g0/0
    5. 配置ip:R2(config-if)#ip add 192.168.1.2 255.255.255.0
    6. 开启接口:R2(config-if)#no shutdown
    7. 进入接口:R2(config-if)#int g0/1
    8. 配置ip:R2(config-if)#ip add 192.168.10.1 255.255.255.0
    9. 开启接口:R2(config-if)#no shutdown
    10. 进入全局模式: R2(config-if)#exit
    11. 配置ospf:R2(config)#router ospf 1
    12. 宣告网段与区域:R2(config-router)#network 192.168.1.0 0.0.0.255 area 1
    13. 宣告网段与区域:R2(config-router)#network 192.168.10.0 0.0.0.255 area 1
    14. 进入特权模式:R2(config-router)#end
    15. 保存:R2(config-router)#end

    4、R3配置

    1. 进入特权模式:Router>en
    2. 进入全局模式:Router#conf t
    3. 修改设备名称:Router(config)#hostname R3
    4. 进入接口:R3(config)#int g0/1
    5. 配置ip:R3(config-if)#ip add 192.168.10.2 255.255.255.0
    6. 开启接口:R3(config-if)#no shutdown
    7. 进入全局模式:R3(config-if)#exit
    8. 配置ospf:R3(config)#router ospf 1
    9. 宣告网段与区域:R3(config-router)#network 192.168.10.0 0.0.0.255 area 1
    10. 进入特权模式: R3(config-router)#end
    11. 保存:R3#wr

    5、测试

    1. R1查看路由表:
      在这里插入图片描述
    2. R3查看路由表:
      在这里插入图片描述
    展开全文
  • cisco路由器OSPF基础配置命令

    万次阅读 多人点赞 2020-04-10 13:20:43
    1.基本配置 R1(config)#interface fastEthernet 0/0 R1(config-if)#ip address 172.16.1.1 255.255.255.0 R1(config-if)#no shutdown R1(config)#interface s2/0 R1(config-if)#ip add 192.168.1.5 255.255.255.252 ...

    在这里插入图片描述
    1.基本配置
    R1(config)#interface fastEthernet 0/0
    R1(config-if)#ip address 172.16.1.1 255.255.255.0
    R1(config-if)#no shutdown
    R1(config)#interface s2/0
    R1(config-if)#ip add 192.168.1.5 255.255.255.252
    R1(config-if)#clock rate 64000
    R1(config-if)#no shutdown

    R2(config)#interface s3/0
    R2(config-if)#ip add 192.168.1.6 255.255.255.252
    R2(config-if)#no shutdown
    R2(config)#interface fa1/0
    R2(config-if)#ip add 10.10.10.1 255.255.255.0
    R2(config-if)#no shutdown

    2.OSPF协议配置
    R1(config)#router ospf 1
    启动ospf进程,进程ID为1(进程ID取值范围是1-65535中的一个整数),此进程号只是本地的一个标识,具有本地意义,与同一个区域中的OSPF路由器进程号没有关系,进程号不同不影响邻接关系的建立。
    R1(config-router)#network 172.16.1.0 0.0.0.255 area 0
    宣告网络,即定义参与OSPF进程的接口或网络,并指定其运行的区域(区域0为骨干区域),通配符掩码用来控制要宣告的范围,任何在此地址范围内的接口都运行OSPF协议,发送和接收OSPF报文,0表示精确匹配,将检查匹配地址中对应位,1表示任意匹配,不检查匹配地址中对应位。
    R1(config-router)#network 192.168.1.4 0.0.0.3 area 0

    R2(config)#router ospf 1
    R2(config-router)#network 192.168.1.4 0.0.0.3 area 0
    R2(config-router)#network 10.10.10.0 0.0.0.255 area 0

    注意事项:
    (1)在广域网口DCE端要配置时钟速率;
    (2)ospf进程建议相同的进程号,利于网络规划管理;
    (3)声明网段后,掩码用反掩码。

    3.查看路由信息
    R1#show ip route 查看路由表
    R1#show ip protocols 查看已配置并运行的路由协议
    R1#show ip ospf neighbor 查看邻居表
    R1#show ip ospf neighbor detail 显示邻居路由器的详细信息
    R1#show ip ospf database 查看拓扑表,即链路状态数据库
    R1#show ip ospf interface 查看所有运行OSPF的接口信息
    R1#show ip ospf interface s2/0 查看s2/0接口的OSPF信息
    R1#show interfaces s2/0 查看路由器的接口信息

    查看Router ID号
    R1# show ip protocols
    R1#show ip ospf 1
    R2#show ip ospf neighbor

    4.更改接口相关信息
    (1)下面更改接口带宽以影响链路Cost
    R1(config)#interface s2/0
    R1(config-if)#bandwidth 64
    查看更改结果
    R1#show interfaces s2/0 查看带宽值
    R1#show ip ospf interface s2/0 查看开销值
    R1#show ip route ospf 查看路由表,看度量值的变化

    (2)下面直接更改接口相关Cost
    R1(config)#interface s2/0
    R1(config-if)#ip ospf cost 200
    查看更改结果
    R1#show ip ospf interface s2/0 查看开销值
    R1#show ip route ospf 查看路由表,看度量值的变化
    R1#show interfaces s2/0 查看带宽值有无变化

    5.监测和调试OSPF
    R1#debug ip ospf events 监测OSPF事件
    R1#undebug all 关闭
    R1#debug ip ospf packet 监测OSPF包的传输 (PT模拟器没有该命令)

    展开全文
  • 思科模拟器 使用IOS配置启用ospf路由

    千次阅读 2019-10-06 18:56:41
    例如: 在ISP1、ISP2、ISP3上配置ospf动态路由 在ISP1上启用ospf路由,宣告网络 在ISP2上启用ospf路由,宣告网络 在ISP3上启用ospf路由,宣告网络 在ISP1上使用show ip route 查看路由表 使用ping命令检查PC1到inter-...
  • Cisco OSPF路由手工汇总

    2021-06-23 10:41:08
    二、实验配置 R1: router ospf 1 router-id 1.1.1.1 auto-cost reference-bandwidth 1000 network 172.16.0.0 0.0.3.255 area 1 #环回接口汇总网络,反子网掩码 network 172.16.12.1 0.0.0.0 area 1 R2: router ...
  • 1.OSPF路由协议概述 内部网关协议和外部网关协议: 自治系统(AS) 内部网关协议(IGP) ...
  • Ciscoospf动态路由协议的详细配置

    千次阅读 2019-11-28 10:23:38
    传送门
  • 思科动态路由协议的配置,如RIP OSPF
  • OSPF路由协议通过向全网扩散本设备的链路状态信息,使网络中每台设备最终同步一个具有全网链路状态的数据库,然后路由器采用 SPF 算法,以自己为根,计算到达其他网络的最短路径,最终形成全网路由...
  • 静态路由 R1: en configure terminal ip route 172.31.0.0 255.255.255.0 172.31.1.193 ip route 172.31.1.128 255.255.255.192 172.31.1.193 ip route 0.0.0.0 0.0.0.0 172.31.1.0 ip route 172.31.1.196 255....
  • Cisco路由器的ospf高级路由配置

    千次阅读 2019-10-24 12:22:40
    一 实验拓扑图 二 实验目的 在不同域,不同路由协议,综合配置实现全网互通。 三 实验环境 GNS3,Windows10操作系统,SecureCRT8.0 四 实验过程 对R1路由器进行配置 ...
  • OSPF高级配置 项目图和具体实行要求 公司网络中运行了多种路由协议 配置重分发实现公司内部网络互通 总公司R3上重分发默认路由实现全网互通 项目需求分析 R2、R3和R4配置OSPF R4和R5配置RIP R3配置默认路由访问...
  •  前一篇博客使用了 距离矢量路由协议的 RIP协议来动态配置路由。本篇博客学习使用OSPF协议实现动态路由。 一、OSPF的基本概念  OSPF(,开放的最短路径优先协议) 自治系统(AS):一个使用相同路由策略的区域; ...
  • 思科路由模拟器 -- (4)OSPF协议及配置

    万次阅读 多人点赞 2017-10-29 00:27:14
    2.分析路由:R1上需要配置哪些OSPF路由?R2、R3和R4呢? 3.在各路由器进行OSPF的基本配置 4.等待一段时间后,在各路由器上查看路由表,观察管理距离和度量值等 5.测试连通性。配置好OSPF协议后,看各自路由器是否...
  • 2.所有路由器采用OSPF路由配置。 3.所有PC手动配置IP等配置信息。 实验内容: 1.首先我们先对各个网段进行划分。 我们将一个C类网络192.168.58.0进行子网划分给下方右侧PC所处网段进行分配。 由于避免子网位为...
  • 1、单区域配置OSPF路由配置好IP地址信息: #物理接口 interface GigabitEthernet0/0/0 ip address 10.0.123.2 255.255.255.0 # #回环接口 interface LoopBack0 ip address 10.0.1.1 255.255.255.0 # ...
  • OSPF路由协议配置(计算机网络实验) (3页) 本资源提供全文预览,点击全文预览即可全文预览,如果喜欢文档就下载吧,查找使用更方便哦!9.9 积分F0/0:173.18.3.1^FaO/Oo/o:171.16.3. 1sO: 172.16.2.1(注:从用户模式...
  • 两台路由器之间配置OSPF认证,只有通过认证才能建立OSPF邻居关系。 实验拓扑: 配置: 1. 配置各端口的IP地址 R1: R1(config)#int loopback1 R1(config-if)#ip address 1.1.1.1 255.255.255.0 R1(config-if)#exit R1...
  • 思科OSPF配置示例

    2009-07-27 09:11:07
    思科OSPF配置示例,经典思科命令 思科OSPF配置示例,经典思科命令 思科OSPF配置示例,经典思科命令 思科OSPF配置示例,经典思科命令
  • OSPF路由协议通过向全网扩散本设备的链路状态信息,使网络中每台设备最终同步一个具有全网链路状态的数据库,然后路由器采用SPF算法,以自己为根,计算到达其他网络的最短路径,最终形成全网路由信息。 2.实验设备...
  • Cisco路由器配置OSPF

    千次阅读 2019-09-15 16:27:27
    Cisco路由器配置OSPF 配置路由器IP地址 配置计算机IP地址以及网关 配置OSPF 1、先配置loopback地址(loopback的子网掩码为23位) 2、启动OSPF 第一句是启动ospf进程,后面跟进程ID,可随意设置;然后设置router-...
  • 思科模拟器上怎么配置动态路由RIP?动态路由会自主选择最佳路径的,不像静态路由某个节点瘫痪了,整个网络就都瘫痪了,下面我们来看看思科模拟器上配置动态路由RIP的图文教程
  • 思科静态路由配置

    2014-10-15 14:32:07
    思科静态路由配置
  • 前言对于思科和计算机网络的初学者,有不少人都被路由协议中复杂的概念以及配置选项吓过,我也是其中之一……动态路由协议确实非常复杂,特别是 OSPF,RFC 文档无比冗长!不过,新手来说,根本不需要了解那么多内容...
  • 单区域OSPF路由协议配置

    千次阅读 2020-05-07 21:48:19
    1、配置OSPF动态路由协议,使得3台Cisco路由器模拟远程网络互联。 2、对运行中的OSPF动态路由协议进行诊断。 二、实验原理:(写,该实验对应哪些协议?应用哪些技术?等等) OSPF(Open Shortest Path First,开放...
  • Cisco路由器的ospf虚链路路由配置

    千次阅读 2019-10-28 15:24:58
    通过OSPF虚链路的配置,实现跨区域主机的通信。 三 实验环境 GNS3,Windows10操作系统,SecureCRT8.0 四 实验过程 1.对路由器R1,R2,R3,R4进行接口ip配置 R1:conf t int f0/0 ip add 192.168.1.1 255.255.255.0 ...
  • OSPF具有可扩展性的一个原因是它的路由更新机制。OSPF使用LSA在OSPF节点之中共享路由信息。这些广播信息会在整个区中进行传播但不会超越一个区。因此,区中的每一个路由器都知道本区的拓扑。然而,一个区的拓扑对...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 12,700
精华内容 5,080
关键字:

思科配置ospf路由