精华内容
下载资源
问答
  • 思科配置ssh命令
    千次阅读
    2020-12-21 23:53:35

    原标题:Cisco路由器SSH登录的配置命令行

    当我们使用telnet登录到设备时,用户名和密码是采用明文的方式传输的,为了保证数据的安全,建议采用SSH的方式登录设备。以下就是Cisco路由器SSH的配置:

    1. 配置hostname和domain-name

    R1(config)#hostname R1

    R1(config)#ip domain-name frame.com

    2. 产生密钥,这里产生的是1024位的密钥,密钥长度范围为360-2048

    R1(config)#crypto key generate rsa general-keys modulus 1024

    The name for the keys will be: R1.frame.com

    % The key modulus size is 1024 bits

    % Generating 1024 bit RSA keys, keys will be non-exportable…[OK]

    R1(config)#

    3. 配置SSH的信息

    配置所使用的SSH版本:

    R1(config)#ip ssh version 2

    配置SSH会话的超时时间:

    R1(config)#ip ssh time-out 120

    配置SSH认证的最大次数:

    R1(config)#ip ssh authentication-retries 3

    启用SSH和telnet认证:

    R1(config)#line vty 0 4

    R1(config-line)#transport input ssh telnet

    R1(config-line)#login local //使用本地认证,登录时必须输入用户名和密码才可以,如果是no login,则不需要密码

    4. 配置本地认证用户

    R1(config)#username frame password cisco

    5. telnet和ssh登录测试

    Telnet登录:

    R2#telnet 1.1.1.1

    Trying 1.1.1.1 … Open

    Username: frame

    Password:

    R1>

    SSH登录:

    R2#ssh -l frame 1.1.1.1

    Password:

    R1>

    通过使用-l指定登录的用户名。

    服务器端查看SSH会话:show ssh

    R1#sh ssh

    Connection Version Mode Encryption Hmac State Username

    0 1.99 IN aes128-cbc hmac-sha1 Session started frame

    0 1.99 OUT aes128-cbc hmac-sha1 Session started frame

    %No SSHv1 server connections running.返回搜狐,查看更多

    责任编辑:

    更多相关内容
  • 思科SSH登陆配置命令过程

    千次阅读 2020-06-12 09:54:24
    然后我们随便选择一台路由器配置SSH,此处,我用的是R2进行配置。 第一步:我们将验证此台设备是否可以采用SSH,配置命令为show ip ssh,如图所示: 如果出现如图所示的提示信息,即可以进行配置 第二步:我们将...

    我们将采用Cisco Packet Tracer进行拓扑搭建,如图所示:
    在这里插入图片描述
    首先,我们将进行路由器的基础配置,包括设备名称以及IP地址,以及将他们激活,如图所示:
    在这里插入图片描述
    在这里插入图片描述
    然后我们随便选择一台路由器配置SSH,此处,我用的是R2进行配置。
    第一步:我们将验证此台设备是否可以采用SSH,配置命令为show ip ssh,如图所示:
    在这里插入图片描述
    如果出现如图所示的提示信息,即可以进行配置
    第二步:我们将配置域名
    第三步:我们将生成一个RSA密钥对
    第四步:配置用户用户登陆认证,SSH登陆是需要用户名和密码的
    第五步:配置vty线路
    第六步:配置为本地模式
    如图所示:
    在这里插入图片描述
    在这里插入图片描述
    到此为止,我们登陆配置过程已经完成,下次我们将从R1到R2尝试连接:
    在这里插入图片描述
    到此就成功了!!!

    展开全文
  • cisco交换机配置ssh远程登陆

    万次阅读 多人点赞 2019-09-11 21:25:53
    前言: 最近整理一些以前的学习笔记(有部分缺失,会有些乱,日后再补)。 过去都是存储在本地,此次传到网络留待...cisco SSH远程登陆配置 0.配置ip,启动端口 Switch>enable //进入特权模式 Switch#config...

    前言:

    最近整理一些以前的学习笔记(有部分缺失,会有些乱,日后再补)。
    过去都是存储在本地,此次传到网络留待备用。


     

    cisco SSH远程登陆配置

    0.配置ip,启动端口

    Switch>enable						            //进入特权模式
    Switch#configure terminal				        //进入全局模式
    Switch(config)#interface vlan 1                 //进入端口vlan1
    Switch(config-if)#ip address 设置ip 子网掩码	//设置ip
    Switch(config-if)#no shutdown			        //启动端口
    

    1.配置hostname和domain-name

    · rsa的秘钥是用hostname和domain-name产生的
      Switch> enable
      Switch# configure terminal
      Switch(config)# hostname Switch-ssh             //修改设备名,配置ssh的时候不能为router
      Switch-ssh(config)# ip domain-name test.com     //修改域名,配置ssh必须
      Switch-ssh(config)# aaa new-model               //开启3a认证(部分已开启)
    

    2.生成RSA秘钥

    · 生成RSA秘钥后ssh服务会自动开启,反之会自动关闭
    Switch-ssh(config)# crypto key generate rsa         //生成RSA秘钥
        How many bits in the modulus [512]: 768         //设置秘钥长度,指定ssh2版本要求至少768
        %SSH-5-ENABLED: SSH 1.5 has been enabled        //ssh自动开启
    Switch-ssh(config)# crypto key zeroize rsa          //删除RSA秘钥
    

    3.创建新用户和密码

    Switch-ssh(config)# username 用户名 privilege 0 secret 密码    //0,ssh时不会自动进入特权模式
    

    4.配置enable特权密码

    Switch-ssh(config)# enable secret 密码
    

    5.配置vty(虚拟终端)

    Switch-ssh(config)# line vty 0 4                    //4,最大并行连接数
    Switch-ssh(config-line)# transport input ssh        //只允许用ssh登陆
    Switch-ssh(config-line)# exec-timeout 10 0          //超时时间
    Switch-ssh(config-line)# logging synchronous        //光标跟随,同步信息输出
    Switch-ssh(config-line)# login local                //本地密码检测
    

    6.ssh的其他设置

    Switch-ssh(config)# ip ssh authentication-retries 2    //ssh认证失败的次数
    Switch-ssh(config)# ip ssh time-out 120                //ssh超时时间,单位秒
    Switch-ssh(config)# ip ssh version 2                   //指定ssh的协议版本
    Switch-ssh(config)# ip ssh source-interface f0/0       //指定ssh的接口(vlan也可以)
    

    7.保存配置

    # write
    

    8.测试登陆

    • 在cisco设备上使用ssh命令需要指定用户(若本地未配置username)
      # ssh -l 交换机用户名 交换机ip地址
          Password:用户密码
      # sw_ssh>enable
          Password: 特权密码
      

    转载于:https://my.oschina.net/xinsui1314x/blog/3078047

    展开全文
  • 思科设备SSH登录配置

    千次阅读 2021-08-17 18:18:12
    某公司有一台核心设备R1,为了方便进行管理,配置SSH远程登录,使用路由器R2模拟客户端,配置SSH协议登录R1。 实验拓扑如下: ![在这里插入图片描述]...

    某公司有一台核心设备R1,为了方便进行管理,配置SSH远程登录,使用路由器R2模拟客户端,配置SSH协议登录R1。

    实验拓扑如下:
    在这里插入图片描述
    R1配置:
    Router>en
    Router#conf
    Router(config)#hostname R1
    R1(config)#int f0/0
    R1(config-if)#ip add
    R1(config-if)#hostname R1
    R1(config-if)#ip add
    R1(config-if)#ip add
    R1(config-if)#ip address 192.168.2.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#no shutdown
    R1(config-if)#ex
    R1(config-if)#exit
    R1(config)#username ccna pa
    R1(config)#username ccna password ccna //设置登录使用的用户名密码和信息
    R1(config)#ip domain-na
    R1(config)#ip domain-name 123.com //设置ip域名
    R1(config)#
    R1(config)#cry
    R1(config)#crypto ke
    R1(config)#crypto key ge
    R1(config)#crypto key generate rsa //生成RSA密钥对
    The name for the keys will be: R1.123.com
    Choose the size of the key modulus in the range of 360 to 2048 for your
    General Purpose Keys. Choosing a key modulus greater than 512 may take
    a few minutes.

    How many bits in the modulus [512]: 1024 //设置密钥对长度为1024
    % Generating 1024 bit RSA keys, keys will be non-exportable…[OK]

    R1(config)#
    *3? 1 0:5:49.938: %SSH-5-ENABLED: SSH 1.99 has been enabled

    配置vty
    R1(config)#lin
    R1(config)#line v
    R1(config)#line vty 0 4
    R1(config-line)#tr
    R1(config-line)#transport in
    R1(config-line)#transport input ssh //打开SSH登录服务
    R1(config-line)#log
    R1(config-line)#login lo
    R1(config-line)#login local
    R1(config-line)#

    ssh的其它配置:
    R1(config)#ip ssh time-out 30 //设置ssh超时时间为30s
    R1(config)#ip ssh au
    R1(config)#ip ssh authentication-retries 5 //设置ssh认证失败的次数为5次
    R1(config)#ip ssh ver
    R1(config)#ip ssh version 2 //设置ssh的版本

    R2配置:
    Router#conf
    Configuring from terminal, memory, or network [terminal]?
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#ho
    Router(config)#hostname R2
    R2(config)#
    R2(config)#
    R2(config)#int f0/0
    R2(config-if)#ip add
    R2(config-if)#ip address 192.168.2.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#no shutdown

    验证:客户端R2登录R1
    在这里插入图片描述

    展开全文
  • Cisco 配置SSH

    2020-03-27 15:52:52
    三种方式 无认证 ... ...进入虚拟线路配置模式:line vty 0 4 (0 4 表示允许5个终端同时访问) ...注:从终端访问必须配置enable口令 ,配置命令如下: 进入全局配置模式:config t 配置口令:enable ([secret]...
  • Cisco ASA SSH配置

    千次阅读 2018-04-28 11:52:01
    1.配置服务器端ciscoasa(config)#crypto key generate rsa(创建RSA密钥,默认是1024bit) //指定rsa系数的大小,这个值越大,产生rsa的时间越长,cisco推荐使用1024.2.ciscoasa(config)#write mem //保存刚刚产生的...
  • 思科SSH配置

    万次阅读 多人点赞 2019-01-03 14:54:00
    R1(config)#hostname R1 //配置ssh的时候路由器的名字不能为router R1(config)#aaa new-model //默认是no aaa new-model, 如果配置为aaa new-model,line vty就不需要配置login local R1(config)#ip domain-name ...
  • Cisco交换机、路由器配置SSH功能(必须设备支持SSH功能才行) 1、配置用户和密码 username admin password 0 admin@123 2、配置linevty接口
  • 前言Ssh是加密通讯而telnet是明文通讯,所以在保密要求较高的网络需要使用ssh来管理网络设备,在Cisco路由器产品系列中只有7200系列、7500系列和12000系列(GSR)等高端产品的IOS支持SSH.一般支持SSH的IOS版本文件名...
  • Cisco路由器配置命令

    千次阅读 2021-10-15 15:43:48
    特权模式:这一级别用户可以使用show命令进行配置查看,但是还是无法进行配置。在用户模式下输入enable进入。 一般是Router# 全局模式:这一级别下用户可以对路由器进行配置。特权模式下输入config terminal可以...
  • Cisco-ASA防火墙配置命令-SSh-Telnet

    千次阅读 2020-06-02 16:31:53
    R1 en conf t int f0/0 ip add 192.168.1.2 255.255.255.0 no sh exit ip route 0.0.0.0 0.0.0.0 192.168.1.1 R2 en conf t ...ssh ver 2 限定使用版本 打开一台虚拟机配置ip:192.168.3.2 255.255.255.0 192.168.3.1
  • 思科防火墙配置命令(详细命令总结归纳)

    万次阅读 多人点赞 2021-10-08 07:01:58
    防火墙的实施是每个网络基础设施必要且不可分割的组成部分,传统的防火墙功能已经从最初保护网络免于未授权外部访问的攻击得到了进一步的发展,现在的防火墙通常具备多种功能,下面介绍一下思科防火墙的详细配置方法...
  • CISCO常用配置命令

    千次阅读 2021-09-20 22:28:29
    无论在国内市场还是国际市场,CISCO交换机、路由器在网络设备领域都占据了主导地位,因此了解基础的CISCO设备配置命令,能够看懂设备配置信息,对内网渗透过程帮助很大。本文首先介绍CISCO设备基本命令,然后利用...
  • CiSCO 交换机配置 SSH 登陆

    千次阅读 2017-03-10 23:37:00
    CiSCO 交换机配置 SSH 登陆 题目:在三层交换机上仅运行 SSH 服务,且用户名和密码的方式登录交换机。 (一)了解主机名与域名 ​ 1、"主机名" 为该设备的名称 ​ 2、"域名" 为该设备所属的所属者 (二)配置主机名...
  • 思科设备SSH登陆详细配置过程

    万次阅读 多人点赞 2017-04-30 11:51:49
    进行完基本配置之后开始配置SSH服务器(R2) 首先验证设备是否支持SSH R2#show ip ssh 能够识别这条命令就说明支持。 配置IP域名。 使用config# ip domain-name domain-name 全局配置模式命令配置网络 IP 域名...
  • 本文实例讲述了思科认证CiSCO 交换机配置SSH 登陆操作命令。分享给大家供大家参考,具体如下:题目:在三层交换机上仅运行 SSH 服务,且用户名和密码的方式登录交换机。(一)了解主机名与域名​1、"主机名" 为该...
  • Cisco 防火墙 SSH配置

    千次阅读 2019-09-13 17:57:43
    1.如果开启机器,命令行出现如下情况: rommon #0> rommon 加载系统的小系统。常用来做镜像恢复,一些特殊参数设置等。...2.可用boot命令 rommon #0> boot Launching BootLoader... Default ...
  • 交换机配置SSH

    千次阅读 2021-06-03 09:33:43
    一、思科交换机 1.设置域名 Switch(config)#ip domain-name test.com 2.设置SSH key Switch(config)#crypto key generate rsa general-keys modulus 512 3.设置允许SSH Switch(config)#line vty 0 4 Switch...
  • Hello大家好,我是Lionel,今天我给大家带来思科路由器配置SSH,Telnet和修改交换机名字的教程。看我下面操作首先我们启动交换机,看到 Switch>上面的单词(启动过程很慢)配置SSH我们依次输入下面的命令,后面有...
  • 交换机路由器命令自动配置小工具 支持华为、华三、思科的交换机、路由器命令自动配置 配置自动保存txt文件到当前config目录 目前仅支持SSH单线程
  • 华三、思科开启ssh服务
  • 常用命令思科常用基础配置

    千次阅读 2021-06-23 15:46:45
    此博文是介绍思科的基础命令,包括如何配置主机名、IP地址、telnet、ssh远程登录等常用基础命令。博文的初衷是作为一篇备忘录,在长时间不配置思科设备,临时要用时候的备查,可以可以作为新手入门必备命令,必须要...
  • 锐捷交换机配置ssh password登录命令

    千次阅读 2021-08-28 16:22:12
    enable ...enable service ssh-server ip ssh version 2 username user01 privilege 15 password 7 mima211 username user01 login mode ssh lin vty 0 4 login local transport input all end write
  • 交换机路由器命令自动配置小工具 支持华为、华三、思科的交换机、路由器命令自动配置 配置自动保存txt文件到当前config目录 目前仅支持SSH多线程
  • 思科3750配置只允许SSH登录

    千次阅读 2017-11-14 13:57:00
    交换机IOS版本过低的不支持SSH,如果执行crypto key generate rsa时提示没有这个命令那肯定就是不支持SSH了。 进入全局配置模式 conf t 1.启用ssh 首先需要创建用户 username cisco password ciscocisco 注意:如果...
  • cisco vlan管理口配置,及ssh简单配置

    千次阅读 2020-04-27 23:48:48
    二层交换机管理接口配置思路: 创建vlan在进入vlanif配置ip等等 (配置好后vlanif的状态是down掉的) ...ssh配置思路 进入全局,建立域名,生成大于768位的rsa密钥 (生成密钥后会自动打开ssh功能) 建...
  • Cisco 特权模式、Telnet、SSH验证口令配置R1#configure terminalR1(config)#enable password XXXX控制台登录口令:router#config terminalrouter(config)#line console 0router(config-line)#exec-timeout 0 0 //...
  • 思科交换机 ssh和telnet远程登录

    千次阅读 2021-05-18 14:20:06
    Cisco SSH Telnet 远程登录配置 拓扑 一、Sw0上建立一个管理Vlan 8 Switch(config)#hostname HOM #更改交换机名称如果不更改rsa生成秘钥时会报错 HOM(config)#int vlan 8 HOM(config-if)#ip add 10.0.8.1 255.255....
  • 以及另一个记事本上的配置(配置文件)在目的是从配置文件通过SSH到IP列表列表。如果设备接受了命令,则应将日志放入成功.txt如果由于某种原因不接受该命令,则应附加一个日志失败.txt在但这行不通。你能帮我修好吗?...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 4,877
精华内容 1,950
关键字:

思科配置ssh命令

友情链接: EJB3.0_Servlet.rar