精华内容
下载资源
问答
  • 保存和恢复思科配置文件
  • 思科配置文件解释

    千次阅读 2018-10-10 22:43:18
    ##line vty 0 4,该命令是允许用户远程登陆,即不用用户插Console线缆,只要设备连接网络,配置了接口IP地址即可远程使用Telnet、或者ssh的方式登陆到设备上,,CISCO设备一般支持16个并行的远程虚拟终端,按照编号...
    hostname Switch   //主机名,此处用的默认的
    !
    boot-start-marker   //启动开始标记
    boot-end-marker     //启动结束标记,这个不用配
    !
    !
    !
    !
    no aaa new-model  //去掉AAA接入控制模式
    system mtu routing 1500  //设置路由时的MTU大小
    !
    !
    !
    !
    crypto pki trustpoint TP-self-signed-1869362816   
     enrollment selfsigned   //设置申请证书的方式
     subject-name cn=IOS-Self-Signed-Certificate-1869362816  //证书的名称分发者信息
     revocation-check none   //是否返回查询证书服务器
     rsakeypair TP-self-signed-1869362816   //在验证和申请证书之前需要的钥匙对
    !         
    ! 
    ##这里没有什么好纠结的,是设备自己根证书。        
    crypto pki certificate chain TP-self-signed-1869362816
     certificate self-signed 01
      3082023F 308201A8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
      69666963 6174652D 31383639 33363238 3136301E 170D3933 30333031 30303031 
      30365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 38363933 
      36323831 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
      8100C3B3 6E1E063E 988E60A0 439A9D25 31467AD1 4462816C BB16E878 776BF1F0 
      D1A9CCC2 59E952B0 B6193F4F 7FD032BC 450D47C0 1318D71D D75046E3 380C72CF 
      B817DCE9 726E732B F5BEA0BF D68996F6 8A952402 E3840551 2AFB05B3 F0F85E87 
      0C4C01C4 A13CF98D B5D5EDBD 67EEAAF6 1C82523C DDAA3424 8F80DC56 758AD202 
      10290203 010001A3 67306530 0F060355 1D130101 FF040530 030101FF 30120603 
      551D1104 0B300982 07537769 7463682E 301F0603 551D2304 18301680 145225C6 
      C75CD3BD C0B5FD7D 1C81DFE5 2C71DA51 78301D06 03551D0E 04160414 5225C6C7 
      5CD3BDC0 B5FD7D1C 81DFE52C 71DA5178 300D0609 2A864886 F70D0101 04050003 
      81810008 F21A5E76 7290F5AA 76E84652 25A7EE99 CC9FE785 F2C4B5C2 A48A40A0 
      7E84FEA1 040FA9A7 0FA2B6F5 6A72B1F6 59FA2B26 CDA8C2FB 10BCFA82 6EE7E31E 
      341F535F 0C875980 521A5EC8 8196B6C0 0F369695 FEF934EF 5336E78E F8EECE28 
      A34E60C0 FA8A7603 79085C12 1F8BAF9E A2A0EACD 8CA4AC84 9A4864C9 2088FEC0 AED95C
      quit    
    !         
    !         
    !         
    spanning-tree mode pvst   //设置生成树模式为PVST格式
    spanning-tree extend system-id   //扩展生成树的系统ID,为了能够在一个机框里支持1024个MAC地址
    !         
    vlan internal allocation policy ascending //cisco交换机指定内部vlan号分配是使用升序(ascending:从低到高)或者降序(descending:从高到低);内部vlan号是交换机内部用来标识用,对用户配置没有什么影响
    !         
    !         
    !         
    interface FastEthernet0/1
     switchport access vlan 210
     switchport mode access
    !         
    interface FastEthernet0/2
     switchport access vlan 210
     switchport mode access
    !         
    interface FastEthernet0/3
     switchport access vlan 210
     switchport mode access
    !         
    interface FastEthernet0/4
     switchport access vlan 210
     switchport mode access
    !         
    interface FastEthernet0/5
     switchport access vlan 200
     switchport mode access
    !         
    interface FastEthernet0/6
     switchport access vlan 200
     switchport mode access
    !         
    interface FastEthernet0/7
     switchport access vlan 200
     switchport mode access
    !         
    interface FastEthernet0/8
     switchport access vlan 200
     switchport mode access
    !         
    interface FastEthernet0/9
     switchport access vlan 200
     switchport mode access
    !         
    interface FastEthernet0/10
     switchport access vlan 200
     switchport mode access
    !         
    interface FastEthernet0/11
     switchport access vlan 200
     switchport mode access
    !         
    interface FastEthernet0/12
     switchport access vlan 200
     switchport mode access
    !         
    interface FastEthernet0/13
     switchport access vlan 220
     switchport mode access
    !         
    interface FastEthernet0/14
     switchport access vlan 220
     switchport mode access
    !         
    interface FastEthernet0/15
     switchport access vlan 220
    !         
    interface FastEthernet0/16
     switchport access vlan 220
    !         
    interface FastEthernet0/17
     switchport access vlan 200
     switchport mode access
    !         
    interface FastEthernet0/18
     switchport access vlan 200
     switchport mode access
    !         
    interface FastEthernet0/19
     switchport access vlan 200
     switchport mode access
    !         
    interface FastEthernet0/20
     switchport access vlan 200
     switchport mode access
    !         
    interface FastEthernet0/21
     switchport access vlan 200
     switchport mode access
    !         
    interface FastEthernet0/22
     switchport access vlan 200
     switchport mode access
    !         
    interface FastEthernet0/23
    !         
    interface FastEthernet0/24
    !         
    interface GigabitEthernet0/1
     switchport trunk encapsulation dot1q   //定义此接口的协议
     switchport mode trunk    //定义此接口模式为trunk口
    !         
    interface GigabitEthernet0/2
    !         
    interface Vlan1
     no ip address
    !         
    interface Vlan200
     no ip address   //没有分配 IP地址
    !         
    ip classless  //作用于路由转发进程的,告诉路由器工作在无类环境下
    ip http server  //允许http登录
    ip http secure-server
    !         
    !         
    ! 
    ##line vty 0 4,该命令是允许用户远程登陆,即不用用户插Console线缆,只要设备连接网络,配置了接口IP地址即可远程使用Telnet、或者ssh的方式登陆到设备上,,CISCO设备一般支持16个并行的远程虚拟终端,按照编号就是:0 - 15., Line vty 0 4 就是指同时允许5个虚拟终端登陆进行配置,需注意这里配置完成后一定要注意配置enable的密码,要不Telnet是上不去的。
    line con 0
    line vty 0 4
     login    
    line vty 5 15
     login    
    !         
    end       

     

    展开全文
  • 思科防火墙配置指南,包括防火墙NAT匹配规则,静态NAT,动态NAT等。
  • 原版的思科2960配置文件,英语版的,还不错哦。
  • 今天小编就和大家一起来探讨一下怎样备份思科路由器的配置文件呢?关于备份思科路由器相关的配置文件,这一个部分究竟有多么的重要,相信就算小编不用多说,大家都应该知道了吧。其实在路由器的配置过程里面,大家...

    路由器(Router,又称路径器)是一种计算机网络设备,而配置文件就是对于不一样的对象进行不一样配置的文件。今天小编就和大家一起来探讨一下怎样备份思科路由器的配置文件呢?

    关于备份思科路由器相关的配置文件,这一个部分究竟有多么的重要,相信就算小编不用多说,大家都应该知道了吧。其实在路由器的配置过程里面,大家常常都会使用到COPY这一个命令的。那么在这一篇教程里面,小编就为大家详细的介绍一下:究竟怎样使用COPY这一个命令来进行备份cisco路由器的配置文件吧。除此之外,小编还会和大家继续探讨一下究竟怎样从TFTP服务器里面复制备份cisco路由器配置文件。现在我们就一起来看看吧。

    第一个命令

    首先小编要为大家介绍的是copyrunning-configstartup-config,那么这以个命令主要的作用就是把存储在RAM(随机存取存储器,random Access memory,RAM)又称作"随机存储器",是与CPU直接交换数据的内部存储器,也叫主存)的正确配置复制到路由器的NVRAM里面。这样子的话,大家在下一次启动的时候,cisco路由器就会自动的使用这一个正确的配置了。

    第二个命令

    接下来小编要为大家介绍的是copy running-configt ftp,这一个命令的功能就是把RAM里面正确的配置文件复制到TFTP服务器上面。在这里的话,小编强烈推荐网络管理员应该按照下面这样子做,因为假如说路由器不可以从NVRAM里面正常的装载配置文件,那么大家都能够通过从TFTP里面复制到正确的配置文件。

    当网络管理员成功的输入命令并且键入回车按钮以后,那么路由器就会要求大家输入TFTP(简单文件传输协议)服务器的IP地址(IP地址是IP协议提供的一种统一的地址格式,它为互联网上的每一个网络和每一台主机分配一个逻辑地址,以此来屏蔽物理地址的差异。)了。当大家在正确的键入服务器IP地址以后,另外路由器还会要求网络管理员提供所需要备份cisco路由器配置文件名字。一般情况下,小编都会建议大家使用网络管理员比较容易记住的文件名字。这个时候路由器都会提示网络管理员按下YES按钮来确认操作的。

    第三个命令

    最后小编为大家介绍的是copyt ftp running-config这一条命令,爱计入说路由器的配置文件不小心出现了一些问题,那个这个时候大家就能够通过从TFTP服务器里面复制备份cisco路由器配置文件。有人就会问小编,应该怎样设置呢?具体配置如下:

    小编结语:

    以上是今天考试认证的教程了,为大家探讨一下怎样备份思科路由器的配置文件呢?希望这对你有所帮助。如果你也有这样的需要,那就赶快来学习一下吧。如果大家喜欢课课家教育的话,不妨可以推荐更多的朋友来哟!

    展开全文
  • 当遇到路由器配置大于NVRAM的大小时,通常的建议是将配置保存在外部的TFTP服务器上,然后在路由器上使用命令bootnetwork或boothost来调取配置文件。我们这里介绍一个方法可以避免借助于外部主机:1配置路由器,在...

    当遇到路由器配置大于

    NVRAM

    的大小时,通常的建议是将配置保存在外部的

    TFTP

    服务

    器上,然后在路由器上使用命令

    boot network

    boot host

    来调取配置文件。

    我们这里介绍一个方法可以避免借助于外部主机:

    1

    配置路由器,在配置中,配置两条从网络上调用配置的命令:

    ervice config

    oot network tftp://10.10.10.10/host-config

    oot host tftp://10.10.10.10/startup-config

    10.10.10.10

    是路由器

    LAN

    口的地址

    2

    再在配置中增加下面两条

    alias

    命令,这样路由器感觉是到网络上的外接服务器去下载配

    置,实际上还是在本地的中下载配置:

    tftp-server flash:/startup-config alias startup-config

    tftp-server flash:/host-config alias host-config

    3

    保存配置

    4

    将配置文件传到

    flash

    展开全文
  • 1、copyrunning-...2、copyrunning-configtftp这个命令是将RAM中正确的配置文件拷贝到TFTP服务器上,我们强烈推荐网络管理员这样做,因为如果路由器不能从NVRAM中正常装载配置文件,我们可以通过从TFTP中...

    1

    copy running-config startup-config

    这个命令是将存储在

    RAM

    的正确配置拷贝到路由器的

    NVRAM

    中。

    这样,

    在下一次启动时,

    路由器就会使用这个正确的配置。

    2

    copy running-config tftp

    这个命令是将

    RAM

    中正确的配置文件拷贝到

    TFTP

    服务器上,我们强烈推荐网络管理员这

    样做,因为如果路由器不能从

    NVRAM

    中正常装载配置文件,我们可以通过从

    TFTP

    中拷

    贝正确的配置文件。

    it168#copy running-config tftp

    address or name of remote host

    []?129.0.0.3

    destination file name [it168-confg]?

    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    624 bytes copied in 7.05 secs

    it168#

    当网络管理员输入命令并键入回车后,路由器会要求输入

    TFTP

    服务器的

    IP

    地址,在正确

    的键入服务器

    IP

    地址后,路由器还要求网络管理员提供需要备份的配置文件名。一般我们

    建议使用管理员容易记忆的文件名。这时路由器会提示管理员按

    YES

    确认操作。

    3

    copy tftp running-config

    如果路由器的配置文件出现问题,

    这时我们就可以通过从

    TFTP

    服务器中拷贝备份的配置文

    件。具体配置如下:

    it168#copy tftp running-config

    address or name of remote host[]?

    129.0.0.3

    source filename []?it168-confg

    destination file name [running-config]?

    accessing tftp://129.0.0.3/it168-confg

    loading it168-confg from 129.0.0.3

    (via fastethernet 0/0):

    !!!!!!!!!!!!!!!!!!!!!!!

    展开全文
  • 下面我们就为大家介绍如何使用COPY命令备份配置文件,以及如何从TFTP服务器拷贝备份配置文件。1、copy running-config startup-config这个命令是将存储在RAM的正确配置拷贝到路由器的NVRAM中。这样,在下一次启动时...
  • 思科3550配置说明文件

    2011-03-11 23:47:24
    好东西 大家分享啊 我这个是一个公司的思科3550的配置
  • 思科基础实验文件可以用思科模拟器直接打开学习
  • R#erase startup-config 本文转自 gswljy 51CTO博客,原文链接:http://blog.51cto.com/guoshiwei/701127
  • 1.数据备份前的准备 思科设备需要支持TFTP或FTP协议功能 电脑端需要安装TFTP软件,请自行找度娘到官网下载! 2..备份数据处理(相同的...Switch#copy running-config TFTP //复制交换机配置文件保存到TFTP服务...
  • -------------------------------------------------------------------------------------------------------- CISCO交换机备份和恢复配置文件的方法 1、保存配置 将当前运行配置从DRAM存储到启动配置所在的NVRAM...
  • 思科配置命令.DOC

    2011-06-13 10:03:25
    思科配置命令WORD文档 DOC文件~~~
  • 思科 网络设备配置ADSL 录像 exe文件 成都某思科培训学校资深讲师录制的课件 分上下2集
  • 思科交换机配置

    2014-06-05 14:33:22
    思科交换机配置 packet tracer 文件
  • 1. 实验目的通过本实验,读者可以掌握如下技能:(1) 熟悉TFTP 服务器的使用(2) 熟悉备份路由器的配置文件(3) 掌握备份路由器的IOS2. 实验拓扑3. 实验步骤(1) 步骤1:TFTP SERVER 软件的安装、准备Tftp ...
  • Suppose you have a Cisco Router (192.168.1.1) with the “c1sc0zine” community string, a tftp server with 192.168.1.100 ip address and you want to save the running configuration to the tftp-server ...
  • <?xmlversion="1.0"encoding="utf-8"?> <configversion="1.0"> <Client> <Persistent_Chat_Enabled>true</Persistent_Chat_Enabled> </Client> <Option...
  • 从网上找的资源整理而成的word,包括各种协议的配置,从基本的讲起,挺全面的,方便大家查找。
  • 思科网络技术学院教程packet tracer配置文件,1-4的全有,免费下载啦。好不容易找到的。另外的书以及光盘电驴都有。
  • 快速恢复交换机配置:(单机配置通过CRT) copy flash:/config.text tftp://134.17.3.11(之前可以通过tftp下载文件到本地电脑) copy flash:/vlan.dat tftp://134.17.3.11 在CRT软件中,依次点击【传输】----...
  • 思科路由器IOS系统和配置文件的备份、删除及还原 续上篇讲的思科路由器的密码重置,本篇讲一下思科路由器iOS系统的备份、删除 还原。在生产情况下,很少有iOS文件的丢失的,大多是人为的删除,可能是为了安全,也有...
  • 思科路由配置

    2017-05-05 15:21:51
    一个简单的思科路由拓扑文件
  • Cisco IOS配置文件的自动备份与回退需要使用到IOS的archive归档配置模式功能。一般来说,只有IOS的版本号在12.3(4) <含> 与其之后的版本才带有归档配置模式功能。 Cisco IOS配置文件自动备份全部命令如下: ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 420
精华内容 168
关键字:

思科配置文件