精华内容
下载资源
问答
  • 路由器配置IP en 进入用户模式 config interface f+tab键 || interface s+tab键 启用接口模式 紧跟着写上端口号0/0 || 1/0 ...下一跳地址> end 退出接口模式 show ip route 可以查看所配置的route 为se.

    在这里插入图片描述

    路由器配置IP

    en 进入用户模式
    config
    interface f+tab键 || interface s+tab键 启用接口模式
    紧跟着写上端口号0/0 || 1/0
    ip address <ip地址> <子网掩码> 配置IP
    no shutdown

    配置IP route

    en 进入用户模式
    config
    ip route <目的网段> <子网掩码> <下一跳地址>
    end 退出接口模式
    show ip route 可以查看所配置的route

    为serial接口配相同的时钟频率

    当只有两serial接口的时钟频率相同时才可以进行数据传输,否则链路不同,会乱码。
    en 进入用户模式
    config
    interface s+tab键 启用接口模式
    紧跟着写上端口号0/0 || 1/0
    clock rate 64000
    设置成功

    展开全文
  • 思科路由静态NAT配置

    2018-01-12 22:37:17
    实验名称:思科路由静态NAT配置实验拓扑:实验环境:1、3台路由器,2、一台交换机Router 0 边界路由器(内网和外网)Router 1 边界路由器(公网的内网和外网)Pouter 2 内网路由器 (公网的内部网络)3、一台PC ...

    实验名称:思科路由静态NAT配置
    实验拓扑:思科路由静态NAT配置
    实验环境:1、3台路由器,
    2、一台交换机
    Router 0 边界路由器(内网和外网)
    Router 1 边界路由器(公网的内网和外网)
    Pouter 2 内网路由器 (公网的内部网络)
    3、一台PC

    实验步骤:
    1、 配置PC机地址:
    IP : 192.168.10.1/24
    网关:192.168.10.25
    2、 配置Router 0
    Continue with configuration dialog? [yes/no]: n

    Press RETURN to get started!
    Router>
    Router>
    Router>enable
    Router#
    Router#
    Router#configure
    Configuring from terminal, memory, or network [terminal]?
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#int g0/0
    Router(config-if)#no shutdown

    Router(config-if)#
    %LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

    Router(config-if)#
    Router(config-if)#ip add 19.168.10.254 255.255.255.0
    Router(config-if)#q
    ^
    % Invalid input detected at '^' marker.
    Router(config-if)#e
    Router(config)#int g0/1
    Router(config-if)#no shutdown

    Router(config-if)#ip add 100.1.1.1 255.255.255.0
    Router(config-if)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up

    Router(config-if)#
    Router(config-if)#
    Router(config-if)#e
    Router(config)#int g0/0
    Router(config-if)#ip nat inside
    Router(config-if)#e
    Router(config)#int g0/1
    Router(config-if)#ip nat outside
    Router(config-if)#e
    Router(config)#ip nat i
    Router(config)#ip nat inside s
    Router(config)#ip nat inside source s
    Router(config)#ip nat inside source static 192.168.10.1 100.1.1.1
    Router(config)#int g0/0
    Router(config-if)#ip add 192.168.10.254 255.255.255.0
    Router(config-if)#e
    Router(config)#ip route 0.0.0.0 0.0.0.0 100.1.1.2
    Router(config)#ip route 0.0.0.0 0.0.0.0 100.1.1.2
    Router(config)#
    3、 配置Router1
    Continue with configuration dialog? [yes/no]: no

    Press RETURN to get started!

    Router>
    Router>
    Router>
    Router>enable
    Router#
    Router#
    Router#configure
    Configuring from terminal, memory, or network [terminal]?
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#
    Router(config)#int g0/1
    Router(config-if)#no shutdown

    Router(config-if)#
    %LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up

    Router(config-if)#
    Router(config-if)#ip add 100.1.1.2 255.255.255.0
    Router(config-if)#e
    Router(config)#int g0/2
    Router(config-if)#no shutdown

    Router(config-if)#
    %LINK-5-CHANGED: Interface GigabitEthernet0/2, changed state to up

    Router(config-if)#ip add 200.1.1.1 255.255.255.0
    Router(config-if)#e
    Router(config)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2, changed state to up

    Router(config)#
    Router(config)#
    Router(config)#route rip
    Router(config-router)#net
    Router(config-router)#network 100.1.1.0
    Router(config-router)#net
    Router(config-router)#network 200.1.1.0
    Router(config-router)#pa
    Router(config-router)#passive-interface g0/1
    Router(config-router)#
    4、 配置Router 2
    Continue with configuration dialog? [yes/no]: no

    Press RETURN to get started!

    Router>
    Router>
    Router>
    Router>enable
    Router#
    Router#
    Router#configure
    Configuring from terminal, memory, or network [terminal]?
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#
    Router(config)#
    Router(config)#int g0/2
    Router(config-if)#no shutdown

    Router(config-if)#
    %LINK-5-CHANGED: Interface GigabitEthernet0/2, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2, changed state to up

    Router(config-if)#ip add 200.1.1.2 255.255.255.0
    Router(config-if)#
    Router(config-if)#
    Router(config-if)#
    Router(config-if)#
    Router(config-if)#e
    Router(config)#route rip
    Router(config-router)#net
    Router(config-router)#network 200.1.1.0
    Router(config-router)#
    5、 验证测试:

    思科路由静态NAT配置

    思科路由静态NAT配置

    思科路由静态NAT配置

    思科路由静态NAT配置

    思科路由静态NAT配置

    转载于:https://blog.51cto.com/13467772/2060436

    展开全文
  • 思科 配置静态NAT

    千次阅读 2019-05-16 18:48:15
    1.配置静态NAT 问题 随着接入Internet的计算机数量的不断猛增,IP地址资源也就愈加显得捉襟见肘。事实上,除了中国教育和科研计算机网(CERNET)外,一般用户几乎申请不到整段的C类IP地址。在其他ISP那里,即使是...

    1.配置静态NAT
    问题
    随着接入Internet的计算机数量的不断猛增,IP地址资源也就愈加显得捉襟见肘。事实上,除了中国教育和科研计算机网(CERNET)外,一般用户几乎申请不到整段的C类IP地址。在其他ISP那里,即使是拥有几百台计算机的大型局域网用户,当他们申请IP地址时,所分配的地址也不过只有几个或十几个IP地址。显然,这样少的IP地址根本无法满足网络用户的需求。
    1)在R1上将192.168.0.10转换为201.1.1.2,192.168.0.20转换为201.1.1.3,实现访问200.1.1.10
    方案
    借助于NAT,私有(保留)地址的"内部"网络通过路由器发送数据包时,私有地址被转换成合法的IP地址,一个局域网只需使用少量IP地址(甚至是1个)即可实现私有地址网络内所有计算机与Internet的通信需求。
    这种通过使用少量的公有IP 地址代表较多的私有IP 地址的方式,将有助于减缓可用IP地址空间的枯竭。而且还能够有效地避免来自网络外部的攻击,隐藏并保护网络内部的计算机。
    网络拓扑如图-1所示:
    在这里插入图片描述
    图-1
    步骤
    实现此案例需要按照如下步骤进行。
    步骤一:通用配置
    1)配置R1端口IP地址,以及默认路由
    tarena-R1(config)#interface f0/0
    tarena-R1(config-if)#ip address 192.168.0.1 255.255.255.0
    tarena-R1(config-if)#no shutdown
    tarena-R1(config-if)#interface f0/1
    tarena-R1(config-if)#ip address 201.1.1.1 255.255.255.0
    tarena-R1(config-if)#no shutdown
    tarena-R1(config-if)#exit
    tarena-R1(config)#ip route 0.0.0.0 0.0.0.0 201.1.1.254
    2)配置R2端口IP地址
    不需要在R2上配置到企业内网的静态路由,因为NAT的存在,企业内部的地址都将被转换、隐藏。
    tarena-R2(config)#interface f0/0
    tarena-R2(config-if)#ip address 201.1.1.254 255.255.255.0
    tarena-R2(config-if)#no shutdown
    tarena-R2(config-if)#interface f0/1
    tarena-R2(config-if)#ip address 200.1.1.1 255.255.255.0
    tarena-R2(config-if)#no shutdown
    步骤二:静态NAT配置
    1)在R1上将192.168.0.10映射到201.1.1.2,将192.168.0.20映射到201.1.1.3
    静态映射有唯一对应的关系,这也提供了外网到内网主机的访问途径,即如果外网主机想访问内网的192.168.0.10,只要访问201.1.1.2即可。
    通过静态NAT,可以把内网服务器发布到外网。
    tarena-R1(config)#ip nat inside source static 192.168.0.10 201.1.1.2
    tarena-R1(config)#ip nat inside source static 192.168.0.20 201.1.1.3
    2)在R1上配置NAT内、外端口
    tarena-R1(config)#interface f0/0
    tarena-R1(config-if)#ip nat inside
    tarena-R1(config-if)#interface f0/1
    tarena-R1(config-if)#ip nat outside
    3)分别在两台PC机上测试到外网主机的通信
    PC1测试如下所示:
    PC>ipconfig
    FastEthernet0 Connection:(default port)
    Link-local IPv6 Address…: FE80::2E0:F7FF:FED6:54CC
    IP Address…: 192.168.0.10
    Subnet Mask…: 255.255.255.0
    Default Gateway…: 192.168.0.1
    PC>ping 200.1.1.10
    Pinging 200.1.1.10 with 32 bytes of data:
    Request timed out.
    Request timed out.
    Reply from 200.1.1.10: bytes=32 time=1ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=0ms TTL=126
    Ping statistics for 200.1.1.10:
    Packets: Sent = 4, Received = 2, Lost = 2 (50% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms
    PC>
    PC2的测试如下所示:
    PC>ipconfig
    FastEthernet0 Connection:(default port)
    Link-local IPv6 Address…: FE80::2D0:BAFF:FE98:9E29
    IP Address…: 192.168.0.20
    Subnet Mask…: 255.255.255.0
    Default Gateway…: 192.168.0.1
    PC>ping 200.1.1.10
    Pinging 200.1.1.10 with 32 bytes of data:
    Request timed out.
    Request timed out.
    Reply from 200.1.1.10: bytes=32 time=0ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=1ms TTL=126
    Ping statistics for 200.1.1.10:
    Packets: Sent = 4, Received = 2, Lost = 2 (50% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms
    PC>
    4)在R1上查看NAT转换表
    tarena-R1#show ip nat translations
    Pro Inside global Inside local Outside local Outside global
    icmp 201.1.1.3:17 192.168.0.20:17 200.1.1.10:17 200.1.1.10:17
    icmp 201.1.1.3:18 192.168.0.20:18 200.1.1.10:18 200.1.1.10:18
    icmp 201.1.1.3:19 192.168.0.20:19 200.1.1.10:19 200.1.1.10:19
    icmp 201.1.1.3:20 192.168.0.20:20 200.1.1.10:20 200.1.1.10:20
    — 201.1.1.2 192.168.0.10 — —
    — 201.1.1.3 192.168.0.20 — —
    2.配置动态NAT
    问题
    在R1通过动态NAT实现企业内网192.168.0.0/24转换为公网地址201.1.1.2-201.1.1.5,访问200.1.1.10
    方案
    网络拓扑如图-2所示:
    在这里插入图片描述
    图-2
    步骤
    实现此案例需要按照如下步骤进行。
    步骤一:动态NAT配置
    1)删除静态NAT配置
    tarena-R1(config)#no ip nat inside source static 192.168.0.10 201.1.1.2
    tarena-R1(config)#no ip nat inside source static 192.168.0.20 201.1.1.3
    2)在R1上配置包括内网所有IP地址的ACL
    tarena-R1(config)#access-list 1 permit 192.168.0.0 0.0.0.255
    3)在R1上配置合法的IP地址池
    地址池是向ISP(Internet服务提供商,如电信、联通)申请得到的,内网主机(上一步ACL中所包含的IP地址)到外网的访问,内网地址将被动态的、随机的转换为这些合法地址。
    tarena-R1(config)#ip nat pool natpool 201.1.1.2 201.1.1.5 netmask 255.255.255.0
    4)关联ACL和合法的IP地址池
    tarena-R1(config)#ip nat inside source list 1 pool natpool
    5)在R1上配置NAT内、外端口
    tarena-R1(config)#interface f0/0
    tarena-R1(config-if)#ip nat inside
    tarena-R1(config-if)#interface f0/1
    tarena-R1(config-if)#ip nat outside
    6)分别在两台PC机上测试到外网主机的通信
    PC1测试如下所示:
    PC>ipconfig
    FastEthernet0 Connection:(default port)
    Link-local IPv6 Address…: FE80::2E0:F7FF:FED6:54CC
    IP Address…: 192.168.0.10
    Subnet Mask…: 255.255.255.0
    Default Gateway…: 192.168.0.1
    PC>ping 200.1.1.10
    Pinging 200.1.1.10 with 32 bytes of data:
    Reply from 200.1.1.10: bytes=32 time=1ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=0ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=1ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=0ms TTL=126
    Ping statistics for 200.1.1.10:
    Packets: Sent = 4, Received = 2, Lost = 2 (50% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms
    PC>
    PC2测试如下所示:

    PC>ipconfig
    FastEthernet0 Connection:(default port)
    Link-local IPv6 Address…: FE80::2D0:BAFF:FE98:9E29
    IP Address…: 192.168.0.20
    Subnet Mask…: 255.255.255.0
    Default Gateway…: 192.168.0.1
    PC>ping 200.1.1.10
    Pinging 200.1.1.10 with 32 bytes of data:
    Reply from 200.1.1.10: bytes=32 time=0ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=1ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=0ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=1ms TTL=126
    Ping statistics for 200.1.1.10:
    Packets: Sent = 4, Received = 2, Lost = 2 (50% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms
    PC>
    7)在R1上查看NAT转换表
    转换表中的对应关系是动态的,如192.168.0.10被转换为201.1.1.2,但是下一次对外网的访问很有可能被转换为其他地址。
    tarena-R1#show ip nat translations
    Pro Inside global Inside local Outside local Outside global
    icmp 201.1.1.2:21 192.168.0.10:21 200.1.1.10:21 200.1.1.10:21
    icmp 201.1.1.2:22 192.168.0.10:22 200.1.1.10:22 200.1.1.10:22
    icmp 201.1.1.2:23 192.168.0.10:23 200.1.1.10:23 200.1.1.10:23
    icmp 201.1.1.2:24 192.168.0.10:24 200.1.1.10:24 200.1.1.10:24
    icmp 201.1.1.3:21 192.168.0.20:21 200.1.1.10:21 200.1.1.10:21
    icmp 201.1.1.3:22 192.168.0.20:22 200.1.1.10:22 200.1.1.10:22
    icmp 201.1.1.3:23 192.168.0.20:23 200.1.1.10:23 200.1.1.10:23
    icmp 201.1.1.3:24 192.168.0.20:24 200.1.1.10:24 200.1.1.10:24
    3.PAT配置
    问题
    在R1通过PAT配置实现企业内网192.168.0.0/24复用f0/1端口
    方案
    网络拓扑如图-3所示:
    在这里插入图片描述
    图-3
    步骤
    实现此案例需要按照如下步骤进行。
    步骤一:基于端口的PAT配置限制
    1)删除动态NAT配置
    tarena-R1(config)#no ip nat inside source list 1
    tarena-R1(config)#no ip nat pool natpool
    tarena-R1(config)#no access-list 1
    2)在R1上配置包括内网所有IP地址的ACL
    tarena-R1(config)#access-list 1 permit 192.168.0.0 0.0.0.255
    3)关联ACL和路由器连接互联网的端口
    该命令最后加上的overload表示复用。
    tarena-R1(config)#ip nat inside source list 1 interface f0/1 overload
    4)在R1上配置NAT内、外端口
    tarena-R1(config)#interface f0/0
    tarena-R1(config-if)#ip nat inside
    tarena-R1(config-if)#interface f0/1
    tarena-R1(config-if)#ip nat outside
    5)分别在两台PC机上测试到外网主机的通信
    PC1测试如下所示:
    PC>ipconfig
    FastEthernet0 Connection:(default port)
    Link-local IPv6 Address…: FE80::2E0:F7FF:FED6:54CC
    IP Address…: 192.168.0.10
    Subnet Mask…: 255.255.255.0
    Default Gateway…: 192.168.0.1
    PC>ping 200.1.1.10
    Pinging 200.1.1.10 with 32 bytes of data:
    Reply from 200.1.1.10: bytes=32 time=1ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=0ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=1ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=0ms TTL=126
    Ping statistics for 200.1.1.10:
    Packets: Sent = 4, Received = 2, Lost = 2 (50% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms
    PC>
    PC2测试如下所示:
    PC>ipconfig
    FastEthernet0 Connection:(default port)
    Link-local IPv6 Address…: FE80::2D0:BAFF:FE98:9E29
    IP Address…: 192.168.0.20
    Subnet Mask…: 255.255.255.0
    Default Gateway…: 192.168.0.1
    PC>ping 200.1.1.10
    Pinging 200.1.1.10 with 32 bytes of data:
    Reply from 200.1.1.10: bytes=32 time=0ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=1ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=0ms TTL=126
    Reply from 200.1.1.10: bytes=32 time=1ms TTL=126
    Ping statistics for 200.1.1.10:
    Packets: Sent = 4, Received = 2, Lost = 2 (50% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms
    PC>
    6)在R1上查看NAT转换表
    tarena-R1#show ip nat translations
    Pro Inside global Inside local Outside local Outside global
    icmp 201.1.1.1:25 192.168.0.10:25 200.1.1.10:25 200.1.1.10:25
    icmp 201.1.1.1:26 192.168.0.10:26 200.1.1.10:26 200.1.1.10:26
    icmp 201.1.1.1:27 192.168.0.10:27 200.1.1.10:27 200.1.1.10:27
    icmp 201.1.1.1:28 192.168.0.10:28 200.1.1.10:28 200.1.1.10:28
    icmp 201.1.1.1:1024 192.168.0.20:25 200.1.1.10:25 200.1.1.10:1024
    icmp 201.1.1.1:1025 192.168.0.20:26 200.1.1.10:26 200.1.1.10:1025
    icmp 201.1.1.1:1026 192.168.0.20:27 200.1.1.10:27 200.1.1.10:1026
    icmp 201.1.1.1:1027 192.168.0.20:28 200.1.1.10:28 200.1.1.10:1027
    输出结果显示,所有的内网IP地址在访问外网前均被转换成了路由器端口的IP地址。

    展开全文
  • 思科静态路由

    千次阅读 2018-05-02 19:40:58
    #拓扑结构1、CISCO静态路由配置命令Router(config)#ip route destination destination_mask〔IP_address}FastEthernetnumber{Loopback number}Serialnumber]metric]其中destination代表目的网络的网络IP地址...

    #拓扑结构

    1、CISCO静态路由配置命令

    Router(config)#ip route destination destination_mask〔IP_address}FastEthernetnumber{Loopback number}Serialnumber]metric]

    其中destination代表目的网络的网络IP地址或者主机的IP地址,destination mask是目的网络的子网掩码或者目的主机的子网掩码。

    2、华为静态路由配置命令

    在路由器上增加静态路由命令为IP ROUTE.下面,我们将介绍如何用IP ROUTE命令来添加路由,以及IP ROUTE的各项参数。

    IP ROUTE是在系统视图下使用的命令,其完整语法格式如下:

    [Quidway] ip route-static ip-address{mask{masklen}{interface-type interfacce-name}nexthop-address}[preference value][reject | blackhole]

    命令中各参数解释如下:

    目的地址( ip-ddress ):用来标识数据包的目标地址或目标网络,当目的地址和掩码均为0.0.0.0时,配置的缺省路由,即当查找路由表失败后,根据缺省路由进行数据包的转发。

    网络掩码(<mask> | <masklen> ):和目标地址一起来标识目标网络。把目标地址和网络掩码逻辑与,即可得到目标网络。例如:目标地址为129.102.9.10,掩码为255.255.0.0,目标网络为129.102.0.0;由于要求掩码32位中"1”必须是连续的。因此点分十进制格式的掩码可以用掩码长度mask-length来代替,掩码长度为掩码中连续“1”的位数,就是mask-length。

    下一跳地址(nexthop-address):说明数据包所经由的下一跳地址。在一般情况下都会用nexthop-address配置路由,interface-name会自动生成。但如果在某些情况下无法知道下一跳地址,如拨号线路在拨通前是可能不知道对方甚至自己的IP地址的,在此种情况下必须要用Interface配置路由。

    preference关键字用于指定本条静态路由加入路由表的优先级(preference-value)。范围为0-255。在Quidway路由器中,静态路由的缺省优先级是60, RIP的优先级是100, OSPF的优先级是10,接口上直接相连网络的路由优先级最高,总是0。用户可以配置多条到同一目的地但优先级不同的路由。路由器将按照优先级的顺序从中选取唯一的一条加入到路由表中去供转发数据决策用。如配置到达相同目的地的多条路由,如果指定相同优先级,则可实现负载分担;如果指定不同优先级,则可实现路由备份。

    目的地不可达的路由(reject):当到某一目的地的静态路由具有reject属性时,任何去往该目的地的IP报文都将被丢弃,并且通知源主机目的地不可达。

    目的地为黑洞的路由(blackhole ):当到某一目的地的静态路由具有blackhole属性时,任何去往该目的地的IP报文都将被丢弃,也不向数据源发送任何错误消息,象一个黑洞一样。reject和blackhole属性一般用来控制本路由器可达目的地的范围。

    3、缺省路由

    简单地说,缺省路由就是在没有找到匹配的路由表入口项时才使用的路由。即只有当没有合适的路由时,缺省路由才被使用。在路由表中,缺省路由以到网络0.0.0.0/0的路由形式出现。用0.0.0.0作为目标网络号,用0.0.0.0作为子网掩码,所有的网络都会和这条路由记录符合。每个IP地址与0.0.0.0进行二进制“与”操作后的结果都得。,与目标网络号0.0.0.0相等。也就是说用0.0.0.0/0作为目标网络的路由记录符合所有的网络,我们称这种路由记录为缺省路由或默认路由。



    Router>en

    Router#conf t

    Router(config)#int g0/0

    Router(config-if)#shutdown

    Router(config-if)#ip add 10.1.2.10 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#int g0/1

    Router(config-if)#shutdown

    Router(config-if)#ip add 10.1.1.11 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#exit

    Router(config)#ip route 0.0.0.0 0.0.0.0 10.1.2.11

     

     

     

     

     

    Router>en

    Router#conf t

    Router(config)#int g0/0

    Router(config-if)#shutdown

    Router(config-if)#ip add 10.1.2.11 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#int g0/1

    Router(config-if)#shutdown

    Router(config-if)#ip add 10.1.3.10 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#exit

    Router(config)#ip route 10.1.1.0 255.255.255.0 10.1.2.10

    Router(config)#ip route 10.1.4.0 255.255.255.0 10.1.3.11

     

     

    Router>en

    Router#conf t

    Router(config)#int g0/0

    Router(config-if)#shutdown

    Router(config-if)#ip add 10.1.3.11 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#int g0/1

    Router(config-if)#shutdown

    Router(config-if)#ip add 10.1.4.11 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#exit

    Router(config)#ip route 0.0.0.0 0.0.0.0 10.1.3.10



    展开全文
  • 1、在接口下配置bfd和相关参数:interface gx/xbfd interval 400 min_rx 400 multiplier 52、配置静态路由bfd:ip route static bfd gx/x 下一跳地址(静态路由的下一跳地址)3、配置关联接口的静态路由,关联的接口是...
  • 思科高级配置(配置静态NAT)

    千次阅读 2019-05-16 19:59:45
    在其他ISP那里,即使是拥有几百台计算机的大型局域网用户,当他们申请IP地址时,所分配的地址也不过只有几个或十几个IP地址。显然,这样少的IP地址根本无法满足网络用户的需求。 1)在R1上将192.168.0.10转...
  • 思科静态路由协议

    2019-09-01 16:30:17
    思科静态路由协议 ** 1.规划网段(路由是隔离网段的) 配置每个节点IP地址。 R0 Router(config)#interface f0/0 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.10.1 255.255.255.0 ...
  • 配置静态路由与BFD联动(单跳检测)1....配置步骤(1)配置各接口的IP地址(略)(2)配置BFD和静态路由#在Router A上配置静态路由,并使能BFD检测功能,通过BFD echo报文方式实现BFD功能。 system-view[RouterA] bf...
  • 配置思路 :首先给终端配置pc5配置一个测试的地址,其次再给switch3 ,switch 1,router1 配置 ip 地址,最后使pc5,pc6都可以4. 配置步骤: # 给pc5配置 ip地址 ip address 192.168.10.1 255.255.255.0 gateway 192....
  • 静态路由配置实例 以下在Router1上设置了访问192.1.0.64/26这个网下一跳地址为192.200.10.6,即当有目的地址属于192.1.0.64/26的网络范围的数据报,应将其路由到地址为192.200.10.6的相邻路由器。在Router3上设置...
  • 链路1:其中SW1的GE0/0/2接口与SW2的GE0/0/1通过一条高带宽链路互联,采用VLAN11对接(IP地址段为192.168.11.0/24);链路2:SW1的GE0/0/3接口通过另一条线路互联,该条线路中存在一台非可网管交换...
  • route1的配置:router>enroute#conf trouter(config)#interface s0 //进入S0接口router(config-if)#ip address 11.11.1.1 255.255.255.0 //设置S0接口的IP地址router(config-if)#clock ra...
  • 思科静态路由生产环境实例

    千次阅读 2015-07-14 17:11:42
    今天公司添加了一台新的打印机但是由于没有多余的网口来给打印机分配IP地址所以自己就找了一个小路由器单独配置了一个基于串联双路由的模式配置实现了不同网段访问共享打印机。接下来引用了黑客联盟的相关原理来说明...
  • 这里的思科路由器是C7609。按照官网文档,C7609配置BFD的...2、配置静态路由bfd:ip route static bfd gx/x 下一跳地址静态路由的下一跳地址) 3、配置关联接口的静态路由,关联的接口是与对端互联配置bfd参数的...
  • 实验拓扑 实验步骤 我们要使得 1.1.1.0/24、2.2.2.0/24、... (1) 步骤 1:在各路由器上配置 IP 地址、保证直连链路的连通性 R1(config)#int loopback0 R1(config-if)#ip address 1.1.1.1 255.255.255.0 R1(config)...
  • 无论是 NAT,还是 CIDR 等都是缓解 IP 地址短缺的手段,而 IPv6 才是解决地址短缺的最终方法。IPv6 是由 IETF 设计的下一代互联网协议,目的是取代现有的互联网协议 IPv4。 IPv4 的设计思想成功地造就了目前的...
  • 黑洞表项是特殊的静态MAC地址表项,丢弃含有特定源MAC地址或目的的MAC地址的数据帧;防止无用的MAC地址表项占用MAC地址表;将非信任的MAC配置为黑洞MAC地址,当设备收到目的或源MAC地址为黑洞里的MAC时直接丢弃,...
  • 静态路由故障1、静态路由和有类别查找当路由选择表进程检查一条使用中间地址(路由选择表中作为下一跳引用的 IP 地址)的可解析的静态路由时,这个检查总是在有类别方式下完成的,无论是否使用 ip classless命令如果在...
  • ipv6静态路由配置文件

    2013-12-12 10:11:53
    ipv6静态路由的配置,其中设备包括两台思科路由器,设备中设置本地回环地址
  • 思科高级配置(DHCP服务配置

    千次阅读 2019-05-22 18:41:39
    大型企业网络客户机数量较多,客记机IP地址配置如果都为静态配置存在如下问题: 1)增加网络管理员工作量 2)静态手动配置容易输入错误 3)静态手动配置容易冲突 在路由器上配置DHCP服务为客户端自动分配IP地址如图 ...
  • 思科高级配置(配置动态NAT)

    千次阅读 2019-05-15 20:52:43
    问题 在R1通过动态NAT实现企业内网192.168.0.0/24转换为公网地址201.1.1.2-201.1.1.5,访问200.1.1.10 ...1)删除静态NAT配置 tarena-R1(config)#no ip nat inside source static 192.168.0.10 201...
  • 实验11 静态路由配置

    2020-09-29 20:44:49
    1 实验目的 1.1 了解静态路由的优缺点 ...3.2 配置PC机的IP地址(2个),子网掩码,默认网关。(可自己设计) Pc0: 192.168.1.100 255.255.255.0 192.168.1.1 Pc1:192.168.3.100 255.255.255.0 192.168.3
  • 策 略路由配置命令 策略...策略路由(policyroute)实际上是复杂的静态路由,静态路由是基于数据包的目标地址并转发 到指定的下一跳路由器,策略路由还利用和扩展IPACL链接,这样就可以提供更多功能的过滤和分类 route m...
  • 使用思科模拟器配置动态路由

    千次阅读 2019-12-09 18:53:10
    1.在思科模拟器上配置静态路由的网络拓扑图: 2.配置各路由器的名字,在全局模式下输入命令:hostname + 名字。以Router0为例(以下若无说明都是以Router0为例): 3.配置路由器FastEthernet接口的ip地址,在...
  • 思科模拟器 --- 网络地址转换NAT配置

    千次阅读 2019-11-11 10:36:55
    学习目标:理解NAT网络地址转换的原理及功能、掌握静态NAT配置,实现局域网访问互联网 1.定义 ①网络地址转换NAT(Network Address Translation),被广泛应用于各种类型Internet接入方式和各种类型的网络中。原因...
  • 文章目录思科期末实验考试IP地址划分静态路由RIP配置(路由器)OSPF配置HTTP服务器配置DNS配置FTP(交换机备份)TFTP(路由器备份)vtp配置路由登陆密码telnet配置(交换机 / 路由器) IP地址划分 指定网管 划分...

空空如也

空空如也

1 2 3 4 5 ... 8
收藏数 147
精华内容 58
关键字:

思科静态地址配置