精华内容
下载资源
问答
  • default-metric cost ...default-metric cost命令影响所有路由协议重分布过来的metric,包括静态路由。 3>直连路由不受default-metric cost命令影响。 3>所有路由(静态、动态、直连)都受...
    default-metric cost
     
     
    结论:
    1>除BGP重分布后metric为1,其它路由协议都默认为20。
    2>default-metric cost 命令影响所有路由协议重分布过来的metric,包括静态路由。
    3>直连路由不受default-metric cost命令影响。
    3>所有路由(静态、动态、直连)都受redistribute metric影响。
     
     
     
    r1#sh run
    Building configuration...
    Current configuration : 1024 bytes
    !
    interface Serial1/0
    descr iption conn_to_r2_s1/0_192.168.1.2
    ip address 192.168.1.1 255.255.255.0
    serial restart-delay 0
    !
    router ospf 100
    router-id 10.0.0.1
    log-adjacency-changes
    network 192.168.1.0 0.0.0.255 area 0
    ---------------------------------------------
    r2#sh run
    Building configuration...
    Current configuration : 1393 bytes
    !
    interface Loopback0
    ip address 1.1.1.1 255.255.255.0
    ip ospf network point-to-point
    !
    interface FastEthernet0/0
    ip address 2.2.2.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface Serial1/0
    description conn_to_r1_s1/0_192.168.1.1
    ip address 192.168.1.2 255.255.255.0
    serial restart-delay 0
    !
    interface Serial1/1
    description conn_to_r3_s1/0_192.168.2.2
    ip address 192.168.2.1 255.255.255.0
    serial restart-delay 0
    !
    router ospf 100
    router-id 10.0.0.2
    log-adjacency-changes
    redistribute connected metric 33 subnets
    redistribute static subnets
    redistribute rip subnets
    network 192.168.1.0 0.0.0.255 area 0
    default-metric 7
    !
    router rip
    version 2
    network 192.168.2.0
    no auto-summary
    !
    ip route 3.3.3.0 255.255.255.0 Serial1/1
    -----------------------------------------------
    r3#sh run
    Building configuration...
    Current configuration : 1299 bytes
    !
    interface Loopback0
    ip address 5.5.5.5 255.255.255.0
    !
    interface Loopback1
    ip address 6.6.6.6 255.255.255.0
    !
    interface Loopback81
    ip address 3.3.3.3 255.255.255.0
    !
    interface Serial1/0
    description conn_to_r2_s1/1_192.168.2.1
    ip address 192.168.2.2 255.255.255.0
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    router rip
    version 2
    network 5.0.0.0
    network 6.0.0.0
    network 192.168.2.0
    no auto-summary
    ----------------------------------------------------
    r1#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    Gateway of last resort is not set
         1.0.0.0/24 is subnetted, 1 subnets
    O E2    1.1.1.0 [110/33] via 192.168.1.2, 00:15:37, Serial1/0
         2.0.0.0/24 is subnetted, 1 subnets
    O E2    2.2.2.0 [110/33] via 192.168.1.2, 00:15:37, Serial1/0
         3.0.0.0/24 is subnetted, 1 subnets
    //直连路由
    O E2    3.3.3.0 [110/7] via 192.168.1.2, 00:12:03, Serial1/0
         5.0.0.0/24 is subnetted, 1 subnets
    //静态路由
    O E2    5.5.5.0 [110/7] via 192.168.1.2, 00:12:03, Serial1/0
         6.0.0.0/24 is subnetted, 1 subnets
    O E2    6.6.6.0 [110/7] via 192.168.1.2, 00:12:03, Serial1/0
    C    192.168.1.0/24 is directly connected, Serial1/0
    //动态路由
    O E2 192.168.2.0/24 [110/33] via 192.168.1.2, 00:15:37, Serial1/0
    //直连路由

    转载于:https://blog.51cto.com/1841cisco/1020324

    展开全文
  • default-cost这个命令只能用在stub区域,并且只能是stub匹配的ABR上才能启用这条命令。 当我们启动一个stub区域时,会自己发布一条默认的路由,路径开销是去往ABR的累加值。这条命令的作用就是在这个累加值...

     无意间碰到这个命令,书里都没碰到过。

    default-cost这个命令只能用在stub区域,并且只能是stub匹配的ABR上才能启用这条命令。

    当我们启动一个stub区域时,会自己发布一条默认的路由,路径开销是去往ABR的累加值。这条命令的作用就是在这个累加值上面再累加这条命令指定的值。

    实验:

     

    先看一下没有用default-cost这条命令时的效果:

    
      
    1. R2 
    2.  
    3. router ospf 100 
    4.  log-adjacency-changes 
    5.  area 1 stub 
    6.  network 12.1.1.2 0.0.0.0 area 0 
    7.  network 23.1.1.2 0.0.0.0 area 1 

     

    
      
    1. R3 
    2.  
    3. router ospf 10 
    4.  router-id 3.3.3.3 
    5.  log-adjacency-changes 
    6.  area 1 stub 
    7.  network 0.0.0.0 255.255.255.255 area 1 

     

     

    显示开销是65。

    接下来:

     

    
      
    1. r2(config)#router ospf  100 
    2. r2(config-router)#area 1 default-cost 30 
    3. r2(config-router)# 

     

    变成94了,在65的基础上做了累加。

    使用这条命令需要注意的是两点:

    1、必须是stub区域

    2、必须是stub区域连接外部区域的ABR

     

     

     

    转载于:https://blog.51cto.com/yeelone/484463

    展开全文
  • 14.4OSPF--cost--配置命令

    千次阅读 2020-06-28 22:12:48
    文章目录14.4OSPF--cost--配置命令OSPF度量值:cost,开销OSPF配置命令 OSPF度量值:cost,开销 在每一个运行OSPF的接口上,都维护着一个接口Cost Cost= 10^8/BW (bps) = 100Mbps/BW=接口带宽参考值/接口带宽 到一...

    14.4OSPF–cost–配置命令

    标签(空格分隔): HCIA

    OSPF度量值:cost,开销

    • 在每一个运行OSPF的接口上,都维护着一个接口Cost
    • Cost= 10^8/BW (bps) = 100Mbps/BW=接口带宽参考值/接口带宽
    • 到一个目标网络的度量值=
      • 从源到目标所有出站接口的Cost值累加(数据方向)
      • 从源到本路由器沿途所有 入站接口的Cost值累加(路由方向)

    49OSPF度量值:cost,开销
    在这里插入图片描述
    华为回环口cost为0,cisco回环口cost为1

    int lo 1
    ospf cost 9 # 修改cost值
    dis ip routing-table #查看值
    

    50简单cost计算
    在这里插入图片描述

    OSPF配置命令

    命令说明
    ospf 1 router-id 1.1.1.1开启ospf,进程号缺省为1,手动配置router ID
    area 0.0.0.0配置区域
    network 192.168.0.0 0.0.0.255宣告网络,即指定运行OSPF的接口
    使用反掩码来匹配(255.255.255.255-掩码)
    display ospf peer [brief]显示OSPF邻居信息
    ospf timer hello 10修改Hello包发送间隔
    ospf timer dead 40修改Hello包超时时间
    display ospf interface g0/0/0显示OSFP接口信息
    ospf dr-priority 100修改OSPF接口优先级
    ospf cost 10修改开销,范围1~65535,缺省为1
    bandwidth-reference 100调整带宽参考值,默认为100Mbps,需要在整个OSPF网络中统一进行调整。修改成10000,cost为10
    reset ospf process重启OSPF进程

    Router-id 不指定,会自动有。改的话会发生网络震荡。

    172.16.0.5/30
    net 172.16.0.4 0.0.0.3
    nei 172.16.0.5 0.0.0.0

    30-24=6 8-6=2主机位

    块=4=2^主机位=256-掩码252

    255.255.255.252

    51net反掩码自动修改
    在这里插入图片描述

    展开全文
  • OSPF协议配置命令解析

    万次阅读 多人点赞 2018-12-05 22:06:30
    一,ospf命令 命令功能 ospf命令用来创建并运行OSPF进程。 undo ospf命令用来关闭OSPF进程。 缺省情况下,系统不运行OSPF协议,即不运行OSPF进程。 2.命令格式 ospf I process-id I router-id router-id] undo ...

    一,ospf命令
    命令功能
    ospf命令用来创建并运行OSPF进程。
    undo ospf命令用来关闭OSPF进程。
    缺省情况下,系统不运行OSPF协议,即不运行OSPF进程。
    2.命令格式
    ospf I process-id I router-id router-id]
    undo ospf (process-id)
    3.参数说明
    ospf命令参数说明如表2.2所示
    process-id OSPF进程号 整数形式,取值范围是1~6555缺省值是1
    router-id router-id Router ID 点分十进制格式
    4.使用实例
    运行OSPF协议
    在这里插入图片描述
    二,area命令
    1.命令功能
    area命令用来创建OSPF区域,并进入OSPF区域视图。
    undo area命令用来删除指定区域。
    缺省情况下,系统未创建OSPF区域。
    2.命令格式
    area (area-id)
    undo area (area-id)
    3.参数说明
    area-id 指定区域的标识。其中区域号 area-id是可以是0的称为骨干区域 可以是十进制整数或点分十进制格式。采取整数形式时,取值范围是0~4294967295
    4.使用实例
    进入OSPF区域视图
    在这里插入图片描述

    三,network命令
    network命令用来指定运行OSPF协议的接口和接口所属的区域
    1.命令功能
    undo network命令用来删除运行OSPF协议的接口。
    缺省情况下,此接口不属于任何区城。
    2.命令格式
    network (network-address wildcard-mask)
    undo network (network-address wildcard-mask)
    3.参数说明
    network-address 接口所在的网段地址 点分十进制格式
    wildcard-mask P地址的反码,相当于将P地址的掩码反转(0变1,1变0)。 点分十进制格式
    例如0.0.0.255表示掩码长度24位
    4.使用实例
    指定运行OSPF协议的接口的主IP地址位于网段192.168.1.0/24,接口所在的Area1D为2。
    在这里插入图片描述
    四,ospf dr-priority命令
    1.命令功能
    ospf dr-priority命令用来设置接口在选举DR时的优先级。
    undo ospf dr-priority命令用来恢复其缺省值。
    缺省情况下,优先级为1。
    2.命令格式
    ospf dr-priority (priority)
    undo ospf dr-priority
    3.参数说明
    ospf dr-priority命令参数说明
    prority 接口在选举DR或BDR时的优先级。其值越大,优先级越高。 整数形式,取值范围是0~255
    4.使用实例
    设置接口G0/0/0在选举DR时的优先级为8
    在这里插入图片描述
    五,ink-peer命令
    1.命令功能
    vink-peer命令用来创建并配置虚连接。
    undo vlink-peer命令用来删除虚连接或恢复虚连接的参数为缺省值。
    缺省情况下,OSPF不配置虚连接
    2.命令格式
    vlink-peer (router-id)
    undo vlink-peer (router-id)
    3.参数说明
    vink-peer命令参数
    vink-peer命令参数说明
    router-id 指定建立虚连接的对端路由器ID
    4.使用实例
    创建虚连接,对端设备|D为10.1.1.1。
    在这里插入图片描述
    六,stub命令
    1.命令功能
    stub命令用来将一个区域设置为Stub区域。
    undo stub命令用来取消这种设置
    缺省情况下,没有区域被设置为Stub区域
    2.命令格式
    stub【 no-summary I default-route-advertise】
    undo stub
    3.参数说明
    stub命令参数说明
    no-summary 禁止ABR向Stub区域内发送 Summary LSA
    default-route-advertise 在ABR上配置产生缺省的Type-3 LSA到Stub区域
    4.使用实例
    将OSPF区域1设置为Stub区域。
    在这里插入图片描述
    七,nssa命令
    1,命令功能
    nssa命令用来配置OSPF区域为NSSA区域
    undo nssa命令用来取消NSSA区域,恢复OSPF区域为普通区域
    缺省情况下,OSPF没有区域被设置成NSSA区域。
    2.命令格式
    nssa {default-route-advertise| no-summary}
    undo nssa
    3.参数说明
    nssa命令参数说明
    default-route-advertise 在ASBR上配置产生缺省的Type7LSA到NSA区域
    no-summary 禁止ABR向NSSA区域内发送 Summary LSAS
    4.使用实例
    将OSPF区域1设置为Stub区域。将区域1配置成NSSA区域
    在这里插入图片描述

    八,import- route命令
    1.命令功能
    import-route命令用来引入其他路由协议学习到的路由信息
    undo import-route命令用来删除引入的外部路由信息。
    缺省情况下,不引入其他协议的路由信息
    2.命令格式
    import-route {direct | rip 【process-id-rip 】I static I ospf 【process-id-ospf】}【cost cost】
    undo import-route {direct | rip 【process-id-rip 】 I static I ospf【 process-id-ospf 1】}
    3.参数说明
    mport-route命令参数说明
    direct 引入的源路由协议为Dect协议
    rip 引入的源路由协议是R|P
    process-id-rip 引入RP路由协议的进程号 整数形式,取值范围是1~65535缺省值是1
    static 引入的源路由协议是 Static
    OSPF 引入的源路由协议是OSPF
    process-id-ospf 引入OSPF路由协议的进程号 整数形式,取值范围是1~65535,缺省值是1
    cost cost 指定路由开销值 整数形式,取值范围是0~16777214。缺省值是1
    4.使用实例
    指定引入Type2的RP进程40的路由,路由标记为33,开销值为50
    在这里插入图片描述

    九,abr- summary命令
    1.命令功能
    abr- summary命令用来在区域边界路由器(ABR)上配置路由聚合。
    undo abr-summary命令用来取消在区域边界路由器上进行路由聚合的功能。
    缺省情况下,区域边界路由器不对路由聚合。
    2.命令格式
    abr-summary ip-address mask
    undo abr-summary ip-address mask
    3.参数说明
    abr-summary命令参数说明
    ip-address 指定聚合路由的P地址 点分十进制形式
    mask 指定聚合路由的P地址的掩码 点分十进制形式
    4.使用实例
    将OSPF100的区域1中两个网段10.42.10.0和10.42.110.0的路由聚合成一条聚合路由10.42.0.0向其
    他区域发布。
    在这里插入图片描述
    十, authentication-mode命令
    1.命令功能
    authentication-mode命令用来指定OSPF区域所使用的验证模式及验证口令。
    undo authentication-mode命令用来取消该区域已配置的验证模式
    缺省情况下,没有配置区域验证模式
    2命令格式
    authentication-mode {md5 I hmac-md5 I hmac-sha256 }[ key-id( plain plain-text I 【 cipher 】
    cipher-text )}
    undo authentication-mode
    3.参数说明
    authentication-mode命令参数
    simple 使用简单验证模式。缺省情况下, simple验证模式默认是 Cipher类型。
    plain 明文口令类型。此模式下只能键入明文口令,在查看配置文件时以明文方式显示口令。
    plain-text指定明文验证字 字符串形式,可以为字母或数字,区分大小写,不支持空格。当认证模式为 simple时,长度为1~8;
    认证模式为MD5、 HMAC-MD5、 HMAC-SHA256时,长度为1~255。
    cipher 密文口令类型。可以键入明文或密文口令,但在查看配置文件时均以密文方式显示口令 对于MDS/ HMAC-MD5/ HMAC-SHA256验证模式当此参数缺省时,默认为 Cipher类型。
    cipner-rext 指定密文验证字 字符串形式, 可以为字母或数字,区分大小写,不支持空格。当认证模式为 simple时,长度为1-8的明文或48、24或者32的密文;认证模式为MD5,HMAC-MD5、 HMAC-SHA256时,长度为1-255的明文或20-392的密文
    md5 使用MD5密文验证模式
    hmac-md5 使用 HMAC MD5密文验证模式
    hmac-sha256 使用 HMAC-SHA256验证模式
    ey-id 接口密文验证的验证字标识符,必须与对端的验证字标识符一致 整数形式,取值范围是1-255

    4.使用实例
    指定OSPF区域0使用 HMAC-MD5密文验证模式,密码为 galaxy
    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • OSPF配置命令总结

    千次阅读 2020-10-26 15:29:58
    整理了一下OSPF的一些命令,以便今后查阅,基本概括了常用的所有命令(有些到了IE阶段,我都没见到过。。。有需要可以收藏备用!) 还有没有整理的可以在评论区指出一下~ abr-summary(OSPF区域) //用来在区域...
  • OSPF 路由 cost介绍

    2010-07-23 17:25:15
    OSPF 路由 cost介绍 OSPF路由在OSPF协议中,去往一个目的地,途径的每一条链路的Cost计算是在发送时加上该端口Cost,接收时不加。比如要对R1去往12.1.1.2的路由的Metric进行修改,那么一个可行的方法就是...
  • OSPF常用命令

    千次阅读 多人点赞 2018-12-01 15:05:48
    显示OSPF中各区域邻居的信息 display ospf peer brief 显示OSPF的链路状态数据库(LSDB)信息 display ospf lsdb 显示OSPF的接口信息 display ospf interface [PE4]dis ospf interface GigabitEthernet 0...
  • LAB12:OSPF cost修改 使用场合: 通过修改OSPF COST可以影响OSPF的...2.接口下ip ospf cost 命令 3.参考带宽 auto-cost reference-bandwidth ref-bw 需求: 让R1到达3.3.3.0网络优选R2到达。 配置: ...
  • 需求: 让R1到达3.3.3.0网络优选R2到达 配置: R1 interface Loopback0 ip address 1.1.1.1 255.255.255.0 ! interface FastEthernet0/0 ip address 13.1.1.1 255.255.255.0 ...ip ospf network broa...
  • OSPF

    2021-04-16 13:42:55
    Ospf cost ospf常见lsa类型 Stub 末梢区域 totally stub 完全末梢区域 nssa 非完全末梢区域 Totally nassa 完全非完全末梢区域 命令 Ospf Import-route rip 1 Rip Import-route ospf 1 在rip上注入ospf Ospf 1...
  • OSPFcost计算

    千次阅读 2010-11-10 14:37:18
    众所周知,ospfcost=refefencebandwith/bandwith,默认的ospf的参考带宽是100000k,即,100M的链路的cost是1,大于100M的cost也都是1.ospfcost到底是怎么计算的?比如,一条链路有2个端口,是按哪个端口的值来计算的...
  • OSPF引入外部路由时,缺省情况下引入的外部路由不继承原有路由的cost值,而是设置缺省cost值为1。 如果不希望引入的外部路由采用缺省的cost值,可以使用命令default { cost { cost | inherit-metric }改变引入的...
  • 修改OSPF接口的COST

    万次阅读 2018-12-23 21:57:16
  • dis ospf brief 命令解读

    千次阅读 2020-08-03 11:26:57
    [R3]dis ospf brief OSPF Process 1 with Router ID 3.3.3.3 OSPF Protocol Information RouterID: 3.3.3.3 Border Router: Multi-VPN-Instance is not enabled Global DS-TE Mode: Non-Standard IETF Mode ...
  • OSPF相关命令

    2016-06-24 17:51:20
    1.配置末梢区域缺省路由的代价 边界路由器ABR上 area 1 stub area 1 default-cost 20 转载于:https://blog.51cto.com/xueyue8/1792681
  • ip ospf cost 花费理解

    千次阅读 2010-07-23 13:43:22
    OSPF协议中是通过COST值来选择最优路径加入到路由表中去的,那这种比较是如何进行已确定最优路径的呢? IP ospf cost又是如何取值计算的呢 ,下面的文章里我们通过实例来理解。 拓扑图如下所示: 在上图...
  • cisco ospf命令总结

    千次阅读 2014-11-04 14:32:27
    OSPF配置命令Router(config)#router ospf 10 进程号只在本地有效Router(config)#network 192.168.10.0 0.0.0.255 area 0 正反掩码均可Show ip protocolsShow ip route 查看路由表Show ip route ospf 查看路由表中的...
  • OSPF基本原理和命令

    2020-02-25 18:12:57
    OSPF (Open Shortest Path First) , 开放式的最短路径优先协议 -概述 OSPF 协议是公有的标准协议,属于内部网关协议中的 链路状态 路由协议; OSPF 的报文是直接封装在 IP 头部后面的,属于 OSI 模型 第三层; OSPF...
  • ospf配置命令

    2011-12-16 11:33:29
    ospf(open shortest path first)协议即“开放最短路径优先协议”。它是一种基于链路状态的自治系统内部的动态路由协议,它通过路由器间交换链路状态信息来组成一个链路状态数据库,然后基于这个数据库用最短路径...
  • cisco ospf 命令总结

    2013-01-29 10:11:11
    OSPF配置命令 Router(config)#router ospf 10 进程号只在本地有效 Router(config)#network 192.168.10.0 0.0.0.255 area 0 正反掩码均可 Show ip protocols Show ip route 查看路由表 Show ip route ospf ...
  • ospf命令

    2009-07-07 00:44:29
    1.routerospfprocess-id启用ospf进程: 用来启用一个ospf的进程,process-id的范围为1-65535,process-id只在本地有意义,如果你在一台路由器上同时开启了两个process的话,两个process的数据库是不一样,每次路由...
  • OSPF协议中cost值的计算

    千次阅读 2011-12-09 14:03:14
    ospf协议中每个接口根据其速率不同,都有一个默认的公式计算的cost值,ospf协议采用cost值来决定到达目的地的最佳路径,如果存在多条到达目的地的路径,优先选用cost值最低的路径。Cost值的计算是沿目的地途中所有...
  • CISCO OSPF命令总结

    千次阅读 2010-11-13 10:19:00
    花了一天时间把ospf的基本命令 都总结了.绝对心血啊. 好的话就支持顶一个哦 <br />OSPF 配置命令 Router(config)#router ospf 10 进程号只在本地有效 Router(config)#network ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,561
精华内容 1,424
关键字:

cost命令ospf